Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

Isilon: OneFS 8.1: Your OneFS license is unsigned

Summary: License errors show up when running OneFS 8.1. Your OneFS license is unsigned. To enable ESRS, you must first have a signed OneFS license. Update license now.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms



On OneFS 8.1.x, configuring the license can trigger license errors, most common is: "License errors show up when running OneFS 8.1. Your OneFS license is unsigned.  To enable ESRS, you must first have a signed OneFS license.", as in the Webui, under Cluster Management, General Settings, the Remote Support tab.

Sometimes an associated ESRS error may show: "The OneFS Administration Interface does not support the version of ESRS that is currently running on your cluster." that shows under Cluster Management, General Settings, on the Remote Support tab in the webui.  Be aware, that to enable ESRS, a signed license is required.

Check the validity of the license by checking the following.
  1. In the Webui, under Cluster Management, Licensing
    • "OneFS cluster license overview" shows that the "License status" of the license shows "Signed."
    • "Software licenses overview" shows that the "License details" Status show "Licensed" for the modules that should be licensed.
  kA2f1000000G1bfCAC_3_0
  1. From the CLI
    • Running the command "isi license list," Should list 1) the Valid Signature as "Yes," and 2) lists "Licensed" for the modules that should be licensed. Example:
      cluster-1# isi license list
      OneFS License ID: ELMISL######
       Valid Signature: Yes

      Module                Licensed node count  Actual node count  Status     Expiration date
      -----------------------------------------------------------------------------------------
      SMARTQUOTAS           3 Nodes              3 Nodes            Licensed   -               
      SNAPSHOTIQ            3 Nodes              3 Nodes            Licensed   -               
      SMARTCONNECT_ADVANCED 3 Nodes              3 Nodes            Licensed   -               
      SYNCIQ                3 Nodes              3 Nodes            Licensed   -               
      SMARTPOOLS            3 Nodes              3 Nodes            Licensed   -               
      SMARTLOCK             3 Nodes              3 Nodes            Unlicensed -               
      HDFS                  3 Nodes              3 Nodes            Unlicensed -               
      SMARTDEDUPE           3 Nodes              3 Nodes            Unlicensed -               
      CLOUDPOOLS            3 Nodes              3 Nodes            Unlicensed -               
      SWIFT                 3 Nodes              3 Nodes            Unlicensed -               
      HARDENING             0 Nodes              0 Nodes            Unlicensed -               
      ONEFS                 3 Nodes              3 Nodes            Licensed   -               
      -----------------------------------------------------------------------------------------
      Total: 12
    • Run the command on any node: curl --insecure -u root 'https://localhost:8080/platform/5/license/licenses' |egrep 'valid|status|activation|expir|name|swid' and check to ensure activation and expire output is set as 'false', while checking the modules are 'Licensed' and valid_signature is 'true'. 
Example: how it should look for licensed modules and valid license.
"activation_incomplete_alert" : false,
"expired_alert" : false,
"expiring_alert" : false,
"name" : "SMARTQUOTAS", 
"status" : "Licensed",
....
"expired_alert" : false,
"expiring_alert" : false,
"name" : "ONEFS",
"status" : "Licensed",
"swid" : "ELMISL#######",
"valid_signature" : true"

Cause

  • An unsigned/invalid license
  • Incorrect ESRS configuration, which leads to confusion with licensing system leading it to think license is not valid, when it is.
  • In 8.1.x, there are new features added specific to ESRS v3.  There are two different configurations possible.  Only one should be enabled.
  • Specific browsers, that causes stale client-side caching of data when configuring the cluster from the webpages.
  • Unresolved license events/alerts on the cluster, which triggers false alert on the webui.
  • A signed license applied to the cluster before a rolling upgrade from OneFS 8.0.x is complete, leaving some nodes unlicensed.

Resolution

1.  Reboot the Gateway

See https://support.emc.com/kb/510767 - Isilon: How To set up ESRS for OneFS v8.1+It also includes information about troubleshooting new installs.

2.  Invalid/unsigned license.  The license file is obtained by starting in the OneFS webui, Cluster Management, Licensing, scrolling down to the "OneFS license management" section, and clicking the "Open Activation File Wizard," selecting the Software modules needing licensing, clicking the Review Changes button at the bottom, then creating the file.  It will then give instructions on how to submit the file to the licensing group, to obtain the license file that is needed to import to the cluster. Questions or problems that are related to sending the into the licensing site, are to be directed to the account team, so they can engage with the licensing team to resolve any account, site, or license-specific issues.

3.  Validate ESRS configuration If v2 is being used instead of v3, v3 is intended as the only current supported version of ESRS for OneFS 8.1.x.  Disable the v2 gateway, and enable and configure the v3 configuration per the 8.1 documentation.  To enable and connect to the v3 gateway, the Support EMC site username and password will be required, these need to be the same credentials that were used when setting up the v3 gateway during it's provisioning phase.  See the ESRS documentation for information related to ESRS and setting it up to access the Support EMC site during provisioning.  If help is needed with ensuring Support EMC account and correct credentials were used, please speak with the account team responsible for the site over the cluster and ESRS gateway.

4.  Browser issues
1) Avoid using Internet Explorer, as there are known caching issues that may result in incorrect/incomplete info being submitted using the webui.  Try updating, importing the license with FireFox, Chrome, or Safari.
2) Try doing a hard refresh on the browser, then clicking back over to the Remote Support page.

5.  Licensing Events/Alerts on the cluster.  Be sure that any and all events and alerts are resolved on the cluster after submitting the license, so as to not continue triggering the issue.

A signed license applied to the cluster before a rolling upgrade from OneFS 8.0.x is complete, leaving some nodes unlicensed.  Create an activation file after all nodes have been upgraded from OneFS 8.0.x and then apply that signed license file to the cluster.

If all the above solutions have been checked, and the issue continues, please reach out to Isilon Support for further engagement.
  • Run "isi remotesupport connectemc view|grep -i enable" returns Yes
    • Then ESRS v2 is being used.
  • If "isi esrs view|grep -i enable" returns Yes
    • Then ESRS v3 is being used.

6.  More ESRS configuration info and new ESRS Installs

Article Properties


Product

Isilon, PowerScale OneFS

Last Published Date

22 Aug 2022

Version

4

Article Type

Solution