Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

Article Number: 000057111


AppSync: The AppSync GUI does not show the login screen and presents: "Error 404 not found"

Summary: The user sees the "Error 404 not found" screen when trying to log in to the Appsync GUI.

Article Content


Symptoms



The user sees the "Error 404 not found" screen when trying to log in to the Appsync GUI.

The following errors may be seeing in the server.log file:

04-04-2017 12:03:37.854 INFO [DeploymentScanner-threads - 1] [org.jboss.as.server.deployment.scanner] [] [] WFLYDS0019: Deployment apollo.ear was previously deployed by this scanner but has been removed from the server deployment list by another management tool. Marker file E:\EMC\AppSync\jboss\.\standalone\..\applications\apollo.ear.undeployed is being added to record this fact.

04-04-2017 12:03:17.575 INFO [Thread-2] [org.jboss.as.server] [] [] WFLYSRV0220: Server shutdown has been requested.
04-04-2017 12:05:16.007 INFO [MSC service thread 1-7] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Started server default-server.
04-04-2017 12:05:18.041 INFO [MSC service thread 1-3] [org.jboss.ws.common.management] [] [] JBWS022052: Starting JBoss Web Services - Stack CXF Server 5.0.0.Final
 
04-04-2017 12:12:26.097 INFO [Thread-2] [org.jboss.as.server] [] [] WFLYSRV0220:
04-04-2017 12:12:29.320 INFO [MSC service thread 1-6] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Started server default-server.
04-04-2017 12:12:29.711 INFO [MSC service thread 1-8] [org.jboss.ws.common.management] [] [] JBWS022052: Starting JBoss Web Services - Stack CXF Server 5.0.0.Final
 
04-04-2017 12:15:29.212 INFO [Thread-2] [org.jboss.as.server] [] [] WFLYSRV0220: Server shutdown has been requested.
04-04-2017 12:15:35.364 INFO [MSC service thread 1-1] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Started server default-server.
04-04-2017 12:15:35.745 INFO [MSC service thread 1-8] [org.jboss.ws.common.management] [] [] JBWS022052: Starting JBoss Web Services - Stack CXF Server 5.0.0.Final
 
04-04-2017 12:40:30.529 INFO [Thread-2] [org.jboss.as.server] [] [] WFLYSRV0220: Server shutdown has been requested.
04-04-2017 12:43:36.972 INFO [MSC service thread 1-2] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Started server default-server.
04-04-2017 12:43:37.354 INFO [MSC service thread 1-7] [org.jboss.ws.common.management] [] [] JBWS022052: Starting JBoss Web Services - Stack CXF Server 5.0.0.Final

 

Cause

This may be seen if the Appsync Server services are Started and Stopped in quick succession. There are a number of files, such as E:\EMC\AppSync\jboss\.\standalone\..\applications\apollo.ear which are deployed by the Appsync Server during startup. If the service is stopped before these files are fully deployed the Appsync Server may begin to throw this error.

When we check the location C:\EMC\AppSync\jboss\applications we should see the following 6 files in a healthy system: 

  • Apollo.ear
  • apollo.ear.deployed
  • archway-ear.ear
  • archway-ear.ear.deployed
  • remotex.rar
  • remotex.rar.deployed


When we check on a system showing the "Error 404 not found" error we should find some of these files marked as undeployed, eg "apollo.ear.undeployed ".

Resolution

Workaround:
In order to resolve this issue we have to get the Appsync Server service to deploy the .EAR files. Follow the procedure outlined below to accomplish this. 
When we find undeployed files in the C:\EMC\AppSync\jboss\applications folder perform below mentioned steps to resolve:

  1. Stop all the services.
  2. Take backup of the C:\EMC\AppSync\jboss\applications.
  3. Rename Apollo.ear.undeployed to Apollo.ear.dodeploy.
  4. Perform the same steps as step 3 in case any other EAR files are also shown as undeployed.
  5. Start the services.
  6. Check the status for .EAR files again at the location C:\EMC\AppSync\jboss\applications.
i. Apollo.ear
ii. apollo.ear.deployed
iii. archway-ear.ear
iv.archway-ear.ear.deployed
v.remotex.rar
vi.remotex.rar.deployed
  1. Try to log in into appsync GUI after 5 minutes and you should be able to log in.

Article Properties


Affected Product

AppSync

Product

AppSync

Last Published Date

20 Nov 2020

Version

2

Article Type

Solution