Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

Article Number: 000052012


Unisphere for VMAX: Version 8.2 and 8.3 are unable to configure / test email alerts. Error "Failed to set email configuration"

Article Content


Symptoms



Unable to configure email in Unisphere for VMAX 8.2 and 8.3

The "Test" button is grayed (greyed) out. Also, when clicking "OK", you get the error message "Failed to set email configuration":

kA2j0000000kB3QCAU_3_0
Error msg (smas log):
 
2016-06-06 12:27:41,193 ERROR [em.bp.MAIL] (default task-16) com.emc.em.common.mail.MailService.getTransport:Failed to set JavaMail SMTP configuration: javax.mail.AuthenticationFailedException: 334 VXNlcm5hbWU6
 
2016-06-06 12:27:41,194 ERROR [org.jboss.as.ejb3.invocation] (default task-16) WFLYEJB0034: EJB Invocation failed on component MailService for method public abstract void com.emc.em.common.mail.IMailService.setSMTPConfig(com.emc.em.common.mail.SMTPConfig) throws java.lang.Exception: javax.ejb.EJBException: com.emc.em.common.mail.MailServiceException: Failed to set JavaMail SMTP configuration.

May also see in smas log:
ERROR [em.xx.MAIL] (default task-25) com.emc.em.common.mail.MailService.getTransport:Failed to set JavaMail SMTP configuration: com.sun.mail.util.MailConnectException: Couldn't connect to host, port: xxx.xxx.xxx.xxx, 717; timeout -1;

Cause

This is a known issue related to Transport Layer Security (TLS) protocols. One other cause is no connectivity to the SMTP server (discovered with a ping test from MMCS CMD prompt).

Resolution

Refer to the documentation, under the "Known Issues and Limitations" section of the Unisphere Release Notes:

kA2j0000000kB3QCAU_2_0

To get email alerts working for Unisphere 8.2 or greater, you need to upgrade to a Microsoft Exchange Server version that supports TLS 1.2.

To resolve this issue perform the following steps: 
  1. The Exchange environment must have a specific version. Refer to the Microsoft knowledge base and the article titled: "SMTP is not transported over TLS 1.1 or TLS 1.2 protocol in an Exchange Server 2013 environment" (https://support.microsoft.com/en-us/kb/3045301).
  2. Ensure that the Transport Layer Security (TLS)  on the security page on the exchange receive connector is enabled, as well as Anonymous users and un-check Integrated Windows authentication:
kA2j0000000kB3QCAU_2_1
kA2j0000000kB3QCAU_2_2
  1. Try the FQDN and IP address, in the "IP Address/Host" field.
  2. Have Exchange server Admins check their side and inspect logs.
  3. Ensure the browsers are also at current supported levels (as per the Install Guide).
  4. Refer to this link for registry setting requirements: https://technet.microsoft.com/en-us/library/dn786418.aspx#BKMK_SchannelTR_TLS12
  5. Pick the appropriate Schannel SSP registry. In this case, TLSv1.2
  6. There are Exchange Administrator specific tasks to align with their site policies.
  7. Check connectivity to SMTP server with a ping test.
You can also refer to knowledge article 482237 Unisphere cannot send email alerts after upgrade to 8.2

Article Properties


Affected Product

Unisphere for VMAX

Product

Unisphere for VMAX

Last Published Date

20 Nov 2020

Version

2

Article Type

Solution