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Isilon: Job engine will not automatically retry a scheduled job after it has failed

Summary: OneFS's job engine will not automatically retry a scheduled job after it has failed. Administrators need to manually start the job.

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Article Content


Symptoms

When a scheduled OneFS job engine job fails, the job engine will not automatically retry the job. The cause for the failure should be investigated, and corrected, and then the job manually restarted. Once the job has subsequently succeeded OneFS resumes running the job according to schedule.

Jobs that are typically configured with a schedule, by default, are the following:
  • FSAnalyze
  • MediaScan
  • ShadowStoreDelete
  • ShadowStoreProtect
  • SmartPools
  • WormQueue
Jobs that do not run on demand, such as SnapshotDelete and FlexProtect/FlexProtectLin, are not subject to this limitation. They will retry automatically after a failure.

Cause

This behavior within the job engine is by design but may change in the future.

Resolution

An administrator should find and correct the cause of failure and then restart the job manually.

Article Properties


Affected Product

PowerScale OneFS

Last Published Date

28 Jun 2023

Version

5

Article Type

Solution