Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

NetWorker: Troubleshooting Media Waiting Events - waiting for 1 writable volume or no matching devices

Summary: NetWorker: Troubleshooting Media Waiting Events - waiting for 1 writable volume or no matching devices

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

  • A backup or clone operation is performed through NetWorker.
  • The following error messages are observed.
    • Waiting for <number> writable volumes to backup pool '<pool>' <family> on <host>
    • No matching devices; check storage nodes, devices, or pools.
  • These messages can be found through:

Cause

The above alerts are caused when NetWorker cannot find any suitable volume on which to write a backup. They can be generated for one or more of the following reasons mentioned under Resolution section.

Resolution

Action Definitions

The Policy > Workflow > Action configuration and media pools must be properly configured:

Destination Pool

The Destination Pool property of the action defines which pool the data is sent. A pool is a collection of volumes to which NetWorker writes data.
 
The pool attribute is set in the NMC. Select a workflow within a policy and review the relevant action. The backup is sent to the pool which is defined in the 'Destination Pool' action parameter. 
 
Select workflow policy
 
NOTE: If 'Client Override Behavior' on the Action is set to 'Client Can Override', then the 'Pool' value from the client is taken into account as the first priority.

The pool to which the data is being sent must contain an available volume. You can see the list of volumes and their pools in, for example, Media > Disk Volumes.
 
list of volumes and their pools

For specific example, consult this article:

Destination Storage Node

The Destination Storage Node attribute of the workflow action must be set correctly. This field specifies the hostname of the storage node that has the devices which receive the backup data. By default, the NetWorker server appears. To select a remote storage node, click the edit button to the right of the field and select each required storage node.  
 
specify backup options
 
NOTE: If 'Client Override Behavior' on the Action is set to 'Client Can Override', then the storage node defined in the client parameter called 'Storage Nodes' in the client 'Globals (2 of 2) is used as a priority. View > Diagnostic Mode must be enabled in the NMC to see the Storage Nodes field. By default the NetWorker server's storage node (nsrserverhost) is defined.
 
client properties
 
Ensure that there are available (mounted) volumes in the devices on the storage node which you have selected. You can check this in the NMC, in Devices > Devices.
 
image.png
 
NOTE: If the 'Volume Name' column is empty, the device is not mounted. The 'Volume Pool' column is not shown by default, but can be added.

For specific examples, consult this article:

Client Properties

If the NetWorker client resource has 'Data Domain backup' selected, there must be an available Data Domain volume in the selected pool.
client properties
 
NOTE: View > Diagnostic Mode must be enabled in the NMC to see the Deduplication Data Domain options.


Bootstrap Backups 

The NetWorker server's bootstrap save set can only be saved to a volume mounted using the NetWorker server's embedded storage node (by design). That is, the NetWorker server's bootstrap save sets cannot be saved to remote devices (rd=storagenode_name:device_name). 
saved volumes

For specific example, consult this articles:


Pool Properties

The Device specified in the Devices attribute of the Destination Pool must have the correct path. 

device path

The selected devices should be mounted under Devices > Devices:
where to mount devices
NOTE: If the 'Volume Name' column is empty, the device is not mounted. The 'Volume Pool' column is not shown by default, but can be added.


    Name Resolution

    Name resolutions observed with the NetWorker server, Storage Nodes, Clients, or Devices should also be verified.

    For specific examples, consult these articles:


    Cloning Considerations

    Cloning must be configured correctly. NetWorker requires two or more storage devices to perform a clone operation. One device contains the volume with the original data and one device contains the volume to which NetWorker writes the clone data. Source and destination must be two different volumes. Each clone volume can only contain one instance of a cloned save set.
     
     
    Cloning can be set up in several different ways in NetWorker. One common way is to setup a NetWorker group of type 'Save Set Query'. For this, the policy action wizard for the workflow which has been associated with the group can be used to define the 'Destination Storage Node' and 'Destination Pool'. This decides where exactly this clone data is written to. There must be NetWorker volumes available in this pool using this storage node which does not already have a copy of this save set instance on them.
     
    Alternatively, a clone action can be added after a backup action in order to clone those save sets which have been backed up by the previous action. The policy action wizard is used to define where to write the clone data. 
     
    If there is no destination storage node defined in the workflow action, the storage node to which clone data is written depends on the storage nodes listed in the 'Clone storage nodes' field for the source storage node or, if this is blank, the NetWorker server storage node. This value is defined in the properties of the storage node resource 'Configuration' tab. Cloned data originating from this storage node is directed to the first storage node which has an enabled device and a functional media daemon (nsrmmd).


      Tape Devices

      Tape Device issues are causing NetWorker not to be able to write to the target device.


        AFTD Devices

        The NetWorker Advanced File Type Device (AFTD) is not working as expected:

          Additional Information

          Article Properties


          Affected Product

          NetWorker

          Product

          NetWorker, NetWorker Series

          Last Published Date

          19 Feb 2024

          Version

          8

          Article Type

          Solution