Symptoms
Although a regular Avamar client can back up data from mapped CIFS drives and exported NFS mounts, this functionality is not supported.
Dell Support does not assist with configuring or troubleshooting issues relating to the backup or restore of such data.
Common problems related to backing-up CIFS, NFS, and SMB shares include,
but are not restricted to the following:-
- If Windows data is backed up using a UNIX Avamar client, it loses the Windows Access Control Lists (ACLs). Conversely, if UNIX data is backed up using a Windows client, it loses the UNIX ACLs.
- Backup performance may be poor.
- You may experience third-party issues,
- You may experience issues caused by CIFS version interoperability.
- There is no facility to perform VSS-like snapshots of data located across a mapped CIFS or NFS share. Files which are open may not be backed up in a consistent manner.
Cause
The functionality is not supported.
Resolution
Storage devices such as NAS filers should be backed up using an Avamar Network Data Management Protocol (NDMP) accelerator.
The Avamar NDMP accelerator node is a dedicated Avamar client. It runs the regular Avamar Linux client software and the Avamar NDMP plugin to back up data from supported filers using the NDMP protocol.
Information on NDMP accelerator functionality is available in the Avamar NDMP accelerator guide or can contact EMC Account Manager.
If the system exporting the data using CIFS or NFS has an Operating System which is supported by Avamar, install an Avamar client on it and back up the data directly to an Avamar server.
Additional Information