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PowerStore: NAS File System Writes are denied due to Out of Space / out of inodes

Summary: A file system may run out of inodes on PowerStore 2.X or earlier.

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Article Content


Symptoms

A file system that is not out of space in terms of capacity is out of inodes and unable to perform new writes.
For this issue, no error is displayed in the PowerStore Manager user interface and no alert is created for the file system in question.
User and Tree Quotas are not exceeded either.

Error messages on the client side can include, but are not limited to:
mkdir: cannot create directory 'DirectoryName': Invalid argument

Checking the free space using df -h may still report free space on the file share, however df -i shows the share's inode usage.
In this example, PowerStoreShare1 has plenty of free inodes, however PowerStoreShare2 is out of inodes.
[user@<nfs client> ~]$ df -i
Filesystem                      Inodes     IUsed     IFree IUse%   Mounted on
...
NAS_Server:/PowerStoreShare1  16889584        35  16889549    1%  /MountPath1
NAS_Server:/PowerStoreShare2  16889584  16889584         0  100%  /MountPath2

Cause

The file system may have run out of inodes and no longer allows writes to the file system.
An inode represents meta data that is used for files and folders directory structure.

This is not directly related to capacity (space) used.
Depending on the usage pattern, the inodes may be used up, and PowerStoreOS version 2.1 and earlier may not be able to repurpose freed up inodes for further writes.

Resolution

Fix

This issue is resolved in PowerStoreOS version 3.0 and later.
 

Workaround:

Increase the File System size. inode allocation is automatic, and happens in 256 MB chunks. It is usually enough to increase the file system space by a few GB.
After write access is restored, the file system can be shrunk to the original size again.

If increasing the file system size does not solve the issue, contact Dell Technical Support or your Authorized Service Representative, and quote this knowledge base article ID.

Article Properties


Affected Product

PowerStore

Last Published Date

30 Dec 2022

Version

3

Article Type

Solution