Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

PowerStore alert: NAS server is in maintenance mode

Summary: NAS server is in maintenance mode on both the source and destination side.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

When Dell PowerStore encounters an issue, an error alert is generated to help identify the issue. This article explains the different possible causes and the relevant remediation for these error alerts. If your issue is not resolved despite the remediation that is provided, check the technical support contact options.
 
SLN317187_en_US__1icon Note: Cannot find the information that you need? Let us know using the feedback form at the bottom of this article.

Cause

When NAS server is replicating to a peer system and if there is a communication issue due to management network issues between the two systems, then data access will not be impacted. 
However, if the user performs the unplanned failover from the destination then it will bring up the destination NAS server into production mode.
Later when the comminution issue is resolved between source and destination, NAS discovers that both the NAS servers are in production mode and it put the NAS server to maintenance mode to avoid the split-brain which can lead to data corruption.

Resolution

Alert ID SDNAS_PEER_VDM_STATUS_PEERVDM_IN_MAINTENANCE
Alert Text NAS server is in maintenance mode for replication session (%(replicationSessionId)).
Error Code 0x01303502
Impact Data protection is impacted.
Resolution  Solution:
Contact Technical Support for assistance.

Article Properties


Affected Product

PowerStore

Last Published Date

12 Jul 2022

Version

1

Article Type

Solution