Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

PowerStore: Windows VMs crash on boot with stop code 0xC000021A after migrating to PowerStore 

Summary: Migrating VMs from another storage array to PowerStore may result in a blue screen on boot. If the VM is restarted after migration it will blue screen likely with stop code 0xC000021A, but other stop codes are possible. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

VMs using UEFI boot run into a blue screen during boot.
This issue occurs with unpatched versions of ESXi. See VMware KB 2137402.

This applies to:
  • ESXi versions 6.5, 6.7 and 7.0.
  • Windows Server 2012, 2016 and 2019 VMs.
  • VMFS5 or VMFS6.
  • Live or cold migrations.


This issue can be identified in the PowerStore logs by searching for WRITE with size exceeding MAX TRANSFER:
The error displayed is "parse_error_full:364: WRITE with size exceeding MAX TRANSFER SIZE (2056 >= 2048)": 


Or counting the number of such occurrences.

svc_journalctl | grep "WRITE with size exceeding MAX TRANSFER" | wc -l
1131348

Cause

The hosts are not configured as per PowerStore best practices:
https://dl.dell.com/content/manual37523884-dell-emc-powerstore-host-configuration-guide.pdf


In particular see section on recommended configuration values:

Disk.DiskMaxIOSize = 1024


This exposes a known issue in ESXi which is resolved in latest versions.


Resolution

Run the following command on the ESXi hosts to check the current value:
esxcli system settings advanced list -o "/Disk/DiskMaxIOSize"

For PowerStore, Int Value should be set to 1024:
Path: /Disk/DiskMaxIOSize
Type: integer
Int Value: 1024
Default Int Value: 32767
Min Value: 32
Max Value: 32767
String Value:
Default String Value:
Valid Characters:
Description: Max Disk READ/WRITE I/O size before splitting (in KB)


Run the following command on each ESXi host to set the correct value:
esxcli system settings advanced set -o "/Disk/DiskMaxIOSize" --int-value 1024

Additional Information

KB 000182665 describes the same issue but with different symptoms.

Article Properties


Affected Product

PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000T

Product

PowerStore 9000X

Last Published Date

14 Dec 2022

Version

7

Article Type

Solution