Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

Article Number: 000186187


Cloud Disaster Recovery: Issues booting VM and unable to access via RDP despite being able to rehydrate during Failover to Azure

Summary: After a successful failover to Azure, a Windows VM experiences issues when booting and hence, accessibility via RDP fails.

Article Content


Symptoms

Symptoms found in the logs:       

In the database, we see the virtual machine shows no actual errors in the logs. The events all succeed:     

title                     | description                                                                                                                |
+---------------------+---------------------------+----------------------------------------------------------------------------------------------------------------------------+
| Promote DR Test succeeded | DR: SomeVM with activity id: d4102db2-6043-4b46-93be-8892b870c17d promote succeed                                    
| Promote DR Test started   | DR: SomeVM with activity id: d4102db2-6043-4b46-93be-8892b870c17d promote started                                    
| DR ready                  | DR: SomeVM with activity id: edb59960-b7b9-46c3-a796-a2fb0593b500 is ready                                           
| Restore Finished          | Restore Step For: 455f0cf8-192f-409a-b226-cda74745298c with activity id: edb59960-b7b9-46c3-a796-a2fb0593b500 has finished 

Cause

Windows VMs need to be prepared for Azure compatibility. This is covered in the Azure documentation. See link: https://docs.microsoft.com/en-us/azure/virtual-machines/windows/prepare-for-upload-vhd-image

Resolution

Below is a workaround for what was found so far. Accessibility issues and resolutions are not limited to the fix below:       

Follow the configuration recommendations by Microsoft's Azure documentation:  
https://docs.microsoft.com/en-us/azure/virtual-machines/windows/prepare-for-upload-vhd-image  


Review the following sections:     
  • System File Checker
  • Set Windows configurations for Azure
  • Check the Windows services
  • Update remote desktop registry settings
  • Configure Windows Firewall rules
  • Verify the VM
  • Install Windows updates
  • Complete the recommended configurations

Article Properties


Product

Avamar, PowerProtect Data Protection Appliance, PowerProtect Software

Last Published Date

03 Dec 2021

Version

2

Article Type

Solution