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Executive Summary

Document purpose

Audience

This deployment guide provides detailed instructions for installing, configuring, and
operating a software-defined data center (SDDC) based on the VMware Validated
Design for SDDC, using the VMware Cloud Builder virtual appliance to automate the
implementation of this validated design on Dell EMC VxRail appliances.

This deployment guide does not contain instructions for performing all required post-
configuration tasks, which are specific to the requirements of your organization.

This deployment guide is intended for cloud architects, infrastructure administrators,
and cloud administrators who are familiar with and want to use VMware software to
quickly deploy and manage an SDDC that meets the requirements for capacity,
scalability, backup and restore, and extensibility for disaster recovery support.

We value your feedback

Dell EMC and the authors of this document welcome your feedback on the solution
and the solution documentation.

Contact the Dell EMC Solutions team by email or provide your comments by
completing our documentation survey.

Authors: Dell EMC Solutions, Jeff Purcell, Donna Renfro
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VVD on VxRail Deployment Overview
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VVD on VxRail Deployment Overview

Introduction

This deployment uses VMware Cloud Builder for VxRail, which is designed to expedite
the delivery of VVD on VxRail hyper-converged infrastructure (HCI) appliances.

Cloud Builder for VVD automates the deployment and configuration of most SDDC
systems and services. The deployment flow for Cloud Builder VVD on VxRail is
designed to better support services alignment. The deployment is logically separated
into three phases with distinct start and end points so that each phase can be
completed by an organization according to skill set or service definition agreement.

Phase 1—Deploy VxRail clusters

Set up the VxRail infrastructure for the SDDC environment.

Phase 1 includes the following tasks, which are detailed in Deploying VxRail on page
17:

e Deploy two VxRail clusters for the Management and Shared Edge and Compute
domains. Each cluster requires a minimum of four Dell 14G nodes.

¢ Deploy the VxRail Management cluster with the option for an embedded vCenter
and Platform Services Controller. After the cluster is deployed, use the VxRail
vCenter conversion utility to convert the systems to customer-managed systems.

e Deploy the Cloud Builder VM to establish the external vCenter for the VxRail
Shared Edge and Compute cluster. Deploy the second vCenter Server using the
ISO or a scripted process.

e Complete the following additional tasks on the VxRail Shared Edge and Compute
vCenter. Procedures for these tasks are available in the VxRail External vCenter
deployment SolVe procedure at https://solveonline.emc.com.

= Create a datacenter that matches the parameter file.
= Create a vCenter user account for the VxRail administrator.
= Assign the vCenter VMware HCIA entitlement to the account.

The following figure represents the phase 1 tasks.

8 VMware Validated Design v5.0 on Dell EMC VxRail for a Single Region
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VVD on VxRail Deployment Overview

Figure 1 Phase 1 deployment flow
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VVD on VxRail Deployment Overview

Phase 2—Deploy the Cloud Builder SDDC clusters

Phase 2 validates the environment readiness for the Management and Shared Edge
and Compute clusters and automates the deployment of the SDDC using the details
defined in the parameter file.

10

Complete and verify the following prerequisites well in advance of the Cloud Builder
preparation:

Configure the network switches.
Populate the parameter file.
Obtain machine certificates.

Add the Active Directory user and service accounts.

Phase 2 includes the following tasks, which are detailed in Deploying the SDDC
Components on page 41:

Deploy and configure SQL Database for vRealize Automation
Deploy and configure Cloud Builder Virtual Appliance.
Validate the environment.

Generate certificates for the VMware Validated Design (VVD) systems within the
environment.

Deploy NSX Manager, Controllers, and Edge Services.
Configure dynamic routing.

Deploy vRealize Suite (vRealize Automation, vRealize Operations, Log Insight,
vRealize Business).

Note

Some components, such as VMware Update Manager, are optional for VVD on
VxRail. Cloud Builder enables you to select deployment components by using the
parameter file.

The following figure represents the phase 2 tasks.

VMware Validated Design v5.0 on Dell EMC VxRail for a Single Region



Figure 2 Phase 2 deployment flow
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VVD on VxRail Deployment Overview

Phase 3—Complete post-deployment tasks

Phase 3 consists of Cloud Builder post-deployment tasks, including Cloud
Management Platform configuration to prepare for monitoring, logging, and reporting
operations.

Phase 3 includes the following tasks, which are detailed in Post-deployment:
Configuring the Virtual Infrastructure on page 45, Post-deployment: Configuring
vRealize Operations Manager on page 53, and Post-deployment: Configuring the
Cloud Management Platform on page 59:

e Configure the Cloud Management Platform to provide templates, blue prints, and
consumable catalog services.

e Complete the tasks to establish monitoring, logging, and reporting operations.

e (Optional) Complete custom services for complex workflows and services. (Not
covered in this document.)

The following figure represents the phase 3 tasks.

Figure 3 Phase 3 deployment workflow
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CHAPTER 3

Requirements and Prerequisites

This chapter presents the following topics:

Required software

Required SolVe procedures

Requirements and Prerequisites

Required hardWare.........coi i s e e e e een s
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Requirements and Prerequisites

Required software

Ensure that the software in your environment meets the requirements for this

deployment.

Dell EMC software

The products described in this document have been validated with the VxRail 4.7.110
software release. VVD 5.0 is supported on VxRail 4.7.110 and later release versions.

VMware software

The following table lists the required VMware software for this deployment.

Table 1 Required VMware software

Product group and edition

Product name

Product version

Manager Advanced or higher

Manager

VMware Validated Design VMware Cloud Builder 1.0

VMware vSphere Enterprise Plus | ESXi 6.7 Ulb
vCenter Server Appliance 6.7 Ulb
vSphere Update Manager 6.7 Ulb
vSphere Replication 8.11

VMware vSAN Standard or vSAN 6.7 Ulb

higher

VMware NSX Data Center NSX Data Center for 6.4.4

Advanced or higher vSphere

VMware vRealize Suite Lifecycle | vRealize Suite Lifecycle 2.0.0 Patch 2

Manager Manager

VMware vRealize Operations vRealize Operations 7.0

VMware Validated Design Cloud
Builder ISO Bundle

Cloud Builder ISO Bundle

vvd-bundle-johndory-
X. X XXXXXXXX.iSO

The VMware Validated Design for Software-Defined Data Center Release Notes provides
more information about supported product versions.

Required hardware

Ensure that your environment meets the requirements for this deployment.

14

The following table lists the hardware specifications for the management domain and

the compute domain.

Table 2 VxRail appliance specifications per domain

Hardware

Description

Servers

Four VxRail Dell 14G Appliances (Nodes)

CPU (per server)

Dual-socket, 8 cores per socket

Memory (per server)

192 GB

VMware Validated Design v5.0 on Dell EMC VxRail for a Single Region




Requirements and Prerequisites

Table 2 VxRail appliance specifications per domain (continued)

Hardware Description

Storage (per server) BOSS with 2 x 240 GB SATA M.2

One 400 GB SSD - caching tier

Two 1.2 TB HDD @ 10 K RPM - capacity tier

NICs per server Four 10 GbE or 25 GbE NICs
One 1 GbE BMC NIC

Complete the pre-engagement qualification form

Ensure that you have obtained all the deployment requirements.

Capture the installation details for the VxRail deployment by using the Dell EMC VxRail
pre-engagement qualification (PEQ) form, available in the Enablement Tools section
of Dell EMC SolVe Online for VxRail. Use the VxRail information in the PEQ to
populate the Cloud Builder parameters file.

Required SolVe procedures

Download the SolVe procedures that you will need for the deployment.

Go to Dell EMC SolVe Online for VxRail and download the following procedures:
¢ VxRail Installation procedure for Embedded vCenter

¢ VxRail Installation procedure for External vCenter

¢ VMware Validated Design procedure, Convert the Embedded VxRail vCenter
Server to a Customer Managed vCenter Server for VVD

¢ VMware Validated Design procedure, Enable VVD Cloud Builder for VxRail

Complete the pre-engagement qualification form 15


https://solveonline.emc.com/solve/home/51
https://solveonline.emc.com/solve/home/51

Requirements and Prerequisites
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Deploying VxRail
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Deploying VxRail 17



Deploying VxRail

Configure DNS settings for VxRail clusters

Configure DNS settings for Management and Shared Edge and Compute cluster

hosts.

Refer to the following tables to configure DNS settings for hosts in the Management
domain and Shared Edge and Compute domain.

Table 3 Management cluster host values

FQDN

IP address

sfo01mO1vxmO1.sfo01.rainpole.local

172.16.11.100

sfo01mO01psc01.sfoO1.rainpole.local 172.16.11.61

sfo01mO01vc01.sfo01.rainpole.local 172.16.11.62
Table 4 Management domain ESXi host values

Management ESXi Hosts IP

sfo01mO01esx01.sfo01.rainpole.local

172.16.11.101

sfo01mO01esx02.sfo01.rainpole.local

172.16.11.102

sfo01mO01esx03.sfo01.rainpole.local

172.16.11.103

sfo01mO01esx04.sfo01.rainpole.local

172.16.11.104

Table 5 Shared Edge/Compute cluster host values

FQDN IP address
sfo01w01vxmO01.sfo01.rainpole.local 172.16.11.69
sfo01w01psc01.sfoO1.rainpole.local 172.16.11.63
sfo01w01vc01.sfo01.rainpole.local 172.16.11.64

Table 6 Shared Edge/Compute domain ESXi host values

ESXi Hosts

IP

sfo01w01esx01.sfo01.rainpole.local

172.16.31.101

sfo01w01esx02.sfo01.rainpole.local

172.16.31.102

sfo01w01esx03.sfo01.rainpole.local

172.16.31.103

sfo01w01esx04.sfo01.rainpole.local

172.16.31.104

Configure DNS Settings for PSC load balancer

This VMware Validated Design deploys two Platform Services Controllers (PSCs)
behind a load balancer implemented through NSX for vSphere. When you prepare your
environment for automated deployment using Cloud Builder, NSX for vSphere is not

VMware Validated Design v5.0 on Dell EMC VxRail for a Single Region




Deploying VxRail

yet available. Perform DNS configuration to emulate an existing load balancer IP

address for the PSC load balancer in Region A.

Before you begin

Verify that the following static IP addresses are allocated:

e Static IP address for the Management Platform Services Controller

e Static IP address for the Platform Services Controller Load Balancer Virtual IP

Table 7 IP addresses and host names for the PSC load balancer and the PSC for the
management cluster

the Managem

ent Cluster 1

Component Host name |IP address |Domain

Platform Services Controller sfo01pscO1 172.16.11.71 sfoO1.rainpole.local
Load Balancer

Platform Services Controller for | sfo01mO01pscO |172.16.11.61 sfoO1.rainpole.local

Procedure

1. Logintothe dcOlrpl.rainpole.local DNS server.

From the Windows Start menu Search bar, type dnsmgmt .msc and press Enter.

In the DNS Manager dialog box, create an A Record for the PSC load balancer
name VIP:

a. Expand Forward Lookup Zones.

b. Right click the sfo01.rainpole.local zone and select New Host (A or
AAAA).

c. Enter the following values, and then click Add Host.

Name: sfo01psc01

Fully qualified domain name (FQDN):
sfo0lpsc0l.sfo0l.rainpole.local

IP address : 172.16.11.61

Clear Create associate pointer (PTR) record

Note

To create an operational network configuration for

sfo0lpsc0l.sfo0l.rainpole.local, Cloud Builder requires forward
lookup with IP 172.16.11.61 and reverse lookup with IP 172.16.11.71 (the load
balancer VIP). Ensure that the A Record and the pointer (PTR) record are

not associated and point to different IP addresses.

4. Create a pointer (PTR) record for the Platform Services Controller Load
Balancer VIP and point it to the A Record of the Platform Services Controller
Load Balancer VIP:

a. Expand Reverse Lookup Zones.

b. Right clickthe 11.16.172.1in-addr.arpa zone and select New Pointer
(PTR).

c. Type the following values, and then click OK:

Configure DNS Settings for PSC load balancer 19



Deploying VxRail

Host IP address: 172.16.11.71

Fully qualified domain name (FQDN): 71.11.16.172.in-addr.arpa

Host name: sfo01lpsc0l.sfo0l.rainpole.local

Deploy the VxRail Management cluster

Use the VxRail Installation with embedded vCenter Server SolVe procedure to deploy

the management cluster.
Before you begin

Ensure that you have:

e A Windows host that has access to your data center. You use this host to connect
to the data center and perform configuration steps.

¢ Downloaded the VxRail SolVe Installation procedure from Dell EMC Solve Online
for VxRail embedded vCenter deployment.

¢ Populated DNS with forward and reverse lookup records of the VxRail Platform
Services Controller, vCenter, and ESXi hosts. Refer to the system properties in
the following tables to deploy the VxRail cluster.

Table 8 VxRail first-run host requirements

FQDN IP address VLAN ID Default gateway |NTP server
sfo01mO01vxmO01.sfoO1.rainpole.local 172.16.31.100 1611 172.16.11.253 ntp.sfoO1.rainpole.local
sfo01mO01psc01.sfo01.rainpole.local 172.16.31.61

sfo01mO01vc01.sfoO1.rainpole.local 172.16.31.62

Table 9 VxRail Management cluster hosts

Hostname FQDN range

IP range

VLAN ID

Default gateway

NTP server

sfo01mO01esx01.sfoO1.rainpole.local —
sfo01mO01esx04.sfo01.rainpole.local

172.16.11.101 -
172.16.11.104

1611

172.16.11.253

= ntp.sfoOl.rainpole.local

= ntp.lax01.rainpole.local

Table 10 vSAN host configuration

sfo01mO01esx04.sfo01.rainpole.local

172.16.13.104

Hostname FQDN range IP range VLAN ID Default gateway
sfo01mO01esx01.sfo01.rainpole.local — 172.16.12.101 - 1612 172.16.12.253
sfo01mO01esx04.sfo01.rainpole.local 172.16.12.104

Table 11 vMotion host configuration
Hostname FQDN range IP range VLAN ID Default gateway
sfo01mO01esx01.sfo01.rainpole.local — 172.16.13.101 - 1613 172.16.13.253

20 VMware Validated Design v5.0 on Dell EMC VxRail for a Single Region
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Table 12 VM network host configuration

Hostname FQDN range IP range VLAN ID Default gateway
sfo01mO01esx01.sfoO1.rainpole.local — 172.16.14.101 - 1614 172.16.14.253
sfo01mO01esx04.sfo01.rainpole.local 172.16.14.104

The management cluster provides management services for both domains. Use the
initialization wizard to deploy the management cluster.

VxRail Manager provides automated deployment to initialize a vCenter cluster for the
VVD environment. The initialization process deploys and configures ESXi Hosts, vDS
networking, vSAN storage, Platform Services Controller (PSC), and vCenter during
this task.

Procedure

¢ Follow the steps in the VxRail Installation SolVe procedure for Embedded vCenter
on Dell EMC Solve Online.

Convert embedded vCenter and PSC to customer-managed

systems

Use the SolVe procedure to re-establish the PSC and vCenter as customer-managed
systems.

Before you begin

Download the SolVe procedure, Convert the Embedded VxRail vCenter Server to a
Customer Managed vCenter Server for VVD (VMware Validated Design).

This task establishes the foundation for the VVD laaS deployment. This conversion has
the following benefits:

e [t establishes a common identity-management system (SSO) for vCenter Server
enhanced linked mode and cross-site vCenter Server for dual-region deployments.

e It provides better alignment with VVD for lifecycle management.

Procedure

e Follow the steps in the SolVe procedure, Convert the Embedded VxRail vCenter
Server to a Customer Managed vCenter Server for VVD (VMware Validated Design).

Deploy the Cloud Builder virtual appliance

The VMware Cloud Builder virtual appliance automates the implementation of the
SDDC components.

Before you begin
Verify that your environment fulfills the requirements for this deployment:

e Verify that the following static |P addresses and FQDNs for the VMware Cloud
Builder virtual appliance are available:

= |P Address—172.16.11.60
= Host Name—sfoO1cb01
»  Default Gateway—172.16.11.253

Convert embedded vCenter and PSC to customer-managed systems 21
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22

DNS Servers—172.16.11.5 and 172.16.11.4
DNS Domain—sfoO1.rainpole.local

DNS Search—sfoO1.rainpole.local
Subnet Mask—255.255.255.0

NTP Servers—ntp.sfoO1.rainpole.local and ntp.laxO1.rainpole.local

e Verify that your environment satisfies the following prerequisites for the
deployment of the virtual appliance of VMware Cloud Builder:

Environment—Verify that your environment is configured for deployment of
VMware Cloud Builder and of the SDDC as described in Deploying VxRail on
page 17.

Storage—Virtual disk provisioning: Thin, Required storage: 25 GB

Installation packages—Download the . ova file for VMware Cloud Builder.

Procedure

1.

Log in to the Management vCenter in Region A.

a. Open a Web browser and goto https://
sfo0lmO0lesx01l.sfo0l.rainpole.local.

b. Log in using the user name administrator@vsphere.local and the
administrator password.

In the Navigator, select the data center and click Create/Register VM.
The New virtual machine wizard appears.

In the Select creation type dialog box, select Deploy a virtual machine from
an OVF or OVA file and click Next.

In the Select OVF and VMDK files dialog box, enter sf001cb01 for the virtual
machine name, select the VMware Cloud Builder . ova file, and click Next.

In the Select storage dialog box, select VxRail Manager vSAN Datastore-
<uniquelD>, and click Next.

On the License agreements page, click | agree to accept the license
agreement, and click Next.

On the Deployment options page, enter the following values, and then click
Next:

¢ Network mappings— VxRail vCenter Server-<uniqueid>
¢ Disk provisioning—Thin
e Power on automatically—Selected

In the Additional settings dialog box, expand Application, enter the following
values, and then click Next.

Option Value
Root password sfo01cb01_root_password
Note

The passwords must be at least 8 characters, must contain
uppercase, lowercase, digits, and special characters.
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Option

Value

Confirm root password

sfo01cb01_root_password

Enter admin user name

admin

Enter admin password

sfo01cb01_admin_password

Confirm password

sfo01cb01_admin_password

IP address

172.16.11.60

Subnet mask

255.255.255.0

Default Gateway

172.16.11.253

VM hostname

sfo01cb01

Domain name

sfoO1.rainpole.local

Domain search path

sfo01.rainpole.local, rainpole.local

DNS

172.16.11.5,172.16.11.4

NTP

ntp.sfoO1.rainpole.local, ntp.laxO1.rainpole.local

9. In the Ready to complete dialog box, review the virtual machine configuration
and click Finish.

10. Refer to the "Enable VVD Cloud Builder for VxRail" Solve procedure to enable
VxRail configuration tasks.

Generate the JSON deployment files

Generate the VxRail and VVD JSON files that automate the deployment of the laaS
and SDDC components in the management and the shared edge and compute
clusters.

Before you begin
Verify that you have populated the Deployment Parameters XLS file.
Procedure

1. Log in to VMware Cloud Builder:

a. Open a Web browser and goto https://
sfo0lcb0l.sfo0l.rainpole.local.

b. Log in using the user name admin and the Cloud Builder administrator
password.

2. Generate the JSON file used for automated deployment of the SDDC
components:

a. In the Cloud Builder Navigator, select the Deployment Wizard icon.

b. In the Upload Config File tab, from the Select Architecture Type list,
select the VVD for SDDC 5.0 on Dell EMC VxRail (Region A) architecture
and click Upload Config File.

c. Navigate to the Deployment Parameters XLS file and click Open.
d. Click Generate JSON.

Cloud Builder generates two JSON files for the management and the shared
edge and compute clusters, as listed in the following table.
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Architecture JSON filename Workload Deployment
type domain order
VVD for SDDC vvd-vxrail-rega-mgmt.json Management 1
Region A - -
vvd-vxrail-rega-mgmt.json | Compute 2
vxrail-rega-comp- VxRail management | 3
manager.json cluster
vxrail-rega-mgmt-comp.json | VxRail compute 4
cluster

3. Monitor the process and check for errors in the JSON Generator log files
at /opt/vmware/sddc-support/cloud admin tools/logs/
JsonGenerator.log.

Mount the VVD software bundle on Cloud Builder

Prepare for an automated deployment of the SDDC components by uploading the
software bundle and the generated signed certificates, and configuring application
properties.

Procedure
1. Log in to the VMware Cloud Builder virtual appliance.

a. Open a connection to sfo01cb01.sfo0l.rainpole.local using an
SCP software like WinSCP.

b. Log in using the user name admin and the Cloud Builder administrator
password.

2. Upload the VMware Validated Design software bundle file vvd-bundle-
johndory-x.x.x-xxxxxxx.1so tothe /mnt/hgfs directory on the Cloud
Builder appliance.

3. Upload all folders and their content from the CertGenvvD folder C:
\CertGenVVD-3.0.4\SignedByMSCACerts to the /opt/vmware/vvd/
certificates directory on the Cloud Builder appliance.

4. Configure the Cloud Builder appliance and mount the VMware Validated Design
software bundle . iso file:

a. Open an SSH connection to sfo01cb01.sfo01.rainpole.local.

b. Log in using the user name admin and the Cloud Builder administrator
password.

Switch to the root user by running the su command.

Mount the VMware Validated Design software bundle . i so file and configure
application properties by running the following command: /opt/vmware/vvd/
cloud-builder/install/reconfigure.sh.

The script sets the full system path to each application's installation file,
configures specific application properties, and restarts the bring up service.
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Deploy the vCenter Server for the Shared Edge/Compute

cluster

Install and configure the vCenter Server appliance (vCenter Appliance 6.7 U1lb
11726888) to support the Shared Edge and Compute Cluster.

Procedure

1. Start the vCenter Server Appliance Deployment wizard:

a.

b.

Browse to the vCenter Server Appliance ISO file.

Open the dvd-drive:\vcsa-ui-installer\win32\Installer
application file.

2. Complete the vCenter Server Appliance Deployment wizard to perform the
first stage of the installation:

a.
b.

C.

Click Install to start the installation.
Click Next on the Introduction page.

Select Accept license agreement and click Next.

. On the Select deployment type page, select vCenter Server (Requires

External Platform Services Controller) and click Next.

. On the Appliance deployment target page, enter the following settings and

click Next.

e vCenter Server name—sfo01lm0lvc0l.sfo0l.rainpole.local
e HTTPS port—443

e User name—administrator@vsphere.local

¢ Password—vSphere administrator password

. In the Certificate Warning dialog box, click Yes to accept the host

certificate.

g. On the Select folder page, select the default and click Next.

h. On the Select compute resource page, select the sfo01-m01-mgmt01

cluster and click Next.

. On the Set up appliance VM page, enter the following settings, and click

Next.
e VMname—sfo0lw0OlvcOl
* Root password—compvc_root_password

e Confirm root password—compvc_root_password

. On the Select deployment size page, select Large vCenter Server, and

click Next.

. On the Select datastore page, select the VxRail vSAN datastore, select

Enable Thin Disk Mode, and click Next.

. On the Configure network settings page, enter the following settings, and

click Next:
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Setting Value

Network sfo01-m01-vds01-management
IP version 1Pv4

IP assignment Static

System name sfo01w01vc01.sfo01.rainpole.local
IP address 172.16.11.64

Subnet mask or prefix length 255.255.255.0

Default gateway 172.16.11.253

DNS servers 172.16.11.5,172.16.11.4

m. On the Ready to complete stage 1 page, review the configuration and click
Finish to start the deployment.

3. Complete the Install - Stage 2: Set Up vCenter Server Appliance wizard to
complete the second stage of the installation:

a. Click Next on the Introduction page.

b. On the Appliance configuration page, enter the following settings, and click
Next:

e Time synchronization mode—Synchronize time with NTP servers

e NTP servers (comma-separated list)—
ntp.sfoll.rainpole.local

e SSH access—Enabled

c. On the SSO configuration page, enter the following settings and click Next:

e Platform Services Controller—
sfolOlpscO0l.sfo0l.rainpole.local

e HTTPS port—443
¢ SSO domain name—vsphere.local

e SSO password—sso_password

d. On the Ready to complete page, review the configuration and click Finish.
e. Click OK on the warning message.

f. On the Complete page, click Close.

Deploy the Shared Edge and Compute VxRail cluster
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Follow the instructions in the SolVe procedure to install this cluster.

Before you begin

Ensure that the following tasks are complete:

e The Shared Edge and Compute vCenter Server is deployed in Region A.

¢ Network and top-of-rack switches are configured with the required VLANs and
BGP peer interfaces.

¢ A Windows host exists that has access to VxRail Manager within your data center.
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e (Optional) VxRail deployment JSON file exists.

Procedure

1. Download the VxRail Installation with External vCenter procedure from SolVe
Online using the selections shown in the following figure.

Figure 4 Installation guide selections

E M C Contact SolVe Support é

& Solve Desktop

In the event an upgrade is necessary, how many Nodes will there be in the Cluster?
O 3 nodes
® 4 or more nodes

Are you connecting to an external vCenter? Select the SysLog Option
® Yes ® None
O No O External SysLog Server (Customer Provided)

vRealize Log Insight (Embedded to the VxRail cluster)

Is this a Dark Site? i.e. Customer does NOT allow call-home!
© YES - This is a Dark-Site! Customer does NOT allow call-home!
® No - This is NOT a Dark-site! This customer allows call home!

The SolVe Tool produces the deployment guide with the detailed instructions
and dependencies for deploying the VxRail external cluster.

2. Follow the procedures in the SolVe deployment documentation to complete the
Shared Edge and Compute VxRail cluster deployment.

3. (Optional) Deploy the VxRail using the Cloud Builder generated JSON input file:

VxRail deployment supports two options for defining the configuration
properties. A manual process where details are entered by hand, and a JSON
configuration file which is pre-populated with configuration details.

¢ Cloud Builder produces multiple JSON files from the parameter file, including
a VxRail input file for both clusters. If the parameter file is available, log into
Cloud Builder and follow the process to generate the JSON files.

e Obtain the vxrail-rega-comp-manager. json file from Cloud Builder
using ftp or SCP. The file is available in the /opt /vmware/sddc-
support/cloud admin tools/Resources/vxrail-rega directory.

4. Refer to the information in the following tables for either manual or Cloud
Builder VxRail deployment.

Table 13 VxRail Manager, vCenter, and Platform Services Controller details

FQDN IP address VLAN ID Default
gateway
sfo01w01vxmO01.sfoO1.rainpole.local 172.16.11.69 1611 172.16.11.253
sfo01m01psc01.sfo01.rainpole.local @ 172.16.11.63 1611 172.16.11.253
sfo01w01vc01.sfo01.rainpole.local 172.16.11.64 1611 172.16.11.253

a. The second PSC has not been deployed yet, so you must join the management PSC during
this process. Repointing will be completed by Cloud Builder.
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Table 14 Management cluster hosts

FQDN IP address VLAN ID Default
gateway
sfo01w01esx01 ... sfo01w01esx04 172.16.31.101 ... 1631 172.16.31.253

172.16.31.104

Table 15 vSAN host configuration

FQDN IP address VLAN ID Default
gateway
sfo01w01esx01 ... sfo01w01esx04 172.16.33.101 ... 1633 172.16.33.253

172.16.33.104

Table 16 vMotion host configuration

FQDN IP address VLAN ID Default
gateway
sfo01w01esx01 ... sfoOTw01esx04 172.16.32.101 ... 1632 172.16.32.253

172.16.32.104

Configure SSH on vCenter Server and all ESXi hosts

Enable the SSH service to allow Cloud Builder remote connectivity.

Repeat this procedure for all hosts in the management and shared edge and compute
clusters. Use the values in the table in Configure DNS settings for VxRail clusters on
page 18.

Procedure
1. Log in to the vSphere host by using the VMware Host Client:

a. Open a Web browser and go to https://
sfo0lmO0lesx01l.sfo0l.rainpole.local.

b. Log in using the user name root and the esxi root user password.
2. Configure and start the SSH service:
a. In the Navigator, click Manage > Services.
b. Select theSSH service > Actions > Policy > Start and stop with host.

c. Click Start to start the service.

3. Connect to the Management port on the vCenter Server.

a. Open a Web browser and go to https://
sfo0lw0lvc0Ol.sfoOl.rainpole.local:5480.

b. Log in as Root.

c. Select the Access tab and enable SSH.
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CHAPTER 5

Preparing the Environment for Automated
Deployment

This chapter presents the following topics:

Deploy and configure the master Windows system..............coeeieiiiiieeiiireennnnnnn.
Deploy and configure the external SQL Server........cccccceeiiiiiiicccces
Deploy and configure the Windows system for Site Recovery Manager-.............
Generate and replace certificates for the SDDC components

Preparing the Environment for Automated Deployment
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Deploy and configure the master Windows system

30

Deploy and configure a single Master Windows system virtual machine to provision the
vRealize Automation laaS components.

Before you begin
Ensure that the following network requirements are met:

e Verify that you have allocated a static or DHCP IP address for the Master
Windows system.

e Verify the Master Windows system has access to the Internet.

The single Master Windows system virtual machine is cloned and reconfigured during
SDDC deployment to provision the vRealize Automation laaS components: laaS Web
Servers, laaS Manager Service Servers, laaS DEM Servers, and laaS Proxy Servers.
Create a virtual machine on the sfo01m0lvc0l.sfo0l.rainpole.local vCenter
Server for the Master Windows system with the virtual machine, software, and
network configuration listed in the following tables.

Table 17 Virtual machine requirements for the master Windows system

Setting Value

ESXi host mgt-vcenter.rainpole.local

VM name master-iaas-vm

Guest OS Microsoft Windows Server 2016 (64-bit)
vCPU 2

Memory 8 GB

Virtual disk 60 GB

SCSI Controller LS| Logic SAS

Datastore VxRail-Virtual-SAN-Datastore-<hexid>
Network interface VM Network

Network adapter type 1x VMXNET3

Table 18 Software requirements for the master Windows system

Component Requirement

Operating system Windows Server 2016 (64-bit).

VMware Tools Latest version.

Active Directory Join the virtual machine to the sfoO1.rainpole.local
domain.

Internet Explorer Enhanced Turn off ESC.

Security Configuration

Remote Desktop Protocol Enable RDP access.
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Table 18 Software requirements for the master Windows system (continued)

Component Requirement

Java e Java Runtime Environment (JRE) executable
jre-8u191-windows-x64 or later.

e Set the JAVA_HOME environment variable to the
Java installation directory.

e Update the PATH system variable to include the bin
folder of Java installation directory.

Secondary Logon service Start Secondary Logon service and set start-up type to
Automatic.

Procedure

1. Deploy the Master Windows System for vRealize Automation with the specified
configuration.

2. Log in to the vRealize Automation Master Windows virtual machine by using a
Remote Desktop Protocol (RDP) client:

a. Open an RDP connection to the virtual machine.

b. Log in using the Windows administrator user name and password.

3. Click Start, right-click Windows PowerShell, and select More > Run as
Administrator.

4. Set the execution policy by running the following command: Set-
ExecutionPolicy Unrestricted. Confirm the execution policy change at
the prompt.

5. Disable User Account Control (UAC) by running the following command:

set-ItemProperty -Path

"HKLM: \Software\Microsoft\Windows\CurrentVersion\Policies
\System" -Name

"EnableLUA" -Value "0O"

6. Disable IPv6 protocol:

set-ItemProperty -Path

"HKLM: \System\CurrentControlSet\Services\TCPIP6\Parameters" -
Name

"DisabledComponents" -Value Oxff

7. Verify that the source path for Microsoft Windows Server is available:

a. Mount the Microsoft Windows Server ISO file on the Master Windows
system virtual machine.

b. Create the \sources\sxs directory by running the following command in
Windows PowerShell: mkdir C:\sources\sxs

c. Copy the Microsoft Windows Server source files from sources\sxs on the
ISO file to the C: \sources\sxs directory on the virtual machine.
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d. Update the registry with the full system path of the Microsoft Windows
Server source files by running the following command in Windows
PowerShell:

New-Item -Path

"HKLM: \SOFTWARE\Microsoft\Windows\CurrentVersion\Policies
\Servicing"

set-ItemProperty -Path

"HKLM: \SOFTWARE\Microsoft\Windows\CurrentVersion\Policies
\Servicing\" -Name

"LocalSourcePath" -value "c:\sources\sxs"

e. Unmount the Microsoft Windows Server ISO file.

8. Add the svc-vra service account to the Local Administrators group.

a. Click Start, right-click Windows PowerShell, and select More > Run as
Administrator.

b. Run the following command: net localgroup administrators
rainpole\svc-vra /add.

9. Create the svc-vra user profile by logging in to the vRealize Automation
Master Windows virtual machine:

a. Open an RDP connection to the virtual machine.
b. Log in using the user name, rainpole\svc-vra and the svc-vra password.

10. Shut down the Master Windows system virtual machine.

Deploy and configure the external SQL Server

Deploy and configure a Windows-based virtual machine to host the SQL Server
database required for the vRealize Automation laaS components.

Create a virtual machine on the sfo01m0Olesx01.sfo0l.rainpole.local host
for the Microsoft SQL Server with the virtual machine, software, and network
configuration requirements listed in the following tables.

Table 19 Virtual machine requirements for the external vRealize automation SQL Server

Setting Value

ESXi host sfo01mO01vc01.sfoO1.rainpole.local

VM name vra0TmssqlO1

Guest OS Microsoft Windows Server 2016 (64-bit)
vCPU 8

Memory (GB) 16

Hard disk (GB) 200

SCSI Controller LS| Logic SAS

Datastore

VxRail-Virtual-SAN-Datastore-<hexid>

Network interface

vCenter Server Network-<hexid>

Network adapter type

1x VMXNET3
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Table 20 Network requirements for the external vRealize automation SQL Server

Setting Value
Host name vra01mssqlO1
Static IPv4 address 172.16.11.72

Subnet mask

255.255.255.0

Default gateway

172.16.11.253

DNS server

172.16.11.5

FQDN

vra01mssqlO1.rainpole.local

Table 21 Software requirements for the external

vRealize automation SQL Server

Component |Requirement Notes
Operating Windows Server 2016 (64-
system bit).
VMware Tools [ Latest version.
SQL Server SQL Server 2017 Standard | Important:
lat 4-bit).
or_ ater (64-bit) e During the SQL Server installation, the
Microsoft SQL Server . . . .
. Database Engine configuration wizard
Management Studio. .
prompts you to provide the user name
and password for the SQL Server
administrator. If this user was not added
during the SQL Server installation, select
SQ@L Authentication from the
Authentication drop-down menu, type sa
in the User name text box and the sa
password in the Password text box.

e The vRA Database must be configured
with the SQL 2014 compatibility
option selected.

Active Join the virtual machine to
Directory the
sfoll.rainpole.local
domain.
Remote Enable RDP access.
Desktop
Protocol
Procedure

1. Deploy the External vRealize Automation SQL Server VM with the specified

configuration.

(RDP) client:

Log in to the SQL Server virtual machine by using a Remote Desktop Protocol

a. Open an RDP connection to the vra0lmssglOl.rainpole.local virtual

machine.

Deploy and configure the external SQL Server
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b. Log in using the Windows administrator user name and password.
3. Enable Microsoft Distributed Transaction Coordinator (MSDTC):
a. Click the Windows Start button, type comexp.msc, and press Enter.
The Component Services window opens.

b. In the Console Root in the left pane, select Component Services >
Computers > My Computer > Distributed Transaction Coordinator.

c. Right-click Local DTC and select Properties.

d. In the Local DTC Properties dialog box, click Security, select the following
options, and then click OK.

e Network DTC Access
¢ Allow Remote Clients
e Allow Inbound

¢ Allow Outbound

e. In the MSDTC Service dialog box, select Yes to restart the MSDTC service.

4. Create the vRealize Automation account in the SQL Server instance.

a. Click the Windows Start button and open Microsoft SQL Server
Management Studio.

b. In the Connect to Server dialog box, for the Server Name leave the default
value, from the drop-down menu select Windows Authentication, and click
Connect.

c. In the Object Explorer tree, expand the VRAOTMSSQ@LO1 server instance,
right click the Security folder, and select New > Login.

d. In the Login dialog box, under Genreal, type rainpole\svc-vra in the
Login name text box.

e. On the Server Roles page, select sysadmin and click OK.
5. Create the new vRealize Automation database.

a. Click the Windows Start button and open Microsoft SQL Server
Management Studio.

b. Right-click the Databases folder and select New Database.
The New Database wizard opens.

c. On the General page, type VRaDB01 for Database name and rainpole
\svc-vra for Owner.

d. On the Options page, configure the following recovery model settings, and
then click OK.

¢ Recovery model—Simple
¢ Compatibility level—SQL Server 2014 (120)
¢ Other options > Miscellaneous > Allow Snapshot Isolation—True

¢ Other options > Miscellaneous > Is Read Committed Snapshot On—
True

6. Allow access to Microsoft SQL Server on TCP port 1433.
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a. Click the Windows Start button, type WF.msc, and press Enter.
The Windows Firewall with Advanced Security window appears.

b. In the Navigation pane, right-click Inbound Rules and select New Rule.
The New Inbound Rule wizard opens.

c. For Rule Type, select Port and click Next.

d. For Protocol and Ports, select TCP, type the port number 1433 in the
Specific local ports text box, and click Next.

e. For Action, select Allow the connection and click Next.
f. For Profile, select the Domain.Private and Public profiles, and click Next.
g. For Name, type Microsoft SQL Server Port (1433) and click Finish.
7. Allow access for Microsoft Distributed Transaction Coordinator:
a. Click the Windows Start button, type WF.msc and press Enter.
The Windows Firewall with Advanced Security window appears.
b. In the Navigation pane, select Inbound Rules > New Rule Inbound Rules.
The New Inbound Rule wizard opens.

c. For Rule Type, select Predefined > Distributed Transaction Coordinator,
and click Next.

d. For Predefined Rules, select all rules for Distributed Transaction
Coordinator (RPC-EPMAP), Distributed Transaction Coordinator
(RPC), and Distributed Transaction Coordinator (TCP-In), and then click
Next.

e. For Action, select Allow the connection and click Finish.

8. Unmount any ISO files that are mounted to the virtual machine.

Deploy and configure the Windows system for Site
Recovery Manager

Deploy and configure a Windows-based virtual machine to create the necessary
infrastructure to facilitate deployment of Site Recovery Manager with VMware Cloud
Builder. This virtual machine must meet specific configuration and software
requirements.

Note

This procedure is optional for Single Region deployments, but required for Dual Region
deployments.

Create a virtual machine on the sfo01m0l1vc0l.sfo0l.rainpole.local vCenter
server for Site Recovery Manager with the following virtual machine, software, and
network configuration.

Table 22 Virtual machine requirements for Site Recovery Manager VM

Setting Value

vCenter Server sfo01mO01vc01.sfoO1.rainpole.local
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Table 22 Virtual machine requirements for Site Recovery Manager VM (continued)

Setting Value

VM Name sfo01TmO1srmO1

Guest OS Windows Server 2016 (64-bit)

vCPU 2

Memory (GB) 2

Virtual Disk (GB) 40

SCSI Controller LSI Logic SAS

Datastore VxRail-Virtual-SAN-Datastore-<hexid>
Network Interface vCenter Server Network-<hexid>
Network Adapter Type 1x VMXNET3

Table 23 Network requirements for Site Recovery Manager VM

Setting Value

Host Name sfo01TmO1srmO1

Static IPv4 Address 172.16.11.124

Subnet Mask 255.255.255.0

Default Gateway 172.16.11.253

DNS Server 172.16.11.5

FQDN sfo01mO01srm01.sfo01.rainpole.local
Open Ports 9086, 5678

Table 24 Software requirements for the Site Recovery Manager VM

Setting Value

Operating System Windows Server 2016 (64-bit)
VMware Tools Latest version.

Active Directory Join the virtual machine to the

sfoO1.rainpole.local domain.

License Verify that you have obtained a VMware Site
Recovery Manager license that satisfies the
requirements of this design.

Internet Explorer Enhanced Security Turn off ESC
Configuration

Remote Desktop Protocol Enable RDP access.

Procedure

1. Deploy the Site Recovery Manager virtual machine with the specified
configuration.
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2. Login to the Site Recovery Manager virtual machine by using a Remote
Desktop Protocol (RDP) client:

a. Open an RDP connection to the sfo01m01srm01 virtual machine.

b. Log in using the Windows administrator user name and password.

3. Click Start, right-click Windows PowerShell, and select More > Run as
Administrator.

4. Add the svc-srm service account to the local Administrators group by running
the following command:

net localgroup administrators rainpolel\svc-srm /add

5. Configure NTP settings:

a. Enable Windows Time Service and start by running the following commands.

w32tm /config /manualpeerlist:“ntp.sfo0l.rainpole.local
ntp.lax0l.rainpole.local” /syncfromflags:manual /
reliable:YES /update

net stop w32time && net start w32time

b. Verify the time synchronization configuration by executing the following
command:

w32tm /query /status

Generate and replace certificates for the SDDC components

In an SDDC, the security of the environment depends on the validity and trust of the
management certificates. To ensure secure and operational connectivity between the
SDDC components, generate new signed certificates to prepare for replacing the
temporary self-signed certificates.

The high-level steps are as follows:
1. Create and add a Microsoft certificate authority template on page 37.

2. Generate signed certificates for the SDDC components on page 38.

Create and add a Microsoft certificate authority template

Set up a Microsoft Certificate Authority template on the Active Directory (AD)
servers for the region.

Before you begin

e This VMware Validated Design sets the Certificate Authority service on the Active
Directory (AD) dcOlrpl.rainpole.local (root CA) server. Verify that the
Certificate Authority Service role and the Certificate Authority Web Enrollment
role are installed and configured on the Active Directory Server.

e Use a hashing algorithm of SHA-256 or higher on the certificate authority.

e Verify that relevant firewall ports relating to the Microsoft Certificate Authority
and related services are open.

The template contains the certificate authority (CA) attributes for signing certificates
of VMware SDDC solutions. After you create the template, you add it to the
certificate templates of the Microsoft CA.
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Procedure

1.

10.
1.

12.

Log in to the Active Directory server using a Remote Desktop Protocol (RDP)
client using the Active Driectory administrator user name and password.

Select Start > Run, type certtmpl.msc, and click OK.

In the Certificate Template console, under Template Display Name, right-
click Web Server and click Duplicate Template.

In the Duplicate Template window, leave Windows Server 2003 Enterprise
selected for backward compatibility and click OK.

In the Properties of New Template dialog box, click the General tab.

In the Template display name text box, type vMware as the name of the new
template.

Click the Extensions tab and specify the extensions information:
a. Select Application Policies and click Edit.
b. Select Server Authentication > Remove > OK.

c. If the Client Authentication policy is present, select it, click Remove, and
click OK.

d. Select Key Usage > Edit.
e. Select Signature is proof of origin (nonrepudiation).
f. Leave the default for all other options.

g. Click OK.

Click the Subject Name tab, ensure that Supply in the request is selected,
and click OK to save the template.

To add the new template to your CA, click Start > Run, enter certsrv.msc,
and click OK.

In the Certification Authority window, expand the left pane if it is collapsed.

Right-click Certificate Templates and select New > Certificate Template to
Issue.

In the Enable Certificate Templates dialog box, in the Name column, select
VMware certificate, and click OK.

Generate signed certificates for the SDDC components
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Use the Certificate Generation Utility for VMware Validated Design (CertGenVvvD)
and VMware Cloud Builder to generate new signed certificates and replace the
default, self-signed certificates for the SDDC components.

Before you begin

Ensure the Windows host system where you connect to the data center and
generate the certificates is joined to the domain of the Microsoft Certificate
Authority.

Install Java Runtime Environment version 1.8 or later.

Configure the JAVA_HOME environment variable to the Java installation
directory.

Update the PATH system variable to include the bin folder of Java installation
directory.
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¢ Install OpenSSL toolkit version 1.0.2 for Windows.

e Update the PATH system variable to include the bin folder of the OpenSSL
installation directory.

¢ Download the CertGenVvD-version. zip file of the Certificate Generation
Utility from VMware Knowledge Base article 2146215 and extract the ZIP file to
the C: drive.

Procedure

1. Log in to the Windows host that has access to your data center.

2. Set the execution policy to Unrestricted:

a.

b.

Click Start, right-click Windows PowerShell, and select More > Run as
Administrator.

Set the execution policy by running the following command:

Set-ExecutionPolicy Unrestricted

3. Use the CertConfig utility to generate the certificate configuration files:

a.

Open the completed Deployment Parameters XLS file and select the
CertConfig worksheet.

. From the File menu, select Save As, set the file format to Comma delimited

(*.csv), rename the file to SDDC-CertConfig.csv, and click Save.

. Transfer the SDDC-CertConfig.csv file to the Windows host.

. Rename the current ConfigFiles folder located in C:

\CertGenVVD-3.0.4toConfigFiles.Old.

. Create anew ConfigFiles folder inthe C:\CertGenvvD-3.0.4

directory.

. Click Start, right click Windows PowerShell, and select More > Run as

Administrator.

. Navigate to the C: \CertGenvvD-3.0. 4 folder and run the following

command: .\Certconfig-1.1.0.psl SDDC-Certconfig.csv.

. Follow the on-screen instructions and set the following values:

¢ Default Organization—Rainpole Inc
¢ Default OU—RAainpole

e Default Location—SFO

e Default State—CA

e Default Country—US

e Default Key Size—2048

. Verify that the C: \CertGenvvD-3.0.4\ConfigFiles folder is populated

with the necessary certificate configuration files.

4. Validate the local machine configuration:

a.

b.

Click Start, right-click Windows PowerShell, and select More > Run as
Administrator.

Navigate to the C: \CertGenvvD-3.0. 4 folder and validate the
configuration by running the following command:

.\CertGenvvD-3.0.4.psl -validate

Generate signed certificates for the SDDC components 39


https://kb.vmware.com/kb/2146215

Preparing the Environment for Automated Deployment

5. Use the CertGenvvVD utility to generate the signed certificate files:

a. Click Start, right-click Windows PowerShell, and select More > Run as
Administrator.

b. Navigate to the C: \CertGenvvD-3.0. 4 folder and generate the signed
certificates by running the following command:

.\CertGenvvD-3.0.4.psl -MSCASigned -attrib
'CertificateTemplate:VMware'

c. Follow the on-screen instruction and type a passphrase for PEM/P12 file
encryption.
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CHAPTER 6

Deploying the SDDC Components

This chapter presents the following topics:

Automated SDDC deployment prerequisites

Deploying the SDDC Components

Audit deployment parameters and target environment
Start automated deployment for the Management cluster
Start automated deployment for the Shared Edge and Compute cluster
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Deploying the SDDC Components

Automated SDDC deployment prerequisites
Before you start the automated SDDC deployment, verify that your environment
fulfills the requirements for this deployment.

Verify that your environment satisfies the following prerequisites for the automated
SDDC deployment.

Environment
Verify that:

e Your environment is configured for deployment of the SDDC as documented in
Deploying VxRail on page 17.

e Active Directory is configured with all child domains and all service accounts and
groups are created and configured.

¢ DNS entries are configured for the root and child domains.

e Two servers external to the SDDC NTP are configured and time synchronization is
configured on all ESXi hosts and AD domain controllers.

e Your environment meets all physical network requirements and that all host names
and |IP addresses are allocated for external services and virtual infrastructure
components.

e Secondary storage for certain SDDC features is mounted.

For additional information, see the VMware Validated Design on Dell EMC VxRail
Appliances Planning Guide.

Software
Ensure that the following tasks have been completed.

¢ Fill in the Deployment Parameters XLS file for Region A.

e Verify that you have generated CA-signed certificates for the management
components of the SDDC. See Generate and replace certificates for the SDDC
components on page 37.

Installation packages
Download the . iso file for the software bundle for VMware Validated Design to your
local file system.

Audit deployment parameters and target environment

Perform an audit of both JSON deployment files and specific target environment
prerequisites to ensure that you can successfully deploy the components of the
management and the shared edge and compute clusters using VMware Cloud Builder.

Before you begin
Enable SSH on all VxRail nodes before performing the audit.

Validate the JSON deployment files for both the management and the shared edge
and compute clusters. In case any of the tests fail, you must fix any errors and
perform the validation process again. Additional information can be found in the Cloud
Builder Platform Audit log file, /opt/vmware/sddc-support/

cloud admin tools/logs/PlatformAudit.log.
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Procedure
1. Log in to VMware Cloud Builder:

a. Open a Web browser and go to https://
sfo0lcb0l.sfo0l.rainpole.local.

b. Log in using the user name admin and the Cloud Builder administrator
password.

In the Cloud Builder Navigator, click the Deployment Wizard icon.
Select the Validate Environment tab.

From the Select File to Validate drop-down menu, select the vvd-vxrail-
rega-mgmt . json file and click Validate.

5. (Optional) If the Validation fails due to user input errors, perform the validation
process again with .XLS file modification:

a. Fix input errors in the . XLs file.

b. In the Upload Config File tab, from the Select Architecture Type drop-
down menu, select the VVD for SDDC Region A architecture and click
Upload Config File.

c. Navigate to the Updated Deployment Parameters XLS file and click Open.
d. On Overwrite Existing JSON File(s), select Yes to replace.

e. Click the Back button and repeat step 4.

6. Repeat step 5, if necessary, until all validation tasks have completed
successfully.

The vvd-vxrail-rega-mgmt. json file is successfully validated against the
predefined run parameters.

After you finish

After successful validation of vvd-vxrail-rega-mgmt. json and vvd-vxrail-
rega-comp. json files, click Next to start the deployment process. The clusters are
deployed in dependent order.

Note

You must deploy the management cluster first. Deploy the workload domain only after
successful completion of the management cluster.

Start automated deployment for the Management cluster

After you successfully validate the vvd-std-rega-mgmt . json JSON file, start the
automated deployment of the components in the management cluster.

Procedure
1. Log in to VMware Cloud Builder:

a. Open a Web browser and go to https://
sfo0lcb0l.sfo0l.rainpole.local.

b. Log in using the user name admin and the Cloud Builder administrator
password.

2. In the Cloud Builder Navigator, select the Deployment Wizard icon.
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3. Select the Deploy an SDDC tab.

4. From the Select Deployment File drop-down menu, select the vvd-vxrail-
rega-mgmt . json JSON file and click Deploy.

Automated deployment of the components in the management cluster begins.
5. Monitor the deployment and check the following log files for errors:

/opt/vmware/bringup/logs/vcf-bringup.log

/opt/vmware/bringup/logs/vcf-bringup-debug.log

Start automated deployment for the Shared Edge and
Compute cluster

After you have deployed the management cluster, you start the automated
deployment of the components in the shared edge and compute cluster.

Procedure
1. Log in to VMware Cloud Builder:

a. Open a Web browser and go to https://
sfo0lcb0l.sfo0l.rainpole.local.

b. Log in using the user name admin and the Cloud Builder administrator
password.

In the Cloud Builder Navigator, select the Deployment Wizard icon.
Select the Deploy an SDDC tab.

From the Select Deployment File drop-down menu, select the vvd-vxrail-
rega-mgmt . json JSON file and click Deploy.

Automated deployment of the components in the shared edge and compute
cluster begins.

5. Monitor the deployment and check the following log files for errors:

/opt/vmware/bringup/logs/vcf-bringup.log

/opt/vmware/bringup/logs/vcf-bringup-debug.log
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CHAPTER /7

Post-deployment: Configuring the Virtual
Infrastructure

This chapter presents the following topics:

e Configure a distributed firewall for management applications...........cccceeunnnnnen.
e Update DNS records for the PSC load balancer...........ccccoeeeiiiiiiieiiicvenicinceeeis

Post-deployment: Configuring the Virtual Infrastructure
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Configure a distributed firewall for management
applications

Configure a distributed firewall to increase the security level of your environment by
allowing only the network traffic that the SDDC requires. The explicit firewall rules you
define allow access to management applications.

Procedure

1. Add vCenter Server instances to the NSX distributed firewall exclusion list on
page 46.

To ensure that network access between vCenter Server and NSX is not
blocked, exclude vCenter Server from all the distributed firewall rules.

2. Create IP sets for management cluster components on page 47.

Create IP sets for all management applications . Use the IP sets later to create
security groups for use with the distributed firewall rules.

3. Create security groups on page 48.

Create security groups for use in configuring firewall rules for the groups of
applications in the SDDC.

4. Create distributed firewall rules on page 50.

Create firewall rules to allow administrators to connect to the various VMware
solutions, to allow for user access to the vRealize Automation portal, and to
provide the external connectivity to the SDDC.

Add vCenter Server instances to the NSX distributed firewall exclusion list

46

To ensure that network access between vCenter Server and NSX is not blocked,
exclude vCenter Server from all the distributed firewall rules.

You configure the NSX distributed firewall by using a vCenter Server. If a rule
prevents access between NSX Manager and vCenter Server, you are not able to
manage the distributed firewall. You must exclude vCenter Server from all the
distributed firewall rules and ensure that access between the two products is not
blocked.

Procedure
1. Use the vSphere Client to log in to the vCenter Server:

a. Open a Web browser and go to https://
sfo0lm0lvc0l.sfol0l.rainpole.local/ui.

b. Log in using the user name administrator@vsphere.local and the
vSphere administrator password.

2. Exclude vCenter Server instances from the distributed firewall rules:
a. From the Home menu, select Networking & Security.
b. In the Navigator pane, select Firewall Settings > Exclusion List.
c. Select 172.16.11.65 from the NSX Manager drop-down menu.
d. Click Add.
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e. In the Select VM(s) to exclude dialog box, select sfo01mO01vc01, add it to
the Selected Objects list, and click OK.

Create IP sets for management cluster components
Create IP sets for all management applications.

You use IP sets later to create security groups for use with the distributed firewall
rules.

You perform this procedure multiple times to configure all the necessary IP sets. For
applications that are load balanced, include their VIP in the IP set.

The following table lists the IP sets required for the management components.

Table 25 Required IP sets for management components

Name

IP addresses

Platform Services Controller Instances

Platform-Service-Controller_IPs

vCenter Server Instances

vCenter-Server_|Ps

vRealize Automation Appliances

vRealize-Automation-Appliances_IPs

vRealize Automation Windows

vRealize-Automation-Windows _IPs

vRealize Automation Proxy Agents

vRealize-Automation-Proxy-Agents-IPs

vRealize Business Server

vRealize-Business_IPs

vRealize Business Data Collector

vRealize-Business-Data-Collector_IPs

VMware VADP Solution

vStorage-API for Data-Protection-
Solution_IPs

vRealize Operations Manager

vRealize-Operations-Manager_IPs

vRealize Operations Manager Remote
Collectors

vRealize-Operations-Manager-Remote-
Collectors_IPs

vRealize Log Insight

vRealize-Log-Insight_IPs

vRealize Suite Lifecycle Manager

vRealize-Suite-Lifecycle-Manager_IPs

Site Recovery Manager

Site-Recovery-Manger_IPs

vSphere Replication

vSphere-Replication_IPs

SDDC

Management-VLAN_Subnets, Management-
VXLAN_Subnets

Administrators

Administrators_Subnet

Procedure

1. Use the vSphere Client to log in to the vCenter Server:

a. Open a Web browser and go to https://
sfo0lm0lvc0l.sfo0l.rainpole.local/ui.

b. Log in using the user name administrator@vsphere.local and the

vSphere administrator password.

2. Create an IP set:
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. From the Home menu, select Networking & Security.

a
b. In the Navigator pane, select Groups and Tags > IP Sets .

(2]

. Select 172.16.11.65 from the NSX Manager drop-down menu.
. Click Add.

o

e. In the New IP Set dialog box, configure the values for the IP set that you are
adding, and then click Add.

e Name—vCenter Server Instances
¢ |P Addresses— 172.16.11.62, 172.16.11.64

¢ Universal Synchronization—On

3. Repeat Step 2 to create IP sets for all remaining components.

Create security groups

Create security groups for use in configuring firewall rules for the groups of
applications in the SDDC.

A security group is a collection of assets (or objects) from your vSphere inventory
that you group. You perform this procedure multiple times to configure all the
necessary security groups. In addition, you create the VMware Appliances and
Windows Servers groups from the security groups you add in the previous repetitions
of this procedure.

Table 26 Security groups for the management cluster components in the SDDC

Name Object Type Selected Object

Platform Services Controller Instances IP Sets Platform Services Controller Instances
vCenter Server Instances IP Sets vCenter Server Instances

vRealize Automation Appliances IP Sets vRealize Automation Appliances
vRealize Automation Windows IP Sets vRealize Automation Windows
vRealize Business Server IP Sets vRealize Business Server

vRealize Automation Proxy Agents IP Sets vRealize Automation Proxy Agents
vRealize Business Data Collector IP Sets vRealize Business Data Collector
VMware Storage API for VADP Solution |IP Sets VMware VADP

vRealize Operations Manager IP Sets vRealize Operations Manager

vRealize Operations Manager Remote IP Sets vRealize Operations Manager Remote Collectors
Collectors

vRealize Suite Lifecycle Manager IP Sets vRealize Suite Lifecycle Manager

Site Recovery Manager IP Sets Site Recovery Manager

vSphere Replication IP Sets vSphere Replication

vRealize Log Insight IP Sets vRealize Log Insight

SDDC IP Sets SDDC

Administrators IP Sets Administrators
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Table 26 Security groups for the management cluster components in the SDDC (continued)

Name

Object Type Selected Object

Windows Servers

Security Groups

Site Recovery Manger
vRealize Automation Windows

vRealize Automation Proxy Agents

VMware Appliances

Security Groups

Platform Services Controller Instances

vCenter Server Instances

vSphere Replication

vRealize Automation Appliances

vRealize Business Server

vRealize Business Data Collector

VMware vStorage API for Data Protection Solution
vRealize Operations Manager

vRealize Operations Manager Remote Collectors
vRealize Suite Lifecycle Manager

vRealize Log Insight

Procedure

1. Use the vSphere Client to log in to the vCenter Server:

a. Open a Web browser and go to https://
sfo0lm0lvcO0l.sfo0l.rainpole.local/ui.

b. Log in using the user name administrator@vsphere.local and the

vSphere administrator password.

2. From the Home menu, select Networking & Security > Groups and Tags >

Security Groups.

Select 172.16.11.65 from the NSX Manager drop-down menu.

Click Add.

The Create Security Group wizard appears.

5. On the Name and Description page, enter the following settings, and then click

Next.

¢ Name—Platform Services Controller Instances

¢ Universal Synchronization—On

6. On the Select Objects to Include page, select IP Sets from the Object Type
drop-down menu, from Available Objects, add Platform Services Controller
Instances to Selected objects, and click Next.

7. On the Ready to Complete page, verify the configuration values that you
entered and click Finish.

8. Repeat this procedure to create all the necessary security groups.

Create security groups
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Create distributed firewall rules

50

Create firewall rules to allow administrators to connect to the various VMware
solutions, to allow for user access to the vRealize Automation portal, and to provide
the external connectivity to the SDDC.

Procedure
1. Use the vSphere Client to log in to the vCenter Server:

a. Open a Web browser and go to https://
sfo0lm0lvc0l.sfo0l.rainpole.local/ui.

b. Log in using the user name administrator@vsphere.local and the
vSphere administrator password.

2. Add a section of rules for the management applications:
a. From the Home menu, select Networking & Security > Firewall.
b. From the NSX Manager drop-down menu, select 172.16.11.65.
c. Click Add Section.

3. Inthe Add New Section dialog box, enter the following information, and then
click Add:

¢ Section Name—VMware Management Services
¢ Universal Synchronization—On
4. Create a distributed firewall rule to allow an SSH access to administrators for
the different VMware appliances:
a. Click Add rule.
b. In the Name column of the new rule, type Allow SSH to admins.

c. In the Source column, select Edit, select Security Group from the Object
Type drop-down menu, add Administrators to the Selected Objects list,
and click Save.

d. In the Destination column, click Edit, select Security Group from the
Object Type list, add VMware Appliances to the Selected Objects list, and
click Save.

e. In the Service column, click Edit, add SSH to the Selected Objects list, and
click Save.

f. Click Publish.

5. Repeat the previous step to create the following distributed firewall rules:

Name Source Destination Service /
Port

Allow VRA Portal to * any e vRealize Automation HTTP, HTTPS

end users. Appliances

e vRealize Automation Windows

e vRealize Business Server
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Name Source Destination Service /
Port

Allow vRA Console * any vRealize Automation Appliances TCP:8444

Proxy to end users

Allow SDDC to any. SDDC * any * any

Allow PSC to admins. | Administrators | Platform Services Controller HTTPS

Instances
Allow RDP to admins. | Administrators | Windows Servers RDP

Allow Orchestrator to
admins.

Administrators

vRealize Automation Appliances

TCP:8281, 8283

Allow vRB Data Administrators | vRealize Business Data Collector HTTP, HTTPS
Collector to admins.
Allow vVROPs to Administrators |4 yRealize Operations Manager HTTP, HTTPS
admins.

e vRealize Operations Manager

Remote Collectors

Allow vRLI to admins. | Administrators | vRealize Log Insight HTTP, HTTPS
Allow VRSLCM to Administrators | vRealize Suite Lifecycle Manager |HTTPS
admins.
Allow VAMI to Administrators | VMware Appliances TCP:5480
admins.
Allow VMware VADP | Administrators | VMware Appliances TCP:8543

Solution to admins.

6. Change the default rule action from Allow to Block:

a. From the NSX Manager drop-down menu, select 172.16.11.65.

b. Under Default Section Layer3, in the Action column for the Default Rule,
change the action to Block, and then click Save.

c. Click Publish.

Network security improves by allowing only network traffic required by the

SDDC to pass.

Update DNS records for the PSC load balancer

Modify the DNS address of the Platform Services Controller load balancer.

Edit the sfo0lpsc0l.sfo0l.rainpole.local DNS entry to point to the virtual IP
address (VIP) of the 172.16.11.71 load balancer, instead of pointing to the
sfo01lm0lpscO1 IP address.

Procedure

1.
2,

Log in to the DNS server that resides in the sfo0l.rainpole.local domain.

From the Windows Start menu Search text box, type dnsmgmt .msc and press

Enter.

In the DNS Manager dialog box, under Forward Lookup Zones, select the
sfo01.rainpole.local domain and, on the right, locate the sfoO1psc01 record.

Update DNS records for the PSC load balancer
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4. Double-click sfo01psc01, enter the following settings, and then click OK.
¢ Fully Qualified domain name (FQDN)—sfo01psc01.sfoO1.rainpole.local
e |P Address—172.16.11.71
¢ Update Associated Pointer (PTR) record—Not selected
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CHAPTER 8

Post-deployment: Configuring vRealize
Operations Manager

This chapter presents the following topics:

e Enable automatic synchronization of authentication sources........c..ccccccveennnnne.e. 54
¢ Remove existing service accounts in vRealize Operations Manager................... 54
e Configure user privileges on vRealize Operations Manager-..........cccccveuuuucceeennnn. 55
¢ Integrate vRealize Log Insight with vRealize Operations Manager..................... 55
e Configure user privileges for integration with vRealize Automation................... 56
e Verify integration of vRealize Operations Manager as a metrics provider........... 57
e Define default policy monitoring goals.........ccccooviiiiiieiiciciierrr e 57
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Enable automatic synchronization of authentication sources

Enable the automatic synchronization of authentication sources in vRealize Operations
Manager and define monitoring goals for the default policy.

vRealize Operations Manager maps imports LDAP users to user groups after you
enable Automatically synchronize user membership for configured groups for the
rainpole.local and sfo0l.rainpole.local Active Directory instances.

Procedure
1. Log in to vRealize Operations Manager.

a. Open a Web browser and go to https://
vropsOlsvrOl.rainpole.local.

b. Log in using the user name admin and the deployment administrator
password.

2. On the main navigation bar, click Administration.

3. Configure the authentication sources to enable an automatic synchronization
for the rainpole.local Active Driectory instance:

a. In the left pane, click Access > Authentication Sources.
b. On the Authentication Sources page, select rainpole.local and click Edit.

c. In the Edit Source for User and Group Import dialog box, expand Details
and select Automatically synchronize user membership for configured
groups.

d. Click OK.

4. Repeat the previous step for the sfo01.rainpole.local Active directory.

Remove existing service accounts in vRealize Operations
Manager

After enabling automatic synchronization of authentication sources, remove the svc-
vrli-vrops and svc-vra-vrops service accounts and later add them, because
vRealize Operations Manager does not provide an API to perform synchronization in
an automated way.

Procedure
1. Log in to vRealize Operations Manager.

a. Open a Web browser and go to https://
vropsOlsvrOl.rainpole.local.

b. Log in using the user name admin and the deployment administrator
password.

On the main navigation bar, click Administration.
on the left side, click Access > Access Control.

Remove the existing svc-vrli-vrops and svc-vra-vrops service
accounts:

a. On the Access Control page, select svc-vrli-vrops and click Delete.
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b. In the Delete User dialog box, click Yes.

c. Repeat steps a and b for the svc-vra-vrops service account to remove it.

Configure user privileges on vRealize Operations Manager

Assign an administrator role to the svc-reli-vrops service account for the launch
in context integration of vRealize Operations Manager with vRealize Log Insight..

Procedure
1. Log in to vRealize Operations Manager.

a. Open a Web browser and go to https://
vropsOlsvrOl.rainpole.local.

b. Log in using the user name admin and the deployment administrator
password.

On the main navigation bar, click Administration.
In the left pane, click Access > Access Control.

On the Access Control page, click the User Accounts tab and click the Import
Users icon.

5. On the Import Users page, import the svc-vrli-vrops service account:
a. From the Import From drop-down menu, select rainpole.local.
b. Select the Basic option for the search query.
c. In the Search String text box, type sve-vrli-vrops and click Search.

d. Select svc-vrli-vrops@rainpole.local and click Next.

6. On the Assign Groups and Permissions page, click the Objects tab, configure
the following settings, and then click Finish.

e Select Role—Administrator
¢ Assign this role to the user—Selected
¢ Allow access to all objects in the system—Selected

7. When prompted with the warning about allowing access to all objects on the
system, click Yes.

Integrate vRealize Log Insight with vRealize Operations
Manager

Connect vRealize Log Insight in Region A with vRealize Operations Manager to launch
vRealize Log Insight from within vRealize Operations Manager.

Use the launch in context functionality between the two management applications to
troubleshoot management nodes and vRealize Operations Manager by using
dashboards and alerts in the vRealize Log Insight user interface.

Procedure
1. Log in to the vRealize Log Insight user interface

a. Open a Web browser and go to https://
sfol0lvrliOl.sfo0Ol.rainpole.local.
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b. Log in with the user name admin and the deployment administrator
password.

In the vRealize Log Insight user interface, click the configuration drop-down
menu icon and select Administration.

Under Integration, click vRealize Operations.
On the vRealize Operations Manager page, select Enable launch in context.
Click Test Connection to validate the connection and click Save.

Click OK to close the progress dialog box.

Configure user privileges for integration with vRealize

Automation

Configure read-only privileges for the svc-vra-vrops service account on vRealize
Operations Manager for integration with vRealize Automation.

vRealize Automation can collect metrics from vRealize Operations Manager for
reclamation of tenant workloads that have a low use of CPU, memory, or disk space.

Procedure
1.

Log in to vRealize Operations Manager.

a. Open a Web browser and go to https://
vropsOlsvrOl.rainpole.local.

b. Log in using the user name admin and the deployment administrator
password.

On the main navigator bar, click Administration.

On the Access Control page, click the User Accounts tab and click the Import
Users icon.

On the Import Users page, import the svc-vra-vrops service account:
a. From the Import From drop-fown menu, select rainpole.local.

b. Select the Basic option for the search query.

c. In the Search String text box, type sve-vra-vrops and click Search.

d. Select svc-vra-vrops@rainpole.local and click Next.

On the Assign Groups and Permissions page, click the Objects tab, configure
the following settings, and then click Finish.

e Select Role—ReadOnly
e Assign this role to the user—Selected

¢ Select Object—vCenter Adapter > vCenter Adapter - sfo01w01vc01
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Verify integration of vRealize Operations Manager as a
metrics provider

In vRealize Automation, verify that vRealize Operations Manager is successfully
integrated as a metrics provider, so that vRealize Automation can pull metrics for the
reclamation of tenant workloads.

Procedure
1. Log in to the vRealize Automation Rainpole portal.

a. Open a Web browser and go to https://
vraOlsvr0Ol.rainpole.local/vcac/org/rainpole.

b. Log in with the user name vra-admin-rainpole and the vRealize
Automation rainpole administrator password. Domain is rainpole.local.

2. Select Administration > Reclamation > Metrics Provider.

3. Click Test Connection to verify that the connection is successful.

Define default policy monitoring goals
In vRealize Operations Manager, enable the Define monitoring goals option for the
default policy for each vCenter Adapter instance.

Procedure
1. Log in to vRealize Operations Manager.

a. Open a Web browser and go to https://
vropsOlsvrOl.rainpole.local.

b. Log in using the user name admin and the deployment administrator
password.

On the main navigation bar, click Administration.
In the left pane of vRealize Operations Manager, click Solutions.

In the solution table, select the VMware vSphere solution and click the
Configure icon.

The Manage Solution - VMware vSphere dialog box appears.
Under Instance Settings, select the sfo01mO01vc01 vCenter adapter.
Click Define Monitoring Goals.

Under Enable vSphere Hardening Guide Alerts, click Yes, leave the default
configuration of the other options, and click Save.

In the Success dialog box, click OK.
Click Save Settings.
10. In the Info dialog box, click OK.
11. Repeat steps 5 to 10 for the Compute vCenter Server adapter.
12. In the Manage Solution - VMware vSphere dialog box, click Close.

Verify integration of vRealize Operations Manager as a metrics provider 57



Post-deployment: Configuring vRealize Operations Manager

58 VMware Validated Design v5.0 on Dell EMC VxRail for a Single Region



CHAPTER 9

Post-deployment: Configuring the Cloud
Management Platform

This chapter presents the following topics:
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Configure vRealize Automation for a large-scale deployment

Increase the values of the ProxyAgentServiceBinding attributes to configure the
vRealize Automation Manager Service to contain many data objects.

Procedure

Log in to the virtual machine of the vRealize Automation laaS Manager Service
by using a Remote Desktop Protocol (RDP) client:

a. Open an RDP connection to the vra0limsOla.rainpole.local virtual
machine.

b. Log in with the user name rainpole\svec-vra and the svc-vra password.

Openthe C:\Program Files (x86)\VMware\vCAC\Server
\ManagerService.exe.config file in a text editor with administrative
rights.

Locate the following line in the ManagerService.exe.config file:

<binding name="ProxyAgentServiceBinding”
maxReceivedMessageSize="13107200">
<readerQuotas maxStringContentLength=713107200" />

Edit the values of the following parameters, increasing them by a factor of 10 as
shown:

¢ maxReceivedMessageSize—131072000
¢ maxStringContentLength—131072000

Save your changes to the ManagerService.exe.config file and close th
text editor.

Open the Windows Start menu and select Restart to restart the virtual
machine.

Repeat this procedure for the vra0lims0Olb.rainpole.local virtual
machine.

Configure the content library

60

Create a content library and populate it with templates that you can use to deploy
virtual machines in your environment. Content libraries let you synchronize templates
among different vCenter Server instances so that all the templates in your
environment are consistent.

There is only one Compute vCenter Server in this VMware Validated Design, but if you
deploy more instances for use by the compute cluster, they can also use this content
library.

Procedure

Use the vSphere Client to log in to the Compute vCenter Server:

a. Open a Web browser and goto https://
sfo0lw0lvcO0l.sfo0Ol.rainpole.local/ui.
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b. Log in using the user name administrator@vsphere.local and the
vSphere administrator password.

2. From the Home menu, select Content Libraries and click the + icon.
The New Content Library wizard opens.

3. On the Name and location page, enter the following settings and click Next.
¢ Name— sfo01-w0O1cl-vraO

¢ vCenter Server—sfo01w01vc01.sfoO1.rainpole.local

4. On the Configure content library page, enter the following settings and click
Next.

¢ Local content library—Selected

e Publish externally—Selected

¢ Enable authentication—Selected

e Password— sfo07-w0OTcl-vraO1_password

e Confirm password—sfo07-w0O7c/-vra0O1_password

5. On the Add storage page, select the sfo01-w01-1ib01 datastore to store
the content library and click Next.

6. Inthe Ready to Complete page, click Finish.

Import OVF files for virtual machine templates

You can import OVF packages that you previously prepared to use as templates for
deploying virtual machines. The virtual machine templates that you add to the content
library are used as vRealize Automation blueprints.

Before you begin

Verify that you have prepared the OVF templates, as specified in the "Virtual Machine
Template Specifications" section of the VMware Validated Design on VxRail Appliance
Planning Guide.

Repeat this procedure three times to import the virtual machine templates listed in the
following table.

Table 27 Virtual machine templates

VM template name Operating system type

redhat6-enterprise-64 Red Hat Enterprise Server 6 (64-bit)

windows-2012r2-64 Windows Server 2012 R2 (64-bit)

windows-2012r2-64-sql2012 Windows Server 2012 R2 (64-bit) with SQL
2012

Procedure

1. Use the vSphere Client to log in to the Compute vCenter Server:

a. Open a Web browser and go to https://
sfo0lw0lvcO0l.sfo0Ol.rainpole.local/ui.

b. Log in using the user name administrator@vsphere.local and the
vSphere administrator password.
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From the Home menu, select Content Libraries.
Right-click the content library sfo01-w01cl-vra01 and select Import Item.

In the Import Library Item dialog box, specify the settings for the first
template and click Import.

e Source file— URL or local path to redhat6-enterprise-64.ovf
and . vmdk file

¢ Item name—redhat6-enterprise-64

¢ Notes—Red Hat Enterprise Server 6 (64-bit)

5. Repeat the procedure to import the remaining virtual machine templates.

Create machine prefixes

62

As a fabric administrator, you create machine prefixes that are used to create names
for machines provisioned through vRealize Automation.

Tenant administrators and business group managers select these machine prefixes and
assign them to provisioned machines through blueprints and business group defaults.

Machine prefixes are shared across all tenants. Every business group has a default
machine prefix. Every blueprint must have a machine prefix or use the group default
prefix. Fabric administrators are responsible for managing machine prefixes. A prefix
consists of a base name to be followed by a counter of a specified number of digits.
When the digits are all used, vRealize Automation rolls back to the first number.

Procedure
1. Log in to the vRealize Automation Rainpole portal.

a. Open a Web browser and go to https://
vraOlsvr0Ol.rainpole.local/vcac/org/rainpole.

b. Log in with the user name vra-admin-rainpole and the vRealize
Automation rainpole administrator password. Domain is rainpole.local.

Click Infrastructure > Administration > Machine Prefixes.

Click New and specify the following settings to create a default machine prefix
for the Production group, and then click Save.

e Name—Prod-
¢ Number of Digits—5
¢ Next Number—1
4. Click New and specify the following settings to create a default machine prefix
for the Development group, and then click Save.
e Name—Dev-
¢ Number of Digits—5

e Next Number—1
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Create business groups

Tenant administrators create business groups to associate a set of services and
resources to a set of users that often correspond to a line of business, department, or
other organizational unit.

Users must belong to a business group to request machines.

For this implementation, create two business groups:

Production

Development

Procedure

1.

10.

Log in to the vRealize Automation Rainpole portal.

a. Open a Web browser and go to https://
vraOlsvr0Ol.rainpole.local/vcac/org/rainpole.

b. Log in with the user name vra-admin-rainpole and the vRealize
Automation rainpole administrator password. Domain is rainpole.local.

Select Administration > Users and Groups > Business Groups.
Click New.

On the General tab, enter the following values and click Next.

¢ Name—Production

¢ Send capacity alert emails to— vra-admin-
rainpole@rainpole.local

On the Members tab, type ug-vra-admins-rainpole@rainpole.local in the
Group manager role text box, press Enter, select the displayed group, and click
Next.

On the Infrastructure tab, select Prod- from the Default machine prefix
drop-down menu and click Finish.

Click New.
On the General tab, configure the following values, and click Next.
¢ Name—Development

¢ Send capacity alert emails to—vra-admin-
rainpole@rainpole.local

On the Members tab, type ug-vra-admins-rainpole@rainpole.local in the
Group manager role text box, and click Next.

On the Infrastructure tab, select Dev- from the Default machine prefix drop-
down menu and click Finish.
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Create reservation policies

A reservation policy is often used to collect resources into groups for different service
levels, or to make a specific type of resource easily available for a particular purpose.
Reservation policies group similar reservations together.

Create the reservation policy tag first, then add the policy to reservations to allow a
tenant administrator or business group manager to use the reservation policy in a
blueprint.

When you request a machine, it can be provisioned on any reservation of the
appropriate type that has sufficient capacity for the machine. You can apply a
reservation policy to a blueprint to restrict the machines provisioned from that
blueprint to a subset of available reservations. A reservation policy can include
reservations of different types, but only reservations that match the blueprint type are
considered when selecting a reservation for a particular request.

Procedure
1. Log in to the vRealize Automation Rainpole portal.

a. Open a Web browser and go to https://
vraOlsvr0Ol.rainpole.local/vcac/org/rainpole.

b. Log in with the user name vra-admin-rainpole and the vRealize
Automation rainpole administrator password. Domain is rainpole.local.

Select Infrastructure > Reservations > Reservation Policies.
Click New, configure the following settings, and click OK.

¢ Name—SFO-Production-Policy

e Type—Reservation Policy

e Description—Reservation policy for Production Business Group

4. Click New, configure the following settings, and click OK.
¢ Name—SFO-Development-Policy
e Type—Reservation Policy

¢ Description—Reservation policy for Development Business Group

5. Click New, configure the following settings, and click OK.
¢ Name—SFO-Edge-Policy
e Type—Reservation Policy

¢ Description—Reservation policy for Tenant Edge resources

Create external network profiles

64

Before members of a business group can request virtual machines, fabric
administrators must create network profiles to define the subnet and routing
configuration for those virtual machines

Each network profile is configured for a specific network port group or virtual network
to specify the IP address and the routing configuration for virtual machines
provisioned to that network.
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You repeat this procedure six times to create the following six external network

profiles

e Ext-Net-Profile-Production-App
e Ext-Net-Profile-Production-DB
e Ext-Net-Profile-Production-Web

e Ext-Net-Profile-Development-App

e Ext-Net-Profile-Development-DB

e Ext-Net-Profile-Development-Web

Procedure

1. Log in to the vRealize Automation Rainpole portal.

a. Open a Web browser and go to https://
vraOlsvr0Ol.rainpole.local/vcac/org/rainpole.

b. Log in with the user name vra-admin-rainpole and the vRealize
Automation rainpole administrator password. Domain is rainpole.local.

2. Select Infrastructure > Reservations > Network Profiles > New > External.

3. On the New Network Profile - External page, specify the network profiles on
the General tab.

a. Add the values in the following table for the Production Group External
Network Profile:

Table 28 Production Group external network profile values

Setting Production Web value Production DB value Production App value
Name Ext-Net-Profile-Production-Web | Ext-Net-Profile-Production-DB Ext-Net-Profile-Production-App
Description External Network profile for Web | External Network profile for DB External Network profile for App

tier of Production Business Group

tier of Production Business Group

tier of Production Business Group

Subnet mask

255.255.255.0

255.255.255.0

255.255.255.0

Gateway 172.11.10.1 172.11.111 172.11.121
b. Add the values for the Development Group External Network Profile:
Table 29 Development Group external network profile values
Setting Development Web value Development DB value Development App value
Name Ext-Net-Profile-Development- Ext-Net-Profile-Development-DB | Ext-Net-Profile-Development-
Web App
Description External Network profile for Web | External Network profile for DB External Network profile for App

tier of Development Business
Group

tier of Development Business
Group

tier of Development Business
Group

Subnet mask

255.255.255.0

255.255.255.0

255.255.255.0

Gateway

172.12.101

172.12.111

172.12.12.1

4. On the DNS tab, enter the following values for the profile you are creating:
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¢ Primary DNS—172.16.11.4
e Secondary DNS—172.17.11.4
e DNS suffix—sfoO1.rainpole.local

¢ DNS search suffixes—sfoO1.rainpole.local

5. On the Network Ranges tab, click New and enter the following values for the
profile you are creating:

a. Configure the Production Business Network Range with the following

values:

Table 30 Production Business Network Range values

Setting Production Web value Production DB value Production App value
Name Production-Web Production-DB Production-App
Description Static IP range for Web tier of Static IP range for DB tier of the Static IP range for App tier of the
the Production Group Production Group Production Group
Start IP 172.11.10.20 172.11.11.20 172.11.12.20
End IP 172.11.10.250 172.11.11.250 172.11.12.250
b. Configure the Production Development Business Network Range with the
following values:
Table 31 Production Development Business Network Range values
Setting Production Web value Production DB value Production App value
Name Development-Web Development-DB Development-App
Description Static IP range for Web tier of Static IP range for DB tier of the Static IP range for App tier of the
the Development Group Development Group Development Group
Start IP 172.12.10.20 172.12.11.20 172.12.12.20
End IP 172.12.10.250 172.12.11.250 172.12.12.250

c. Click OK to save the network range.

6. Click OK to save the network profile.

7. Repeat this procedure to create all external network profiles.

Create reservations for the shared edge and compute

cluster

Before members of a business group can request machines, as a fabric administrator,
you must allocate resources to them by creating a reservation. Each reservation is

configured for a specific business group to grant them access to request machines on
a specified compute resource.

Perform this procedure twice to create reservations for both the Production and
Development business groups:
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Group Name

Production SFO01-Comp01-Prod-Res01

Development SFO01-Comp01-Dev-Res01
Procedure

1. Log in to the vRealize Automation Rainpole portal.

a. Open a Web browser and go to https://
vraOlsvr0l.rainpole.local/vcac/org/rainpole.

b. Log in with the user name vra-admin-rainpole and the vRealize
Automation rainpole administrator password. Domain is rainpole.local.

Select Infrastructure > Compute Resources > Compute Resources.

In the Name column, select the compute cluster sfo01-w01-comp01 and select
Data Collection from the drop-down menu.

4. Click the four Request now buttons in each field on the page.

Wait for the data collection process to complete.

5. Click Refresh and verify that Status shows Succeeded for both Inventory
and Network and Security Inventory.

6. Select Infrastructure > Reservations > Reservations > New > vSphere

(vCenter).

The New Reservation - vSphere (vCenter) page appears.

7. Select the General tab and configure the following values:

Table 33 Values for the General tab

Setting Production Group value | Development Group value
Name SFO01-Comp01-Prod-Res01 | SFO01-Comp01-Dev-Res01
Tenant Rainpole Rainpole

Business Group Production Development

Reservation Policy

SFO-Production-Policy

SFO-Development-Policy

Priority

100

100

Enable This Reservation

Selected

Selected

8. Select the Resources tab and configure the following values:

Table 34 Values for the Resources tab

Setting Value

Compute resource sfo01-w01-comp01 (sfo01w01vcO1.sfoO1.rainpole.local)

Memory (GB) This Reservation 200

Select the sfo01-w01-lib01 check box.

Storage (GB)
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Table 34 Values for the Resources tab (continued)

Setting Value

Priority 1

This Reservation Reserved 2000

Resource Pool

sfo01-wO1rp-user-vm

9. Select the Network tab, select the network path check boxes listed in the
following table from the Network Paths list, and select the corresponding
network profile from the Network Profile drop-down menu for the business
group whose reservation you are configuring.

a. Configure the Production Business Group with the following values:

Production network path

Production Group network profile

vxw-dvs-xxxxx-Production-Web-VXLAN

Ext-Net-Profile-Production-Web

vxw-dvs-xxxxx-Production-DB-VXLAN

Ext-Net-Profile-Production-DB

vxw-dvs-xxxxx-Production-App-VXLAN

Ext-Net-Profile-Production-App

. Configure the Development Business Group with the following values:

Development network path

Development Group network
profile

vxw-dvs-xxxxx-Development-Web-
VXLAN

Ext-Net-Profile-Development-Web

vxw-dvs-xxxxx-Development-DB-
VXLAN

Ext-Net-Profile-Development-DB

vxw-dvs-xxxxx-Development-App-

VXLAN

Ext-Net-Profile-Development-App

10. Click OK to save the reservation.

11. Repeat this procedure to create a reservation for the Development Business
Group.

Create reservations for user edge resources

Before members of a business group can request virtual machines, as a fabric
administrator, you must allocate NSX Edge resources to that business group by
creating a reservation.

68

Each reservation is configured for a specific business group to grant them access to
request virtual machines on a specified compute resource.

Perform this procedure twice to create reservations for both the Production and
Development business groups.

Group

Name

Production

SFOO01-Edge01-Prod-Res01
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Group

Name

Development

SFOO01-Edge01-Dev-Res01

Procedure

1. Log in to the vRealize Automation Rainpole portal.

a. Open a Web browser and go to https://
vraOlsvr0Ol.rainpole.local/vcac/org/rainpole.

b. Log in with the user name vra-admin-rainpole and the vRealize
Automation rainpole administrator password. Domain is rainpole.local.

2. Select Infrastructure > Reservations > Reservations > New > vSphere
(vCenter).
The New Reservation - vSphere (vCenter) page appears.
3. Select the General tab and configure the following values:
Setting Production Group Value |Development Group
Value
Name SFOO01-Edge01-Prod-Res01 SFOO01-Edge01-Dev-Res01
Tenant Rainpole Rainpole
Business Group Production Development
Reservation Policy SFO-Edge-Policy SFO-Edge-Policy
Priority 100 100
Enable This Reservation. Selected Selected
4. Select the Resources tab and configure the following values:
Setting Value
Compute resource sfo01-wO01-
comp01(sfo01w01vc01.sfoO1.rainpole.local)
Memory (GB) This Reservation 200
Storage (GB) Select the sfo01-w01-vsan01 check box. This
Reservation Reserved 2000 Priority 1
Resource Pool sfo01-wO1rp-user-edge
5. Select the Network tab, select the network path check boxes listed in the

following tables from the Network Paths list, and select the corresponding
network profile from the Network Profile drop-down menu for the business
group whose reservation you are configuring.

a. Configure the Production Business Group with the following values:

Production Port Group

Production Network Profile

vxw-dvs-xxxxx-Production-Web-VXLAN

Ext-Net-Profile-Production-Web

vxw-dvs-xxxxx-Production-DB-VXLAN

Ext-Net-Profile-Production-DB
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Production Port Group

Production Network Profile

vxw-dvs-xxxxx-Production-App-VXLAN | Ext-Net-Profile-Production-App

b. Configure the Development Business Group with the following values:

Production Port Group

Production Network Profile

vxw-dvs-xxxxx-Development-Web-
VXLAN

Ext-Net-Profile-Development-Web

vxw-dvs-xxxxx-Development-DB-
VXLAN

Ext-Net-Profile-Development-DB

vxw-dvs-xxxxx-Development-App-
VXLAN

Ext-Net-Profile-Development-App

6. Click OK to save the reservation.

7. Repeat this procedure to create a reservation for the Development Business

Group.

Create virtual machines using templates in the content
library

70

vRealize Automation cannot directly access virtual machine templates in the content
library. You must create a virtual machine using the virtual machine templates in the
content library, then convert the template in vCenter Server.

Perform this procedure on all vCenter Server compute clusters that you add to
vRealize Automation, including the first vCenter Server compute instance.

Repeat this procedure three times for each of the following VM templates in the

content library:

Table 35 VM templates

VM template name

Guest OS

windows-2012r2-64

Windows Server 2012 R2 (64-bit)

windows-2012r2-64-sql2012

Windows Server 2012 R2 (64-bit)

redhat6-enterprise-64

Red Hat Enterprise Server 6 (64-bit)

Procedure

1. Use the vSphere Client to log in to the Compute vCenter Server:

a. Open a Web browser and go to https://
sfo0lw0lvc0l.sfo0l.rainpole.local/ui.

b. Log in using the user name administrator@vsphere.local and the

vSphere administrator password.

From the Home menu, select VMs and Templates.

Expand the sfo01w01lvc0l.sfo0l.rainpole.local vCenter Server.

right-click the sfo01-w01dc data center and select New Folder > New VM and

Template Folder.
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Type the folder name vM Templates and click OK.
From the Home menu, select Content Libraries.
Select sfo01-w01cl-vra01 > Templates.

Right-click the VM Template windows-2012r2-64 and click New VM from This
Template.

© N o o

The New Virtual Machine from Content Library wizard opens.
9. On the Select a name and folder page, user the same template name.

You use the same template name to create a common service catalog that
works across different vCenter Server instances within your data center
environment.

10. Select VM Templates as the folder for this virtual machine and click Next.

11.  On the Select a compute resource page, expand the sfo01-w01-comp01
cluster, select the sfo01-wO1rp-user-vm resource pool, and click Next.

12. On the Review details page, verify the template details and click Next.

13. On the Select storage page, select the sfo01-w01-1ib01 datastore, select Thin
Provision from the Select virtual disk format drop-down menu, and click
Next.

14. On the Select networks page, select sfo01-w01-vds01-management for the
Destination Network, and click Next.

vRealize Automation changes the network according to the blueprint
configuration.

15. On the Ready to complete page, review your configurations for the virtual
machine, and click Finish.

A new task for creating the virtual machine appears in the Recent Tasks pane.
After the task is complete, the new virtual machine is created.

16. Repeat this procedure for all the VM templates in the content library.

Convert virtual machines to VM templates

You can convert the virtual machines directly to templates instead of making a copy
by cloning.

Repeat this procedure for each of the VM templates in the content library.

Table 36 VM templates

VM template name Guest OS

windows-2012r2-64 Windows Server 2012 R2 (64-bit)
windows-2012r2-64-sq|2012 Windows Server 2012 R2 (64-bit)
redhat6-enterprise-64 Red Hat Enterprise Server 6 (64-bit)
Procedure

1. Use the vSphere Client to log in to the Compute vCenter Server:

a. Open a Web browser and go to https://
sfo0lw0lvcOl.sfo0Ol.rainpole.local/ui.
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b. Log in using the user name administrator@vsphere.local and the
vSphere administrator password.

2. From the Home menu, select VMs and Templates.

3. In the Navigator pane, expand sfo01w01vc01.sfo0O1.rainpole.local > sfo01-
wO01dc > VM Templates.

4. Inthe vM Templates folder, right-click the windows-2012r2-64 virtual
machine and click Template > Convert to Template.

5. Click Yes to confirm the template conversion.

Repeat this procedure for all the VM templates in the content library, verifying
that each VM template appears in thevM Templates folder.

Configure single machine blueprints

Virtual machine blueprints determine the virtual machine attributes, the manner in
which it is provisioned, and its policy and management settings.

Procedure
1. Create a service catalog on page 72.
2. Create a single machine blueprint on page 72.
3. Create entitlements for business groups on page 75.
4. Configure entitlements for blueprints on page 76.
5. Test the deployment of a single machine blueprint on page 77.

Create a service catalog

A service catalog provides a common interface for consumers of IT services to request
services, track their requests, and manage their provisioned service items.

Procedure
1. Log in to the vRealize Automation Rainpole portal.

a. Open a Web browser and go to https://
vraOlsvr0Ol.rainpole.local/vcac/org/rainpole.

b. Log in with the user name vra-admin-rainpole and the vRealize
Automation rainpole administrator password. Domain is rainpole.local.

2. From the Administration tab, select Catalog Management > Services > New.
3. Inthe New Service page, configure the following settings and click OK.

¢ Name—SFO Service Catalog

e Description—Default setting (blank)

e lcon—Default setting (blank)

e Status—Active

Create a single machine blueprint

72

Create blueprints for cloning the virtual machine templates using the specified
resources on the Compute vCenter Server.

Tenants can later use these blueprints for automatic provisioning. A blueprint is the
complete specification for a virtual, cloud, or physical machine. Blueprints determine a

VMware Validated Design v5.0 on Dell EMC VxRail for a Single Region



Post-deployment: Configuring the Cloud Management Platform

machine's attributes, the manner in which it is provisioned, and its policy and

management settings.

Repeat this procedure to create the following three blueprints:

Table 37 Blueprints to create

Blueprint name

VM template

Customization
specification

Reservation policy

Windows Server 2012 R2 -
SFO Prod

windows-2012r2-64
(sfo01w01vc01.sfo01.rainpole.
local)

os-windows-joindomain-
custom-spec

SFO-Production-Policy

Windows Server 2012 R2
With SQL2012 - SFO Prod

windows-2012r2-64-
sq12012(sfo01w01vc01.sfo01.r
ainpole.local)

os-windows-joindomain-
custom-spec

SFO-Production-Policy

Redhat Enterprise Linux 6 -
SFO Prod

redhat6-
enterprise-64(sfo01w01vc01.s
foO1.rainpole.local)

os-linux-custom-spec

SFO-Production-Policy

To test blueprints in a development environment, or according to your business needs,
create development blueprints using the same process as for production blueprints.

Procedure

1. Log in to the vRealize Automation Rainpole portal.

a. Open a Web browser and go to https://

vraOlsvr0Ol.rainpole.local/vcac/org/rainpole.

b. Log in with the user name vra-admin-rainpole and the vRealize

Automation rainpole administrator password. Domain is rainpole.local.

Select Design > Blueprints > New.

In the New Blueprint dialog box, on the General tab, configure the following
settings, and click OK.

Name—Windows Server 2012 R2 -SFO Prod
Deployment limit—Default setting (blank)
Lease (days): Minimum—30

Lease (days): Maximum—270

Archive (days)—15

Select the vSphere (vCenter) Machine icon and drag it in the Design Canvas.

Select the General tab, configure the following settings, and then click Save.

ID—Default setting (vSphere_vCenter_Machine_1)
Description—Default setting (blank)

Display location on request—Not selected
Reservation policy—SFO -Production-Policy
Machine prefix—Use group default

Instances: Minimum—Default setting

Instances: Maximum—1
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6. Select the Build Information tab, configure the following settings, and then
click Save.

Blueprint type—Server

Action—Clone

Provisioning workflow—CloneWorkflow
Clone from—windows-2012r2-64

Customization spec—s-windows-joindomain-custom-spec

Note

If the value of the Clone from setting does not list windows-2012r2-64
template, you must perform a data collection on the sfo01-w01-compO01
Compute Resource.

Verify that the required customization spec is available in vSphere Client
under Menu > Policies and Profiles > VM Customization Specifications.

7. Select the Machine Resources tab, configure the following settings, and then
click Save.

Table 38 Machine Resources tab values

Setting Minimum Maximum

CPUs 2 4

Memory (MB) 4096 16384

Storage (GB) Default setting Same value as Minimum

8. Select the Network tab.

a.

In the Categories section, select Network & Security to display the list of
available network and security components.

. Select the Existing Network component and drag it in the Design Canvas.

. Click the Existing network object and on the General tab, select the Ext-

Net-Profile-Production-Web network profile, and click OK.

Use the following table to create subsequent blueprints.

Table 39 Network names for blueprints

Blueprint name Existing network

Windows Server 2012 R2 - SFO Prod Ext-Net-Profile-Production-Web

Windows Server 2012 R2 With SQL2012 | Ext-Net-Profile-Production-DB
- SFO Prod

Redhat Enterprise Linux 6 - SFO Prod Ext-Net-Profile-Production-App

. Click Save.
. In the Design Canvas, select the vSphere_vCenter_Machine object.

. Select the Network tab, click New, configure the following settings, and

click OK.
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Table 40 Network tab values

Network Assignment type Address

Ext-Net-Profile- Static IP Default setting (blank)
Production-Web

Ext-Net-Profile- Static IP Default setting (blank)
Production-DB

Ext-Net-Profile- Static IP Default setting (blank)
Production-App

g. Click Finish to save the blueprint.
9. Select the blueprint Windows Server 2012 R2 -SFO Prod and click Publish.

10. Repeat this procedure to create additional blueprints.

Create entitlements for business groups

Add a service, catalog item, or action to an entitlement, to allow the users and groups
identified in the entitlement to request provisionable items in the service catalog.

The entitlement allows members of a particular business group (for example, the
Production business group) to use the blueprint. Without the entitlement, users
cannot use the blueprint.

Perform this procedure to create an entitlement for the Production business group.

Table 41 Production group parameters

Entitlement name |Status Business group User & groups
Prod-SingleVM- Active Production ug-vra-admins-
Entitlement rainpole
Procedure

1. Log in to the vRealize Automation Rainpole portal.

a. Open a Web browser and go to https://
vraOlsvr0Ol.rainpole.local/vcac/org/rainpole.

b. Log in with the user name vra-admin-rainpole and the vRealize
Automation rainpole administrator password. Domain is rainpole.local.

On the Administration tab, select Catalog Management > Entitlements.
Click New.
The New Entitlement page appears.
4. On the General tab, configure the following values, and click Next.
¢ Name—Prod-SingleVM-Entitlement
e Description—Default setting (blank)
e Expiration Date—Default setting (blank)
e Status—Active

¢ Business Group—Production
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¢ All Users and Groups—Not selected
e Users and Groups—ug-vra-admins-rainpole

5. One the Items & Approvals tab, add the actions that the users from the
Production business group are entitled to.

a. On the Entitled Actions page, click the Add Actions icon, add the following
actions, and click OK.

¢ Connect using RDP (Machine)
¢ Power Cycle (Machine)

¢ Power off (Machine)

e Power on (Machine)

¢ Reboot (Machine)

¢ Shutdown (Machine)

b. Click Finish.

Configure entitlements for blueprints

Entitle users to the actions and items that belong to the service catalog by associating
each blueprint with an entitlement.

Repeat this procedure to associate the blueprints with their entitlement.

Table 42 Blueprint entitlement configuration

Blueprint name Service catalog Add to entitlement

Windows Server 2012 R2 - SFO Prod SFO Service Catalog Prod-SingleVM-
Entitlement

Windows Server 2012 R2 With SQL2012 | SFO Service Catalog Prod-SingleVM-
- SFO Prod Entitlement

Red hat Enterprise Linux 6 - SFO Prod | SFO Service Catalog Prod-SingleVM-
Entitlement

Procedure
1. Log in to the vRealize Automation Rainpole portal.

a. Open a Web browser and go to https://
vraOlsvr0Ol.rainpole.local/vcac/org/rainpole.

b. Log in with the user name vra-admin-rainpole and the vRealize
Automation rainpole administrator password. Domain is rainpole.local.

On the Administration tab, select Catalog Management > Catalog Items.

On the Catalog Items pane, select the Windows Server 2012 R2 - SFO Prod
blueprint in the Catalog Items list and click Configure.

4. On the General tab of the Configure Catalog Item dialog box, select SFO
Service Catalog from the Service drop-down menu, and click OK.

5. Associate the blueprint with the Prod-SingleVM-Entitlement entitlement:

a. Select Entitlements > Prod-SingleVM-Entitlement.
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b. In the Edit Entitlement window, select the Items & Approvals tab, add the
Windows Server 2012 R2 - SFO Prod blueprint to the Entitled Items list,
and click OK.

c. Click Finish.
6. On the Catalog tab, verify that the blueprints are listed in the Service Catalog.

7. Repeat this procedure to associate all the blueprints with their entitlements.

Test the deployment of a single machine blueprint

Test your environment and confirm the successful provisioning of virtual machines
using the newly created blueprints.

If multiple availability zones have been configured, you must manually place all the
virtual machines provisioned by vRealize Automation into the appropriate VM group
for the availability zone.

Procedure
1. Log in to the vRealize Automation Rainpole portal.

a. Open a Web browser and go to https://
vraOlsvrOl.rainpole.local/vcac/org/rainpole.

b. Log in with the user name vra-admin-rainpole and the vRealize
Automation rainpole administrator password. Domain is rainpole.local.

2. On the Catalog tab, click Click here to apply filters and select SFO Service
Catalog from the catalog of available services.

Click Request for one of the blueprints.
Click Submit.

Verify that the request finishes successfully:

a. On the Deployments tab, select the deployment that you submitted, click
History, and wait several minutes for the request to complete.

Click the Refresh icon every few minutes until a Successful message
appears.

b. Under Status, verify that the virtual machine successfully provisioned.

6. Verify that the virtual machine provisions in the shared edge and compute
cluster:

a. Open a Web browser and goto https://
sfo0lw0lvcO0l.sfo0l.rainpole.local/ui.

b. Log in using the user name administrator@vsphere.local and the
vSphere administrator password.

c. From the Menu option, select Hosts and Clusters.

d. In the Navigator pane, expand sfo01w01vc01.sfoO1.rainpole.local > sfo01-
wO01-comp01 > sfo01-wO1rp-user-vm and verify that the virtual machine is
present.
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Reconfigure the Microsoft SQL Server instance

When you deploy vRealize Automation, the Microsoft SQL Server is outside of the
vRealize Automation application virtual network and you must reconfigure the
Microsoft SQL Server.

Before you begin
Allocate a static IP address on the cross-region application virtual network.

Procedure
1. Use the vSphere Client to log in to the vCenter Server:

a. Open a Web browser and goto https://
sfo01lm0lvc0l.sfo0l.rainpole.local/ui.

b. Log in using the user name administrator@vsphere.local and the
vSphere administrator password.

2. Shut down the vRealize Automation components:

a. From the Home menu, select Hosts and Clusters and expand the
sfo01mO01vc01.sfo01.rainpole.local tree.

b. Right-click the following VMs according to their shutdown order and select
Power > Shut Down Guest OS.

Table 43 Virtual machine shutdown order

Product Virtual machine name | Shutdown order
in Region A

vRealize Business for Total Number of VMs (2) |1

Cloud sfoO1lvrbcO1 1
vrb01svrO1 2

vRealize Automation Total Number of VMs (12) |2
vra01demO1b 1
vraOldemO1a 1
sfoOliasO1b 1
sfoOliasOla 1
vra01imsO1b 2
vraO1imsO1a 3
vraO1iwsO1b 4
vraOliwsO1a 5
vraO1svrOic 6
vraO1svrO1b 7
vraOlsvrO1a 8
vra01mssqlO1 9
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3. Migrate the Microsoft SQL Server virtual machine to the sfo01-mO01fd-vra
folder and connect to the Mgmt-xRegion01-VXLAN port group:

a.

e.

From the Home menu, select Hosts and Clusters and expand the
sfo01mO01vc01.sfoO1.rainpole.local tree.

. Right-click vraO1mssql01, select Move to folder > sfo01-m01fd-vra, and

click OK.

. Right-click vraO1mssql01 and select Edit Settings.
. On the Edit Settings page, browse to the Network Adapter 1 distributed

port group that ends with Mgmt -xRegion01-VXLAN and click OK.

Right-click vraO1mssql01 and select Power > Power on.

4. Change the IP address of the vraO1mssqlO1 virtual machine:

a.
b.

C.

Right-click vraO1mssql01, and select Open Console.
Log in with the Windows administrator user name and password.

From the Windows Start menu, select Control Panel > Network and
Sharing Center.

. Click change adapter settings.
. Right-click the Ethernet adapter and select Properties.
. Select Internet Protocol Version 4 (TCP/IPv4) > Properties.

. Enter the following settings and click OK:

e [P Address—192.168.11.62
e Subnet Mask—255.255.255.0
¢ Default Gateway—192.168.11.1

5. Change the IP address in the DNS for the vraO1mssql01 virtual machine:

a.

Log in to the DNS server that resides in the sfoO1.rainpole.local domain by
using a Remote Desktop Protocol (RDP) client.

. Open an RDP connection to the dcOlrpl.rainpole.local DNS server.
. Log in with the Active Directory administrator user name and password.

. From the Windows Start menu, type dnsmgmt.msc in the Search text box

and press Enter.

. In the DNS Manager dialog box, under Forward Lookup Zones, select the

rainpole.local domain.

. In the right pane, double-click the vraO1mssql01 record, modify the IP

Address using the following settings, and click OK

¢ Fully qualified domain name (F@DN)—vraO1mssqlO1.rainpole.local
e IP Address—192.168.11.62

¢ Update associated pointer (PTR) record—Selected

6. Login to the SQL Server virtual machine by using a Remote Desktop Protocol
(RDP) client:

a.

Open an RDP connection to the vra0lmssqgl0l.rainpole.local virtual
machine.
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b.

Log in with the Windows administrator user name and password.

7. Install vRealize Log Insight Windows Agents in vraO1mssqlO1:

a.

From the vraO1mssqlO1 Windows environment, log in to the vRealize Log
Insight user interface:

e Open a Web browser and goto https://
sfo0lvrliOl.sfo0Ol.rainpole.local.

e Log in with the user name admin and the deployment administrator
password.

. Click the configuration drop-down menu icon and click Administration.

. Under Management, select Agents and click the Download Log Insight

Agent Version link.

. In the Download Log Insight Agent Version dialog box, click Windows MSI

(32-bit/64-bit) and save the .msi file on the vraO1mssqlO1 virtual machine.

. Open an administrative command prompt, and navigate to the directory

where you saved the .ms1i file.

. Run the following command to install the vRealize Log Insight agent with

custom values:

VMware-Log-Insight-Agent-4.7.0-
build number 192.168.31.10.msi SERVERPORT=9000
AUTOUPDATE=yes LIAGENT SSL=no

. In the VMware vRealize Log Insight Agent Setup wizard, accept the

license agreement and click Next.

. In the Host text box, select sfo01vrli01.sfoO1.rainpole.local and click

Install.

Click Finish.

8. Use the vSphere Client to log in to the vCenter Server:

a.

b.

Open a Web browser and go to https://
sfo01lm0lvc0l.sfo0l.rainpole.local/ui.

Log in using the user name administrator@vsphere.local and the
vSphere administrator password.

9. Power on the remaining vRealize Automation components:

a.

b.

From the Home menu, select Hosts and Clusters and expand the
sfo01mO01vc01.sfo01.rainpole.local tree.

Right-click the following VMSs, according to their startup order and select
Power > Power on.

Table 44 Virtual machine startup order

Product Virtual machine name | Startup order
in Region A

vRealize Automation Total Number of VMs (11) |1
vraOlsvrO1a 1
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Table 44 Virtual machine startup order (continued)

Product Virtual machine name | Startup order
in Region A

vraO1svrO1b

vraO1svrOic

vraOliwsO1a

vraO1liws01b

|| D[ NN

vra0limsO1a

vra01ims01b

~

sfoOliasO1a

sfo0liasO1b

vraOldemO1a

vraOldemO1b

N| | ]| 6| ©

vRealize Business for vRealize Business for
Cloud Cloud

vrb01svrO1 1

sfo01vrbc01 2

10. Test your environment and confirm the successful provisioning of virtual
machines.

See Test the deployment of a single machine blueprint on page 77.
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APPENDIX A

Using the Cloud Builder VM to Deploy vCenter
Server

This appendix presents the following topic:

¢ Deploying vCenter Server using the Cloud Builder VM...........o.euieiiiiiiiiniiiiiienene.

Using the Cloud Builder VM to Deploy vCenter Server

83



Using the Cloud Builder VM to Deploy vCenter Server

Deploying vCenter Server using the Cloud Builder VM

Use the following script to deploy a vCenter Server instance using the Cloud Builder

VM.
" version": "2.13.0",
"new vcsa": {
o' {
"hostname": "mgt-vcenter.lab3.local",
"username": "administrator@vsphere.local",
"password": "VMw@rel!",
"deployment network": "vCenter Server Network-ad9cf3dl-72a2-4729-
beff-723c2876225b",
"datacenter": "VxRail-Datacenter",
"datastore": "VxRail-Virtual-SAN-Datastore-ad9cf3dl-72a2-4729-
beff-723c2876225b",
"target": "VxRail-Virtual-SAN-Cluster-ad9cf3dl-72a2-4729-beff-723c2876225b"
}y
"appliance": {
"thin disk mode": true,
"deployment option": "management-small",
"name": "wld-vcenter"
}y
"network": {
"ip family": "ipv4",
"mode": "static",

"ip": "172.16.64.20",
"dns servers": [ "172.16.64.4" 1,

"prefix": "24",
"gateway": "172.16.64.1",
"system name": "wld-vcenter.lab3.local"
by
"os": {
"password": "VMw@rel!",
"ntp servers": [ "ntp.lab3.local" ],
"ssh enable": true
}r
"sso": {
"password": "VMw@rel!",
"domain name": "vsphere.local",
"platform services controller": "mgt-psc0l.lab3.local",

"sso port": 443
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