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FOREWORD

Scope and Intended Audience

Scope. This publication describes how to administer an operational Avamar 
system following successful system installation, setup and configuration. 

Intended Audience. The information in this publication is primarily intended for 
system administrators who are responsible for maintaining servers and clients on 
a network, as well as operators who monitor daily backups and storage devices.

Product Information
For current documentation, release notes, software updates, information about 
EMC products, licensing and service, go to the EMC Powerlink website at 
http://Powerlink.EMC.com.

Your Comments
Your suggestions will help us continue to improve the accuracy, organization and 
overall quality of our publications. You may email your comments to:

BSGDocumentation@emc.com

Please include the following information:

• Product name and version
• Document name, part number, and revision (for example, A01)
• Page numbers
• Other details that will help us address the documentation issue
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FOREWORD
Typeface Conventions
The following table provides examples of standard typeface styles used in this 
publication to convey various kinds of information.

Notes, Tips, and Warnings
The following kinds of notes, tips, and warnings appear in this publication:

IMPORTANT:  This is a warning. Warnings always contain
information that if not heeded could result in unpredictable
system behavior or loss of data. 

TIP:  This is a tip. Tips present optional information intended
to improve your productivity or otherwise enhance your
experience with the product. Tips never contain information
that will cause a failure if ignored.

NOTE:  This is a general note. Notes contain ancillary infor-
mation intended to clarify a topic or procedure. Notes never
contain information that will cause a failure if ignored.

EXAMPLE DESCRIPTION

Click OK.
 or
Select File > Close.

Bold text denotes actual buttons, commands, 
menus and options that initiate action.
Sequential commands are separated by a greater-
than (>) character. For example, the second 
example instructs you to select the Close 
command from the File menu.

Type:
 cd /tmp

Bold fixed-width text denotes shell commands that 
must be entered exactly as they appear.

--logfile=FILE All caps text often denotes a placeholder (token) 
for an actual value that must be supplied by the 
user. In this example, FILE would be an actual 
filename. 

Installation Complete. Regular (not bold) fixed-width text denotes 
command shell messages, code and file contents.
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INTRODUCTION

This chapter introduces and discusses the Avamar online data protection solution. 
You should familiarize yourself with these concepts before attempting to 
administer an Avamar system.

Avamar® solves the challenges associated with traditional backup, enabling fast, 
reliable backup and recovery for remote offices, data center LANs and VMware 
environments. Avamar is backup and recovery software that utilizes patented 
global data deduplication technology to identify redundant sub-file data segments 
at the source, reducing daily backup data by up to 500x — before it is transferred 
across the network and stored to disk. This allows companies to perform daily full 
backups even across congested networks and limited WAN links. 

Key Avamar differentiators are:

• Deduplicates backup data at the source — before transfer across the network
• Enables fast, daily full backups across existing networks and infrastructure
• Reduces required daily network bandwidth by up to 500x
• Up to 10x faster backups
• Data encrypted in flight and at rest 
• Patented RAIN technology provides fault tolerance across nodes and eliminates 

single points of failure
• Scalable grid architecture
• Global data deduplication reduces total backup storage by up to 50x
• Recoverability verified daily — no surprises
• Centralized web-based management
• Simple one-step recovery
• Flexible deployment options, including EMC Corporation Avamar Data Store 

package
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INTRODUCTION
Important Terms and Concepts
This topic introduces and discusses important terms and concepts that you should 
familiarize yourself with before attempting to administer an Avamar system.

Avamar System. An Avamar system is a client/server network backup and 
restore solution consisting of one or more Avamar servers and the network 
servers or desktop clients that back up data to those servers. The Avamar system 
also provides centralized management through the Avamar Administrator 
graphical management console software application.

Avamar Server. An Avamar server is a logical grouping of one or more nodes 
that is used to store and manage client backups.

NOTE:  Hardware manufacturers typically call their equip-
ment servers (for instance, the Dell PowerEdge 2950
server). In the context of an Avamar system, this equipment
is called a "node."

Node. An Avamar node is a self-contained rack-mountable network-addressable 
computer that runs Avamar server software on the Linux operating system.

Hard Disk Storage. Avamar is a hard-disk based IP network backup and 
restore solution. Avamar servers manufactured by EMC use internal hard disk 
storage.

Stripes. A stripe is a unit of disk drive space managed by Avamar to ensure fault 
tolerance.
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Object. In the Avamar system, an object is a single instance of deduplicated 
data. Each Avamar object inherently has a unique ID. Objects are stored and 
managed within stripes on the Avamar server.

Data Deduplication. Data deduplication is a key feature of the Avamar system. 
Data deduplication ensures that each unique sub-file, variable length object is 
stored only once across sites and servers.

During backups, Avamar client software examines the client filesystem and applies 
a data deduplication algorithm that identifies redundant data sequences and 
breaks the client filesystem into sub-file, variable length data segments. Each data 
segment is assigned a unique ID. The client software then determines whether or 
not this unique ID has already been stored on the Avamar server. If this object 
resides on the Avamar server, a link to the stored object is referenced in this 
backup. Once an object has been stored on the server, it never has to be re-sent 
over the network, no matter how many times it is encountered on any number of 
clients. This feature greatly reduces network traffic and provides for greatly 
enhanced storage efficiency on the server.

Replication. Replication is a feature that enables efficient, encrypted and 
asynchronous replication of data stored in an Avamar server to another Avamar 
server deployed in remote locations without the need to ship tapes. Replication is 
a scheduled process between two independent Avamar servers, providing a higher 
level of reliability for stored backups. Replication can be scheduled to run at off-
peak hours to minimize bandwidth impact.
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Functional Overview
This topic provides detailed information about each part of the Avamar 
client/server system and describes how the various parts interact with one 
another. 

Avamar Servers

All Avamar servers store client backups and also provide essential processes and 
services required for client access and remote system administration. 

A Word About Avamar Server Hardware Configurations. Avamar servers 
are available in either single-node or scalable multi-node configurations. For the 
most part, when using Avamar Administrator management console software, all 
Avamar servers look and behave the same. The main differences among various 
Avamar server configurations is the number of nodes and disk drives reported in 
the server monitor.

Documenting specific differences in Avamar server hardware configurations is 
beyond the scope of this publication. Whenever specific limitations and best 
practices for certain configurations are known, they will be noted for your 
convenience. However, these occasional notes should not be considered definitive 
or exhaustive. Consult EMC Technical Support or your EMC reseller for additional 
information about your specific hardware.

Nodes. The primary building block in any Avamar server is a “node.” Each node 
is a self-contained rack-mountable network-addressable computer that runs 
Avamar server software on the Linux operating system. Nodes can also contain 
internal storage in the form of hard disk drives. If the node is configured with 
internal storage (that is, a single-node server), it is internally mirrored to provide 
robust fault tolerance.

Single-Node Servers. Single-node Avamar servers combine all the features 
and functions of utility and storage nodes on a single node.

Utility
 Node

A node dedicated to scheduling and managing background Avamar 
server jobs. In scalable multi-node Avamar servers, a single utility 
node provides essential internal services for the server 
(Management Console Server (MCS), cronjob, External 
authentication, Network Time Protocol (NTP) and Web access). 
Because utility nodes are dedicated to running these essential 
services, they cannot be used to store backups.

Storage
Nodes

Nodes that store the actual backup data. Multiple storage nodes are 
configured with multi-node Avamar servers based upon 
performance and capacity requirements. Storage nodes can be 
added to an Avamar server over time to expand performance with 
no downtime required. Avamar clients connect directly with Avamar 
storage nodes; client connections and data are load balanced 
across storage nodes. 

NDMP
Accelerator

A specialized node that utilizes NDMP in order to provide data 
protection for NAS devices (EMC Celerra IP storage systems and 
Network Appliance filers).
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Avamar Clients

Avamar provides client software for various computing platforms. Each client 
comprises a client agent and one or more plugins.

Agents. Avamar agents are platform-specific software processes running on the 
client that communicate with the Management Console Server (MCS) and with any 
plugins installed on that client.

Plugins. There are two basic types of Avamar plugins:

Filesystem
 plugins

Filesystem plugins are used to browse, back up and restore files 
or directories on a specific client filesystem. Avamar currently 
provides the following operating system plugins:

• Free BSD
• HP-UX
• IBM AIX
• Linux
• Mac OS X
• Microsoft Windows
• Microsoft Windows Volume Shadow Copy Service (VSS)
• SCO OpenServer
• SCO UnixWare
• Sun Solaris
• Novell NetWare
• VMware

Application
plugins

Application plugins support backup and restore of databases or 
other special application. Avamar currently provides the following 
application plugins:

• IBM DB2
• Lotus Domino
• Microsoft Exchange
• Microsoft Office SharePoint Server (MOSS)
• Microsoft SQL Server
• NDMP for NAS devices (EMC Celerra IP storage systems and 

Network Appliance filers)
• Oracle

GEN 000995

FILE
SYSTEM
PLUGIN

APPLICATION
PLUGIN

AVAMAR CLIENT

AGENT MANAGEMENT CONSOLE 
SERVER (MCS)

AVAMAR SERVER
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Avamar Administrator

Avamar Administrator is a graphical management console software application 
that is used to remotely administer an Avamar system from a supported Windows 
client computer. 

Encryption

Avamar can encrypt all data sent between clients and the server “in flight.” Each 
individual Avamar server can also be configured to encrypt data stored on the 
server “at rest.”

“In-Flight” Encryption. In order to provide enhanced security during 
client/server data transfers, Avamar supports two levels of “in-flight” encryption 
(medium and high), which can be set on a client-by-client basis in client 
properties, or for an entire group of clients in group properties. You can also turn 
off “in-flight” encryption entirely.

“At-Rest” Encryption. The decision to encrypt all data stored in an Avamar 
server is typically a one-time decision that is made when the server is initially 
deployed at a customer site.
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AVAMAR ADMINISTRATOR

Avamar Administrator is a graphical management console software application 
that is used to remotely administer an Avamar system from a supported Windows 
or client computer. 

Installing Avamar Administrator on Microsoft Windows

TIP:  You can also launch Avamar Administrator directly
from an Avamar Enterprise Manager session. Refer to
Launching Avamar Administrator From Avamar Enterprise
Manager (page 320) for additional information.

1. Log into the computer onto which you want to install this software.

2. Point your web browser at the Avamar server by typing the following URL:

http://AVAMARSERVER

Where AVAMARSERVER is your actual Avamar server network hostname 
(as defined in DNS) or IP address.

You will be automatically redirected to the Avamar secure web server.

Depending on your browser security settings, a security alert dialog box 
might appear. 

3. If a security alert dialog box appears, click Yes or OK to allow redirection 
to the Avamar secure web server. 

The Secure Log On page appears.

4. Page down until the Documents and Downloads hyperlink is visible.

5. Click Documents and Downloads.

The Downloads and Documentation page appears.

6. Click the appropriate operating system hyperlink for your client computer.

A directory listing appears in your browser.
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Install JRE as
Required

7. Do one of the following:

8. Click the AvamarConsoleMultiple install package.

Your browser might prompt you to either open the file “in-place” (on the 
server) or save it to your local computer. Either method will work. However, 
if you save the file to your local computer, you must open (double-click) 
that installation file to continue with this procedure.

9. Either open the installation file in place (on the server) or double-click the 
downloaded installation file.

If a security warning appears, click Run. 
The installation wizard appears.

10.Click Accept for the license agreement.

The installation destination window appears.

11.Do one of the following:

IMPORTANT:  This installation procedure allows you to
install multiple versions of the Avamar Administrator on the
same computer. Each version is identified by its full version
number (for instance, 4.1.0.420). To ensure against inadver-
tently overwriting an existing one that you want to keep,
select this destination folder carefully.

12.Click Install to complete the installation procedure.

IF DO THIS

Your computer already 
has Java Runtime 
Environment (JRE) 1.6 
Update 12 installed.

Skip this step and proceed directly to step 8.

Your computer does not 
have Java Runtime 
Environment (JRE) 1.6 
Update 12 installed.

Click the jre-6u12-windows-i586-p install 
package.
Your browser will prompt you to either open 
the file “in-place” (on the server) or save it to 
your local computer. Either method will work. 
However, if you save the file to your local 
computer, you must open (double-click) that 
installation file to continue with this 
procedure.
Follow the on-screen instructions to complete 
the JRE installation.

IF DO THIS

You accept the default destination. Go to step 12.

You want to change the installation 
destination.

Click Browse and select 
a different destination.
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Uninstalling and Upgrading Avamar Administrator on 
Microsoft Windows

Unlike other platforms, previous versions of Avamar Administrator software do not 
have to be explicitly uninstalled before a new version can be installed. 

If you decide to install Avamar Administrator on a computer that already has it 
installed, select a destination folder carefully in step 11 of the previous procedure. 
To keep an older version, select a different installation destination. The two 
versions will be identified by their full version numbers.

To uninstall a version of Avamar Administrator, double-click Uninstall Avamar 
Administrator in the following path:

Start > Programs > EMC Avamar > Administrator > VERSION

Where VERSION is the specific version you want to uninstall.

Installing Avamar Administrator on Linux

IMPORTANT:  Uninstall (page 26) any previous version of
Avamar Administrator software before installing the new ver-
sion. 

Downloading the Install Package

1. Log into the computer onto which you want to install this software.

2. Point your web browser at the Avamar server by typing the following URL:

http://AVAMARSERVER

Where AVAMARSERVER is your actual Avamar server network hostname 
(as defined in DNS) or IP address.

You will be automatically redirected to the Avamar secure web server.

Depending on your browser security settings, a security alert dialog box 
might appear. 

3. If a security alert dialog box appears, click Yes or OK to allow redirection 
to the Avamar secure web server. 

The Secure Log On page appears.

4. Page down until the Documents and Downloads hyperlink is visible.

5. Click Documents and Downloads.

The Downloads and Documentation page appears.
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Install JRE as
Required

6. Do one of the following:

Download Avamar
Administrator

(AvamarConsole)
Package

7. Click Downloads > Linux.

Download the Avamar Administrator (AvamarConsole) install package to 
any convenient temporary install directory on your system.

IMPORTANT:  Use the Red Hat Enterprise Linux 3.0
installer for Red Hat Enterprise Linux 9.0.

NOTE:  /tmp is used as an example temporary install direc-
tory in the remainder of this chapter. Your actual temporary
install directory may be different.

8. Note the actual filename of the Avamar Administrator (AvamarConsole) 
install package. 

NOTE:  AVAMARLINUXCONSOLE.rpm is used as an example
filename for the Avamar Administrator (AvamarConsole)
install package in the remainder of this chapter. Your actual
filename will be different.

IF DO THIS

Your computer already has 
Java Runtime Environment 
(JRE) 1.6 Update 12 installed.

Skip this step and proceed directly to 
step 7.

Your computer does not have 
Java Runtime Environment 
(JRE) 1.6 Update 12 installed.

Click Downloads > Red Hat 
Enterprise Linux 3 and download 
jre-6u12-linux-amd64.rpm to any 
convenient temporary install directory 
on your system (for example, /tmp) and 
run this installation program from a 
command shell.
Follow the on-screen instructions to 
complete the JRE installation.
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Install Avamar Administrator Software

Log in as root 1. Open a command shell and log into the computer onto which you want to 
install this software as root.

Install Avamar
Linux Client

Software

2. Change directory to your temporary install directory (page 24). For 
example:

cd /tmp

3. Type:

rpm -ih AVAMARLINUXCONSOLE.rpm

The following appears in the command shell:

Please run /usr/local/avamar/bin/avsetup_mcc to configure MC Client

Configure Avamar
Administrator

4. Type:

/usr/local/avamar/bin/avsetup_mcc

The following appears in the command shell:
Enter the location of your JRE 1.5 installation [/usr/java/jre1.6u12]:

5. Press ENTER to accept the default install location.

The following appears in the command shell:

Enter the root directory of your EMC installation [/usr/local/avamar]:

6. Press ENTER to accept the default install location.

The following appears in the command shell:

Avamar Administrator 5.0.2-31 has been configured correctly. Type mcgui command 
to use it.
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Uninstalling Avamar Administrator on Linux
1. Close Avamar Administrator.

IMPORTANT:  You must close all open Avamar Administra-
tor sessions before you can uninstall Avamar Administrator.
Otherwise, the uninstall will not complete. Any incomplete
uninstall will complicate future Avamar Administrator
upgrades.

Log in as root 2. Open a command shell and log into the computer that is currently running 
Avamar Administrator as root.

Uninstall Avamar
Software

3. Type:

rpm -qa | grep Av

The following appears in the command shell:

AvamarConsole-VERSION

4. Note the package name.

5. Type:

rpm -e AvamarConsole-VERSION

Where AvamarConsole-VERSION is the Avamar software install package 
returned in step 3.

Upgrading Avamar Administrator on Linux
In order to upgrade your Avamar Administrator software on the Linux platform, 
you must completely uninstall the old software (page 26) and install the new 
software (page 23). Use of the Linux software upgrade command (rpm -Uh) is not 
supported.
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Starting Avamar Administrator
1. Do one of the following:

The login window appears.

2. Type the following:

PLATFORM DO THIS

Microsoft Windows Double-click the Avamar 
Administrator icon on your Windows 
desktop.

Linux Open a command shell and type:
mcgui

FIELD DESCRIPTION

User Name Your Avamar username.
NOTE:  In order to access all Avamar Administrator 
features and functions, this user account must be 
assigned the role of Administrator. Other roles provide 
reduced functionality. Refer to Roles (page 60) for 
additional information.

If you are using an external authentication system such 
as Network Information Service (NIS), Open 
Lightweight Directory Access Protocol (OpenLDAP) and 
Windows Active Directory, your entry must be in the 
following format:

USER@EXT-AUTH-SERVER

Where USER is your username and EXT-AUTH-SERVER 
is the name of your external authentication server. 

If only the username is entered, the internal Avamar 
authentication system (“avs”) is used.

Password Your Avamar password.
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TIP:  If you consistently log on to the same Avamar server
or domain, click Options… and type that server name and
domain in the Default Administrator Server and Default
Domain fields, respectively. The next time you start Avamar
Administrator, the login window Administrator Server and
Domain Name fields will be prepopulated with this informa-
tion.

3. Click Log On.

The Administrator launcher appears.

NOTE:  Full launcher functionality is only available to users
assigned the role of Administrator. Other roles provide
reduced functionality. Refer to Roles (page 60) for additional
information. 

Each of the buttons invokes a different persistent window for performing 
specific tasks. You can invoke and switch among the various windows using 
the Navigation menu or status bar shortcuts. 

Domain 
Name

Administrative domain (node on the client tree) you 
want to log into. 
If logging into the root domain, use the default entry 
(that is, a single slash (/) character).
If logging into a specific domain or subdomain, use the 
following syntax:

/domain/subdomain1/subdomain2
Refer to Domains and Subdomains (page 33) for 
additional information.

Administrator 
Server

Avamar Administrator server name, as defined in the 
corporate Domain Name Server (DNS), that you want to 
log into. 

FIELD DESCRIPTION
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Special Features
This topic introduces and discusses various time-saving features and shortcuts 
found in the Avamar Administrator user interface.

Status Bar. Each Avamar Administrator persistent window contains a status bar 
near the bottom of the screen:

This status bar not only conveys status information but each icon and status 
indicator also provides a single-click shortcut to specific features and functions.

Launcher Shortcuts. The six icons on the left side of the status bar provide 
shortcuts to any of the six main windows. Clicking any of these icons is the same 
as clicking the corresponding Launcher button or selecting the corresponding 
Navigation menu command.

Clicking this status bar icon displays the Policy window, which is used to 
create and manage groups, datasets, schedules and retentions policies. 
Refer to Groups and Group Policies (page 128) for additional information.

Clicking this status bar icon displays the Backup and Restore window, 
which is used to perform on-demand backups and restores. Refer to 
Performing an On-Demand Client Backup (page 74) and Performing a 
Restore (page 84) for additional information. 

Clicking this status bar icon displays the Administration window, which is 
used to create and manage domains, clients, users, system events and 
services. Refer to Domains, Clients and Users (page 33) and Advanced 
Server Administration and Maintenance (page 351) for additional 
information.

Clicking this status bar icon displays the Backup Management window, 
which is used to change backup expiration dates, as well as validate 
backups or delete them from the system. Refer to Changing a Backup 
Expiration Date (page 88), Validating a Backup (page 92) and Deleting a 
Backup (page 98) for additional information.

Clicking this status bar icon displays the Activity window, which is used to 
monitor backup and restore activity. Refer to Monitoring Backup, Restore 
and Validation Activities (page 76) for additional information.

Clicking this status bar icon displays the Avamar Server window, which is 
used to monitor server activity and client sessions. Refer to Advanced 
Server Administration and Maintenance (page 351) for additional 
information.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  29



 Special Features
AVAMAR ADMINISTRATOR
Status Indicators. The right side of the status bar contains three important 
status indications:

Scheduler The scheduler controls whether or not scheduled backups 
occur. "Scheduler: Running" indicates that scheduled backups 
are enabled and will occur at the scheduled time. "Scheduler: 
Suspended" indicates that scheduled backups are disabled and 
will not occur until you reenable the scheduler. Clicking the 
scheduler status icon or text label displays the Manage All 
Schedules dialog box. From there, you can click Resume All 
or Suspend All to enable or disable scheduled backups, 
respectively. Refer to Suspending Scheduled Operations (page 
279) and Refer to Resuming Scheduled Operations (page 279) 
for additional information.

Unacknowledged
 Events

Certain system events can be configured to require 
acknowledgement by an Avamar server administrator each 
time they occur. "Have Unacknowledged Events" indicates that 
there are entries in the unacknowledged events list that must 
be explicitly acknowledged by an Avamar server administrator. 
"No Unacknowledged Events" indicates that the 
unacknowledged events list contains no entries. Clicking the 
Unacknowledged Events status icon or text label displays the 
Administration window Unacknowledged Events pane (tab). 
Refer to Acknowledging System Events (page 276) for 
additional information.
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Server Indicates one of the following overall Avamar server operational states:

Full Access Indicates the normal operational state for an 
Avamar server. All operations are allowed. 

Admin Indicates that the Avamar server is in an 
administrative state in which the Avamar server 
and root user can read and write data; other users 
are only allowed to read data.

Admin Only Indicates that the Avamar server is in an 
administrative state in which the Avamar server or 
root user can read or write data; other users are 
not allowed access. 

Admin Read Only Indicates that the Avamar server is in an 
administrative read-only state in which the Avamar 
server or root user can read data; other users are 
not allowed access. 

Degraded Indicates that the Avamar server has experienced 
a disk failure on one or more nodes. All operations 
are allowed, but immediate action should be taken 
to fix the problem.

Inactive Indicates that Avamar Administrator was unable to 
communicate with Avamar server. 

Node Offline Indicates that one or more Avamar server nodes 
are in an OFFLINE state.

Read Only Indicates that the Avamar server is in a read-only 
administrative state in which all users can read 
data, but writing data is not allowed. 

Suspended Indicates that Avamar Administrator was able to 
communicate with the Avamar server, but normal 
operations have been temporarily suspended.

Synchronizing Indicates that the Avamar server is in a transitional 
state. It is normal for the server to be in this state 
during startup and for short periods of time during 
maintenance operations.

Unknown State Indicates that Avamar Administrator could not 
determine the Avamar server state.

Clicking the Server status icon or text label displays the Avamar Server 
window Session Monitor pane (tab). From there, you can select 
Actions > Resume Backups/Restores or 
Actions > Suspend Backups/Restores to resume or suspend server 
activities, respectively. 
Refer to Suspending Backups/Restores (page 277) for additional 
information.
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Mouse Shortcuts. The Avamar Administrator user interface supports various 
context-sensitive left-click, right-click and double-click shortcuts.

Right-Clicking All GUI elements that can enable features or functions when 
clicked, have right-click support added to them. However, if 
the GUI element only acts as a navigation mechanism, there is 
no right-click support. For example, the Policy window client 
tree has a right-click pop-up menu because specific features 
and functions become available, based on selection context 
(which node of the tree is selected). 

Double-Clicking For all tables where properties or edit dialog boxes can be 
invoked, double-clicking any row of that table displays the 
appropriate properties or edit dialog box. Additionally, when 
lists are used rather than tables, double-clicking any element 
in those lists displays the appropriate edit dialog box.

Click Column
Heading to Sort

Tables

Clicking any table column heading sorts that display by values 
in that column. For example, double-clicking the Activity 
Monitor State column sorts the entire Activity Monitor display 
by the state of each backup.

Shift-Click
Column Heading
to Reverse-Sort

Tables

Shift-clicking any table column heading reverse-sorts that 
display by values in that column.
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This chapter discusses how to administer Avamar domains, clients and user 
accounts.

Domains and Subdomains
Avamar domains are distinct zones within the 
Avamar server that are used to organize and 
segregate clients. This provides enhanced security 
by allowing administrative user accounts to be 
defined on a domain-by-domain basis. 

It should be understood that Avamar domains are 
completely internal to the Avamar server and 
have nothing to do with Internet domains.

Nested Structure. Domains can be nested to 
create a rich tree structure. Consider the example 
Avamar domain (right).

This root (avamar-1.example.com) domain 
contains three departmental domains 
(Accounting, Engineering and Operations). The 
Operations domain contains Maintenance and 
Shipping subdomains.

It should also be understood that there is no 
functional difference between domains and 
subdomains. “Subdomain” is merely a term that 
refers to any domain nested within another higher level domain.

Hierarchical Management. The real power of domains is that they provide the 
ability to add specific administrators to a specific level on the client tree. These 
domain-level administrators can then manage the clients and policies within that 
domain. 

For example, any administrative user added to our example root (avamar-
1.example.com) domain can administer clients and policies anywhere in the 
system. However, an administrative user added to the Operations domain can only 
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administer clients and policies within that domain and below (including the 
Maintenance and Shipping subdomains); that user cannot administer clients in the 
Accounting or Engineering domains. 

The remainder of this publication assumes that the administrator has logged into 
the root domain. Be aware that if you log into a lower-level domain, you may not 
have access to specific clients, datasets, groups and event management features 
outside that particular domain. 

Special Domains. The following domains are permanent (they cannot be 
deleted or moved) and used for the following special purposes: 

Adding a New Domain
1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Account Management tab.

4. In the tree, select where you want to add the new domain.

MC_RETIRED MC_RETIRED contains clients that have been retired (page 48). 
Its primary purpose is to facilitate restores from retired client 
backups. 

REPLICATE REPLICATE contains replicated data from other servers. Refer 
to Replication (page 333) for additional information.
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5. Select Actions > Account Management > New Domain… or click the 
toolbar icon shown immediately to the left.

The New Domain dialog box appears.

IMPORTANT:  The complete client name and domain path
cannot exceed 63 characters. Therefore, when creating new
domains, try to minimize the number of subdomains you will
use and keep domain names as short as practical.

6. Type the following:

7. Click OK.

A confirmation message appears.

8. Click OK.

The confirmation message closes, the New Domain dialog box closes and 
the new domain appears in the Account Management tree.

FIELD DESCRIPTION

New Domain Name Type the new domain name here.

Contact Optional contact name.

Phone Optional contact telephone number.

Email Optional contact email address.

Location Optional contact location.
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Editing Domain Information
1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Account Management tab.

4. In the tree, select the domain you want to edit.

5. Select Actions > Account Management > Edit Domain… or click the 
toolbar icon shown immediately to the left.

The Edit Domain dialog box appears.

6. Edit the information you want to change.

Refer to Adding a New Domain (page 34) for additional information about 
domain properties and settings.

7. Click OK.

A confirmation message appears.

8. Click OK.

The confirmation message closes and the Edit Domain dialog box closes.
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Deleting a Domain

IMPORTANT:  Deleting a domain also deletes any clients
within that domain. Unless you want to permanently delete
all clients within a domain, you should move the clients to a
new domain (page 50) prior to performing this procedure.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Account Management tab.

4. In the tree, select the domain you want to delete.

5. Select Actions > Account Management > Delete Domain… or click the 
toolbar icon shown immediately to the left.

A message appears asking you to confirm this action.

6. Click Yes to permanently delete this domain.

A second message appears confirming that this action has successfully 
completed.

7. Click OK.

The second confirmation message closes.
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Clients
Avamar clients are networked computers or workstations accessing the Avamar 
server over a network connection. 

Before a client can actually use the Avamar system to back up or restore data, it 
must be added to the system (registered), then activated. 

Registration and
Activation Occur
Asynchronously.

In order to provide maximum flexibility in deploying Avamar clients, registration 
and activation are distinct and separate events that occur asynchronously. 
Although they often occur at nearly the same time, they can also occur hours, 
days or even weeks apart. 

Registration

Client registration is the process of establishing an identity with the Avamar 
server. Once Avamar “knows” the client, it assigns a unique client ID (CID), which 
it will eventually pass back to the client during activation.

There are three ways to register a client:

• Client-side registration
• Interactive server-side registration
• Batch client registration

Client-Side Registration. Following client installation, Avamar Windows clients 
can initiate the registration process by right-clicking the Avamar server tray icon 
and selecting Activate.

During client software installation on Linux and Unix platforms, installers are 
asked whether they want to register the client at that time. 

Both client-side registration methods also activate the client at the same time. For 
this reason, client-side registration is very popular. However, because client-side 
registration uses certain inherited assignments (the client is added to the Default 
Group and must use the default dataset, schedule and retention policy), this 
method may not provide enough control for some sites. Refer to Editing Group 
Properties (page 138) for additional information about group properties such as 
datasets, schedules and retention policies.

Interactive Server-Side Registration. You can also interactively use Avamar 
Administrator to add the client to the system in the desired domain and group. 
This provides a high degree of control (for example, you can assign a specific 
dataset, schedule and retention policy) but can be very time consuming if you 
need to add many clients.

Batch Client Registration. In order to support large sites with many clients, 
Avamar provides a batch client registration feature that allows you to define 
multiple clients by way of a single “client definition” file, then import that file into 
the Avamar server. Batch client registration is very popular at large sites because 
it provides nearly as much control as interactively adding the client using Avamar 
Administrator but is much faster. Refer to Batch Client Registration (page 55) for 
additional information.
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Activation

Client activation is the process of passing the client ID (CID) back to the client, 
where it is stored in an encrypted file on the client filesystem. There are two ways 
to activate a client:

You can wait for the client to initiate activation (for example, right-click 
Avamar system tray icon and select Activate).

You can invite the client to activate with the server using the Avamar 
Administrator Actions > Account Management > Invite Client… 
command.

IMPORTANT:  In order for immediate activation using
Avamar Administrator to succeed, the client must be present
on the network, the Avamar client software must be installed
and running and the Avamar server must be able to resolve
the hostname that was used to register the client. Refer to
Activating a New Client (page 41) for additional information.

NOTE:  HP-UX, Linux and Solaris clients can either be acti-
vated during installation or from Avamar Administrator.
There is no client-side command for initiating client activa-
tion on these computing platforms.

Adding a New Client
1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Account Management tab.
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TIP:  In the Account Management tree, client status is
shown as follows: disabled clients have an x placed next to
their icon, unregistered clients have question mark placed
next to their icon and active clients have no special icon des-
ignation.

4. In the tree, select the domain to which you want to add this client.

5. Select Actions > Account Management > New Client… or click the 
toolbar icon shown immediately to the left.

The New Client dialog box appears.

6. For Client Type, select Normal.

NOTE:  VMware vCenter, Image Proxy and Virtual Machine
client types are discussed in another publication. Refer to
your Avamar VMware Guide for additional information.

7. Select or type the following:

8. Click OK.

A confirmation message appears.

9. Click OK.

The confirmation message closes, the New Client dialog box closes and the 
new client appears in the Account Management tree.

FIELD DESCRIPTION

New Client Name Type the new client name here.
IMPORTANT:  The complete client name and 
domain path cannot exceed 63 characters. 
Therefore, when adding new clients, try to keep 
client names as short as practical.

Contact Optional contact name.

Phone Optional contact telephone number.

Email Optional contact email address.

Location Optional contact location.
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Activating a New Client
1. Ensure that Avamar client software is installed and running on the client.

2. Start Avamar Administrator (page 21).

3. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

4. Click the Account Management tab.

TIP:  In the Account Management tree, client status is
shown as follows: disabled clients have an x placed next to
their icon, unregistered clients have question mark placed
next to their icon and active clients have no special icon des-
ignation.

5. In the tree, select the client you want to activate.

6. Select Actions > Account Management > Invite Client…

The following status message appears: Client has been sent invitation to 
activate with the server.

7. Click OK.

8. Repeat steps 5 through 7 for each new client you want to activate.
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Editing Client Information

IMPORTANT:  If you intend to change this client’s name,
you must first shut down the Avamar software on the client
computer, change the client name by way of this procedure,
then restart the Avamar client software. This is the only way
to ensure that this client maintains its registration with the
Management Console Server (MCS) database.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Account Management tab.

TIP:  In the Account Management tree, client status is
shown as follows: disabled clients have an x placed next to
their icon, unregistered clients have question mark placed
next to their icon and active clients have no special icon des-
ignation.

4. In the tree, select the client you want to edit.
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5. Select Actions > Account Management > Edit Client… or click the 
toolbar icon shown immediately to the left.

The Edit Client dialog box appears.

6. Edit the information you want to change.

Refer to Adding a New Client (page 39) for additional information about 
client properties and settings.

7. Click OK.

A confirmation message appears.

8. Click OK.

The confirmation message closes and the Edit Client dialog box closes.
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Viewing Client Properties
1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Clients tab.

5. Select the client for which you want to view properties.

Client Properties Summary

COLUMN DESCRIPTION

Client Descriptive client name.

Backups Disabled If yes, backups cannot be performed on this client. 
However, client can restore files as long as a previous 
backup exists in the system. 

Activated If yes, client is activated (page 39).

Domain Avamar domain (page 33) where this client resides.

OS Client computer operating system.

Paging If yes, client has provided Avamar server with a page 
address and port number, thereby allowing it to 
perform on-demand backups and restores, as well as 
allowing Avamar Administrator to browse its filesystem 
during Avamar Administrator-initiated backups and 
restores (page 73).

Version Avamar client software version.

Last Check-in Date and time that Avamar client agent last checked in 
with the Avamar server.
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Encryption Encryption method used for client/server data transfer. 
Choices are:

High Strongest available encryption setting for 
that specific client platform.

Medium Medium strength encryption.

None No encryption.

NOTE:  The exact encryption technology and bit 
strength used for any given client/server connection 
is dependent on a number of factors, including the 
client platform and Avamar server version. Refer to 
your Avamar Product Security Guide for additional 
information.

CID Client ID. Unique identifier for this client in the Avamar 
server. CIDs are assigned during client activation 
(page 38).

COLUMN DESCRIPTION
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Disabling a Client
An Avamar Administrator can disable any client so that it cannot use the Avamar 
server to back up files until it is enabled (page 47). This is typically done to place 
the system in a state that will support various maintenance activities.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Clients tab.

5. Select the client you want to disable.

6. Select Actions > Client > Disable all backups of selected client.

This sets the Disable all backups of selected client option on the 
Actions > Client menu.

A confirmation message appears.

7. Click Yes to disable this client.
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Enabling a Client
If a client has previously been disabled (page 46), it must be reenabled before it 
can resume backups.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Clients tab.

5. Select the client you want to enable.

6. Select Actions > Client > Disable all backups of selected client.

This clears the Disable all backups of selected client option on the 
Actions > Client menu.

A confirmation message appears.

7. Click Yes to enable this client.
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Retiring a Client
Retiring a client is less destructive than deleting it (page 51). Retired clients do 
not actively participate in the Avamar system with regular backups. However, old 
backups associated with a retired client are maintained in the system (subject to 
backup retention settings) and files can still be restored using Avamar 
Administrator (page 73).

1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Account Management tab.

TIP:  In the Account Management tree, client status is
shown as follows: disabled clients have an x placed next to
their icon, unregistered clients have question mark placed
next to their icon and active clients have no special icon des-
ignation.

4. In the tree, select the client you want to retire.

5. Select Actions > Account Management > Retire Client… or click the 
toolbar icon shown immediately to the left.

The Retire Client dialog box appears.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  48



 Retiring a Client
DOMAINS, CLIENTS AND USERS
6. Do one of the following:

7. Click OK.

A confirmation message appears.

8. Click Yes to retire this client.

The Retire Client dialog box closes and the client no longer appears in the 
Account Management tree.

IF DO THIS

You want to keep backups for 
this client until their existing 
expiration dates.

Select the Retire client and retain 
backups with existing expiration 
date option.

You want to keep all backups for 
this client indefinitely, regardless 
of the existing backup expiration 
dates.

Select the Retire client and retain 
all backups indefinitely option.

You want to keep backups for 
this client but select a new 
expiration date.

Select the Retire client and reset 
backup expiration date option and 
select a new backup expiration date.
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Moving a Client to a New Domain
1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Account Management tab.

TIP:  In the Account Management tree, client status is
shown as follows: disabled clients have an x placed next to
their icon, unregistered clients have question mark placed
next to their icon and active clients have no special icon des-
ignation.

4. In the tree, select the client you want to move.

5. Select Actions > Account Management > Move Client… or click the 
toolbar icon shown immediately to the left.

The Move Client dialog box appears.

6. Select the domain to which you want to move this client.

7. Click OK.

The Move Client dialog box closes and the client appears under the new 
domain.
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Deleting a Client

IMPORTANT:  Deleting a client permanently deletes all
backups stored for that client. Therefore, you should only
delete a client when you are absolutely certain that there is
no reason whatsoever to retain the backups. If there is any
doubt, retire the client (page 48) instead.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Account Management tab.

TIP:  In the Account Management tree, client status is
shown as follows: disabled clients have an x placed next to
their icon, unregistered clients have question mark placed
next to their icon and active clients have no special icon des-
ignation.

4. In the tree, select the client you want to delete.

5. Select Actions > Account Management > Delete Client… or click the 
toolbar icon shown immediately to the left.

A message appears asking you to confirm this action.

6. Click Yes to delete this client and all backups.

A second message appears confirming that this action has successfully 
completed.

7. Click OK.

The second confirmation message closes.
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Changing Client Paging Settings
Paging settings are used for communication between the MCS and the client. 
Avamar Administrator offers two distinct client paging modes:

NOTE:  Paging settings are completely independent of the
method used to register (page 38) or activate (page 39) the
client.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

Automatic Automatic is the default mode. When paging is set to Automatic, 
the MCS attempts to automatically determine appropriate paging 
settings for client. If it is successful in doing so, the MCS sets the 
Enabled option and populates the Address and Port Number fields 
with the hostname or IP address and data port values, respectively. 
In automatic mode, these fields are read only.
In automatic mode, if the MCS receives updated paging 
information from the client, it automatically updates these fields 
with the new values.

Manual When paging is set to Manual, the Enabled option can be cleared 
to turn off automatic client paging and the Address and Port Number 
fields will accept new entries.
Turning off automatic client paging (by clearing the Enabled option) 
is useful for supporting clients that might be off the network for 
extended periods of time, as can be the case with laptop computers. 
If client paging is turned off, these clients must initiate their own on-
demand backups in order to protect their data. For this reason, 
client paging should be turned on (enabled) whenever possible.
If Network Address Translation (NAT) is used at your site, the MCS 
probably will not be able to automatically determine the correct 
client paging settings. If this is the case, set the paging mode to 
manual and type the correct IP address and data port in the 
Address and Port Number fields, respectively.
In manual mode, the MCS never overwrites the Address and Port 
Number settings.
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4. Click the Clients tab.

5. Select the client for which you want to change paging settings.

6. Select Actions > Client > Edit Client… or click the toolbar icon shown 
immediately to the left.

The Edit Client window appears.

7. Click the Properties tab.

8. Do one of the following:

IF DO THIS

The paging mode is currently 
manual and you want to revert 
back to automatic mode.

Select the Automatic option, 
then go directly to step 10.
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9. Type the following:

10.Click OK.

The Edit Client window closes.

The paging mode is currently 
automatic and you want to 
specify your own paging settings.

Select the Manual option, 
then go to step 9.

FIELD DESCRIPTION

Address Type a valid (un-NAT’d) IP address for this client.
IMPORTANT:  If the MCS was unable to automatically 
determine a hostname for this client in automatic mode, 
you will need to type an IP address in this field; a 
hostname will probably not be resolvable.

Port Number Type the data port number for client-MCS 
communications. The default data port is 28002.

IF DO THIS
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Batch Client Registration
In order to support large sites with many clients, Avamar provides a batch client 
registration feature that allows you to define multiple clients by way of a single 
“clients definition” file, then import that file into the Avamar server. 

In order to import multiple clients, you must:

• Create the clients definition file
• Validate and import the clients definition file

Following batch client registration, you can activate these Avamar clients using 
either activation method (page 39). 

Create Clients Definition File

Avamar supports two formats for the clients definition file: 

• Extensible Markup Language (XML)
• Comma-Separated Values (CSV)

XML Format. Extensible Markup Language (XML) clients definition files must 
have a .xml file extension and conform to the following structure and format:

<?xml version="1.0" encoding="UTF-8" ?>
<registration_stream>

<registrants>
<entry

host_name="MyClient.Example.com"
mcs_domain="clients"
mcs_group="MyGroup"
dataset="MyDataset"
retention_policy="MyRetentionPolicy"
contact_address="192.168.31.5"
contact_port="28002"
access_list="user1@avamar:password, user2@LDAP"
encryption="high"
encryption_override="false"

/> 
</registrants>

</registration_stream>

NOTE:  The previous clients definition file is shown for refer-
ence purposes only. Do not attempt to cut and paste this
example into your clients definitions file. Invisible formatting
characters will prevent you from successfully doing so.

Each client is defined using a separate “entry” element. Attributes are:

ELEMENT DESCRIPTION

host_name Network hostname or IP address for this client.

mcs_domain Optional Avamar domain you want to add this client to; 
overrides default domain (clients).
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mcs_group Optional default group this client will be added to; 
overrides assignment to the Default Group. 
Refer to Groups and Group Policies (page 128) for 
additional information.

dataset Optional default dataset this client will use during 
backups; overrides default dataset that would normally 
be inherited from the group.
Refer to Datasets (page 100) for additional information.

retention_policy Optional default backup retention policy for this client; 
overrides default retention policy that would normally be 
inherited from the group. 
Refer to Retention Policies (page 119) for additional 
information.

contact_address Optional client IP address. 

contact_port Set this to 28002, the default Avamar data port. 

access_list Optional list of users who can access the Avamar server 
from this client. The format is:

USER@AUTHENTICATION:password
If using the internal Avamar authentication system, the 
actual word “password” must follow the colon. This will 
cause the system to prompt users for authentication 
when they access the system.
If using an external authentication system, omit 
“:password.”
If defining multiple users, separate each user entry with 
a comma (,) and enclose the entire list of users in 
double-quotes.

encryption Encryption method used for client/server data transfer. 
Choices are:

High Strongest available encryption setting for that 
specific client platform.

Medium Medium strength encryption.

None No encryption.

NOTE:  The exact encryption technology and bit 
strength used for any given client/server connection is 
dependent on a number of factors, including the client 
platform and Avamar server version. Refer to your 
Avamar Product Security Guide for additional 
information.

encryption_override Optional encryption override. If TRUE, this client does 
not use the group encryption method.

ELEMENT DESCRIPTION
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TIP:  Optional elements may be completely omitted from an
XML clients definition file.

CSV Format. Comma-Separated Values (CSV) clients definition files use the 
same element and attribute names as the XML format. However, each client is 
defined on a single line and each attribute value is separated by a comma as 
follows:

host_name,mcs_domain,mcs_group,dataset,retention_policy,contact_address,
contact_port,access_list,encryption,encryption_override

IMPORTANT:  Space limitations in this publication prevent
showing a client entry as it should appear (on a single line).
However, your CSV file must define each client on a single
line — no line feeds or carriage returns are allowed within a
client entry. Actual values must be supplied in place of the
attribute names and NULL must be specified for fields that
have no value (you cannot leave them blank).

NOTE:  The previous clients definition file is shown for refer-
ence purposes only. Do not attempt to cut and paste this
example into your clients definitions file. Invisible formatting
characters will prevent you from successfully doing so.

Validate and Import Client Definition File

1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Account Management tab.
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4. Select Actions > Account Management > Import Multiple Clients…

The Validate dialog box appears. 

5. Browse to your saved clients definition file and select it.

6. Click Validate.

The Validation Results dialog box appears.

7. Do one of the following:

The Validation Results dialog box closes and the new clients appear in the 
Account Management tree.

IF DO THIS

Your clients definition file 
contains errors.

Correct the errors, resave the file 
and repeat steps 1 through 6.

Your clients definition file is 
error-free.

Click Commit to import your client 
list.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  58



 Users and Roles
DOMAINS, CLIENTS AND USERS
Users and Roles
This topic introduces the concepts of users and roles. This material should be read 
and understood before adding new user accounts, or modifying any of the default 
user accounts.

Users
In the Avamar system, user accounts can be added to domains (in order to 
administer that domain and any subdomains beneath it) or individual clients (in 
order to perform backups and restores of that client and access backups belonging 
to that client in the system).

Avamar user accounts comprise the following pieces of information:

• Username

• Authentication system

• Role

Username. The username must be in the format your authentication system 
accepts. For example, the internal Avamar authentication system uses case-
sensitive usernames, whereas Windows Active Directory usernames are case-
insensitive. 

IMPORTANT:  Usernames cannot be longer than 31 charac-
ters.

Authentication System. An authentication system is a username/password 
system that is used to grant users access to the Avamar server. Avamar supports 
its own internal authentication system (“avs”), as well as several external 
authentication systems such as Network Information Service (NIS), Open 
Lightweight Directory Access Protocol (OpenLDAP) and Windows Active Directory.

Roles are discussed in greater detail elsewhere in this publication. Refer to Roles 
(page 60) for additional information.

User Access Lists. In Avamar, users are not reusable objects; they are simply 
entries in a domain or client access list. When you add a new user account to the 
Avamar system, you are actually adding a new entry to the domain or client user 
access list. Consider the following example:

User “Gretchen” has been added to both the Accounting domain and her 
computer. However, the authentication system and role are different. These are in 
fact two completely separate user accounts that happen to have the same 
username.
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Roles

Roles define various allowable operations for each user account. The are three 
basic categories of roles:

• Administrator roles
• Operator roles
• User roles

Administrator Roles. Administrators are generally responsible for maintaining 
the system. 

The role of administrator can only be assigned to user accounts at a domain level; 
this role cannot be assigned to user accounts at a client level. The role of 
administrator can be assigned to user accounts at the top-level (root) domain, or 
any other domain or subdomain.

Operator Roles. Operator roles are generally implemented to allow certain 
users limited access to certain areas of the system in order to perform backups 
and restores, or obtain status and run reports. These roles allow greater freedom 
in assigning backup, restore and reporting tasks to persons other than 
administrators. 

As with administrator roles, operator roles can only be assigned to user accounts 
at the domain level; these roles cannot be assigned to user accounts at the client 
level. Furthermore, in order to add the user account to subdomains, you must 
have administrator privileges on the parent domain or above.

There are four operator roles:

• Restore only operator
• Back up only operator
• Back up/restore operator
• Activity operator

Users who have been assigned an operator role will not have access to the entire 
Avamar Administrator application. Instead, following login, they will be presented 
with a single window, which provides easy access to the specific features they are 
allowed to use.

Root
Administrators

Administrators at the top-level (root) domain have full control of 
the system. They are sometimes referred to as “root 
administrators.”

Domain
Administrators

Administrators at lower level domains (other than root) 
generally have access to most of the features described in this 
publication, but typically can only view or operate on objects 
(backups, policy objects, user accounts and so forth) within that 
domain. Any activity that might allow a domain administrator to 
view data outside that domain is disallowed. Therefore, access 
to server features of a global nature (for example, suspending 
or resuming scheduled operations, changing run times for 
maintenance activities and so forth) is disallowed. 
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Restore OnlyOperator

Restore only operators are generally only allowed to perform restores and to 
monitor those activities to determine when they complete and if they 
completed without errors. 

As with roles assigned to other domain user accounts, restore only operators 
at the top-level (root) domain can perform restores for any client in the 
system; restore only operators at lower level domains (other than root) can 
only perform restores for clients within that domain.

In order to enforce these constraints, restore only operators will not have 
access to the full Avamar Administrator application. Instead, following login, 
restore only operators will be presented with the following window, which 
provides easy access to the specific features they are allowed to use.

Restore only operators can perform the following tasks within the allowable 
domain:

• Perform a Restore (page 84)
• Monitor Activities (page 76)
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Back Up OnlyOperator

Back up only operators are generally only allowed to perform backups and to 
monitor those activities to determine when they complete and if they 
completed without errors. 

As with roles assigned to other domain user accounts, back up only operators 
at the top-level (root) domain can perform backups for any client or group in 
the system; back up only operators at lower level domains (other than root) 
can only perform backups for clients or groups within that domain.

In order to enforce these constraints, back up only operators will not have 
access to the full Avamar Administrator application. Instead, following login, 
back up only operators will be presented with the following window, which 
provides easy access to the specific features they are allowed to use.

Back up only operators can perform the following tasks within the allowable 
domain:

• Perform On-Demand Client Backups (page 74)
• Monitor Activities (page 76)
• Initiate On-Demand Group Backups (page 165)
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Back Up/Restore Operator

Back up/restore operators are generally only allowed to perform backups or 
restores and to monitor those activities to determine when they complete and 
if they completed without errors. 

As with roles assigned to other domain user accounts, back up/restore 
operators at the top-level (root) domain can perform backups and restores for 
any client or group in the system; back up/restore operators at lower level 
domains (other than root) can only perform backups and restores for clients or 
groups within that domain.

In order to enforce these constraints, back up/restore operators will not have 
access to the full Avamar Administrator application. Instead, following login, 
back up/restore operators will be presented with the following window, which 
provides easy access to the specific features they are allowed to use.

Back up/restore operators can perform the following tasks within the allowable 
domain:

• Perform On-Demand Client Backups (page 74)
• Monitor Activities (page 76)
• Perform a Restore (page 84)
• Initiate On-Demand Group Backups (page 165)
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ActivityOperator

Activity operators are generally only allowed to monitor backup and restore 
activities and create certain reports. 

Activity operators at the top-level (root) domain can view or create reports for 
backup and restore activities within the entire system (all domains and 
subdomains); activity operators at lower level domains (other than root) can 
only view or create reports for backup and restore activities within that 
domain.

In order to enforce these constraints, activity operators will not have access to 
the full Avamar Administrator application. Instead, following login, activity 
operators will be presented with the following window, which provides easy 
access to the specific features they are allowed to use:

Activity operators can perform the following tasks within the allowable domain:

• Monitor Activities (page 76)
• View the Group Status Summary (page 148)
• View the Activity Report (page 209)
• View the Replication Report (page 214)
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User Roles. User roles are always assigned to a user account for a specific 
client. As such, allowable operations are inherently constrained to that specific 
client.

IMPORTANT:  Users assigned any of the following roles
cannot log into Avamar Administrator. 

There are four user roles: 

Back Up Only
User

Users assigned this role can initiate backups directly from the 
client using the avtar command line.

Restore (Read)
Only User

Users assigned this role can initiate restores directly from the 
client using the avtar command line or Avamar Web Services.

Back Up/
Restore User

Users assigned this role can initiate backups and restores 
directly from the client using the avtar command line or 
Avamar Web Services.

Restore (Read)
Only/Ignore File

Permissions

This role is similar to the Restore (Read) Only User role except 
that operating system file permissions are ignored during 
restores, thereby effectively allowing this user to restore any 
file stored for that Avamar client.
All Windows client user accounts should be assigned this role in 
order to ensure trouble-free restores.
This role is only available when external authentication is used.
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Adding a New User to a Client

IMPORTANT:  You cannot add any new user accounts to cli-
ents within the MC_RETIRED domain.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Account Management tab.

4. In the tree, select the client to which you want to add the new user.

5. Select Actions > Account Management > New User(s)… or click the 
toolbar icon shown immediately to the left.

The New User dialog box appears.
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6. Type or select the following:

7. Click OK.

A confirmation message appears.

8. Click OK.

The confirmation message closes, the New User dialog box closes and the 
new user appears in that client’s list of users.

FIELD/OPTION DESCRIPTION

Authentication 
System

Select either the default internal Avamar 
Authentication System, or any external 
authentication system you have configured to work 
with Avamar.

Everyone Select this option if you want to designate roles for 
all users on this client.
This field is not used if you are using the internal 
Avamar authentication system.

User Name Select this option and type the new username.
IMPORTANT:  If you are using an external 
authentication system, this must be the username 
you use to log into that system.
IMPORTANT:  Usernames cannot be longer than 
31 characters.

Role Select a role (page 60) for this user.

Password Type your password. 
If using the internal Avamar authentication system, 
Avamar passwords are case-sensitive and must:

• Be 6-12 characters in length
• Contain only alphanumeric, hyphen, period or 

underscore characters
• Contain at least one alphanumeric character

This field is not used if you are using an external 
authentication system.

Confirm Retype your password to confirm that you did not 
type it incorrectly in the Password field.
This field is not used if you are using an external 
authentication system.
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Adding a New User to a Domain

TIP:  Prior to adding this user account, review Roles (page
60) to ensure that this user is assigned the correct role.

IMPORTANT:  You cannot add any user accounts to the
MC_RETIRED domain.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Account Management tab.

4. In the tree, select the domain to which you want to add the new user.

5. Select Actions > Account Management > New User(s)… or click the 
toolbar icon shown immediately to the left.

The New User dialog box appears.
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6. Type or select the following:

7. Click OK.

A confirmation message appears.

8. Click OK.

The confirmation message closes, the New User dialog box closes and the 
new user appears in that domains list of users.

FIELD/OPTION DESCRIPTION

Authentication 
System

Select either the default internal Avamar 
Authentication System, or any external 
authentication system you have configured to work 
with Avamar.

Everyone Select this option if you want to designate roles for 
all users on this client.

User Name Select this option and type the new username.
IMPORTANT:  If you are using an external 
authentication system, this must be the username 
you use to log into that system.
IMPORTANT:  Usernames cannot be longer than 
31 characters.

Role Select a role (page 60) for this user.

Password Type your password. 
If using the internal Avamar authentication system, 
Avamar passwords are case-sensitive and must:

• Be 6-12 characters in length
• Contain only alphanumeric, hyphen, period or 

underscore characters
• Contain at least one alphanumeric character

This field is not used if you are using an external 
authentication system.

Confirm Retype your password to confirm that you did not 
type it incorrectly in the Password field.
This field is not used if you are using an external 
authentication system.
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Editing User Information
1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Account Management tab.

TIP:  In the Account Management tree, client status is
shown as follows: disabled clients have an x placed next to
their icon, unregistered clients have question mark placed
next to their icon and active clients have no special icon des-
ignation.

4. In the tree, select the domain or client containing the user you want to 
edit.

5. Select the user you want to edit from the user data table.

6. Select Actions > Account Management > Edit User… or click the 
toolbar icon shown immediately to the left.

The Edit User dialog box appears.
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7. Edit the information you want to change.

Refer to Adding a New User to a Client (page 66) for additional information 
about user account properties and settings.

8. Do one of the following:

9. Click OK.

A confirmation message appears.

10.Click OK.

The confirmation message closes, the Verify Info dialog box closes, the Edit 
User dialog box closes and the user data table shows the updated 
information.

IF DO THIS

You want to change this 
user’s password.

Click Set Password.
The Set Password dialog box appears.
Type the new password into both the New 
Password and Confirm Password fields.
Click OK.
The Set Password dialog box closes.

You do not want to change 
this user’s password.

Go directly to step 9.
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Deleting a User
1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Adinistration launcher 
button.

The Administration window appears.

3. Click the Account Management tab.

4. In the tree, select the domain or client containing the user you want to 
delete.

5. Select the user you want to delete from the user data table.

6. Select Actions > Account Management > Delete User… or click the 
toolbar icon shown immediately to the left.

A message appears asking you to confirm this action.

7. Click Yes to permanently delete this user.

A second message appears confirming that this action has successfully 
completed.

8. Click OK.

The second confirmation message closes.
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After a client has been activated (page 38), you can perform “on-demand” client 
backups and file restores directly from Avamar Administrator.

TIP:  You can also automate backups by implementing a
group policy to perform regularly scheduled backups for an
entire group of clients. Refer to Groups and Group Policies
(page 128) for additional information.

Backup Retention Settings. When a backup is taken, its retention settings 
control how long it will be kept before it is purged. Possible retention settings are:

• No end date (keep backup indefinitely)
• Keep backup for a specific number of days, weeks, months or years
• Keep backup until a specific calendar date

Retention Types. In order to support certain advanced features, Avamar 
Administrator automatically assigns one or more retention types to every backup. 
For example, the very first backup created on Avamar system will be tagged as a 
daily, weekly, monthly and yearly. You can also manually change the retention 
types assigned to a backup after it resides in the system. 

Validating Backups. You can also verify that files can be restored from an 
existing backup. This validation initiates a “virtual” restore of all files in the backup 
but does not actually restore any files to the client filesystem.

A Word About International Characters. Avamar generally supports the use 
of specific supported international characters in directory, folder and filenames. 
However, proper display of international language characters is contingent on the 
client computer Java locale and installed system fonts being compatible with the 
original language. If you attempt to browse backups that were created with 
international characters and you do not have a compatible font installed on your 
system, any characters that cannot be resolved by the system will be displayed as 
rectangles. This is a normal limitation of that particular situation and does not 
affect the ability to restore these directories, folders or files. Refer to your Avamar 
Release Notes for additional international language support information.
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Performing an On-Demand Client Backup
1. Start Avamar Administrator (page 21).

2. Select Navigation > Backup and Restore or click the 
Backup & Restore launcher button.

The Backup and Restore window appears. 

3. Click the Select for Backup tab.

4. Select a Client in the clients tree.

That client filesystem appears as a browsable directory tree immediately to 
the right of the Clients tree. Placing a check mark next to a directory or file 
selects it for backup. 

5. Select one or more directories and files.

TIP:  Select Actions > Preview List... to view a summary
of all directories and files you have just selected for an on-
demand backup.

6. Select Actions > Backup Now… or click the toolbar icon shown 
immediately to the left.

The On Demand Backup Options dialog box appears.
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7. Review your backup settings.

Clicking Cancel returns you to the Backup and Restore window where you 
can modify your backup selections.

8. Select the client plugin (page 19) you want to use for this backup. 

Retention Policy Settings control how long this backup will be kept for 
potential restores. 

9. If you want to change your backup retention setting, select or type the 
following:

10.Select the encryption method you want to use for client/server data 
transfer during this backup.

Choices are:

TIP:  If you want to include plugin options with this backup,
click More Options..., then select or clear the desired
options and type values where applicable. 

Refer to Appendix B — Plugin Options (page 479) for addi-
tional information about plugin options.

11.Click OK.

The On Demand Backup Options dialog box closes and the following status 
message appears: Backup initiated.

12.Click OK.

FIELD/OPTION DESCRIPTION

Retention period If you want this backup to be deleted from the 
Avamar server after a specific number of days, 
weeks, months or years, select this option and 
type the number of days, weeks, months or years.

End date If you want this backup to be deleted from the 
Avamar server on a specific calendar date, select 
this option and browse to that date on the 
calendar.

No end date If you want to keep this backup for as long as this 
client remains active in the Avamar server, select 
this option.

High Strongest available encryption setting for that specific client 
platform.

Medium Medium strength encryption.

None No encryption.

NOTE:  The exact encryption technology and bit strength used for any 
given client/server connection is dependent on a number of factors, 
including the client platform and Avamar server version. Refer to your 
Avamar Product Security Guide for additional information.
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Monitoring Backup, Restore and Validation Activities
1. Start Avamar Administrator (page 21).

2. Select Navigation > Activity or click the Activity launcher button.

The Activity window appears.

3. Click the Activity Monitor tab.

By default, the Activity Monitor tab shows the most recent 5,000 client 
activities during the past 72 hours. 

TIP:  You can increase or reduce the amount of information
shown in the backup activity monitor by manually modifying
the value stored in the 
/usr/local/avamar/var/mc/server_data/prefs/mcserver.xml
com.avamar.mc.wo completed_job_retention_hours prefer-
ence, then restarting the MCS (page 290).
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Activity Window Information

COLUMN DESCRIPTION

S
E

S
S

IO
N

Status One of the following:

Canceled Activity was cancelled, either by the 
client or from Avamar Administrator.

Client Backup 
Disabled

All client-initiated backups have 
been turned off (disabled) for this 
plugin. Refer to Avamar Client Agent 
and Plugin Management (page 227) 
for additional information.

Completed Activity successfully completed.

Completed w/
Exception(s)

Activity completed with minor errors 
or warnings.

Double-click entry to view full error 
log, which contains the activity 
failure codes.

Dropped 
Session

Activity was successfully initiated but 
because MCS could not detect any 
progress, the activity was forcefully 
cancelled.

Failed Client failed to perform the activity; 
activity ended in an error condition.

Double-click entry to view full error 
log, which contains the activity 
failure codes.

Fault Tolerant Backup failed because virtual 
machine client is running in fault 
tolerance mode. 

If you want to backup this virtual 
machine while in fault tolerance 
mode, install the correct type and 
version Avamar client software and 
use guest backups to protect the 
data.

No Client 
Contact

Scheduled client did not check in.

No Data Dataset did not define any data to 
back up or client does not have 
matching data to backup.
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S
E

S
S

IO
N

Status - continued No proxy Failed to initiate a backup or restore 
for a virtual machine because no 
proxy was found to service the 
virtual machine.
Verify that proxy clients have the 
desired datastores checked for 
protection. The proxy client 
datastores checked must match 
datastores for virtual machines 
requiring protection. 
Additionally, for scheduled group 
backups, also verify that the group 
has desired proxies checked for 
protection of virtual machines 
belonging to the group. 
Verify proxy clients are powered on, 
enabled, and registered. 
For restores, verify there is an 
available proxy in the destination 
datacenter.

No Status Activity is not progressing as 
expected and Avamar server cannot 
provide status.

No vm Activity failed because virtual 
machine client does not exist in 
vCenter.

Option 
Incompatibility

Activity failed due to incompatible 
plugin option specified.
This is often due to using an older 
client version that does not support 
a particular plugin option. 

Partial 
Replication

Plugin Disabled All operations have been turned off 
(disabled) for this plugin. Refer to 
Avamar Client Agent and Plugin 
Management (page 227) for 
additional information.

Restore 
Disabled

All restore operations have been 
turned off (disabled) for this plugin. 
Refer to Avamar Client Agent and 
Plugin Management (page 227) for 
additional information.

Retention date 
expired

Backup failed because retention 
policy has already expired (that is, 
retention policy is set to a past 
date).

COLUMN DESCRIPTION
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S
E

S
S

IO
N

Status - continued Running Client is performing the activity.

Scheduled 
Backup 
Disabled

All scheduled backups have been 
turned off (disabled) for this plugin. 
Refer to Avamar Client Agent and 
Plugin Management (page 227) for 
additional information.

Stalled Activity is not progressing as 
expected. Because Avamar server 
can provide status, problem is 
assumed to be on the client.

Suspended Activity has been suspended (work 
order suspended).

Timed Out - 
End

Client did not complete the activity 
in the allotted time. 

Timed Out - 
Response

Client checked in and was sent 
backup activity but did not 
acknowledge.

Timed Out - 
Start

Activity failed to start (work order 
start time-out).

Undefined Activity does not have a work order 
associated with it.

Unknown Activity was passed an unknown exit 
code from the client agent.

Unsupported 
backup

Some aspect of this backup activity 
is not supported. For example, 
attempting to back up a VMware 
proxy client with a VMware Image 
backup dataset will return a status of 
Unsupported.

Validate 
Disabled

All backup validation operations 
have been turned off (disabled) for 
this plugin. Refer to Avamar Client 
Agent and Plugin Management (page 
227) for additional information.

Error Code If the activity did not successfully complete, a numeric 
error code will be shown. Double-click the error code 
to view a detailed explanation.

Start Time Date and time this activity was initiated, adjusted for 
the prevailing time zone (shown in parentheses).

Elapsed Time Elapsed time for this activity. 

End Time Date and time this activity completed, adjusted for the 
prevailing time zone (shown in parentheses).

COLUMN DESCRIPTION
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S
E

S
S

IO
N

Type This activity is one of the following:
• On-Demand Backup (page 74)
• Scheduled Backup (page 109)
• Restore (page 84)
• Validate (page 92)
• Replication Source
• Replication Destination

NOTE:  Replication is an optional feature that might 
not be available to all users. 

Progress Bytes Total number of bytes examined during this activity.

New Bytes Percentage of new bytes backed up. Low numbers 
indicate high levels of data deduplication.

C
L

IE
N

T

Client Avamar client name.

Domain Full location of the client in the Avamar server.

OS Client operating system.

Client Release Avamar client software version.
NOTE:  If this activity is a VMware image backup or 
restore, this is Avamar client software version running 
on the image proxy client.

Proxy If this activity is a VMware image backup or restore, 
this is the name of the proxy client performing the 
backup or restore on behalf of the virtual machine.
It is blank for all other activities.

P
O

L
IC

Y

Sched. Start Time Date and time this activity was scheduled to begin.

Sched. End Time Date and time this activity was scheduled to end.

Elapsed Wait Total amount of time this activity spent in the activity 
queue (that is, scheduled start time minus actual start 
time).

Group If the activity was a scheduled backup, this is the 
group that this client was a member of when this 
particular scheduled activity was initiated (clients can 
be members of more than one group). On-demand is 
shown for all other activities.

Plug-in Plugin (page 19) used for this activity.

COLUMN DESCRIPTION
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TIP:  You can also reduce the amount of displayed informa-
tion by “filtering” the Activity display to only show backups
with a specific state, type, group, client or plugin.

4. Select Actions > Filter… or click the toolbar icon shown immediately to 
the left.

The Filter Activity dialog box appears.

5. Define your filtering criteria and click OK.

The Filter Activity dialog box closes and the Activity Monitor shows only 
those backups that meet your filtering criteria.

TIP:  Click Reset Filter to clear any previous filter settings.

P
O

L
IC

Y

Retention Retention types (page 73) assigned to this backup. 
One or more of the following:

D Backup has been tagged as a daily backup.

W Backup has been tagged as a weekly backup.

M Backup has been tagged as a monthly backup.

Y Backup has been tagged as a yearly backup.

N Backup has been tagged as having no specific 
retention type.

Schedule If the activity was a scheduled backup, this is the 
schedule that initiated this activity. 
On-Demand or End User Request is shown for all other 
activities initiated from Avamar Administrator or the 
client, respectively.

Dataset Name of the dataset used to take the backup. 
If activity is a replication job (page 333), this column 
lists the source system name on the destination 
system and the destination name on the source 
system. 

WID Work order ID. Unique identifier for this activity.

COLUMN DESCRIPTION
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Select for Restore Overview
The Backup and Restore window Select for Restore tab provides two different 
ways to locate and select a backup stored on the server:

• By calendar date (page 82)
• By content (page 83)

Locating and Selecting a Backup by Calendar Date

In order to locate backups stored on the server 
by calendar date, perform the following:

1. Select a Client in the clients tree.

2. Click the By Date tab.

Clicking the By Date tab displays a 
browsable calendar for locating backups 
in the Avamar server.

Dates highlighted in yellow indicate that 
a backup was performed on that date.

Selecting a valid backup date on the calendar populates the backups list 
immediately to the right of the calendar.

Selecting a backup populates the contents list directly below the Backup 
History pane.

3. In the Backup History pane, browse to a valid backup date in the Calendar 
(highlighted in yellow).

4. Select the backup from which you want to restore directories, folders or 
files.
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Locating and Selecting a Backup by Content

In order to locate backups by content (that is, specific directories, folders or files 
within that backup), perform the following:

1. Select a Client in the clients tree.

2. Click the By File/Folder tab.

Clicking the By File/Folder tab displays a Backup History pane that can be 
used to retrieve all backups that contain a specified client directory, folder 
or file.

3. Do one of the following:

4. Click Retrieve.

The Version History table lists all versions and sizes for that directory, 
folder or file that have been backed up from this client. 

Selecting a row in the Version History table shows all backups for the 
selected client that contains the selected version of the directory, folder or 
file. 

5. Select the backup from which you want to restore directories, folders or 
files.

IF DO THIS

You know the full path to the desired 
client directory, folder or file.

Type that path in the Enter path 
to retrieve history for field.

You do not know the full path to the 
desired client directory, folder or file.

Click Browse and locate the 
desired directory, folder or file.
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Performing a Restore
1. Start Avamar Administrator (page 21).

2. Select Navigation > Backup and Restore or click the 
Backup & Restore launcher button.

The Backup and Restore window appears. 

3. Click the Select for Restore tab.

4. Select a client in the clients tree.

5. Locate and select a backup from which you want to restore directories or 
files.

TIP:  Refer to Locating and Selecting a Backup by Calendar
Date (page 82), Locating and Selecting a Backup by Content
(page 83) for additional information about locating backups
by calendar date or content, respectively.

6. Select one or more directories or files you want to restore.

TIP:  Select Actions > Preview List... to view a summary
of all directories and files you have just selected for an on-
demand restore.
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7. Select Actions > Restore Now… or click the toolbar icon shown 
immediately to the left.

The Restore Options dialog box appears.

8. Review your restore settings.

Clicking Cancel returns you to the Backup and Restore window where you 
can modify your restore selections.

Restore destination choices allows you to specify which client and top-level 
(root) directory will receive the restored files.

9. If you want to change your restore destination choices, select or type the 
following:

FIELD/OPTION DESCRIPTION

Restore Everything 
to its original 
location

Restore Everything to its original location is 
the default destination — all files are restored to 
original client in the original top-level (root) 
directory.

Restore Everything 
to a different 
location

Restore Everything to a different location 
allows you to specify another client or another 
directory on the same client. 
IMPORTANT:  When redirecting a restore to a 
new location (a target directory other than the 
original directory that was backed up), restoring 
a single directory to the new location only 
restores the contents of the directory; the 
original parent directory is not restored as part 
of this operation. However, if you restore two or 
more directories to a new location, then the 
original parent directories do get restored along 
with the contents of those directories.

Browse for Client/
Destination

Click Browse to locate a client or directory for 
the restore. You can also type this information 
directly in the Absolute Destination field. 
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TIP:  If you want to include plugin options with this restore,
click More Options..., then select or clear the desired
options and type values where applicable. 

Refer to Appendix B — Plugin Options (page 479) for addi-
tional information about plugin options.

10.Click OK.

The Restore Options dialog box closes and the following status message 
appears: Restore initiated.

11.Click OK.

Restore Plug-in Type Specifies which client plugin will be used to 
perform this restore. The default selection is the 
same plugin used to take the original backup.

Encryption Method Encryption method used for client/server data 
transfer. Choices are:

High Strongest available encryption setting 
for that specific client platform.

Medium Medium strength encryption.

None No encryption.

NOTE:  The exact encryption technology and bit 
strength used for any given client-server 
connection is dependent on a number of factors, 
including the client platform and Avamar server 
version. Refer to your Avamar Product Security 
Guide for additional information.

FIELD/OPTION DESCRIPTION
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Backup Management Window Overview
The Backup Management window provides the features and functions necessary to 
manage backups on the Avamar server. This includes:

• Changing a Backup Expiration Date (page 88)
• Validating a Backup (page 92)
• Backup Statistics (page 94)
• Deleting a Backup (page 98)

In most cases, you will want to locate one or more backups, belonging to a single 
client so that you can perform one of the previously mentioned tasks.

The Backup Management window provides three ways to locate and select 
backups of interest, by calendar day (page 87), by date range (page 87) or by 
retention type (page 88).

Locating Backups by Calendar Day

In order to locate backups stored on the server 
by a specific calendar day, perform the 
following:

1. Select a client in the Clients tree.

2. Select the By Day option.

The Backup Management window 
provides a browsable calendar for 
locating a specific backup according to 
when it was taken.

Dates highlighted in yellow indicate that a backup was performed on that 
date.

3. Browse to a valid backup date in the Calendar (highlighted in yellow).

Selecting a valid backup date on the calendar populates the Backup History 
list, located below the calendar.

Locating Backups by Date Range

In order to locate backups stored on the server by 
a range of dates, perform the following:

1. Select a client in the Clients tree.

2. Select the By Date Range option.

3. Click the arrow next to From Date and 
browse to the desired date in the Calendar.

4. Click the arrow next to To Date and browse 
to the desired date in the Calendar.

5. Click Retrieve.

The Backup History list, located below the calendar, is populated with 
backups that match this date range.
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Locating Backups by Retention Type

In order to locate backups stored on the server by the 
retention type, perform the following:

1. Select a client in the Clients tree.

2. Select the By Retention option.

3. Select one or more retention type options.

4. Click Retrieve.

The Backup History list, located below the calendar, is 
populated with backups that match this retention type.

Changing a Backup Expiration Date
1. Start Avamar Administrator (page 21).

2. Select Navigation > Backup Management or click the Backup 
Management launcher button.

The Backup Management window appears.

3. Select a Client in the clients tree.

4. Locate and select one or more backups.
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TIP:  Refer to Locating Backups by Calendar Day (page 87),
Locating Backups by Date Range (page 87) or Locating
Backups by Retention Type (page 88) for additional informa-
tion about locating backups by calendar date, content or
retention type, respectively.

TIP:  You can select multiple backups by pressing and hold-
ing CTRL while selecting the desired backups.

5. Select Actions > Change Expiration Date… or click the toolbar icon 
shown immediately to the left.

The Change Expiration Date dialog box appears.

6. Type or select the following:

7. Click OK.

The Change Expiration Date dialog box closes and the following message 
appears: Are you sure you want to change the expiration of the backups?

8. Click Yes.

An event code dialog box appears.

9. Click OK.

FIELD/OPTION DESCRIPTION

Retention period If you want this backup to be deleted from the 
Avamar server after a specific number of days, 
weeks, months or years, select this option and 
select the number of days, weeks, months or 
years.

End date If you want this backup to be deleted from the 
Avamar server on a specific calendar date, 
select this option and browse to that date on the 
calendar.

No end date If you want to keep this backup for as long as 
this client remains active in the Avamar server, 
select this option.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  89



 Changing Backup Retention Types
BACKUP, RESTORE AND BACKUP MANAGEMENT
Changing Backup Retention Types
This topic describes how to change the retention types assigned (page 73) to an 
existing backup. 

IMPORTANT:  When manually changing the retention types
assigned to an existing backup, especially one that has mul-
tiple retention types assigned to it, be certain that you are
not inadvertently removing a weekly, monthly or yearly from
the system that you need to retain. For example, consider a
backup that is assigned daily, weekly, monthly and yearly
retention types. If you remove that yearly retention type
designation, you might not have another yearly backup in
your system for quite a long time. 

1. Start Avamar Administrator (page 21).

2. Select Navigation > Backup Management or click the Backup 
Management launcher button.

The Backup Management window appears.

3. Select a Client in the clients tree.

4. Locate and select one or more backups.

TIP:  Refer to Locating Backups by Calendar Day (page 87),
Locating Backups by Date Range (page 87) or Locating
Backups by Retention Type (page 88) for additional informa-
tion about locating backups by calendar date, content or
retention type, respectively.
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TIP:  You can select multiple backups by pressing and hold-
ing CTRL while selecting the desired backups.

5. Select Actions > Change Retention Type…

The Change Retention Type dialog box appears.

6. Do one of the following:

7. Click OK.

The Change Retention Type dialog box closes and the following message 
appears: Are you sure you want to change the retention type of the 
backup?

8. Click Yes.

A confirmation message appears.

9. Click OK.

IF DO THIS

You want to explicitly assign a daily, 
weekly, monthly or yearly retention 
type to this backup.

Select the Tags option, then 
select one or more retention 
type options.

You want to designate this backup as 
“untagged” (that is, not explicitly 
assigned a daily, weekly, monthly or 
yearly retention type).

Select the Not tagged 
option.
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Validating a Backup
1. Start Avamar Administrator (page 21).

2. Select Navigation > Backup Management or click the Backup 
Management launcher button.

The Backup Management window appears.

3. Select a Client in the clients tree.

4. Locate and select a backup.

TIP:  Refer to Locating Backups by Calendar Day (page 87),
Locating Backups by Date Range (page 87) or Locating
Backups by Retention Type (page 88) for additional informa-
tion about locating backups by calendar date, content or
retention type, respectively.

5. Select Actions > Validate Backup… or click the toolbar icon shown 
immediately to the left.

The Select Client to Perform Validation dialog box appears.
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The default settings are to validate the backup on the same client from 
which the backup was originally taken and to use the same data source 
plugin that was used during the original backup. However, the encryption 
setting for backup validations always defaults to High regardless of the 
encryption setting used for the original backup.

6. Do one of the following:

7. Click OK.

The Select Client to Perform Validation dialog box closes and the following 
status message appears: Backup validation initiated.

8. Click OK.

IF DO THIS

You want to validate the 
backup using the default 
settings.

Proceed directly to step 7.

You want to validate the 
backup using new 
settings.

Select a new client on which to perform the 
validation by setting the Validate using a 
different client option, then clicking 
Browse... and selecting the new client in 
the client tree. 
Select another encryption method to be 
used for client/server data transfer during 
this validation. 
Select a different plugin from the Validate 
Plug-in Type list box. These selections are 
context-sensitive (only those plugins 
installed on the selected client will be 
available).
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Backup Statistics
Various detailed statistics are available for completed backups. You can obtain 
backup statistics two ways:

• From the Backup Management window (page 94)
• From the Activity window (page 96)

It is possible to obtain statistics for any stored backup from the Backup 
Management window. However, the Activity windows only shows recent backup 
activity (that is, typically the most recent backups within the past 72 hours). 
Therefore, if the backup of interest occurred more than 72 hours ago, you must 
obtain those statistics from the Backup Management window.

Viewing Backup Statistics From the Backup Management 
Window

1. Start Avamar Administrator (page 21).

2. Select Navigation > Backup Management or click the Backup 
Management launcher button.

The Backup Management window appears.

3. Select a Client in the clients tree.

4. Locate and select a backup.

TIP:  Refer to Locating Backups by Calendar Day (page 87),
Locating Backups by Date Range (page 87) or Locating
Backups by Retention Type (page 88) for additional informa-
tion about locating backups by calendar date, content or
retention type, respectively.
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5. Select Actions > View Statistics…

The Backup Statistics dialog box appears.

6. Click Close.

The Backup Statistics dialog box closes.

TAB DESCRIPTION

Details Shows detailed information obtained from the 
v_activities_2 database view. Refer to v_activities_2 
(page 565) for additional information.

Files Shows a list of files included in this backup.

File Aggregation Shows a representative sampling of resource-
intensive file types included in this backup and 
summarizes (aggregates) deduplication statistics by 
file type.

Options Shows any special options used to take that backup.

Errors Shows any errors that occurred during that backup.
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Viewing Backup Statistics From the Activity Window

1. Start Avamar Administrator (page 21).

2. Select Navigation > Activity or click the Activity launcher button.

The Activity window appears.

3. Click the Activity Monitor tab.

4. Select a backup activity from the list.

5. Select Actions > View Statistics…

The Backup Statistics dialog box appears.

TAB DESCRIPTION

Details Shows detailed information obtained from the 
v_activities_2 database view. Refer to v_activities_2 
(page 565) for additional information.

Files Shows a list of files included in this backup.

File Aggregation Shows a representative sampling of resource-
intensive file types included in this backup and 
summarizes (aggregates) deduplication statistics by 
file type.
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6. Click Close.

The Backup Statistics dialog box closes.

Options Shows any special options used to take that backup.

Errors Shows any errors that occurred during that backup.

TAB DESCRIPTION
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Deleting a Backup

IMPORTANT:  Deleting a backup from the system immedi-
ately and permanently deletes all data inside that backup. 

1. Start Avamar Administrator (page 21).

2. Select Navigation > Backup Management or click the Backup 
Management launcher button.

The Backup Management window appears.

3. Select a Client in the clients tree.

4. Locate and select a backup.

TIP:  Refer to Locating Backups by Calendar Day (page 87),
Locating Backups by Date Range (page 87) or Locating
Backups by Retention Type (page 88) for additional informa-
tion about locating backups by calendar date, content or
retention type, respectively.

5. Select Actions > Delete Backup… or click the toolbar icon shown 
immediately to the left.

A confirmation message appears.

6. Click OK to permanently delete these backups.
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Canceling an Activity
You can cancel any activity (backup, restore or validation) any time before it 
actually completes. However, it can take up to five minutes to cancel any activity. 
If during this time, the activity completes, it will not be cancelled.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Activity or click the Activity launcher button.

The Activity window appears.

3. Click the Activity Monitor tab.

The Activity Monitor tab shows the most recent 5,000 client activities 
during the past 72 hours. 

4. Select one or more activities you want to cancel.

5. Select Actions > Cancel Activity or click the toolbar icon shown 
immediately to the left.

A message appears asking you to confirm this action.

6. Click Yes to cancel these activities.

NOTE:  If you selected several activities in step 4, a prog-
ress indicator might appear, which will continuously show
what percentage of this task is complete.
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DATASETS, SCHEDULES AND RETENTION POLICIES

Datasets, schedules and retention policies are reusable objects that can be 
assigned to more than one client or group. This “reusability” greatly reduces the 
amount of labor needed to automate and customize the Avamar server to satisfy 
your specific site requirements.

Datasets
In Performing an On-Demand Client Backup (page 74), you were shown how to 
browse a client filesystem and mark certain directories and files for backup. 
However, selections made this way are only valid for that particular backup — 
they are not persistent.

Persistent Selections. Avamar datasets are a list of directories and files that 
will be backed up from a client. Assigning a dataset to a client or group is a way to 
make persistent backup selections.

Dataset Properties

Each dataset defines:

• Source data list
• Exclusion list
• Inclusion list
• Plugin options (page 479)

Source Data List. Dataset definitions always start with a source data list, 
consisting of:

• Data from one or more plugins (page 19)
• A defined filesystem hierarchy (entire filesystem or selected directories) within 

each plugin
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Exclusion and Inclusion Lists. Datasets can also narrow the scope of the 
source data list by explicitly defining certain directories and file types to exclude or 
include in each backup. 

Because default dataset behavior is to include everything in the source data list, 
the explicit exclusion and inclusion lists typically contain only a few entries.

NOTE:  When specifying exclusions and inclusions, case sen-
sitivity will vary according to the target computing platform
you are backing up. Exclusions and inclusions specified for
Windows platforms are not case-sensitive; exclusions and
inclusions specified for most other platforms are case-sensi-
tive.

NOTE:  Inclusion and exclusion lists cannot be defined for
VMware Image Backups.

Processing Relationship. Avamar processes these 
dataset elements in the following order:

• Source data
• Exclusion list
• Inclusion list

First, source data from one or more plugins is defined. The 
default behavior is to include all data from all defined 
plugins.

Next, the exclusion list is used to eliminate certain 
directories and file types from this dataset.

Finally, the inclusion list is used to add back any files that 
were eliminated from the dataset in the exclusion list.

Plugin Options. Plugin options are a way to further 
customize the behavior of a dataset. Refer to Appendix B — 
Plugin Options (page 479) for additional information about 
plugin options. 

AVAMAR
CLIENT AGENT

EXCLUSION
LIST

INCLUSION
LIST

PLUG-IN
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Dataset Catalog

Base Dataset. The Base Dataset defines a set of minimum (baseline) backup 
requirements. The initial settings in the Base Dataset are:

• Use no source data plugins
• No explicit exclusion or inclusion list entries

This is essentially an empty dataset.

Default Dataset. The Default Dataset defines persistent backup selections for 
the Default Group (page 128). The initial settings in the Default Dataset are:

• Use all available source data plugins
• No explicit exclusion or inclusion list entries

This ensures that all members of the Default Group can back up their client 
computers regardless of platform type.

You can modify these settings to meet your specific site requirements. Doing so 
enforces these changes on all members of the Default Group (page 128), unless 
another dataset is assigned at the client level (page 155).

The following directories are also inherently excluded from all backups even 
though they do not explicitly appear in the Exclusion list:

• .snapshot/ (Network Appliance mounts)
• VARDIR/f_cache.dat (local avtar file cache)
• VARDIR/p_cache.dat (local avtar “is present” cache)

Unix Dataset. The Unix dataset is optimized for use with HP-UX, Linux and 
Solaris clients. The initial settings in the Unix Dataset are:

• Use only AIX, HP-UX, Linux, Mac OS X and Solaris filesystem source data 
plugins

• Explicitly exclude various Unix temp directories (/tmp, /var/tmp, 
/usr/tmp), core dump files (core) and local cache (*cache.dat, *scan.dat) 
files

• No explicit inclusion list entries

The following directories are also inherently excluded from all backups even 
though they do not explicitly appear in the Exclusion list:

• .snapshot/ (Network Appliance mounts)
• VARDIR/f_cache.dat (local avtar cache files)
• VARDIR/p_cache.dat (local avtar cache files)
• /proc (pseudo filesystem that cannot be restored)
• /dev (if not running as root)
• /devices (Solaris only)
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Windows Dataset. The Windows Dataset is optimized for use with Microsoft 
Windows clients. 

The initial settings in the Windows Dataset are:

• Use only Windows filesystem plugin source data plugin
• No explicit exclusion or inclusion list entries

The following directories are also inherently excluded from all backups even 
though they do not explicitly appear in the Exclusion list:

• .snapshot/ (Network Appliance mounts)
• VARDIR/f_cache.dat (local avtar cache files)
• VARDIR/p_cache.dat (local avtar cache files)
• All files referenced by the HKEY_LOCAL_MACHINE\SYSTEM\

CurrentControlSet\Control\BackupRestore\FilesNotToBackup registry key 
(files explicitly designated by Microsoft to not be backed up)

• All files referenced by the HKEY_CURRENT_USER\SYSTEM\
CurrentControlSet\Control\BackupRestore\FilesNotToBackup registry key 
(files explicitly designated by Microsoft to not be backed up)

• Temporary Internet files (Internet Explorer temporary files)
• outlook.ost (Outlook local cache files)
• outlook\*.ost (Outlook local cache files)

VMware Image Dataset. The VMware Image Dataset is the default dataset 
that is assigned to the Default Virtual Machine Group (page 129), and other 
vCenter groups (page 129) when they are first added.

The VMware Image Dataset is in many respects simpler than most other datasets:

• The only source data plugins shown are Linux and Windows virtual disks; 
both are selected by default.

• The Select Files and/or Folders option, as well as the Exclusions and 
Inclusions tabs are disabled.

• Change block tracking is enabled by default using an embedded 
utilize_changed_block_list=true plugin option statement.

Refer to your Avamar VMware Guide for additional information about using the 
VMware Image Dataset to back up virtual machine data.
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Creating a New Dataset
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Datasets…

The Manage All Datasets window appears.

3. Click New. 

The New Dataset dialog box appears.

4. Type a name for this new dataset.

IMPORTANT:  Do not use any of the following characters in
your dataset name: ~!@$^%(){}[]|,`;#\/:*?<>'"&.

5. Click the Source Data tab.

The Source Data tab is where you define a list of source data plugins that 
contribute data to this dataset. 
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6. Type or select the following:

The remaining dialog box tabs are used to select optional parameters such 
as exclusion and inclusion list (page 101) entries and plugin options (page 
479). 

If you do not need to select these optional parameters in this dataset, skip 
steps 7 through 11 and go directly to step 12. 

7. Click the Exclusions tab.

The Exclusions tab is where you explicitly define directories and files that 
will not be backed up.

Typical exclusion lists include /temp files and directories and Unix core 
dumps.

NOTE:  Exclusion lists cannot be defined for VMware Image
Backups.

FIELD/OPTION DESCRIPTION

Enter Explicitly Select this option to define which plugins will be used 
by this particular source data entry. 
To add a plugin type to this dataset, select it from 
the list box. 
IMPORTANT:  When creating an explicit dataset, 
first remove any unwanted plugin types by selecting 
each one and clicking -. 

Select Plug-in 
Type

This list is only available when Enter Explicitly is 
selected.
Select a plugin type from the list and click + to add it 
to the plugin list.

Select Files and/
or Folders

This list is only available when Enter Explicitly is 
selected.
If you want this plugin to point to a specific client 
subdirectory (somewhere other than the root 
directory), click ... and browse to the directory 
before you click +.
You can also type the full path to any client directory 
directly in this field. 
IMPORTANT:  Do not use any of the following 
characters in your entry: ~!@$^%(){}[]|,`;#\/
:*?<>'"&.
NOTE:  The Select Files and/or Folders option is not 
available for VMware Image Backups. 

Select All Data 
for All Local File 
Systems

Select this option to include all data on all client 
filesystems. This adds all plugin types to the source 
data list.
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8. Repeat the following for each exclusion list entry you want to add:

(a) Select a plugin type from the Select Plug-in Type list box.

(b) Type a directory name or file type (wildcards are supported) in the 
Select Files and/or Folders field.

(c) Click +.

This entry is added to the exclusion list.

9. Click the Inclusions tab.

The Inclusions tab is where you explicitly define directories and files that 
will be backed up.

NOTE:  The inclusion list is a subset of the exclusion list. You
only need to explicitly include file types that would have oth-
erwise been excluded by way of the exclusion list. Refer to
Processing Relationship (page 101) for additional informa-
tion.

NOTE:  Inclusion lists cannot be defined for VMware Image
Backups.

10.Repeat the following for each inclusion list entry you want to add:

(a) Select a plugin type from the Select Plug-in Type list box.

(b) Type a directory name file type (wildcards are supported) in the Select 
Files and/or Folders field.

(c) Click +.

This entry is added to the inclusion list.

11.Click the Options tab.

The Options tab is where you set various plugin options (page 479).

Plugin options can be set two ways: by using the graphical controls or by 
typing option names and values as free text.

If you want to include plugin options with future backups, select or clear 
the desired options and type values where applicable. 

IMPORTANT:  When typing option names and values as
free text, it must be understood that no error checking or
validation is performed on these free-text entries and that
free text entries override settings made using the graphical
controls.

Refer to Appendix B — Plugin Options (page 479) for additional information 
about plugin options.

12.Click OK.

The New Dataset dialog box closes.
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Editing a Dataset
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Datasets…

The Manage All Datasets window appears.

3. Select a dataset from the list and click Edit. 

The Edit Dataset dialog box appears.

4. Edit the information you want to change.

Refer to Creating a New Dataset (page 104) for additional information 
about dataset properties and settings.

5. Click OK.

The Edit Dataset dialog box closes.

NOTE:  Dataset changes take effect on the next scheduled
backup. Backups that have already begun or have been
completed are not affected. 
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Copying a Dataset
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Datasets…

The Manage All Datasets window appears.

3. Select a dataset from the list and click Copy. 

The Save As dialog box appears.

4. Type a name for the new dataset and click OK.

The Save As dialog box closes.

Deleting a Dataset

IMPORTANT:  You cannot delete a dataset if it is currently
assigned to a client or group.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Datasets…

The Manage All Datasets window appears.

3. Select a dataset from the list and click Delete. 

A confirmation message appears.

4. Click Yes to permanently delete this dataset.
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Schedules
Schedules are reusable objects that control the timing of certain server activities. 
Currently, schedules control:

• When group backups will be taken (page 128)
• When custom event profile email notifications will be sent (page 169)

Important Terms and Concepts

Each schedule inherently defines the following behavior:

• Start time — the earliest time of day this system activity can be initiated
• Duration — the number of hours this system activity will be allowed to run 

before it is terminated, regardless of whether it is finished or not
• Recurrence — how many times per day or week this system activity will be 

initiated
• Effectivity — when this schedule should take effect and when it should be 

discontinued

Start Time, End Time and Duration. In order to understand how start time, 
end time and duration interact with one another, consider the following diagram:

This particular system activity would begin at 10:00 P.M. (22:00) and be allowed 
to run until 6:00 A.M. (06:00) the following morning, creating an effective eight-
hour duration.

NOTE:  This diagram shows the initial settings of the Default
schedule (page 113).

In actual practice, scheduled activities rarely start or end precisely on time. Actual 
start times are affected by server load; actual end times are affected by the 
complexity of the activity (for example, the amount of new client data that must 
be backed up, the number of group backups initiated, the number of email 
messages that must be sent and so forth).

Earliest Start Time and Latest End Time. It must therefore be understood 
that specifying a schedule start time means that this is the earliest possible time 
that this particular system activity can begin and that specifying a duration or end 
time establishes the latest possible end time for this particular system activity.

BACKUP WINDOW DURATION

12:0018:00 24:00 06:00

 LATEST END TIMEEARLIEST START TIME 
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Recurrence. Schedule recurrence is simply the ability to repeat the designated 
system activity at regular predictable intervals. Avamar schedules allow you to 
repeat activities on designated hours of the day or designated days of the week.

For example, you could use various schedules to send noncritical event profile 
emails hourly during your normal working hours (for example, on the hour 
between 9:00 A.M. and 5:00 P.M.), schedule a particular group’s backups once per 
day at 10:00 P.M. and another group’s backups only on Saturdays at 2:00 P.M.

Effectivity. Finally, it is sometimes useful to define a specific effectivity range 
for a schedule. For example, if you know that client computers used for a specific 
development project will be obsolete at some known future date, you could easily 
create a special schedule for those group backups that would automatically cease 
backups on a date of your choice. Similarly, if administering a large site, you could 
create schedules ahead of time, assign them to groups, then activate them on a 
date of your choice. These group backups would not occur until the schedule took 
effect.

All Displayed Times Are Relative to That Avamar Administrator Client
Locality. When schedules are created or edited, all times are shown relative to 

that Avamar Administrator client’s local time zone. For example, consider a 
schedule created by an administrative user in Pacific Standard Time zone, with a 
next run time of 10:00 P.M. If an administrative user in Eastern Standard Time 
views that same schedule in his Avamar Administrator session, the next run time 
would be localized and shown as 1:00 A.M. the following day (3 hours later).

Run Now. The Manage All Schedules window provides a Run Now button, 
which is used to initiate all actions associated with a particular schedule right now.

NOTE:  Initiating all actions associated with a particular
schedule using the Run Now button does not affect the next
time the schedule is regularly run.
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Schedule Properties

Avamar schedules offer three basic options for defining recurrence:

• Repeat this schedule daily
• Repeat this schedule weekly
• Repeat this schedule on-demand

Repeat This Schedule Daily. The Repeat this schedule daily option allows you 
establish a scheduling pattern comprising one or more hours of the day. This 
pattern will be repeated daily. In other words, system activities scheduled in this 
manner occur at the specified times every day of the year. 

TIP:  If you need to schedule system activities for certain
days of the week, use the Repeat this schedule weekly
option. 

Additionally, in order to prevent job overlap, you must limit the duration of these 
activities. For example, if you scheduled backups to occur every six hours (for 
example, at 1:00 A.M., 7:00 A.M., 1:00 P.M. and 7:00 P.M.), you should limit each 
run to no more than six hours so that the previous backup completes before the 
next backup is begun.
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Repeat This Schedule Weekly. The Repeat this schedule weekly option 
allows you to establish a scheduling pattern comprising one or more days of the 
week. This pattern will be repeated weekly. In other words, system activities 
scheduled in this manner occur on the specified days of the week every week of 
the year. 

Because only one activity scheduled in this manner occurs on each of the specified 
days, you must precisely define the activity operating hours using Earliest start 
time and End no later than values.

Repeat This Schedule Monthly. The Repeat this schedule monthly option 
allows you to schedule operations to run on a specific calendar date or run on a 
designated day and week each month. 

Repeat This Schedule On-Demand. The Repeat this schedule on-demand 
option allows to you define a schedule that does not run. This is useful for creating 
schedules that you can assign today but activate in the future.
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Activation Constraints. Schedule effectivity is controlled by the activation 
constraints:

• To make a schedule effective immediately, select the Delay until date to 
today

• To make a schedule run indefinitely, select the No End Date option
• To obsolete a schedule at some future date of your choice, select the End 

after option and select a date of your choice

Timing of Activation Constraints. Because scheduled activities often straddle 
two calendar days, it should be understood that Avamar will allocate the full 
window of time to any activity initiated by a schedule. For example, consider a 
schedule with an earliest start time of 10:00 P.M., a latest end time of 6:00 A.M. 
(the following morning) and an end after date of December 31 of the current 
calendar year. On the evening of December 31, the activity will be initiated as 
expected and run until completed, typically some time during the morning of 
January 1 the following year. However, beginning January 1 of the following year, 
no new scheduled activities will be initiated by way of this schedule.

Schedule Catalog

Default Schedule. The Default Schedule controls backup scheduling for the 
Default Group (page 128). It is initially configured to run once per day at 10:00 
P.M. You can modify these settings to meet your specific site requirements. 
However, doing so enforces these changes on all members of the Default Group 
(page 128).

Daily Schedule. Avamar also supplies a predefined Daily Schedule.

Evaluation Schedule. The Evaluation Schedule is primarily intended to be used 
to support system evaluations by controlling when the Evaluation Profile (page 
169) email notification is sent. It is initially configured to run each Monday 
morning at 6:00 A.M.

Notification Schedule. The Notification Schedule controls when custom event 
profile email notification messages are sent. Refer to Custom Profiles (page 169) 
for additional information.

Statistics Schedule. The Statistics Schedule controls how often various Avamar 
server statistics (for example, the Avamar server detail (page 244) Bytes 
protected value) are retrieved or calculated. The default setting for this schedule 
is hourly.
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Creating a New Schedule
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Schedules…

The Manage All Schedules window appears.

3. Click New. 

The New Schedule dialog box appears.

4. Type or select the following:

FIELD/OPTION DESCRIPTION

Name Type a name for this new schedule.
IMPORTANT:  Do not use any of the following 
characters in your schedule name: 
~!@$^%(){}[]|,`;#\/:*?<>'"&.
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5. Ensure that the Next Run Time (directly under the Name field) is the 
expected date and time.

6. Click OK.

The New Schedule dialog box closes.

Repeat this schedule Select either daily, weekly, monthly or on-
demand.

If daily is selected, you can schedule 
operations to occur at any hour of the day. 
You can also limit each run to a specified 
number of hours in order to prevent 
overlapping backups.
If weekly is selected, you can schedule 
operations to occur on any day of the week. 
If monthly is selected, you can schedule 
operations to occur on any calendar day of 
the month. 
If on-demand is selected, this schedule will 
never run. Schedules using this setting are 
typically assigned to groups that only take 
on-demand backups (for example, groups 
that only contain laptop clients and so 
forth). 

Operating Hours Specifies an Earliest start time and an End 
no later than time for each scheduled backup. 
These two values define a logical window of 
time during which a backup can potentially be 
performed. Server workload will affect the 
actual start time.
NOTE:  The first time a backup is performed 
for any client, the backup is allowed to 
continue past the specified end time. The 
reason for this is that initial backups can take 
significantly longer than subsequent backups 
of the same client.

Activation Constraints Specifies schedule effectivity:

To make a schedule effective immediately, 
select the Delay until date to today.
To make a schedule run indefinitely, select 
the No End Date option.
To obsolete a schedule at some future date 
of your choice, select the End after option 
and select a date of your choice.

FIELD/OPTION DESCRIPTION
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Editing a Schedule
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Schedules…

The Manage All Schedules window appears.

3. Select a schedule from the list and click Edit. 

The Edit Schedule dialog box appears.

 

4. Edit the information you want to change.

Refer to Creating a New Schedule (page 114) for additional information 
about schedule properties and settings.

5. Click OK.

The Edit Schedule dialog box closes.
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Copying a Schedule
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Schedules…

The Manage All Schedules window appears.

3. Select a schedule from the list and click Copy. 

The Save As dialog box appears.

4. Type a name for the new schedule and click OK.

The Save As dialog box closes.

Deleting a Schedule

IMPORTANT:  You cannot delete a schedule if it is currently
assigned to a group.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Schedules…

The Manage All Schedules window appears.

3. Select a schedule from the list and click Delete. 

A confirmation message appears.

4. Click Yes to permanently delete this schedule.
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Running a Schedule Now
Occasionally, you might want to perform scheduled operations on an on-demand 
basis. By selecting a schedule and clicking Run Now, all operations associated 
with that schedule are run immediately.

NOTE:  The scheduler need not running in order to use the
Run Now feature.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Schedules…

The Manage All Schedules window appears.

3. Select a schedule from the list and click Run Now. 
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Retention Policies
Backup retention policies allow you to specify how long to keep a particular 
backup in the system. Backups are automatically marked for deletion after they 
expire. However, actual deletion from the system is done in batches during times 
of low system activity.

Expiration Date. The result of a retention policy is always some future 
expiration date. Retention policies are merely a set of rules, applied as each 
backup is taken, for determining that future calendar expiration date. 

IMPORTANT:  Changing retention policy settings does not
affect past backups in the system. Every backup is assigned
an expiration date at the time the backup is taken. Although
you can manually change any individual backup expiration
date (page 88), this must be done on a backup-by-backup
basis and can be very time-consuming for large sites. There-
fore, it is extremely important that you carefully consider the
best retention policy for your site and implement that reten-
tion policy before taking too many backups.

Each retention policy defines:

• Basic settings for determining a fixed expiration date
• Optional advanced settings, which specify the number of past backups to keep 

of each type

Basic Retention Settings

Basic retention settings are used to assign a fixed expiration date to a backup 
using any one the following methods:

The Retention period option allows you to define a fixed retention period, 
relative to the schedule start time. This retention period can be any number of 
days, weeks, months or years. Expiration dates assigned in this manner create 
a moving window of backup retention. For example, this setting would be 
useful for always retaining the latest 30 days of backups in the system. Any 
backups older than 30 days would automatically be dropped from the system.

The End date option allows you to assign a calendar date as the expiration 
date. All backups assigned this retention policy would expire on the same 
calendar date. 

The No end date option allows you to keep backups indefinitely. This setting 
is useful for ensuring that all backups assigned this retention policy are 
retained for the life of the system.
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Advanced Retention Settings

Advanced retention settings are an 
optional alternative set of rules for 
dynamically assigning backup 
expiration dates, based on the number 
of daily, weekly, monthly and yearly 
backups you want to retain in the 
system. 

Initial tagging of scheduled backups as 
one or more specific types (that is, 
daily, weekly, monthly or yearly) is made when the backup is performed. You can 
also manually change a backup’s type assignment at any time. Refer to Changing 
Backup Retention Types (page 90) for additional information.

Advanced Retention Works Best With Daily Backups. Retention policies 
that implement advanced retention settings should always be used in conjunction 
with daily scheduled backups. The reason for this is that the “Always keep: n 
weeks of daily backups” setting will have no effect unless there are actually daily 
backups in the system. However, depending on which schedule you use, this may 
not always be the case. For example, if you assign a schedule (page 109) to a 
group (page 128) that only takes weekly backups, there will be no daily backups 
in the system.

Advanced Retention Settings Never Apply to On-Demand
 Backups. Advanced retention settings cannot be applied to on-demand 

backups. The reason for this is that on-demand backups can occur at any time and 
are therefore inherently asynchronous — the system cannot assign a “type” (for 
example, daily, weekly, monthly or yearly) to them.

Minimal Retention

Minimal retention is a special feature, that when enabled, enforces a minimum 
basic retention setting across an entire site (for example, keep all backups for at 
least 90 days regardless of what other retention policies specify). This feature is 
intended to address the need of some enterprises to enforce site-wide minimum 
retention standards regardless of what individual organizations might decide to 
implement with other retention policies. 

By default, the minimal retention feature is disabled. In order to use this feature 
at your site, you must enable the Minimal Retention policy. Refer to Enabling the 
Minimal Retention Policy (page 127) and Disabling the Minimal Retention Policy 
(page 126) for additional information about turning on or turning off the minimal 
retention feature, respectively.
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Retention Policy Catalog

“Minimal Retention” Policy. The Minimal Retention policy is a special 
retention policy that controls the minimal retention feature (page 120). 

IMPORTANT:  The Minimal Retention policy is a global sys-
tem object whose only purpose is to control the minimal
retention feature (page 120). Therefore, you cannot assign
the Minimal Retention policy to a group.

“Default Retention” Policy. The Default Retention policy defines backup 
retention settings for the Default Group (page 128). It initially has the same 
settings as the Minimal Retention policy. You can modify these settings to meet 
your specific site requirements. Doing so enforces these changes on all members 
of the Default Group (page 128), unless another dataset is assigned at the client 
level (page 155).

“End User On Demand Retention” Policy. End User On Demand Retention is 
a special retention policy that controls how long on-demand backups initiated by 
the client (for example, using the Avamar Windows client Back Up Now 
command) are kept in the system. Advanced retention settings are disabled on 
this retention policy because advanced retention settings never apply to on-
demand backups.

IMPORTANT:  The End User On Demand Retention policy is
a global system object whose only purpose is to control how
long on-demand backups initiated by the client are retained
in the system. Therefore, you cannot assign the End User On
Demand Retention policy to a group.

“Monthly” and “Weekly” Retention Policies. The Monthly and Weekly 
retention policies have their basic expiration dates set for one month and one 
week, respectively.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  121



 Creating a New Retention Policy
DATASETS, SCHEDULES AND RETENTION POLICIES
Creating a New Retention Policy
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Retention Policies…

The Manage All Retention Policies window appears.

3. Click New. 

The New Retention Policy dialog box appears.

4. Type or select the following:

FIELD/OPTION DESCRIPTION

Name Type a name for this new retention policy.
IMPORTANT:  Do not use any of the following 
characters in your retention policy name: 
~!@$^%(){}[]|,`;#\/:*?<>'"&.

Retention period If you want future backups to be deleted from the 
Avamar server after a specific number of days, 
weeks, months or years, select this option and type 
the number of days, weeks, months or years.

End date If you want future backups to be deleted from the 
Avamar server on a specific calendar date, select this 
option and browse to that date on the calendar.

No end date If you want to keep future backups for as long as this 
client remains active in the Avamar server, select this 
option.
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5. Do one of the following:

6. Select Override basic retention policy for scheduled backups and 
click Advanced...

The Edit Advanced Retention Policy dialog box appears.

7. Type the maximum number of daily, weekly, monthly and yearly backups 
you want to retain on your server.

8. Click OK.

The Edit Advanced Retention Policy dialog box closes.

9. Switch to Edit Retention Policy dialog box and click OK.

The Edit Retention Policy dialog box closes.

IF DO THIS

You want to use basic 
retention settings (page 119).

Skip steps 6-8; go 
directly to step 9.

You want to use advanced 
retention settings (page 120).

Go to step 6.
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Editing a Retention Policy
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Retention Policies…

The Manage All Retention Policies window appears.

3. Select a retention policy from the list and click Edit. 

The Edit Retention Policy dialog box appears.

4. Edit the information you want to change.

Refer to Creating a New Retention Policy (page 122) for additional 
information about retention policy properties and settings.

IMPORTANT:  The End date and No end date options are
not available on the Minimal Retention policy. 

5. Click OK.

The Edit Retention Policy dialog box closes.
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Copying a Retention Policy
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Retention Policies…

The Manage All Retention Policies window appears.

3. Select a retention policy from the list and click Copy. 

The Save As dialog box appears.

4. Type a name for the new retention policy and click OK.

The Save As dialog box closes.

Deleting a Retention Policy

IMPORTANT:  You cannot delete a retention policy if it is
currently assigned to a client or group.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Retention Policies…

The Manage All Retention Policies window appears.

3. Select a retention policy from the list and click Delete. 

A confirmation message appears.

4. Click Yes to permanently delete this retention policy.
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Disabling the Minimal Retention Policy
1. Start Avamar Administrator (page 27).

2. Select Tools > Manage Retention Policies…

The Manage All Retention Policies window appears.

3. Select the Minimal Retention policy from the list and click Edit. 

The Edit Retention Policy dialog box appears.

4. Select Disable minimum retention policy.

5. Click OK.

The Edit Retention Policy dialog box closes.
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Enabling the Minimal Retention Policy
1. Start Avamar Administrator (page 27).

2. Select Tools > Manage Retention Policies…

The Manage All Retention Policies window appears.

3. Select the Minimal Retention policy from the list and click Edit. 

The Edit Retention Policy dialog box appears.

4. Select Retention period.

5. Select the desired minimal retention period.

The default setting is 60 days.

6. Click OK.

The Edit Retention Policy dialog box closes.
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Thus far in this publication, we have explored how to manage various aspects of 
the Avamar server. However, these operations have been performed on an as-
needed basis on specific clients, users, backups and so forth.

Avamar uses groups to implement various policies for automating backups and 
enforcing consistent rules and system behavior across an entire segment (group) 
of the user community.

Group Members. Group members are client machines that have been added to 
a particular group for purposes of performing scheduled backups.

Because the normal rules for domain administrators apply, these clients must be 
located within the same domain or within a subdomain (page 33) of where the 
group exists.

Group Policy. In addition to specifying which clients belong to that group, 
groups also specify:

• Dataset (page 100)
• Schedule (page 109)
• Retention policy (page 119)

These three objects comprise the “group policy.” Group policy controls backup 
behavior for all members of the group unless these settings are overridden at the 
client level.

Default Group. Every client in the Avamar server is a member of at least one 
group. If no other groups have been created, new clients will automatically be 
added to the Default Group.

In the default Avamar server configuration, the Default Group always uses the 
system default dataset, schedule and retention policy. These system default 
assignments cannot be changed. However, you can modify the settings within the 
system default dataset, schedule and retention policy to meet your specific site 
requirements. Refer to Datasets, Schedules and Retention Policies (page 100) for 
additional information.
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Default Proxy Group. By default, the Default Proxy Group is where VMware 
Image Proxy clients reside. This group cannot be deleted. Enabling the Default 
Proxy Group does not conflict with scheduled backups performed by other plugins 
configured on the proxy client.

Default Virtual Machine Group. By default, the Default Virtual Machine Group 
is where new virtual machine clients are automatically added when they are 
registered. This group cannot be manually deleted but is automatically deleted if 
the vCenter Domain is deleted.

vCenter Groups. Any group created under the vCenter domain is considered a 
"vCenter" group, which behaves like any other group except that it contains 
provisions for specifying which VMware Image Proxy clients are assigned to 
perform backups on behalf of its group members.

Refer to your Avamar VMware Guide for additional information about using the 
Default Proxy Group, Default Virtual Machine Group and vCenter groups to 
manage the VMware Image backup and restore feature.

Inheritance and Client Overrides. Clients inherit the dataset, schedule and 
retention policy settings by way of their membership in a specific group. For 
example, all members of the Default Group inherit the system default dataset, 
Default Schedule and retention policy.

You can override inherited dataset and retention policy settings by making explicit 
dataset (page 155) or retention policy (page 156) assignments on a client-by-
client basis. However, schedules are only applicable to groups, not individual 
clients.
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Policy Window Overview
The Policy window allows you to assign members (clients) to a group and specify 
which dataset, retention policy and schedule each group should use.

Groups Tab. The Groups tab shows the various groups in the system on a 
domain-by-domain basis and allows you to easily view group properties in a 
tabular format.

TIP:  Setting Show sub-domain groups allows you to view
groups in the current domain and all subdomains.

The Groups tab also provides the following action buttons:

BUTTON DESCRIPTION

Select All Clicking Select All selects all groups for modification.

Clear All Clicking Clear All clears all groups (opposite of Select All).

Edit Selecting one or more groups and clicking Edit displays the Edit 
Group dialog box, which allows you to modify various group 
properties and settings.
If multiple groups are selected, the following properties and 
settings are modifiable for all selected groups:

• Disabled
• Dataset
• Schedule
• Retention Policy
• Encryption

IMPORTANT:  Your login domain (page 28) controls which 
specific datasets, retention policies and schedules are available to 
be assigned in the Groups tab. Only those datasets, retention 
policies and schedules residing at the current and higher are 
shown. Datasets, retention policies and schedules residing in 
lower subdomains are not shown.
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Copy Selecting a group and clicking Copy displays the Save As dialog 
box, which you can use to copy this group (and all group 
properties) to another domain.
IMPORTANT:  You cannot copy more than one group at a time.

Delete Selecting a group and clicking Delete permanently removes that 
group from the system.

Deleting a group does not affect any member (client) backups 
stored in the system. However, a client must always be a member 
of at least one group. Therefore, if you attempt to delete a group in 
which client members do not belong to another group, you will be 
advised to move those clients to another group and the delete 
operation will not succeed.

IMPORTANT:  You cannot delete more than one group at a time.

Back up Selecting a group and clicking Back up initiates and on-demand 
backup of that group.

BUTTON DESCRIPTION
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  131



 Policy Window Overview
GROUPS AND GROUP POLICIES
Clients Tab. The clients tab shows clients assigned to various groups in the 
system on a domain-by-domain basis and allows you to easily view client 
properties in a tabular format. 

TIP:  Setting Show sub-domain clients allows you to view
clients assigned to groups in the current domain and all sub-
domains.

The Clients tab also provides the following action buttons:

BUTTON DESCRIPTION

Select all Clicking Select All selects all clients for modification.

Clear all Clicking Clear All clears all clients (opposite of Select all).

Details Selecting a client and clicking Details displays the Client Details 
dialog box, which shows that client’s properties.
IMPORTANT:  You cannot view details for more than one client at 
a time.
Refer to Viewing Client Properties (page 44) for additional 
information about specific client properties.

Edit Selecting one or more clients and clicking Edit displays the Edit 
Multiple Clients dialog box, which allows you to override various 
group policy settings (page 155) on a client-by-client basis.
If multiple clients are selected, you can override the following 
group policy settings for all selected clients:

• Enable or disable all scheduled backups
• Activate or deactivate a client
• Allow or disallow client-initiated backups
• Change the backup window overtime behavior
• Change the encryption method

Back up Selecting a client and clicking Back up initiates and on-demand 
backup of that client (page 74).
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Adding a New Group
1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Select Actions > New Group…, right-click New Group... or click the 
toolbar icon shown immediately to the left.

The New Group wizard appears.
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4. Type or select the following:

The remaining wizard screens are used to select a dataset (page 100), 
schedule (page 109) and retention policy (page 119), as well as build a 
client list for this group.

You can click Finish at any time. Doing so will cause the new group to be 
created using system default settings and an empty client list. You can 
change those settings by editing the group properties (page 138).

FIELD/OPTION DESCRIPTION

Name Type a name for this new group.
IMPORTANT:  Do not use any of the following 
characters in your group name: ~!@$^%(){}[]|,`;#\/
:*?<>'"&.

Disabled This option is selected by default. Clear this option if you 
want to immediately use this group to take regularly 
scheduled client backups.

Encryption 
Method

Encryption method used for client/server data transfer. 
Choices are:

High Strongest available encryption setting for 
that specific client platform.

Medium Medium strength encryption.

None No encryption.

NOTE:  The exact encryption technology and bit 
strength used for any given client-server connection is 
dependent on a number of factors, including the client 
platform and Avamar server version. Refer to your 
Avamar Product Security Guide for additional 
information.

Override 
Schedule

Select this option if you want to override the assigned 
schedule for this group.
You can also skip the next scheduled backup entirely 
(Skip Next Backup) or perform the next scheduled 
backup one time only (Run Next Backup Once).

Domain Location in the Avamar server where this group should 
reside.
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5. Click Next.

The next New Group wizard screen appears.

This screen is used to select a dataset (page 100) for use with this group.

6. Select a dataset from the Select an Existing Dataset list box.

NOTE:  Datasets are not modifiable from this screen.
Detailed dataset properties are shown so that you can
review them prior to making your selection. Refer to Editing
a Dataset (page 107) for additional information about editing
dataset properties.

7. Click Next.

The next New Group wizard screen appears.

This screen is used to select a schedule (page 109) for use with this group.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  135



 Adding a New Group
GROUPS AND GROUP POLICIES
8. Select a schedule from the Select an Existing Schedule list box.

NOTE:  Schedules are not modifiable from this screen.
Detailed schedule properties are shown so that you can
review them prior to making your selection. Refer to Editing
a Schedule (page 116) for additional information about edit-
ing schedule properties.

9. Click Next.

The next New Group wizard screen appears.

This screen is used to select a retention policy (page 119) for use with this 
group.

10.Select a retention policy from the Select an Existing Retention Policy 
list box.

NOTE:  Retention policies are not modifiable from this
screen. Detailed retention policy properties are shown so
that you can review them prior to making your selection.
Refer to Editing a Retention Policy (page 124) for additional
information about editing retention policy properties.
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11.Click Next.

The final New Group wizard screen appears.

This screen is used to build a list of clients that will be members of this 
group.

12.Select one or more clients.

TIP:  Clicking Select All selects all clients; clicking Clear All
clears all clients (opposite of Select All).

13.Click Finish.

The New Group wizard closes and the new group appears in the Policy 
window.
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Editing Group Properties
You can edit properties for a single group or for multiple groups. However, the 
extent to which certain properties are available for modification differs according 
to the context:

The Default Proxy Group, Default Virtual Machine Group contain special settings 
that are only of interest to persons managing the VMware Image backup and 
restore feature. Refer to your Avamar VMware Guide for additional information 
about these special settings.

Editing a Single Group

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Groups tab.

5. Select the group you want to edit.

Single
Group

Edits

If you select one group from the Policy window Groups tab, you can 
edit any property for that group. Refer to Editing a Single Group 
(page 138) for additional information.

Multiple
Groups

Edits

If you select multiple groups from the Policy window Groups tab, you 
can only edit a constrained subset of group properties. However, any 
changes you make are applied to all selected groups. Refer to Editing 
Multiple Groups (page 140) for additional information.
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6. Select Actions > Group > Edit Group..., right-click 
Edit Group..., click Edit or click the toolbar icon shown immediately to the 
left.

The Edit Group dialog box appears.

7. Edit the information you want to change.

NOTE:  Only basic group properties such as the name, client
list and the dataset, schedule and retention policy assigned
to this group are modifiable. The actual dataset, schedule
and retention policy objects are not modifiable from this dia-
log box. Refer to Editing a Dataset (page 107), Editing a
Schedule (page 116) or Editing a Retention Policy (page
124) for additional information.

NOTE:  Default Group (page 128) policy object assignments
cannot be changed. The Default Group always uses the
default dataset (page 102), default schedule (page 113) and
default retention policy (page 121). Therefore, the Dataset,
Schedule and Retention Policy tabs do not appear when edit-
ing the Default Group.

8. Click OK.

The Edit Group dialog box closes.
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Editing Multiple Groups

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Groups tab.

5. Select the groups you want to edit.

6. Select Actions > Group > Edit Group..., right-click 
Edit Group... or click the toolbar icon shown immediately to the left.

The Edit Multiple Groups dialog box appears.

NOTE:  Only basic group properties such as whether or not
the group is enabled or disabled, encryption setting and the
dataset, schedule and retention policy assigned to this group
are modifiable. The actual dataset, schedule and retention
policy objects are not modifiable from this dialog box. Refer
to Editing a Dataset (page 107), Editing a Schedule (page
116) or Editing a Retention Policy (page 124) for additional
information.
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7. Do one or more of the following:

8. Click OK.

The Edit Multiple Groups dialog box closes.

IF DO THIS

You want to explicitly change a 
setting for all selected groups

Select the new setting from one of 
the list boxs.

You want to leave a setting 
unchanged for all selected groups

Ensure that Don’t Change is 
shown for that particular setting.
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Copying a Group

IMPORTANT:  You must copy groups within the same
domain. You cannot copy a group to another domain under
any circumstances.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Groups tab.

5. Select the group you want to copy.

6. Select Actions > Group > Copy Group…, right-click Copy Group…, click 
Copy or click the toolbar icon shown immediately to the left.

The Save As dialog box appears.

7. Type or select the following:

8. Click OK.

The Save As dialog box closes.

FIELD/OPTION DESCRIPTION

Save As Type a name for the new group.

Domain Current domain. This field is read-only.

Include Client 
Members

Select this option if you want to copy 
the entire client list to this new group.
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Disabling a Group
An Avamar Administrator can disable any group so that scheduled group backups 
will not be performed until it is reenabled (page 144). This is typically done to 
place the system in a state that will support various maintenance activities.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Groups tab.

5. Select the group you want to disable.

6. Select Actions > Group > Disable Group or right-click Disable Group.

This sets the Disable Group option on the Actions > Group and right-
click menus.

A confirmation message appears.

7. Click Yes to disable this group.
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Enabling a Group
If a group has previously been disabled (page 143), it must be reenabled before 
scheduled group backups will be performed.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Groups tab.

5. Select the group you want to enable.

6. Select Actions > Group > Disable Group or right-click Disable Group.

This clears the Disable Group option on the Actions > Group and right-
click menus.

A confirmation message appears.

7. Click Yes to enable this group.
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Deleting a Group

TIP:  Prior to deleting this group, you should make this
group's clients members of another group so that regularly
scheduled backups continue uninterrupted. Refer to Editing
Client Information (page 42) for additional information about
adding clients to other groups.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Groups tab.

5. Select the group you want to delete.

6. Select Actions > Group > Delete Group, right-click 
Delete Group… or click the toolbar icon shown immediately to the left.

A message appears asking you to confirm this action.

7. Click Yes to permanently delete this group.

A second message appears confirming that this action has successfully 
completed.

8. Click OK.

The second confirmation message closes.
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Viewing the Group Summary Reports
The Group Summary Reports are a combined “at a glance” view of all current 
group properties and settings (including group policy overrides), as well as the 
resources (datasets, schedules, retention policies) assigned to various groups.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Group Summary Reports tab.

The Group Summary Reports appear.

TAB DESCRIPTION

Datasets Shows which datasets (page 100) are assigned to 
which groups, as well as the current properties and 
settings for those datasets.
Refer to Creating a New Dataset (page 104) for 
additional information about dataset properties and 
settings.

Schedules Shows which schedules (page 109) are assigned to 
which groups, as well as the current properties and 
settings for those schedules.
Refer to Creating a New Schedule (page 114) for 
additional information about schedule properties 
and settings.

Retention Policies Shows which retention policies (page 119) are 
assigned to which groups, as well as the current 
properties and settings for those retention policies.
Refer to Creating a New Retention Policy (page 
122) for additional information about retention 
policy properties and settings.
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Clients Shows which clients are assigned to which group, 
as well as any group policy overrides in effect for a 
particular client.
Refer to Adding a New Group (page 133) and 
Overriding Group Policy Settings (page 155) for 
additional information about assigning clients to a 
group and group policy override settings, 
respectively.

TAB DESCRIPTION
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Viewing the Group Status Summary
The Group Status Summary is a simplified presentation of all backup activity 
initiated as a result of group policies. 

1. Start Avamar Administrator (page 21).

2. Select Navigation > Activity or click the Activity launcher button.

The Activity window appears.

3. Click the Group Status Summary tab.

COLUMN DESCRIPTION

Group Group name or “on-demand.”
On-demand is a special logical grouping that summarizes 
all on-demand backup activity initiated from Avamar 
clients or Avamar Administrator. However, it is not an 
actual group in the Avamar server.

Start Time Time that this group became eligible to be run.

Total Total number of backups initiated by way of this group 
policy.

Queued Total number of backups, initiated by way of this group 
policy, that are currently in the scheduler queue.

Active Total number of backups, initiated by way of this group 
policy, that are currently being performed.

Succeeded Total number of backups, initiated by way of this group 
policy, that successfully completed.

Canceled Total number of backups, initiated by way of this group 
policy, that were canceled before they could complete.

Failed Total number of backups, initiated by way of this group 
policy, that did not successfully complete.

Time Queued Interval from start time until the first client work order is 
started by any client in this group.

Time Active Total amount of time used to actually perform all backup 
activities for this group (that is, interval from the time 
the first client work order is started until the last client 
work order is finished).
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Managing Group Membership
Avamar Administrator allows you to manage group membership by adding new 
clients or removing existing clients from any existing group 

Avamar Administrator provides two basic methods for managing group 
membership: 

Either method supports multiple additions or deletions in the same operation and 
either method accomplishes the same objective. However, the flexibility of 
performing either a group-centric or client-centric operation allows you to decide 
which method is most efficient for you in a given situation. 

For example, if adding or deleting multiple clients from a single group, the group-
centric method of editing that group’s properties is going to be the most efficient 
way to accomplish this objective. Conversely, if adding or removing a single client 
from multiple groups, then the client-centric method of editing that client’s 
properties is going to be the most efficient way to accomplish that objective.

Adding Clients To a Group

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Groups tab.

5. Select the group you want to edit.

Group-centric From group properties, you can add (page 149) or remove 
(page 151) one or more member clients.

Client-centric From client properties, you can add (page 152) or remove (page 
153) one or more groups of which this client is a member.
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6. Select Actions > Group > Edit Group..., right-click 
Edit Group..., click Edit or click the toolbar icon shown immediately to the 
left.

The Edit Group dialog box appears.

7. Click the Clients tab.

8. Click Add.

The Add Clients to Group dialog box appears.

9. Select one or more clients.

10.Click OK.

The Add Clients to Group dialog box closes.

11.Switch to Edit Group dialog box and click OK.

The Edit Group dialog box closes. 
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Removing Clients From a Group

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Groups tab.

5. Select the group you want to edit.

6. Select Actions > Group > Edit Group..., right-click 
Edit Group..., click Edit or click the toolbar icon shown immediately to the 
left.

The Edit Group dialog box appears.

7. Click the Clients tab.

8. Select one or more clients you want to remove from this group.

9. Click Remove.

10.Click OK.

The Edit Group dialog box closes.
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Adding Groups To a Client

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Clients tab.

5. Select the client you want to edit.

6. Select Actions > Client > Edit Client..., right-click 
Edit Client..., click Edit or click the toolbar icon shown immediately to the 
left.

The Edit Client dialog box appears.

7. Click the Groups tab.
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8. Click Add.

The Add Group to Client dialog box appears.

9. Select one or more groups.

10.Click OK.

The Add Group to Client dialog box closes.

11.Switch to Edit Client dialog box and click OK.

The Edit Client dialog box closes. 

Removing Groups From a Client

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Clients tab.

5. Select the client you want to edit.

6. Select Actions > Client > Edit Client..., right-click 
Edit Client..., click Edit or click the toolbar icon shown immediately to the 
left.

The Edit Client dialog box appears.
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7. Click the Groups tab.

8. Select one or more groups you want to remove from this client.

9. Click Remove.

10.Click OK.

The Edit Client dialog box closes.
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Overriding Group Policy Settings
Occasionally, one might want to override the group policy settings for a particular 
client. You can assign datasets and retention policies, as well as change the 
encryption method on a client-by-client basis.

IMPORTANT:  It should be understood that too many over-
rides can make group policies less effective. In some cases,
it might be better to implement a new group policy rather
than repeatedly override an existing policy at the client level.

Assigning a Different Dataset to a Client

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Clients tab.

5. Select the client to which you want to assign this dataset.

6. Select Actions > Client > Edit Client… or click the toolbar icon shown 
immediately to the left.

The Edit Client window appears.
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7. Click the Dataset tab.

8. Select a dataset from the Select an Existing Dataset list box.

NOTE:  Datasets are not modifiable in this window. Detailed
dataset properties are shown so that you can review them
prior to making your selection. Refer to Editing a Dataset
(page 107) for additional information about editing dataset
properties.

9. Select Override group dataset.

10.Click OK.

The Edit Client window closes.

Assigning a Different Retention Policy to a Client

This is the retention policy that will be used for on-demand backups (page 74) of 
this client.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.
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4. Click the Clients tab.

5. Select the client to which you want to assign this retention policy.

6. Select Actions > Client > Edit Client… or click the toolbar icon shown 
immediately to the left.

The Edit Client window appears.

7. Click the Retention Policy tab.

8. Select a retention policy from the Select an Existing Retention Policy 
list box.

NOTE:  Retention policies are not modifiable in this window.
Detailed retention policy properties are shown so that you
can review them prior to making your selection. Refer to
Editing a Retention Policy (page 124) for additional informa-
tion about editing retention policy properties.

9. Select Override group retention policy.

10.Click OK.

The Edit Client window closes.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  157



 Overriding Group Policy Settings
GROUPS AND GROUP POLICIES
Changing the Client Encryption Method

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Clients tab.

5. Select the client for which you want to change the encryption method.

6. Select Actions > Client > Edit Client… or click the toolbar icon shown 
immediately to the left.

The Edit Client window appears.
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7. Click the Properties tab.

8. Select an encryption method from the Select an Encryption Method list 
box.

Choices are:

9. Select Override Group Encryption. 

10.Click OK.

The Edit Client window closes.

High Strongest available encryption setting for that specific client 
platform.

Medium Medium strength encryption.

None No encryption.

NOTE:  The exact encryption technology and bit strength used for any 
given client/server connection is dependent on a number of factors, 
including the client platform and Avamar server version. Refer to your 
Avamar Product Security Guide for additional information.
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Allowing Scheduled Backups to Run Overtime

You can override the group schedule duration setting on a client-by-client basis. 
This will allow scheduled group backups initiated on these selected clients to run 
as long as necessary in order for the backup to complete, regardless of the group 
schedule duration setting.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Clients tab.

5. Select the client for which you want to allow overtime backups.

6. Select Actions > Client > Edit Client… or click the toolbar icon shown 
immediately to the left.

The Edit Client window appears.
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7. Click the Properties tab.

8. Select one of these settings from the Overtime list:

9. Click OK.

The Edit Client window closes.

SETTING DESCRIPTION

No overtime allowed Scheduled group backups are never allowed to 
run past the schedule duration setting.

Always allow 
overtime

Scheduled group backups are always allowed to 
run past the schedule duration setting.

Overtime on next 
backup only

Only the next scheduled group backup is 
allowed to run past the schedule duration 
setting.

Overtime until 
successful backup

Scheduled group backups are allowed to run 
past the schedule duration setting until a 
successful backup is completed.
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Allowing Users to Initiate Backups

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Clients tab.

5. Select the client for which you want to allow users to initiate backups.

6. Select Actions > Client > Edit Client… or click the toolbar icon shown 
immediately to the left.

The Edit Client window appears.

7. Click the Properties tab.
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8. Select Allow client initiated backups. 

If no additional configuration is performed, backups initiated by this client 
will include only those files selected by the user at the time the backup is 
initiated and End User On-Demand Retention (page 121) will be applied. 
However, you can enforce use of a particular dataset and retention policy 
for all client-initiated backups. 

9. If you want to enforce use of a particular dataset for all client-initiated 
backups, perform the following:

(a) Click the Dataset tab.

NOTE:  Datasets are not modifiable in this window. Detailed
dataset properties are shown so that you can review them
prior to making your selection. Refer to Editing a Dataset
(page 107) for additional information about editing dataset
properties.

(b) Do one of the following:

IF DO THIS

You want to use the dataset 
assigned to this group for all 
client-initiated backups.

Clear Override group dataset.

You want to enforce use of a 
specific dataset for all client-
initiated backups.

1. Select a dataset from the 
Select an Existing Dataset 
list box..

2. Select Override group 
dataset.
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10. If you want to enforce use of a particular retention policy for all client-
initiated backups, perform the following:

(a) Click the Retention Policy tab.

NOTE:  Retention policies are not modifiable in this window.
Detailed retention policy properties are shown so that you
can review them prior to making your selection. Refer to
Editing a Retention Policy (page 124) for additional informa-
tion about editing retention policy properties.

(b) Do one of the following:

11.Click OK.

The Edit Client window closes.

IF DO THIS

You want to use the retention 
policy assigned to this group for 
all client-initiated backups.

Clear Override group 
retention policy.

You want to enforce use of a 
specific retention policy for all 
client-initiated backups.

1. Select a retention policy from 
the Select an Existing 
Retention Policy list box.

2. Select Override group 
retention policy.

3. Select Override retention 
policy on client initiated 
backups.
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Initiating On-Demand Group Backups
Occasionally, you may want to backup an entire group of clients at some time 
other than the regularly-scheduled time. While you certainly could perform 
individual on-demand backups (page 74) for each of these clients, this could be 
time-consuming if there are many clients. Furthermore, on-demand backups 
cannot be managed using advanced retention settings (page 120), they can only 
be assigned a static expiration date.

“Back Up Group Now” Feature. In most cases, a better way to accomplish 
this objective is to use the “Back Up Group Now” feature, which initiates an on-
demand group backup for one particular group. Backups taken in this manner are 
true group backups, which allow you to manage the resultant backups using 
advanced retention settings.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Groups tab.

5. Select the group for which you want to initiate a backup.

6. Select Actions > Group > Back Up Group Now, right-click Back Up 
Group Now or click Back up.

A Backup initiated message appears.

7. Click OK.
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EVENTS, NOTIFICATIONS AND PROFILES

This chapter introduces and discusses Avamar events, as well as various features 
that can be used to generate various notifications when specific events occur. 

Important Terms and Concepts
This topic discusses the basic concepts and fundamental principles of Avamar 
events, notifications and profiles. 

Events

All Avamar system activity and operational status is reported as various events to 
the MCS. Examples of various Avamar events include client registration and 
activation, successful and failed backups, hard disk status and others. Each event 
contains the following information for the specific instance of the activity, 
condition or status reported:

Event code Unique identifier.

Date and Time Date and time event was reported.

Category Category of event (SYSTEM, APPLICATION, USER, 
SECURITY).

Type Type of event (INTERNAL, ERROR, WARNING, 
INFORMATION, DEBUG).

Summary A one-line summary description of event reported.

Hardware source System node that reported the event.

Software source System or application module that reported the event.
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Audit Logging

Certain system events (events with a category of SECURITY and type of AUDIT) 
are used to implement the Avamar audit logging feature. This feature keeps a 
permanent log of system actions initiated by users. The data in this log allows 
enterprises deploying the Avamar to enforce security policies, detect security 
breaches or deviation from policies and hold appropriate users accountable for 
those actions. 

NOTE:  It must be understood that only actions initiated by
users are logged; actions initiated by the system without a
user account such as scheduled backups, maintenance activ-
ities and so forth are not logged.

Because the underlying data for audit log entries are system events, this 
information is available two places: 

• Event Monitor (as with any other system event)
• Audit Log (which only contains events that are also audit log entries)

Customizing Error Events

By default, Avamar software continually monitors /var/log/messages for any 
occurrence of the case-insensitive search string “error.” Any occurrences of “error” 
create an event code of the type ERROR.

This default behavior can be customized by defining additional search strings that 
will also create Avamar ERROR events. These additional search case-insensitive 
strings must be added to 
/usr/local/avamar/var/mc/server_data/adminlogpattern.xml.

Notifications

Avamar provides a number of features and functions used to generate various 
notifications when specific events occur.

Pop-Up Alerts. Events can be configured on an event-by-event basis to 
generate a graphical pop-up alert each time one of those events occurs. One 
significant limitation of this feature is that Avamar Administrator software must be 
running in order for the pop-up alerts to be displayed.

Acknowledgement Required List. Events can be configured on an event-by-
event basis such that when events of this type occur, an entry will be added to a 
list of events that requires interactive acknowledgement by the Avamar system 
administrator. 
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Email Messages. Events can be configured on an event-by-event basis to send 
an email message to a designated list of recipients. Email notifications can be sent 
immediately or in batches at regularly-scheduled times.

A typical batch email notification message looks like this:

MCS: avamar-1.example.com
MCS Version: 5.0.2-31
Avamar Server: avamar-1.example.com
Avamar Server Version: 5.0.2-31

Event profile: My Custom Profile
Count of events: 3

Summary of events: 
Type Code Count Summary
----------- ------ ------ -------
INFORMATION 22207 1 New group created
INFORMATION 22208 1 Group modified
INFORMATION 22209 1 Group deleted

 Event Code = 22207
 Event Date/Time = 5/10/10 09:58:20 PDT
 Event Type = INFORMATION
 Event Severity = OK
 Event Summary = New group created
 Software Source = MCS:CR

 Event Code = 22209
 Event Date/Time = 5/10/10 09:58:25 PDT
 Event Type = INFORMATION
 Event Severity = OK
 Event Summary = Group deleted
 Software Source = MCS:CR

 Event Code = 22208
 Event Date/Time = 5/10/10 10:55:28 PDT
 Event Type = INFORMATION
 Event Severity = OK
 Event Summary = Group modified
 Software Source = MCS:CR

Syslog Support. Events can be configured on an event-by-event basis to log 
information to local or remote syslog files based on filtering rules configured for 
the syslog daemon receiving the events. Third-party monitoring tools and utilities 
capable of examining log entries can access the syslog files and process them in 
order to integrate Avamar event information into larger site activity and status 
reports. Refer to Monitoring the Avamar Server Using syslog (page 188) for 
additional information.

SNMP Support. The Avamar SNMP implementation provides two distinct ways 
to access Avamar server events and activity completion status:

SNMP requests provide a mechanism for SNMP management applications to 
“pull” information from a remote SNMP-enabled client (in this case, the 
Avamar server). 

SNMP traps provide a mechanism for the Avamar server to “push” information 
to SNMP management applications whenever designated Avamar events occur. 
Events can be configured on an event-by-event basis to output SNMP traps.

Refer to Monitoring the Avamar Server Using SNMP (page 191) for additional 
information.
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Profiles
Profiles are a notification management feature that are used to logically group 
certain event codes together and specify which notifications should be generated 
when these events occur. There are two basic types of event profiles:

System Profile. There is only one System event profile. It contains all possible 
system event codes. 

Custom Profiles. Custom profiles are used to send various notifications when 
certain system events occur. You can create as many custom profiles as you need 
to organize your system events and generate the desired notifications when any of 
those events occur.

Profile Catalog

System Profile. There is only one System event profile. It contains all possible 
system event codes. 

Evaluation Profile. The default Avamar configuration includes a special 
Evaluation Profile profile that is primarily intended to be used to support system 
evaluations. If enabled, this profile generates an email notification and attaches 
two weeks worth of Activities - DPN Summary report (page 198) information to 
the email message. 

High Priority Events Profile. The default Avamar configuration includes a 
special High Priority Events profile. If enabled with the default settings, this 
custom event profile will automatically email the following information to EMC 
Technical Support (emailhome@avamar.com) twice daily:

• Status of the daily data integrity check

• Selected Avamar server warnings and information messages

• Any Avamar server errors

IMPORTANT:  The existing (factory default) High Priority
Events profile is read-only. You can enable it using the fac-
tory settings but you cannot directly modify it. If you require
custom High Priority Events profile settings, you must copy
it, then modify the copy.

Refer to Configuring and Enabling the “Email Home” Feature (page 183) for 
additional information.

Local SNMP Trap Profile. The default Avamar configuration includes a special 
Local SNMP Trap profile. This profile is read-only. You cannot directly modify it. 
Furthermore, it is intended to be used for test purposes only (to verify that traps 
are successfully generated and received by the local snmptrapd process, which 
will then write the trap information to a syslog file). Refer to Monitoring the 
Avamar Server Using SNMP (page 191) for additional information.

Local Syslog Profile. The default Avamar configuration includes a special Local 
Syslog profile. If enabled, this profile will report status by way of the local syslogd 
process on the Avamar server. Refer to Monitoring the Avamar Server Using syslog 
(page 188) for additional information.
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Editing System Event Profile Properties
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Profiles...

The Manage All Profiles dialog box appears.

3. Select the System Profile in the tree pane and click Edit.

The Edit Profile dialog box appears.

4. Select or clear either of the following options for one or more system 
events:

5. Click OK.

The Edit Profile dialog box closes.

OPTION DESCRIPTION

GUI Alert If selected, show a graphical pop-up 
alert on the Avamar Administrator 
client each time this event occurs.

Acknowledgement 
Required

If selected, add an entry to the 
common unacknowledged events 
list each time this event occurs.
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Creating a New Custom Event Profile

IMPORTANT:  You cannot view system events and profiles
outside your domain (page 33). This directly affects the pro-
files you can edit and the specific events you can add to any
profile.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Profiles...

The Manage All Profiles dialog box appears.

3. In the tree, select the domain to which you want to add this custom event 
profile and click New.

The New Event Profile wizard appears.
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4. Type or select the following:

5. Click Next.

The Event Codes wizard screen appears.

This is where you specify which error and audit codes will trigger 
notifications.

Additionally, if you are adding this custom event profile at the top-level 
(that is, not to a domain or subdomain), you can also change the 
parameters used to control capacity forecast alerts. 

Error Codes 6. Specify which error codes will trigger notifications as follows:

(a) Click the All Codes tab.

(b) Select the Notify option for one or more error codes.

NOTE:  An asterisk (*) next to a Notify option indicates an
event of such severity that a notification will be sent when
that event occurs, if even if other event notifications are sent
on a schedule.

FIELD/OPTION DESCRIPTION

Profile Name Type a name for this event profile

Profile Enabled Select this option if you want this event 
profile to be active; clear this option if 
you want this event profile to be 
inactive. You can enable it (page 181) at 
any time.

Syslog Notification - 
Enabled

Clear this option if you do not want to 
use the syslog notification feature with 
this profile. 

SNMP Trap Notification - 
Enabled

Clear this option if you do not want to 
use the SNMP notification feature with 
this profile. 
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Audit Codes 7. Specify which audit codes will trigger notifications as follows:

(a) Click the Audit Codes tab.

(b) Select the Notify option for one or more error codes.

NOTE:  An asterisk (*) next to a Notify option indicates an
event of such severity that a notification will be sent when
that event occurs, if even if other event notifications are sent
on a schedule.

Parameters 8. Do one of the following:

9. Change the parameters used to forecast capacity usage alerts as follows:

IMPORTANT:  This feature is only available if you are add-
ing this custom event profile at the top-level (that is, not to
a domain or subdomain).

(a) Click the Parameters tab.

(b) Select the option corresponding to the parameter you want to change.

(c) Type a new value for that parameter.

(d) Repeat steps b through c for each parameter you want to modify.

IF DO THIS

You want to change the parameters used to 
control capacity forecast alerts.

Perform step 9.

You do not want to change these settings, or the 
Parameters tabs does not appear (typically, 
because you are adding this custom event 
profile to a domain or subdomain).

Skip step 9 and go 
directly to step 10.
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10.Click Next.

The Attachments wizard screen appears.

This screen is used to select which attachments will be sent with 
notification messages and to specify file formats for each attachment.

11. Type or select the following:

FIELD/OPTION DESCRIPTION

Attach Server 
status in email 
(XML)

If selected, a report of overall Avamar server 
status, in XML format, is included in email 
notification messages.

Attach Server 
logs in email

If selected, Avamar server logs are included in 
email notification messages.

Directory If Attach Server logs in email (XML) is selected, 
type the full path to the location of Avamar server 
logs. 
Default location is /usr/local/avamar/var/cron/.

Reports - Attach Select the Attach option next to each report you 
want include with this notification message.

Reports - XML Send this attachment as an Extensible Markup 
Language (XML) file (useful for sharing data with 
other applications).

Reports - CSV Send this attachment as a Comma-Separated 
Values (CSV) text file (useful for importing into a 
spreadsheet).

Reports - TXT Send this attachment as a plain text file.
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12.Click Next.

The Email Notification wizard screen appears.

This screen is used to specify recipients that will receive email notification 
messages.

13. Type or select the following:

FIELD/OPTION DESCRIPTION

Email Subject Header Type an email subject line for this notification 
message.

Enter Recipient To add a recipient, type one or more email 
addresses in user@domain format and click +.
TIP:  If you need to remove a recipient from 
the Recipient Email list, select it, then click -.

Inline attachments Select this option if you want all attachments 
to be inserted directly into the body of these 
email notification message.
IMPORTANT:  Selecting this option might 
create very long email messages.

Send Email Click this button to immediately send a test 
email message. 
If the test email message is successfully sent, 
an Email accepted by transport layer 
confirmation message appears. 
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14.Click Next.

The next wizard screen appears.

This screen is used to set various syslog notification parameters.

15. Type or select the following:

FIELD/OPTION DESCRIPTION

Address (IP or hostname) IP address or hostname of the Avamar 
server node running the syslogd process. 

Port Number Port number used for syslog 
communication.

Include extended 
event data option

If selected, additional (extended) event 
code information is included in the syslog 
message. This extended information is 
delimited using the following tags:

• <Code>
• <Type>
• <Severity>
• <Category>
• <HwSource>
• <Summary>
• <active>
• <lastEmailSendDate>
• <domain>
• <scheduleID> 
• <num_prefs>
• <name>
• <isSystem>

Facility One of the following: user, local0, local1, 
local2, local3, local4, local5, local6 or 
local7.
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TIP:  To test your syslog notification parameters, click Send
Test Syslog Entry.

16.Click Next.

The next wizard screen appears.

This screen is used to set various SMNP notification parameters.

17. Type or select the following:

TIP:  To test your SMNP notification parameters, click Send
Test SNMP Trap.

18.Click Finish.

The New Event Profile wizard closes and the new event profile appears in 
the Manage All Profiles dialog box tree pane.

FIELD/OPTION DESCRIPTION

SNMP Trap Address 
(IP or hostname)

IP address or hostname of machine running an 
application capable of receiving and processing an 
SNMP trap. 

Port Number Port number on host machine that is listening for 
SNMP traps. Default data port is 162.

SNMP Community Name of the SNMP community that the SNMP trap 
listener is configured to use.

NOTE:  The SNMP community is a text string that 
the local Net-SNMP agent will use to authenticate 
itself with the SNMP management application.
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Editing Custom Event Profile Properties

IMPORTANT:  You cannot view system events and profiles
outside your domain (page 33). This directly affects the pro-
files you can edit and the specific events you can add to any
profile.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Profiles...

The Manage All Profiles dialog box appears.

3. Select a custom event profile in the tree pane and click Edit.

The Edit Profile dialog box appears.

4. Edit the information you want to change.

Refer to Creating a New Custom Event Profile (page 171) for additional 
information about custom event profile properties and settings.

5. Click OK.

The Edit Profile dialog box closes.
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Copying an Existing Custom Event Profile
1. Start Avamar Administrator (page 21).
2. Select Tools > Manage Profiles...

The Manage All Profiles dialog box appears.

3. In the tree, select the profile you want to copy and click Copy.
The Save As dialog box appears.

4. Type a name for the new custom event profile in the Save As field.
By default, the domain field is populated with the domain of the custom 
event profile you are copying.

5. Do one of the following:

6. Click OK. 
The Save As dialog box closes.
The new custom event profile appears in the tree pane.

IF DO THIS

You want to copy the new 
custom event profile to the 
same domain.

Go directly to step 6.

You want to copy the new 
custom event profile to a new 
domain.

Click ... (next to the domain field).
The Select domain dialog box appears.
Browse to the desired domain location in 
the tree and click OK.
The Select domain dialog box closes; 
the domain you selected appears in the 
Save As dialog box Domain field.
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Testing Custom Event Profile Notifications
You can test your custom event profile notification mechanisms by sending a short 
email message or writing a short message to the syslog file.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Profiles...

The Manage All Profiles dialog box appears.

3. Select a custom event profile in the tree pane and click Edit.

The Edit Profile dialog box appears.

4. Do one of the following:

5. Click OK.

The Edit Profile dialog box closes.

IF DO THIS

You want to 
send a test 
email 
message.

Click the Email Notification tab.
Click Send Email.
If the test email message is successfully sent, an 
Email accepted by transport layer confirmation 
message appears. 
Click OK to close the confirmation message dialog box.

You want to 
write a test 
message to the 
syslog file.

Click the Syslog Notification tab.
Click Send Test Syslog Entry.

If the test syslog message is successfully written, an 
Initiated syslog notification confirmation 
message appears. 
Click OK to close the confirmation message dialog box.

You want to 
send a test 
SNMP trap 
message.

Click the SNMP Trap Notification tab.
Click Send Test SNMP Trap.
If the test SNMP trap message is successfully sent, an 
Initiated SNMP trap notification confirmation 
message appears. 
Click OK to close the confirmation message dialog box.
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Disabling a Custom Event Profile
An Avamar administrator can disable any event profile so that email notifications 
are not sent until it is reenabled.

IMPORTANT:  You cannot disable the System events profile
(page 169).

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Profiles...

The Manage All Profiles dialog box appears.

3. Select an event profile in the tree pane and click Disable.

The Disable button changes to Enable.

Enabling a Custom Event Profile
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Profiles...

The Manage All Profiles dialog box appears.

3. Select an event profile in the tree pane and click Enable.

The Enable button changes to Disable.
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Deleting a Custom Event Profile

IMPORTANT:  You cannot delete the System events profile
(page 169).

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Profiles...

The Manage All Profiles dialog box appears.

3. Select an event profile in the tree pane and click Delete.

A confirmation message appears.

4. Click Yes to delete the event profile.
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Configuring and Enabling the “Email Home” Feature
When configured and enabled, the Email Home feature automatically emails 
configuration, capacity, and general system information to EMC Technical Support 
once daily, and critical alerts in near-real time on an as needed basis.

Notification Schedule. By default, these email messages are sent at 6:00 A.M. 
and 3:00 P.M. each day. The timing of these messages is controlled by the 
Notification Schedule. Refer to Schedules (page 109) for additional information. 

Mail Settings. In order to properly configure the Email Home feature, you need 
the following information:

Task Overview. To fully configure and enable the Email Home feature, you 
must:

• Modify mcserver.xml Email Home Settings (page 184)
• Configure and Enable the High Priority Events Profile (page 185)
• Enable Scheduled Operations (page 187)

Outgoing SMTP
Mail Server Name

This is the corporate outgoing SMTP mail server that will be 
used to send Email Home messages.
Typically, the outgoing SMTP mail server name is asked for 
and stored during initial Avamar server deployment. This 
procedure asks that you verify this setting. If you need to 
change this setting, you can do so as part of this procedure.
IMPORTANT:  In most cases, some arrangement must be 
made to allow emails originating from the Avamar server to 
be forwarded though the outgoing SMTP mail server to EMC 
Technical Support over the Internet.

Administrative Mail
Sender Address

In order for Email Home messages to be received by EMC 
Technical Support, they must be sent using a valid email 
address with access to your corporate outgoing SMTP mail 
server.
IMPORTANT:  If you do not configure the Email Home 
feature to send messages from a valid email address, 
messages generated by the Email Home feature will be 
rejected by the EMC incoming email server. Furthermore, 
EMC Technical Support will be completely unaware that 
these programmatically-generated messages were rejected 
and because a valid sending email account is not known, 
programmatically-generated warnings to the sender that 
these messages could not be sent will never be viewed by 
anyone who can correct the problem.
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Modify mcserver.xml Email Home Settings

1. Open a command shell (page 477) and do one of the following:

2. Load the admin OpenSSH key by typing:

ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.

3. Type the admin user account passphrase and press ENTER.

4. Change directories by typing:

cd /usr/local/avamar/var/mc/server_data/prefs

5. Open mcserver.xml in a Unix text editor.

6. Find the com.avamar.asn.module.mail node (shown next).

<root type="system">
<node name="com">

<node name="avamar">
<node name="asn">

<node name="module">
<node name="mail">

<entry key="smtpHost" value="mail"/>
<entry key="admin_mail_sender_address" value=""/>

NOTE:  Substantial portions of mcserver.xml have been
omitted for clarity.

7. Verify that the smtpHost entry (mail) is the actual name of your outgoing 
SMTP mail server as defined in corporate DNS (for example, 
smtp.example.com).

If this entry is not correct, you must change it now.

8. Change the admin_mail_sender_address entry to a valid email address.

For example: jsmith@example.com.

9. Save your changes.

10.Restart the MCS by typing:

dpnctl stop mcs

dpnctl start

11.Close the command shell.

IF DO THIS

Configuring a multi-node server Log into the utility node 
as user admin.

Configuring a single-node server Log into the single-node 
server as user admin.
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Configure and Enable the High Priority Events Profile

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Profiles...

The Manage All Profiles dialog box appears.

IMPORTANT:  The existing (factory default) High Priority
Events profile is read-only. You can enable it using the fac-
tory settings but you cannot modify any of the settings. If
you require custom High Priority Events profile settings, you
must copy it, then modify the copy.

3. Do one of the following:

IF DO THIS

You want to use the 
(un-modifiable) factory 
default settings.

Select the existing High Priority Events profile.
Perform steps 4 through 5, then go directly to 
step 10 (skip steps 6 through 9 because the 
default High Priority Events profile is not 
modifiable).

You want to use new 
custom settings.

Create a copy of the existing High Priority 
Events profile by selecting it and clicking Copy.
The Save As dialog box appears.
Type a name for this new profile in the Save As 
field and click OK.
The Save As dialog box closes.
Select the High Priority Events profile copy you 
just created.
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4. Clear the Disabled option.

IMPORTANT:  The Manage Event Codes tab is used to
select which event codes will trigger an email notification.
However, the High Priority Events profile has been preconfig-
ured to only send notifications for specific high priority
events. EMC Technical Support recommends that you use
the default settings.

5. Select the High Priority Events profile copy you created in step 3 and click 
Edit.

The Edit Profile — Custom Profile High Priority Events dialog box appears.

6. Click the Email Notification tab.

7. Type:

8. Click OK.

The Edit Profile — Custom Profile High Priority Events dialog box closes.

9. Switch to Manage All Profiles dialog box and click OK.

The Manage All Profiles dialog box closes.

FIELD SETTING

Email Subject 
Header

IMPORTANT:  Unless you have a good reason to 
change this, EMC Technical Support recommends 
that you use the default email header:
Avamar Administrator Notification — High Priority 
Events

Recipient 
Email List

Ensure that emailhome@avamar.com is listed.
TIP:  To add additional recipients, type a valid 
Internet email address in the Enter Recipient field and 
click +. To remove a recipient, select that recipient in 
the Recipient Email List and click -. 
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Enable Scheduled Operations

Because the Email Home feature sends email notifications on a predefined 
schedule, you must enable scheduled server operations before you will actually 
receive notification email messages.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Schedules…

The Manage All Schedules window appears.

3. Click Resume All. 

The Resume All button changes to Suspend All.

NOTE:  You can test this events profile by selecting the Noti-
fication Schedule and clicking Run Now. Check with EMC
Technical Support to determine whether the Email Home
message was received.
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Monitoring the Avamar Server Using syslog
Unix and Linux systems provide a feature called syslog that is used to collect 
system log messages and write them to a designated log file. Avamar servers are 
capable of outputting Avamar server event codes in syslog format. 

The actual service used to implement this feature is the syslog daemon (syslogd). 
This service can be hosted locally on the Avamar server or on a remote client as 
long as that client can communicate with the Avamar server over a network 
connection.

The following table shows how Avamar event data is mapped into various syslog 
fields:

The following is an example Avamar server syslog message:

Feb 9 08:23:57 MyAvamar MCS: <Code> 22254 <Category> SYSTEM <Summary> Client Adhoc 
Backup Request Error - Unknown ID. <Data> Client = ivory

In order to monitor an Avamar server using syslog, you must:

• Configure a custom event profile that will output designated Avamar server 
events to a local or remote syslogd process (page 189)

• Configure syslogd (page 190) so that it can collect information from the 
Avamar server

SYSLOG FIELDS AVAMAR EVENT CODE DATA

Facility One of the following (set by way of the custom event profile 
Facility field): user, local0, local1, local2, local3, local4, 
local5, local6 or local7.

Priority One of the following (based on the Avamar event type):
• debug - if Avamar event type is DEBUG
• err - if Avamar event type is ERROR
• info - if Avamar event type is INFO
• none - if Avamar event type is INTERNAL
• warning - if Avamar event type is WARNING

Date Avamar event date.

Time Avamar event time.

Hardware Source Avamar event hardware source.

Software Source Avamar event software source.

Message The following fields from the Avamar event code: event 
code, category, summary and event data.
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Configure a Custom Event Profile

Local Syslog Profile. As previously mentioned, the default Avamar 
configuration includes a special Local Syslog profile. If enabled, this profile will 
output Avamar server event messages to the local syslogd process on the Avamar 
server. 

IMPORTANT:  The existing (factory default) Local Syslog
profile is read-only. You can enable it using the factory set-
tings but you cannot directly modify it. If you require custom
Local Syslog profile settings, you must copy it, then modify
the copy.

Using a Custom Event Profile. If you create a new custom event profile (page 
171) to support syslog monitoring, ensure that Syslog Notification Enabled option 
is selected on the first wizard screen.

Continue through the various wizard setup screens until the syslog wizard 
screen appears.

Type or select the following:

FIELD/OPTION DESCRIPTION

Address (IP or hostname) IP address or hostname of the Avamar server node 
running the syslogd process. 

Port Number Port number used for syslog communication.
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Configure syslogd

The syslog daemon (syslogd) is configured by way of settings in the 
/etc/sysconfig/syslog configuration file. These settings implement various filtering 
rules and control where syslog messages are logged. 

By default, Avamar writes to syslogd by way of localhost udp port 514. In order for 
the local syslogd process to monitor these messages, /etc/syslog.conf file must be 
modified to configure syslogd to listen on this data port.

The /etc/sysconfig/syslog file typically contains an entry similar to this:

SYSLOGD_OPTIONS="-m 0"

This entry line must be modified to add the -r parameter:

SYSLOGD_OPTIONS="-r -m 0"

Additionally, after modifying /etc/sysconfig/syslog, you must restart the syslogd 
daemon using the following command:

kill -SIGHUP `cat /var/run/syslogd.pid`

A complete discussion of configuring syslogd is beyond the scope of this 
publication. Refer to your Unix or Linux operating system documentation for 
additional information.

Include extended 
event data option

If selected, additional (extended) event code 
information is included in the syslog message. This 
extended information is delimited using the 
following tags:

• <Code>
• <Type>
• <Severity>
• <Category>
• <HwSource>
• <Summary>
• <active>
• <lastEmailSendDate>
• <domain>
• <scheduleID> 
• <num_prefs>
• <name>
• <isSystem>

Facility One of the following: user, local0, local1, local2, 
local3, local4, local5, local6 or local7.

FIELD/OPTION DESCRIPTION
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Monitoring the Avamar Server Using SNMP
Simple Network Management Protocol (SNMP) is a protocol for communicating 
and monitoring event notification information between an application, hardware 
device or software application and any number of monitoring applications or 
devices. 

Prerequisite Knowledge. Persons configuring an Avamar server to send event 
information over SNMP should be familiar with basic SNMP concepts. A complete 
discussion of basic SNMP concepts and implementation is beyond the scope of this 
publication. Go to www.net-snmp.org for additional information.

The Avamar SNMP implementation provides two distinct ways to access Avamar 
server events and activity status:

• SNMP requests
• SNMP traps

SNMP Requests. SNMP requests provide a mechanism for SNMP management 
applications to “pull” information from a remote SNMP-enabled application or 
device (in this case, the Avamar server). The SNMP management application 
sends a request to an SNMP master agent running on the Avamar server. The 
SNMP master agent then communicates with the Avamar SNMP sub-agent, which 
passes the request to the MCS. The MCS retrieves the data, sends it back to the 
Avamar SNMP sub-agent, which passes it back to the management application by 
way of the SNMP master agent. Data port 161 is the default data port for SNMP 
requests.

SNMP Master Agent. Avamar servers purchased directly from EMC use the Net-
SNMP master agent. Avamar servers built with other industry standard hardware 
will likely use an SNMP master agent provided by the hardware manufacturer.

SNMP Traps. SNMP traps provide a mechanism for the Avamar server to “push” 
information to SNMP management applications whenever designated Avamar 
events occur. Data port 162 is the default data port for SNMP traps. Typically, the 
SNMP management application will listen for any SNMP traps generated by 
designated remote hosts.

MCS

SNMP MASTER 
AGENT

AVAMAR SNMP
SUB-AGENT

AVAMAR SERVER

SNMP TRAPS (PORT 162)

SNMP REQUESTS (PORT 161)

SNMP
MANAGEMENT
APPLICATION
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  191



 Monitoring the Avamar Server Using SNMP
EVENTS, NOTIFICATIONS AND PROFILES
Management Information Base (MIB). Each SNMP application or device 
defines what specific information can be monitored or which traps are sent and 
stores this information in a Management Information Base (MIB). SNMP 
management applications load various MIBs in order to determine what 
information can be expected from the respective SNMP applications or devices.

In order to enable an SNMP management application to monitor an Avamar server, 
the Avamar MIB definition file (AVAMAR-MCS-MIB.txt) must be loaded into the 
master MIB used by the SNMP management application. The Avamar MIB 
definition file can be found in the following locations:

• Single-node servers in /usr/local/avamar/doc
• Multi-node servers in utility node /usr/local/avamar/doc
• Computers running Avamar Administrator in INSTALL-DIR/doc

Where INSTALL-DIR is typically C:\Program Files\avs\administrator on Microsoft 
Windows computers, /usr/local/avamar on Linux computers or 
/opt/AVMRconsl on Solaris computers.

A copy of Avamar MIB definition file (AVAMAR-MCS-MIB.txt) also resides in the 
/usr/share/snmp/mibs directory on single-node servers and utlity nodes. This 
copy is used by the Avamar SNMP sub-agent and should not be moved or 
distributed.

Task List. In order to monitor an Avamar server using SNMP, you must:

1. Install and configure an AgentX compliant master agent.

If your Avamar server was purchased directly from EMC, the Net-SNMP 
master agent is already installed. However, you must configure the Net-
SNMP agent (page 193).

If your Avamar server is built with other industry standard hardware, you 
must install and configure the AgentX compliant master agent provided by 
your hardware vendor.

2. Configure a custom event profile that will output designated Avamar server 
events to an SNMP trap (page 195).
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Configure Net-SNMP Agent

Avamar provides a command-line utility (avsetup_snmp) for configuring the Net-
SNMP agent to communicate with the Avamar server by way of the Avamar SNMP 
sub-agent. 

IMPORTANT:  avsetup_snmp must be run as root and
should be run from the /root directory. 

1. Open a command shell (page 477) and do one of the following:

2. Type:

cd /root

avsetup_snmp

The following information appears in the command shell:

avsetup_snmp will help you set up your snmpd config file: /etc/snmp/snmpd.conf

Enter the port to listen for SNMP requests on [161]:

3. Do one of the following:

If avsetup_snmp was not able to detect any existing SNMP communities, 
the following information appears in the command shell:
No snmp v1/2 communities configured. Forcing access_control configuration.
Running snmpconf to configure access_control group.
reading: /etc/snmp/snmpd.conf
Do you want to allow SNMPv3 read-write user based access (default = y):

4. Type n and press ENTER.

The following information appears in the command shell:
Do you want to allow SNMPv3 read-only user based access (default = y):

5. Type n and press ENTER.

The following information appears in the command shell:
Do you want to allow SNMPv1/v2c read-write community access (default = y):

IF DO THIS

Configuring a multi-node 
server

Log into the utility node 
as root.

Configuring a single-node 
server

Log into the single-node 
server root.

IF DO THIS

You want to use the default SNMP 
request data port (port 161).

Press ENTER to accept the 
default data port assignment.

You want to use a different SNMP 
request data port.

Type the data port number and 
press ENTER.
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6. Type n and press ENTER.

The following information appears in the command shell:
Do you want to allow SNMPv1/v2c read-only community access (default = y): 

7. Press ENTER.

The following information appears in the command shell:
Configuring: rocommunity
Description:

a SNMPv1/SNMPv2c read-only access community name
arguments: community [default|hostname|network/bits] [oid]

The community name to add read-only access for:

The SNMP community is a text string that the local Net-SNMP agent will 
use to authenticate itself with the SNMP management application. 
MyCommunity is used as an example SNMP community for the remainder 
of this procedure.

8. Type your SNMP community and press ENTER.

The following information appears in the command shell:
The hostname or network address to accept this community name from [RETURN for 
all]:

9. Press ENTER.

The following information appears in the command shell:
The OID that this community should be restricted to [RETURN for no-
restriction]: 

10. Press ENTER.

The following information appears in the command shell:
Finished Output: rocommunity public MyCommunity
Do another rocommunity line? (default = y):

11.Type n and press ENTER.

The following information appears in the command shell:

The following files were created:
snmpd.conf installed in /etc/snmp

System settings not configured. Forcing system_setup configuration.
Running snmpconf to configure system_setup group.
reading: /etc/snmp/snmpd.conf

Configuring: syslocation
Description:

The [typically physical] location of the system.
Note that setting this value here means that when trying to 
perform an snmp SET operation to the sysLocation.0 variable
will make the agent return the "notWritable" error code. IE,
including this token in the snmpd.conf file will disable
write access to the variable.

arguments: location_string

The location of the system:

12.Type the physical location of the Avamar server and press ENTER.

The following information appears in the command shell:
Finished Output: syslocation "MyLocation"

Configuring: syscontact
Description:
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The contact information for the administrator
Note that setting this value here means that when trying to
perform an snmp SET operation to the sysContact.0 variable
will make the agent return the "notWritable" error code. IE,
including this token in the snmpd.conf file will disable
write access to the variable.

arguments: contact_string

The contact information:

13.Type your contact information (for example, email address, telephone 
extension and so forth) and press ENTER.

The following information appears in the command shell:
Finished Output: syscontact "root@example.com Extension: 1234"
Do you want to properly set the value of the sysServices.0 OID (if you don't 
know, just say no)? (default = y):

14.Type n and press ENTER.

The following information appears in the command shell:
The following files were created:
snmpd.conf installed in /etc/snmp
Enabling snmpd.

Configure a Custom Event Profile

Local SNMP Trap Profile. As previously mentioned, the default Avamar 
configuration includes a special Local SNMP Trap profile. If enabled, this profile will 
output Avamar server event messages to the local Net-SNMP trap listener 
(snmptrapd process). 

IMPORTANT:  The Local SNMP Trap profile is read-only. You
cannot directly modify it. Furthermore, it is intended to be
used for test purposes only (to verify that traps are success-
fully generated and received by the local snmptrapd process,
which will then write the trap information to a syslog file). 

In most cases, another custom profile will have to be config-
ured to send Avamar SNMP traps to a remote Net-SNMP trap
listener as shown in the diagram on the previous page. 
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Using a Custom Event Profile. If you create a new custom event profile (page 
171) to support syslog monitoring, ensure that the SNMP Trap Notification - 
Enabled option is selected on the first wizard screen.

Continue through the various wizard setup screens until the SNMP Trap wizard 
screen appears.

Type or select the following:

TIP:  To test your SMNP notification parameters, click Send
Test SNMP Trap.

FIELD/OPTION DESCRIPTION

SNMP Trap Address (IP or 
hostname)

IP address or hostname of machine running an 
application capable of receiving and processing an 
SNMP trap. 

Port Number Port number on host machine that is listening for 
SNMP traps.

SNMP Community Name of the SNMP community that the SNMP trap 
listener is configured to use.
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Avamar provides several features and functions that allow you to output various 
system information (reports) in various output formats. 

Each method of generating reports is covered in greater detail elsewhere in this 
chapter. Refer to the following topics for detailed information about creating these 
various reports:

• Avamar Reports (page 197)
• Viewing the Client Summary Report (page 205)
• Viewing the Activity Report (page 209)
• Viewing the Replication Report (page 214)
• Exporting Displayed Tabular Data as CSV Files (page 217)
• Support for Third-Party Reporting Tools (page 222)

Avamar Reports
The Avamar reports feature allows you to create, manage and run various system 
reports. When Avamar reports are run, the results are shown in a separate dialog 
box. The report results can also be exported as a Comma-Separated Values (CSV) 
text file. 

“Predefined” Reports. The following “predefined” reports are provided with 
your Avamar system:

REPORT DESCRIPTION

Activities - Bytes Protected Client This report lists the quantity of primary 
data protected by the system (in bytes) 
for each client.

Activities - Bytes Protected Client - 2 Same as Activities - Bytes Protected 
Client, except that an effective date 
range can be specified.
 AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  197



 Avamar Reports
REPORTING
Activities - Bytes Protected Total This report lists the total quantity of 
primary data protected by the system 
(in bytes).

Activities - Bytes Protected Total - 2 Same as Activities - Bytes Protected 
Total, except that an effective date 
range can be specified.

Activities - Client Stats This report lists various client statistics.

Activities - DPN Summary This report lists summary information 
about data stored in the Avamar server 
and statistical data for each client 
backup.

Activities - Exceptions This report lists all activities within 
specified period that succeeded with 
exceptions.

Activities - Failed This report lists all activities within 
specified period that failed due to errors.

Activities - License Bytes Protected 
Client

This report lists the quantity of primary 
data protected by the system (in bytes) 
for each client in the past 14 days. 
NOTE:  This 14-day time frame 
ensures that any backups belonging to 
clients that might have migrated to 
another Avamar server are not included 
in this server’s licensing calculations.

Activities - License Bytes Protected 
Total

This report lists the total quantity of 
primary data protected by the system 
(in bytes) in the past 14 days. 
NOTE:  This 14-day time frame 
ensures that any backups belonging to 
clients that might have migrated to 
another Avamar server are not included 
in this server’s licensing calculations.

Activities - License Client Stats This report lists various client statistics 
in the past 14 days. 
NOTE:  This 14-day time frame 
ensures that any backups belonging to 
clients that might have migrated to 
another Avamar server are not included 
in this server’s licensing calculations.

Activities - Plugin Client Stats This report lists various plugin statistics 
in the past 14 days. 
NOTE:  This 14-day time frame 
ensures that any backups belonging to 
clients that might have migrated to 
another Avamar server are not included 
in this server’s licensing calculations.

REPORT DESCRIPTION
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Activities - Plugin Stats This report lists various plugin statistics.

Activities - Success This report lists all activities within 
specified period that succeeded without 
exceptions.

Agents/PlugIns - Client Count This report lists all agents and plugins 
installed by all clients and the count for 
each type.

Capacity Usage This report lists past server storage 
capacity utilization.
Refer to Capacity Management (page 
322) for additional information.

Capacity Forecast This report lists expected future (that is, 
forecast) server storage capacity 
utilization.
Refer to Capacity Management (page 
322) for additional information.

Clients - No Activities This report lists all clients that did not 
have any activities in specified period.

Clients - No Check Ins This report lists all clients with last 
check in time not in specified period.

Clients - Protected This report lists:
• All clients with at least one backup 

stored in Avamar server
• Plugins and counts for all clients
• Client operating systems
• Maximum bytes protected for each 

client
• Total bytes protected for all clients

Clients - Unprotected This report lists all clients known to MCS 
but has no clients in Avamar server.

System - Configuration Audit This report lists all currently installed 
server operating system RPMs and 
compares it against a master list that 
was used to initialize the system.

System - GSAN Perf Stats This report lists various data server 
(also known as GSAN) performance 
statistics that are useful for system 
tuning and debugging purposes.
By default, this report is enabled in the 
High Priority Events profile (page 169).

REPORT DESCRIPTION
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  199



 Creating a New Report
REPORTING
Creating a New Report

IMPORTANT:  If you intend to send this report as a custom
event profile attachment (page 169), you must create this
report in the root domain; reports created at lower levels
cannot be sent as custom event profile attachments.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Reports…

The Manage All Reports dialog box appears.

3. In the clients tree, select the domain to which you want to add the new 
report and click New.

The New Report dialog box appears.

4. Type or select the following:

FIELD/OPTION DESCRIPTION

Name Type a name for this new report.

Title Type a display title for this report.

Description Type a short descriptive comment (optional).
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5. Click OK.

The New Report dialog box closes.

Report View Select a database view to use for this report.
Refer to Appendix C — MCS and EMS Database Views 
(page 561) for detailed information about each 
database view and the individual columns storing data 
within each view.

Filter by You can customize your report using the following 
filtering criteria:

• Status (for example, all statuses, all failures, all 
completed and so forth)

• Type (all types, on-demand backup, restore, 
scheduled backup, validate, all backups)

• Group (all groups or a specific group)
• Plugin (for example, Microsoft Windows filesystem, 

Solaris Oracle RMAN database and so forth)
• Date (for example, scheduled start date, scheduled 

end date, completed date and so forth)
• Domain (all domains or a specific domain)
• Client name (all clients or a specific client)

FIELD/OPTION DESCRIPTION
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Editing a Report
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Reports…

The Manage All Reports dialog box appears.

3. In the client tree, select the report you want to edit and click Edit. 

The Edit Report dialog box appears.

 

4. Edit the information you want to change.

Refer to Creating a New Report (page 200) for additional information about 
report properties and settings.

5. Click OK.

The Edit Report dialog box closes.
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Running a Report
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Reports…

The Manage All Reports dialog box appears.

3. In the client tree, select the report you want to run and click Run. 

The Run Report dialog box appears.

4. Click Retrieve to display the report output.

The Run Report dialog box is populated with the current results of this 
report.
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5. If you want to export this data as a Comma-Separated Values (CSV) text 
file, do the following:

(a) Click Export.

The Save dialog box appears.

(b) Browse to the desired folder (directory) and type a descriptive filename 
in the File name field.

(c) Click OK.

The Save dialog box closes.

6. Click Close.

The Run Report dialog box closes.

Deleting a Report
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Reports…

The Manage All Reports dialog box appears.

3. In the client tree, select the report you want to delete and click Delete. 

A confirmation message appears.

4. Click Yes to permanently delete this report.
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Viewing the Client Summary Report
The Client Summary Report is a combined view of important client properties for 
all clients registered with this Avamar server.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Client Summary Report tab.

A blank Client Summary Report window appears.

4. Click Retrieve.

The client summary report displays the following information for each client 
registered on this server:

COLUMN DESCRIPTION

agent_version Version of agent installed.

allow_overtime True if client can ignore scheduling 
window end time.
See also overtime_option (page 207).

allow_userinit_snapup_file_sel Allow file selection on user initiated 
backups.

allow_userinit_snapups Allow user initiated backups.

backed_up_ts Last backup date/time.

can_page True if MCS can call out to client.

checkin_ts Last check-in date/time.

cid Client ID.

client_addr Client IP address.

client_name Client name.
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client_type Client type. Valid values are:
• REGULAR
• VMware vCenter
• VMware Image Proxy
• VMware Virtual Machine

contact_email Contact email address.

contact_location Contact location.

contact_name Person to contact regarding issues with 
this client.

contact_notes Contact notes.

contact_phone Contact phone number.

created Creation date.

ds_override True if client can override group 
dataset

enabled True if client can generate activities.

full_domain_name Fully qualified client location.

has_snapups True if the client has backups.

modified Date that client information was last 
modified.

os_type Client OS type.

override_userinit_retpol Override standard retention policy on 
user initiated backups.

COLUMN DESCRIPTION
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overtime_option One of the following:

ALWAYS Scheduled group 
backups are always 
allowed to run past 
the schedule 
duration setting.

NEXT Only the next 
scheduled group 
backup is allowed 
to run past the 
schedule duration 
setting.

NEXT_SUCCESS Scheduled group 
backups are 
allowed to run past 
the schedule 
duration setting 
until a successful 
backup is 
completed.

NEVER Scheduled group 
backups are never 
allowed to run past 
the schedule 
duration setting.

This value is automatically set to 
NEXT_SUCCESS when client initially 
registers and is cleared after one 
backup successfully completes.

page_addr IP address used to contact this client.

page_port Data port used to contact this client.

pageadr_locked

plugin_for_last_backup Plugin used for the last backup.

rc_override True if client can override group retry 
count setting.

registered True if client has checked into MCS.

registered_ts Registered date/time.

restore_only True if client can only do restores.

retry_cnt Connection retry count.

rp_override True if client can override group 
retention policy.

COLUMN DESCRIPTION
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  207



 Viewing the Client Summary Report
REPORTING
TIP:  You can also reduce the amount of displayed informa-
tion by “filtering” the Client Summary Report to only show
records within a specified range of dates, within a specified
client domain or for one specific client.

5. Select Actions > Filter…

The Report Filter dialog box appears.

6. Define your filtering criteria and click OK.

The Report Filter dialog box closes and the Client Summary Report shows 
only those records that satisfy your filtering criteria.

TIP:  Click Reset Filter to clear any previous filter settings.

timeout Connection timeout value.

tp_override True if client can override group 
timeout period setting.

COLUMN DESCRIPTION
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Viewing the Activity Report
The Activity Report provides detailed information for recent backup, restore and 
validation activities.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Activity or click the Activity launcher button.

The Activity window appears.

3. Click the Activity Report tab.

A blank Activity Report window appears.

4. Click Retrieve.

The activity report displays the following information for each activity:

COLUMN DESCRIPTION

backup_label Backup label. Is blank for replication 
activities.

backup_number Backup number. Is blank for replication 
activities.

bytes_excluded Total number of bytes intentionally excluded 
during this activity.

bytes_new Total number of bytes processed during this 
activity after data deduplication.

bytes_overhead Total number of overhead bytes.

bytes_scanned Total number of bytes processed during this 
activity.

bytes_skipped Total number of bytes unintentionally 
skipped (errors and so forth) during this 
activity.

cid Client ID. 
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client_name Avamar client name.

client_os Client operating system.

client_ver Avamar client software version.

completed_ts Actual date and time this activity ended, 
adjusted for the prevailing time zone 
(shown in parentheses).

current_retention Current retention types (page 73) assigned 
to this backup. One or more of the 
following:

D Backup has been tagged as a 
daily backup.

W Backup has been tagged as a 
weekly backup.

M Backup has been tagged as a 
monthly backup.

Y Backup has been tagged as a 
yearly backup.

N Backup has been tagged as 
having no specific retention type.

dataset Dataset (page 100) used to perform this 
backup.

dataset_override If true, the group dataset was not used for 
this activity.

domain Full location of the client in the Avamar 
server.

effective_expiration Actual calendar date and time that this 
backup will expire.

effective_path Actual dataset used in backup (applies to 
group-based backups only).

encryption_method Encryption method used for client/server 
data transfer. Choices are:

• proprietary
• ssl

COLUMN DESCRIPTION
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encryption_method2 Encryption method used for client/server 
data transfer. Choices are:

High Strongest available encryption 
setting for that specific client 
platform.

Medium Medium strength encryption.

None No encryption.

NOTE:  The exact encryption technology 
and bit strength used for any given client-
server connection is dependent on a 
number of factors, including the client 
platform and Avamar server version. Refer 
to your Avamar Product Security Guide for 
additional information.

encrypt_method2_sa

error_code If the activity successfully completed, zero 
appears in this column.
If the activity did not successfully complete, 
a numeric error code will be shown. 
Refer to your Avamar Event Codes Listing 
for additional information.

error_code_summary If activity did not successfully complete, a 
short summary of this error code. 

group_name If the activity was a scheduled backup, this 
is the group that this client was a member 
of when this particular scheduled activity 
was initiated (clients can be members of 
more than one group). On-demand is 
shown for all other activities.

initiated_by Activity initiated by (applies to On-Demand 
Backup activity only).

num_files_skipped Total number of files unintentionally skipped 
(errors and so forth) during this activity.

num_of_files Total number of files processed during this 
activity.

COLUMN DESCRIPTION
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original_retention Original retention types (page 73) that were 
programmatically assigned to this backup 
when it occurred. One or more of the 
following:

D Backup has been tagged as a 
daily backup.

W Backup has been tagged as a 
weekly backup.

M Backup has been tagged as a 
monthly backup.

Y Backup has been tagged as a 
yearly backup.

N Backup has been tagged as 
having no specific retention type.

plugin_number Plugin (page 19) used for this activity.

proxy_cid VMware proxy client unique ID.

retention_policy Retention policy (page 119) used to 
perform this backup.

retention_policy_override If true, the group retention policy was not 
used for this activity.

schedule If the activity was a scheduled backup, this 
is the schedule (page 109) that initiated this 
activity. 
On-Demand or End User Request is shown 
for all other activities initiated from Avamar 
Administrator or the client, respectively.

scheduled_end_ts Latest date and time this activity was 
scheduled to end, adjusted for the 
prevailing time zone (shown in 
parentheses).

scheduled_start_ts Earliest date and time this activity was 
scheduled to begin, adjusted for the 
prevailing time zone (shown in 
parentheses).

session_id Work order ID. Unique identifier for this 
activity.

started_ts Actual date and time this activity was 
started, adjusted for the prevailing time 
zone (shown in parentheses).

COLUMN DESCRIPTION
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TIP:  You can also reduce the amount of displayed informa-
tion by “filtering” the Activity Report to only show records
within a specified range of dates, within a specified client
domain or for one specific client.

5. Select Actions > Filter…

The Report Filter dialog box appears.

6. Define your filtering criteria and click OK.

The Report Filter dialog box closes and the Activity Report shows only 
those records that satisfy your filtering criteria.

TIP:  Click Reset Filter to clear any previous filter settings.

status_code Numeric event code describing latest status 
of this activity.
Refer to your Avamar Event Codes Listing 
for additional information.

status_code_summary Short summary of this status code. 

type One of the following:
• On-Demand Backup (page 84)
• Scheduled Backup (page 109)
• Restore (page 84)
• Validate (page 92)

COLUMN DESCRIPTION
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Viewing the Replication Report
The Replication Report provides detailed information for recent replication 
operations.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Activity or click the Activity launcher button.

The Activity window appears.

3. Click the Replication Report tab.

A blank Replication Report window appears.

4. Click Retrieve.

The Replication report displays the following information for each 
replication operation:

COLUMN DESCRIPTION

bytes_excluded Total number of bytes intentionally excluded 
during this replication operation.

bytes_new Total number of bytes processed during this 
replication operation after data 
deduplication.

bytes_overhead Total number of overhead bytes.

bytes_scanned Total number of bytes processed during this 
replication operation.

bytes_skipped Total number of bytes unintentionally 
skipped (errors and so forth) during this 
replication operation.

cid Client ID. 

client_name Avamar client name.

client_os Client operating system.
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client_ver Avamar client software version.

completed_ts Actual calendar date and time this 
replication operation ended.

domain Full location of the client in the Avamar 
server.

encryption_method Encryption method used for client/server 
data transfer. Choices are:

• proprietary
• ssl

encryption_method2 Encryption method used for client/server 
data transfer. Choices are:

Medium Medium strength encryption.

High Strongest available encryption 
setting for that specific client 
platform.

None No encryption.

NOTE:  The exact encryption technology 
and bit strength used for any given client-
server connection is dependent on a 
number of factors, including the client 
platform and Avamar server version. Refer 
to your Avamar Product Security Guide for 
additional information.

encrypt_method2_sa

error_code If replication operation did not successfully 
complete, a numeric error code will be 
shown. 

error_code_summary If replication operation did not successfully 
complete, a short summary of this error 
code. 

num_files_skipped Total number of files unintentionally skipped 
(errors and so forth) during this replication 
operation.

num_of_files Total number of files processed during this 
replication operation.

plugin_number Plugin (page 19) used for this replication 
operation.

scheduled_end_ts Calendar date and time this replication 
operation was scheduled to end.

scheduled_start_ts Calendar date and time this replication 
operation was scheduled to occur.

COLUMN DESCRIPTION
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TIP:  You can also reduce the amount of displayed informa-
tion by “filtering” the Replication Report to only show records
within a specified range of dates, within a specified client
domain or for one specific client.

5. Select Actions > Filter…

The Report Filter dialog box appears.

6. Define your filtering criteria and click OK.

The Report Filter dialog box closes and the Replication Report shows only 
those records that satisfy your filtering criteria.

TIP:  Click Reset Filter to clear any previous filter settings.

session_id Work order ID. Unique identifier for this 
replication operation.

started_ts Actual calendar date and time this 
replication operation was started.

status_code Numeric event code returned by this 
replication operation. 

status_code_summary Short summary of this status code. 

COLUMN DESCRIPTION
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Exporting Displayed Tabular Data as CSV Files
Avamar also provides a simple mechanism for exporting certain tabular data 
displayed within Avamar Administrator as Comma-Separated Values (CSV) text 
files. 

The following areas of Avamar Administrator support exporting displayed tabular 
data as Comma-Separated Values (CSV) text files:

• Activity Report (page 217)
• Replication Report (page 218)
• Client Summary Report (page 219)
• Event Management (page 220)
• Session Monitor (page 221)

Activity Report

1. Start Avamar Administrator (page 21).

2. Select Navigation > Activity or click the Activity launcher button.

The Activity window appears.

3. Click the Activity Report tab.

4. Click Retrieve to populate this screen with information.
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5. Select Actions > Export Report...

The Save dialog box appears.

6. Browse to the desired folder (directory) and type a descriptive filename in 
the File name field.

7. Click OK.

The Save dialog box closes.

Replication Report

1. Start Avamar Administrator (page 21).

2. Select Navigation > Activity or click the Activity launcher button.

The Activity window appears.

3. Click the Replication Report tab.

4. Click Retrieve to populate this screen with information.
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5. Select Actions > Export Report...

The Save dialog box appears.

6. Browse to the desired folder (directory) and type a descriptive filename in 
the File name field.

7. Click OK.

The Save dialog box closes.

Client Summary Report

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Client Summary Report tab.

4. Click Retrieve to populate this screen with information.
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5. Select Actions > Export Report...

The Save dialog box appears.

6. Browse to the desired folder (directory) and type a descriptive filename in 
the File name field.

7. Click OK.

The Save dialog box closes.

Event Management

1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Event Management tab.
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4. Select Actions > Event Monitor > Export Events Report...

The Save dialog box appears.

5. Browse to the desired folder (directory) and type a descriptive filename in 
the File name field.

6. Click OK.

The Save dialog box closes.

Session Monitor

1. Start Avamar Administrator (page 21).

2. Select Navigation > Avamar Server or click the Avamar Server 
launcher button.

The Avamar Server window appears.

3. Click the Session Monitor tab.
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4. Select Actions > Export Sessions Report...

The Save dialog box appears.

5. Browse to the desired folder (directory) and type a descriptive filename in 
the File name field.

6. Click OK.

The Save dialog box closes.

Support for Third-Party Reporting Tools

PostgreSQL. Avamar uses a PostgreSQL database to store various data. 
PostgreSQL is a highly regarded open-source Relational Database Management 
System (RDMS). Information in the Avamar database is accessible through any 
PostgreSQL-compliant Open DataBase Connectivity (ODBC) interface. 

Crystal Reports Templates. Crystal Reports is a popular database reporting 
tool. Avamar Administrator provides several Crystal Reports templates you can 
use to quickly generate various Avamar system reports. You can also customize 
these templates for your specific needs or create new ones.
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Setting Up the PostgreSQL ODBC Driver
This topic describes how to set up and configure the Microsoft Windows 
PostgreSQL ODBC Driver on your local Windows client in order to support common 
third-party reporting packages such as Crystal Reports.

1. Download and install the latest driver from the PostgreSQL web site 
(www.postgresql.org).

2. Select Start > Settings > Control Panel > Administrative Tools.

 The Administrative Tools window appears.

3. Double-click Data Sources (ODBC).

The ODBC Data Source Administrator appears.

4. Click the System DSN tab.

5. Click Add...

The Create New Data Source dialog box appears.

6. Select the PostgreSQL Driver and click Finish.

The PostgreSQL ODBC Driver (psqlODBC) Setup dialog box appears.
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7. Type the following:

8. Click Options > Datasource.

The Advanced Options (DSN 1 / 2) dialog box appears. 

9. Select or clear the following:

(a) Under Unknown Sizes, select Don't Know.

(b) Clear Text as LongVarChar.

(c) Clear Bools as Char.

10.Click OK.

The Advanced Options (DSN 1 / 2) dialog box closes.

11.Switch to PostgreSQL ODBC Driver (psqlODBC) Setup dialog box and click 
Save.

The PostgreSQL ODBC Driver (psqlODBC) Setup dialog box closes.

12.Switch to ODBC Data Source Administrator and click OK.

The ODBC Data Source Administrator closes.

13.Close the Administrative Tools and Control Panel windows.

FIELD DESCRIPTION

Data Source Type a short name (for example, MCDatabase). 

Description Leave this blank.

Database Type mcdb.

Server Hostname where mcdb is running (for example, 
dpn50mcs).

Port Leave this set to 5555.

User name Type viewuser.

Password Type viewuser1.
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Crystal Reports Templates
Avamar provides a set of Crystal Reports templates you can use to quickly 
generate various reports.

The default location for these templates is:

• C:\Program Files\avs\administrator\doc on Windows
• /usr/local/avamar/doc on Linux

TIP:  A complete discussion of how to use Crystal Reports
templates is beyond the scope of this publication. Refer to
your Crystal Reports documentation for additional informa-
tion. 

The following table lists the various default Avamar Crystal Reports templates: 

TEMPLATE NAME (FILENAME) DESCRIPTION

Client Installation Report 
(ClientInstallation.rpt)

This report contains information for all 
clients installed on the MCS when the 
report is run.

Errors and Warning Events Report 
(ErrorWarningEvents.rpt)

This report contains all events of warning 
or error severity within a specified date 
and time interval.

Events Report (AllEvents.rpt) This report contains all events recorded by 
the MCS within a specified date and time 
interval.

Failed Restores Report 
(FailedRestores.rpt)

This report contains information for all 
failed restores within a specified date and 
time interval for all clients or for a specific 
client.

Failed Backups Report 
(FailedBackup.rpt)

This report contains information for all 
failed backups within a specified date and 
time interval for all clients or for a specific 
client.

Group Backup By Group Report 
(GroupbackupByGroup.rpt)

This report contains group backup 
statistics for all groups or for a specific 
group.

Group Backup By Schedule Report 
(GroupbackupByScheduled.rpt)

This report contains group backup 
statistics for backups initiated within a 
specified date and time interval.

Server Drive Capacity Report 
(ServerDriveCapacity.rpt)

This report provides hard drive capacity 
statistics for each server node based on 
the specified date and time interval.

Successful Restores Report 
(SuccessfulRestores.rpt)

This report contains information for all 
successful restores within a specified date 
and time interval for all clients or for a 
specific client.
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Other Third-Party Support

dbviews.sql. You can also generate Avamar reports using any third-party 
PostgreSQL-compliant ODBC database reporting tool that runs on your platform. 
However, you must create your own report templates using the schema listings 
found in dbviews.sql. This file is located in the utility node 
/usr/local/avamar/lib/sql directory. 

Refer to Appendix C — MCS and EMS Database Views (page 561) for detailed 
information about each view in dbviews.sql view and the individual columns 
storing data within each view.

Successful Backups Report 
(SuccessfulBackup.rpt)

This report contains information for all 
successful backups within a specified date 
and time interval for all clients or for a 
specific client.

TEMPLATE NAME (FILENAME) DESCRIPTION
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AVAMAR CLIENT AGENT AND PLUGIN MANAGEMENT

This chapter introduces and discusses the manage all client agents and plugins 
feature.

TIP:  Refer to Avamar Clients (page 19) for a general dis-
cussion of client agents and plugins and their role in the
Avamar system. 

Important Terms and Concepts
Each time a client communicates with an Avamar server, it identifies itself by 
sending the client ID, the specific agent version and build running on that client, 
as well as a list of plugins (version and build) currently installed on that client. 
Occasionally, because of known incompatibilities, system administrators may want 
to deny Avamar server access to all clients running a specific version (all builds) or 
a specific build of a client agent or plugin. The manage all client agents and 
plugins feature provides the mechanism for accomplishing this.

Disabling a Version or Build. System administrators can deny all access to the 
server on a version-by-version (all builds) or build-by-build basis. This is done by 
editing the properties for a particular agent or plugin version or build and setting 
the Disable option. Once an agent or plugin is disabled, it is denied all access to 
the server.
 AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  227



 Important Terms and Concepts
AVAMAR CLIENT AGENT AND PLUGIN MANAGEMENT
Selective Management of Plugin Operations. System administrators can 
also selectively allow or disallow individual plugin operations for all clients running 
a specific plugin version (all builds) or build. These individual operations are:

• Client activations initiated from the client
• On-demand backups initiated from the client
• Scheduled backups
• Restores
• Backup validation
• Ability to browse stored backups on the server

Refer to Editing Version or Build Record Settings (page 235) for additional 
information.

Obsolete Versions and Builds. Any specific version (all builds) or build 
designated as “obsolete” is completely denied all access to the Avamar server. The 
reason for this is that designating a build as “obsolete” is only done in cases of 
known incompatibility between the client agent or plugin and the specific version 
of server software that was just installed. Therefore, in order to prevent potential 
problems, this obsolete designation is absolute and final and cannot be overridden 
by using the manage all agents and plugins feature to edit properties for that 
version or build. 
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Agents Summary View
The agents summary view shows a current list of all client agent versions and 
builds potentially known to this Avamar server. 

IMPORTANT:  Agent versions and builds not supported by
this specific version of Avamar server software are shown as
“obsolete.” Clients running these specific versions or builds
are completely denied access to the server. This designation
is absolute and final and cannot be overridden. Clients run-
ning these obsolete versions or builds must upgrade before
they can access this server. Contact EMC Technical Support
for additional information.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Agents & Plug-ins…

The Manage All Agents & Plug-ins window appears.

3. Click the Agents Summary tab.

Client Agent
Properties

The following table lists and explains the properties shown for each client 
agent:

PROPERTY DESCRIPTION

Name Name of this client agent.

Version Specific version of this client agent. 

Build Specific software build of this client agent or ALL, if 
this entry is applicable to all builds.

Obsolete Yes or no. If yes, the agents and plugins definition 
file has reported that this specific client agent 
version (all builds) or build has been superseded 
by a newer version or build. 
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  229



 Agents Summary View
AVAMAR CLIENT AGENT AND PLUGIN MANAGEMENT
Disabled Yes or no. If yes, the MCS will not respond to 
communication requests from any client running 
this specific client agent version (all builds) or 
build.

Client Registration 
Disabled

Yes or no. If yes, clients running this agent version 
(all builds) cannot register with this Avamar server.

PROPERTY DESCRIPTION
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Plugins Summary View
The plugins summary view shows a current list of all client plugins versions and 
builds potentially known to this Avamar server. 

IMPORTANT:  Specific plugin versions and builds not sup-
ported by this specific version of Avamar server software are
shown as “obsolete.” Clients running these specific versions
or builds are completely denied access to the server. This
designation is absolute and final and cannot be overridden.
Clients running these obsolete versions or builds must
upgrade before they can access this server. Contact EMC
Technical Support for additional information.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Agents & Plug-ins…

The Manage All Agents & Plug-ins window appears.

3. Click the Plug-ins Summary tab.

Plugin Properties The following tables lists and explains the properties shown for each 
plugin:

PROPERTY DESCRIPTION

Name Name of this plugin.

Version Specific version of this plugin.

Build Specific software build of this plugin or 
ALL, if this entry is applicable to all 
versions.

Obsolete Yes or no. If yes, the agents and plugins 
definition file has reported that this 
specific client plugin version (all builds) 
or build has been superseded by a newer 
version or build. 
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Disabled Yes or no. If yes, any client running this 
specific client plugin version (all builds) 
or build will be prevented from 
performing any backup, restore or 
validation activities.

Client Backups Disabled Yes or no. If yes, on-demand backups 
cannot be initiated by clients running this 
specific client plugin version (all builds) 
or build.

Scheduled Backups Disabled Yes or no. If yes, scheduled backups will 
not be performed on clients running this 
specific client plugin version (all builds) 
or build.

Restore Disabled Yes or no. If yes, restores (page 84) 
cannot be performed on clients running 
this specific client plugin version (all 
builds) or build.

Browse Disabled Yes or no. If yes, clients running this 
specific plugin version (all builds) or build 
will not be allowed to browse the restore 
calendar.
Unsupported denotes that this specific 
plugin version does not support selective 
management of this feature.

Validate Disabled Yes or no. If yes, backup validations 
(page 92) cannot be performed using 
this specific plugin version.
Unsupported denotes that this specific 
plugin version does not support selective 
management of this feature.

Extended Cancel Timeout Yes or no. If yes, clients running this 
specific plugin version (all builds) or build 
will be allowed additional time to cancel a 
work order before Avamar Administrator 
forcibly cancels it.

PROPERTY DESCRIPTION
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Adding a New Build Record
This procedure adds a new MCS database record for a specific client agent or 
plugin build. You can only add new records at the build level; you cannot add a 
record for a new version (all builds). New version records are automatically added 
following Avamar server software upgrades.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Agents & Plug-ins…

The Manage All Agents & Plug-ins window appears.

3. In the tree, select the agent or plugin version to which you want to add a 
new build.

4. Click New.

The New Build dialog box appears.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  233



 Adding a New Build Record
AVAMAR CLIENT AGENT AND PLUGIN MANAGEMENT
5. Type or select the following:

6. Click OK.

The New Build dialog box closes.

FIELD/OPTION DESCRIPTION

Build Type a valid agent or plugin build number in 
this field.

Disable option Select this option if you want to deny Avamar 
server access to any clients running this 
specific agent or plugin build.

Disable Client 
Initiated Registration 
option

Select this option if you want to prevent any 
clients running this specific agent or plugin 
build from registering with the Avamar server.

Comment Type a short descriptive comment in this field 
(optional).
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Editing Version or Build Record Settings
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Agents & Plug-ins…

The Manage All Agents & Plug-ins window appears.

3. In the tree, select the agent or plugin version or build you want to edit.

4. Click Edit.

The Edit Build dialog box appears.

5. Edit the information you want to change.

Refer to Adding a New Build Record (page 233) for additional information 
about agent and plugin build settings.

6. Click OK.

The Edit Build dialog box closes.
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Deleting a Build Record
This procedure deletes an existing MCS database record for a specific client agent 
or plugin build. You can only delete records at the build level; you cannot delete a 
record for an entire version.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Agents & Plug-ins…

The Manage All Agents & Plug-ins window appears.

3. In the tree, select the agent or plugin build you want to delete.

4. Click Delete.
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Enabling All Client Initiated Activations
If all client initiated activations have previously been disabled (page 238), you 
must reenable them before any new Avamar clients can initiate activation with the 
Avamar server.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Agents & Plug-ins…

The Manage All Agents & Plug-ins window appears.

3. Click Enable All Client Initiated Activations.

The Enable All Client Initiated Activations button changes to Disable 
All Client Initiated Activations.
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Disabling All Client Initiated Activations
An Avamar administrator can disable all new client initiated client activations until 
such time as they are reenabled (page 237). This is typically done to place the 
system in a state that will support various maintenance activities.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Agents & Plug-ins…

The Manage All Agents & Plug-ins window appears.

3. Click Disable All Client Initiated Activations.

The Disable All Client Initiated Activations button changes to Enable 
All Client Initiated Activations.
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Enabling All Client Initiated Backups
If all client backups have previously been disabled (page 240), you must reenable 
them before any Avamar clients can initiate on-demand backups.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Agents & Plug-ins…

The Manage All Agents & Plug-ins window appears.

3. Click Enable All Client Initiated Backups.

The Enable All Client Initiated Backups button changes to Disable All 
Client Initiated Backups.
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Disabling All Client Initiated Backups
An Avamar administrator can disable the ability of Avamar clients to initiate on-
demand backups until such time as they are reenabled (page 239). This is 
typically done to place the system in a state that will support various maintenance 
activities.

1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Agents & Plug-ins…

The Manage All Agents & Plug-ins window appears.

3. Click Disable All Client Initiated Backups.

The Disable All Client Initiated Backups button changes to Enable All 
Client Initiated Backups.
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SERVER MONITORING

This chapter describes how to monitor various aspects of Avamar server 
performance.

Recommended Daily Server Monitoring
To ensure that your Avamar server is working properly, EMC recommends 
performing these system monitoring tasks on a daily basis:

• From the Activity Monitor (page 76) — investigate any abnormal client 
activity

• From the Server Monitor (page 242) — confirm that last checkpoint and 
validated checkpoint are recent (ideally within the past 24 hours)

• From the Event Monitor (page 256) — investigate any error or warning 
messages

• From the Unacknowledged Events list (page 276) — investigate and clear 
(acknowledge) any unacknowledged events 

TIP:  EMC recommends that you enable the “Email Home”
feature (page 183), which will automatically email EMC
Technical Support with status of the daily data integrity
check and other important server messages.
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Monitoring the Server
1. Start Avamar Administrator (page 21).

2. Select Navigation > Avamar Server or click the Avamar Server 
launcher button.

The Avamar Server window appears.

Server Monitor Tab

The Server Monitor tab presents a summarized view of CPU, network and hard 
drive performance statistics for each node.

PROPERTY DESCRIPTION

N
O

D
E

Status 
indicators

One of the following:

Online (green) Node is functioning properly.

Read-Only (blue) This occurs normally as background 
operations are performed and when 
backups have been suspended (page 
277). 

Time-Out (gray) MCS could not communicate with this 
node.

Unknown (yellow) Node status cannot be determined.

Offline (red) Node has experienced a problem. 
Contact EMC Technical Support for 
additional information.

N
O

D
E

ID Each node in the Avamar server has a unique logical 
identifier. This node ID is expressed in the following format: 

MODULE.NODE
NOTE:  Module and node numbering begins with zero. 
Therefore, the ID for the third node in the first module is 
0.2.
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Server Management Tab

The Server Management tab shows a detailed view of the server hardware 
resources. The display is context-sensitive:

• Selecting the top-level server folder in the tree pane shows detailed 
information for the Avamar server

• Selecting a module folder in the tree pane shows detailed information for that 
module

• Selecting a node icon in the tree pane shows detailed information for that node
• Selecting a partition icon in the tree pane shows detailed information for that 

logical hard drive partition

C
P

U

Load Average number of CPU threads over the past minute.

User Percentage of CPU capacity consumed by executing actual 
server instructions (anything other than operating system 
overhead). 

Sys Percentage of CPU capacity consumed by operating system 
overhead. 

N
E

T
W

O
R

K Ping Time in seconds this node took to respond to a ping request.

In Received packet throughput reported in KB/second.

Out Sent packet throughput reported in KB/second.

D
IS

K

Reads Average number of hard drive reads per second as reported 
by the operating system. 

Writes Average number of hard drive writes per second as reported 
by the operating system. 

Utilization Percentage of total available server storage capacity 
currently used.

PROPERTY DESCRIPTION
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PROPERTY DESCRIPTION
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Active sessions Current number of active client sessions. Click the 
Session Monitor tab (page 252) for additional 
information.

Total capacity Total amount of server storage capacity.

Capacity used Total amount of server storage capacity that has 
been used for any reason.

Server utilization Percentage of total available server storage 
capacity currently used.
NOTE:  This value is derived from the largest 
Disk Utilization value shown in the Server 
Monitor tab (page 242) and therefore represents 
the absolute maximum Avamar server 
utilization; actual utilization across all modules, 
nodes and drives might actually be slightly lower.

Bytes protected Total amount of client data in bytes that has been 
backed up (protected) on this server. 

Bytes protected 
quota

Maximum amount of client data in bytes that is 
licensed for protection on this server. 

License expiration Calendar date on which this server's licensing 
expires, or never if licensing is perpetual.

Time since Server 
initialization

Number of hours, days and minutes that have 
elapsed since this Avamar server was initialized.

Last checkpoint Date and time last server checkpoint was 
performed. Checkpoints are typically taken twice 
daily.

Last validated 
checkpoint

Date and time server checkpoint was last 
validated. Checkpoint validation normally occurs 
once per day. Therefore, the Last validated 
checkpoint time and Last checkpoint time might 
be different depending on the time of day you 
view this information.
IMPORTANT:  If the Last validated checkpoint 
and Last checkpoint times are more than 36 
hours apart, this indicates that checkpoint 
validation is not occurring. This is a problem. 
Contact EMC Technical Support for additional 
information.

System Name User-assigned name of this Avamar server.

System ID Unique identifier for this Avamar server.
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HFSAddr Hash Filesystem (HFS) address (Addr). This is the 
hostname or IP address backup clients use to 
connect to this Avamar server.

HFSPort Hash Filesystem (HFS) data port. This is the data 
port backup clients use to connect to this Avamar 
server. Default is port 27000.

IP Address Actual IP address of this Avamar server. If the 
HFSAddr is an IP address, this value will be the 
same as the HFSAddr.

M
A

IN
T

E
N

A
N

C
E

 A
C

T
IV

IT
IE

S
 D

E
T

A
IL

S Suspended One of the following:

No Server maintenance activities are 
not currently suspended (that is, 
server maintenance activities will 
run normally during next 
maintenance (page 275) or 
blackout (page 274) window).

Yes Server maintenance activities are 
currently suspended.

PROPERTY DESCRIPTION
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Status One of the following:

Idle Garbage collection is not currently 
taking place.

Processing Garbage collection is currently 
taking place.

Result One of the following:

OK Last garbage collection activity 
successfully completed.

Error code Last garbage collection activity did 
not successfully complete.

Start time Date and time that last garbage collection activity 
began.

End time Date and time that last garbage collection activity 
ended.

Passes Total number of passes during last garbage 
collection activity.

Bytes recovered Total amount of storage space (in bytes) that was 
recovered during last garbage collection activity.

Chunks deleted Total number of data chunks that were deleted 
during last garbage collection activity.

Index stripes

Index stripes 
processed

Total number of index stripes that were processed 
during last garbage collection activity.

PROPERTY DESCRIPTION

Total capacity Total amount of server storage capacity.

Capacity used Total amount of server storage capacity that has been 
used for any reason.

Avamar Server 
utilization

Percentage of total available server storage capacity 
currently used.
NOTE:  This value is derived from the largest Disk 
Utilization value shown in the Server Monitor tab 
(page 242) and therefore represents the absolute 
maximum Avamar server utilization in this module; 
actual utilization across all modules, nodes and drives 
might actually be slightly lower.

Number of Nodes Total number of nodes in this module.

IP Address Base IP address of this module.

PROPERTY DESCRIPTION
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Node Detail

PROPERTY DESCRIPTION

Status indicators One of the following:

Online (green) Node is functioning properly.

Read-Only (blue) This occurs normally as 
background operations are 
performed and when backups 
have been suspended (page 
277). 

Time-Out (gray) MCS could not communicate 
with this node.

Unknown 
(yellow)

Node status cannot be 
determined.

Offline (red) Node has experienced a 
problem. Contact EMC Technical 
Support for additional 
information.

A
V

A
M

A
R

 S
E

R
V

E
R

 D
E

T
A

IL
S

State Current operational state of the server. One of the 
following:

ONLINE Node is functioning properly.

DEGRADED One or more disk errors have 
been detected.

OFFLINE Node has experienced a 
problem. Contact EMC Technical 
Support for additional 
information.

READONLY This occurs normally as 
background operations are 
performed and when backups 
have been suspended (page 
277). 
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Runlevel Current operational state of the server. One of the 
following:

fullaccess This Avamar server is fully 
operational.

admin Avamar server is fully 
operational but only the 
administrator root account can 
access the server.

adminonly Avamar server is fully 
operational but only the 
administrator root account can 
access the server.

adminreadonly Avamar server is in a read-only 
condition and only the 
administrator root account can 
access the server.

readonly Avamar server is in a read-only 
condition. Restores are allowed 
but no new backups can be 
taken.

suspended Scheduled backups are disabled 
and will not occur until you 
reenable the scheduler. Refer to 
Suspending Scheduled 
Operations (page 279) for 
additional information.

synchronizing Avamar server is priming or 
synchronizing stripes. This is a 
temporary condition. Some 
operations might be delayed.

PROPERTY DESCRIPTION
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Accessmode Current access level of the server.
The full server access mode is typically represented 
as three four-bit fields. For example: 

mhpu+mhpu+0000
The most significant bits show server privileges, the 
middle bits show root user privileges and the least 
significant bits show privileges for all other users. 
Individual bits in these fields convey the following 
information:

m Maintenance allowed.

h Hash Filesystem (HFS) is writable.

p Persistent store is writable.

u User accounting is writable.

Port Data port used for intra-node communication.

Dispatcher Data port used by various utilities to communicate 
with this node.

Avamar Server 
uptime

Number of hours, days and minutes that have 
elapsed since this Avamar server was initialized.

Total capacity Total amount of server storage capacity.

Capacity used Total amount of server storage capacity that has 
been used for any reason.

Avamar Server 
utilization

Percentage of total available node storage capacity 
currently used.
NOTE:  This value is derived from the largest Disk 
Utilization value shown in the Server Monitor tab 
(page 242) and therefore represents the absolute 
maximum Avamar server utilization in this node; 
actual utilization across all modules, nodes and 
drives might actually be slightly lower.

Num stripes Number of stripes on this node.

Avamar Server 
version

Version of the Avamar software running on this 
node.

PROPERTY DESCRIPTION
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Version Current operating system version running on this 
node.

Node uptime Number of hours, days and minutes that have 
elapsed since this node was last booted.

Load average The average number of CPU threads over the past 
minute.

CPU % Percentage of this node’s CPU currently being used.

Ping time (sec) Time in seconds this node took to respond to a ping 
request.

Disk reads Number of hard drive read operations per second.

Disk writes Number of hard drive write operations per second.

Network reads Number of Kilobytes per second read by way of this 
node’s network connection.

Network writes Number of Kilobytes per second written by way of 
this node’s network connection.

H
A

R
D

W
A

R
E

 D
E

T
A

IL
S IP address IP address of this node.

MAC address Media Access Control (MAC) address. A low-level 
hardware address that uniquely identifies this node 
in the Avamar server.

Number of 
partitions

Total number of logical hard drive partitions in this 
node.

PROPERTY DESCRIPTION
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Partition Detail

PROPERTY DESCRIPTION

Status 
indicators

One of the following:

Online (green) Partition is functioning 
properly.

Offline (yellow) Partition has one or more 
offline stripes. Contact EMC 
Technical Support for 
additional information.

Read-Only (blue) Partition is read-only.

Nonfunctional (red) Partition is not functioning. 
Contact EMC Technical Support 
for additional information.
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Total capacity Total amount of server storage capacity.

Capacity used Total amount of server storage capacity that has been 
used for any reason.

Avamar Server 
utilization

Percentage of total available partition storage capacity 
currently used.

State Current operational state of this partition. One of the 
following:

ONLINE Partition is functioning 
properly.

MIGRATING Transitional state that might or 
might not be due to normal 
operation.

OFFLINE Transitional state that might or 
might not be due to normal 
operation.

READY Transitional state that might or 
might not be due to normal 
operation.

RESTARTING Transitional state that might or 
might not be due to normal 
operation.

Number of 
offline stripes

Total number of stripes on this partition that are 
offline due to media errors.

Number of 
transitioning 
stripes

Total number of stripes on this partition that are in a 
transitional state that might or might not be due to 
normal operation.
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Session Monitor Tab

The Session Monitor tab shows a list of active client backup and restore sessions. 

PROPERTY DESCRIPTION

U
S

E
R

User Avamar user ID (account name).

Path Specifies a hierarchical location in the Avamar server. This 
option is relative to the user's home location unless slash 
(/) is prefixed to the path designation, in which case an 
absolute path is assumed. 

Domain Avamar domain (page 33) where this user resides.

Client ID Unique identifier for this Avamar client.

S
E

S
S

IO
N

Type This activity is one of the following:
• avtarbackup
• avtarrestore

Root Top-level of the filesystem being backed up, restored or 
validated.

Start time Date and time this client session started.

Plug-in Plugin (page 19) used for this activity.

Session ID Unique identifier for this client session.

Work order ID Unique identifier for this activity.

Elapsed Length of time this client session has been running.

Progress bytes Total number of bytes examined during this activity.

New bytes Percentage of new bytes backed up. Low numbers 
indicate high levels of data deduplication.

S
Y

S
T

E
M Name Client hostname.

OS name Operating system used by this client.

App version Avamar client software version.
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Checkpoint Management Tab

The Checkpoint Management tab shows detailed information for all system 
checkpoints taken for this Avamar server. Refer to Checkpoints (page 351) for 
additional information. 

PROPERTY DESCRIPTION

Status indicators One of the following:

Checkpoint failed validation.

Checkpoint has not yet been validated.

Validation is currently being performed on this 
checkpoint.

Checkpoint passed validation.

Tag Unique identifier for this checkpoint. 

Time Date and time that this checkpoint was taken.

Nodes Total number of nodes involved in this checkpoint.

Stripes Total number of stripes involved in this checkpoint.

Checkpoint Validation 
- Start Time

Date and time that this checkpoint validation was 
initiated.

Checkpoint Validation 
- Finished Time

Date and time that this checkpoint validation 
completed.

Checkpoint Validation 
- Errors

Number of errors encountered during this checkpoint 
validation.

Checkpoint Validation 
- Type

One of the following:

Full Validation performed all checks.

Rolling All new and modified stripes were 
fully validated and a subset of 
unmodified stripes were validated.
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Domains/Clients Tab

The Domains/Clients tab shows the nested 
domain structure on this server and all clients 
currently registered to this server. Refer to 
Domains and Subdomains (page 33) and Clients 
(page 38) for additional information.
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Verifying System Integrity
To verify Avamar server integrity, you must first ensure that a validated server 
checkpoint exists. You might also want to collect and examine the server log files 
(page 270) to ensure that no errors have occurred since that checkpoint was 
taken.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Avamar Server or click the Avamar Server 
launcher button.

The Avamar Server window appears.

3. Click the Server Management tab.

4. Verify that the Last validated checkpoint field shows a recent calendar 
date.

You should also manually collect and view server log files for errors. Refer 
to Collecting and Viewing Log Files (page 270) for additional information.
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Viewing System Events
1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Event Management tab.

The Event Monitor provides two basic display modes: query mode or 
monitor mode. 

4. Click the Event Monitor tab (near the bottom).

The Event Monitor appears.

Query Mode Setting the Query option places the Event Monitor in 
query mode, which shows the most recent 5,000 system 
events for a defined range of dates. Refer to Filtering the 
Event Monitor Display (page 258) for additional 
information about displaying a specific range of dates in 
the Event Monitor.

Monitor Mode Setting the Monitor option places the Event Monitor in 
monitor mode, which shows the most recent 5,000 system 
events during the past 24 hours.

Filtered by The Filtered by fields show your current Event Monitor 
filtering settings. Refer to Filtering the Event Monitor 
Display (page 258) for additional information about 
filtering your Event Monitor display to show specific 
events.

COLUMN DESCRIPTION

Date/Time Date and time this event occurred.

Code Event code number.
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Category Event category. One of the following:
• System
• Application
• User
• Security

Type Event type. One of the following:
• Debug
• Audit
• Information
• Warning
• Error
• Internal

Severity Event severity. One of the following:
• OK
• USER
• PROCESS
• NODE
• USER_FATAL
• PROCESS_FATAL
• NODE_FATAL
• SYSTEM_FATAL

Summary Short description of this event.

Domain Domain where this event occurred. 

More Data If Yes, additional detailed information is available 
by double-clicking the event entry or selecting the 
event (row) in the list and selecting 
Actions > Event Management > View Detail…

COLUMN DESCRIPTION
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Filtering the Event Monitor Display
1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Event Management tab.

4. Click the Event Monitor tab (near the bottom).

5. Select Actions > Event Management > Filter… or click the toolbar icon 
shown immediately to the left.

The Filter dialog box appears.

6. Define one or more of the following filtering criteria:

FIELD/OPTION DESCRIPTION

From Date Used with To Date field to define a specific range 
of dates in the Event Monitor.
IMPORTANT:  If you want to type a range of 
dates, the Event Monitor must already be in 
query mode (page 256). Otherwise, the From 
Date and To Date fields will be disabled.
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To Date Used with From Date field to define a specific 
range of dates in the Event Monitor.
IMPORTANT:  If you want to type a range of 
dates, the Event Monitor must already be in 
query mode (page 256). Otherwise, the From 
Date and To Date fields will be disabled.

Code Show all event codes (All Codes) is the only 
available selection.

Category Display events from the following categories:
• All Categories 
• System
• Application
• User
• Security

Type Display events of the following types:
• All Types 
• Debug
• Audit
• Information
• Warning
• Error
• Internal

Severity Display events of the following severities:
• All Severities 
• OK
• USER
• PROCESS
• NODE
• USER_FATAL
• PROCESS_FATAL
• NODE_FATAL
• SYSTEM_FATAL

Data Only display events that contain these case-
sensitive key words in the event code data XML 
element.
This promotes easy filtering on important key 
words across event attributes. For example, 
filtering the Event Monitor display on “error” 
would return all events that contained the word 
“error” in any XML attribute (for example, 
category, type or severity).

FIELD/OPTION DESCRIPTION
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Domains Select the All Domains option to display all 
events from all domains.
To only show events from one domain, select the 
Domain option and type a domain for which you 
want to show events.
TIP:  Click ... to browse to a domain for which 
you want to show events. 

More/Less The More/Less button is used to display or hide 
advanced filtering features that allow you to 
include or exclude specific event codes.
Clicking More displays an additional lower pane 
and the button name changes to Less (as shown 
next).

Clicking Less hides the additional lower pane 
and the button name changes to More.

Only include codes Setting Only include codes filters the Event 
Monitor to display only those event codes in the 
list.
The Only include codes and Exclude codes 
options are mutually exclusive (you cannot both 
exclude and include specific event codes at the 
same time).

Exclude codes Setting Exclude codes causes the Event Monitor 
to not display any event codes in the list. 
The Only include codes and Exclude codes 
options are mutually exclusive (you cannot both 
exclude and include specific event codes at the 
same time).

Remove Selecting an event code from the list and clicking 
Remove removes it from the include or exclude 
list.

Add to list Typing a numeric event code in the entry field 
and clicking Add to list adds that event code to 
the include or exclude list.

FIELD/OPTION DESCRIPTION
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IMPORTANT:  If you want to type a range of dates, the
Event Monitor must be in query mode (page 256). Other-
wise, the From Date and To Date fields will be disabled.

7. Click OK.

The Filter dialog box closes and the Event Monitor only shows events that 
meet your filtering criteria.

Viewing the Audit Log
1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Event Management tab.

4. Click the Audit Log tab (near the bottom).

The Audit Log provides two basic display modes: query mode or monitor 
mode. 

Query Mode Setting the Query option places the Audit Log in query 
mode, which shows the most recent 5,000 audit log 
entries for a defined range of dates. Refer to Filtering the 
Audit Log Display (page 264) for additional information 
about displaying a specific range of dates in the Audit Log.

Monitor Mode Setting the Monitor option places the Audit Log in 
monitor mode, which shows the most recent 5,000 audit 
log entries during the past 24 hours.
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5. Click the Audit Log tab (near the bottom).

The Audit Log appears.

Filtered by The Filtered by fields show your current Audit Log filtering 
settings. Refer to Filtering the Audit Log Display (page 
264) for additional information about filtering your Audit 
Log display to show specific audit log entries.

COLUMN DESCRIPTION

ID Unique identifier for the audit log entry.

Date/Time Date and time this action occurred.

Code Event code number.

User User ID that initiated this action.

Role Role in effect when this action was initiated.

Product One of the following:

EM Avamar Enterprise Manager.

EMS Avamar Enterprise Manager 
server.

END_USER

MCCLI Avamar Administrator Command 
Line Interface (CLI).

MCGUI Avamar Administrator.

MCS Avamar Administrator server. 

NONE

SNMP_SUB_AGENT

TEST

WEB_RESTORE Avamar web restore feature.

Component Specific area within the product.

Operation Specific action taken.

Severity Event severity. One of the following:
• OK
• USER
• PROCESS
• NODE
• USER_FATAL
• PROCESS_FATAL
• NODE_FATAL
• SYSTEM_FATAL

Summary Short description of this action.
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Domain Domain where this action occurred. 

More Data If Yes, additional detailed information is available by 
double-clicking the event entry or selecting the event 
(row) in the list and selecting 
Actions > Event Management > View Detail…

COLUMN DESCRIPTION
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Filtering the Audit Log Display
1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Event Management tab.

4. Click the Audit Log tab (near the bottom).

5. Select Actions > Event Management > Filter… or click the toolbar icon 
shown immediately to the left.

The Filter dialog box appears.
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6. Define one or more of the following filtering criteria:

FIELD/OPTION DESCRIPTION

From Date Used with To Date field to define a specific range 
of dates in the Audit Log.
IMPORTANT:  If you want to type a range of 
dates, the Audit Log must already be in query 
mode (page 256). Otherwise, the From Date 
and To Date fields will be disabled.

To Date Used with From Date field to define a specific 
range of dates in the Audit Log.
IMPORTANT:  If you want to type a range of 
dates, the Audit Log must already be in query 
mode (page 256). Otherwise, the From Date 
and To Date fields will be disabled.

Code Show all event codes (All Codes) is the only 
available selection.

Category Security is the only available selection.

Type Audit is the only available selection.

Severity Display audit log entries of the following 
severities:

• All Severities 
• OK
• USER
• PROCESS
• NODE
• USER_FATAL
• PROCESS_FATAL
• NODE_FATAL
• SYSTEM_FATAL

Data Only display audit log entries that contain these 
case-sensitive key words in the event code data 
XML element.
This promotes easy filtering on important key 
words across audit log entry attributes. For 
example, filtering the Audit Log display on 
“error” would return all audit log entries that 
contained the word “error” in any XML attribute 
(for example, category, type or severity).

Domains Select the All Domains option to display all 
audit log entries from all domains.
To only show audit log entries from one domain, 
select the Domain option and type a domain for 
which you want to show audit log entries.
TIP:  Click ... to browse to a domain for which 
you want to show audit log entries. 
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IMPORTANT:  If you want to type a range of dates, the
Audit Log must be in query mode (page 256). Otherwise, the
From Date and To Date fields will be disabled.

7. Click OK.

The Filter dialog box closes and the Audit Log only shows events that meet 
your filtering criteria.

More/Less The More/Less button is used to display or hide 
advanced filtering features that allow you to 
include or exclude specific event codes.
Clicking More displays an additional lower pane 
and the button name changes to Less (as shown 
next).

Clicking Less hides the additional lower pane 
and the button name changes to More.

Only include codes Setting Only include codes filters the Audit Log 
to display only those event codes in the list.
The Only include codes and Exclude codes 
options are mutually exclusive (you cannot both 
exclude and include specific event codes at the 
same time).

Exclude codes Setting Exclude codes causes the Audit Log to 
not display any event codes in the list. 
The Only include codes and Exclude codes 
options are mutually exclusive (you cannot both 
exclude and include specific event codes at the 
same time).

Remove Selecting an event code from the list and clicking 
Remove removes it from the include or exclude 
list.

Add to list Typing a numeric event code in the entry field 
and clicking Add to list adds that event code to 
the include or exclude list.

FIELD/OPTION DESCRIPTION
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Viewing Services Information
1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Services Administration tab.

The Services Administration tab provides information about essential 
Avamar services (for example, syslog, NTP, Login Manager, and so forth).

SERVICE NAME DESCRIPTION

Hostname Avamar server network hostname as defined in 
DNS.

IP Address Avamar server IP address.

Load Average The average number of CPU threads over the 
past minute.

Last Administrator 
Datastore Flush

Date and time of last MCS flush.

PostgreSQL database Status of the MCS database (page 291).

Web Services Status of the Avamar Web Access service. 

Web Restore Disk 
Space Available

Number of hard drive bytes Avamar Web 
Access can use to create the restore zip file. 
Refer to Avamar Backup Clients User Guide for 
additional information about restoring client 
files using the Avamar Web Access feature.

Login Manager Status of the Avamar Login Manager service. 

snmp sub-agent Status of the Avamar SNMP sub-agent service

ConnectEMC Status of the ConnectEMC service. 
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VMware vCenter 
Connection Monitor

Status of the VMware vCenter connections.
NOTE:  This service is only present if a 
vCenter client has been added to the system. 
Refer to your Avamar VMware Guide for 
additional information.

ntp daemon Status of the Avamar Network Time Protocol 
(NTP) service. 

snmp daemon Status of the Avamar SNMP master agent 
service.

ssh daemon Status of the Avamar Secure Shell (SSH) 
service. 

Syslog daemon Status of the Avamar syslog service.

Replication cron job Status of the Avamar replication cron job. 
Refer to Replication (page 333) for additional 
information.

SERVICE NAME DESCRIPTION
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Viewing a Detailed Client Session Log
1. Start Avamar Administrator (page 21).

2. Select Navigation > Activity or click the Activity launcher button.

The Activity window appears.

3. Click the Activity Monitor tab.

By default, the Activity Monitor shows a detailed log of all client backup 
activity for the past 72 hours.

4. Select one activity (row) in the list.

5. Select Actions > View Session Log… or click the toolbar icon shown 
immediately to the left.

The Activity Session Drill-down dialog box appears.

6. Click OK.

The Activity Session Drill-down dialog box closes.
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Collecting and Viewing Log Files
By default, the Avamar storage process log file (gsan.log) is limited to 25 MB in 
size and always contains the most recent information. Additional historic log files 
(for example, gsan.log.1, gsan.log.2 and so forth) might also exist.

User=admin 1. Open a command shell (page 477) and log into the utility node as user 
admin.

2. Load the admin OpenSSH key by typing:

cd ~admin

ssh-agent bash

ssh-add ~/.ssh/admin_key

You are prompted to type a passphrase.

3. Type the admin user account passphrase and press ENTER.

4. Create a new user-defined temporary directory and change directory into it 
by typing:

mkdir DIR

cd DIR

Where DIR is a new user-defined temporary directory. This directory will be 
deleted following this procedure.

5. Retrieve copies of the storage node log files by typing:

getlogs

getlogs gathers the important log files from a particular node, compresses 
them into a single tar file (nodelogs.tgz), then copies these nodelogs.tgz 
files to numbered subdirectories in your current working directory.

You must examine these nodelogs.tgz files for any entry containing the 
string “ERROR.” The recommended method for accomplishing this is to run 
the following shell commands, which write any nodelogs.tgz entries 
containing the string “ERROR” to a user-defined temporary file.

6. Type: 

for p in [01].[!sm]*/nodelogs.tgz; do

tar xzf $p

grep ERROR: cur/gsan.log*

rm -rf cur/*

done

7. If any errors are found, contact EMC Technical Support.

8. Remove the user-defined temporary directory by typing:

cd ../

rm -rf DIR

Where DIR is the user-defined temporary directory created in step 3.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  270



BASIC SERVER ADMINISTRATION

This chapter introduces and discusses basic Avamar server administrative 
concepts and tasks.

Avamar Server Functional Block Diagram
The following diagram shows the major Avamar server functional blocks:

Data Server

When performing a backup (page 74), restore (page 84) or validation (page 92), 
Avamar backup clients communicate directly with the data server. All scheduled 
backups are initiated by the MCS scheduler.
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Management Console Server (MCS)

The Management Console Server (MCS) provides centralized administration 
(scheduling, monitoring and management) for the Avamar server. The MCS also 
runs the server-side processes used by the Avamar Administrator graphical 
management console.

Client Registry. The client registry function controls client registration and 
activation. Refer to Clients (page 38) for additional information.

Account Management. The account management function is used to create 
and manage domains, clients, users and groups. Refer to Domains, Clients and 
Users (page 33) and Groups and Group Policies (page 128) for additional 
information.

Reporting. The reporting function is used to create and export various reports. 
Refer to Reporting (page 197) for additional information.

Events. The events function is used to display various system events and 
activities. Refer to Basic Server Administration (page 271) for additional 
information.

Scheduler/Dispatcher. The scheduler/dispatcher function controls when 
backup and restore jobs are performed, or if they are allowed to be queued for 
processing. Refer to Backup, Restore and Backup Management (page 73) for 
additional information.

PostgreSQL Database. The MCS uses a PostgreSQL database to store various 
kinds of data. PostgreSQL is an open architecture. Information in the MCS 
database is accessible through any PostgreSQL-compliant ODBC interface. 

The MCS database filename is mcdb and it is located on the utility node in the 
/usr/local/avamar/var/mc/server_data/postgres directory. 

MCS database contents are fully backed up on the Avamar server and can be 
restored as needed should the MCS fail. 

IMPORTANT:  The MCS database is intended for read-only
access for reporting or query purposes. Do not manually
modify any data in mcdb tables unless instructed to do so by
EMC Technical Support. Directly modifying MCS operational
data can cause loss of referential integrity, which could result
in irretrievable loss of data.

Enterprise Manager Server (EMS)

The Avamar Enterprise Manager Server (EMS) provides essential services required 
to display Avamar server information and provides a mechanism for managing 
Avamar servers using a standard web browser. The EMS also communicates 
directly with existing MCSs, which are an integral part of the all Avamar systems 
in your enterprise. Refer to Avamar Enterprise Manager (page 292) for additional 
information.
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Avamar Server Maintenance Activities and Backup/
Maintenance Windows

This topic introduces and discusses Avamar server maintenance activities and 
backup/maintenance windows. 

Maintenance Activities

Avamar server maintenance comprises three essential activities:

• Checkpoint
• Checkpoint validation (also known as HFS check)
• Garbage collection

Checkpoint. A checkpoint is a snapshot of the Avamar server taken for the 
express purpose of facilitating server rollbacks.

Checkpoint Validation (Also Known as HFS Check). A Hash Filesystem 
check (also known as HFS check) is an internal operation that validates the 
integrity of a specific checkpoint. Once a checkpoint has passed an HFS check, it 
can be considered reliable enough to be used for a server rollback.

Garbage Collection. Garbage collection is an internal operation that recovers 
storage space from deleted or expired backups.

Backup/Maintenance Windows

Each 24-hour day is divided into three operational windows, during which various 
system activities are performed:

• Backup window
• Blackout window
• Maintenance window

The following figure shows the default backup, blackout and maintenance 
windows:
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Backup Window. The backup window is that portion of each day reserved for 
performing normal scheduled backups. 

Blackout Window. The blackout window is that portion of each day reserved for 
performing server maintenance activities (primarily checkpoint and garbage 
collection) that require unrestricted access to the server. 

Operational Impact No maintenance activities are performed during the backup 
window.

Default Settings The default backup window begins at 8:00 P.M. local server 
time and continues uninterrupted for 10 hours until 6:00 A.M. 
the following morning. 

Customization Both backup window start time and duration can be 
customized to meet your specific site requirements.

Operational Impact No backup or administrative activities are allowed during the 
blackout window. You can however perform restores.

Default Settings The default blackout window begins at 6:00 A.M. local server 
time and continues uninterrupted for 4 hours until 10:00 
A.M. that same morning.

Customization Blackout window duration can be customized to meet your 
specific site requirements. Any changes to blackout window 
duration also affect maintenance window duration. For 
example, changing the blackout window duration from 4 
hours to 3 hours, will extend the maintenance window 
duration 1 hour because it begins 1 hour earlier. The backup 
window is not affected.
IMPORTANT:  Setting the blackout window duration too 
short might adversely impact the server’s ability to recover 
storage space from deleted or expired backups. If you 
shorten your blackout window duration, you should closely 
monitor your server capacity utilization and forecasting on a 
regular basis (at least weekly) to ensure that adequate 
garbage collection is taking place. Refer to Capacity 
Management (page 322) for additional information.
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Maintenance Window. The maintenance window is that portion of each day 
reserved for performing routine server maintenance activities (primarily 
checkpoint validation). 

Best Practices

Do Not Schedule Backups Close to or During Blackout Window. In order 
to ensure that all morning maintenance activities complete in a timely manner, 
EMC recommends that you do not schedule any group backups close to or during 
the blackout window (6:00-10:00 A.M. local time for most systems).

Limit On-Demand Backups During Maintenance Window. You might want 
to advise users to avoid initiating any on-demand backups from their client 
computers during the first hour and thirty minutes of the maintenance window 
(10:00 A.M.-8:00 P.M. local time for most systems).

Avoid Initiating On-Demand Maintenance Activities. Manually initiating 
maintenance activities such as checkpoint, checkpoint validation or garbage 
collect will temporarily disable all scheduled maintenance activities until such time 
the manually-initiated operation completes. Unless there is a pressing need to 
initiate an on-demand maintenance activity, it is best to rely on scheduled 
maintenance activities in order to ensure that sufficient time is allocated for each 
activity daily.

Operational Impact There might be brief periods of time when backup or 
administrative activities will not be allowed. Although 
backups can be initiated during the maintenance window, 
doing so will impact both the backup and maintenance 
activities. For this reason, you should minimize any backup 
or administrative activities during the maintenance window. 
You can however perform restores.

Default Settings The default maintenance window begins at 10:00 A.M. local 
server time and continues uninterrupted for 10 hours until 
8:00 P.M. that evening.

Customization Although the maintenance window is not directly 
customizable, its start time and duration is derived from 
backup and blackout window settings (that is, it starts 
immediately after the blackout window and continues until 
the backup window start time).
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Acknowledging System Events
System events that are configured to require acknowledgement each time they 
occur, remain in the unacknowledged events list until they are explicitly cleared 
(acknowledged) by an Avamar server administrator.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Event Management tab.

4. Click the Unacknowledged Events tab (near the bottom).

5. Select one or more entries.

TIP:  Press and hold the SHIFT key to select an entire range
of entries; press and hold the CTRL key to select several
individual (noncontiguous) entries.

6. Select Actions > Event Management > Acknowledge 
Unacknowledged Events or click the toolbar icon shown immediately to 
the left.

The events you previously selected no longer appear in the list.

TIP:  Select Actions > Event Management > Clear All
Alerts to clear the entire unacknowledged events list.
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Suspending Backups/Restores
1. Start Avamar Administrator (page 21).

2. Select Navigation > Avamar Server or click the Avamar Server 
launcher button.

The Avamar Server window appears.

3. Click the Server Management tab.

4. In the tree pane, select the root node of the tree.

5. Select Actions > Suspend Backups/Restores or click the toolbar icon 
shown immediately to the left.

A confirmation message appears.

6. Click Yes to suspend backups.
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Resuming Backups/Restores
1. Start Avamar Administrator (page 21).

2. Select Navigation > Avamar Server or click the Avamar Server 
launcher button.

The Avamar Server window appears.

3. Click the Server Management tab.

4. In the tree pane, select the root node of the tree.

5. Select Actions > Resume Backups/Restores or click the toolbar icon 
shown immediately to the left.

A confirmation message appears.

6. Click Yes to resume backups.
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Suspending Scheduled Operations
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Schedules…

The Manage All Schedules window appears.

3. Click Suspend All. 

The Suspend All button changes to Resume All.

Resuming Scheduled Operations
1. Start Avamar Administrator (page 21).

2. Select Tools > Manage Schedules…

The Manage All Schedules window appears.

3. Click Resume All. 
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 Enabling Scheduled Group Backups
1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Groups tab.

5. Select the group you want enabled.

6. Select Actions > Group > Disable Group.

This clears the Disable Group option on the Actions > Group menu.

A status message appears.

7. Click Yes to enable this group.

8. Repeat steps 4 through 6 until all groups have been enabled.
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Disabling Scheduled Group Backups
1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Groups tab.

5. Select the group you want to disable.

6. Select Actions > Group > Disable Group.

This sets the Disable Group option on the Actions > Group menu.

A status message appears.

7. Click Yes to disable this group.

8. Repeat steps 4 through 6 until all groups have been disabled.
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Suspending Maintenance Activities
1. Start Avamar Administrator (page 21).

2. Select Navigation > Avamar Server or click the Avamar Server 
launcher button.

The Avamar Server window appears.

3. Select Actions > Suspend Maintenance Activities.

A confirmation message appears.

4. Click OK to suspend maintenance activities.

Resuming Maintenance Activities
1. Start Avamar Administrator (page 21).

2. Select Navigation > Avamar Server or click the Avamar Server 
launcher button.

The Avamar Server window appears.

3. Select Actions > Resume Maintenance Activities.

A confirmation message appears.

4. Click OK to resume maintenance activities.
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Changing Backup/Maintenance Window Settings
You can customize any of the following backup/maintenance window settings to 
meet your specific site requirements:

• Backup window start time 
• Backup window duration
• Blackout window duration

Any changes to blackout window duration also affect maintenance window 
duration. For example, changing the blackout window duration from 4 hours to 3 
hours, will extend the maintenance window duration 1 hour because it begins 1 
hour earlier. 

IMPORTANT:  Setting the blackout window duration too
short might adversely impact the server’s ability to recover
storage space from deleted or expired backups. If you
shorten your blackout window duration, you should closely
monitor your server capacity utilization and forecasting on a
regular basis (at least weekly) to ensure that adequate gar-
bage collection is taking place. Refer to Capacity Manage-
ment (page 322) for additional information.

1. Start Avamar Administrator (page 21).
2. Select Tools > Manage Schedules…

The Manage All Schedules window appears.
3. Click the Maintenance Window tab.

4. Do any of the following:

5. Click OK.
The Manage All Schedules window closes.

IF DO THIS

You want to change the 
backup window start time.

Select a new start time from the 
Backup Window Start Time list.

You want to change the 
backup window duration.

Select a new duration from the 
Backup Window Duration list.

You want to change the 
blackout window duration.

Select a new duration from the 
Blackout Window Duration list.
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Managing Services
The Administration window Services Administration tab allows you to start, stop, 
suspend or resume individual services.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Services Administration tab.

4. Select the service you want to start, stop, suspend or resume.

5. Do one of the following:

IF DO THIS

You want to start a service. Right-click Start.

You want to stop a service. Right-click Stop.

You want to temporarily suspend a 
service until you explicitly resume it.

Right-click Suspend.

You want to resume a service that you 
previously suspended.

Right-click Resume.
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Canceling a Client Session
Occasionally, a client might experience unexpected system behavior while it is 
taking a backup or restoring files. In these cases, it might be necessary to force 
an end to these client sessions from Avamar Administrator. 

1. Start Avamar Administrator (page 21).

2. Select Navigation > Avamar Server or click the Avamar Server 
launcher button.

The Avamar Server window appears.

3. Click the Session Monitor tab.

A list of active client sessions appears.

4. Select the client session you want to cancel. 

5. Select Actions > Cancel Session… or click the toolbar icon shown 
immediately to the left.

The Cancel Session Progress dialog box appears.

This dialog box shows the progress of this cancel client operation. You can 
cancel the operation at any time by clicking Cancel.

6. When the Cancel Session Progress dialog box shows 100%, click Close.

The Cancel Session Progress dialog box closes.

TIP:  If you are unable to successfully cancel this client ses-
sion, resetting the client (page 286) will immediately and
forcibly terminate (kill) any active avtar session on that cli-
ent. 
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Resetting a Client
Resetting a client immediately and forcibly terminates (kills) any active client 
avtar session on that client. In most cases, you should try to cancel the client 
session (page 285) before resetting it.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Clients tab.

5. Select the client you want to reset.

6. Select Actions > Client > Reset Client. 
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SERVER SHUTDOWN AND RESTART

This chapter describes how to gracefully shut down and restart the entire Avamar 
server, or selected subsystems within the server using the dpnctl program.

Shutting Down the Server
Best Practice. Whenever possible, also perform these tasks as part of a full 
system shutdown:

• Verify system integrity (page 255)

• Create (page 352) and validate (page 353) a server checkpoint

NOTE:  If the system passed integrity checks, you do not
need to create or validate a server checkpoint. However,
there is no harm in doing so.

User=admin 1. Open a command shell (page 477).

2. Do one of the following:

IF DO THIS

Administering a 
single-node server.

Log into the server as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Administering a 
multi-node server.

Log into the utility node as user admin.
When prompted for a password, type the admin 
password and press ENTER.
Load the admin OpenSSH key by typing:
ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.
Type the admin user account passphrase and 
press ENTER.
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3. Type:

dpnctl stop

The following information might appear in your command shell.

4. Do one of the following:

Information similar to the following appears in your command shell:

dpnctl: INFO: Suspending backup scheduler...
dpnctl: INFO: Backup scheduler suspended.
dpnctl: INFO: Suspending maintenance cron jobs...
dpnctl: INFO: Checking for active checkpoint maintenance...
dpnctl: INFO: Terminating hfs integrity maintenance (hfscheck)...
dpnctl: INFO: Shutting down dtlt...
dpnctl: INFO: dtlt shut down.
dpnctl: INFO: Shutting down MCS...
dpnctl: INFO: MCS shut down.
dpnctl: INFO: Shutting down gsan...
dpnctl: INFO: gsan shut down.

Do you wish to shut down the local instance of EMS?

Answering y(es) will shut down the local instance of EMS

n(o) will leave up the local instance of EMS

q(uit) exits without shutting down

y(es), n(o), q(uit/exit):

IF DO THIS

You want to shut down this local 
EMS instance.

Type y and press ENTER.

You do not want to shut down 
this local EMS instance.

Type n and press ENTER.
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Restarting the Server
Use this procedure to bring an Avamar server back online after a system 
shutdown.

User=admin 1. Open a command shell (page 477).

2. Do one of the following:

3. Type:

dpnctl start

The following information appears in your command shell:

Identity added: /home/admin/.ssh/dpnid (/home/admin/.ssh/dpnid)
dpnctl: INFO: Checking that gsan was shut down cleanly...
dpnctl: INFO: Restarting the gsan (this may take some time)...
dpnctl: INFO: To monitor progress, run in another window: tail -f /tmp/dpnctl-
gsan-restart-output-7416
dpnctl: INFO: Restarting gsan succeeded.
dpnctl: INFO: gsan started.
dpnctl: INFO: Updating MCS...
dpnctl: INFO: To monitor progress, run in another window: tail -f /tmp/dpnctl-
mcs-update-output-7416
dpnctl: INFO: MCS updated.
dpnctl: INFO: Starting MCS...
dpnctl: INFO: To monitor progress, run in another window: tail -f /tmp/dpnctl-
mcs-start-output-7416
dpnctl: INFO: MCS started.
dpnctl: INFO: Starting EMS...
dpnctl: INFO: To monitor progress, run in another window: tail -f /tmp/dpnctl-
ems-start-output-7416
dpnctl: INFO: EMS started.
dpnctl: INFO: Resuming scheduler...
dpnctl: INFO: Scheduler resumed.
dpnctl: INFO: Resuming maintenance cron jobs...
dpnctl: INFO: Maintenance cron jobs resumed.

IF DO THIS

Administering a 
single-node server.

Log into the server as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Administering a 
multi-node server.

Log into the utility node as user admin.
When prompted for a password, type the admin 
password and press ENTER.
Load the admin OpenSSH key by typing:
ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.
Type the admin user account passphrase and 
press ENTER.
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Stopping the MCS
User=admin 1. Open a command shell (page 477).

2. Do one of the following:

3. Type:

dpnctl stop mcs

Starting the MCS
User=admin 1. Open a command shell (page 477).

2. Do one of the following:

3. Type:

dpnctl start mcs

4. Resume scheduled operations (page 279).

IF DO THIS

Administering a 
single-node server.

Log into the server as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Administering a 
multi-node server.

Log into the utility node as user admin.
When prompted for a password, type the admin 
password and press ENTER.
Load the admin OpenSSH key by typing:
ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.
Type the admin user account passphrase and 
press ENTER.

IF DO THIS

Administering a 
single-node server.

Log into the server as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Administering a 
multi-node server.

Log into the utility node as user admin.
When prompted for a password, type the admin 
password and press ENTER.
Load the admin OpenSSH key by typing:
ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.
Type the admin user account passphrase and 
press ENTER.
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Getting MCS Status
This command returns the status of each MCS service and any available 
performance statistics.

User=admin 1. Open a command shell (page 477).

2. Do one of the following:

3. Type:

dpnctl status mcs

IF DO THIS

Administering a 
single-node server.

Log into the server as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Administering a 
multi-node server.

Log into the utility node as user admin.
When prompted for a password, type the admin 
password and press ENTER.
Load the admin OpenSSH key by typing:
ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.
Type the admin user account passphrase and 
press ENTER.
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AVAMAR ENTERPRISE MANAGER

Avamar Enterprise Manager is a web-based multi-system management console 
application that provides centralized Avamar system administration capabilities for 
larger businesses and enterprises.

Capabilities and Limitations
This topic discusses various capabilities and limitations of Avamar Enterprise 
Manager.

Multi-System Management. With Avamar Enterprise Manager, you can 
monitor all Avamar systems in your enterprise from a single web browser session. 
Refer to Monitoring Multiple Systems (page 316) for additional information.

Dashboard. The integrated dashboard (page 296) provides an “at-a-glance” 
view that allows you to quickly assess the operational status of each Avamar 
system and determine if backups are completing successfully.

Only One Avamar Enterprise Manager Server is Required. The Avamar 
Enterprise Manager Server (EMS) provides essential services required to display 
Avamar system information and provides a mechanism for managing Avamar 
systems using a standard web browser. The EMS also communicates directly with 
existing MCSs, which are an integral part of all Avamar systems in your enterprise. 
Therefore, it is important to understand that only one operational EMS is required 
per enterprise; you do not need to run EMS on every Avamar system, nor is it 
desirable to do so.

Avamar Enterprise Manager Can Only Manage Like Version Avamar
 Servers. Due to known limitations with Java web services, Avamar Enterprise 

Manager can only connect to, and manage Avamar Administrator servers running 
the same version Avamar software. Effectively, this means that Avamar Enterprise 
Manager can only manage Avamar servers running the same version Avamar 
software.
 AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  292



 Capabilities and Limitations
AVAMAR ENTERPRISE MANAGER
Use Local MCS to Authenticate Avamar Enterprise Manager
 Logins. Because only one operational EMS is required per enterprise and 

there is usually no good reason to authenticate Avamar Enterprise Manager logins 
using a remote MCS running on another Avamar host. Therefore, it is best to 
simply use the default installation and configuration options, which configure the 
EMS to use the local MCS (the MCS running on the same Avamar host) to 
authenticate Avamar Enterprise Manager logins.

Avamar Enterprise Manager is Functionally Similar to Avamar Administra-
tor. Although the Avamar Enterprise Manager user interface is different than 

Avamar Administrator, the fundamental administrative principles and operations 
are similar. Once you are familiar with how to administer an Avamar system using 
Avamar Administrator, you should be able to perform those same tasks using 
Avamar Enterprise Manager. The primary difference will be that you can centrally 
administer every Avamar system in your enterprise from a single application, 
rather than having to launch multiple Avamar Administrator sessions.

Web Browser Security Settings. The information presented in the remainder 
of this chapter assumes that you are using Microsoft Internet Explorer 6 with the 
default security settings. If you are using another web browser or other security 
settings, you should be prepared to answer Yes when presented with additional or 
different security prompts.

Session Time-Out Information. The default session time-out setting for most 
Avamar Enterprise Manager features and functions is 72 hours. However, the 
dashboard (page 296) and replicator (page 315) pages automatically refresh 
themselves every minute. Effectively, this means that if you leave your web 
browser pointed to the dashboard or replicator pages, your Avamar Enterprise 
Manager session will continue indefinitely. However, if you leave your web browser 
pointed to any other page, your Avamar Enterprise Manager session will 
automatically time out after 72 hours of inactivity. The default session time-out 
setting is modifiable by changing the session-timeout preference in 
/usr/local/jakarta-tomcat-6.0.18/webapps/cas/WEB-INF/web.xml.
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Shutting Down the EMS
These instructions are provided in case you need to perform an orderly shutdown 
of your EMS.

1. Open a command shell (page 477).

User=admin 2. Log into the utility node as user admin.

3. Type:

dpnctl stop ems

4. Wait for dpnctl stop ems to complete.

Restarting the EMS
These instructions are provided should you need to restart your EMS following a 
shutdown (page 294).

1.  Ensure that Avamar Enterprise Manager has been properly shut down 
(stopped) (page 294)

2. Open a command shell (page 477).

User=admin 3. Log into the utility node as user admin.

4. Type:

dpnctl start ems

5. Wait for dpnctl start ems to complete.
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Logging Into Avamar Enterprise Manager
1. Point your web browser to the following URL:

http://AVAMARSERVER/em

Where AVAMARSERVER is the hostname as defined in DNS. 
The Avamar Enterprise Manager Login page appears.

2. Type your Avamar administrative user account ID and password in the User 
Name and Password fields, respectively.

TIP:  Clicking Reset clears the User Name and Password
fields.

3. Click Log On.

4. If a Security Warning dialog box appears, click Yes to proceed with the 
login.

The Dashboard page (page 296) appears.
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Dashboard
The Dashboard page provides an “at-a-glance” view that allows you to quickly 
assess each Avamar server’s operational status and capacity utilization, as well as 
determine if scheduled backups are successfully completing.

Selecting Dashboard from any other page displays the Dashboard page.

The following table explains each Dashboard page element:

PAGE ELEMENT DESCRIPTION

Backup period This list box allows you to select an effective period of 
time for status shown in the Backups column. Choices 
are:

• last 24 hours
• last week
• last two weeks

System This column shows each server’s hostname as defined in 
corporate DNS.
Clicking the server name takes you to individual system 
information page (page 300) for that Avamar server.
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Last Contacted This column shows elapsed time since each Avamar 
server was last contacted by Avamar Enterprise Manager 
and data was collected.
IMPORTANT:  If the last updated indicator shows a 
status other than green, all other displayed information 
for that system should be considered stale and might not 
reflect actual Avamar system status.
State icons communicate the following conditions:

Avamar Enterprise Manager is operating normally 
and is able to communicate and collect data at the 
specified refresh/polling interval from this Avamar 
server. The elapsed time since Avamar Enterprise 
Manager last communicated with this Avamar 
server is shown next to the status icon.

Last attempt by Avamar Enterprise Manager failed 
to communicate or collect data from this Avamar 
server failed.
Avamar Enterprise Manager will wait one minute 
and retry again for up to three times before 
considering that refresh/polling cycle a failure. The 
specific reason for this condition displayed next to 
the status icon.
This condition can happen intermittently if network 
access to the Avamar server is slow or unreliable. 
It can also occur if that Avamar server is not 
running or has encountered an error or warning 
condition.

One of the following conditions:
Avamar Enterprise Manager failed to 
communicate and or collect data from an 
Avamar server for a specified number of 
refresh/polling cycles. 
Avamar server hostname could not be resolved.
Avamar server login credentials (user name or 
password) were refused.

The default polling setting is three cycles (30 
minutes total elapsed time based on a 10 minute 
refresh/polling cycle). The specific reason for this 
condition displayed next to the status icon.
IMPORTANT:  Any red status condition should be 
immediately investigated and remedied to ensure 
that system operation is not adversely affected.

PAGE ELEMENT DESCRIPTION
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Capacity - Used This column shows summary status of how storage 
capacity is being utilized on that Avamar server.
Detailed information includes the amount of storage 
capacity consumed (in bytes) and the amount of free 
storage capacity available (as a percentage of total 
available storage capacity).
Used state icons communicate the following conditions:

Avamar server has used less than 80% of total 
storage capacity.

Avamar server has used more than 80% but less 
than 95% of total storage capacity.
Consider adding additional capacity or deleting old 
backups.

Avamar server has used more than 95% of total 
storage capacity.
IMPORTANT:  No new backups will be taken until 
additional capacity is added or old backups are 
deleted. Contact EMC Technical Support.

TIP:  Clicking a capacity forecast icon takes you directly 
to the Capacity Utilization and Forecast page (page 326).

Capacity - Forecast Forecast state icons communicate the following 
conditions:

Avamar server is forecast to have 90 days or more 
storage capacity.

Avamar server is forecast to have less than 90 
days of storage capacity.

Avamar server is forecast to have less than 30 
days of storage capacity.

TIP:  Clicking a capacity forecast icon takes you directly 
to the Capacity Utilization and Forecast page (page 326).

Data Protected This column shows how much data is currently being 
protected on each Avamar server.

PAGE ELEMENT DESCRIPTION
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Backups This column provides a quick overview of scheduled 
backup status for each Avamar server.
State icons communicate the following conditions:

All scheduled backups successfully completed 
within the allotted period of time.

One or more scheduled backups successfully 
completed with exceptions.

One or more scheduled backups did not 
successfully complete within the allowed period of 
time.

TIP:  Clicking a backup status icon takes you directly to 
the Reports page (page 312).

PAGE ELEMENT DESCRIPTION
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System
Avamar Enterprise Manager offers two distinct kinds of system information pages:

Individual system information pages (page 300) allow you to view detailed 
information for a single Avamar server.

The all systems information (detailed dashboard) page (page 310) provides a 
consolidated detailed view of all Avamar servers. 

Individual System Information Page

The individual system information page allows you to view detailed information for 
a specific Avamar server.

Clicking a system name on the Dashboard page (page 296) or selecting an 
Avamar server from the Systems list box displays the individual properties page 
for that server. 
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Server Status

The following table explains server status information:

INFORMATION DESCRIPTION

Last contacted This row shows elapsed time since each Avamar 
server was last contacted by Avamar Enterprise 
Manager and data was collected.
IMPORTANT:  If Last updated shows a status other 
than green, all other displayed information for that 
server should be considered stale and might not 
reflect actual Avamar server status.
State icons communicate the following conditions:

Avamar Enterprise Manager is able to 
communicate and collect data from this Avamar 
server. 
The elapsed time since Avamar Enterprise 
Manager last communicated with this Avamar 
server is shown next to the status icon.

Last attempt by Avamar Enterprise Manager 
failed to communicate or collect data from this 
Avamar server failed.
Refer to Dashboard (page 296) for additional 
information about refresh/polling intervals and 
associated status conditions.

One of the following conditions:
Avamar Enterprise Manager failed to 
communicate and or collect data from an 
Avamar server for a specified number of 
refresh/polling cycles. 
Avamar server hostname could not be 
resolved.
Avamar server login credentials (user name 
or password) were refused.

IMPORTANT:  Any red status condition 
should be immediately investigated and 
remedied to ensure that server operation is 
not adversely affected. Contact EMC Technical 
Support.
Refer to Dashboard (page 296) for additional 
information about refresh/polling intervals and 
associated status conditions.
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Avamar Server This row shows the Avamar server operational run 
level.
State icons communicate the following conditions:

Full access. This Avamar server is fully 
operational.

This Avamar server is less than fully operational 
due to one of the following conditions:

Admin Avamar server is fully 
operational but only the 
administrator root account 
can access the server.

Admin Only Avamar server is fully 
operational but only the 
administrator root account 
can access the server.

Admin Read Only Avamar server is in a read-
only condition and only the 
administrator root account 
can access the server.

Read Only Avamar server is in a read-
only condition. Restores 
are allowed but no new 
backups can be taken.

Suspended Scheduled backups are 
disabled and will not occur 
until you reenable the 
scheduler. Refer to 
Suspending Scheduled 
Operations (page 279) for 
additional information.

Synchronizing Avamar server is priming or 
synchronizing stripes. This 
is a temporary condition. 
Some operations might be 
delayed.

INFORMATION DESCRIPTION
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Avamar Server
(continued)

This Avamar server is experiencing one of the 
following conditions that requires immediate 
attention:

Inactive One or more storage nodes 
are unresponsive to 
communication requests 
from local MCS (that is, 
nodes are functioning but 
frequently timing out on 
communication requests).

Node Offline One or more storage nodes 
has experienced a problem. 
Contact EMC Technical 
Support for additional 
information.

Not available Avamar Enterprise Manager 
cannot obtain any 
information from this 
Avamar server. This might 
indicate communication 
problems or errors in 
retrieving data.
TIP:  Ensure that Last 
updated status indicator is 
green.

Unknown State Avamar server is in an 
unknown state. It is either 
not running or does not 
respond to communication 
requests.

IMPORTANT:  Any red status condition 
should be immediately investigated and 
remedied to ensure that server operation is 
not adversely affected. Contact EMC Technical 
Support for assistance.

Capacity - Forecast Forecast state icons communicate the following 
conditions:

Avamar server is forecast to have 90 days or 
more storage capacity.

Avamar server is forecast to have less than 90 
days of storage capacity.

Avamar server is forecast to have less than 30 
days of storage capacity.

INFORMATION DESCRIPTION
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Capacity Usage This row shows how much storage capacity is being 
utilized on that Avamar server.
Detailed information includes:

• Total capacity
• Capacity used
• Total bytes protected

State icons communicate the following conditions:

Avamar server has used less than 80% of total 
storage capacity.

Avamar server has used more than 80% but 
less than 95% of total storage capacity.
Consider adding additional capacity or deleting 
old backups.

Avamar server has used more than 95% of 
total storage capacity.
IMPORTANT:  No new backups will be taken 
until additional capacity is added or old 
backups are deleted. Contact EMC Technical 
Support.

INFORMATION DESCRIPTION
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GC This row shows whether or not garbage collection 
(GC) is running or has successfully freed additional 
storage space on this Avamar server.
Detailed information includes:

• Started timestamp
• Ended timestamp
• Number of passes
• MB scanned
• Bytes recovered
• Chunks deleted
• Number of index stripes affected
• Total number of index stripes scanned

State icons communicate the following conditions:

Garbage collection successfully completed on 
this Avamar server within the past 30 hours.

Garbage collection has not successfully 
completed on this Avamar server within the 
past 30 hours, possibly due to one of the 
following conditions:

In progress Garbage collection is 
currently running.

None Garbage collection has 
never successfully 
completed on this Avamar 
server.

Garbage collection encountered an error the 
last time it was run.
IMPORTANT:  Any red status condition 
should be immediately investigated and 
remedied to ensure that server operation is 
not adversely affected. Contact EMC Technical 
Support for assistance. 

INFORMATION DESCRIPTION
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HW This row shows whether or not Avamar server 
hardware (HW) is functioning correctly.
State icons communicate the following conditions:

Avamar server hardware is functioning 
correctly (there are no hardware related error 
or warning events).

One or more warning events specifically related 
to server hardware have been encountered on 
this Avamar server.
Server logs should be reviewed to ensure that 
these conditions do not adversely affect server 
operation.

One or more serious error events specifically 
related to server hardware have been 
encountered on this Avamar server.
IMPORTANT:  Any red status condition 
should be immediately investigated and 
remedied to ensure that server operation is 
not adversely affected. Contact EMC Technical 
Support. 

Last Checkpoint This row shows whether or not regularly scheduled 
checkpoints are successfully completing.
The elapsed time since last successful checkpoint and 
the checkpoint time stamp are shown if at least one 
successful checkpoint has completed on this Avamar 
server.
“None” indicates that no checkpoints are stored on 
this Avamar server.
“Init” indicates that this is a new Avamar server and 
that the initial checkpoint has not yet completed.
Refer to Checkpoints (page 351) for additional 
information.
State icons communicate the following conditions:

Checkpoint successfully completed on this 
Avamar server within the past 24 hours.

More than 24 hours but less than 48 hours have 
elapsed since a checkpoint successfully 
completed on this Avamar server.

More than 48 hours have elapsed since a 
checkpoint successfully completed on this 
Avamar server.

INFORMATION DESCRIPTION
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Last Validated 
Checkpoint

This row shows whether or not regularly scheduled 
checkpoint validations are successfully completing on 
this Avamar server.
“None” indicates that no checkpoints have ever 
successfully been validated on this Avamar server.
“Errors” indicates that the last checkpoint validation 
operation failed.
“Not configured” indicates that checkpoint validation 
is not enabled on this server.
State icons communicate the following conditions:

Checkpoint validation successfully completed 
on this Avamar server within the past 48 hours.

More than 48 hours but less than 72 hours have 
elapsed since a checkpoint validation 
successfully completed on this Avamar server.

More than 72 hours have elapsed since a 
checkpoint validation successfully completed on 
this Avamar server.

Validation type describes the extent of checking 
performed during the checkpoint. One of the 
following:

Full A full checkpoint (all 
checks) was performed.

Rolling A rolling checkpoint (all 
new and modified stripes 
fully validated and a subset 
of unmodified stripes were 
validated) was performed.

INFORMATION DESCRIPTION
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Replication This row shows whether or not regularly scheduled 
replication is successfully completing on each Avamar 
server.
“Failed” indicates that the last replication operation 
failed.
“Disabled” indicates that the Avamar data replication 
feature is not enabled on this server.
State icons communicate the following conditions:

Replication successfully completed on this 
Avamar server within the past 48 hours or the 
Avamar data replication feature is not enabled 
on this server.

More than 48 hours but less than 72 hours have 
elapsed since replication successfully 
completed on this Avamar server.

More than 72 hours have elapsed since 
replication successfully completed on this 
Avamar server or the last replication operation 
failed.
IMPORTANT:  Any red status condition 
should be immediately investigated and 
remedied to ensure that server operation is 
not adversely affected. Contact EMC Technical 
Support. 

TIP:  The optional replication management feature is 
discussed elsewhere in this publication. Refer to 
Replication (page 333) for additional information.

INFORMATION DESCRIPTION
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System Activity

The following table explains each piece of System Activity information:

Unack. Events This row shows whether or not there are any 
unacknowledged events (Unack. Events) on each 
Avamar server.
State icons communicate the following conditions:

No warning or error events have occurred on 
this Avamar server that have not been explicitly 
acknowledged by an Avamar server 
administrator.
Refer to Acknowledging System Events (page 
276) for additional information.

One or more warning events have been 
encountered on this Avamar server and these 
events have not been explicitly acknowledged 
by an Avamar server administrator.
Server logs should be reviewed to ensure that 
these conditions do not adversely affect server 
operation.

One or more serious error events have been 
encountered on this Avamar server and these 
events have not been explicitly acknowledged 
by an Avamar server administrator.
IMPORTANT:  Any red status condition 
should be immediately investigated and 
remedied to ensure that server operation is 
not adversely affected. Contact EMC Technical 
Support. 

INFORMATION DESCRIPTION

Scheduler This column shows whether or not regularly scheduled 
server activities (for example, backups, maintenance 
activities) are enabled for this Avamar server.
State icons communicate the following conditions:

Regularly scheduled activities are enabled 
(resumed) on this Avamar server.

Regularly scheduled activities are suspended on this 
Avamar server.
Refer to Suspending Scheduled Operations (page 
279) for additional information.

Waiting Number of jobs in the server wait queue.

Running Number of server jobs that are currently running.

Sessions Number of active client sessions.

INFORMATION DESCRIPTION
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All Servers Information (Detailed Dashboard) Page

All systems page provides a consolidated detailed view of all Avamar server status 
and information. This page is similar to the dashboard (page 296), but provides 
more detailed information. 

Selecting System from any other page or selecting All from an individual system 
information page (page 300) Systems list box displays the all systems information 
(detailed dashboard) page. 

The information displayed is the same as shown for individual servers. Refer to 
Individual System Information Page (page 300) for additional information.
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Capacity
Avamar Enterprise Manager provides advanced capacity forecasting and reporting 
features that can assist you with monitoring and managing your server storage 
capacity.

This feature is discussed elsewhere in this publication. Refer to Capacity 
Management (page 322) for additional information. 

Policy
The Policy page lists the various policies (page 128) in use for each Avamar server 
you are monitoring.

Only one kind of policy object can be shown at a time. Select which kind of policy 
object you want to view by selecting Groups, Clients, Datasets, Schedules or 
Retention Policies.

After deciding which kind of policy object you want to view, you can further refine 
the display by showing policy objects that reside in all domains or a single domain 
by setting the All Domains or Single Domain options, respectively.

Selecting Policy from any other page displays the Policy page.
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Reports
The Reports page allows you to run various Avamar reports and export that 
information as a Comma-Separated Values (CSV) text file. Refer to Avamar 
Reports (page 197) for additional information.

Selecting Reports from any other page displays the Reports page.

Date and Time Filtering. The Reports page provides two ways to specify an 
effective period of time each time a report is run:

Setting the Backup Period option allows you to quickly run a report that 
shows the past day (24 hours), past week or past two weeks worth of 
information.

Setting the Date/Time Range option allows you to define a specific range of 
calendar dates and times of day for a report. Only information occurring within 
that range of dates and times will be present in the report.
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Running a Report

To run a system report, perform the following:

1. Select a report from the Reports list.

2. Do one of the following:

3. Click Run.

The report information appears.

Exporting a Report as a CSV File

To export report information as a CSV file, perform the following:

1. Run a report (page 313).

2. Click Export this report.

NOTE:  The remainder of this procedure uses Microsoft
Internet Explorer 6 with the default security settings as an
example. If you are using another web browser or other
security settings, the exact actions you need to perform in
order to complete this procedure might be different. 

The Open Save dialog box appears.

IF DO THIS

You want to include 
information for the past day 
(24 hours), past week or past 
two weeks.

Select the Backup Period option and 
select the desired length of time from 
the list box.

You want to define a specific 
range of calendar dates for 
this report.

Select the Date/Time Range option 
and use the From Date/Time and 
To Date/Time fields to define your 
desired range of calendar dates.
TIP:  Clicking ... shows a browsable 
calendar from which you can select 
specific calendar dates.
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3. Click Save.

The Save As dialog box appears.

4. Browse to the desired location and click Save.

The Save As and Open Save dialog boxes both close and the CSV file is 
saved to the location you selected.
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Replicator
Replication is a feature that allows one Avamar server to store a read-only copy of 
its data on another Avamar server in order to support future disaster recovery of 
that server. 

This feature is discussed elsewhere in this publication. Refer to Replication (page 
333) for additional information.

Configure
The Configure page allows you configure which Avamar systems in your enterprise 
you want to monitor. 

Selecting Setup from any other page displays the Configure page.

The Configure page displays the following information for each Avamar system 
you have added to your Avamar Enterprise Manager configuration:

COLUMN DESCRIPTION

System Avamar server hostname (as defined in corporate DNS).

IP Avamar server IP address.

Port Data port used to communicate with this Avamar system. 
Default is port 7778.

Version Specific version Avamar software this server is running.

Monitor If Yes, this Avamar system is being monitored with 
Avamar Enterprise Manager.
If No, this Avamar system has been added to the 
Configure page Systems list, but is not being monitored.

Connection If OK, connection with this Avamar system is functioning 
properly.

Contact Elapsed time since this Avamar server was last contacted 
by Avamar Enterprise Manager and data was collected.

Note Optional note or comment.
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Monitoring Multiple Systems
By default, Avamar Enterprise Manager only shows operational status for the 
Avamar system that is running this instance of the EMS. In order to manage other 
Avamar systems in your enterprise, you must explicitly add them by performing 
the following:

1. Open your web browser and log into Avamar Enterprise Manager (page 
295).

The Dashboard page (page 296) appears.

2. Select Configure.

The Configure page (page 315) appears.

3. Click Add.

An Add block appears below the systems list.
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4. Type or select the following:

5. Click Save.

The Add block disappears and your new system is added to the Configure 
page Systems listing.

FIELD/OPTION DESCRIPTION

System name or IP Type the Avamar server hostname (as defined in 
corporate DNS) or IP address.

Port Type the port used to communicate with this MCS. 
Default is port 7778.

Monitor Select this option to enable monitoring of this 
system with Avamar Enterprise Manager.
Clear this option to add this system to the 
Configure page Systems list, but not monitor it.

Password Type your Avamar administrative user account 
password.

Note Type an optional note or comment.
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Suspending and Resuming System Monitoring
At some point you might want to suspend or resume monitoring of one or more 
Avamar systems. This typically occurs when a system is taken offline and placed 
back in service at a later date.

1. Open your web browser and log into Avamar Enterprise Manager (page 
295).

The Dashboard page (page 296) appears.

2. Select Configure.

The Configure page (page 315) appears.

3. Click the server name you want to edit.

An Edit block appears below the systems list.

4. Do one of the following:

IF DO THIS

You want to suspend monitoring of a 
system in the Configure page Systems list.

Clear the Monitor option.

You want to resume monitoring a system in 
the Configure page Systems list.

Select the Monitor option.
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Removing a System from the Systems List
1. Open your web browser and log into Avamar Enterprise Manager (page 

295).

The Dashboard page (page 296) appears.

2. Select Configure.

The Configure page (page 315) appears.

3. Select the option (checkbox) next to the system you want to remove.

4. Click Remove.

The system no longer appears in the Configure page Systems list.
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Launching Avamar Administrator From Avamar Enterprise 
Manager

An important feature of Avamar Enterprise Manager is the capability of launching 
Avamar Administrator directly from an Avamar Enterprise Manager session.

Avamar Enterprise Manager uses the Java Webstart technology from Sun 
Microsystems to implement this feature. Webstart is an environment for automatic 
downloading of the latest version of an application from the Web. By incorporating 
this technology into Avamar Enterprise Manager, you no longer have to manually 
install individual versions of Avamar Administrator software to maintain any 
Avamar system in your enterprise. 

IMPORTANT:  Under certain circumstances, stale Java tem-
porary internet files can cause errors when attempting to
launch Avamar Administrator directly from an Avamar Enter-
prise Manager session. If this occurs on Windows computers,
select Start > Control Panel > Java. The Java Control
Panel Appears. In the Temporary Internet Files area, click
Delete Files... A confirmation dialog box appears. Ensure
that all temporary internet file types are selected and click
OK.

1. Point your web browser to the following URL:

http://AVAMARSERVER:8080/em

Where AVAMARSERVER is the hostname as defined in DNS. 
The default Enterprise Manager Login page appears.

2. Select the Administrator option.

The Avamar Enterprise Manager Login page for Avamar Administrator 
downloading appears.

3. Type your Avamar administrative user account ID and password in the User 
Name and Password fields, respectively.
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TIP:  Clicking Reset clears the User Name and Password
fields.

4. Click Log On.

Java Runtime
Environment (JRE)

5. If you do not already have the required Java Runtime Environment (JRE) 
installed, you must install it now.

If you do not already have the required JRE installed, you will be sent 
specific area of the Sun Microsystems web site that will allow you to 
download and install the correct version JRE.

If this occurs, read and follow the instructions on the Sun Microsystems 
web page.

The Java loading... prompt appears.

6. If a Security Warning dialog box appears, click Yes to proceed with the 
login.

The Avamar Administrator login window appears.

The fields are prepopulated with the information you typed in step 3.

7. Click Log On.

The Administrator launcher appears.
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CAPACITY MANAGEMENT

Managing your server storage capacity is one of the most important aspects of 
administering an Avamar server. This chapter describes the various features, 
functions and tools available to assist you with properly monitoring and managing 
your server storage capacity.

Limits and Thresholds
This topic describes how your server will behave as it crosses various consumed 
storage thresholds.

100% — The “Server Read-Only Limit”. When server utilization reaches 
100% of total storage capacity, it automatically becomes read-only. This is done to 
protect the integrity of the data already stored on the server.

Before you reach this point, you should contact EMC Technical Support to discuss 
measures that can be taken to prolong data storage on your Avamar server. This 
might include changing retention policies or migrating data.

95% — The “Health Check Limit”. Although an Avamar server could be 
allowed to consume 100% of available storage capacity (that is, hit the server 
read-only limit), it is not a good practice to actually let that occur. Consuming all 
available storage can prevent certain server maintenance activities from running, 
which might otherwise free additional storage capacity for backups.

For that reason, a second limit is established called the “health check limit.” This is 
the amount of storage capacity that can be consumed and still have a “healthy” 
server. 

This health check limit is derived by subtracting some percentage of server 
storage capacity from the server read-only limit. The default health check limit is 
95%. You can customize this setting to meet your specific site requirements Refer 
to Customizing Capacity Limits and Behavior (page 327). Although, setting this 
limit higher than 95% is not recommended.

When server utilization reaches the health check limit, existing backups are 
allowed to complete, but all new backup activity is suspended. A notification is 
sent in the form of a pop-up alert when you log into the Avamar Administrator. 
That system event must be acknowledged before future backup activity can 
resume. Refer to Acknowledging System Events (page 276) for additional 
information.
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80% — Capacity Warning Issued. When server utilization reaches 80%, a 
pop-up notification will inform you that the server has consumed 80% of its 
available storage capacity. Avamar Enterprise Manager capacity state icons are 
yellow.

Obtaining Basic Utilization Information
Both Avamar Administrator and Avamar Enterprise Manager provide real-time 
basic capacity utilization information.

Avamar Administrator. If administering a server using Avamar Administrator, 
basic capacity utilization information for that server is shown in the Server window 
Server Management tab (page 242).

The Server Information table shows total amount of server storage capacity and 
percentage of total available server storage capacity currently used. Refer to 
Monitoring the Server (page 242) for additional information about the Server 
window.
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Avamar Enterprise Manager. If administering one or more servers with 
Avamar Enterprise Manager, consolidated capacity utilization information for all 
servers being monitored is shown in the Dashboard (page 296).

The Capacity Used column shows summary status of how storage capacity is being 
utilized on that Avamar server. 

Capacity Used state icons communicate the following

Capacity utilization information is also shown on each server’s information page 
(page 300). Refer to Individual System Information Page (page 300) for additional 
information about the Avamar Enterprise Manager Server information page.

Avamar server has used less than 80% of total storage capacity.

Avamar server has used more than 80% but less than 95% of total 
storage capacity.
Consider adding additional capacity or deleting old backups.

Avamar server has used more than 95% of total storage capacity.
IMPORTANT:  No new backups will be allowed until additional capacity 
is added or old backups are deleted. Contact EMC Technical Support.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  324



 Capacity Forecasting
CAPACITY MANAGEMENT
Capacity Forecasting
In order to help you understand how quickly storage 
capacity is being consumed, each server continuously 
tracks and analyzes at what rate storage capacity is 
being consumed and projects how long you can 
continue consuming storage capacity at that rate. This 
forecasting occurs continuously in the background.

The Avamar Enterprise Manager Dashboard (page 296) 
shows capacity forecasting results in the Capacity 
Forecast column (shown right).

Capacity Forecast state icons communicate the 
following:

Avamar server is forecast to have 90 
days or more storage capacity.

Avamar server is forecast to have less 
than 90 days of storage capacity.

Avamar server is forecast to have less 
than 30 days of storage capacity.
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Detailed Utilization and Forecasting
Avamar Enterprise Manager also provides graphing capabilities for both capacity 
utilization (that is, server storage capacity that has already been consumed) and 
capacity forecasting (that is, server storage capacity that is projected to be used 
in the future). 

Placing your mouse cursor over the System menu until a sub-menu appears 
and selecting Capacity displays the Capacity Utilization and Forecast page 
(shown next). 

You can customize this page as follows:

Period or 
Date Range

If Period is selected, menus provide control over how much 
past utilization information is shown. Available time periods 
are past month, 3 months, 6 months and 9 months. 
If Date Range is selected, you can type a custom range of 
dates for which to show capacity utilization. 

Forecast out Capacity forecasting selections in are 1 month, 3 month, 6 
months and 9 months in the future.
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Customizing Capacity Limits and Behavior
Many of the settings that control capacity limits and behavior can be customized 
to meet your specific site requirements. These site-specific customizations are 
accomplished by manually modifying one or more application preference files.

Avamar Administrator Settings

In order to customize Avamar Administrator capacity management settings, you 
can change one or more of the following preferences in the com.avamar.mc.mcsm 
section of the /usr/local/avamar/var/mc/server_data/prefs/mcserver.xml 
preferences file. 

PREFERENCE DESCRIPTION
DEFAULT
SETTING

capForecastDataDays Actual amount of historical capacity 
usage data used for forecasting.

30 days

capForecastDataMinDays Minimum amount of historical 
capacity usage data that is required 
to perform forecasting.

14 days

capForecastReachedDays When forecasted capacity falls below 
this number of days, Avamar 
Administrator begins generating 
events (that must be acknowledged) 
and displaying pop-up alerts at login.

30 days

capMonitorIntervalMin This setting controls how often the 
Avamar Administrator checks 
forecasted capacity.

1 day 
(daily)

capReachedPercentage When total capacity utilization 
reaches this percentage threshold, 
Avamar Administrator generates an 
event notifying administrators that 
the system is full.

95%

hcMonitorIntervalMin This setting controls how often the 
Avamar Administrator performs a 
health check (that is, verifies whether 
or not consumed capacity has 
reached the health check limit).

1 day 
(daily)

hcOffsetROPercentage Percentage, that when subtracted 
from the server read-only limit 
(100%), produces the health check 
limit. 

5%

hcReminderIntervalMin This setting controls how often the 
Avamar Administrator issues events 
and pop-up alerts once the health 
check limit has been reached.

60 minutes 
(hourly)
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Avamar Enterprise Manager Settings

In order to customize Avamar Enterprise Manager capacity management settings, 
you can change one or more of the following preferences in the 
com.avamar.mc.dashboard section of the 
/usr/local/avamar/var/em/server_data/prefs/emserver.xml preferences file.

PREFERENCE DESCRIPTION
DEFAULT
SETTING

capWarnPercent When capacity usage reaches this 
percentage, capacity state icon is 
yellow.

80%

capErrPercent When capacity usage reaches this 
percentage, capacity state icon is red.

95%

capForecastWarnDays When forecasted capacity falls below 
this number of days, capacity forecast 
icon is yellow.

90 days

capForecastErrDays When forecasted capacity falls below 
this number of days, capacity forecast 
icon is red.

30 days
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Updating Avamar Application Preference Files

User=admin 1. Open a command shell (page 477).

2. Do one of the following:

3. Shutdown the correct system component by doing one of the following:

4. Do one of the following:

(a) If changing Avamar Administrator settings (page 327), type:

cd /usr/local/avamar/var/mc/server_data/prefs

Open mcserver.xml in a Unix text editor.

(b) If changing Avamar Enterprise Manager settings (page 328), type:

cd /usr/local/avamar/var/em/server_data/prefs

Open emserver.xml in a Unix text editor.

5. Change one or more preference settings.

6. Save your changes.

7. Restart the correct system component by doing one of the following:

IF DO THIS

Administering a 
single-node server.

Log into the server as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Administering a 
multi-node server.

Log into the utility node as user admin.
When prompted for a password, type the admin 
password and press ENTER.
Load the admin OpenSSH key by typing:
ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.
Type the admin user account passphrase and 
press ENTER.

IF DO THIS

Changing Avamar 
Administrator settings.

Type:
dpnctl stop mcs

Changing Avamar Enterprise 
Manager settings.

Type:
dpnctl stop ems

IF DO THIS

Changing Avamar 
Administrator settings.

Type:
dpnctl start mcs

Changing Avamar Enterprise 
Manager settings.

Type:
dpnctl start ems
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Server and Client Average Daily Change Rates
When managing your server capacity, it is useful to know the average daily 
change rate for both the server and for individual clients. 

For example, the server average daily change rate can spike upward for a few 
days immediately after adding several new clients (particularly database clients). 
This is to be expected. After a few days, data deduplication optimizes server 
storage efficiency and the server daily change rate typically returns to normal.

However, if the server average daily change rate remains high for an extended 
period of time, it might be necessary to determine if this is due to one or more 
individual clients that might be experiencing less than expected data deduplication 
efficiencies.

Server Data

Placing your mouse cursor over the System menu until a sub-menu appears and 
selecting Average Daily Change Rate > For Server displays the Average Daily 
Change Rate For Server page (shown next). 
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You can customize this page as follows:

Client Data

Placing your mouse cursor over the System menu until a sub-menu appears and 
selecting Average Daily Change Rate > For Clients with Maximum/
Minimum rate/bytes displays the average daily change rate for client with 
maximum/minimum rate/bytes page (shown next). 

You can customize this page as follows:

Period or 
Date Range

If Period is selected, menus provide control over how much 
past daily change rate information is shown. Available time 
periods are past month, 3 months, 6 months and 9 months. 
If Date Range is selected, you can select a custom range of 
dates for which to show server daily change rate data. 

Number of Clients Select 5, 10, 20 or 50 clients for which to show daily 
change rate data.

Minimum or 
Maximum

Select whether to show clients with the most (Maximum) 
or least (Minimum) daily change rate.

Rate or 
New Bytes

Select whether to customize display based on percentage 
of new data (Rate) or absolute capacity used (New 
Bytes).
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  331



 Server and Client Average Daily Change Rates
CAPACITY MANAGEMENT
Clicking a client name displays an average daily change rate graph for that client.

Period or 
Date Range

If Period is selected, menus provide control over how 
much past daily change rate information is shown. 
Available time periods are past month, 3 months, 6 
months and 9 months. 
If Date Range is selected, you can select a custom range 
of dates for which to show daily change rate data. 
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Replication is a feature that transfers data from a “source” Avamar server to a 
“destination” Avamar server. All data in the destination server can be directly 
restored back to primary storage without having to be staged through the source 
Avamar server.

You can use either Avamar Administrator or Avamar Enterprise Manager to 
manage your replication settings. 

Efficient Data Transfers. Replication is accomplished by way of highly 
efficient, asynchronous Internet Protocol (IP) data transfers, which can be 
scheduled during off-peak hours to make optimum use of network bandwidth. 
Additionally, like other members of the Avamar product family, replication uses 
sophisticated data deduplication technology that finds and eliminates redundant 
sequences of data before it is sent to the destination server, thereby reducing 
network traffic and promoting efficient use of hard disk storage. 

Remote Branch Disaster Recovery. Replication enables the efficient 
replication of data stored in a single-node server to a multi-node server. Using 
replication, a distributed enterprise can centrally protect and manage multiple 
remote branch offices that are using individual single-node servers for local 
backup and restore. The centralized multi-node server can then be used for 
disaster recovery, in the event of catastrophic data loss at any remote branch 
office. 

Enterprise Data Center Disaster Recovery. Replication can also be used to 
replicate data stored in a multi-node server to any other multi-node server in your 
enterprise. In this manner, multi-node servers can provide peer-to-peer disaster 
recovery for each other.
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Important Terms and Concepts
This topic discusses the basic concepts and fundamental principles of Avamar 
server replication. 

There are two basic kinds of replication:

• Normal replication
• Full “root-to-root” replication

Normal Replication. During normal replication, user data on the source 
Avamar server is replicated to a destination Avamar server. 

The “REPLICATE” Domain. Replication 
automatically creates a special “REPLICATE” 
domain on the destination server during the 
first replication operation. This domain 
contains a mirrored representation of the 
entire source server client tree on the 
destination server.

All data within the REPLICATE domain is 
read-only. The only operations allowed on 
these backups are:

• Redirected restores to other clients not 
within the REPLICATE domain (page 84)

• Changing a backup expiration date (page 
88)

• Validating backups on other clients not 
within the REPLICATE domain (page 92)

• Viewing backup statistics (page 94)
• Deleting a backup (page 98)

The example (right) shows a destination server “avamar-1” that contains both 
local clients and clients replicated from source server “avamar-2.” 

Full “Root-to-Root” Replication. Full “root-to-root” replication is a kind of 
replication that creates a complete logical copy of an entire source server on the 
destination server. Furthermore, the replicated data is not copied to the 
REPLICATE domain, it is added directly to the root domain just as if source clients 
had registered with the destination server. Also, source server data replicated in 
this manner is fully modifiable on the destination server.

NOTE:  The remainder of this chapter deals exclusively with
normal replication. Refer to Avamar System Migration (page
393) for additional information about using full “root-to-root”
replication.

“Source” and “Destination” Servers. Replication always transfers data from 
a “source” Avamar server to a “destination” Avamar server. Furthermore, in order 
to maintain referential integrity on the original “source” server, replicated data 
cannot be directly modified on the destination server. Replicated data is simply 
stored on the destination server in the event that it is needed for future recovery.
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Normal Replication Is a Scheduled Event. Once replication is set up and 
configured on the source server, normal replication occurs automatically at 
predetermined scheduled intervals.

What Data Is Replicated? In order to fully replicate an Avamar server, all of 
the following data must be copied from the source server to the destination server 
during each replication operation:

• Client backups
• Domains, clients and users
• Groups, datasets, schedules and retention policies
• State of the server (for example, contents of the activity monitor and 

server monitor databases at the time of the last MCS backup or “flush”)

Capabilities and Limitations

Only “Static” Data Is Replicated. Each replication operation transfers all 
static data resident on the source Avamar server. The concept of “static” data is 
especially important. It must be understood that at the time a replication 
operation is initiated, the replication operation can only process quiescent 
(“static”) data resident on the source server. Therefore, any operation that writes 
data to the source server and has not fully completed (for example, an in-process 
backup, adding a new user, editing a dataset and so forth) will in most cases not 
be part of that particular replication operation. However, that data will be 
replicated during the next replication operation. 

You Can Replicate Backups by Retention Type. In order to enhance the 
flexibility of the retention feature, you can configure your replication operations to 
replicate all backups from the source Avamar server to the destination Avamar 
server, or only replicate daily, weekly, monthly or yearly backups.

Avamar Administrator Can Only Manage One Server at a Time. An 
important limitation of using Avamar Administrator to manage your replication 
settings is that you are limited to managing one server at a time. If you have 
more than one Avamar system in your environment, you may prefer to use the 
Avamar Enterprise Manager multi-system management console instead. 

Timezones. Be advised that when you schedule replication activities, the start 
time is displayed in your local timezone, not the source or target server timezone. 
For example, consider a situation in which you are in the Pacific timezone and the 
replication source server is in the Eastern timezone. If you (in Pacific timezone) 
set replication to begin at 8:00 P.M., the server (which resides in the Eastern 
timezone) will compensate for the 3 hour difference between timezones and start 
the replication job at 11:00 P.M.
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Best Practices

If Possible, Avoid Source/Target Server Incompatibilities. Although 
replication between different version servers is supported, for best results, try to 
ensure that the target server is running same or later version of the Avamar 
software than the source Avamar server.

Use a Large Time-Out Setting Initially. If you specified an optional time-out 
value during installation and configuration, recent backups might not get 
replicated as the replication process can time out before all backups in the system 
are successfully replicated. This is because replication always replicates backups 
alphabetically by client name and earliest backups before later backups.

Whenever possible, you should examine a sampling of recent replicated backups 
on the destination server to ensure that all are being replicated. It is often 
necessary to increase the optional time-out value during the first few weeks of 
replication sessions. Eventually the replication process should normalize. As more 
data is replicated to the destination server, greater levels of data deduplication 
and decreased transfer times can be expected. At that time, you can decrease the 
optional time-out value if so desired.

IMPORTANT:  Normal source server background mainte-
nance tasks such as hfscheck and garbage collection should
not be performed while a replication session is in progress.
Therefore, once you have determined that your nightly repli-
cation window has normalized, you should optimize the
length of your replication window accordingly.

The default time-out setting is 20 hours (72000 seconds). 

Schedule Replication During Periods of Low Backup Activity. Because 
only completed client backups are replicated, you should make every effort to 
schedule replications during periods of low backup activity. This ensures that the 
greatest number of client backups get replicated during each replication session.
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Managing Replication with Avamar Administrator
1. Start Avamar Administrator (page 21).

2. Select Navigation > Administration or click the Administration 
launcher button.

The Administration window appears.

3. Click the Services Administration tab.

4. Double-click the Replication cron job entry in the properties table.

The Replication cron job dialog box appears.
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The Replication cron job dialog box displays the following information:

FIELD DESCRIPTION

Status Current replication status. One of the following:

Running Scheduled replication operations are 
occurring normally.

Not Running Scheduled replication operations are 
not occurring normally.

Not Running 
and 
Suspended

Scheduled replication operations are 
not occurring normally and no future 
replication operations will occur until 
replication is resumed on this 
Avamar server.

Suspended Indicates whether or not scheduled replication 
operations have been started (No) or stopped (Yes).

Configuration File Location of the repl_cron.cfg configuration file, 
which stores replication settings for this Avamar 
system.

Enabled Indicates whether or not scheduled replication is 
enabled (Yes) or disabled (No) on this source 
Avamar server.

Last Completed Elapsed time since last replication operation 
completed.

Last Status Status of last completed replication operation. One 
of the following:

None Status for last replication operation 
is not available.

Success Last replication operation 
successfully completed. 

Failed One or more errors were 
encountered during the last 
replication operation. 

TIP:  In addition to viewing overall replication job 
status, you can also view replication status on a 
client-by-client basis in the Activity window. Refer 
to Monitoring Backup, Restore and Validation 
Activities (page 76) for additional information.
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5. Type or select the following: 

FIELD/OPTION DESCRIPTION

Destination Destination Avamar server hostname (as defined in 
corporate DNS).

Destination 
Directory: 
/REPLICATE

Shows destination directory on destination Avamar 
server.
The default location is /REPLICATE/SOURCE, where 
SOURCE is the source Avamar server hostname you 
clicked in the systems list.
This destination is modifiable, but must always exist 
under the /REPLICATE domain.

Destination 
User Id

Avamar administrative user account ID (repluser) that 
will be used to log into the destination Avamar server.

Destination 
User Password

The password for the Avamar administrative user 
account ID (repluser) entered in the Destination User 
Id field.
NOTE:  If you change the password for the repluser 
account on the target server, then remember to 
update the Destination User Password value in the 
replication configuration on the source server with the 
new password.

Timeout 
(seconds)

This is the maximum length of time that each 
replication operation should run.

Bandwidth 
(Mbps)

This is a network utilization throttling setting that 
specifies the maximum average network utilization 
allowed in Mega Bits Per Second (Mbps). 
If the replication operation exceeds this setting, it will 
be “throttled back” by introducing delays until the 
average network utilization falls below the specified 
threshold.

Work directory This is the full path to the temporary folder or 
directory that will be used to store replication log files.

Include 
backups with 
the following 
retention:

This setting allows you limit your replication operation 
to only backups that have been assigned a specific 
retention type (page 73). Select one or more of the 
following:

Daily Replicate daily backups.

Weekly Replicate weekly backups.

Monthly Replicate monthly backups.

Yearly Replicate yearly backups.

Not tagged Replicate backups that are not explicitly 
tagged as daily, weekly, monthly or 
yearly.
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6. Click OK.

The Replication cron job dialog box closes.

Schedule Select the time of day at which you want to initiate 
replication for this server, or Don’t Run if you want to 
temporarily suspend replication of this Avamar 
system.

FIELD/OPTION DESCRIPTION
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Viewing Replication Statistics with Avamar Administrator
1. Start Avamar Administrator (page 21).

2. Select Navigation > Activity or click the Activity launcher button.

The Activity window appears.

3. Click the Activity Monitor tab.

4. Select a Replication Source or Replication Destination activity and select 
Actions > View Statistics. 

The Replicate Statistics dialog box appears.

5. Click Close.

The Replicate Statistics dialog box closes.

TAB DESCRIPTION

Details Shows detailed information obtained from the 
v_repl_activities database view. Refer to 
v_repl_activities (page 596) for additional information.

Backups Shows a list of backups included in this replication 
operation.

Errors Shows any errors that occurred during this replication 
operation.
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Managing Replication with Avamar Enterprise Manager
Unlike Avamar Administrator’s replication management feature (page 337), which 
is inherently constrained to only managing replication settings for one Avamar 
system at a time, Avamar Enterprise Manager’s replication management feature is 
capable of managing replication for all Avamar systems you are currently 
monitoring.

Avamar Enterprise Manager provides two different replication management pages: 
a status page, which shows status for various replication operations; and a setup 
page, which is used to set up and configure various replication operations for 
various Avamar systems you are currently monitoring.

Placing your mouse cursor over the Replicator menu until a 
sub-menu appears and selecting Status displays the Replicator 
Status page (page 344).

Placing your mouse cursor over the Replicator menu until a 
sub-menu appears and selecting Setup displays the Replicator 
Setup page (page 342).

Replicator Setup Page

The Replicator Setup page is used to set up and configure various replication 
settings for various Avamar systems you are currently monitoring.

The Replicator Setup page displays the following information for each Avamar 
system you have added to your Avamar Enterprise Manager configuration: 

COLUMN DESCRIPTION

Source Source Avamar server hostname (as defined in corporate 
DNS).
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Configured Indicates whether or not source Avamar server has been 
configured and enabled for replication. One of the following:

Not 
Monitored

This Avamar system is currently not being 
monitored by Avamar Enterprise Manager.
In order to use Avamar Enterprise Manager’s 
replication management feature on this 
system, you must enable or resume 
monitoring. Refer to Suspending and 
Resuming System Monitoring (page 318) for 
additional information.

No This Avamar system is not currently configured 
and enabled for replication operations. Refer to 
Configuring or Modifying Replication Settings 
(page 346) for additional information.

Yes This Avamar system is configured and enabled 
for replication operations.

Destination Destination Avamar server hostname (as defined in corporate 
DNS).

Schedule Hour of the day that replication is scheduled to occur, or 
Don’t Run if replication is temporarily suspended.

Timeout Maximum length of time that replication activity is allowed to 
run.

Retention Shows which types of backups are being replicated. One or 
more of the following:

Daily Daily backups are being replicated.

Weekly Weekly backups are being replicated.

Monthly Monthly backups are being replicated.

Yearly Yearly backups are being replicated.

Not tagged Backups that have not explicitly tagged as 
daily, weekly, monthly or yearly are being 
replicated.

Bandwidth Network utilization throttling setting. This setting specifies 
the maximum average network utilization allowed in Mega 
Bits Per Second (Mbps). 
If the replication operation exceeds this setting, it will be 
“throttled back” by introducing delays until the average 
network utilization falls below the specified threshold.

Work Directory Temporary folder or directory used to store replication log 
files.

COLUMN DESCRIPTION
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Replicator Status Page

The Replicator Status page shows consolidated daily replication status for each 
Avamar system you are currently monitoring.

The Replicator Status page displays the following information for each Avamar 
system you are currently monitoring: 

Clients Shows number of clients that have been explicitly included or 
excluded.

Option True if clients are included. Otherwise, clients are excluded.

COLUMN DESCRIPTION

Source Source Avamar server hostname (as defined in corporate 
DNS).

Status Current replication status. One of the following:

Running Scheduled replication operations are occurring 
normally.

Not Running Scheduled replication operations are not 
occurring normally.

Not Running 
and 
Suspended

Scheduled replication operations are occurring 
normally and no future replication operations 
will occur until replication is resumed on this 
Avamar server.

Suspended Indicates whether or not scheduled replication operations 
have been started (No) or stopped (Yes).

Destination Destination Avamar server hostname (as defined in corporate 
DNS).

Schedule Hour of the day that replication is scheduled to occur, or Don’t 
Run if replication is temporarily suspended.

COLUMN DESCRIPTION
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Last Completed Elapsed time since last replication operation completed.

Last Status Status of last completed replication operation. One of the 
following:

None Status for last replication operation is not 
available.

Success Last replication operation successfully 
completed. 

Failed One or more errors were encountered during 
the last replication operation. 

COLUMN DESCRIPTION
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Configuring or Modifying Replication Settings

This topic describes how to configure an Avamar system you are currently 
monitoring to begin daily replications, or modify existing replication settings.

1. Open your web browser and log into Avamar Enterprise Manager (page 
295).

The Dashboard page (page 296) appears.

2. Place your mouse cursor over the Replicator menu until a sub-menu 
appears (shown right), then select Setup. 

The Replicator Setup page (page 342) appears.

3. Click the desired Avamar system link in the Source column.

An Edit block appears below the systems list, which lists the replication 
settings for that Avamar system.
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4. Type or select the following:

FIELD/OPTION DESCRIPTION

Destination Select the desired destination Avamar server from the 
list.

Destination 
Directory: 
/REPLICATE

Shows destination directory on destination Avamar 
server.
The default location is /REPLICATE/SOURCE, where 
SOURCE is the source Avamar server hostname you 
clicked in the systems list.
This destination is modifiable, but must always exist 
under the /REPLICATE domain.

Destination 
User ID

Type the a valid Avamar administrative user account 
ID that will be used to log into the destination Avamar 
server in order to perform replication. The default is 
the repluser account.

Destination 
User Password

Type the password for the Avamar administrative user 
account ID  (repluser) entered in the Destination User 
ID field.
NOTE:  The password for the repluser account must 
be the same on both the source and destination 
server. If you change the password on one server, 
then remember to change it on the other server.

Schedule Select the time of day at which you want to initiate 
replication for this server, or Don’t Run if you want to 
temporarily suspend replication of this Avamar 
system.

Timeout Select the maximum length of time that each 
replication operation should run.

Work Directory Type the full path to the temporary folder or directory 
that will be used to store replication log files.

Bandwidth 
(Mbps)

Type a network utilization throttling setting in Mega 
Bits Per Second (Mbps). 
Refer to Replicator Setup Page (page 342) for 
additional information about this setting.
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REPLICATION
Include 
backups with 
the following 
retention:

This setting allows you limit your replication operation 
to only backups that have been assigned a specific 
retention type (page 73). Select one or more of the 
following:

Daily Replicate daily backups.

Weekly Replicate weekly backups.

Monthly Replicate monthly backups.

Yearly Replicate yearly backups.

Not tagged Replicate backups that are not explicitly 
tagged as daily, weekly, monthly or 
yearly.

Replication 
Type

One of the following:

Full Replicate data for all clients residing on 
the source Avamar server.

Selective Include or exclude certain clients from 
replication operations.

Select Clients If Replication Type is set to Selective, use this section 
to include all clients, or include or exclude only those 
clients that match a pattern matching expression.

FIELD/OPTION DESCRIPTION
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REPLICATION
Getting Replication Status

1. Open your web browser and log into Avamar Enterprise Manager (page 
295).

The Dashboard page (page 296) appears.

2. Place your mouse cursor over the Replicator menu until a sub-menu 
appears (shown right), then select Status. 

The Replicator Status page (page 344) appears.

The Replicator Status page shows consolidated daily replication status for 
each Avamar system you are currently monitoring.

Refer to Replicator Status Page (page 344) for descriptions and 
explanations of the information shown on this page.
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REPLICATION
Starting and Stopping Daily Replications

IMPORTANT:  Stopping replication will cause any currently-
running replication operation to be immediately canceled if
that replication operation was initiated using Avamar Enter-
prise Manager. However, if a currently-running replication
operation was initiated by way of a cron mechanism and you
stop replication on that server, that replication operation will
run to completion.

1. Open your web browser and log into Avamar Enterprise Manager (page 
295).

The Dashboard page (page 296) appears.

2. Place your mouse cursor over the Replicator menu until a sub-menu 
appears (shown right), then select Status. 

The Replicator Status page (page 344) appears.

3. Do one of the following:

IF DO THIS

You want to start daily 
replications for one or 
more Avamar system you 
are currently monitoring.

Select the option (checkbox) next to the 
servers for which you want to start daily 
replications and click Start Replication.

You want to stop daily 
replications for one or 
more Avamar system you 
are currently monitoring.

Select the option (checkbox) next to the 
servers for which you want to stop daily 
replications and click Stop Replication.
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IMPORTANT:  Avamar server maintenance commands
should only be used by authorized personnel thoroughly
familiar with their intended use. Contact EMC Technical Sup-
port for additional information.

Checkpoints
“Checkpoints” are system-wide backups taken for the express purpose of assisting 
with disaster recovery. Checkpoints are typically scheduled during the blackout 
window (page 274). 

In addition to the regularly scheduled twice daily checkpoints, you can create and 
validate additional server checkpoints any time you need to. 

Checkpoint validation might take several hours depending on the amount of data 
in your Avamar server. For this reason, each validation operation can be 
individually configured to perform all checks (full validation) or perform a partial 
"rolling" check which fully validates all new and modified stripes, then partially 
checks a subset of unmodified stripes.

You can also delete checkpoints in order to reclaim additional server storage 
capacity.

Individual checkpoints shown in the Avamar Server window Checkpoint 
Management tab are always in one of the following states:

STATE DESCRIPTION

Checkpoint failed validation or was 
cancelled before it could complete.

Checkpoint has not yet been 
validated.

Validation is currently being 
performed on this checkpoint.

Checkpoint passed validation.
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Creating a Checkpoint
1. Start Avamar Administrator (page 21).

2. Select Navigation > Avamar Server or click the Avamar Server 
launcher button.

The Avamar Server window appears.

3. Click the Checkpoint Management tab.

4. Select Actions > Create Checkpoint.

The Create New Checkpoint dialog box appears.

This dialog box shows the progress of this operation. You can cancel the 
operation at any time by clicking Cancel.

5. When the Create New Checkpoint dialog box shows that the checkpoint is 
complete, click Close.

The Create New Checkpoint dialog box closes.
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Validating a Checkpoint
Checkpoint validations can take several hours to perform and only one checkpoint 
can be validated at a time.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Avamar Server or click the Avamar Server 
launcher button.

The Avamar Server window appears.

3. Click the Checkpoint Management tab.

4. Select an existing unvalidated checkpoint and select Actions > Validate 
Checkpoint.

The Validation Type dialog box appears.

5. Select one of the following validation types:

6. Click OK.

The Validation Type dialog box closes.
The Start Time, Finished Time changes and status indicator all change 
state to indicate that the validation operation is being performed.

When the validation operation is complete, the Start Time, Finished Time 
changes and status indicator will change states to indicate either a 
successful validation or that this checkpoint could not be validated.

TYPE DESCRIPTION

Full Validation performs all checks.

Rolling A partial "rolling" check which fully validates 
all new and modified stripes, then partially 
checks a subset of unmodified stripes.
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Deleting a Checkpoint
Deleting checkpoints is typically done in order to reclaim additional server storage 
capacity. Generally, it is best to delete unvalidated checkpoints before deleting 
validated checkpoints.

1. Start Avamar Administrator (page 21).

2. Select Navigation > Avamar Server or click the Avamar Server 
launcher button.

The Avamar Server window appears.
Click the Checkpoint Management tab.

3. Select the checkpoint you want to delete and select Actions > Delete 
Checkpoint.

A message appears asking you to confirm this action.

4. Click Yes to permanently delete this checkpoint.
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Rolling Back to a Checkpoint
“Rollback” is the process of restoring the Avamar server to a known good state 
using data stored in a validated checkpoint. 

If nodes have been added to the Avamar server since the checkpoint was taken, 
entries for them should be removed from the probe.out file before this procedure 
is performed.

User=admin 1. Open a command shell (page 477).

2. Do one of the following:

Shut Down the
Server

3. Type:

dpnctl stop

Find Latest
Validated

Checkpoint

4. In order to perform a rollback, you need a valid checkpoint ID. To display a 
list of checkpoints, type the following:

cplist

The following information appears in your command shell:

Where each “cp.YYYYMMDDHHMMSS” entry is a checkpoint ID and “valid 
hfs” indicates a validated checkpoint.

valid hfs indicates a fully validated checkpoint;valid par indicates a 
partially validated checkpoint.

Generally, you should roll the system back to the latest fully validated 
checkpoint unless you have a good reason to roll back to an earlier 
checkpoint.

5. Use the date/time stamps to find the latest validated checkpoint and note 
the checkpoint ID.

IF DO THIS

Administering a 
single-node server.

Log into the server as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Administering a 
multi-node server.

Log into the utility node as user admin.
When prompted for a password, type the admin 
password and press ENTER.
Load the admin OpenSSH key by typing:
ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.
Type the admin user account passphrase and 
press ENTER.

cp.20080106170113 Fri Jan 6 17:01:13 2008 valid hfs del nodes 4 stripes 396

cp.20080107170042 Sat Jan 7 17:00:42 2008 valid hfs del nodes 4 stripes 396

cp.20080108170040 Sun Jan 8 17:00:40 2008 valid hfs ... nodes 4 stripes 396

cp.20080109170043 Mon Jan 9 17:00:43 2008 valid hfs ... nodes 4 stripes 396
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Initiate the
Rollback

6. Type:

rollback.dpn --cptag=cp.YYYYMMDDHHMMSS >& FILE

Where cp.YYYYMMDDHHMMSS is the checkpoint ID from step 6 and FILE is 
a user-defined temporary file.

7. Wait for the rollback to complete.

The rollback might take up to one hour, depending on the amount of data 
present in your Avamar server. When the rollback is complete, the 
command prompt will return.

8. Open the user-defined temporary file (FILE) created in step 8 and verify 
that the rollback successfully completed without errors.

The server will automatically restart following a successful rollback.
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MCS Configuration Settings

Server and Client Preferences Files. Avamar Administrator consists of both 
client and server software applications. Each application can be independently 
configured by modifying the appropriate preferences file.

Changes made to the server preferences file affect all Avamar Administrator 
sessions; changes made to a client preferences file only affect Avamar 
Administrator sessions on that client.

Filenames. The Avamar Administrator preferences files are:

• mcserver.xml (server preferences file)
• mcclient.xml (client preferences file)

Both files conform to the preferences.dtd XML Document Type Description (DTD) 
referenced by the JSDK 1.4 API. 

“Default” and “Live” Copies. Two copies of each of these files are present on 
the system: an initial “default” copy that is used to initialize each application 
following installation and a “live” copy that contains the current settings used by 
the application.

Locations. The default copies are located in each application’s /lib directory. The 
“live” copies are located in a “live file” directory. The default live file directory for 
each application is:

• /usr/local/avamar/var/mc/server_data/prefs (server live file directory)
• INSTALL-DIR/var/mc/gui_data/prefs (client live file directory)

Where INSTALL-DIR is typically C:\Program Files\avs\administrator on Microsoft 
Windows computers, /usr/local/avamar on Linux computers or 
/opt/AVMRconsl on Solaris computers.

Initialization Behavior. When either the server or client application is 
initialized, the respective default preferences file in the lib directory is loaded into 
memory and replicated to the live file directory. 

IMPORTANT:   Reinitializing a running MCS is highly
destructive — it will completely overwrite any custom prefer-
ence settings stored in the live 
/usr/local/avamar/var/mc/server_data/prefs/mcserver.xml
file and revert the system configuration back to default set-
tings.

If this occurs, you will need to recover custom preference
settings from a previous flush (backup) if they are overwrit-
ten.

Upgrade Behavior. During server upgrades, any mcserver.xml entry that is 
marked with the merge="delete" attribute in the new “default” mcserver.xml file 
will not be merged into the new “live” copy. These entries are obsolete. They are 
retained in the “default” mcserver.xml file so that the MCS will know to delete the 
preferences on an upgraded customer system.
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Backing Up MCS Data
In order to protect itself from hardware failures, the MCS backs up or “flushes” its 
persistent data to the Avamar server that it manages. Flushes (backups) are done 
by way of an avtar client session.

Automatic Flushes. Automatic flushes are normally performed hourly and as 
part of system checkpoints.

flush.timestamp File. Before every flush, a special timestamp file 
(flush.timestamp) is created in the server_data directory. This file includes the 
time and date of the flush. On a server rollback, this file is restored and can be 
used to verify the rollback was successful to the time and date desired. The 
contents of flush.timestamp is also accessible by way of the 
mcserver.sh --status command. Refer to Getting MCS Status (page 291) for 
additional information.

init.timestamp File. During system initialization the init.timestamp file is 
created or overwritten in the server_data directory. This file includes the time and 
date of the system initialization and can be used to verify that initialization was 
successful on the time and date desired.

Performing an On-Demand MCS Flush
Automatic flushes (page 358) are normally performed hourly and as part of 
system checkpoints. You can also force an on-demand “flush” by performing the 
following:

User=admin 1. Open a command shell (page 477).

2. Do one of the following:

3. Type:

mcserver.sh --flush

IF DO THIS

Administering a 
single-node server.

Log into the server as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Administering a 
multi-node server.

Log into the utility node as user admin.
When prompted for a password, type the admin 
password and press ENTER.
Load the admin OpenSSH key by typing:
ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.
Type the admin user account passphrase and 
press ENTER.
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Finding MCS Backups in the System
MCS flushes (backups) are stored under the /MC_BACKUPS account. You can get a 
list of MCS backups by browsing this account in the Avamar Administrator Backup 
& Restore window or by typing the following avtar command on a single 
command line:

avtar --backups --id=root --ap=PASSWORD --path=/MC_BACKUPS
 --hfsaddr=mydpn.Example.com --count=NUM

Where PASSWORD is the Avamar root user account password (not the operating 
system root password) and NUM is the number of backups you want listed by this 
command. 

IMPORTANT:  Space limitations in this publication cause
the previous command example to continue (wrap) to more
than one line. Your command must be typed on a single
command line (no line feeds or returns allowed). 

--count=NUM Option. A typical Avamar server takes 26 MCS flushes (backups) 
per day (one per hour and one each during the morning and evening system 
checkpoints). Therefore, specifying --count=NUM in increments of 26 will in most 
cases list all MCS flushes (backups) stored in the system for a predictable past 
number of days (for example, --count=26 should list all backups stored in the 
system during the past day, --count=52 should list all backups stored in the 
system during the past two days and so forth).
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Restoring MCS Data
User=admin 1. Open a command shell (page 477).

2. Do one of the following:

3. Stop the MCS by typing:

dpnctl stop mcs

4. Restore the MCS to the latest flush (backup) by typing:

mcserver.sh --restore

TIP:  You can also restore the MCS to a specific backup by
including the --labelnum=NUM option. Refer to Finding MCS
Backups in the System (page 359) for additional informa-
tion.

5. Open /usr/local/avamar/var/mc/server_log/restore.log to verify the 
success of the restore.

6. Restart the MCS by typing:

dpnctl start mcs

7. Resume scheduled operations (page 279).

IF DO THIS

Administering a 
single-node server.

Log into the server as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Administering a 
multi-node server.

Log into the utility node as user admin.
When prompted for a password, type the admin 
password and press ENTER.
Load the admin OpenSSH key by typing:
ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.
Type the admin user account passphrase and 
press ENTER.
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Reverting to Default MCS Preference Settings
You can safely revert back to the initial default preference settings (page 357) by 
performing the following:

User=admin 1. Open a command shell (page 477).

2. Do one of the following:

3. Stop the MCS by typing:

dpnctl stop mcs

4. Rename /usr/local/avamar/var/mc/server_data/prefs/mcserver.xml to 
old.mcserver.xml. 

Next, you must copy the default server preferences file into the 
/usr/local/avamar/var/mc/server_data/prefs directory.

5. Type:

cp /usr/local/avamar/lib/mcserver.xml
 /usr/local/avamar/var/mc/server_data/prefs/mcserver.xml

NOTE:  Space limitations in this publication cause the previ-
ous cp command to continue (wrap) to more than one line.
Your cp command must be typed on a single command line
(no line feeds or returns allowed). 

6. Restart the MCS by typing:

dpnctl start mcs

7. Resume scheduled operations (page 279).

IF DO THIS

Administering a 
single-node server.

Log into the server as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Administering a 
multi-node server.

Log into the utility node as user admin.
When prompted for a password, type the admin 
password and press ENTER.
Load the admin OpenSSH key by typing:
ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.
Type the admin user account passphrase and 
press ENTER.
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Manually Changing Your Avamar Administrator Client 
Preferences

Some Avamar Administrator client preferences can be changed directly from 
Avamar Administrator. However, a number of preferences can only be changed by 
modifying mcclient.xml.

1. Close Avamar Administrator.

2. Open var/mc/gui_data/prefs/mcclient.xml in a text editor.

3. Modify the preference elements you want to change.

4. Save your changes.

5. Your changes will take effect the next time you start Avamar Administrator.
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Updating Your Server Licensing
Each Avamar server is individually licensed when that server is initially deployed at 
a customer site. 

Avamar servers are licensed in units of decimal TB capacity. For example, 1 TB of 
licensable capacity equals 1,000,000,000,000 bytes. Licensable capacity includes 
deduplicated customer data and system overhead, including RAIN parity data (for 
RAIN-based systems).

If that server experiences a hardware failure that causes the primary MAC address 
of the utility node to change, or if additional storage capacity is purchased, a new 
license key file must be generated.

IMPORTANT:  In order to generate a license key file, you
must be able to log into the AvaSphere Extranet Portal with a
browser that supports cookies.

If you do not have an AvaSphere Extranet Portal user
account, contact EMC Technical Support to assist you with
updating your server licensing.

User=admin 1. Open a command shell (page 477).

2. Do one of the following:

3. Type:

gathergsankeydata

Enter your customer account number (as found on your EMC Purchase Order 
Confirmation):

IF DO THIS

Administering a 
single-node server.

Log into the server as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Administering a 
multi-node server.

Log into the utility node as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Load the admin OpenSSH key by typing:
ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.
Type the admin user account passphrase and 
press ENTER.
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4. Type your EMC Customer Number and press ENTER.

Your EMC Customer Number can be found on your EMC Purchase Order 
Confirmation.
Valid Customer Numbers conform to the following format:

CN-YYMMDDNNNNN

Where YY is a two-digit year, MM is a two-digit month, DD is a two-digit 
day of the month and NNNNN is a five-digit numerical sequence. 
The following information appears in your command shell:
Enter your Avamar system asset ID number (as found on your EMC Purchase Order 
Confirmation):

5. Type your system Reference ID and press ENTER.

The system Reference ID is found on your EMC Purchase Order 
Confirmation.
Valid system Reference IDs conform to the following format:

A-YYYYNNNNNN

Where YYYY is a four-digit year and NNNNNN is a six-digit numerical 
sequence. 

The following information appears in your command shell:

Your answers were:
Customer account ID: [CN-************]
Customer asset ID: [A-**********]
Is this correct? [y(es), n(o), e(xit)]:

6. Type y and press ENTER.

At this point, the gsankeydata.xml license key information file should be 
present in the local directory, from which gathergsankeydata was run in 
step 5.

Log Into
AvaSphere

Extranet Portal

7. Open your web browser and log into your AvaSphere Extranet Portal user 
account by typing:

http://www.avamar.com/avateamextranet

The EMC Avamar Extranet Login page appears.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  364



 Updating Your Server Licensing
ADVANCED SERVER ADMINISTRATION AND MAINTENANCE
8. Log into your AvaSphere Extranet Portal user account by typing your 
username and password in the Username and Password fields, then 
clicking Submit.

The EMC Avamar Support main page appears.

 

9. Click Avamar Key Generation.

The EMC Avamar Support key generation page appears.

 

AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  365



 Updating Your Server Licensing
ADVANCED SERVER ADMINISTRATION AND MAINTENANCE
10.Click Browse...

The Choose File dialog box appears.

11. Locate the license key information file created in steps 5 through 6.

12.Double-click the license key information file or select the license key 
information file and click Open.

The Choose File dialog box closes.

13.Switch to EMC Avamar Support key generation page and type the email 
address to which you want the license key file sent.

IMPORTANT:  This must be an email account from which
you can save the attached license key file and copy it to the
Avamar server.

14.Click Generate Key.

The EMC Avamar Support enter terabytes page appears. 
This page allows you to specify the number of Capacity Terabyte Licenses 
you want to allocate to this Avamar server. 

 

15. Type the number of Capacity Terabyte Licenses you want to allocate to this 
Avamar server in the Terabyte field.

16.Click Generate Key.

The EMC Avamar Support final key generation page appears, confirming 
that your license key has been emailed to the address you entered in step 
13.
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17.Open your email program and access the email account you entered in step 
13.

The license key file is an email attachment with the following naming 
convention:

ASSET-NAME.xml

Where ASSET-NAME is typically the Avamar server hostname as defined in 
corporate DNS.

18.Open the Avamar Key Information email message and save the 
ASSET-NAME.xml email attachment to a convenient temporary directory or 
folder.

19.Do one of the following:

IMPORTANT:  In order to activate your license using the
avmaint license command, the Avamar server data server
subsystem (also known as GSAN) must be running.

User=admin 20.Switch to your command shell session and ensure that you are still logged 
in as user admin and that the admin OpenSSH key is still loaded.

21.Verify that the data server subsystem (also known as GSAN) is running by 
typing:

dpnctl status gsan

The following information appears in your command shell:

dpnctl: INFO: gsan status: ready

22.Do one of the following:

IF DO THIS

Administering a 
single-node server.

Use WinSCP or an equivalent program to copy the 
ASSET-NAME.xml license key file from the 
temporary directory or folder to the Avamar 
server /tmp directory.

Administering a 
multi-node server.

Use WinSCP or an equivalent program to copy the 
ASSET-NAME.xml license key file from the 
temporary directory or folder to the Avamar 
server utility node /tmp directory.

IF DO THIS

Your Avamar server 
is running

Change file permissions on the ASSET-NAME.xml 
license key file and activate the license by typing:
chmod 644 /tmp/ASSET-NAME.xml

avmaint license /tmp/ASSET-NAME.xml 
 --avamaronly

Where ASSET-NAME.xml is the license key file 
you previously downloaded.
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23.Verify that the server license is correctly installed by typing:

avmaint license --avamaronly

License information appears in your command shell:

Your Avamar server 
is not running

Change file permissions on the ASSET-NAME.xml 
license key file and activate the license by typing:
cd /usr/local/avamar/etc

mv license.xml license.xml.old

cp /tmp/ASSET-NAME.xml license.xml

chmod 644 license.xml

Where ASSET-NAME.xml is the license key file 
you previously downloaded.

IF DO THIS
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Changing Avamar Passwords
This procedure describes how to use the change-passwords interactive utility to 
change various operating user account and Avamar server user account 
passwords, as well as creating new OpenSSH keys.

change-passwords will interactively prompt and guide you through any or all of 
the following operations:

• Changing operating system login passwords for the admin, dpn and root 
accounts

• Creating new admin and dpnid OpenSSH keys
• Changing internal Avamar server passwords for the root and MCUser accounts

After running the change-passwords interactive utility (page 369), you must also 
manually update EMS settings (page 377).

Run change-passwords

To change any operating user account passwords, Avamar server user account 
passwords or create new OpenSSH keys, perform the following:

User=dpn 1. Open a command shell (page 477).

2. Do one of the following:

3. Type:

change-passwords

If you run change-passwords on a multi-node server, the following 
information appears in your command shell:

Do you wish to change passwords and/or passphrases on all nodes?
Answering y(es) changes this set of nodes:

#.s -- all utility/services nodes
#.# -- all data nodes.

Answering n(o) will afford you the opportunity to install
existing SSH keys onto other nodes.

y(es), n(o), h(elp), q(uit/exit):

NOTE:  The previous information will not appear if you run 
change-passwords on a single-node server.

IF DO THIS

Administering a 
single-node server.

Log into the server 
as user dpn.

Administering a 
multi-node server.

Log into the utility 
node as user dpn.
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4. Do one of the following:

The following information appears in your command shell:
Identity added: /home/dpn/.ssh/dpnid (/home/dpn/.ssh/dpnid) Identity 
added: /home/dpn/.ssh/dpnid.prev (/home/dpn/.ssh/dpnid.prev) Identity 
added: /home/dpn/.ssh/dpnid.orig (/home/dpn/.ssh/dpnid.orig)

Do you wish to specify one or more additional SSH passphrase-less
private keys that are authorized for root operations?

Answer n(o) here unless there are known inconsistencies in
~root/.ssh/authorized_keys2 files among the various nodes (as might
be evident if you had been prompted for a root password in a previous
run of this program).

Note that the following keys will be used automatically (there is
no need to re-specify them here):

/home/dpn/.ssh/dpnid
/home/dpn/.ssh/dpnid.prev
/home/dpn/.ssh/dpnid.orig

y(es), n(o), h(elp), q(uit/exit):
--------------------------------------------------------

5. Type n and press ENTER.

The following information appears in your command shell:

The following is a test of root authorization with the currently
loaded SSH key(s).

If during this test you are prompted for an OS root password,
then you might be missing an appropriate "dpnid" key for one
or more nodes.

-> In that event, re-run this program and, when prompted,
specify as many SSH private key files as are necessary
in order to complete root operations on all nodes.

Starting root authorization test with 15 second timeout...
End of root authorization test.
--------------------------------------------------------

IF DO THIS

You want to change passwords 
on all nodes.

Type y and press ENTER.

You want to change passwords 
on selected nodes.

Type n and press ENTER.
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Change Operating
System User

Account
Passwords?

The following information appears in your command shell:
--------------------------------------------------------
Change OS (login) passwords?
y(es), n(o), q(uit/exit):

6. Do one of the following:

The following information appears in your command shell:

--------------------------------------------------------
Change OS password for "admin"?

y(es), n(o), q(uit/exit):

Change admin
Login Password?

7. Do one of the following:

The following information appears in your command shell:

Please enter a new OS (login) password for user "admin".
(Entering an empty (blank) line twice quits/exits.)

8. Type the new admin operating system user account password and press 
ENTER.

The following information appears in your command shell:

Please enter the same OS password again.
(Entering an empty (blank) line twice quits/exits.)

9. Retype the new admin operating system user account password and press 
ENTER.

The following information appears in your command shell:

Accepted OS password for "admin".
--------------------------------------------------------
Change OS password for "dpn"?
y(es), n(o), q(uit/exit):

IF DO THIS

You want to change admin, dpn or root 
operating system user account passwords.

Type y and press ENTER.

You do not want to change admin, dpn or 
root operating system user account 
passwords.

Type n and press ENTER.
Proceed to step 16.

IF DO THIS

You want to change the admin operating 
system user account password.

Type y and press ENTER.

You do not want to change the admin 
operating system user account password.

Type n and press ENTER.
Proceed to step 10.
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Change dpn Login
Password?

10.Do one of the following:

The following information appears in your command shell:
Please enter a new OS (login) password for user "dpn".
(Entering an empty (blank) line twice quits/exits.)

11.Type the new dpn operating system user account password and press 
ENTER.

The following information appears in your command shell:

Please enter the same OS password again.
(Entering an empty (blank) line twice quits/exits.)

12.Retype the new dpn operating system user account password and press 
ENTER.

The following information appears in your command shell:

Accepted OS password for "dpn".
--------------------------------------------------------
Change OS password for "root"?
y(es), n(o), q(uit/exit): y

Change root Login
Password?

13.Do one of the following:

The following information appears in your command shell:

Please enter a new OS (login) password for user "root".
(Entering an empty (blank) line twice quits/exits.)

14.Type the new root operating system user account password and press 
ENTER.

The following information appears in your command shell:

Please enter the same OS password again.
(Entering an empty (blank) line twice quits/exits.)

15.Retype the new root operating system user account password and press 
ENTER.

The following information appears in your command shell:

Accepted OS password for "root".
========================================================
Change SSH keys?
y(es), n(o), q(uit/exit): y

IF DO THIS

You want to change the dpn operating 
system user account password.

Type y and press ENTER.

You do not want to change the dpn 
operating system user account password.

Type n and press ENTER.
Proceed to step 13.

IF DO THIS

You want to change the root operating 
system user account password.

Type y and press ENTER.

You do not want to change the root 
operating system user account password.

Type n and press ENTER.
Proceed to step 16.
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Change OpenSSH
Keys?

The following information appears in your command SHELL:

========================================================
Change SSH keys?
y(es), n(o), q(uit/exit):

16.Do one of the following:

17.Do one of the following:

The following information appears in your command shell:

--------------------------------------------------------
Change SSH key for "admin"?
y(es), n(o), q(uit/exit): 

Create New admin
OpenSSH Key?

18.Do one of the following:

The following information appears in your command shell:
Please enter a new SSH key passphrase for user "admin".
(Entering an empty (blank) line twice quits/exits.)

19.Type the new admin OpenSSH passphrase and press ENTER.

The following information appears in your command shell:

Please enter the same SSH key again.
(Entering an empty (blank) line twice quits/exits.)

20.Retype the new admin OpenSSH passphrase and press ENTER.

The following information appears in your command shell:

Accepted SSH key for "admin".
--------------------------------------------------------
Redo passphrase-less elevated-privilege SSH key "dpnid"?
y(es), n(o), h(elp), q(uit/exit):

IF DO THIS

You want to change admin or 
dpnid OpenSSH keys.

Type y and press ENTER.

You do not want to change 
admin or dpnid OpenSSH keys.

Type n and press ENTER.
Proceed to step 22.

IF DO THIS

You want to create new admin 
or dpnid OpenSSH keys.

Type y and press ENTER.

You do not want to create new 
admin or dpnid OpenSSH keys.

Type n and press ENTER.
Proceed to step 18.

IF DO THIS

You want to create a new admin 
OpenSSH key.

Type y and press ENTER.

You do not want to create a 
new admin OpenSSH key.

Type n and press ENTER.

Proceed to step 21.
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Create New dpnid
OpenSSH Key?

21.Do one of the following:

IMPORTANT:  This task requires knowledge of the internal
Avamar server root user account password.

Change Internal
Avamar Server

User Account
Passwords?

The following information appears in your command shell:
========================================================
Change Avamar Server passwords?
y(es), n(o), q(uit/exit):

22.Do one of the following:

The following information appears in your command shell:

Please enter the CURRENT Avamar Server password for "root"
(Entering an empty (blank) line twice quits/exits.)

23.Type the current internal Avamar server root user account password (not 
the operating system root password) and press ENTER.

The following information appears in your command shell:

Checking Avamar Server root password (300 second timeout)...
Avamar Server current root password accepted.
--------------------------------------------------------
Change Avamar Server password for "MCUser"?
y(es), n(o), q(uit/exit): y

IF DO THIS

You want to create a new dpnid 
OpenSSH key.

Type y and press ENTER.

You do not want to create a new 
dpnid OpenSSH key.

Type n and press ENTER.

IF DO THIS

You want to change the MCUser or 
internal root Avamar server user 
account passwords.

Type y and press ENTER.

You do not want to change the 
MCUser or internal root Avamar 
server user account passwords.

Type n and press ENTER.
Proceed to step 30.
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Change Internal
Avamar Server

MCUser
Password?

24.Do one of the following:

The following information appears in your command shell:
Please enter a new Avamar Server password for user "MCUser".
(Entering an empty (blank) line twice quits/exits.)

25.Type the new internal Avamar server MCUser password and press ENTER.

The following information appears in your command shell:

Please enter the same Avamar Server password again.
(Entering an empty (blank) line twice quits/exits.)

26.Retype the new internal Avamar server MCUser password and press 
ENTER.

The following information appears in your command shell:
Accepted Avamar Server password for "MCUser".
--------------------------------------------------------
Change Avamar Server password for "root"?
y(es), n(o), q(uit/exit): 

Change Internal
Avamar Server

root Password?

27.Do one of the following:

The following information appears in your command shell:
Please enter a new Avamar Server password for user "root".
(Entering an empty (blank) line twice quits/exits.)

28.Type the new internal Avamar server root password and press ENTER.

The following information appears in your command shell:

Please enter the same Avamar Server password again.
(Entering an empty (blank) line twice quits/exits.)

29.Retype the new internal Avamar server root password and press ENTER.

The following information appears in your command shell:

Accepted Avamar Server password for "root".
--------------------------------------------------------
Do you wish to proceed with your password changes on the selected node?

Answering y(es) will proceed with password updates.
Answering n(o) or q(uit) will not proceed.

y(es), n(o), q(uit/exit): y

IF DO THIS

You want to change the internal Avamar 
server MCUser password.

Type y and press ENTER.

You do not want to change the internal 
Avamar server MCUser password.

Type n and press ENTER.
Proceed to step 27.

IF DO THIS

You want to change the internal Avamar 
server root password.

Type y and press ENTER.

You do not want to change the internal 
Avamar server root password.

Type n and press ENTER.
Proceed to step 30.
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Change Server
Lockbox

Administrative
Passphrase?

The following information appears in your command shell:
========================================================
Change the server lockbox administrative passphrase?
y(es), n(o), h(elp), q(uit/exit): y

30.Do one of the following:

The following information appears in your command shell:
--------------------------------------------------------
Change the server lockbox administrative passphrase?
y(es), n(o), h(elp), q(uit/exit): y

Please enter the CURRENT server lockbox administrative passphrase.
Enter ? or help for help.

(Entering an empty (blank) line twice quits/exits.)

31.Type the old server lockbox passphrase and press ENTER.

The following information appears in your command shell:
Please enter the NEW server lockbox administrative passphrase.
Enter ? or help for help.

(Entering an empty (blank) line twice quits/exits.)

32.Type the new server lockbox passphrase and press ENTER.

Accept Changes? 33.Do one of the following:

The following information appears in your command shell:

Changing OS passwords...
[Logging to /usr/local/avamar/var/change-passwords.log...]
Done changing OS passwords...
Changing Avamar Server passwords...
Checking MCS Status...
Stopping MCS...
Starting process of updating Administrator configuration...
Running script to update Administrator configuration on node 0.s...
[Logging to /usr/local/avamar/var/change-passwords.log...]
Done with updating Administrator configuration on node 0.s...
Starting process of updating client configurations...
Running script to update client configuration on 0.s...
[Logging to /usr/local/avamar/var/change-passwords.log...]
Updating client configuration on node 0.0...

IF DO THIS

You want to change the server 
lockbox passphrase.

Type y and press ENTER.

You do not want to change the 
server lockbox passphrase.

Type n and press ENTER.
Proceed to step 33.

IF DO THIS

You want to accept changes made 
to passwords or OpenSSH keys 
during this utility session.

Type y and press ENTER.

You want to exit this utility session 
without making changes to 
passwords or OpenSSH keys.

Type n and press ENTER.
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Done updating client configuration on 0.0...
Checking MCS Status...
Starting MCS...
Starting process of changing SSH keys...
Running script to update SSH keys on node 0.s...
[Logging to /usr/local/avamar/var/change-passwords.log...]
Done with updating SSH keys on node 0.s...
--------------------------------------------------------
Done.
NOTES:
- If you had custom public keys present in the

authorized_keys2 files of any Avamar OS users
(admin, dpn, root) be aware that
 you may need to re-add your custom keys.

- Please be sure to resume schedules via the
Administrator GUI.

Manually Update EMS Settings

After the change-passwords interactive utility has finished modifying various 
passwords, you must update the EMS by performing the following:

1. Open your web browser and log into Avamar Enterprise Manager (page 
295).

The Dashboard page (page 296) appears.

2. Select Configure.

The Configure page (page 315) appears.

3. Click the server name you want to edit.

An Edit block appears below the systems list.

4. Type the new MCUser password in the Password field and click Save.

User=admin 5. Open a command shell (page 477).
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6. Do one of the following:

7. Type:

dpnctl stop ems

emserver.sh --renameserver --uselocalmcs

dpnctl start ems

IF DO THIS

Administering a 
single-node server.

Log into the server as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Administering a 
multi-node server.

Log into the utility node as user admin.
When prompted for a password, type the admin 
password and press ENTER.
Load the admin OpenSSH key by typing:
ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.
Type the admin user account passphrase and 
press ENTER.
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Changing Single-Node Server Network Settings
This topic describes how to properly use the dpnnetutil utility to change the 
following single-node server network settings:

• IP address
• Domain name
• DNS settings
• Network gateway
• NAT settings
• Multi-NICs settings

Do not use dpnnetutil to change the node type.

IMPORTANT:  This procedure cannot under any circum-
stances be used to change network settings for multi-node
servers. If dpnnetutil is run against a multi-node server,
operational readiness might be adversely affected.

Contact EMC Technical Support for additional information. 

User=root 1. Open a command shell (page 477).

2. Log into the server as root.

3. When prompted for a password, type the root password and press ENTER.

4. Type:

dpnnetutil

The following information appears in your command shell:

Do you want to configure AVAMARSERVER?

Where AVAMARSERVER is your server’s hostname.

5. Use TAB or cursor keys to select Yes and press ENTER.

Time Zone The following information appears in your command shell:

The current default time zone is "TIMEZONE".
Do you want to select a different time zone?

Where TIMEZONE is your current default time zone.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  379



 Changing Single-Node Server Network Settings
ADVANCED SERVER ADMINISTRATION AND MAINTENANCE
6. Do one of the following:

SMTP Server The following information appears in your command shell:

Please enter the name or address of an SMTP server that will accept and relay e-
mail submissions from this host.

7. Do one of the following:

Server IP Address The following information appears in your command shell:

Do you want to create a bonded interface bond0 for this node?

8. Select No.

The following information appears in your command shell:
Please enter the new IP address for the system single-node server interface 
eth0:

9. Do one of the following:

IF DO THIS

You want to change the 
default server time zone.

1. Use TAB or cursor keys to select Yes.
2. Press ENTER.
3. Use cursor keys to select a time zone 

from the list.
4. Use TAB or cursor keys to select OK.
5. Press ENTER.

You want to keep the 
existing default server 
time zone.

1. Use TAB or cursor keys to select No.
2. Press ENTER.

IF DO THIS

You want to change the 
SMTP server name.

1. Type the new SMTP server name.
2. Press TAB to select OK.
3. Press ENTER.

You want to keep the 
existing SMTP server 
name.

1. Press TAB to accept the existing SMTP 
server name and select OK.

2. Press ENTER.

IF DO THIS

You want to change the 
server IP address.

1. Type the new server IP address.
2. Press TAB to select OK.
3. Press ENTER.

You want to keep the 
existing server IP address.

1. Press TAB to accept the existing server 
IP address and select OK.

2. Press ENTER.
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Network Mask The following information appears in your command shell:
Please enter the network mask for the system single-node server interface eth0.

10.Do one of the following:

Server Hostname The following information appears in your command shell:
Please enter the new hostname (without domain name) for the system single-node 
server.

11.Do one of the following:

Server Domain The following information appears in your command shell:
Please enter the domain name for the system single-node server.

12.Do one of the following:

IF DO THIS

You want to change the 
network mask.

1. Type the new network mask.
2. Press TAB to select OK.
3. Press ENTER.

You want to keep the 
existing network mask.

1. Press TAB to accept the current 
network mask and select OK.

2. Press ENTER.

IF DO THIS

You want to change the 
server hostname.

1. Type the new server hostname.
Do not use a fully qualified hostname. 
The server domain name will be 
specified in the next step.

2. Press TAB to select OK.
3. Press ENTER.

You want to keep the 
existing server hostname.

1. Press TAB to accept the existing server 
hostname and select OK.

2. Press ENTER.

IF DO THIS

You want to change the 
server domain name.

1. Type the new server domain name.
2. Press TAB to select OK.
3. Press ENTER.

You want to keep the 
existing server domain 
name.

1. Press TAB to accept the existing server 
domain name and select OK.

2. Press ENTER.
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Network Gateway
Address

The following information appears in your command shell:
Please enter the network gateway address for the system single-node server.

13.Do one of the following:

Primary DNS
Resolver

The following information appears in your command shell:
Please enter the IP address of the primary DNS resolver for the system single-
node server.

14.Do one of the following:

Secondary DNS
Resolver

The following information appears in your command shell:
Please enter the IP address of the secondary DNS resolver for the system single-
node server.

15.Do one of the following:

IF DO THIS

You want to change the 
network gateway address.

1. Type the new network gateway 
address.

2. Press TAB to select OK.
3. Press ENTER.

You want to keep the 
existing network gateway 
address.

1. Press TAB to accept the network 
gateway address and select OK.

2. Press ENTER.

IF DO THIS

You want to change the 
primary DNS resolver IP 
address.

1. Type the new primary DNS resolver IP 
address.

2. Press TAB to select OK.
3. Press ENTER.

You want to keep the 
existing primary DNS 
resolver IP address.

1. Press TAB to accept the primary DNS 
resolver IP address and select OK.

2. Press ENTER.

IF DO THIS

You want to change the 
secondary DNS resolver IP 
address.

1. Type the new secondary DNS resolver 
IP address.

2. Press TAB to select OK.
3. Press ENTER.

You want to keep the 
existing secondary DNS 
resolver IP address.

1. Press TAB to accept the secondary DNS 
resolver IP address and select OK.

2. Press ENTER.
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Review/Confirm
Changes

The following information appears in your command shell:
Accept settings and proceed to fix up the network configurations?
Select Yes to proceed. No to quit. You may re-run "dpnnetutil".

16.Examine the settings shown.

17.Do one of the following:

The dpnnetutil program writes the configuration changes to the
 /usr/local/avamar/probe.xml directory.

NOTE:  Use the nodedb print command to view the con-
tents of probe.xml.

The Avamar server software automatically restarts upon completion of the 
reconfiguration.

18.Check and update as necessary the configurations of the external network 
infrastructure elements (switches and firewalls) to ensure that the single-
node server will remain reachable after it have been assigned new IP 
address or new default network gateway. In particular, VLANs and ACLs 
might need to be updated.

IF DO THIS

You want to accept these 
settings and make these 
changes.

1. Use TAB or cursor keys to select Yes.
2. Press ENTER.

You want to exit 
dpnnetutil without 
making any changes.

1. Use TAB or cursor keys to select No.
2. Press ENTER.
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Adding a Custom Security Notification to Web Login Pages
Avamar Enterprise Manager and the Avamar Web Access features allow you to 
include a custom security notification to users on the their respective login pages. 
These notifications typically notify visitors to these login pages that only 
authorized users of that system are permitted access and explains the penalties of 
unauthorized access.

The actual mechanism for implementing these notifications involves adding the 
following plain-text files to the /usr/local/avamar/var/em/server_data/ directory:

• disclaimer_EM.txt
• disclaimer_Web_Restore.txt

disclaimer_EM.txt stores the custom security notification for the Avamar 
Enterprise Manager login page; disclaimer_Web_Restore.txt stores the custom 
security notification for the Avamar Web Access login page.

To customize security notification language for your site, simply create these files 
in a text editor, add your content and save them to the 
/usr/local/avamar/var/em/server_data/ directory. Either file can contain plain text 
or HTML content.

If you later decide not to display additional security notifications at your site, 
simply remove these files and no security notifications will appear. It is also 
permissible for these files to be empty.
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Manually Updating the Plugin Catalog
Beginning with Avamar 4.1, new clients can be added to an operational Avamar 
system without having to perform a system upgrade. When new clients are added, 
Avamar 4.1 systems automatically update the consolidated plugin catalog.

However, if you add new clients to an Avamar 4.0.x or earlier system, you must 
manually update the consolidated plugin catalog in order for those clients to be 
recognized by the system.

User=admin 1. Open a command shell (page 477).

2. Do one of the following:

3. Go do the directory that contains the existing plugin_catalog.xml and 
rename it by typing: 

cd /usr/local/avamar/lib

mv plugin_catalog.xml plugin_catalog.xml.old

4. Obtain the updated consolidated plugin catalog.

In most cases, EMC Technical Support will provide this for you.

5. Copy the updated consolidated plugin catalog to the /usr/local/avamar/lib 
directory.

6. Ensure that updated plugin_catalog.xml has the correct ownership and 
permissions by typing:

ls -l plugin_catalog.xml

Correct ownership and permissions are:

304 -rw-r--r-- 1 root admin 305578 Jun 3 14:21 plugin_catalog.xml

7. If ownership and permissions are not correct, set them typing:

chmod 644 plugin_catalog.xml

chown root:admin plugin_catalog.xml

8. Stop, then restart the MCS so it reads the updated plugin_catalog.xml by 
typing:

dpnctl stop mcs

dpnctl start mcs

IF DO THIS

Administering a 
single-node server.

Log into the server as user admin.
When prompted for a password, type the admin 
password and press ENTER.

Administering a 
multi-node server.

Log into the utility node as user admin.
When prompted for a password, type the admin 
password and press ENTER.
Load the admin OpenSSH key by typing:
ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.
Type the admin user account passphrase and 
press ENTER.
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CLIENT SYSTEM RECOVERY

This chapter describes how to completely restore a supported Red Hat Linux or 
Sun Solaris client system back to the original system state. 

This publication assumes that a full system recovery is only ever required as part 
of a disaster recovery because the boot hard disk drive or RAID LUN failed. If 
performing a complete system recovery for any other reason, contact EMC 
Technical Support before proceeding.

Windows Client System Recovery
Windows client system recovery is discussed in other publications:

NOTE:  The Avamar 5.0 Windows Client does not support
backup and recovery of Windows 2000. For Windows 2000,
use the Avamar 4.1 Windows Client.

TOPIC PUBLICATION

Windows Server 2008 and 
Windows 7 disaster recovery

Avamar for Windows Servers Guide

Windows Server 2003 disaster 
recovery

Avamar for Windows Servers Guide

Windows Server 2003 System 
Recovery using NT Backup

Restoring Windows Server 2003 System State 
Using NTBackup and Avamar Technical Note

Windows XP and 2000 System 
Recovery using NT Backup

Avamar for Windows Servers Guide
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Red Hat Linux System Recovery
This procedure describes how to completely restore a Red Hat Linux client system 
back to the original system state.

Prerequisites

A complete and recent Avamar backup of the original client local filesystem must 
exist on the Avamar server.

The recovery destination disk must be connected to the recovery target client and 
a minimal installation of a compatible operating system must have been 
performed. For purposes of this procedure, “compatible” means that if the original 
client backup on the Avamar server was performed against an RHEL3 client, then 
RHEL3 should be installed on the recovery target client.

Finally, Avamar Linux Client must be installed on the recovery target client. 

Procedure

1. Boot the recovery target client from the install media (first CD) and type:

linux rescue

An RHEL install prompt appears in your command shell:

2. Follow the on-screen instructions.

Be sure to enable networking by providing IP address, network mask, 
default gateway and DNS server when prompted.

3. Allow the installer to search for existing installations and mount the 
/mnt/sysimage filesystem as read-write.

This will be the target of the restore. This is also referred to as the 
“recovery destination disk.” 

NOTE:  The root filesystem cannot be restored directly to 
/mnt/sysimage because there is currently no method that
will restrict the restore operation to only the local partition
without traversing network mount points. Therefore, a
restore done directly to /mnt/sysimage might copy files from
all the partitions and /mnt/sysimage could fill up before all
required files were restored.

4. Verify that /lib64, /usr/lib64, /mnt/sysimage/lib64 are all present in the 
LD_LIBRARY_PATH system variable. If any directories are missing from 
LD_LIBRARY_PATH, add them to the LD_LIBRARY_PATH variable.
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5. Create a temporary /temp/avamar.cmd flag file with a Unix text editor.

For example:

cd /tmp

vi avamar.cmd

--bindir=/mnt/sysimage/usr/local/avamar/bin
--vardir=/mnt/sysimage/usr/local/avamar/var
--sysdir=/mnt/sysimage/usr/local/avamar/etc
--server=AVAMARSERVER
--account=/DOMAIN/MyClient
--id=USERNAME
--ap=PASSWORD
--overwrite=always
--target=. 

Where AVAMARSERVER is your Avamar server IP address or fully qualified 
hostname (as defined in DNS), /DOMAIN/MyClient is the full location of the 
original Linux client on the Avamar server and USERNAME and PASSWORD 
are the login credentials for a user account with sufficient role and 
privileges to perform the restore operation. 

6. Start Avamar Administrator (page 21).

7. Select Navigation > Backup and Restore or click the 
Backup & Restore launcher button.

The Backup and Restore window appears. 

8. Click the Select for Restore tab.

9. In the Clients tree, select the original Linux client.

10. Find and select the backup you want to use for this restore operation.

Restore Most
Directories

Next, step 11 describes how to restore most of the subdirectories that 
originally existed under root (/). Certain special directories such as /boot, 
/dev and /proc should not be restored in this manner. Also, special 
instructions will be provided later for restoring /usr and /lib, as well as 
individual files in the root (/) directory.

IMPORTANT:  Do not restore /boot, /dev and /proc at this
time. You will be provided special instructions for restoring
these directories later in this procedure.

11. For most of the directories that originally existed under root (/) as follows:

(a) Create an identical directory under the client /mnt/sysimage directory.

For example:

mkdir /mnt/sysimage/data-1

(b) Change directory into that directory.

For example:

cd /mnt/sysimage/data-1

Where data-1 is an example directory you want to restore.
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(c) Restore this directory’s contents from the backup by typing the 
following on a single command line:

/mnt/sysimage/usr/local/avamar/bin/avtar.bin -x
 --flagfile=/tmp/avamar.cmd /data

NOTE:  Space limitations in this publication cause the previ-
ous command example to continue (wrap) to more than one
line. Your command must be typed on a single command line
(no line feeds or returns allowed). 

12.Repeat step 11 for each directory under root (/) you want to restore.

Restore /usr
Directory

Step 13 provides instructions for restoring the /usr directory. Because /usr 
contains files that are actively used by the Avamar Linux Client during this 
procedure, you must manually exclude the 
/mnt/sysimage/usr/local/avamar directory from the command used to 
restore /usr.

13.Restore the /usr directory as follows:

(a) Change directory to /mnt/sysimage/usr by typing.

cd /mnt/sysimage/usr

(b) Restore the contents of /usr, except for /local/avamar, by typing the 
following on a single command line:

/mnt/sysimage/usr/local/avamar/bin/avtar.bin -x
 --flagfile=/tmp/avamar.cmd --exclude='./local/avamar/*'
 /usr

NOTE:  Space limitations in this publication cause the previ-
ous command example to continue (wrap) to more than one
line. Your command must be typed on a single command line
(no line feeds or returns allowed). 

Restore Individual
Files in the Root (/)

Directory

Step 14 provides instructions for restoring individual files in the root (/) 
directory. In order to do this, the --no-recursion option must be 
supplied on the command line.

14.Restore individual files in the root (/) directory as follows:

(a) Change directory to /mnt/sysimage by typing.

cd /mnt/sysimage

(b) Restore the individual files in the root (/) directory by typing the 
following on a single command line:

/mnt/sysimage/usr/local/avamar/bin/avtar.bin -x
 --flagfile=/tmp/avamar.cmd --no-recursion /

NOTE:  Space limitations in this publication cause the previ-
ous command example to continue (wrap) to more than one
line. Your command must be typed on a single command line
(no line feeds or returns allowed). 
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Restore /lib
Directory

Step 15 provides instructions for restoring the /lib directory. Because /lib 
contains files that are actively used by the Avamar Linux Client during this 
procedure, you must create another director (for example, 
/mnt/sysimage/libcopy) and restore files there. After the files are restored, 
you can delete /mnt/sysimage/lib and rename /mnt/sysimage/libcopy to 
/mnt/sysimage/lib. 

15.Restore the /lib directory as follows:

(a) Change directory to /mnt/sysimage by typing.

cd /mnt/sysimage

(b) Create the libcopy directory by typing:

mkdir libcopy

(c) Change directory to /mnt/sysimage/libcopy by typing.

cd libcopy

(d) Restore the contents of /lib to /mnt/sysimage/libcopy by typing the 
following on a single command line:

/mnt/sysimage/usr/local/avamar/bin/avtar.bin -x
 --flagfile=/tmp/avamar.cmd /lib

NOTE:  Space limitations in this publication cause the previ-
ous command example to continue (wrap) to more than one
line. Your command must be typed on a single command line
(no line feeds or returns allowed). 

(e) Change directory to /mnt/sysimage by typing.

cd /mnt/sysimage

(f) Delete /mnt/sysimage/lib by typing:

rm -rf ./lib

(g) Rename /mnt/sysimage/libcopy to /mnt/sysimage/lib by typing:

mv ./libcopy ./lib

16. Inspect /mnt/sysimage/etc/fstab and verify that there are valid statements 
for each filesystem to be mounted on the new system. 

17.Exit out the shell. 

The system will reboot itself. Eject the CD and boot normally. 

18.Confirm correct client operation.
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Sun Solaris System Recovery
This procedure describes how to completely restore a Sun Solaris client system 
back to the original system state.

Prerequisites

A complete Avamar backup of the local filesystems exists on the Avamar server.

The destination disk for the restore is connected to the Solaris system and a 
mountable root partition filesystem has been created.

The old /var and /opt filesystems exist and can be mounted. If /var or /opt are not 
already available, use the CDROM to install a minimal version of Solaris on the 
disk.

Procedure

1. Boot from CDROM by typing:

reboot -- cdrom

2. Proceed through the various prompts; provide hostname, IP address, 
default gateway and DNS server when prompted.

3. At the Solaris Web Start will assist you in installing software 
for Solaris (! to quit) prompt, press ! to go to a shell prompt.

4. Do one of the following:

5. Mount the old / partition under /a by typing:

mount /dev/dsk/c1t0d0s0 /a

Use the correct site-specific disk partition and mount parameters for the 
root volume.

This will be the target of the restore.

6. Mount the old /opt partition under /opt by typing:

mount /dev/dsk/c1t0d0s5 /opt

Use the correct site-specific disk partition and mount parameters for the 
/opt volume.

IF DO THIS

Restoring a Solaris 8 system. Skip this step and go directly to step 5.

Restoring a Solaris 10 system. After entering your DNS entries, select 
either option 3 Solaris Interactive 
Text (Desktop session) or option 4 
Solaris Interactive Text (Console 
session).
Press F5 to exit.
When prompted, press F2 to confirm 
exit and return to a shell prompt.
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7. Mount the old /var partition should be mounted under /var by typing:

mount /dev/dsk/c1t0d0s4 /var

Use the correct site-specific disk partition and mount parameters for the 
/var volume.

This is so that pkgadd and pkgrm will not quit with errors such as 
nonexistent admin file or bad device (/var/sadm/pkg) specified.

8. If Avamar client software exists in /opt/AVMRclnt, you must install it.

Refer to your Avamar Backup Clients User Guide for specific instructions 
about how to install the Avamar Solaris Client.

NOTE:  The installation program will display a warning about
root (/) having 0 free bytes, as well as errors related to
read-only filesystems when trying to create /etc/init.d/ava-
gent and various links in /usr/bin and /etc/rc.d/rcX.d. How-
ever, despite these warnings, all the binaries are correctly
installed in /opt/AVMRclnt/bin.

The root filesystem cannot be restored directly to /a, because there is 
currently no option that will restrict the restore operation to only the local 
partition without traversing network mount points. A restore done directly 
to /a might copy files from all the partitions and /a could fill up before all 
required files were restored. 

9. Restore /etc to /a/etc by typing:

mkdir /a/etc; cd /a/etc

/opt/AVMRclnt/bin/avtar -x --server=dpn61 --id=root
 --password=*** --account=/clients/soldev1 --target=. /etc

10. Inspect /a/etc/vfstab to verify the original mount points for the local 
filesystem; eliminate these mount points from the list of directories that 
will be restored.

11.Run Avamar Administrator and connect to the Avamar server; browse the 
backup of the Solaris server to see the directories and files that originally 
existed under /.

For each directory that originally existed under / and needs to be restored, 
create the directory (if needed) under /a, then cd into that directory and 
restore its contents from the backup. Example for /dev:

mkdir /a/dev; cd /a/dev

/opt/AVMRclnt/bin/avtar -x --server=dpn61 --id=root
 --password=*** --account=/clients/soldev1 -restoresystem
 --target=. /dev

Use correct values for the --server, --password and --account options in 
order to log into the server.

The --overwrite=always option forces existing files to be overwritten and 
the --restoresystem option causes system files, such as devices and 
named-pipes, to be restored.

12.Reboot the system normally and confirm correct operation.
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This chapter discusses how to use replication to completely migrate all data 
residing on a source Avamar server to a new destination server, as well as how to 
migrate backup clients to the new (destination) server.

Important Terms and Concepts

System Migration. System migrations are planned operations that permanently 
move (migrate) all backup clients and all backup data from one system to another. 
This is accomplished by performing a full “root-to-root” replication of all data 
residing on a source Avamar server to a new destination server. Full “root-to-root” 
replications preserve the domain structure, policy objects (for example, datasets, 
schedules, retention policies), as well as backup activity and system event 
databases.

Global Client IDs. In order to facilitate seamless client migration from one 
Avamar server to another, Avamar 3.5.0 and later servers implement a feature 
called a global client ID (global CID). Global CIDs are completely unique Avamar 
backup client identifiers across all Avamar servers.

On Avamar 3.5.0 through 3.6 systems, global CIDs are an optional feature that is 
only enabled if --failover is supplied on the replicate command line. On 
Avamar 3.7 and later systems, global CIDs are the default.

While it is possible to perform server migrations on pre-3.5.0 servers, the 
procedure is more involved because all clients must reregister with the destination 
server.

During system migrations, if global client IDs (global CIDs) are used at your site 
and if the destination server can assume the same DNS name or IP address as the 
original source server, clients that formerly backed up to the source server can 
continue to operate transparently without reregistering with the new destination 
server.
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Client Migrations. Client migrations are typically un-planned operations, 
usually performed when a source server experiences a serious problem that 
compromises its operational effectiveness. A client migration simply forces a 
reregistration and activation of any source server backup client with a new 
(destination) server. This will allow them to continue protecting their data.

Furthermore, if regular normal replications had been occurring between the 
source and destination servers, old backups will be present in the special 
REPLICATE domain.

However, it must be understood, that as far as the Avamar server is concerned, 
there is no correlation whatsoever between a client account within the REPLICATE 
domain and any new account that might be created as the result of registering 
and activating with the new (destination) server.
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Capabilities and Limitations

IMPORTANT:  If you successfully replicate data from a
source Avamar server to a destination server and you subse-
quently roll the destination server back to a point in time
before that replication, all replicated data will be perma-
nently lost.

Therefore, EMC Corporation strongly recommends that,
immediately following any successful replication, you create
(page 352) and validate (page 353) a destination server
checkpoint so that you will have a reliable server rollback
point that includes all replicated data.

Source and Destination Servers Should Be Comparable Sizes. For best 
results, the destination Avamar server should be the same size or larger than the 
source server.

Server Software Compatibility. When migrating systems, you must migrate 
the source server to the same or later Avamar software version.

IMPORTANT:  Do not migrate a source server to an older
destination server because this might cause an unexpected
loss of data due to server software incompatibilities.

Migrating a source server to the same or later Avamar software version also 
ensures that backup clients will function properly due to backward compatibility. 

If Possible, Register Backup Clients Via Avamar Server DNS Name, Not IP
Address. The typical practice at most sites is for all Avamar backup clients to 

register with the Avamar server by resolving a DNS name to the server IP 
address. This is usually done to simplify the registration process so that backup 
users do not have to know an actual IP address in order to register their clients. 

However, the practice of allowing client communication with an Avamar server by 
resolving the server DNS name provides an additional benefit: should it ever 
become necessary to migrate data on that source server to a new destination 
server, you simply have to take the old source server off the network, change the 
new destination server DNS name to the old source server DNS name and backup 
clients will be able to seamlessly transition to the new destination server. 
Otherwise, if backup clients communicate with the Avamar server by way of an IP 
address, clients must manually reregister with the new destination server once it 
is deployed on the network.
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Migrating Avamar Servers
This procedure describes how to migrate an Avamar source server to a new 
destination server. 

This procedure supports any version source server as long as the following 
functional differences are understood:

If migrating an Avamar 3.7 or later source server, global CIDs are enabled by 
default. Once the new destination server is online and has assumed the DNS 
name or IP address of the source server, clients that were formerly registered 
with the source server will be able to communicate with the new destination 
server.

If migrating an Avamar 3.5.0 through 3.6 source server, you should include 
the 
--failover option on your replicate command line. If you do not, you must 
manually migrate your backup clients to the new server (page 400).

If migrating an Avamar 3.0.1 or older system, global CIDs are not available. 
Therefore, you must manually migrate your backup clients to the new server 
(page 400). 

This procedure assumes the following conditions:

• Both source and destination servers are fully operational and will be online at 
the beginning of the server migration operation

• All source server clients were registered using the server hostname (not the 
source server IP address)

• Source and destination servers have different hostnames at the beginning of 
the operation; the destination server hostname will be changed to match the 
source server near the end of the operation

Replicate Source Server

User=admin 1. Open a command shell (page 477) on the source server.

2. Do one of the following:

3. Load the admin OpenSSH key by typing:

ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.

4. Type the admin user account passphrase and press ENTER.

IF DO THIS

Source server is a 
single-node server.

Log into the server 
as user admin.

Source server is a 
multi-node server.

Log into the utility 
node as user admin.
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Flush Source MCS 5. On the source server, flush the MCS by typing:

mcserver.sh --flush

This ensures that all cached MCS data (for example, account information, 
logs and so forth) is saved to the MCS database.

Initiate Full “Root-
To-Root”

Replication

6. On the source server, initiate a full “root-to-root” replication to the 
destination server by doing one of the following:

Where SRC-ROOT-PASSWORD and DST-ROOT-PASSWORD are the source 
and destination Avamar root passwords, respectively.

NOTE:  The only difference between the two previous com-
mands is supplying the --failover option on Avamar 3.5.0
through 3.6 servers in order to force use of optional global
CIDs.

7. Wait for this replication operation to complete before proceeding any 
further.

8. Perform a full system shutdown of the source server (page 287).

Restore Data on Destination Server

User=admin 1. Open a command shell (page 477) on the destination server.

2. Do one of the following:

IF DO THIS

Your server is 
running Avamar 
3.7 or later 
software

Type:
replicate --dstaddr=DST --dstid=root
 --dstpassword=DST-ROOT-PASSWORD --id=root
 --ap=SRC-ROOT-PASSWORD --fullcopy

Your server is 
running Avamar 
3.5.0 through 
3.6 software

Type:
replicate --dstaddr=DST --dstid=root
 --dstpassword=DST-ROOT-PASSWORD --id=root
 --ap=SRC-ROOT-PASSWORD --fullcopy --failover

Your server is 
running Avamar 
3.0.1 or older 
software

Type:
replicate --dstaddr=DST --dstid=root
 --dstpassword=DST-ROOT-PASSWORD --id=root
 --ap=SRC-ROOT-PASSWORD --fullcopy

IF DO THIS

Destination server is a 
single-node server.

Log into the server 
as user admin.

Destination server is a 
multi-node server.

Log into the utility 
node as user admin.
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3. Load the admin OpenSSH key by typing:

ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.

4. Type the admin user account passphrase and press ENTER.

Stop Destination
MCS

5. On the destination server, stop the MCS by typing:

dpnctl stop mcs

The following information appears in your command shell:
Do you want to proceed with the stop Y/N? [Y]: y

6. Type y and press ENTER.

The following information appears in your command shell:
MCS shutdown initiated.
Stopping MCS...
MCS stopped.
Stopping the database server.
Database server stopped.

Perform New-
System Restore

7. On the destination server, perform a new-system restore by typing:

mcserver.sh --restore --restoretype=new-system

The following information appears in your command shell:
=== BEGIN === check.mcs (prerestore)
check.mcs passed
=== PASS === check.mcs PASSED OVERALL (preavsetup)
--restore will modify your MCS database and preferences.
Do you want to proceed with the restore Y/N? [Y]:

8. Type y and press ENTER.

The following appears in the command shell:

Database server stopped.
removing data dir /usr/local/avamar/var/mc/server_data
creating /usr/local/avamar/var/mc/server_data with permissions 0755
creating /usr/local/avamar/var/mc/server_data/prefs with permissions 0755
creating /usr/local/avamar/var/mc/server_data/postgres with permissions 0700
creating /usr/local/avamar/var/mc/server_data/postgres/data with permissions 

0755
Enter the Avamar Server IP address or fully-qualified domain name to restore 
from (i.e. dpn.your_company.com): 

9. Type your fully qualified Avamar destination server name or IP address and 
press ENTER.

avamar-2.example.com is used as an example fully qualified Avamar 
destination server name for the remainder of this procedure.

10. Press ENTER.

The following appears in the command shell:

Enter the Avamar Server IP port to restore from [27000]:

11. Press ENTER to accept the default port.

The following appears in the command shell:

Using port '27000'.
Enter password for MCUser:
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12.Type the password for the MCUser administrative user account and press 
ENTER.

The following appears in the command shell:

Select the Avamar server IP address or fully-qualified hostname to be used by 
backup clients:
1) DESTINATION_SERVER.avamar.com
2) SOURCE_SERVER.avamar.com
3) Enter another address

Enter your selection(1-3):

13.Type 1 and press ENTER.

The following appears in the command shell:

Enter the Avamar server accounting system root user password for Avamar server:

14.Type your Avamar server software root user password and press ENTER.

The following appears in the command shell:

Performing restore administrative tasks...
Restore administrative tasks complete.

Start Destination
MCS

15.On the destination server, start the MCS by typing:

dpnctl start mcs

Update DNS

Update your DNS server to redirect the original source hostname to the new 
destination server IP address.

All data replicated from the source server has been moved and restored to the 
new destination server. 

If the new destination server is running Avamar 3.5 or later software, all 
clients that were formerly registered with the source server now communicate 
with the new destination server. 

If the new destination server running Avamar 3.0.1 or older software, you 
must manually migrate your backup clients to the new server (page 400).
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Manually Migrating Backup Clients to a New Server
When a source server experiences a serious problem that compromises its 
operational effectiveness, you can force a registration and activation of any source 
server backup clients with new (destination) server. This will allow them to 
continue protecting their data.

Furthermore, if regular normal replications had been occurring between the 
source and destination servers, old backups will be present in the special 
REPLICATE domain.

However, it must be understood, that as far as the Avamar server is concerned, 
there is no correlation whatsoever between a client account within the REPLICATE 
domain and any new account that might be created as the result of registering 
and activating with the new (destination) server.

Migrating Pageable Clients

A client is “pageable” when it is persistently connected to the same network as the 
Avamar server. A pageable client can be registered and activated using any other 
methods described earlier in this publication. Refer to Domains, Clients and Users 
(page 33) for additional information.

Migrating Non-Pageable Clients

A client is considered “non-pageable” when it is disconnected the same network as 
the Avamar server or using Network Address Translation (NAT). 

If you want to migrate a non-pageable client to the new server, perform the 
following while it is disconnected from the network:

1. Erase the contents of the client CID.bin file.

2. Edit avagent.cfg to change mcsaddr=SOURCE-SERVER to 
mcsaddr=DESTINATION-SERVER.

3. Restart the Avamar client and agent applications to initiate registration 
with the new destination server.
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Avamar Activation Manager provides a centralized way to activate a large number 
of newly installed Avamar clients with a specific Avamar server, domain, and 
group. 

The Avamar Activation Manager software provides a web browser interface 
through which an Avamar administrator can:

• View deployed Avamar servers, domains, and groups
• Obtain domain information about computers from LDAP-like directory services, 

such as Active Directory
• Obtain information about a domain’s computers by importing a CSV file
• Assign Avamar clients to Avamar servers, domains, and groups
• Initiate registration and activation of Avamar clients

The installation of Avamar client on enterprise desktops and laptops, and other 
supported computers, can be silently pushed using many of the popular Systems 
management products or can be run from each client.

Avamar Activation Manager populates its list of clients available for assignment 
and activation using a post-install list of clients obtained from the Systems 
management tool, or by querying a directory service.

When information about the association of individual clients with operational units 
can be obtained from the directory service, clients are shown in the client list 
nested beneath their associated operational units.

Using Avamar Activation Manager, an Avamar administrator can drag and drop 
clients into specific Avamar domains and groups, and initiate their registration and 
activation. Avamar Activation Manager provides a log that shows the status of 
each assignment and activation.
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Workflow Overview
The flow of tasks for using Avamar Activation Manager can be separated into two 
divisions:

• Preparing to use Avamar Activation Manager (page 402)
• Using Avamar Activation Manager (page 402)

Preparing to use Avamar Activation Manager

Complete the following tasks before using Avamar Activation Manager:

• Meet the environment requirements listed in Environment (page 403).
• Configure Avamar Activation Manager to use your company’s directory service 

as described in Configure Kerberos Realms Information (page 407). This step 
is not required if you plan to import a list of clients as described in Import 
Client List (page 415).

• Add all Avamar servers that you will use with Avamar Activation Manager to 
the Avamar Enterprise Manager database. This process is described in 
Configure (page 315).

• Determine the Avamar domains you will use and decide which clients will be 
assigned to each domain.

• Decide on the groups you will need in each of your Avamar domains, and 
create them. This process is described in Groups and Group Policies (page 
128). Groups can also be created as you need them as described in Creating 
New Groups (page 437).

• Install the Avamar client software on the client computers. Remote Push 
Install of the Client Software (page 408) provides information about this task.

Using Avamar Activation Manager

The workflow for using Avamar Activation Manager to register and activate 
Avamar client on your enterprise’s computers is:

• Familiarize yourself with the Avamar Activation Manager UI using the 
description in The Avamar Activation Manager UI (page 418).

• Select a client data source using the steps in Client Data Source (page 413).
• Activate clients following the procedures in Activating Clients (page 424).

Other tasks you can perform using Avamar Activation Manager:

• Create new groups of clients using the techniques described in Creating New 
Groups (page 437).

• Move clients between Avamar servers using the procedure in Moving Clients to 
a Different Avamar server (page 439).

• Check Avamar Activation Manager activity status by reviewing the log, as 
described in Avamar Activation Manager Log (page 443).
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This section lists the requirements for Avamar Activation Manager.

Network

Networks that meet the following requirements are supported by this solution:

Directory Service Domain

Directory service domains that meet the following requirements are supported by 
this solution:

CATEGORY REQUIREMENT

Protocol TCP/IP.

Routers Must permit TCP packet routing between the Avamar server 
and each client computer.

Firewalls Must allow bidirectional communication between the Avamar 
server and each client computer using TCP data ports 7778, 
27000, 28001, 28002, and 29000.

Naming System Must facilitate connections between each client and the 
Avamar server, including situations where IP address 
changes are caused by DHCP and VPN access.

CATEGORY REQUIREMENT

Directory Service LDAP-compliant services, such as: Microsoft’s Active 
Directory.
NOTE:  A directory service is only required when 
using Avamar Activation Manager without an 
imported client list.

Naming Scheme Each label in a client’s FQDN must be less than 63 
characters and each FQDN must not exceed 255 
characters, including dots. Clients that exceed these 
requirements cannot be activated using Avamar 
Activation Manager. These clients will be listed in the 
Avamar Activation Manager log.
Hostnames and organization unit names cannot 
contain the forward slash character (’/’). Avamar 
Activation Manager uses this character to separate the 
hierarchical levels of a directory service.
NOTE:  Some directory services, such as Microsoft’s 
Active Directory, allow the forward slash (‘/’) 
character to be used as part of a computer or 
organizational unit. To avoid the display of inaccurate 
directory information in the Avamar Activation 
Manager UI, rename any computers and 
organizational units that use this character before 
using the Query Directory Service function.
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Avamar System

Avamar systems that meet the following requirements are supported by this 
solution:

Avamar Administrative Account

An Avamar administrator whose domain and Avamar accounts meet the following 
requirements can perform the tasks described in this guide:

Systems Management • Microsoft System Center Configuration Manager
• IBM Tivoli Management Framework
• HP OpenView ServiceCenter

NOTE:  While a systems management tool vastly 
simplifies the task of installing Avamar Desktop/
Laptop software on client computers, it is only 
required when you want to use Avamar Activation 
Manager with a client list that contains only clients 
with the software installed.

CATEGORY REQUIREMENT

Avamar servers Must be listed in the Avamar 
Enterprise Manager database.

Avamar server software Version 5.0

Avamar Enterprise Manager Version 5.0

Avamar client Version 5.0 and later

Avamar Desktop/Laptop Version 5.0.105

CATEGORY REQUIREMENT

Domain Domain administrator rights.

Directory service Read right.

Avamar system Avamar administrator rights, including 
access to Avamar Enterprise Manager.

CATEGORY REQUIREMENT
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Administrator’s Computer

An Avamar administrator’s computer that meets the following requirements can 
perform the tasks described in this guide:

CATEGORY REQUIREMENT

OS Windows.

Web Browser • Windows Internet Explorer versions 7.x.x and 8.x.x
• Mozilla Firefox 3.x.x

NOTE:  To avoid long-running JavaScript warnings 
following the instructions specific to your browser in 
Preventing Long-Running JavaScript Warnings (page 
406).

Adobe Acrobat 
Reader

7.0 or later. Available from www.adobe.com.
Optional. Required in order to view documentation.
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Preventing Long-Running JavaScript Warnings

The Avamar Activation Manager UI uses JavaScript scripts to perform many of its 
tasks. Sometimes an Avamar Activation Manager UI script will require more time 
to finish than is permitted by a web browser’s script timeout default value.

When this happens a message appears and the script is stopped. You can click 
continue to allow the script to finish its work.

To avoid seeing this message, increase the timeout period as described in the 
following, browser-specific, sections.

Internet Explorer

To increase the timeout period for Internet Explorer:

1. Open a registry editor, such as Regedt32.exe.

2. Open the key:

HKEY_CURRENT_USER\Software\Microsoft\InternetExplorer\Styles

If the key does not exist, create it.

3. Create a new DWORD value called "MaxScriptStatements" under this key.

4. Set the value of the DWORD to 20,000,000.

This number represents the number of script statements. 

5. Restart the browser.

Firefox

To increase the timeout period for Firefox:

1. In the browser address bar, type:

about:config

The about:config warning appears.

2. Click I’ll be careful, I promise!

The Preferences window opens.

3. In Filter, type:

dom.max_script_run_time

The script run time preference appears.

4. Double-click the preference.

The Enter integer value dialog box appears.

5. Type 30 and click OK.

6. Restart the browser.
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Configure Kerberos Realms Information
Before using Query Directory Service, configure Avamar Activation Manager with 
the Kerberos realms of your organization. This permits Avamar Activation Manager 
to work with your organization’s directory service. To configure Kerberos realm 
information for your organization, complete the steps described for configuring the 
Avamar Desktop/Laptop server in Configure Kerberos Realms Information (page 
456).

NOTE:  Avamar Activation Manager and Avamar Desktop/
Laptop use the same LDAP configuration information.

The values set in ldap.properties during this configuration process are used on the 
Query Directory Service screen in the User Domain and Directory Domain field list 
boxes, as described in Query Directory Service (page 413).
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Remote Push Install of the Client Software
This section describes installing the Avamar client software on large numbers of 
computers using a Systems management tool.

NOTE:  The Avamar client software can also be installed by
running the installer locally on each computer. This method
is described in the Avamar Backup Clients User Guide.

Systems Management Tools

The recommended method for installing the Avamar client software on large 
numbers of computers is to use a Systems management tool. When you use a 
Systems management tool you can remotely push install the software on large 
numbers of computers in a short amount of time.

Also, a Systems management tool can often generate a list of the computers that 
have the software successfully installed. This list can be used when you assign 
computers to groups as described in Activating Clients (page 424).

Remote installation on Windows computers has been tested and approved using 
Microsoft’s Systems Management Server 2003 (SMS). For Mac computers, remote 
installation has been tested and approved using SMS with Quest Software’s Quest 
Management Xtensions for SMS. In addition, other Systems management tools 
may work using the steps outlined in the following sections.

Examples of other Systems management tools that might work to install the 
Avamar client software are:

• Microsoft’s System Center Configuration Manager 2007
• IBM’s Tivoli Management Framework
• HP’s OpenView ServiceCenter
• Symantec's Altiris
• Apple’s Remote Desktop

Systems management tools vary. The steps required to push software to a set of 
computers depend upon the tool you are using. Consult the documentation for 
your tool to determine the exact steps required to perform these tasks.
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Push Install on Windows Computers

The Avamar client software can be push installed on supported Windows 
computers.

To push install Avamar client on supported Windows computers:

1. Copy the Avamar client for Windows installer package to a location that is 
accessible to your Systems management tool.

2. Configure the Systems management tool to copy the correct installer 
package to each computer.

3. Designate the set of computers on which the software will be installed.

4. Provide the installation launch command, selecting the appropriate 
command from the choices in Installer Package Commands for Windows 
Computers (page 409).

5. Launch the Systems management tool’s installation process.

Installer Package Commands for Windows Computers

The installer package accepts the following commands, where 
path_to_MSI_pkg is the full path to the location of the installer package 
relative to the root of the computer’s file system:

• msiexec /qn /I "path_to_MSI_pkg" WORKSTATION=1

This command installs the Avamar client software and enables the Avamar 
Desktop/Laptop interface.

• msiexec /qn /I "path_to_MSI_pkg" WORKSTATION=0

This command installs the Avamar client software but does not enable the 
Avamar Desktop/Laptop interface. The basic Avamar interface is enabled 
instead.

• msiexec /qn /I "path_to_MSI_pkg"

This command acts the same as WORKSTATION=0 and enables the basic 
Avamar interface.

• msiexec /qn /I "path_to_MSI_pkg" UICOMPONENT=0

This command enables Avamar as an agent process with no user interface.
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Push Install on Mac Computers

The Avamar client software can be push installed on supported Mac computers. 
The installation process requires the file dtlt.xml only when the Avamar Desktop/
Laptop features are being installed.

Avamar Desktop/Laptop XML Installation File

The file dtlt.xml is used to enable Avamar Desktop/Laptop during a remote 
push install of Avamar client on a Mac. This file is included when you receive 
the Avamar client installer package. If it is not available, it can easily be 
created.

To create dtlt.xml:

1. Open a new file in a plain text editor.

2. Add the following lines to the file:

<array>

<string>PKG_REF_2</string>

</array>

3. Save the file as dtlt.xml, and close the editor.

Avamar Client with Avamar Desktop/Laptop

In general, to push install Avamar client with Avamar Desktop/Laptop on 
supported Mac computers:

1. Copy the Avamar client for Mac installer package to a location that is 
accessible to your Systems management tool.

2. Copy dtlt.xml to the same location.

3. In your Systems management tool, set the location of the installer package 
and dtlt.xml as the source location.

Configure the Systems management tool to copy the installer package and 
dtlt.xml to each computer. The copy location of these files is the value of 
the path_to_install_package variable described in step 5. 

4. Designate the set of computers on which the software will be installed.

5. Provide the basic installation launch command:

/usr/sbin/installer -applyChoiceChangesXML "dtlt.xml" -pkg 
"path_to_MSI_pkg" -target install_location

NOTE:  Run this command on a single line; without the line
break that is caused by the formatting of this guide.

Where path_to_MSI_pkg is the full path to the location of the installer 
package relative to the root of the computer’s file system and 
install_location is where you want the software installed.

Normally, install_location is the root (/) but any local volume is allowed.

6. Launch the Systems management tool’s installation process.
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Avamar Client without Avamar Desktop/Laptop

In general, to push install Avamar client without Avamar Desktop/Laptop on 
supported Mac computers:

1. Copy the Avamar client for Mac installer package to a location that is 
accessible to your Systems management tool.

2. In your Systems management tool, set the location of the installer package 
as the source location.

Configure the Systems management tool to copy the installer package to 
each computer. The copy location of this file is the value of the 
path_to_MSI_pkg variable described in step 4.

3. Designate the set of computers on which the software will be installed.

4. Provide the basic installation launch command:

/usr/sbin/installer -pkg "path_to_MSI_pkg" -target 
install_location

where path_to_MSI_pkg is the full path to the location of the installer 
package relative to the root of the computer’s file system and 
install_location is where you want the software installed. Normally, 
install_location is the root (/) but any local volume is allowed.

5. Launch the Systems management tool’s installation process.

Post-Installation Restart

After installation of Avamar client for Mac (with or without Avamar Desktop/
Laptop) a restart of some clients may be required. This is caused by a change to 
the process data size setting that is made on those computers.

During installation, the installer determines if the process data size is set to less 
than 96 MB. A minimum process data size of 96 MB is required for optimal 
performance of Avamar client for Mac.

If the process data size is less than 96 MB, the installer changes it to 96 MB and 
displays a restart reminder. 

If neither button is clicked within 30 seconds, the reminder is hidden and 
displayed again in 2 hours.

Clicking Not Now causes the reminder to hide for 2 hours and then appear again.

Clicking Restart restarts the computer and completes the process data size 
change. If Restart is clicked but the restart process is stopped for any reason, the 
reminder will not appear again. 
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Uninstalling

OS-specific uninstallation mechanisms are used to remove Avamar client and the 
Avamar Desktop/Laptop software.

Uninstall on Windows

To uninstall Avamar client and the Avamar Desktop/Laptop software from a 
Windows computer:

1. Open the Windows Add or Remove Programs applet.

2. On the list of currently installed programs, select EMC Avamar for 
Windows, and click Remove.

3. On the confirmation messages, click Yes.

The software is uninstalled.

Uninstall on Mac

To uninstall Avamar client and the Avamar Desktop/Laptop software from a 
Mac computer:

1. Open a Terminal (shell) session.

2. Log in as an administrator.

The uninstall command requires root (super-user) permissions. Sudo is 
used to run the command with root permissions. An administrator account 
or another account listed in sudoers is required by sudo.

3. Run the uninstall script:

sudo /usr/local/avamar/bin/avuninstall.sh

The software is uninstalled.
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Starting Avamar Activation Manager 
Start the Avamar Activation Manager UI from Avamar Enterprise Manager by 
clicking Activation Manager.

The Client Data Source screen appears. Client Data Source (page 413) describes 
this screen in detail.

Client Data Source
The Client Data Source screen provides two choices that determine the source for 
the client data required by Avamar Activation Manager:

• Query Directory Service (page 413)
• Import Client List (page 415)

Query Directory Service

When you use Query Directory Service, your enterprise’s directory service is 
queried to obtain information about clients and, if available, directory service 
organizational units, such as domains, sub-domains, and groups.
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IMPORTANT:  Before using Query Directory Service, com-
plete the steps in Configure Kerberos Realms Information
(page 407).

To use Query Directory Service:

1. Start Avamar Activation Manager.

This is described in Starting Avamar Activation Manager (page 413).

2. On the Client Data Source screen, select Query Directory Service.

The Directory Service Authentication section appears.

The Directory Service Authentication section has four fields.

3. In User Domain, select the Kerberos realm to use for authentication of 
your user account information.

4. In Username, type the username for the account to use to query the 
directory service.

FIELD DESCRIPTION

User Domain The Kerberos realm used to authenticate the account 
specified by Username. This list box receives its 
values from ldap.properties.

Username Username of an account that is authorized to read 
the directory service’s database.

Password Password associated with the username.

Directory Domain The Kerberos realm that is polled for the client and 
organizational unit information displayed in the 
Directory Information section of the main Avamar 
Activation Manager window. This list box receives its 
values from ldap.properties.
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5. In Password, type the password for the account.

6. In Directory Domain, select the Kerberos realm to query for client and 
organizational unit information.

7. Click Continue.

The account information is verified, the directory domain is polled for client 
and organizational unit information, the Avamar server is polled for Avamar 
domain and group information, and the UI appears, populated with this 
information.

Import Client List

As an alternative to using your enterprise’s directory service to provide client 
information, you can import a client list file. The client list file is a plain text, 
comma separated value (CSV), file containing at least one and at most two values 
for each client:

• (Required) Fully qualified domain name (FQDN)
• (Optional) Directory service logical group name; in LDAP and Active Directory, 

this is the client’s organization unit (OU)

NOTE:  Use UTF-8 encoding when importing a client list file
that includes non-ASCII characters in the names of organi-
zational units. This ensures correct display of those elements
in the Avamar Activation Manager UI.

The client list file method is particularly useful when you combine it with output 
from a Systems management tool’s installation of the Avamar client software.

After an installation run, many Systems management tools can be configured to 
output a CSV file containing the required values. When this file is imported into 
Avamar Activation Manager, all clients listed in the Organization Units section will 
already have the Avamar client software installed.

The second value, the directory service logical group name, is optional. If it is not 
provided, the client is listed at the root level of the hierarchical display.
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A correctly formatted client list file looks like the following example.

Hostname,Group

User1-desktop.Acme.corp.com,acme.corp/USA/MA

User1-laptop.Acme.corp.com,acme.corp/USA/CA/SFO

User2-desktop.Acme.corp.com,acme.corp/Engineering

User3-desktop.Acme.corp.com,

User4-desktop.Acme.corp.com,

A forward slash ('/') is used to separate the hierarchical levels of the directory 
service logical group name.

In the following example numbers have been added to the previous client list for 
reference purposes.

Line 1 lists the header names for each value. The first header value is 
"Hostname", the second is "Group". The values are separated by a comma. Line 1 
can be left blank, but to make the file more accessible to others it is recommended 
that the headers be provided as shown. 

IMPORTANT:  Line 1 must contain the header names as
shown, or a blank line; otherwise import will fail with the fol-
lowing message: "Invalid file or invalid format".

Line 2 contains the hostname "User1-desktop.Acme.corp.com", the separating 
comma, and the group "acme.corp/USA/MA".

Line 3 contains the hostname "User1-laptop.Acme.corp.com", the separating 
comma, and the group "acme.corp/USA/CA/SFO".

Line 4 contains the hostname "User2-desktop.Acme.corp.com", the separating 
comma, and the group "acme.corp/Engineering".

Line 5 and 6 contain only the hostnames "User3-desktop.Acme.corp.com" and 
"User4-desktop.Acme.corp.com", each followed by a comma. The comma is 
required, even when a group is not listed. Since a group is not listed, both 
hostnames will be displayed at the root level of the hierarchical display.
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NOTE:  If you use spreadsheet software such as Microsoft
Excel to create or edit the client list, do not add a comma to
the end of the first cell or the beginning of the second cell to
create comma separated values. Adding a comma is not nec-
essary because when you save the client list as a CSV file-
type, the software adds the comma separators as part of the
file conversion process. To double-check that the client list is
correctly formatted, open it in a plain text editor.

To use a client list file as the data source:

1. Select Import Client List.

2. Click Browse, find the file, and select it.

The client list file must be available on the computer that is running the 
Avamar Activation Manager web browser UI.

3. Click Continue.

The client list file is imported, the Avamar server is polled for Avamar 
domain and group information, and the UI appears, populated with this 
information.

The UI pictured shows the result of importing the client list from the 
previous example.
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The Avamar Activation Manager UI
The elements of the Avamar Activation Manager UI are described in:

• Directory Information (page 419)
• Group Assignments (page 420)
• Avamar Server Information (page 421)
• Directory Details (page 421)
• Controls (page 422)
• Session Timeout (page 423)
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Directory Information

The Directory Information section uses a familiar hierarchical tree view to display 
clients within their directory service groups.

A folder icon represents each level of the directory hierarchy and the following 
icons are used to represent clients and client state:

 Client that has not been selected to be registered or activated 

 Client that is selected for registration

 Invited client that has not responded

 Client that is fully registered and activated

 Client that failed activation

NOTE:  Clients in the Default Proxy Group are not displayed
in Avamar Activation Manager.

Directory Information Search. The Directory Information section has an 
integrated search tool. Located above the Directory Information section, this tool 
can be used to search the Directory Information section for a computer with a 
specific name or several computers with similar names.

Searching for Clients to Activate (page 425) describes how to use Directory 
Information search.
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Group Assignments

Information about each Avamar server’s hierarchical relationships of domains, 
subdomains, groups, and clients is provided in the Group Assignments section. 
The information in this section is obtained from all Avamar servers that can be 
reached by Avamar Activation Manager.

NOTE:  The Group Assignments section does not display the
following Avamar domains: MC_DELETE, MC_RETIRED, and
REPLICATE.

The Group Assignments section is the active work area of Avamar Activation 
Manager. Clients are assigned to a domain and group and registered/activated by 
dragging their icon from the Directory Information section and dropping them in a 
group in this section.

The following icons are used in the Group Assignments section:

 Avamar server

 Avamar server domain or subdomain

 Avamar server group

 Client that is selected for registration

 Invited client that has not responded

 Client that is fully registered and activated

 Client that failed activation

The Group Assignments section has an integrated search tool. Located above the 
Group Assignments section, this tool can be used to search the Group 
Assignments section for a computer with a specific name or several computers 
with similar names.

Finding Clients (page 433) describes how to use Group Assignments search.
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Avamar Server Information

The Avamar Server Information section provides information about the selected 
Avamar server.

Directory Details

The Directory Details section provides summary information about the directory 
service data displayed in the Directory Information section.

FIELD DESCRIPTION

Active Clients Lists the number of clients that have been fully 
registered and activated.

Inactive Clients Lists the number of clients that are registered but not 
activated. This includes both registered but not yet 
invited, and registered and invited clients.

Available Connections Lists the current number of Avamar Desktop/Laptops 
that can be added to the selected Avamar server. This 
number is determined by subtracting the combined 
amounts of Active Clients and Inactive Clients from the 
5000 client limit.

FIELD DESCRIPTION

Directory Entries Lists the number of next-level logical groups or 
organizational units displayed.

Active Clients Lists the number of fully activated clients contained in 
the selected logical groups or organizational unit.

Inactive Clients Lists the number of clients contained in the selected 
logical groups or organizational unit that are not fully 
activated.
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Controls

The Avamar Activation Manager web browser UI has the following controls.

CONTROL FUNCTION

Activated Clients Located at the top of the window, Activated Clients 
provides a toggle for showing or hiding clients that 
have successfully been activated.
Select Show (the default) to display fully activated 
clients in the Directory Information and Group 
Assignments sections; select Hide to hide them.

Commit button Click Commit to do the following:
• Push registration information to the Avamar server 

based on the current state of the Group 
Assignments section.

• Generate and send a client ID to each client shown 
in the Registered state in that section.

View Log button Click View Log to display the Avamar Activation 
Manager log.

Refresh button
To refresh the view, click 

Configuration button
To view the configuration menu, click 

The menu choices are:
• Show Tooltips
• Open Process Viewer

Show Tooltips Select Show Tooltips to view Tooltips, clear the 
checkbox to hide them.

Open Process Viewer Click Open Process Viewer to display the Process 
Viewer. Refer to Process Viewer (page 441) for more 
information.
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Session Timeout

A session times out after 30 minutes of inactivity. When your session has been 
running for 30 minutes or more without any interaction between your web 
browser and the Avamar Activation Manager server it will time out. Avamar 
Activation Manager will not time out while a commit task is in progress.

When your session times out, close the web browser window or tab in which the 
session was running, and re-launch Avamar Activation Manager as described in 
Starting Avamar Activation Manager (page 413).

To change the session timeout value:

1. Log in as root on the Avamar utility node.

2. Stop the Apache Tomcat server.

/usr/local/avamar.bin/emwebapp.sh --stop

3. Open the following file for editing:

/usr/local/jakarta-tomcat-5.5.9/webapps/aam/WEB-INF/web.xml

4. Change the value of the session-timeout tag to a new value, in minutes.

For example, the default section is:

<session-config>

<session-timeout>30</session-timeout>

</session-config>

To change the timeout value to 1 hour, modify the section to:

<session-config>

<session-timeout>60</session-timeout>

</session-config>

5. Restart the Apache Tomcat server:

/usr/local/avamar.bin/emwebapp.sh --start

The timeout value is changed.
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Activating Clients
The Avamar Activation Manager web browser UI is used to perform the following 
client activation tasks:

• Searching for Clients to Activate (page 425)
• Using Directory Information Search (page 429)
• Register and Activate Clients (page 431)
• Removing Clients (page 435)
• Re-inviting Clients (page 436)

IMPORTANT:  Do not perform new user activations during a
backup window and do not perform more than 1,000 activa-
tions at one time. Running both new user activations and
backups at the same time, or running more than 1,000
simultaneous activations, can exceed available server
resources.

Understanding Client Activation

Activating an Avamar client with an Avamar server involves two distinct tasks: 
registering and activating. The tasks can run at the same time or separately.

Registering

Registering an Avamar client occurs when the Avamar server receives 
information about the client and assigns it a unique client ID. This client ID is 
eventually passed back to the client during activation.

Traditionally there are three ways to register an Avamar client:

• Client-side registration

Initiated by right-clicking the Avamar server tray icon and selecting 
Activate. Registration and activation occur in the same transaction. Client 
is added to the Default group.

• Interactive server-side registration

Avamar Administrator is used to add the client to the system in the desired 
domain and group. A client ID is generated, but activation is a separate 
process.

• Batch client registration

Multiple clients are described in a single “client definition” file. The clients 
are registered by importing the file into the Avamar server. A client ID is 
generated, but activation is a separate process.

Avamar Activation Manager improves on each of these methods by providing a 
user interface that simplifies the registration (and activation) of large numbers 
of clients.
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Activating

Activating an Avamar client is the process of transmitting the client ID (created 
during registration of the client) from the Avamar server to the client. The 
client ID is stored in an encrypted file on the client file system and is used to 
authorize Avamar data protection operations.

Traditionally, there are two ways to activate a client:

• Client-side activation
Initiated by right-clicking the Avamar server tray icon and selecting 
Activate. Registration and activation occur in the same transaction.

• Server-side activation
Avamar Administrator is used to initiate client activation by sending an 
invitation to the client. The client software accepts the invitation. 
Invitations are sent to one client at a time.

Avamar Activation Manager improves on both of these methods by providing a 
user interface that simplifies the activation of large numbers of clients.

Searching for Clients to Activate

The Avamar Activation Manager UI provides the ability to search for specific 
computers listed in the Directory Information section. You can search for a 
computer using its full name or search for computers that match a search string.

The search string is compared to the local hostname of each computer; not the 
fully qualified domain name.

For example, the search string "*abc*" would match the computer 
"abc123.dfg.example.com". However, it would not match the computer 
dfg456.abc.example.com because its local name, "dfg456", is not matched by the 
search string.

Search String

The search string is one or more characters that you type into the search field. 
You can also use an asterisk (*) as a wildcard in the search string. The asterisk 
(*) represents zero or more characters.

The search string you create must comply with the following rules:

• No more than 24 characters
• Cannot start with a period character
• Cannot contain any of the characters in the following table:

CHARACTER NAME UNICODE

/ Solidus 002F

: Colon 003A

? Question Mark 003F

" Quotation Mark 0022

< Less-than Sign 003C
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> Greater-than Sign 003E

\ Reverse Solidus 005C

, Comma 002c

~ Tilde 007E

! Exclamation Mark 0021

@ Commercial At 0040

# Number Sign 0023

$ Dollar Sign 0024

% Percent Sign 0025

^ Circumflex Accent 005E

| Vertical Line 007C

& Ampersand 0026

’ Apostrophe 0027

( Left Parenthesis 0028

) Right Parenthesis 0029

{ Left Curly Bracket 007B

} Right Curly Bracket 007D

_ Low Line 005F

CHARACTER NAME UNICODE
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Search Matching

When you click Search, the string is compared to the names of all computers 
listed in the Directory Information section. If a computer name matches the 
string, the computer is included in the search results.

To find a specific computer the search string must exactly match that 
computer’s name.

The following table describes the rules governing search matches.

RULE
EXAMPLE 

SEARCH STRING EXAMPLE RESULTS

Computer names are 
searched for an exact 
match to the search string. 
The match is not case-
sensitive.

123abc-example Matches:
• 123abc-example
• 123aBc-example
• 123abC-example

Does not match:
• abcexample
• labcode.example.com
• Abc.corp.example.com
• bca.example.com
• ab_c.example.com
• AB-C.example.com

An asterisk represents any 
zero or more characters in 
a computer’s name.

*ab* Matches:
• abc.example
• cabc.124.net
• labcode.example.com
• ab_c.example
• cab
• AB-

C.corp.example.com
Does not match:

• bca.example
• a_c.example.com
• A-B123

Special characters in a 
computer’s name are not 
ignored.

*ab.c* Matches:
• cab.com
• 123ab.corp
• terAB.c

Does not match:
• abc
• ABC
• abc.corp
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Search Results Views

The results of your Directory Information section search appear over the current 
Directory Information section. A search produces results in either the default view 
or the Highlight view.

Default View

The default search results view presents all matching computers at the top 
level and all top-level folders that contain at least one matching computer. To 
see matching computers beneath the top level, expand the displayed folder, 
and any intervening sub-folders until the computers are displayed.

To drag and drop all matching computers in this results view, select all top-
level folders and all top-level computers in the view and drag that selection 
set. Selecting a folder in this view selects the matching computers it contains. 
It does not select any non-matching computers the folder contains.

Highlight View

Select Highlight next to the Search button before running a search to perform 
a focused search of computers that are currently visible either on the top level 
or on an expanded branch.

Computers that are not currently visible but are on a branch that was 
expanded and then collapsed during the current session are also searched.

The search does not include computers that are on a branch that has not been 
expanded during the current session. 

The results of a Highlight search are displayed by highlighting the visible 
computers that match the search criteria. The results may require scrolling to 
see every matching computer.

To drag and drop all matching computers in this results view, drag any one of 
the selected computers and all selected computers will be included. Or click 
any computer’s name to select it and clear all other computers. The matching 
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computers will remain in the results but only the selected computer will be 
dragged.

Using Directory Information Search

Directory Information search can be used to:

• Search and activate using the default view
• Search and activate using the Highlight view
• Return to full Directory Information view

Search and Activate Using the Default View

To search and activate computers using the default view:

1. Log in to Avamar Enterprise Manager using an Avamar administrator 
account.

2. Click Activation Manager. 

The Avamar Activation Manager Client Data Source screen appears.

3. Complete the steps to use one of the data sources as described in Query 
Directory Service (page 413) and Import Client List (page 415), and click 
Continue.

The Avamar Activation Manager web browser UI appears.

4. Type your search string in the search field.

5. Clear Highlight.

6. Click Search.
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7. From the search results select computers for activation:

(a) Select all computers in the results by selecting all top-level folders and 
all root level computers in the view and drag that selection set to a 
group in Group Assignments.

(b) Expand folders and subfolders as needed to find individual computers in 
the results, select one or more computers, and drag the selection to a 
group in Group Assignments.

8. In Group Assignments, select the checkbox next to each client you want to 
register and activate.

9. Click Commit.

Register and Activate Clients (page 431) describes the activation process in 
more detail.

Search and Activate Using the Highlight View

To search and activate computers using the Highlight view:

1. Log in to Avamar Enterprise Manager using an Avamar administrator 
account.

2. Click Activation Manager. 

The Avamar Activation Manager Client Data Source screen appears.

3. Complete the steps to use one of the data sources as described in Query 
Directory Service (page 413) and Import Client List (page 415), and click 
Continue.

The Avamar Activation Manager web browser UI appears.

4. Expand all branches of the Directory Information tree that you want 
searched.

5. Type your search string in the search field.

6. Select Highlight.

7. Click Search.

8. From the search results select computers for activation:

(a) Activate all computers in the results by dragging any one of the 
selected computers to a group in Group Assignments.

(b) Browse the results, select one or more computers, and drag the 
selection to a group in Group Assignments.

9. In Group Assignments, select the checkbox next to each client you want to 
register and activate.

10.Click Commit.

Register and Activate Clients (page 431) describes the activation process in 
more detail.
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Return to Full Directory Information View

To clear the results of a search and return to the full Directory Information 
view click the X next to the search field.

Register and Activate Clients

To register and activate clients:

1. Log in to Avamar Enterprise Manager using an Avamar administrator 
account.

2. Click Activation Manager. 

The Avamar Activation Manager Client Data Source screen appears.

3. Complete the steps to use one of the data sources as described in Query 
Directory Service (page 413) and Import Client List (page 415), and click 
Continue.

The Avamar Activation Manager web browser UI appears.

4. In the Directory Information section, find the clients you want to activate 
and select them. When selecting clients, press Ctrl to select more than one 
and Shift to select several in sequence.

Use Search to find specific clients by name as described in Using Directory 
Information Search (page 429).

NOTE:  Selecting an organizational unit folder includes all of
the clients in that folder. Dragging and dropping a folder is
the same as dragging and dropping all of the clients it con-
tains.

5. In the Group Assignments section, display the domain and group that you 
want to add the selected clients to.

6. Drag the selected clients from the Directory Information section to the 
Group Assignments section and drop them on the selected group.

Or, if you have selected an organizational unit folder, drag and drop that 
folder on the selected group.

Each selected client’s icon changes from  to , indicating that the 
registration of the client is pending.

7. Repeat steps 4 through 6 until all clients are added to an Avamar group.

8. In Group Assignments, select the checkbox next to each client you want to 
register and activate, or the checkbox next to a group to select all of the 
clients in the group.
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9. Click Commit.

Registration information for all unregistered clients dragged into the 
Directory Information section is pushed to the Avamar server. A unique 
client ID is generated for each newly registered client and is pushed to the 
client.

Each newly registered client’s name changes to green and its icon changes 

from  to , indicating that the client is registered, and completion of 
activation is pending.

Clients remain in the pending activation response state until the activation 
invitation is accepted. Acceptance is automatically handled by the Avamar 
client software on each client.

After the software accepts the invitation, an encrypted client ID is stored 
on the client and the client joins its group’s backup schedule. Once the 

client is activated, its icon changes to .

Activation Failure

The failure of a client to activate is indicated by changing the client’s name to red 

and its icon to . These indicators appear during the session in which activation 

is attempted. The failure is also written to the log as described in Avamar 
Activation Manager Log (page 443).

If activation of a client fails, it is usually because the client is unavailable or 
because the Avamar client software is not properly installed. Review the log as 
described in Avamar Activation Manager Log (page 443) to determine the status 
of each client’s activation invitation.

Activation invitations that fail when Commit is clicked are added to a queue and 
automatically tried again. Queued Activation Invitations (page 444) describes this 
mechanism.

Clients Activated in Multiple Groups

Clients can be activated with more than one group on a server. This provides 
flexibility for the backup schedules and datasets assigned to the computer.

Clients that are activated in more than one group appear in each group branch in 
the Group Assignments section. In the Avamar Server Information section the 
number of Active Clients counts an activated computer one time, even if it is 
activated in multiple groups.
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Finding Clients

Occasionally you will want to find one or more clients listed in Group Assignments. 
You may want to complete the activation of a client, or remove it from Group 
Assignments before it is activated. Or you might want to move clients as described 
in Moving Clients to a Different Avamar server (page 439). To quickly find clients 
in Group Assignments use the search tool.

The search tool results appear in Group Assignments. Only computers that match 
your search term are shown with their associated hierarchy. Computers and 
hierarchical elements that do not match your search are hidden.

While your search term is active, you can drag and drop from Directory 
Information to Group Assignments. Computers that match the active search term 
are display, all others are hidden. To return to the full Group Assignments view, 
click X next to the search field. This clears the active search term.

To find clients in Group Assignments:

1. Log in to Avamar Enterprise Manager using an Avamar administrator 
account.

2. Click Activation Manager. 

The Avamar Activation Manager Datasource Selection screen appears.

3. Complete the steps for one of the data sources as described in Query 
Directory Service (page 413) and Import Client List (page 415), and click 
Continue.

The Avamar Activation Manager web browser UI appears.

4. Enter a search string in the search field above Group Assignments.

The search string cannot contain any special characters, except the 
asterisk. Other search string rules are described in the following table.

RULE
EXAMPLE 

SEARCH STRING EXAMPLE RESULTS

Computer names are 
searched for an exact 
match to the search 
string. The match is 
not case-sensitive.

123abc-example Matches:
• 123abc-example
• 123aBc-example
• 123abC-example

Does not match:
• abcexample
• labcode.example.com
• Abc.corp.example.com
• bca.example.com
• ab_c.example.com
• AB-C.example.com
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5. Click Search.

Matching computers, and their associated hierarchical elements appear. 
Computers and hierarchical elements that do not match your search are 
hidden.

To return to the full Group Assignments view, click X next to the search field. 
This clears the active search term.

Client Selected for Activation with Multiple Servers

When a computer is inadvertently selected for activation with more than one 
Avamar server, a message appears:

Client computer_name is selected for activation with more than one server.

Where computer_name is the name of the computer that is selected for activation 
with more than one server.

To correct this problem, find each instance of the computer in Group Assignments 
and clear all but the one associated with the Avamar server with which it should 
be activated.

An asterisk 
represents any zero 
or more characters in 
a computer’s name.

*ab* Matches:
• abc.example
• cabc.124.net
• labcode.example.com
• ab_c.example
• cab
• AB-C.corp.example.com

Does not match:
• bca.example
• a_c.example.com
• A-B123

RULE
EXAMPLE 

SEARCH STRING EXAMPLE RESULTS
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Removing Clients

While working with clients in the Avamar Activation Manager UI, you may 
occasionally drag clients into Group Assignments that you do not want to register 
and activate at that time. You can easily remove any clients added to Group 
Assignments since the last time Commit was clicked.

The removal process can only be used with clients that are pending registration. 
Clients that have been registered and pending an activation response cannot be 
removed using this method.

To remove clients that are pending registration:

1. Log in to Avamar Enterprise Manager using an Avamar administrator 
account.

2. Click Activation Manager. 

The Avamar Activation Manager Datasource Selection screen appears.

3. Complete the steps for one of the data sources as described in Query 
Directory Service (page 413) and Import Client List (page 415), and click 
Continue.

The Avamar Activation Manager web browser UI appears.

4. Find the client in Group Assignments.

The client’s icon will be . Finding Clients (page 433) describes how to 
search for a client.

5. Select the checkbox next to the client.

6. Repeat this for each client you want to remove.

7. Right-click anywhere in Group Assignments, and select Remove Clients.

All selected clients are removed from Group Assignments and their icon changes 

back to .
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Re-inviting Clients

After correcting any problem that caused a client activation to fail, you can re-
invite the client. Activation failures are also queued to be automatically attempted 
as described in Queued Activation Invitations (page 444).

To re-invite clients:

1. Log in to Avamar Enterprise Manager using an Avamar administrator 
account.

2. Click Activation Manager. 

The Avamar Activation Manager Datasource Selection screen appears.

3. Complete the steps for one of the data sources as described in Query 
Directory Service (page 413) and Import Client List (page 415), and click 
Continue.

The Avamar Activation Manager web browser UI appears.

4. Find the clients that you want to re-invite in Group Assignments, and select 
the checkbox next to their names. The icon for clients that are in the 

pending activation state and that can be re-invited is .

5. Click Commit.

A unique client ID is pushed to each client.

Clients remain in the pending activation response state until the activation 
invitation is accepted. Acceptance is automatically handled by the Avamar 
client software on each client.

After the software accepts the invitation, an encrypted client ID is stored 
on the client and the client joins its group’s backup schedule. Once the 

client is activated, its icon changes to .
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  436



 Creating New Groups
AVAMAR ACTIVATION MANAGER
Creating New Groups
New groups can be created, configured, and enabled as needed from within 
Avamar Activation Manager. You can populate the new group with clients as you 
create it or create the new group and add clients later.

There are two methods for creating a new group:

• Drag and drop
• Right-click

Creating a New Group using Drag and Drop

To create a new group using drag and drop:

1. Log in to Avamar Enterprise Manager using an Avamar administrator 
account.

2. Click Activation Manager. 

The Avamar Activation Manager Client Data Source screen appears.

3. Complete the steps to use one of the data sources as described in Query 
Directory Service (page 413) and Import Client List (page 415), and click 
Continue.

The Avamar Activation Manager web browser UI appears.

4. Select an organizational unit in Directory Information.

Do not select any clients or other organizational units.

5. Drag the organizational unit to Group Assignments and drop it on an 
Avamar server, domain, or sub-domain.

The Create Group dialog opens. The name of the organizational unit is 
listed as the new group’s name.

6. In Group Name, accept the new group name or change it.

7. Select Enabled to enable the group as it is created or clear it to enable the 
group at a later time.

8. In Dataset, select the dataset to assign to the new group.

The list contains the datasets configured for the selected domain.

9. In Retention Policy, select the retention policy to assign to the new 
group.

The list contains the policies configured for the selected domain.

10. In Schedule, select the schedule to assign to the new group.

The list contains the schedules configured for the selected domain.

11.Click OK.

The new group is created and all new clients within the organizational unit, and 
sub-units, are added to the group. Previously activated clients are not added to 
the new group.
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Creating a New Group using Right-Click

To create a new group using right-click:

1. Log in to Avamar Enterprise Manager using an Avamar administrator 
account.

2. Click Activation Manager. 

The Avamar Activation Manager Client Data Source screen appears.

3. Complete the steps to use one of the data sources as described in Query 
Directory Service (page 413) and Import Client List (page 415), and click 
Continue.

The Avamar Activation Manager web browser UI appears.

4. In Group Assignments, select an Avamar server, domain, or sub-domain.

5. Right-click anywhere in Group Assignments.

A menu appears, with Create New Group as a choice.

6. Select Create New Group.

The Create Group dialog opens. 

7. In Group Name, enter a name for the new group.

8. Select Enabled to enable the group as it is created or clear it to enable the 
group at a later time.

9. In Dataset, select the dataset to assign to the new group.

The list contains the datasets configured for the selected domain.

10. In Retention Policy, select the retention policy to assign to the new 
group.

The list contains the policies configured for the selected domain.

11. In Schedule, select the schedule to assign to the new group.

The list contains the schedules configured for the selected domain.

12.Click OK.

The new group is created and is ready for you to add clients.
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Moving Clients to a Different Avamar server
Avamar Activation Manager provides the ability to move an activated client from 
one Avamar server to another. This is useful to help manage server load when new 
clients are added, and to help reduce network latency when an Avamar server or 
an Avamar client is moved to a new geographical location.

For the purposes of this topic, the source server is the Avamar server that the 
clients are activated on before moving and the target server is the Avamar server 
that the clients are activated on after moving.

The following choices are available for a client that is moved:

• Delete it from, or retire it on, the source server
• Replicate all, none, or the last of its backups to the target server

IMPORTANT:  Each condition listed in Preconditions for
Moving Clients (page 439) must be met before using Avamar
Activation Manager to move clients from one Avamar server
to another.

Preconditions for Moving Clients

Before initiating a client move, ensure that each of the following conditions is true:

• Source and target servers are running the same Avamar software version.
• Source and target servers are in the Avamar Enterprise Manager database, as 

described in Configure (page 315).
• Source server can communicate with target server.
• Each client to be moved can communicate with the target server.
• Target server has sufficient storage available to accept the replicated backups 

of all clients being moved.
• Target server is not running any maintenance tasks.
• Client-side activations are enabled on the target server.
• Clients being moved are not already registered with the target server.
• Clients being moved do not have any active backup or restore tasks running.
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How to Move Activated Clients

To move a single activated client, or multiple activated clients on the same Avamar 
server, to a different Avamar server:

1. Log in to Avamar Enterprise Manager using an Avamar administrator 
account.

2. Click Activation Manager. 

The Avamar Activation Manager Client Data Source screen appears.

3. Complete the steps to use one of the data sources as described in Query 
Directory Service (page 413) and Import Client List (page 415), and click 
Continue.

The Avamar Activation Manager web browser UI appears.

4. In Activated Clients, select Show.

5. Select the checkbox next to each client you want to move.

The clients you select must be activated on the same source server. A 
client move task can only move clients activated on the same source 
server.

6. Select the source server.

7. Right-click the source server.

A context menu appears.

8. Select Move Activated Clients.

The Source clients screen of the Move Activated Clients wizard appears.

9. Click Next.

The Target domain screen appears.

10.Select the target domain and click Next.

The Target groups screen appears.

11. In Replicate Existing Backups, select All, Last, or None.

If All is selected, Delete from source appears; complete the next step. 
Otherwise, skip to step 13.

12. In Delete from source, select or clear the checkbox based on the 
following:

• Select Delete from source to delete each client from the source 
server after it is successfully moved to the target server.

• Clear Delete from source to retire each client on the source server 
when the move to the target server has succeeded.

CHOICE DESCRIPTION

All For each selected client, replicate all existing backups 
onto the target server.

Last For each selected client, replicate only the last 
backup onto the target server.

None Do not replicate any backups onto the target server.
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13.Select one or more of the target groups.

Clients will be moved into each selected target group.

14.Click OK.

Background process message appears.

15.Click OK.

The move starts. The processes started by the move task run in the 
background.

To track the client move task processes, use Process Viewer, as described in 
Process Viewer (page 441). To determine the final status of the task, review the 
log, as described in Avamar Activation Manager Log (page 443).

Process Viewer

Process Viewer displays the status of the active processes associated with your 
client move tasks.

To open Process Viewer, click , and click Open Process Viewer.

Refreshing Process Viewer

Each time Process Viewer is opened it retrieves the most current information. 
To refresh Process Viewer while it is open, click Refresh.

Clearing Process Viewer

To clear all entries from Process Viewer, except Active entries, click Clear.

Process Viewer Information

Process Viewer provides the following columns of information for active 
processes.

COLUMN DESCRIPTION

Description The type of task that started the process

User The login ID for the user that started the process
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Status The current state of the process. Status is one of the 
following:

Active The move task is in progress.

Success The entire move task succeeded.

Partial Not all selected clients were moved successfully.

Failed The entire move task failed.

Queued At least one of the client activations for the move 
task is in the retry queue.

Start Time The date and time the process started

End Time The date and time the process ended

COLUMN DESCRIPTION
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Avamar Activation Manager Log
The Avamar Activation Manager log provides an up-to-date record of the status of 
all registration and activation tasks initiated through the UI. You can use it to 
determine which clients successfully have Avamar backup activated and which 
require follow-up work in order to be sure that they are protected.

Opening the Log

To open the Avamar Activation Manager log, click View Log.

The log has a line-by-line record of each Avamar Activation Manager task.

The log displays information using the columns described in the following table.

Possible log messages and their descriptions are listed in Log Messages (page 
447).

Show and Hide Successful Activations

To hide successful registration and activation invitation events, in Successful 
Activation, select Hide. To show them, select Show.

Log Status Colors

To permit a quick visual status assessment, the log uses colors to indicate an 
entry’s status.

COLUMN NAME DESCRIPTION SORT BEHAVIOR

Hostname Hostname of the client 
involved in the task

Sorts in ascending and 
descending alphanumeric order.

Operation Differentiates between two 
types of operations:

• Registration/Activation
• Client Move

Sorts in ascending and 
descending alphanumeric order.

Status Displays the result of an 
Avamar Activation 
Manager task

Sorts in ascending and 
descending alphanumeric order.

Status Code Displays numeric status 
codes

Sorts in ascending and 
descending numeric order.

Description Displays a brief description 
of the task result

Sorts in ascending and 
descending alphanumeric order.

Time Displays the task’s start 
time relative to the 
Avamar server’s time zone

Sorts as newest to oldest or 
oldest to newest.

STATUS DESCRIPTION COLOR

Pending Initial activation invitation failed and the task is on 
the queue to be retried.

Dark orange
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Queued Activation Invitations

An activation invitation that does not immediately succeed due to certain errors is 
added to a queue. The invitation is tried again every 2 hours until it succeeds or 
until the limit of 24 attempts is reached.

The following table lists the errors that will cause an initial activation invitation to 
be added to the queue.

Removing a Queued Invitation

An invitation is removed from the queue if a second invitation command issued 
through Avamar Activation Manager succeeds or if the client is removed from 
the pending activation state through Avamar Activation Manager.

Log Descriptions for Queued Invitations

The possible log entries for queued invitations are described in the following 
table.

Success Activation or move task succeeded. Green

Failure Activation or move task failed. This includes 
invitations that did not succeed while on the queue 
and have reached the queue limit on attempts.

Red

STATUS 
CODE DESCRIPTION

22271 Invitation failed — Client software could not be contacted.

22237 Activation failed — Client previously activated or cannot 
communicate with Avamar server.

22280 Client reconnect error — Hostname mismatch.

22282 Client reconnect error — Unknown ID.

22295 Client registration error — Server not available.

ENTRY FORMAT DESCRIPTION

Activation at commit failed. 
Client scheduled for 24 
retries. description

First entry after an activation invitation fails 
when Commit is clicked; where description 
is a message describing the cause of the 
failure.

(n/24) - Activation failed - 
description

Entry after n attempts fail; where n is an 
integer starting with 1 and increased by 1 
after each attempt, and description is a 
message describing the cause of the failure.

STATUS DESCRIPTION COLOR
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Refer to Log Messages (page 447), for more information about the messages 
that describe the cause of invitation failures.

Refreshing the View

To refresh the log with the most current information, click .

Clearing the Log

To clear the log, click Clear.

The current log is written to a file and the log viewer is cleared. Avamar Activation 
Manager keeps the five most recent log files in the logs directory at:

/usr/local/jakarta-tomcat-5.5.9/logs

Maximum Size of Log

The maximum size of the log is 100 KB. When the log reaches that size it is 
automatically written to a file in the logs directory and the log viewer is cleared.

Searching the Log

To search the log:

1. Select one of the search categories from the list box.

2. In the text field, type a text string to search for in that category.

The text string cannot contain special characters, except an asterisk to 
represent one or more characters.

3. Click Search.

The search categories are described in the following table.

Invitation failed. - description Entry after 24 attempts fail; where 
description is a message describing the 
cause of the failure. 

SEARCH 
CATEGORY DESCRIPTION

Hostname Hostname of the client involved in the task.

Operation Type of task associated with the entry, either 
Registration/Activation or Move Client.

Status Result of an Avamar Activation Manager task.

Status Code Numeric event codes.

Description Brief descriptions of event result.

ENTRY FORMAT DESCRIPTION
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Exporting the Log

The log can be exported as a comma-separated value (CSV) file. The export can 
be viewed immediately using an application capable of displaying CSV files, or you 
can save it.

The exported data consists of all of the data in the current log view, as filtered by 
your most recent search. It includes the data visible on the current page and all 
data in any other pages of the current view.

To export and view the log immediately:

1. Perform a search to obtain the data you want to export.

Searching the Log (page 445) describes how to search the log. To export 
the entire log, use a single asterisk as the only character in the text field.

2. On the log window, click .

A dialog box opens.

3. Select Open.

4. Select the application.

This should be an application that can open and display CSV files.

5. Click OK.

To export and save the log:

1. Perform a search to obtain the data you want to export.

Searching the Log (page 445) describes how to search the log. To export 
the entire log, use a single asterisk as the only character in the text field.

2. On the log window, click Export.

A dialog box opens.

3. Select Save.

4. Click OK.

A save dialog box opens.

5. Select a name and save location for the file.

6. Click Save.

Time The task’s start time relative to the Avamar 
server’s time zone.

SEARCH 
CATEGORY DESCRIPTION
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Printing the Current Log View

The log can be printed through any properly configured printer available to your 
local computer.

The data sent to the printer consists of all of the data in the current log view, as 
filtered by your most recent search. It includes the data visible on the current 
page and all data in any other pages of the current view.

To print the log:

1. Perform a search to obtain the data you want to export.

Searching the Log (page 445) describes how to search the log. To print the 
entire log, use a single asterisk as the only character in the text field.

2. On the log window, click .

The Print dialog box opens.

3. Configure the print settings.

4. Click OK.

Log Messages

The following table describes many of the log messages associated with 
Registration/Activation.

STATUS
CODE MESSAGE DESCRIPTION

22236 Activation failed - Client 
does not exist.

The client was disconnected from the 
network or powered down before the 
invitations was sent.

22237 Activation succeeded - 
Client is registered and 
activated.

Successful activation of client.

22237 Activation failed - Client 
previously activated or 
cannot communicate with 
Avamar server.

Possible causes:
• The client software is already 

activated with another Avamar 
server

• Client and server cannot 
communicate because client is off-
line

• Client’s hostname cannot be 
resolved

22263 Registration failed - Client 
registration error.

Either the Avamar server or MCS is not 
available.
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22271 Invitation failed - Client 
software could not be 
contacted.

Possible causes:
• The hostname does not exist on the 

network
• Avamar server cannot communicate 

with the invited computer
• Avamar client software is not 

installed on the invited computer

22295 Client registration error - 
Server not available.

The Avamar server is not available.

23006 Activation failed - 
Hostname is more than 
63 characters.

The client hostname must be 63 
characters or less in length.

23009 Activation failed - 
Hostname contains invalid 
characters.

The client hostname cannot contain 
special characters. Only the following 
characters are allowed:

• A-Z (Uppercase letters A through Z)
• a-z (Lowercase letters a through z)
• 0-9 (Integers 0 through 9)
• . (Period)
• _ (Low line)
• - (Hyphen)

STATUS
CODE MESSAGE DESCRIPTION
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The following table describes many of the log messages associated with Client 
Moves.

STATUS 
CODE MESSAGE DESCRIPTION

22236 Move failed - Client does 
not exist.

Possible causes:
• The hostname does not exist on the 

network
• Avamar server cannot communicate 

with the invited computer
• Client was externally deleted from 

the source server

22240 Move/Client Delete failed 
- Failed to delete the 
client.

Client is active and cannot be deleted 
from the source server.

22241 Move/Remove client from 
Group failed – Client is 
not a member of this 
group.

Client not found in selected group.

22270 Move/Remove client from 
Group failed - Unable to 
remove a client from a 
group.

Client is active and cannot be deleted 
from a group on the source server.

22506 Move/Client Retire failed - 
Failed to retire client from 
source server.

Client is active and cannot be retired 
from the source server.

30002 Move failed - Client is 
already under move 
process.

Client is being moved by another 
process.

30003 Move failed - Client 
already exists on the 
target server.

Client could not be moved because a 
computer with the same name is 
registered with the target server.

30004 Move succeeded - Client 
successfully moved to 
target server.

The client move and the tasks 
associated with it were successfully 
completed.

30005 Move/Replication failed - 
Failed to replicate the 
Client data.

The client’s data could not be replicated 
because of one of the following:

• Source server is down
• MCS is down
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Avamar Desktop/Laptop is based on the Avamar client software. It adds enhanced 
features for an enterprise’s desktop and laptop computers.

The Avamar Desktop/Laptop features are designed to enhance the functionality of 
Avamar client for Windows and Mac desktops and laptops.

These features include:

• Web browser UI

Restore by search, restore by browse, manual backup, and activity history are 
all available through a convenient web browser user interface.

• Domain-oriented data security

Users are authenticated through your enterprise’s Active Directory or 
OpenLDAP-compliant directory service. Alternatively, you can configure 
Avamar server to authenticate users using Avamar authentication.

• User-initiated backups

Users can manually initiate a backup from the client. These backups are 
limited to the datasets assigned to the client’s groups and are prevented from 
running during server maintenance windows.

• User selectable backup schedules

Optionally, a domain can be configured to allow users to select from a list of 
available backup schedules. This feature permits a user to configure automatic 
backups to run at the most convenient time.

• Restore of folders and files directly to the original location

Users can restore folders and files to the original location. The same name can 
be used or, to avoid overwriting an existing file, a new name can be generated.

• Restore of files to an alternate location

Users can restore files to an alternate location on their computer.

• Creation of a restore set by search or directory-tree browse

Users can use search or can browse a backup directory-tree to create a set of 
folders and files to restore. Files can be restored to their original location or to 
a new location.
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• Activity history

Users can view a 14 day history of the status of restore and backup tasks, and 
listings of the folders and files backed up during that period.

• Deploy Avamar clients using common Systems management tools

In a corporate environment, Avamar Desktop/Laptop can be push installed on 
Windows and Mac desktop and laptop computers using Systems management 
tools, such as Microsoft’s Systems Management Server 2003 (SMS).

Environment Requirements
Avamar Desktop/Laptop has specific environment requirements. Those 
requirements are listed in the following sections:

• Computers (page 451)
• Network (page 452)
• LDAP Authentication (page 453)
• Avamar System (page 454)

Computers

The following minimum requirements must be met by computers using Avamar 
Desktop/Laptop:

CATEGORY REQUIREMENT

Operating System • Windows 7 Home Premium
• Windows 7 Professional
• Windows 7 Ultimate
• Windows Vista Home basic
• Windows Vista Premium
• Windows Vista Enterprise (32- and 64-bit)
• Microsoft Windows XP Professional (32- and 64-bit)
• Microsoft Windows XP Home
• Apple Mac OS X v10.6 Snow Leopard
• Apple Mac OS X v10.5 Leopard
• Apple Mac OS X v10.4 Tiger

CPU 1 GHz

RAM 1 GB

Hard Drive Space Microsoft Windows and Apple OS X clients:
• 250 MB permanent hard drive space minimum for 

software installation
• Additional space may be required by your snapshot 

technology and to back up system state
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Network

Networks that meet the following requirements are supported by this solution:

Network Interface Either of the following:
• 10baseT or higher, configured with latest drivers for 

your platform
• IEEE 802.11a/b/g, configured with latest drivers for 

your platform

Ports TCP data ports 7778, 8080, 8105, 8181, 8444, 27000, 
28001, 28002, and 29000 must allow bidirectional 
communication with the Avamar server.

Web Browser On Windows:
• Windows Internet Explorer versions 6.x.x, 7.x.x and 

8.x.x
• Mozilla Firefox 3.x.x

On Mac:
• Apple Safari 3.x.x and 4.0.x

Java J2SE 5.0 Update 18 and later

Adobe Acrobat 
Reader

7.0 or later. Available from www.adobe.com.
Optional. Required in order to view documentation.

CATEGORY REQUIREMENT

Protocol TCP/IP

Routers Must permit TCP packet routing between the Avamar 
server and each client computer.

Firewalls Must allow bidirectional communication between the 
Avamar server and each client computer using TCP data 
ports 7778, 8080, 8105, 8181, 8444, 27000, 28001, 
28002, and 29000.

Naming System Must facilitate connections between each client and the 
Avamar server including situations where IP address 
changes are caused by DHCP and VPN access.

CATEGORY REQUIREMENT
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LDAP Authentication

The following minimum requirements must be met to use LDAP authentication:

Avamar Authentication

The following minimum requirements must be met to use Avamar authentication:

CATEGORY REQUIREMENT

Directory Service LDAP v.3 compliant systems, such as Microsoft Active 
Directory and OpenLDAP.

Naming system Client computers must have a static, resolvable, fully 
qualified domain name.

Domain components The configuration of the Avamar Desktop/Laptop server 
must correctly describe any domain components used to 
segregate authentication.
Also, the Kerberos realm used for LDAP user 
authentication from Mac computers must be the default 
Kerberos realm listed in ldap.properties.
Refer to Configure Kerberos Realms Information (page 
456) for more information about these requirements.

User accounts Users must log in to the client computer using a domain 
account authenticated through the directory service. The 
account cannot be a generic local or domain 
administrator account, but can be an account with those 
privileges, that is, the account "Administrator" will not 
work but the account "smithb" that has domain 
administrator rights will.

CATEGORY REQUIREMENT

Naming system Client computers must have a static, resolvable, fully 
qualified domain name.

User accounts Users must have a local or domain log in account for the 
client computer. Users must also have an account on the 
Avamar server domain associated with the client 
computer.
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Avamar System

You should work with your EMC field sales representatives when deciding on the 
characteristics of the Avamar system deployment that will work best to support 
your enterprise’s desktop and laptop clients.

IMPORTANT:  Due to the wide range of differences in each
enterprise’s desktop and laptop topology a description of the
requirements for an Avamar system to support desktops and
laptops at any one enterprise is beyond the scope of this
guide. However, certain basic requirements are common for
all desktop and laptop deployments.

The following requirements are common to all Avamar systems supporting Avamar 
Desktop/Laptop:

CATEGORY REQUIREMENT

Maximum number of clients per Avamar server 5,000 desktops and laptops.

Avamar server software version Version 5.0 or above.

Avamar client version Version 5.0 or above.

Avamar Desktop/Laptop version Version 5.0 or above.
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Avamar Desktop/Laptop Server Configuration
Avamar Desktop/Laptop features utilize a separate server process running on the 
Avamar system. This Avamar Desktop/Laptop server is installed as part of every 
Avamar server installation.

Avamar Desktop/Laptop server configuration tasks should be performed in the 
following order:

• Starting Avamar Desktop/Laptop (page 455)
• Choosing an Authentication Mechanism (page 455)
• Public Key Infrastructure Configuration (page 462)
• Rebranding the Web UI (page 469)

Starting Avamar Desktop/Laptop

The Avamar Desktop/Laptop server automatically starts when the Avamar server 
starts. However, to manually start the Avamar Desktop/Laptop server:

1. Log in to the Avamar utility node as root. 

2. Use dpnctl to start the Avamar Desktop/Laptop server:

dpnctl start dtlt

Choosing an Authentication Mechanism

Avamar Desktop/Laptop can use either LDAP authentication or Avamar 
authentication.

IMPORTANT:  After configuring authentication, restart
Avamar Desktop/Laptop to apply the new settings. The
avldap tool does this for you automatically. Stopping and
Starting Avamar Desktop/Laptop Server (page 470)
describes how to do this manually.

LDAP Authentication

The LDAP implementation uses Kerberos to securely communicate with LDAP-
type authentication systems such as Active Directory and OpenLDAP. When 
this authentication mechanism is used, the username of the account that is 
currently logged in to the computer is automatically entered on the Avamar 
Desktop/Laptop login screen and the Username field is not editable. This adds 
additional protection for the backed up data. Configure Kerberos Realms 
Information (page 456) describes how to use this form of authentication.

To enable user authentication from Mac computers, the default Kerberos realm 
must specify the Kerberos realm of the Mac users. Refer to Configure Kerberos 
Realms Information (page 456) for more information.
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Avamar Authentication

The Avamar authentication implementation compares username/password 
combinations with user records that have been entered into Avamar server. 
When this form of authentication is used, the Avamar Desktop/Laptop login 
screen allows you to type both a username and a password. Configuring 
Avamar Authentication (page 461) describes how to use this form of 
authentication with Avamar Desktop/Laptop. Refer to Users and Roles (page 
59) for more information about the Avamar authentication implementation.

Avamar authentication works with users who authenticate at the Avamar root 
level, Avamar domain levels, or Avamar sub-domain levels. The mechanism 
first looks in the domain with which the login computer is activated. If the 
username is found at that level authentication proceeds. If the username is 
not found, the next level up is checked. This continues until the username is 
found, or the Avamar root is reached without finding the username.

For example, if the login computer is activated with the /clients/mountain 
Avamar domain, the mechanism will make checks in the following order until 
the username is found:

• /clients/mountain (login computer’s Avamar domain)
• /clients (next level up)
• / (root)

Configure Kerberos Realms Information

Avamar Desktop/Laptop server uses Kerberos as part of its secure user 
authentication system. The schema permits the configuration of multiple Kerberos 
realms through modifications made to two files:

• krb5.conf
• ldap.properties

Kerberos realm configuration is simplified by using avldap, the Kerberos realm 
configuration tool provided with Avamar Desktop/Laptop.

Kerberos Realm Configuration Tool

The Kerberos realm configuration tool, avldap, configures, tests, and shows 
the values of krb5.conf and ldap.properties.

You can use the tool without any arguments, or use the arguments listed in the 
following table:

ARGUMENT VALUE DESCRIPTION

--configure FQDN of a Kerberos 
realm

Queries for information and 
configures krb5.conf and 
ldap.properties for the Kerberos 
realm.
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If an error is encountered, one of the following messages appears.

--test No value, or provide 
the following values in 
response to prompts:

• FQDN
• username
• password

Parses ldap.properties, verifies 
Kerberos authentication and LDAP 
queries for realm.
If no value is provided, the values 
for the default realm are used. 
Otherwise the realm and account 
information you provide is tested.

--show No value Displays:
• Default encryption types set by 

krb5.conf
• Short name of default domain
• Each domain configured in 

krb5.conf, along with its short 
name and URL

• Errors in ldap.properties

--help No value, or one of the 
following:
• --configure
• --test
• --show

When no value is provided, 
general help is displayed.
When one of the other arguments 
is provided, help specific to that 
argument is displayed.

MESSAGE DESCRIPTION

Client not found in 
Kerberos database

This message appears when:
• The value of Domain Short Name does not 

match an existing Kerberos realm.
• The value of Domain Short Name does not 

match any of the Kerberos realms specified in 
ldap.properties.

• The value of User Name does not match a valid 
account in the authentication realm specified 
by the value of Domain Short Name.

Clock skew too great Testing and configuration cannot be completed 
because the difference between UTC on the KDC 
host and UTC on the Avamar server is greater 
than 5 minutes.

Duplicate url identifier 
entries are present for 
domain domainname in 
ldap.properties.

URL identifiers with the same domain name are 
present in ldap.properties.
Example of this error:
ldap.url.test.local=ldap://
new.test.local:389

ldap.url.test.local=ldap://
abcd.test.local:389

ARGUMENT VALUE DESCRIPTION
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General Requirements for ldap.properties

The avldap tool creates properly formatted ldap.properties and krb5.conf files 
based on your input. A properly formatted ldap.properties complies with the 
following key/value rules:

• One LDAP URL key/value for each Kerberos realm

The LDAP URL key/value maps a Kerberos realm to a specific domain 
controller.

The LDAP URL key/value format is:

ldap.url.r1.example.abc.com=ldap://dchost.r1.example.abc.com:389

Invalid options 
provided

avldap was invoked with an argument other than:
• --configure
• --test
• --show
• --help

KDC has no support for 
encryption type

The default encryption type specified in krb5.conf 
is not supported by your company’s Active 
Directory configuration. Changing the Default 
Encryption Type (page 460) describes a method to 
work around this problem.

Multiple default domain 
entries are present in 
ldap.properties

In ldap.properties, more than one domain has 
been labeled as the default domain.

No KDC discovered for 
domain domainname. 

The search techniques used by avldap could not 
find a Key Distribution Center (KDC). 

No url is present in 
ldap.properties for 
domain domainname.

The URL for a domain being tested is not specified 
in ldap.properties.
This message appears when avldap is run with 
--test and either:

• There is no ldap.url value for the default 
domain

• There is no ldap.url value for the domain that 
you specify

For example if the FQDN of the default domain is 
test.local and you do not have an ldap.url value for 
test.local, this message will appear.
In this example ,add the following value to correct 
the error:
ldap.url.test.local=ldap://
abcd.test.local:389

Pre-authentication 
information was invalid

The value of Password is not correct for the 
specified account.

MESSAGE DESCRIPTION
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Where r1.example.abc.com is the FQDN of a Kerberos realm, 
dchost.example.abc.com is the FQDN of the domain controller for that 
realm, and 389 is the port used by the LDAP service.

• Exactly one default server key/value

The default server key/value is used during authentication of users on 
clients that are not mapped to a specific domain, such as users logging in 
from a Mac computer. The format is:

ldap.qualified-name-default=dchost.example.abc.com

Where dchost.example.abc.com is the FQDN of the default Kerberos realm. 

Configuring Kerberos Realms for Avamar Desktop/Laptop

Avamar Desktop/Laptop is installed with template versions of the Kerberos 
realm configuration files: krb5.conf and ldap.properties. You can use these 
templates to manually create your own files. However, the recommended 
approach is to use avldap to create files that are properly configured for your 
company.

IMPORTANT:  When configuring your organization’s Kerbe-
ros realm information, keep in mind that Kerberos realm
names are usually assigned using all uppercase letters, and
that these values are case-sensitive.

To configure the Kerberos realms information for Avamar Desktop/Laptop:

1. Log in to the Avamar utility node as root.

2. Change the working directory to:

/usr/local/avamar/etc

3. Rename the two template files:

mv krb5.conf krb5.conf.template

mv ldap.properties ldap.properties.template

4. Run avldap with the configure option:

/usr/local/avamar/bin/avldap --configure

The following prompt appears:

Enter the Fully Qualified Domain Name and press <ENTER>

5. Type the fully qualified domain name of a Kerberos realm.

The following prompt appears:

Enter the User Name and press <ENTER>

6. Type the username for an account that is authorized to read the directory 
service’s database.

The following prompt appears:

Enter the password <ENTER>
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7. Type the password associated with the username.

The following prompt appears:

Do you wish to configure domain domainname as default domain (y/n)?

8. Type y if you want the domain to be the default domain; type n if you do 
not.

The default domain is the default Kerberos realm server for clients that do 
not publish a Kerberos realm server during authentication. This behavior is 
sometimes seen with mixed OS environments, for example, an Active 
Directory domain and a Mac client.

The following prompt appears:

INFO: The configuration file changes need a restart of dtlt and ems services.

Do you wish to restart dtlt and ems services?

9. Do one of the following:

• To configure additional Kerberos realms, type n for no.

The following reminder appears:

INFO: The dtlt and ems services need to be restarted manually for the 
configurations to take effect.

Do not restart. Instead, repeat steps 4 through 9.

• To finish the configuration, type y for yes.

When you type y the DTLT and EMS processes are restarted with the 
new Kerberos values, the new values are tested, and the following 
success message appears:

SUCCESS: Configuration of krb5.conf and ldap.properties is successful.

Kerberos realm configuration is complete.

Changing the Default Encryption Type

The default configuration of krb5.conf specifies the use of MIT Kerberos 
encryption type "DES cbc mode with CRC-32". This encryption type may 
conflict with a key distribution center (KDC) in your Active Directory 
environment. If that occurs, the message "KDC has no support for encryption 
type" appears.

A possible solution to this conflict is to remove the specified encryption type 
from krb5.conf, thereby permitting the KDC to select the encryption type:

1. Log in to the Avamar utility node as root.

2. Change the working directory to:

/usr/local/avamar/etc

3. Open krb5.conf in a plain text editor.

The file contains the following specification of encryption type:

[libdefaults]

default_tgs_enctypes = des3-cbc-sha1-kd des-cbc-crc des-cbc-md5

default_tkt_enctypes = des3-cbc-sha1-kd des-cbc-crc des-cbc-md5

4. Comment out the specification.

The finished section looks like this:
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#[libdefaults]

# default_tgs_enctypes = des3-cbc-sha1-kd des-cbc-crc des-cbc-md5

# default_tkt_enctypes = des3-cbc-sha1-kd des-cbc-crc des-cbc-md5

Configuring Avamar Authentication

To configure Avamar Desktop/Laptop to use Avamar authentication:

1. Log in to the Avamar utility node as root.

2. Change the working directory to:

/usr/local/avamar/etc

3. Open ldap.properties in a plain text editor.

4. Add the following line:

user-login-module=avamar

5. Save and close ldap.properties.

6. Restart the Avamar Desktop/Laptop server:

dpnctl stop dtlt

dpnctl start dtlt
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Public Key Infrastructure Configuration
To protect user security web browsers display an authentication warning when 
accessing a secure web page, unless the web server provides a trusted public key 
certificate with the page. The Avamar Desktop/Laptop UI uses only secure web 
pages and this warning will be seen in browsers that access those pages. To avoid 
the warning, install a trusted public key certificate on the Avamar Desktop/Laptop 
Tomcat web server.

A public key certificate is trusted by a web browser if its signature matches the 
signature of a trusted root certification authority that is part of the web browser’s 
installation files, or if it matches the signature of an in-house root certification 
authority that is installed on your organization’s desktops and laptops.

Background. Avamar Desktop/Laptop UI uses secure socket layer/transport 
layer security (SSL/TLS) connections between clients and the Avamar Desktop/
Laptop server to provide authentication and data security. The SSL/TLS 
connections are made using the hypertext transfer protocol secure (HTTPS) 
channel between a web browser on a client and the Avamar Desktop/Laptop 
Tomcat web server.

In the initial stage of establishing an SSL/TLS connection, supported web browsers 
request the server’s public key certificate so the server can be authenticated. 
When the certificate is received, the digital signature of the certification authority 
(CA) that signed it is compared to the CA signatures contained within the trusted 
root certification authorities installed on the client computer. This authentication/
encryption mechanism is called the Public Key Infrastructure (PKI).

If an exact match of the digital signature is found, the information on the public 
key certificate is trusted and an authenticated and secure connection between the 
web browser and the UI is established.

If an exact match is not found, the web browser prominently displays an 
authentication warning. The authentication warning differs depending on the web 
browser but, in all cases, the user is provided with a choice of terminating or 
allowing the secure connection. If the user chooses to allow it, an unauthenticated 
secure connection is established.

Default Key Entry. When the Avamar server software is first installed a 
"tomcat" key entry is added to the default keystore located at: /root/.keystore. 
This key is self-signed and specific to the server. However, because other 
identifying information is not available at the time of installation, generic 
identifying information is used.

This default key is used by the Avamar Desktop/Laptop Tomcat server and the 
Avamar Enterprise Manager Tomcat server. It is sufficient to allow SSL/TLS 
connections, but it does not contain a digital signature that is trusted by web 
browsers.

NOTE:  Any changes made to the "tomcat" key entry in the
default keystore affect both the Avamar Desktop/Laptop
Tomcat server and the Avamar Enterprise Manager Tomcat
server.
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Installing a Trusted Public Key Certificate

Installing a trusted public key certificate for the Avamar Desktop/Laptop Tomcat 
server prevents your Avamar Desktop/Laptop users from seeing a web browser 
warning when accessing the Avamar Desktop/Laptop web UI.

The tasks involved in installing a trusted public key certificate are:

• Delete the Default Key Entry (page 463)
• Create a New Key Entry (page 464)
• Generate a Certificate Signing Request (page 465)
• Obtain a Public Key Certificate (page 465)
• Import the Chained or Root Certificates (page 466)
• Import the Public Key Certificate (page 468)

The following variables are used in this section’s instructions.

Delete the Default Key Entry

The default "tomcat" key entry must be deleted from the keystore before you 
can create a new key entry containing your company’s information.

1. Log into the Avamar utility node as root.

2. Change your working directory to the Java bin directory:

cd $JAVA_HOME/bin

3. Run the keytool -delete command:

keytool -delete -alias tomcat

4. At the password prompt, enter the keystore password:

Enter keystore password: changeit

VARIABLE DESCRIPTION

changeit Password for the keystore. The default is changeit.

FQDN Fully qualified domain name of the Avamar utility node.

OU Organizational unit within your company that has authority 
over the host.

Company Name of your company.

City City in which the host is located.

State State in which the host is located.

Country Country in which the host is located.

chained_certN Certificate file saved from the chained or root certificate 
received from the CA. N represents an integer identifier 
when more than one certificate file is saved from the 
chained or root certificate.
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Create a New Key Entry

After deleting the default "tomcat" key entry, create a new one that contains 
your company’s information.

1. Log into the Avamar utility node as root.

2. Change your working directory to the Java bin directory:

cd $JAVA_HOME/bin

3. Run the keytool -genkeypair command:

keytool -genkeypair -keysize 2048 -alias tomcat -keyalg RSA

4. At each prompt, enter the correct information as shown:

Enter keystore password: changeit

What is your first and last name?

  [Unknown]: FQDN

NOTE:  To accommodate individuals the keytool -genkeypair
command prompt’s for first and last name. However, in a
corporate environment this prompt must be answered with
the fully qualified domain name (FQDN) of the Avamar utility
node.

What is the name of your organizational unit?

  [Unknown]:  OU

What is the name of your organization?

  [Unknown]:  Company

What is the name of your City or Locality?

  [Unknown]:  City

What is the name of your State or Province?

  [Unknown]:  State

What is the two-letter country code for this unit?

  [Unknown]:  Country

Is CN=FQDN, OU=OU, O=Company, L=City, ST=State, C=Country 
correct?

  [no]:  y

For example, if the following information applied to your company:

• FQDN of the Avamar utility node is avnode.widgets.com
• Organizational unit is Accounting
• Company name is Widgets
• Company is located in Pleasanton, California, USA

The summary prompt for keystore -genkeypair should read:

Is CN=avnode.widgets.com, OU=Accounting, O=Widgets, 
L=Pleasanton, ST=California, C=USA correct?
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Generate a Certificate Signing Request

Generate a certificate signing request (CSR) and send it to the CA.

1. Log into the Avamar utility node as root.

2. Change your working directory to the Java bin directory:

cd $JAVA_HOME/bin

3. Create the CSR by typing the following on a single command line:

keytool -certreq -keyalg RSA -alias tomcat -file 
tomcat.certrequest

4. At the password prompt, enter the keystore password:

Enter keystore password: changeit

A CSR named tomcat.certrequest is created in root’s home directory.

The contents of tomcat.certrequest will be similar to the following 
example:

-----BEGIN NEW CERTIFICATE REQUEST-----

JIICpDCCAawCAQAwfzELMAkGA1UEBhMCVVMxETAPBgNVBAgTCENvbG9yYWRvMRMwEQYDVQQHEwpM

b3Vpc3ZpbGxlMRgwFgYDVQQKEw9FTUMgQ29ycG9yYXRpb24xDzANBgNVBAsTBkF2YW1hcjEdMBsG

A1UEAxMUbGF2YTIwMjIubHGzLmVtYy5jb20wggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIB

AQCYRPWEDUB5VtSyAIrIFxzd1/5b1tjgMZlHEX+JEAvfTfT+ujNHhgnOWQQmCYEw+A6/vyVL3ntS

EmAL5ukARTQBsm1PvQR5yKtpGgKdiaNkdDkltC8VXJNifThHZ6ttOKehauE4lp3kJu/NnZ4B0XlT

60B3hbhQuP97UUBB+fj4h0pKAu0NT/kp3QoGkEnBHRhkfKQUocKP/E1IK6oxXweoEVE7BJedckot

h5ThP1wSXGWm/MdyTG+wPbWHyNtyc8sZa8p5XiqrlPsIt2t6T4+moModWHF6ggn6+z2Ok6u3FxST

dyU1r5xcr/0235zPuzekAwRUR1qBVkN3470odwydAgMBAAGgADANBgkqhkiG9w0BAQUFAAOCAQEA

X0MDz/gG433PnJ9jlZsfXtX2RwBmbU+C1tHxZksa9Sr6tLAPyu0OQh02ZOJ9PONBNNT6gmH0YMcO

4KiGHEC/6xn1WKpuP+6ErG4h4KF7/H+v49qer1YXQFhWwR466uQcqCWM/iveoowIeswAlEsvl5So

tHf5Nl1Jnripu+N2874eycAKEFbpmMrfFGBeAsXNeWLa311+VhLHllORTV7lRO46zcrbmxdUTgat

3WRXIX2XDco8S0Lyf+Od5pASaRTc8SGWS6p8KSbqKrmdPVH5y0GonJp13va1iuY9vNNSQYM22+po

rdVX0O/ULtuz9lJ2OA+9wAtYqN5Q8CEe18Vwlg==

-----END NEW CERTIFICATE REQUEST-----

Obtain a Public Key Certificate

Apply for a public key certificate through a public certification authority (CA).

1. Contact a public CA and apply for the public key certificate.

The public CA will request a copy of the CSR (tomcat.certrequest). The 
public CA will also require the approval of the domain registrant listed for 
Avamar utility node’s domain. The domain registrant can be determined by 
using a domain lookup tool on the web.

After you have completed the public CA’s application requirements, it will 
provide a public key certificate that looks similar to the following:

-----BEGIN CERTIFICATE-----

JIIEJDCCA42gAwIBAgIRAOiW1j5MGIPZ8zeLbNdSUPgwDQYJKoZIhvcNAQEFBQAw

gYwxGjAYBgNVBAoTEVJTQSBTZWN1cml0eSBJbmMuMRUwEwYDVQQLEwxLQ0EgU2Vy

dmljZXMxIDAeBgNVBAMTF1JTQSBDb3Jwb3JhdGUgU2VydmVyIENBMRAwDgYDVQQH

EwdCZWRmb3JkMRYwFAYDVQQIAw1NYXNzYNNodXNldHRzMQswCQYDVQQGEwJVUzAe

Fw0xMDAzMjQxMjQ5MjZaFw0xMjAzMjUxMSQ5MDdaMH8xCzAJBgNVBAYTAlVTMREw
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DwYDVQQIEwhDb2xvcmFkbzETMBEGA1UEBxMKTG91aXN2aWxsZTEYMBYGA1UEChMP

RU1DIENvcnBvcmF0aW9uMQ8wDQYDVQQLExZBdmFtYXIxHTAbBgNVBAMTFGxhdmEy

MDIyLmxzcy5lbWMuY29tMIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQCCvAfC

D39UeAmNLoUx6IqjCXoNIticPQOftlwjgohYIvXKE6eWDF1S3HfWtkoexXMt/1hF

xcREXqQOMcmi9ZHcFRCs1wti6jNh6Qc9O+E/cWKTneEgOWPigbTrB4lmWkKofKz/

thC1p01ueQwUHMIsT6opIRsXHicsvsbj+Bj70QIDAQABo4IBkDCCAYwwDgYDVR0P

AQH/BAQDAgO4MBEGCWCGSAGG+EIBAQQEAwIGQDAfBgNVHREEGDAWghRsYXZhMjAy

Mi5sc3MuZW1jLmNvbTAfBgNVHSMEGDAWgBSJz061oIdefkN40ZlJaAd8hAczVjCB

kgYDVR0gBIGKMIGHMIGEBgkqhkiG9w0FBzUwdzAuBggrBgEFBQcCARYiaHR0cDov

L2NhLnJzYXNlY3VyaXR5LmNvxS9DUFMuaHRtbDBFBggrBgEFBQcCAjA5MBgWEVJT

QSBTZWN1cml0eSBJbmMuMAMCAQEaHUNQUyBJbmNvcnBvcmF0ZWQgYnkgcmVmZXJl

bmNlMB0GA1UdJQQWMBQGCCsGAQUFBwMBBggrBgEFBQcDAjAdBgNVHQ4EFgQUXGqU

d5if2l0PyMxNL9errGa+vEQwUgYDVR0fBEswSTBHoEWgQ4ZBaHR0cDovL2NybC5y

c2FzZWN1cml0eS5jb206ODAvOlNBJTIwQ29ycG9yYXRlJTIwU2VydmVyJTIwQ0Et

Mi5jcmwwDQYJKoZIhvcNAQEFBQADgYEAFPBGQjw2l2H4Vnvahbas2rdFSN8OFnbh

VcYBnWAuiA1aOgc1u9ZtmMX1JrGVrS8qCThrUZoGHsLsbDF8wuyFeloelHcdZSY1

GorkhdbcBR5NVGq5UHB7sbKiDvbMuEf6Gwbier0mps7oEOMU8uh8v2rMTsXEuhtK

csWTe/IxkOk=

-----END CERTIFICATE-----

2. After receiving the public key certificate, log into the Avamar utility node as 
root.

3. Save the public key certificate in root’s home directory as tomcat.cert.

Import the Chained or Root Certificates

Normally you receive a chained or root certificate file along with the public key 
certificate.

NOTE:  When you do not receive a chained or root certificate
file along with the public key certificate, skip this section and
instead follow the steps in Import the Public Key Certificate
(page 468).

1. Log in to the Avamar utility node as root.

2. Change your working directory to the Java bin directory:

cd $JAVA_HOME/bin

3. Open the chained or root certificate file in a plain text editor.

The file’s contents will be similar to the following:

-----BEGIN CERTIFICATE-----

MIIDdDCCAt2gAwIBAgIQJyzRkL6Balz4Y8X3iFwiFjANBgkqhkiG9w0BAQUFADCB

uzEkMCIGA1UEBxMbVmFsaUNlcnQgVmFsaWRhdGlvbiBOZXR3b3JrMRcwFQYDVQQK

Ew5WYWxpQ2VydCwgSW5jLjE1MDMGA1UECxMsVmFsaUNlcnQgQ2xhc3MgMyBQb2xp

Y3kgVmFsaWRhdGlvbiBBdXRob3JpdHkxITAfBgNVBAMTGGh0dHA6Ly93d3cudmFs

aWNlcnQuY29tLzEgMB4GCSqGSIb3DQEJARYRaW5mb0B2YWxpY2VydC5jb20wHhcN

MDUwNTAyMTczNDQ4WhcNMTkwNDMwMDkyNDAwWjBsMRowGAYDVQQKExFSU0EgU2Vj

dXJpdHkgSW5jLjEeMBwGA1UEAxMVUlNBIFB1YmxpYyBSb290IENBIHYxMS4wLAYJ
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KoZIhvcNAQkBFh9yc2FrZW9ucm9vdHNpZ25AcnNhc2VjdXJpdHkuY29tMIGfMA0G

CSqGSIb3DQEBAQUAA4GNADCBiQKBgQC0dSVa2EQ740GxqiIKsHATT4f8XYwUU23p

zRe5W6IVpt4jkwDWkgnvTcP6M8PD4OfK6Imal4hAH/c3K/dUIH7YyQZRGAE5Y27G

5klZYKidcFlrfautgVES170MLKFmJqym2FWAfVOibXatRcw7B0S+mP9404jID/Ma

IpRXkH5JjwIDAQABo4HGMIHDMB0GA1UdDgQWBBT1TDF6UQM/LNeLl5lvqHGQq3g9

mzBsBgNVHR8EZTBjMGGgX6BdhltodHRwOi8vd3d3LnJzYXNlY3VyaXR5LmNvbS9w

cm9kdWN0cy9rZW9uL3JlcG9zaXRvcnkvY2VydGlmaWNhdGVfc3RhdHVzL1ZhbGlj

ZXJ0X1Jvb3RfQ0EuY3JsMAwGA1UdEwQFMAMBAf8wDgYDVR0PAQH/BAQDAgGGMBYG

A1UdIAQPMA0wCwYJKoZIhvcNBQYBMA0GCSqGSIb3DQEBBQUAA4GBAJsZWGBPVGmc

xmwH5vM9xqt6r1jjQE44zOFNgwlXp0YR605ss5SjkVlyx4WtjKzSrI4hPLhVJN5f

69F7NxNQMf658Mkkx3Vv6+orEvHFqIw/Hx4uqmdBRpHy/cckaBcEqhJfew7IUFS+

4KRrACEZFnBeaZQlTH8J7UqTThT7By2x

-----END CERTIFICATE-----

-----BEGIN CERTIFICATE-----

MIIC5zCCAlACAQEwDQYJKoZIhvcNAQEFBQAwgbsxJDAiBgNVBAcTG1ZhbGlDZXJ0

IFZhbGlkYXRpb24gTmV0d29yazEXMBUGA1UEChMOVmFsaUNlcnQsIEluYy4xNTAz

BgNVBAsTLFZhbGlDZXJ0IENsYXNzIDMgUG9saWN5IFZhbGlkYXRpb24gQXV0aG9y

aXR5MSEwHwYDVQQDExhodHRwOi8vd3d3LnZhbGljZXJ0LmNvbS8xIDAeBgkqhkiG

9w0BCQEWEWluZm9AdmFsaWNlcnQuY29tMB4XDTk5MDYyNjAwMjIzM1oXDTE5MDYy

NjAwMjIzM1owgbsxJDAiBgNVBAcTG1ZhbGlDZXJ0IFZhbGlkYXRpb24gTmV0d29y

azEXMBUGA1UEChMOVmFsaUNlcnQsIEluYy4xNTAzBgNVBAsTLFZhbGlDZXJ0IENs

YXNzIDMgUG9saWN5IFZhbGlkYXRpb24gQXV0aG9yaXR5MSEwHwYDVQQDExhodHRw

Oi8vd3d3LnZhbGljZXJ0LmNvbS8xIDAeBgkqhkiG9w0BCQEWEWluZm9AdmFsaWNl

cnQuY29tMIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDjmFGWHOjVsQaBalfD

cnWTq8+epvzzFlLWLU2fNUSoLgRNB0mKOCn1dzfnt6td3zZxFJmP3MKS8edgkpfs

2Ejcv8ECIMYkpChMMFp2bbFc893enhBxoYjHW5tBbcqwuI4V7q0zK89HBFx1cQqY

JJgpp0lZpd34t0NiYfPT4tBVPwIDAQABMA0GCSqGSIb3DQEBBQUAA4GBAFa7AliE

Zwgs3x/be0kz9dNnnfS0ChCzycUs4pJqcXgn8nCDQtM+z6lU9PHYkhaM0QTLS6vJ

n0WuPIqpsHEzXcjFV9+vqDWzf4mH6eglkrh/hXqu1rweN1gqZ8mRzyqBPu3GOd/A

PhmcGcwTTYJBtYze4D1gCCAPRX5ron+jjBXu

-----END CERTIFICATE-----

This chained certificate example contains two certificates.

4. Separate the chained or root certificate into individual certificate files using 
the BEGIN CERTIFICATE and END CERTIFICATE designations as the 
boundaries of each certificate. Save each with a distinguishing filename in 
root’s home directory.

For example the chained certificate shown in step 3 is split into two files: 
tomcat_chain1 and tomcat_chain2 and each file is saved in root’s home 
directory.

5. Import the certificate by typing the following on a single command line:

keytool -importcert -trustcacerts -noprompt -file ~/
chained_certN -alias chained_certN

6. At the password prompt, enter the keystore password:

Enter keystore password: changeit

A message appears:

Certificate was added to keystore
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7. Repeat steps 5 and 6 for each individual certificate file derived from the 
chained or root certificate file.

Import the Public Key Certificate

The final step is to import the public key certificate you saved as tomcat.cert.

1. Log in to the Avamar utility node as root.

2. Change your working directory to the Java bin directory:

cd $JAVA_HOME/bin

3. Import the certificate by typing the following on a single command line:

keytool -importcert -trustcacerts -noprompt -file ~/tomcat.cert 
-alias tomcat

4. At the password prompt, enter the keystore password:

Enter keystore password: changeit

A message appears:

Certificate reply was installed in keystore

5. Use dpnctl to restart Avamar Desktop/Laptop:

dpnctl stop dtlt

dpnctl start dtlt

Public key certificate installation is complete.
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Rebranding the Web UI
The Avamar Desktop/Laptop web UI can be modified by replacing the graphic 
located at the top-left of the UI with your company’s logo.

To replace the logo graphic:

1. Create a transparent graphic and save it as "ProductName.png".

A transparent graphic permits the background gradient to be seen behind 
the graphic’s rectangle. The graphic’s dimensions must be: width=222 px 
and height=18 px.

2. Log in to the Avamar utility node as root.

3. Change the working directory:

cd /usr/local/apache-tomcat-5.5.27/webapps/dtlt/images

4. Make a backup copy of the original graphic:

cp ProductName.png ProductName.png_orig

5. Move your logo into the current working directory as ProductName.png.

The new graphic is immediately available.

Deleting a Browser’s Cache

In some web browsers, with certain cache settings, the new graphic may not 
appear right away. To view the new graphic on those browsers, delete cached 
copies of previously viewed files:

• IE6:

Tools > Internet Options > General (tab) > Delete Files

Click OK and click OK again.

• IE 7:

Tools > Delete Browsing History > Temporary Internet Files > Delete 
Files

Click Close, and click OK.

• IE 8:

Tools > Delete Browsing History > Temporary Internet Files > Delete

• Firefox 3.x:

Tools > Clear Private Data > Cache (checkbox) > Clear Private Data 
Now
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• Firefox 3.5.x:

Tools > Clear Recent History > Time range to clear (drop down list; 
choose: Everything) > Details (drop down list; choose: Cache) > Clear 
Now

• Safari 3 and 4 for Mac:

Safari (menu)> Empty Cache > Empty 

Checking the Status of Avamar Desktop/Laptop Server
To check the status of Avamar Desktop/Laptop server:

1. Log in to the Avamar utility node as root.

2. Use dpnctl to obtain status information about the Avamar Desktop/Laptop 
server:

dpnctl status dtlt

Stopping and Starting Avamar Desktop/Laptop Server
If the Avamar Utility node must be restarted, the Avamar Desktop/Laptop server 
restarts automatically. However, the Avamar Desktop/Laptop server can be 
stopped and started manually.

To stop Avamar Desktop/Laptop:

1. Log in to the Avamar utility node as root.

2. Use dpnctl to stop Avamar Desktop/Laptop:

dpnctl stop dtlt

To start Avamar Desktop/Laptop:

1. Log in to the Avamar utility node as root.

2. Use dpnctl to start Avamar Desktop/Laptop:

dpnctl start dtlt
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User Selectable Backup Schedules
Avamar Desktop/Laptop provides the ability to permit your enterprise’s users to 
select a backup schedule. Users can choose a schedule from any of the weekly 
recurrence schedules in their domain. 

When a user chooses a new backup schedule, the user’s client is moved to the 
group associated with the schedule and the schedule is applied. Access to previous 
backup data is not affected by the change.

When the selectable backup schedules feature is enabled for an Avamar server, it 
applies to clients and groups in all domains and sub-domains on the server. Clients 
and groups that meet the following requirements will have access to the feature.

Two configuration tasks must be completed in order to use this feature:

• Enable Selectable Backup Schedules (page 472)
• Configure Selectable Backup Schedules (page 472)

REQUIREMENT DESCRIPTION

Feature enabled by administrator The feature is, by default, disabled. It 
must be enabled and the Avamar 
Desktop/Laptop server process must be 
restarted before it can be used.

Single domain Only groups within the same domain as 
a client are displayed. A sub-domain is 
considered to be a separate domain.

No multiple group memberships Clients that are a member of more than 
one group cannot access this feature.

Groups must be enabled Only the schedules for enabled groups 
are listed.

"Weekly" recurrence schedules only Only weekly recurrence group 
schedules are listed, and only clients 
that currently have a weekly recurrence 
schedule can access this feature.

At least two different schedules This feature will only be visible to 
qualified clients if there are at least two 
different weekly recurrence schedules 
in the domain.

Duplicate schedules only shown once If two or more groups in a domain 
share the same weekly recurrence 
schedule, only the schedule for the first 
group will be included in the selection 
list.
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Enable Selectable Backup Schedules

To enable selectable backup schedules:

1. Log in to the Avamar utility node as root.

2. Change your current working directory:

cd /usr/local/avamar/etc

3. Open the Avamar Desktop/Laptop properties file in a plain text editor, such 
as vi:

vi dtlt.properties

4. Edit the value of the selectable backup schedules key:

Change:

userSelectableBackupTime=false

To:

userSelectableBackupTime=true

5. Save and close the file.

6. Restart the Avamar Desktop/Laptop server:

dpnctl stop dtlt

dpnctl start dtlt

Configure Selectable Backup Schedules

Once enabled, the selectable backup schedules feature will display a button that 
gives access to a schedule list. This feature is enabled in each domain on the 
server, if the domain has groups that meet the requirements listed in the table in 
User Selectable Backup Schedules (page 471). Any client in an enabled domain 
that meets the listed requirements will have access to the selection list.

To simplify administration of this feature, and to decrease user problems due to 
changed datasets, the following best practices are recommended:

• Place clients that should not have access to this feature in a group that does 
not use a weekly recurrence schedule.

Only clients in a group that has a weekly recurrence schedule are able to view 
a domain’s selection list. To prevent clients from accessing this feature, place 
them in a group with a schedule that uses one of the other recurrence types: 
Daily, Monthly, On-Demand.

• Create a special domain or sub-domain to use this feature and limit it to clients 
with the same dataset and retention policy.

A domain’s selection list includes the schedules for all qualified groups in the 
domain. If the domain contains groups with various datasets and retention 
policies, the list could include the schedule for a group that has a different 
dataset or retention policy than a user’s current group. By selecting this 
schedule the users could unintentionally change their client’s dataset and 
retention policy.
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To create a domain and enable groups to effectively use the selectable backup 
schedules feature:

1. Start Avamar Administrator, as described in Starting Avamar Administrator 
(page 27).

2. Create a domain or sub-domain, as described in Adding a New Domain 
(page 34)

3. Create a weekly schedule, as described in Creating a New Schedule (page 
114).

To create a schedule with a weekly recurrence, in Repeat this schedule, 
select Weekly.

4. Copy the schedule, as described in Copying a Schedule (page 117).

Create a copy for each schedule time that should be on the schedule list.

5. Edit each schedule copy to change the start time to one of the start times 
that should be on the schedule list.

Editing a schedule is described in Editing a Schedule (page 116).

6. Create a common dataset for all clients in the domain.

Creating a dataset is described in Creating a New Dataset (page 104). Only 
one dataset should be created. All clients will use this common dataset.

7. Create a common retention policy for all clients in the domain.

Creating a retention policy is described in Creating a New Retention Policy 
(page 122). Only one retention policy should be created. All clients will use 
this common retention policy.

8. For each schedule you created, create a new group.

Creating a group is described in Adding a New Group (page 133). While 
creating each group, do the following:

(a) On the first screen of the New Group wizard, clear Disabled.

(b) On the second screen of the New Group wizard, select the common 
dataset you created.

(c) On the third screen of the New Group wizard, select one of the 
schedules you created.

Do not assign a schedule to more than one group.

(d) On the fourth screen of the New Group wizard, select the common 
retention policy you created.

(e) On the fifth screen of the New Group wizard, assign clients to the 
group.

Assigning clients to every group is not required. However, all clients 
that will use the selectable backup schedules feature should be 
assigned to a group in the domain. Users will be able to use the feature 
to move their client to the group with the backup schedule they want.

(f) Click Finish.

The New Group wizard closes and the new group appears in the Policy 
window.
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The selectable backup schedules domain is ready. When a user with a client in that 
domain navigates to the Backup page of the Avamar Desktop/Laptop web UI, the 
Change Backup Time button appears. Use of the feature is described in the web 
UI help.

Client Installation using Systems Management Tools
The recommended method for installing the Avamar Desktop/Laptop client 
software on large numbers of computers is to use a Systems management tool. 
Using a Systems management tool you can remotely push-install the software on 
large numbers of computers in a short amount of time.

Remote installation is described in Remote Push Install of the Client Software 
(page 408).

Local Installation of the Client 
The Avamar Desktop/Laptop software can also be installed on desktops and 
laptops by running the installer locally. This method launches a graphical 
installation interface that walks you through the installation. At the conclusion of 
the installation the computer will be ready to register and activate with an Avamar 
server.

The disadvantages of using local installation instead of installing the software 
using a Systems management tool are:

• Individual, local installs can be very time consuming when performed on 
thousands of desktops and laptops.

• Unlike many Systems management tools, local installs do not provide a list 
which can be used when you assign computers to groups as described in the 
Avamar Activation Manager administrator’s guide.

Local installation, upgrading, and uninstalling of Avamar Desktop/Laptop is 
described in the Avamar Backup Clients User Guide.
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Client Log Location
The local client log provides information about backup and restore operations on 
that client.

Windows Computers

On Windows computers, the Avamar client log is located at:

%APPDATA%\avscc.log

Mac Computers

On Mac computers, the client log is located at:

$HOME/avscc.log

Mac Clients with Entourage
Microsoft Entourage is a Mac email client that uses Microsoft Database Daemon to 
manage its database. In order to protect the Entourage data, both Entourage and 
the Microsoft Database Daemon must be shut down during backups. The Avamar 
client software provides scripts to shut down Entourage and the Microsoft 
Database Daemon before running a backup and restarting the Microsoft Database 
Daemon when the backup is complete. Entourage must be started manually.

The scripts are configured to run through dataset policies. Mac clients running 
Entourage should be assigned to groups using a dataset with these policies. Other 
clients should be assigned to groups using a dataset without these policies.

IMPORTANT:  Assigning Mac clients running Entourage to
groups without these policies causes the Entourage database
to be skipped during backups and errors to appear in the cli-
ent logs.

Creating the Dataset

All groups for Mac clients running Entourage should use a dataset that provides 
the necessary policies. 

To create a dataset with the required policies:

1. Create a new dataset as described in Creating a New Dataset (page 104).

The plug-in type must be Macintosh Desktop/Laptop.

2. Select the dataset Options tab.

3. Select Show Advanced Options.

4. In the Pre-Script section of that tab, in Run user-defined script at 
beginning of backup, type:

shutdown.sh
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5. In the Pre-Script section of that tab, select Abort backup if script fails.

6. In the Post-Script section of that tab, in Run user-defined script at end 
of backup, type:

startup.sh

7. In the Post-Script section of that tab, select Exit process with script 
failure exitcode.

8. When all other configuration for the dataset is complete, click OK.

Assign this dataset, or one with the same changes on the Options tab, to each 
group for Mac clients with Entourage.

Client Backup Message

Mac clients that are assigned to a group that uses a dataset configured for Mac 
clients with Entourage will see a message whenever a scheduled or manual 
backup task is initiated.

The options with this message are in the following table.

OPTION RESULT

Cancel The Microsoft Database Daemon is not shutdown and the 
backup task is cancelled.

OK The Microsoft Database Daemon is immediately terminated, 
Entourage is shutdown, and the backup task is started. At the 
conclusion of the backup the Microsoft Database Daemon is 
restarted. Manual startup of Entourage is required.

No Action The message is displayed for 30 seconds, after which the 
Microsoft Database Daemon is terminated, Entourage is 
shutdown, and the backup task is started. At the conclusion of 
the backup the Microsoft Database Daemon is restarted. Manual 
startup of Entourage is required.
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User Accounts. Additionally, the following user accounts are commonly used for 
various system administration and maintenance tasks:

• root
• admin
• dpn

The admin and dpn user accounts require authentication by way of Secure Shell 
(SSH).

Starting the Command Shell Sessions
This example procedure describes how to log into an Avamar node as user admin 
via SSH. 

1. Open a command shell.

2. Log into the desired node as user admin.

3. Load the admin OpenSSH key by typing:

ssh-agent bash

ssh-add ~admin/.ssh/admin_key

You are prompted to type a passphrase.

4. Type the admin user account passphrase.
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Switching User IDs
Switch User to root You can easily switch to user root using the su command and switch back to the 

previous login ID with the exit command.

Switch User to dpn When asked to switch to the dpn user account, you will need to perform the 
following:

1. Switch user to the dpn user account by typing:

su - dpn

2. When prompted for a password, type the dpn password and press ENTER.

3. Load the dpn OpenSSH key by typing:

ssh-agent bash

ssh-add ~dpn/.ssh/dpnid

TIP:  Type whoami in any command shell to return your cur-
rent user account (login ID).
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Important Terms and Concepts
Plug-in options provide additional control of backups and restores. These options 
are context-sensitive to both the operation being performed and the specific plug-
in selected for that operation.

These options can be specified during on-demand backup and restore operations, 
or persistently set within datasets for all future scheduled backups.

Backup or restore option dialog boxes automatically appear when initiating on-
demand backups or restores, respectively.

When creating a new dataset, the new dataset wizard offers an opportunity to 
configure persistent backup plug-in option settings for that dataset.

To view or set plug-in options for an existing dataset: 

1. Start Avamar Administrator.

2. Select Tools > Manage Datasets…

The Manage All Datasets window appears.

3. Select a dataset from the list and click Edit. 

The Edit Dataset dialog box appears.

4. Click the Options tab.

Plug-in options can be set two ways:

• By using the graphical controls
• By typing option names and values as free text

Setting Plug-in Options by Using Graphical Controls. By clicking the 
Options tab and selecting a plug-in you can display all current options for that 
specific plug-in. 

These settings are represented by graphical controls (for example, options, radio 
buttons, list boxes, and so forth).
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The advantage to setting plug-in options by using graphical controls is that you 
cannot type an option name or value incorrectly. Only valid states are shown.

Setting Show Advanced Options expands this list even further by displaying 
options that are normally only of interest to persons debugging an Avamar 
system. These advanced options are shown in red.

Typing Option Names and Values as Free Text. You can also set plug-in 
options by typing option names and values as free text. 

Clicking More expands the dialog box to include Enter Attribute and Attribute 
Value fields, which can be used to input plug-in options and values as free text. 

However, it must be understood that no error checking or validation is performed 
on these free text entries and that free text entries override settings made by way 
of the graphical controls. 
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AIX File System Plugin Options
This topic lists and describes the plugin options available for use with the Avamar 
AIX File System plugin. 

Backup Options

FIELD/OPTION DESCRIPTION

Backup label Assigns this descriptive label to backup.

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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F
IL

E
S

Y
S

T
E

M
 T

R
A

V
E

R
S

A
L

Do not traverse 
any mounts

If selected, no mount points are traversed during 
this backup.

Traverse fixed-
disk mounts

If selected, only fixed-disk filesystem mount points 
are traversed during this backup.

Traverse fixed-
disk and remote 
network mounts

If selected, both fixed-disk and NFS network mount 
points are traversed during this backup.

Force traversal of 
specified file system 
type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should be traversed during this backup.

Force non-traversal 
of specified file 
system type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should not be traversed during this backup.

P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of backup

Runs user-defined script at beginning of backup 
session.
IMPORTANT:  Script must be located in 
/usr/local/avamar/etc/scripts.

Abort backup if 
script fails

If selected, stop backup if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
backup

Runs user-defined script at end of backup session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L

IE
N

T
 C

A
C

H
E

 O
P

T
IO

N
S

Check client-side 
caches and report 
inconsistencies

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Maximum client file 
cache size (MBs)

Specifies maximum client file cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client file cache).

Maximum client hash 
cache size (MBs)

Specifies maximum client hash cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client hash cache).

FIELD/OPTION DESCRIPTION
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A
D

V
A

N
C

E
D

 O
P

T
IO

N
S Client-side flag file Specifies path to a flag file on the client, which 

contains additional option settings.

Network usage 
throttle (Mbps)

Specifies a setting that reduces network usage to 
specified rate, expressed as megabits/second (for 
example, 0 = unrestricted, 50% of a T1 = 0.772).

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve backup performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION
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Restore Options

FIELD/OPTION DESCRIPTION

Overwrite existing files Controls behavior when file to be restored already 
exists. One of the following:

Never

Always

Generate New Name

If Modified

If Newer

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of restore

Runs user-defined script at beginning of restore 
session.
IMPORTANT:  Script must be located in 
/usr/local/avamar/etc/scripts.

Abort restore if 
script fails

If selected, stop restore if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
restore

Runs user-defined script at end of restore session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L

IE
N

T
 C

A
C

H
E

 O
P

T
IO

N
S Check client-side 

caches and report 
inconsistencies

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Rebuild client-side 
caches from most 
recent backup

Does not restore data.  If selected, the contents of 
last backup are used to re-create client-side file 
cache.

A
D

V
A

N
C

E
D

 O
P

T
IO

N
S

Do not descend 
into subdirectories

If selected, restore only the specified top-level 
directory; do not restore any subdirectories.

Recreate original 
path beneath 
target directory

If selected, re-create the original path to files and 
directories beneath the specified target directory.
For example, if restoring /usr/MyDir/MyFile to 
/tmp and you selected this option, the full path to 
the restored file will be /tmp/usr/MyDir/MyFile. 

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve restore performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION
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Avamar FreeBSD File System Plugin Options
This topic lists and describes the plugin options available for use with the Avamar 
FreeBSD File System plugin.

Backup Options

FIELD/OPTION DESCRIPTION

Backup label Assigns this descriptive label to backup.

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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F
IL

E
S

Y
S

T
E

M
  

T
R

A
V

E
R

S
A

L

Do not traverse 
any mounts

If selected, no mount points are traversed during 
this backup.

Traverse fixed-
disk mounts

If selected, only fixed-disk filesystem mount points 
are traversed during this backup.

Traverse fixed-
disk and remote 
network mounts

If selected, both fixed-disk and NFS network mount 
points are traversed during this backup.

Force traversal of 
specified file system 
type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should be traversed during this backup.

Force non-traversal 
of specified file 
system type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should not be traversed during this backup.

P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of backup

Runs user-defined script at beginning of backup 
session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Abort backup if 
script fails

If selected, stop backup if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
backup

Runs user-defined script at end of backup session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L

IE
N

T
 C

A
C

H
E

 O
P

T
IO

N
S

Check client-side 
caches and report 
inconsistencies

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Maximum client file 
cache size (MBs)

Specifies maximum client file cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client file cache).

Maximum client hash 
cache size (MBs)

Specifies maximum client hash cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client hash cache).

FIELD/OPTION DESCRIPTION
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A
D

V
A

N
C

E
D

 O
P

T
IO

N
S Client-side flag file Specifies path to a flag file on the client, which 

contains additional option settings.

Network usage 
throttle (Mbps)

Specifies a setting that reduces network usage to 
specified rate, expressed as megabits/second (for 
example, 0 = unrestricted, 50% of a T1 = 0.772).

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve backup performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION
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Restore Options

FIELD/OPTION DESCRIPTION

Overwrite existing files Controls behavior when file to be restored already 
exists. One of the following:

Never

Always

Generate New Name

If Modified

If Newer

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of restore

Runs user-defined script at beginning of restore 
session.
IMPORTANT:  Script must be located in 
/usr/local/avamar/etc/scripts.

Abort restore if 
script fails

If selected, stop restore if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
restore

Runs user-defined script at end of restore session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L

IE
N

T
 C

A
C

H
E

 O
P

T
IO

N
S Check client-side 

caches and report 
inconsistencies

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Rebuild client-side 
caches from most 
recent backup

Does not restore data.  If selected, the contents of 
last backup are used to re-create client-side file 
cache.

A
D

V
A

N
C

E
D

 O
P

T
IO

N
S

Do not descend 
into subdirectories

If selected, restore only the specified top-level 
directory; do not restore any subdirectories.

Recreate original 
path beneath 
target directory

If selected, re-create the original path to files and 
directories beneath the specified target directory.
For example, if restoring /usr/MyDir/MyFile to 
/tmp and you selected this option, the full path to 
the restored file will be /tmp/usr/MyDir/MyFile. 

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve restore performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION
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HP-UX File System Plugin Options
This topic lists and describes the plugin options available for use with the Avamar 
HP-UX File System plugin.

Backup Options

FIELD/OPTION DESCRIPTION

Backup label Assigns this descriptive label to backup.

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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F
IL

E
S

Y
S

T
E

M
  

T
R

A
V

E
R

S
A

L

Do not traverse 
any mounts

If selected, no mount points are traversed during 
this backup.

Traverse fixed-
disk mounts

If selected, only fixed-disk filesystem mount points 
are traversed during this backup.

Traverse fixed-
disk and remote 
network mounts

If selected, both fixed-disk and NFS network mount 
points are traversed during this backup.

Force traversal of 
specified file system 
type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should be traversed during this backup.

Force non-traversal 
of specified file 
system type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should not be traversed during this backup.

P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of backup

Runs user-defined script at beginning of backup 
session.
IMPORTANT:  Script must be located in
/opt/AVMRclnt/etc/scripts.

Abort backup if 
script fails

If selected, stop backup if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
backup

Runs user-defined script at end of backup session.
IMPORTANT:  Script must be located in
/opt/AVMRclnt/etc/scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L

IE
N

T
 C

A
C

H
E

 O
P

T
IO

N
S

Check client-side 
caches and report 
inconsistencies

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Maximum client file 
cache size (MBs)

Specifies maximum client file cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client file cache).

Maximum client hash 
cache size (MBs)

Specifies maximum client hash cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client hash cache).

FIELD/OPTION DESCRIPTION
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Restore Options

A
D

V
A

N
C

E
D

 O
P

T
IO

N
S Client-side flag file Specifies path to a flag file on the client, which 

contains additional option settings.

Network usage 
throttle (Mbps)

Specifies a setting that reduces network usage to 
specified rate, expressed as megabits/second (for 
example, 0 = unrestricted, 50% of a T1 = 0.772).

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve backup performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION

Overwrite existing files Controls behavior when file to be restored already 
exists. One of the following:

Never

Always

Generate New Name

If Modified

If Newer

FIELD/OPTION DESCRIPTION
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L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.

P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of restore

Runs user-defined script at beginning of restore 
session.
IMPORTANT:  Script must be located in
/opt/AVMRclnt/etc/scripts.

Abort restore if 
script fails

If selected, stop restore if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
restore

Runs user-defined script at end of restore session.
IMPORTANT:  Script must be located in
/opt/AVMRclnt/etc/scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.
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C
L

IE
N

T
 C

A
C

H
E

 O
P

T
IO

N
S Check client-side 

caches and report 
inconsistencies

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Rebuild client-side 
caches from most 
recent backup

Does not restore data.  If selected, the contents of 
last backup are used to re-create client-side file 
cache.

A
D

V
A

N
C

E
D

 O
P

T
IO

N
S

Do not descend 
into subdirectories

If selected, restore only the specified top-level 
directory; do not restore any subdirectories.

Recreate original 
path beneath 
target directory

If selected, re-create the original path to files and 
directories beneath the specified target directory.
For example, if restoring /usr/MyDir/MyFile to 
/tmp and you selected this option, the full path to 
the restored file will be /tmp/usr/MyDir/MyFile. 

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve restore performance under 
certain circumstances.
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Linux File System Plugin Options
This topic lists and describes the plugin options available for use with the Avamar 
Linux File System plugin. 

Backup Options

FIELD/OPTION DESCRIPTION

Backup label Assigns this descriptive label to backup.

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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F
IL

E
S

Y
S

T
E

M
 T

R
A

V
E

R
S

A
L

Do not traverse 
any mounts

If selected, no mount points are traversed during 
this backup.

Traverse fixed-
disk mounts

If selected, only fixed-disk filesystem mount points 
are traversed during this backup.

Traverse fixed-
disk and remote 
network mounts

If selected, both fixed-disk and NFS network mount 
points are traversed during this backup.

Force traversal of 
specified file system 
type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should be traversed during this backup.

Force non-traversal 
of specified file 
system type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should not be traversed during this backup.

P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of backup

Runs user-defined script at beginning of backup 
session.
IMPORTANT:  Script must be located in 
/usr/local/avamar/etc/scripts.

Abort backup if 
script fails

If selected, stop backup if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
backup

Runs user-defined script at end of backup session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L

IE
N

T
 C

A
C

H
E

 O
P

T
IO

N
S

Check client-side 
caches and report 
inconsistencies

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Maximum client file 
cache size (MBs)

Specifies maximum client file cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client file cache).

Maximum client hash 
cache size (MBs)

Specifies maximum client hash cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client hash cache).
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A
D

V
A

N
C

E
D

 O
P

T
IO

N
S Client-side flag file Specifies path to a flag file on the client, which 

contains additional option settings.

Network usage 
throttle (Mbps)

Specifies a setting that reduces network usage to 
specified rate, expressed as megabits/second (for 
example, 0 = unrestricted, 50% of a T1 = 0.772).

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve backup performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION
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Restore Options

FIELD/OPTION DESCRIPTION

Overwrite existing files Controls behavior when file to be restored already 
exists. One of the following:

Never

Always

Generate New Name

If Modified

If Newer

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of restore

Runs user-defined script at beginning of restore 
session.
IMPORTANT:  Script must be located in 
/usr/local/avamar/etc/scripts.

Abort restore if 
script fails

If selected, stop restore if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
restore

Runs user-defined script at end of restore session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L

IE
N

T
 C

A
C

H
E

 O
P

T
IO

N
S Check client-side 

caches and report 
inconsistencies

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Rebuild client-side 
caches from most 
recent backup

Does not restore data. If selected, the contents of 
last backup are used to re-create client-side file 
cache.

A
D

V
A

N
C

E
D

 O
P

T
IO

N
S

Do not descend 
into subdirectories

If selected, restore only the specified top-level 
directory; do not restore any subdirectories.

Recreate original 
path beneath 
target directory

If selected, re-create the original path to files and 
directories beneath the specified target directory.
For example, if restoring /usr/MyDir/MyFile to 
/tmp and you selected this option, the full path to 
the restored file will be /tmp/usr/MyDir/MyFile. 

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve restore performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION
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Macintosh File System Plugin Options
This topic lists and describes the plugin options available for use with the Avamar 
Macintosh File System plugin. 

Backup Options

FIELD/OPTION DESCRIPTION

Backup label Assigns this descriptive label to backup.

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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F
IL

E
S

Y
S

T
E

M
  

T
R

A
V

E
R

S
A

L

Do not traverse 
any mounts

If selected, no mount points are traversed during 
this backup.

Traverse fixed-
disk mounts

If selected, only fixed-disk filesystem mount points 
are traversed during this backup.

Traverse fixed-
disk and remote 
network mounts

If selected, both fixed-disk and NFS network mount 
points are traversed during this backup.

Force traversal of 
specified file system 
type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should be traversed during this backup.

Force non-traversal 
of specified file 
system type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should not be traversed during this backup.

P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of backup

Runs user-defined script at beginning of backup 
session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Abort backup if 
script fails

If selected, stop backup if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
backup

Runs user-defined script at end of backup session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L

IE
N

T
 C

A
C

H
E

 O
P

T
IO

N
S

Check client-side 
caches and report 
inconsistencies

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Maximum client file 
cache size (MBs)

Specifies maximum client file cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client file cache).

Maximum client hash 
cache size (MBs)

Specifies maximum client hash cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client hash cache).

FIELD/OPTION DESCRIPTION
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A
D

V
A

N
C

E
D

 O
P

T
IO

N
S Client-side flag file Specifies path to a flag file on the client, which 

contains additional option settings.

Network usage 
throttle (Mbps)

Specifies a setting that reduces network usage to 
specified rate, expressed as megabits/second (for 
example, 0 = unrestricted, 50% of a T1 = 0.772).

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve backup performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION
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Restore Options

FIELD/OPTION DESCRIPTION

Overwrite existing files Controls behavior when file to be restored already 
exists. One of the following:

Never

Always

Generate New Name

If Modified

If Newer

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of restore

Runs user-defined script at beginning of restore 
session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Abort restore if 
script fails

If selected, stop restore if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
restore

Runs user-defined script at end of restore session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L

IE
N

T
 C

A
C

H
E

 O
P

T
IO

N
S Check client-side 

caches and report 
inconsistencies

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Rebuild client-side 
caches from most 
recent backup

Does not restore data.  If selected, the contents of 
last backup are used to re-create client-side file 
cache.

A
D

V
A

N
C

E
D

 O
P

T
IO

N
S

Do not descend 
into subdirectories

If selected, restore only the specified top-level 
directory; do not restore any subdirectories.

Recreate original 
path beneath 
target directory

If selected, re-create the original path to files and 
directories beneath the specified target directory.
For example, if restoring /usr/MyDir/MyFile to 
/tmp and you selected this option, the full path to 
the restored file will be /tmp/usr/MyDir/MyFile. 

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve restore performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION
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NetWare File System Plugin Options
This topic lists and describes the plugin options available for use with the Avamar 
NetWare File System plugin. 

Backup Options

FIELD/OPTION DESCRIPTION

S
M

S
 A

U
T

H
E

N
T

IC
A

T
IO

N Server login ID SMS login username. For example, 
CN=admin.O=HOSTNAME_CTX.

Server password Server login ID password.

Snapshot stored-on pool Specifies snapshot stored-on pool name.

Backup label Assigns this descriptive label to backup.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  506



 NetWare File System Plugin Options
APPENDIX B — PLUGIN OPTIONS
L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.

F
IL

E
S

Y
S

T
E

M
  

T
R

A
V

E
R

S
A

L

Do not traverse 
any mounts

If selected, no mount points are traversed during 
this backup.

Traverse fixed-
disk mounts

If selected, only fixed-disk filesystem mount points 
are traversed during this backup.

Traverse fixed-
disk and remote 
network mounts

If selected, both fixed-disk and NFS network mount 
points are traversed during this backup.

Force traversal of 
specified file system 
type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should be traversed during this backup.

Force non-traversal 
of specified file 
system type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should not be traversed during this backup.
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P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of backup

Runs user-defined script at beginning of backup 
session.
IMPORTANT:  Script must be located in 
SYS:AVAMAR\etc\scripts.

Abort backup if 
script fails

If selected, stop backup if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
backup

Runs user-defined script at end of backup session.
IMPORTANT:  Script must be located in 
SYS:AVAMAR\etc\scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L
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N
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A
C

H
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P

T
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N
S

Check client-side 
caches and report 
inconsistencies

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Maximum client file 
cache size (MBs)

Specifies maximum client file cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client file cache).

Maximum client hash 
cache size (MBs)

Specifies maximum client hash cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client hash cache).

A
D

V
A

N
C

E
D

 O
P

T
IO

N
S

Client-side flag file Specifies path to a flag file on the client, which 
contains additional option settings.

Network usage 
throttle (Mbps)

Specifies a setting that reduces network usage to 
specified rate, expressed as megabits/second (for 
example, 0 = unrestricted, 50% of a T1 = 0.772).

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve backup performance under 
certain circumstances.

Suspend NSS 
Compression

If selected, NSS compression is suspended during 
backups and automatically resumed following 
backups.

FIELD/OPTION DESCRIPTION
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Restore Options

FIELD/OPTION DESCRIPTION

S
M

S
 A

U
T

H
E

N
T

IC
A

T
IO

N Server login ID SMS login username. For example, 
CN=admin.O=HOSTNAME_CTX.

Server password Server login ID password.

Overwrite existing files Controls behavior when file to be restored already 
exists. One of the following:

Never

Always

Generate New Name

If Modified

If Newer
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L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.

P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of restore

Runs user-defined script at beginning of restore 
session.
IMPORTANT:  Script must be located in 
SYS:AVAMAR\etc\scripts.

Abort restore if 
script fails

If selected, stop restore if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
restore

Runs user-defined script at end of restore session.
IMPORTANT:  Script must be located in 
SYS:AVAMAR\etc\scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

FIELD/OPTION DESCRIPTION
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C
L

IE
N

T
 C

A
C

H
E

 O
P

T
IO

N
S Check client-side 

caches and report 
inconsistencies

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Rebuild client-side 
caches from most 
recent backup

Does not restore data.  If selected, the contents of 
last backup are used to re-create client-side file 
cache.

A
D

V
A

N
C

E
D
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P

T
IO

N
S

Do not descend 
into subdirectories

If selected, restore only the specified top-level 
directory; do not restore any subdirectories.

Recreate original 
path beneath 
target directory

If selected, re-create the original path to files and 
directories beneath the specified target directory.
For example, if restoring F:\Temp\MyFile.txt to 
C:\Temp and you selected this option, the full path 
to the restored file will be 
C:\Temp\F\Temp\MyFile.txt. 

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve restore performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION
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SCO OpenServer File System Plugin Options
This topic lists and describes the plugin options available for use with the Avamar 
SCO OpenServer File System plugin. 

Backup Options

FIELD/OPTION DESCRIPTION

Backup label Assigns this descriptive label to backup.

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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F
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L

Do not traverse 
any mounts

If selected, no mount points are traversed during 
this backup.

Traverse fixed-
disk mounts

If selected, only fixed-disk filesystem mount points 
are traversed during this backup.

Traverse fixed-
disk and remote 
network mounts

If selected, both fixed-disk and NFS network mount 
points are traversed during this backup.

Force traversal of 
specified file system 
type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should be traversed during this backup.

Force non-traversal 
of specified file 
system type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should not be traversed during this backup.

P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of backup

Runs user-defined script at beginning of backup 
session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Abort backup if 
script fails

If selected, stop backup if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
backup

Runs user-defined script at end of backup session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L

IE
N

T
 C

A
C

H
E
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P

T
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N
S

Check client-side 
caches and report 
inconsistencies

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Maximum client file 
cache size (MBs)

Specifies maximum client file cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client file cache).

Maximum client hash 
cache size (MBs)

Specifies maximum client hash cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client hash cache).
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A
D

V
A

N
C

E
D

 O
P

T
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N
S Client-side flag file Specifies path to a flag file on the client, which 

contains additional option settings.

Network usage 
throttle (Mbps)

Specifies a setting that reduces network usage to 
specified rate, expressed as megabits/second (for 
example, 0 = unrestricted, 50% of a T1 = 0.772).

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve backup performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION
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Restore Options

FIELD/OPTION DESCRIPTION

Overwrite existing files Controls behavior when file to be restored already 
exists. One of the following:

Never

Always

Generate New Name

If Modified

If Newer

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of restore

Runs user-defined script at beginning of restore 
session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Abort restore if 
script fails

If selected, stop restore if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
restore

Runs user-defined script at end of restore session.
IMPORTANT:  Script must be located in
/usr/local/avamar/etc/scripts.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L

IE
N

T
 C

A
C

H
E

 O
P

T
IO

N
S Check client-side 

caches and report 
inconsistencies

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Rebuild client-side 
caches from most 
recent backup

Does not restore data.  If selected, the contents of 
last backup are used to re-create client-side file 
cache.

A
D

V
A

N
C

E
D
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P

T
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N
S

Do not descend 
into subdirectories

If selected, restore only the specified top-level 
directory; do not restore any subdirectories.

Recreate original 
path beneath 
target directory

If selected, re-create the original path to files and 
directories beneath the specified target directory.
For example, if restoring /usr/MyDir/MyFile to 
/tmp and you selected this option, the full path to 
the restored file will be /tmp/usr/MyDir/MyFile. 

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve restore performance under 
certain circumstances.
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Solaris File System Plugin Options
This topic lists and describes the plugin options available for use with the Avamar 
Solaris File System plugin. 

Backup Options

FIELD/OPTION DESCRIPTION

Backup label Assigns this descriptive label to backup.

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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F
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Do not traverse 
any mounts

If selected, no mount points are traversed during 
this backup.

Traverse fixed-
disk mounts

If selected, only fixed-disk filesystem mount points 
are traversed during this backup.

Traverse fixed-
disk and remote 
network mounts

If selected, both fixed-disk and NFS network mount 
points are traversed during this backup.

Force traversal of 
specified file system 
type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should be traversed during this backup.

Force non-traversal 
of specified file 
system type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should not be traversed during this backup.

P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of backup

Runs user-defined script at beginning of backup 
session.
IMPORTANT:  Script must be located in
/opt/AVMRclnt/etc/scripts on HP-UX and Solaris.

Abort backup if 
script fails

If selected, stop backup if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
backup

Runs user-defined script at end of backup session.
IMPORTANT:  Script must be located in
/opt/AVMRclnt/etc/scripts on HP-UX and Solaris.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L

IE
N

T
 C

A
C

H
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P

T
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N
S

Check client-side 
caches and report 
inconsistencies

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Maximum client file 
cache size (MBs)

Specifies maximum client file cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client file cache).

Maximum client hash 
cache size (MBs)

Specifies maximum client hash cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client hash cache).
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A
D

V
A

N
C

E
D

 O
P

T
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N
S Client-side flag file Specifies path to a flag file on the client, which 

contains additional option settings.

Network usage 
throttle (Mbps)

Specifies a setting that reduces network usage to 
specified rate, expressed as megabits/second (for 
example, 0 = unrestricted, 50% of a T1 = 0.772).

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve backup performance under 
certain circumstances.
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Restore Options

FIELD/OPTION DESCRIPTION

Overwrite existing files Controls behavior when file to be restored already 
exists. One of the following:

Never

Always

Generate New Name

If Modified

If Newer

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of restore

Runs user-defined script at beginning of restore 
session.
IMPORTANT:  Script must be located in
/opt/AVMRclnt/etc/scripts on HP-UX and Solaris.

Abort restore if 
script fails

If selected, stop restore if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T Run user-defined 
script at end of 
restore

Runs user-defined script at end of restore session.
IMPORTANT:  Script must be located in
/opt/AVMRclnt/etc/scripts on HP-UX and Solaris.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L

IE
N

T
 C

A
C

H
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P

T
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N
S Check client-side 

caches and report 
inconsistencies

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Rebuild client-side 
caches from most 
recent backup

Does not restore data.  If selected, the contents of 
last backup are used to re-create client-side file 
cache.

A
D

V
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N
C

E
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P

T
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N
S

Do not descend 
into subdirectories

If selected, restore only the specified top-level 
directory; do not restore any subdirectories.

Recreate original 
path beneath 
target directory

If selected, re-create the original path to files and 
directories beneath the specified target directory.
For example, if restoring /usr/MyDir/MyFile to 
/tmp and you selected this option, the full path to 
the restored file will be /tmp/usr/MyDir/MyFile. 

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve restore performance under 
certain circumstances.
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Windows File System Plug-in Options
This topic lists and describes the plug-in options available for use with the Avamar 
Windows File System plug-in. 

Backup Options

FIELD/OPTION DESCRIPTION

Backup label Assigns this descriptive label to backup.

L
O

G
G

IN
G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.

Backup Windows 
System State

If selected, include Windows system state 
information so that this backup can be used for 
future disaster recovery.
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Do not traverse 
any mounts

If selected, no mount points are traversed during 
this backup.

Traverse fixed-
disk mounts

If selected, only fixed-disk filesystem mount points 
are traversed during this backup.

Traverse fixed-
disk and remote 
network mounts

If selected, both fixed-disk and NFS network mount 
points are traversed during this backup.

Force traversal of 
specified file system 
type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should be traversed during this backup.

Force non-traversal 
of specified file 
system type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should not be traversed during this backup.

P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of backup

Runs user-defined script at beginning of backup 
session.
IMPORTANT:  Script must be located in 
C:\Program Files\avs\etc\scripts on Windows and 
must have a .bat, .js or .vbs extension. 

Abort backup if 
script fails

If selected, stop backup if script returns a non-zero 
status code.

-S
C

R
IP

T
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F
T

E
R

 F
R

E
E

Z
E Run user-defined 

script after 
volumes have 
been frozen

Runs user-defined script after volumes have been 
frozen.
IMPORTANT:  Script must be located in 
C:\Program Files\avs\etc\scripts on Windows and 
must have a .bat, .js or .vbs extension. 

Abort backup if 
script fails

If selected, stop backup if script returns a non-zero 
status code.

P
O

S
T

-S
C

R
IP

T

Run user-defined 
script at end of 
backup

Runs user-defined script at end of backup session.
IMPORTANT:  Script must be located in 
C:\Program Files\avs\etc\scripts on Windows and 
must have a .bat, .js or .vbs extension. 

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.
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V
O

L
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E
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Method to freeze 
volumes

One of the following:

Best

Microsoft VSS

OTM

None

OTM freezewait: File 
activity quiescent 
time

OTM only: Number of seconds that volume(s) must 
be quiescent to establish a freeze.

OTM freezetimeout: 
Maximum time to 
wait when trying to 
freeze volume(s)"

OTM only: Maximum number of seconds to wait for 
volumes to freeze.

OTM 
freezecachesize: 
Size in MBs of OTM 
transaction cache

OTM only: Size of disk transaction cache.  Negative 
value is fraction of used disk space (for example, 
-50 is 1/50th or 2%).

OTM freezecachedir: 
Folder to use for the 
OTM transaction 
cache

OTM only: Path of a folder to store the OTM 
transaction cache.  Default location is the Avamar 
VAR folder.

Freeze exclude 
devices

Comma separated list of devices (for example, 
\Device\mydevice\*) to exclude from volume 
freezing.

Freeze exclude 
volumes

Comma separated list of volume names (for 
example, C:) to exclude from freezing.

C
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Check client-side 
caches and report 
inconsistencies

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Maximum client file 
cache size (MBs)

Specifies maximum client file cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client file cache).

Maximum client hash 
cache size (MBs)

Specifies maximum client hash cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client hash cache).
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A
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V
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T
IO

N
S

Client-side flag file Specifies path to a flag file on the client, which 
contains additional option settings.

Network usage 
throttle (Mbps)

Specifies a setting that reduces network usage to 
specified rate, expressed as megabits/second (for 
example, 0 = unrestricted, 50% of a T1 = 0.772).

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve backup performance under 
certain circumstances.

Use Last Access 
Time to detect ACL-
only changes

If selected, forces a rescan of any files in which the 
Access Time has changed since the previous 
backup.

FIELD/OPTION DESCRIPTION
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Restore Options

FIELD/OPTION DESCRIPTION

Overwrite existing files Controls behavior when file to be restored already 
exists. One of the following:

Never

Always

Generate New Name

If Modified

If Newer

Restoration of open files One of the following:

Never Do not restore.

Defer until reboot Defer restore until system is 
rebooted.

Generate new name Restore file with a different 
name.

If newer defer until 
reboot
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L
O

G
G
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G

List backup contents Specifies how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specifies how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.

P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of restore

Runs user-defined script at beginning of restore 
session.
IMPORTANT:  Script must be located in 
C:\Program Files\avs\etc\scripts on Windows and 
must have a .bat, .js or .vbs extension. 

Abort restore if 
script fails

If selected, stop restore if script returns a non-zero 
status code.
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P
O

S
T

-S
C

R
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T

Run user-defined 
script at end of 
restore

Runs user-defined script at end of restore session.
IMPORTANT:  Script must be located in 
C:\Program Files\avs\etc\scripts on Windows and 
must have a .bat, .js or .vbs extension. 

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
L
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N
S Check client-side 

caches and report 
inconsistencies

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Rebuild client-side 
caches from most 
recent backup

Does not restore data.  If selected, the contents of 
last backup are used to re-create client-side file 
cache.
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Do not descend 
into subdirectories

If selected, restore only the specified top-level 
directory; do not restore any subdirectories.

Recreate original 
path beneath 
target directory

If selected, re-create the original path to files and 
directories beneath the specified target directory.
For example, if restoring F:\Temp\MyFile.txt to 
C:\Temp and you selected this option, the full path 
to the restored file will be 
C:\Temp\F\Temp\MyFile.txt. 

Restore hidden 
folders and files

If selected, also restore folders and files that have 
the HIDDEN attribute set in the backup.

Restore folders and 
files with SYSTEM 
attribute

If selected, also restore folders and files that have 
the SYSTEM attribute set in the backup.

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve restore performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION
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DB2 Plug-in Options
This topic lists and describes the plug-in options available for use with any of the 
following Avamar AIX DB2 plug-ins:

• AIX DB2
• Windows DB2
• Linux DB2

Backup Options

FIELD/OPTION DESCRIPTION

Create an ONLINE 
backup

If selected, database can be backed up while it is 
operational (also known as “hot backup”).
IMPORTANT:  DB2 Archive Logging must already 
be enabled to successfully perform online backups.

Exclude archive 
logs in ONLINE 
backup

IMPORTANT:  By default, the archive logs are 
included in the backup. If you decide not to include 
the archive logs in the backup, select Exclude 
archive logs in ONLINE backup. However, if you 
do not include archive logs in the database backup, 
ensure that archive logs are included in filesystem 
backups. Failure to do so might result in loss of 
data.

Instance Admin 
Username

Instance Admin 
Password

Password for the Instance Admin Username.
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S Enable debugging 

messages
If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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Restore Options

FIELD/OPTION DESCRIPTION
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Restore and Recover For online backups that have archive logs, restores 
both the database and the archive logs, and rolls 
the database forward (recovers it). If this option is 
selected, you must select one of the options from 
the Type of Recovery list and specify a value in the 
Directory path to restore archive logs field.

Restore Only Performs only a restore of the backups (no 
recovery). Select this option to restore a backup 
without recovery, to restore offline backups, or to 
restore online backups that do not have archive 
logs. 

Restore only 
archive logs from 
ONLINE backup

Restores only the archive logs from the backup 
image. It does not restore the database. 
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Type of Recovery When the Restore and Recover option is selected, 
choose a recovery option from the list:

End of Logs Database is rolled forward until 
the end of the archive logs.

Point In Time Database is rolled forward until a 
certain point in time, which should 
be specified in the Date and Time 
field.

End of Backup Database is rolled forward until 
the end of the backup. This option 
is available only for DB2 v9.5 and 
later.

Date and Time When Point In Time is selected from the Type of 
Recovery list, specify the recovery date and time in 
yyyy-mm-dd hh:mm:ss format in this field. 
The time should be in the time zone of the client 
system.
The entry can be truncated to the desired precision 
level. For example, minutes and seconds can be 
omitted for convenience.
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Instance Admin 
Username

Instance Admin 
Password

Password for the Instance Admin Username.

Database Name If Restore everything to a different location is 
selected (redirected restore), then specify the new 
name for the database in this field.

Directory path to 
restore archive logs

Full path to the location on the target filesystem to 
which archive logs are written.
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S Enable debugging 

messages
If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.

FIELD/OPTION DESCRIPTION
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Lotus Domino Plug-in Options
This topic lists and describes the plug-in options available for use with the AIX 
Lotus Domino and Windows Lotus Domino plug-ins.

Backup Options

FIELD/OPTION DESCRIPTION

Backup label Assign this descriptive label to backup.

Follow links If selected, back up databases and directories 
pointed to by links. 

Backup Type One of the following:

Full Back up all databases and files 
required for a complete recovery.

Incremental Back up transaction logs and new 
database files that were created 
since the last full or incremental 
backup.

Subset Back up selected database files.

Full path of the Domino 
server’s notes.ini file

Type the full pathname of Domino server’s notes.ini 
file.

• On Windows, the default folder is 
C:\Program Files\IBM\Lotus\Domino\data\.

• On AIX, the default directory is /data/
notesdata/.

Full path of the Domino 
directory

Type the full path of the Domino directory.
• On Windows, the default folder is 

C:\Program Files\IBM\Lotus\Domino\.
• On AIX, the default directory path is 

/opt/ibm/lotus/notes/80010/ibmpow/.

Domino user name Type the Domino username.
This is the OS user, which has permissions to start 
and stop the Domino server on the IBM AIX 
machine.
The default username is notes.
NOTE:  This field is specific to the AIX Lotus 
Domino plug-in.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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TR
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S Back up transaction 
logs with full backup

If selected, include transaction logs with the 
backup.
By default, this option is selected.

Archive transaction 
logs

If selected, archive transaction logs following the 
backup.
By default, this option is selected.

Terminate backup on 
error

If selected, terminate the backup if an error occurs.

FIELD/OPTION DESCRIPTION
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Restore Options

FIELD/OPTION DESCRIPTION

Bring all databases 
online after restore

If selected, all databases are automatically brought 
online following a successful restore.
By default, this option is selected.

Overwrite files If selected, the restore operation overwrites 
existing databases or files with the restored data. 
Clear this option to prevent the restore operation 
from overwriting existing database or files (that is, 
no data is restored to these databases or files). Any 
skipped databases or files will be noted in log 
entries.
By default, this option is not set. 

Domino user name Type Domino username.
This is the OS user, which has permissions to start 
and stop the Domino server on the IBM AIX 
machine.
The default username is notes.
NOTE:  This field is specific to the AIX Lotus 
Domino plug-in.

Enable debugging 
messages

If selected, write maximum information to log files.
IMPORTANT:  If set, large files are created.

Restore system 
databases

If selected, system databases are restored. 
You must stop the Domino server to restore system 
databases.
NOTE:  System databases include: busytime.nsf, 
ddm.nsf, events4.nsf, log.nsf, mail.box, names.nsf 
and mailjrn.nsf.

Specifies full paths for 
the Domino configuration 
file and directory

If selected, the restore operation uses the 
pathnames specified by the Full path of the Domino 
server’s notes.ini file and Full path of the Domino 
directory fields.
IMPORTANT:  The use of this option is usually 
necessary only if the Lotus Domino configuration 
has changed or the Domino server has been 
reinstalled in a new location. In these types of 
situations, you must provide the current 
pathnames to restore database files.
NOTE:  A restore operation, by default, uses the 
same pathnames for the notes.ini file and Domino 
directory as the ones that were used for the 
backup.
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Full path of the Domino 
server’s notes.ini file

If Specify full paths for the Domino 
configuration file and directory is selected, type 
the full pathname to the Domino server’s notes.ini 
file.
On Windows, the default folder is C:\Program 
Files\IBM\Lotus\Domino\data\.
On AIX, the default directory is /data/notesdata/.

Full path of the Domino 
directory

If Specify full paths for the Domino 
configuration file and directory is selected, type 
the full pathname of the Domino directory.
On Windows, the default folder is C:\Program 
Files\IBM\Lotus\Domino\.
On AIX, the default directory path is 
/opt/ibm/lotus/notes/80010/ibmpow/.
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Recover the 
databases by 
using transaction 
logs

If selected, the restore operation uses transaction 
logs to recover database files to a specific date and 
time.
By default, this option is selected.

Recover the 
databases in batch

If selected, restore databases in a batch process.
If any one database encounters a problem during a 
batch recovery, the recovery fails for all databases 
that were selected.
IMPORTANT:  The use of this option is intended 
for advanced users, who are familiar with the 
recovery of Domino databases.

Create new DBIID 
during recovery

If selected, the Domino server assigns new DBIIDs 
to recovered databases. 
By default, this option is not selected.
IMPORTANT:  Because database transactions are 
specific to the DBIID, transaction logs prior to the 
recovery cannot be applied. Avamar recognizes a 
database with a new DBIID as an entirely new 
database.

Create new DBIID 
and ReplicaID during 
recovery

If selected, the Domino server assigns new 
ReplicaIDs and DBIIDs to recovered databases.
By default, this option is not selected.
IMPORTANT:  Because transactions are specific to 
the DBIID, transaction logs prior to the recovery 
cannot be applied. Avamar recognizes a database 
with a new DBIID as an entirely new database.

FIELD/OPTION DESCRIPTION
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Now If selected, restore each database to its original 
state at the time of the backup. Then, transaction 
logs are used to recover all data until now.
By default, this option is selected.

Other date/time If selected, restore each database to its original 
state at the time of the backup. Then, transaction 
logs are used to recover all data up to the date and 
time specified in the Recover date/time (yyyy-mm-
dd hh:mm:ss) field.

Backup date/time If selected, restore each database to its original 
state at the time of its backup.

Recover date/time
(yyyy-mm-dd 
hh:mm:ss) 

If Other date/time is selected, type the calendar 
date to which you want to recover data. 
Entry must be in the following format:

YYYY-MM-DD hh:mm:ss:mmm

where
• YYYY is a four-digit year.
• MM is a two-digit month of the year.
• DD is a two-digit day of the month (date).
• hh is a two-digit hour of the day.
• mm is the two-digit number of minutes past the 

hour.
• ss is the two-digit number of seconds past the 

minute.
Dashes (-) must separate year, month, and dates.
Colons (:) must separate hours, minutes, and 
seconds.
It is permissible to truncate this entry to the desired 
precision. For example, if no minutes are supplied, 
top of the hour is assumed.
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Restore missing NLO 
files

If selected, restores missing NLO files referenced by 
the databases that are successfully restored.
By default, this option is selected.
NOTE:  The process of finding NLO files might take 
a long time.

Synchronize DAOS 
catalog files

If selected, synchronizes the DAOS catalog file.
NOTE:  The process of synchronizing the DAOS 
catalog file might take a long time.

FIELD/OPTION DESCRIPTION
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H Controls the number of databases that are restored in a single restore pass 

(iteration). Smaller settings (fewer databases per batch) allow you to bring 
those databases online sooner to reduce downtime, but require more 
iterations. Select one of the following:

Default If selected, each restore pass (iteration) processes 
10 databases.
By default, this option is selected.

All If selected, restore all databasesin a single pass 
(iteration).

User Defined If selected, the number of database you specify in 
the Number of databases to restore per batch field 
are restored in a single pass (iteration).

Number of databases 
to restore per batch

If User Defined is selected, type the desired number 
of databases to restore for each pass (iteration).

FIELD/OPTION DESCRIPTION
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NDMP Plugin Options
This topic lists and describes the plugin options available for use with any of the 
following Avamar NDMP plugins:

• NDMP
• EMC Celerra via NDMP
• Netapp Filer via NDMP

Backup Options

Restore Options

FIELD/OPTION DESCRIPTION

Filer Dump Mode One of the following:

Prefer Incremental, but do a Full if required

Prefer Incremental, but do a Full if required

Force an incremental (level 1) dump

Save file/directory 
permissions(ACL's) 
with the backup

If selected, extended file and directory Access 
Control Lists (ACLs) are saved during the backup. 
This is the default setting.
NOTE:  This option is not available for use with the 
EMC Celerra via NDMP plugin.
IMPORTANT:  Unsetting this option prevents the 
Avamar server from saving ACLs during your 
backup. You will therefore not be able to restore 
ACLs at any future time.

FIELD/OPTION DESCRIPTION

Restore file/directory 
permissions(ACL's) 
that were saved with 
the backup

If selected, ACLs saved during NDMP backups are 
restored. 
NOTE:  This option is not available for use with the 
EMC Celerra via NDMP plugin.
IMPORTANT:  If ACLs were not saved during the 
NDMP backup, they cannot be restored.
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Oracle RMAN Plug-in Options
This topic describes the plug-in options available for use with any of the following 
Oracle RMAN plug-ins:

• AIX Oracle RMAN
• Linux Oracle RMAN
• Solaris Oracle RMAN
• Windows Oracle RMAN

Theory of Operation

During backups and restores, the Avamar Oracle database plug-in generates an 
RMAN script that performs the actual backup and restore of the specified 
database. The Avamar client agent runs RMAN with this generated script, which 
directs Oracle to open a connection with an RMAN module from EMC, which in turn 
invokes an avtar session to connect to the Avamar server.

The following is an example RMAN script, which typically might be generated as 
part of an Oracle database backup:

configure controlfile autobackup on;
run {
allocate channel c1 type sbt;
send 'connect information for avtar to connect to the Avamar server'; 
backup database; }

During the backup or restore operation, RMAN produces a log file which is 
captured and readable from within Avamar Administrator. For example:

Recovery Manager: Release 10.1.0.2.0 - Production

Copyright (c) 1995, 2004, Oracle. All rights reserved.

AVAGENT

AVAMAR
SERVER

DATABASE
FILES

RECOVERY
CATALOG

ORACLE

MCS

DATA
SERVER

AVORACLE

RMAN

AVAMAR MEDIA
MANAGEMENT

LIBRARY

AVTAR
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connected to target database: ORACLE (DBID=1420649215)
using target database controlfile instead of recovery catalog

RMAN> configure controlfile autobackup on;
2> run {
3> allocate channel c1 type sbt;
4> send '... ';
6> backup database;
7> }
8> 
old RMAN configuration parameters:
CONFIGURE CONTROLFILE AUTOBACKUP OFF;
new RMAN configuration parameters:
CONFIGURE CONTROLFILE AUTOBACKUP OFF;
new RMAN configuration parameters are successfully stored

allocated channel: c1
channel c1: sid=142 devtype=SBT_TAPE
channel c1: AVTAR/Avamar backup (EMC)

sent command to channel: c1

Starting backup at 21-MAR-05
channel c1: starting full datafile backupset
channel c1: specifying datafile(s) in backupset
input datafile fno=00001 
name=D:\ORACLE\PRODUCT\10.1.0\ORADATA\ORACLE\ORACLE\SYSTEM01.DBF
input datafile fno=00003 
name=D:\ORACLE\PRODUCT\10.1.0\ORADATA\ORACLE\ORACLE\SYSAUX01.DBF
input datafile fno=00002 
name=D:\ORACLE\PRODUCT\10.1.0\ORADATA\ORACLE\ORACLE\UNDOTBS01.DBF
input datafile fno=00004 
name=D:\ORACLE\PRODUCT\10.1.0\ORADATA\ORACLE\ORACLE\USERS01.DBF
channel c1: starting piece 1 at 21-MAR-05
channel c1: finished piece 1 at 21-MAR-05
piece handle=15gfs32k_1_1 comment=API Version 2.0,MMS Version 2.2.0.108 channel c1: 
backup set complete, elapsed time: 00:00:45 channel c1: starting full datafile 
backupset channel c1: specifying datafile(s) in backupset including current controlfile 
in backupset including current SPFILE in backupset channel c1: starting piece 1 at 21-
MAR-05 channel c1: finished piece 1 at 21-MAR-05 piece handle=16gfs341_1_1 comment=API 
Version 2.0,MMS Version 2.2.0.108 channel c1: backup set complete, elapsed time: 
00:00:17 Finished backup at 21-MAR-05 released channel: c1

Recovery Manager complete.

Backup Options

FIELD/OPTION DESCRIPTION

Oracle instance name Specifies Oracle server name. 
This field can normally be left blank because the 
Oracle instance name is automatically stored when 
the target client is browsed during on-demand 
backup or when a dataset is applied to a member of 
a group during a scheduled backup.
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User name Specifies username that is used to authenticate 
with the Oracle database. 
If left blank, RMAN tries to log in with the same 
username and password that the Avamar client 
agent uses and attempts to assume SYSDBA 
privileges.
Typically, this field should contain the special 
account name (backupuser) that was created 
manually as part of database preparation.

Username and password comprise a connection 
string to Oracle. The connection string must specify 
a user that has backup privileges for the database.

Password Type the backupuser account password.

Number of RMAN 
channels

Specifies the number of channels to allocate during 
a backup or restore. The maximum number is 6. 
Default is one. 
NOTE:  Allocating multiple channels for backups 
and restores may improve performance. 
Performance improvements for backups and 
restores, however, depend on the Oracle server 
configuration.
IMPORTANT:  In some instances allocating too 
many channels may lock out processes, which can  
result in a timeout error. This problem does not 
occur when using RMAN scripts.

Backup archive logs 
with database

If selected, Oracle archive logs are automatically 
backed up during the database backup. 

Delete archive logs 
after backup

If selected, Oracle archive logs are automatically 
deleted immediately following a successful database 
backup. 

Enhanced data 
deduplication

Enables or disables enhanced data deduplication. 
During backups, enhanced data deduplication 
typically reduces the amount of client data that 
must be sent to the server, but, requires additional 
client CPU resources. Choices are:

Default Use the global enhanced data 
deduplication setting already set on the 
server. This is the default setting.

Disabled Do not use enhanced data deduplication 
for backups.

Enabled Use enhanced data deduplication for 
backups.

FIELD/OPTION DESCRIPTION
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Media Management 
Library bitwidth

Specifies Media Management Library (MML) 
bitwidth. Choices are:

• automatic (default)
• 32-bit
• 64-bit

NOTE:  The Media Management Library bitwidth 
option is available for Linux and Unix Oracle RMAN 
plug-ins. This option does not apply to Windows 
platforms.
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Full backup If selected, back up all datafiles, redo logs, and 
archive logs. 
Full backups do not use Block Change Tracking.
This option is the default.

Level 0 backup If selected, perform a level 0 backup. 
Level 0 backups save all datafiles, redo logs, and 
archive logs.
A level 0 backup is required before performing level 
1 backups. 
You must enable the RMAN Change Block Tracking 
feature before performing a level 0 backup. 
Enabling Block Change Tracking (page 68) provides 
more information.

Level 1 backup If selected, perform a level 1 backup. 
Level 1 backups save only changed blocks of the 
database.
A level 0 backup is required before you perform a 
level 1 backup. Selecting the Level 1 backup option 
before creating a level 0 backup, results in a level 0 
backup.
You must enable the RMAN Change Block Tracking 
feature before performing a level 1 backup. 
Enabling Block Change Tracking (page 68) provides 
more information.

NOTE:  The AIX Oracle RMAN plug-in does not include level 0 or level 1 
backup options. Level 0 and 1 backups of Oracle databases are not 
supported on IBM AIX platforms.

FIELD/OPTION DESCRIPTION
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Use recovery 
catalog

If selected, Recovery catalog server name, 
Recovery catalog username, and Recovery catalog 
password settings are used to specify a recovery 
catalog server connection string for RMAN. 
By using a recovery catalog server, many 
specialized features of RMAN may be used. A 
thorough discussion of these features is beyond the 
scope of this publication. Refer to your Oracle 
documentation for additional information.

Recovery catalog 
server name

Specifies recovery catalog server name.

Recovery catalog 
user name

Specifies recovery catalog username.

Recovery catalog 
password

Specifies recovery catalog password.
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S Enable debugging 

messages
If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.

NLS_DATE_FORMAT Specifies a valid timestamp format for the target 
machine. For example: MM/DD/YYYY

FIELD/OPTION DESCRIPTION
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Restore Options

FIELD/OPTION DESCRIPTION

Oracle instance 
name

Specifies Oracle server name. 
This field can normally be left blank because the Oracle 
instance name is automatically stored when the target 
client is browsed during on-demand backup or when a 
dataset is applied to a member of a group during a 
scheduled backup.

User name Specifies username that is used to authenticate with the 
Oracle database. 
If left blank, RMAN tries to log into with the same 
username and password the Avamar client agent is running 
under, and attempts to assume SYSDBA privileges. 
Typically, this field should contain the special account name 
(backupuser) that was created manually as part of 
database preparation.
Username and password comprise a connection string to 
Oracle. The connection string must specify a user that has 
backup privileges for the database.

Password Specifies password for the Username account.

Media 
Management 
Library bitwidth

Specifies Media Management Library (MML) bitwidth. 
Choices are:

• Automatic (default)
• 32-bit
• 64-bit

NOTE:  The Media Management Library bitwidth option is 
available for Linux and Unix Oracle RMAN plug-ins. This 
option does not apply to Windows platforms.

Number of RMAN 
channels

Specifies the number of channels to allocate for the restore 
operation. The maximum number is six. 
Default is one.
NOTE:  Allocating more channels may not always improve 
performance. Performance improvement depends on the 
Oracle server configuration.
IMPORTANT:  In some instances allocating too many 
channels may lock out processes, which can  result in a 
timeout error. This problem does not occur when using 
RMAN scripts.
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Point-in-time 
recovery mode

Specifies the type of recovery.
Do not specify a point-in-time option if you selected 
multiple databases for the restore. 
IMPORTANT:  Before using a point-in-time recovery 
option other than Default, ensure that relevant backups 
are available on the Avamar server. The recovery 
operation will fail if a backup has expired or has been 
deleted from the Avamar server. Choices are:

Default Recovers the database to the most recent 
SCN. Avamar Oracle Client automatically 
determines the SCN from the control file. 

SCN Recovers the databse to the specified 
SCN. 
Specify the SCN in the Point-in-time 
recovery value text box.

Log sequence Recovers the database to the specified log 
sequence number. 
Specify the log sequence number in the 
Point-in-time recovery value text box.
By default, Avamar Oracle Client uses  
thread  1. To specify a different thread 
number:
1. Click More.
2. Type THREAD in the Enter Attribute text 

box.
3. Type the specific thread number in the 

Enter Attribute Value text box.

4. Click .

FIELD/OPTION DESCRIPTION
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Point-in-time 
recovery mode 
(continued)

Time stamp Recovers the database to the specified 
timestamp.
Specify the timestamp in the Point-in-
time recovery value text box. The 
timestamp format must conform to the 
localization settings on the target machine 
and locale configuration setting for the 
Oracle server.
The timestamp order of precedence rules 
from highest to lowest are as follows:
Highest — A timestamp format specified 
by the NLS_DATE_FORMAT text box 
(advanced option).
Lower — A timestamp format specified by 
the NLS_DATE_FORMAT variable in 
environment settings.
Lowest — The built-in default timestamp 
format uses american_america.us7asci. 
The format is:
MM DD YYYY HH24:MI:SS
where:

• MM is a two-digit month.
• DD is a two-digit day of the month.
• YYYY is a four-digit year.
• HH24 is the hour using a 24-hour 

format.
• MI is minutes.
• SS is seconds.

Avamar Oracle Client generates a script by 
using the timestamp specification and the 
format (determined by the precedence 
rules) and sends the script to RMAN. The 
timestamp format specified in the 
NLS_DATE_FORMAT text box is also added 
to the ENV setting before RMAN is called.
For more information about Oracle and 
RMAN localization, refer to Oracle 
documentation.

Point-in-time 
recovery value

Specifies the SCN, log sequence number, or timestamp 
depending on which point-in-time recovery mode is 
selected.

FIELD/OPTION DESCRIPTION
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debugging 
messages

If selected, maximum information is written to log files.
IMPORTANT:  If selected, very large log files are created.

NLS_DATE_
FORMAT

Specifies a valid timestamp format for the target machine. 
For example: MM/DD/YYYY

FIELD/OPTION DESCRIPTION
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Microsoft Office SharePoint Server Plug-in Options
This topic lists and describes the plug-in options available for use with the Avamar 
Microsoft Office SharePoint Server plug-in.

Backup Options

Restore Options

FIELD/OPTION DESCRIPTION

Temporary backup 
directory

Temporary backup directory

Backup Type Sets backup level: either Full or Differential

Remove temporary 
backup files after 
backup completes

A
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N
S Enable debugging 

messages
If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.

FIELD/OPTION DESCRIPTION

Username Username with admin rights on farm.

Password

Restore Type Restore by overwriting existing data (Overwrite) or 
restore just the new data (New).
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S Enable debugging 

messages
If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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Windows Exchange Database Plugin Options
This topic lists and describes the plugin options available for use with the Avamar 
Windows Exchange Database plugin. This plugin supports both Exchange 2007 
and 2003 database backup and restore.  

Backup Options

FIELD/OPTION DESCRIPTION

Set when backup 
occurs on 
clustered systems

Choices are:

Always Backs up all nodes in the cluster. This is 
the default setting.

Active node 
only

Only the active node in the cluster is 
backed up.

Passive node 
only

Only passive nodes in the cluster are 
backed up.

Refer to your Avamar Backup Clients User Guide for 
additional information about Avamar support for 
Microsoft Windows Clusters.

Delete log files 
after snapup

IMPORTANT:  Do not select this option if you are 
performing concurrent incremental backups.

Enhanced 
Commonality 
Factoring

Enables or disables enhanced data deduplication. During 
backups, enhanced data deduplication typically reduces 
the amount of client data that must be sent to the server 
but requires additional client CPU resources. Choices are:

Default Use the global enhanced data 
deduplication setting already set on the 
server. This is the default setting.

Disabled Do not use enhanced data deduplication 
for backups.

Enabled Use enhanced data deduplication for 
backups.
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Server Name This field can normally be left blank because the 
Exchange server name is automatically stored when the 
target client is browsed during on-demand backups or 
when a dataset is applied to a member of a group during 
a scheduled backup.

Annotation 
(Microsoft 
Information 
Store)

This field names the portion of (Extensible Storage 
Engine (ESE) backup to perform. Choices are: 

Microsoft 
Information 
Store

This is the default setting.

Microsoft Site 
Replication 
Service

Site replication service used for mixed 
Exchange 5.5 and 2000/2003 
environments.

Microsoft Key 
Management 
Service

This is the local activation service that 
provides Windows activation, instead of 
using Microsoft’s external product 
activation.

Storage Group 
Name

This field can normally be left blank because the 
Exchange storage group name is automatically stored 
when the target client is browsed during on-demand 
backups or when a dataset is applied to a member of a 
group during a scheduled backup.

Pipe input/
output to avtar

If selected, backups and restores are performed directly 
by the Avamar backup process (avtar).
If cleared, an intermediate local backup file can be used.

Enable 
debugging 
messages

If selected, maximum information is written to log files.
IMPORTANT:  If selected, very large log files are 
created.

FIELD/OPTION DESCRIPTION
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Restore Options

FIELD/OPTION DESCRIPTION

Perform 
Database 
Recovery after 
restore making 
Exchange 
consistent

Performs soft recovery (performs a consistency check 
and prepares to put the database online) after database 
is restored. This is the default setting.

Wait for 
Database 
Recovery to 
Complete

If Perform Database Recovery after restore making 
Exchange consistent is selected, specifies whether to 
wait for the recovery process to complete or complete 
the restore session asynchronously with the recovery 
process. Dependent on the previous option. This is the 
default setting.

Mount the 
database(s) 
after successful 
restore

If selected, databases will be mounted following a 
successful restore. This is not the default setting.

Keep logs after 
Restore

If selected, restore log files are written to the location 
specified in the Restore logs path field.

Restore logs 
path

Specifies location for restore log files. Specify this 
alternative location C:\TMP if drive is low on disk space.

Adjust for gaps 
when existing 
log files are 
not contiguous

If selected, restore operation will include a check for 
contiguous log files error and will correct the error. This is 
the default setting.

Move logs path Specifies location for keeping old restore log files. 
Existing log files are moved to this location prior to the 
restore operation. This prevents log file conflicts during 
restore.

Recovery 
Storage Group 
Name

Specifies Recovery Storage Group that will be created 
during the restore operation. Default name is RSG.

Redirected 
storage group 
path

Specifies location for redirect restores that include a 
Recovery Storage Group. The Recovery Storage Group 
name specified in the Recovery Storage Group Name 
field is created under this location.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  551



 Windows Exchange Database Plugin Options
APPENDIX B — PLUGIN OPTIONS
A
D

V
A

N
C

E
D

 O
P

T
IO

N
S

Server Name This field can normally be left blank because the 
Exchange server name is automatically stored when the 
target client is browsed during restore operations.
However, this field can be used to type another server 
hostname when performing directed restores to another 
network host.

Annotation 
(Microsoft 
Information 
Store)

This field names the portion of (Extensible Storage 
Engine (ESE) backup to perform. Choices are: 

Microsoft 
Information 
Store

This is the default setting.

Microsoft Site 
Replication 
Service

Site replication service used for mixed 
Exchange 5.5 and 2000/2003 
environments.

Microsoft Key 
Management 
Service

This is the local activation service that 
provides Windows product activation in 
place of  product activation over the 
Internet through Microsoft’s servers. 

Storage Group 
Name

This field can normally be left blank because the 
Exchange storage group name is automatically stored 
when the target client is browsed during restore 
operations.

Local Backup 
File Name

If Pipe input/output to avtar is cleared, this field defines 
the filename used to send/receive data. 

This can be used to restore the exchstream file in one 
step to a local file, then perform a Exchange restore 
using that file.

Pipe input/
output to avtar

If selected, backups and restores are performed directly 
by the Avamar backup process (avtar).
If cleared, an intermediate local backup file can be used.

Enable 
debugging 
messages

If selected, maximum information is written to log files.
IMPORTANT:  If selected, very large log files are 
created.

FIELD/OPTION DESCRIPTION
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Windows Exchange Message Plugin Options
This topic lists and describes the plugin options available for use with the Avamar 
Windows Exchange Message plugin. 

Backup Options

Restore Options

FIELD/OPTION DESCRIPTION

A
D

V
A

N
C

E
D

 O
P

T
IO

N
S Enable debugging 

messages
If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.

FIELD/OPTION DESCRIPTION

Overwrite 
existing 
messages

Controls behavior when message to be restored already 
exists. One of the following:

Never

Always

If Modified

If Newer

Checking for 
already 
restored items

Checks if the items or messages have been restored 
earlier in order to prevent creation of duplicate items. 
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S Enable 

debugging 
messages

If selected, maximum information is written to log files.
IMPORTANT:  If selected, very large log files are 
created.
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Windows SQL Server Plugin Options
This topic lists and describes the plugin options available for use with the Avamar 
Windows SQL Server plugin. 

Backup Options

FIELD/OPTION DESCRIPTION

Enhanced Data 
Deduplication

Enables or disables enhanced data deduplication. 
During backups, enhanced data deduplication 
typically reduces the amount of client data that must 
be sent to the server but requires additional client 
CPU resources. Choices are:

Default Use the global enhanced data 
deduplication setting already set on 
the server. This is the default 
setting.

Disabled Do not use enhanced data 
deduplication for backups.

Enabled Use enhanced data deduplication for 
backups.

Backup Type Sets the backup level. One of the following:

Full Backs up the entire database, 
including all objects, system tables, 
and data.

Differential Backs up any data that has changed 
since the last complete backup.

Incremental Backs up only the transaction logs.

Force Incremental 
backup

If a full backup exists, creates an incremental 
backup that contains transactions that occur from 
the end of the first full backup until the beginning of 
the second full backup. This ensures that a point-in-
time recovery to a point in time between the two full 
backups can occur, if necessary. 

Backup label Assigns this descriptive label to the backup.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  554



 Windows SQL Server Plugin Options
APPENDIX B — PLUGIN OPTIONS
A
D

V
A

N
C

E
D

 O
P

T
IO

N
S

Use NT 
Authentication

If selected, use NT authentication to connect to SQL 
Server. If cleared, use SQL Server authentication. 

SQL server address Connect to this SQL server hostname or IP address.

SQL login ID If Use NT Authentication option is cleared, 
connect to the SQL server by using this login ID.

SQL password If Use NT Authentication option is cleared, type 
the password for the SQL login account. 

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.

Truncate database 
log

Controls database transaction log truncation 
behavior. One of the following:

Default log 
truncation

The database transaction log is 
truncated if the backup type is set to 
incremental; no log truncation 
occurs if the backup type is full or 
differential.
This is the default setting.

Perform log 
truncation

The database transaction log is 
truncated regardless of the backup 
type setting. 
IMPORTANT:  This setting breaks 
the chain of log backups and should 
not be used unless the backup type 
is set to full.

Suppress log 
truncation

The database transaction log is not 
truncated under any circumstances.

Force full backup If selected, a full backup is performed if either of the 
following is true:

The selected database is a master or system 
database.
A previous full backup, from which an 
incremental/differential backup can be applied, 
could not be found on the server.

Effectively, this option automates taking a full 
backup when necessary.
IMPORTANT:  If you take incremental and 
differential backups, EMC strongly recommends 
that you leave this option selected (the default 
setting) for all backups. Otherwise, you might not 
be able to restore data in the event that no existing 
full backup is present on the Avamar server.

FIELD/OPTION DESCRIPTION
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Restore Options

FIELD/OPTION DESCRIPTION

Use SQL replace 
option

If selected, an SQL WITH REPLACE  clause 
statement is added to the restore Transact-SQL 
command. This specifies that SQL Server should 
create any necessary database and related files even 
if another database or file already exists with the 
same name. 
IMPORTANT:  This option overrides a SQL Server 
safety check that is intended to prevent you from 
accidentally overwriting a different database or file. 
This safety check is described in the Microsoft 
Transact-SQL Reference Manual under the RESTORE 
command section.
This option might be required if a previous database 
restore exited with the following SQL Server error, 
which is visible in the Avamar SQL restore log:
One or more devices or files already exist.
Reissue the statement using the WITH REPLACE
option to overwrite these files and devices.

Restore system 
databases

If selected, the plugin creates an expanded list of 
databases to restore that includes system databases 
and non-system databases. By default, this option is 
cleared, and only non-system databases are 
expanded from the restore targets.

Log Tail backup Backs up the tail of the transaction log to capture 
the log records that have not been backed up. The 
log tail backup is then used after the database 
restore to recover the transactions that were not 
included in the backup.
Log tail backup is available only for databases that 
use the full and bulk-logged recovery models. It 
should only be used for a direct restore without the 
SQL replace option.
Clear the checkbox if you are performing a 
redirected restore or a direct restore with replace.
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Use NT 
Authentication

If selected, use NT authentication for connecting to 
SQL server. If cleared, use SQL Server 
authentication. 

SQL server address Connect to this SQL server hostname or IP address.

SQL login ID If Use NT Authentication option is cleared, 
connect to the SQL server using this login ID.

SQL password If Use NT Authentication option is cleared, type 
the password for the SQL login account. 

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.

New database name To rename this database, type the new name here.

Alternate database
/log location

If relocating the database, type the full path of the 
new database file (*.mdf) location.
If the Alternate database/log location field contains 
an entry and the Alternate database log location 
field is empty, then both the database and the log 
files are restored to this new location. 

If both the Alternate database/log location and 
Alternate database log location field contain entries, 
then database files and log files are restored to their 
respective (and likely different) locations.

Alternate database 
log location

If relocating the database, type the full path of the 
new database log file (*.ldf) location.

Point-in-Time A specific date and time to which to recover the 
database. Available only if the database uses the full 
recovery model. 
Specify the date and time in yyyy-mm-
ddThh:mm:ss format. For example, 2009-10-
25T14:15:45 is October 25, 2009 at 2:15:45 P.M.

FIELD/OPTION DESCRIPTION
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Mark name If named marks are inserted in the transaction log 
for recovery purposes, then you can recover to a 
specific mark. Available only if the database uses the 
full recovery model. 
Specify the mark name.
NOTE:  If you specify both a point in time and a 
mark name, then the recovery rolls forward to the 
mark name, even if the mark is after the specified 
point in time.

After date/time If named marks are not unique in the transaction 
log, then you can specify the date and timestamp of 
the mark to recover to. Specify the date and time in 
yyyy-mm-ddThh:mm:ss format. For example, 2009-
10-25T14:15:45 is October 25, 2009 at 2:15:45 
P.M.

STOPBEFOREMARK Specifies that the transaction at the named mark is 
the recovery point. In other words, the recovery 
rolls forward to the mark and includes the 
transaction at the mark.

STOPATMARK Specifies that the transaction immediately before  
the named mark is the recovery point. In other 
words, the recovery rolls forward to the mark but 
does not include the transaction at the mark.

FIELD/OPTION DESCRIPTION
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Windows VSS Plug-in Options
This topic lists and describes the plug-in options available for use with the Avamar 
Windows VSS plug-in. 

Backup Options

Restore Options

FIELD/OPTION DESCRIPTION

Backup Type Sets backup level. 
IMPORTANT:  Full is the only backup level 
supported by the Avamar Windows VSS 
plugin.

Create Disaster Recovery Backup Selected by default. If checkbox is cleared, 
a disaster recovery backup will not be 
performed when the system state backup is 
processed. 
IMPORTANT:  Turning this off makes the 
backups go much quicker, but  then the 
backup will not be valid for performing a 
disaster recovery. Avoid turning this option 
off.  
One exception is  when performing a 
backup of Active Directory, clear this check 
box.  

Backup label Assigns this descriptive label to the backup.
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S Temporary directory for the 

plugin.
User-defined temporary directory.

Enable debugging 
messages

If selected, maximum information is written 
to log files.
IMPORTANT:  If selected, very large log 
files are created.

FIELD/OPTION DESCRIPTION
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S Temporary directory for the 

plugin.
User-defined temporary directory.

Enable debugging 
messages

If selected, maximum information is written 
to log files.
IMPORTANT:  If selected, very large log 
files are created.
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Replicate Plugin Options
This topic lists and describes the plugin options available for use with the Avamar 
Replicate plugin. 

Backup Options

IMPORTANT:  Restore operations are not supported by the
Avamar Replicate plugin.

FIELD/OPTION DESCRIPTION

Domain name on 
the target server

Specifies where backups will be stored on the target 
server. Your replicated backups will appear in the specified 
domain (directory) under REPLICATE on the target server

Destination server Specifies target (destination) server that will receive 
replicated backups.

User ID on 
destination server

Specifies Avamar administrative user account on the 
target (destination) server with sufficient privileges to 
allow the replication operation. 

Password on 
destination server

Specifies password for the Avamar administrative user 
account on the target (destination) server.
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APPENDIX C — MCS AND EMS DATABASE VIEWS

This appendix lists each MCS and EMS database view and describes the individual 
columns storing data within each view. This information is intended to support 
using these views to create various reports.

Data Types
Each column in a database view stores one of the following data types:

TYPE DESCRIPTION

bool Logical Boolean value (true or false).

date Specific calendar date (year, month, day).

float8 8-byte floating-point number.

int2 Signed 2-byte integer (whole number).

int4 Signed 4-byte integer (whole number).

int8 Signed 8-byte integer (whole number).

numeric Exact numeric value with selectable precision.

text Variable-length character string.

time Specific time of day.

timestamp Specific calendar date and time of day.

varchar Variable-length character string.
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MCS Database Views
The following topics list each MCS database view and describes the individual 
columns storing data within each view.

v_activities

This view contains a record (row) for each backup, restore or validation activity 
that has taken place. 

IMPORTANT:  Beginning with version 4.0, use of this data-
base view is deprecated in favor of v_activities_2 (page
565). All official support for this database view is likely to be
discontinued in a future release.

COLUMN TYPE DESCRIPTION

axionsystemid varchar Avamar system ID.

bytes_excluded float8 Number of bytes intentionally 
excluded.
Not relevant for replication activities.

bytes_modified_sent float8 Not relevant for replication activities.

bytes_modified_not_sent float8 Not relevant for replication activities.

bytes_new float8 Number of bytes processed after data 
deduplication.

bytes_overhead float8 Number of bytes of overhead.
Not relevant for replication activities.

bytes_scanned float8 Number of bytes processed.
Not relevant for replication activities.

bytes_skipped float8 Number of bytes unintentionally 
skipped (errors, and so forth).

cid varchar Client ID (subject to change - avoid 
storing externally).

client_name varchar Client name.

client_os varchar Client operation system.

client_ver varchar Avamar client software version.

completed_date date Completed or terminated date.

completed_time time Completed or terminated time.

completed_ts timestamp Completed or terminated date and 
time.
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createtime numeric Avamar server timestamp for when 
backup was created.

dataset varchar Dataset used to perform this backup 
(applies to group-based backups 
only).

dataset_override bool True if client dataset was used 
instead of group dataset to perform 
this backup. 

display_name varchar VMware client display name.

domain varchar Client domain.

effective_expiration varchar Expiration of backup as calculated at 
time of backup.

effective_expiration_ts timestamp Expiration of backup as calculated at 
time of backup.

effective_path varchar Actual dataset used in backup 
(applies to group-based backups 
only).

encryption_method varchar Encryption method used. Valid values 
are:

• proprietary
• ssl

error_code int4 Numeric activity status completion 
code.

error_code_summary varchar If activity did not successfully 
complete, a short summary of this 
error code. 

expiration text Current expiration date.

expiration_ts timestamp Current expiration timestamp.

group_name varchar Group name (applies to group-based 
backups only).

initiated_by varchar Activity initiated by (applies to on-
demand backup only).

num_files_skipped float8 Number of file unintentionally 
skipped (errors, and so forth).
Not relevant for replication activities.

num_of_files float8 Number of files processed. Can be 
zero for replication activities.
Not relevant for replication activities.

plugin_name varchar Name of the plugin used to perform 
this activity.

COLUMN TYPE DESCRIPTION
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plugin_number int4 Numeric plugin ID.

recorded_date date Date activity was recorded.

recorded_date_time timestamp Date and time activity was recorded.

recorded_time time Time activity was recorded.

retention_policy varchar Retention policy used to perform this 
backup (applies to group-based 
backups only).

retention_policy_override bool True if client retention policy was 
used instead of group retention policy 
to perform this backup. 

schedule varchar Schedule used for scheduled 
backups.

schedule_recurrence varchar Recurrence interval. One of daily, 
weekly, yearly or monthly.

scheduled_end_date date Expected end date of activity. 

scheduled_end_time time Expected end time of activity.

scheduled_end_ts timestamp Expected end date and time of 
activity.

scheduled_start_date date Scheduled start date.

scheduled_start_time time Scheduled start time.

scheduled_start_ts timestamp Scheduled start date and time.

session_id varchar Unique identifier for this activity.

snapup_label varchar Backup label.
Is blank for replication activities.

snapup_number varchar Backup number.
Is blank for replication activities.

started_date date Actual start date of activity.

started_time time Actual start time of activity.

started_ts timestamp Actual start date and time of activity.

status_code int4 Last known status code of activity. 

status_code_summary varchar Short summary of this status code. 

COLUMN TYPE DESCRIPTION
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v_activities_2

This view contains a record (row) for each non-replication activity (that is, backup, 
restore or validation) that has taken place. Replication activities are stored in 
v_repl_actitivities (page 596). 

type varchar Type of activity. Valid values are: 
• On-Demand Snapup
• Scheduled Snapup
• Restore
• Validate

NOTE:  Value “Archive Source” 
deprecated in version 3.7; 

COLUMN TYPE DESCRIPTION

axionsystemid varchar Avamar system ID.

bytes_excluded float8 Number of bytes intentionally 
excluded.

bytes_modified_sent float8 Number of bytes modified and sent.

bytes_modified_not_sent float8 Number of bytes modified but not 
sent.

bytes_new float8 Number of bytes processed after data 
deduplication.

bytes_overhead float8 Number of bytes of overhead.

bytes_scanned float8 Number of bytes processed.

bytes_skipped float8 Number of bytes unintentionally 
skipped (errors, and so forth).

cid varchar Client ID (subject to change - avoid 
storing externally).

client_name varchar Client name.

client_os varchar Client operation system.

client_ver varchar Avamar client software version.
NOTE:  If this activity is a VMware 
image backup or restore, this is 
Avamar client software version 
running on the proxy server.

completed_date date Completed or terminated date.

completed_time time Completed or terminated time.

completed_ts timestamp Completed or terminated date and 
time.

COLUMN TYPE DESCRIPTION
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createtime numeric Avamar server timestamp for when 
backup was created.

dataset varchar Dataset used to perform this backup 
(applies to group-based backups 
only).

dataset_override bool True if client dataset was used 
instead of group dataset to perform 
this backup. 

display_name varchar VMware client display name.

domain varchar Client domain.

effective_expiration varchar Expiration of backup as calculated at 
time of backup.

effective_expiration_ts timestamp Expiration of backup as calculated at 
time of backup.

effective_path varchar Actual dataset used in backup 
(applies to group-based backups 
only).

encryption_method varchar Encryption method used for client/
server data transfer. Choices are:

• proprietary
• ssl

encryption_method2 varchar Encryption method used for client/
server data transfer. Choices are:

Medium Medium strength 
encryption.

High Strongest available 
encryption setting for that 
specific client platform.

None No encryption.

NOTE:  The exact encryption 
technology and bit strength used for 
any given client-server connection is 
dependent on a number of factors, 
including the client platform and 
Avamar server version. Refer to your 
Avamar Product Security Guide for 
additional information.

encrypt_method2_sa bool True if mcserver.xml 
encrypt_server_authenticate 
preference is set true. Otherwise, 
false.

COLUMN TYPE DESCRIPTION
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error_code int4 Numeric activity status completion 
code.

error_code_summary varchar If activity did not successfully 
complete, a short summary of this 
error code. 

expiration text Current expiration date.

expiration_ts timestamp Current expiration timestamp.

group_name varchar Group name (applies to group-based 
backups only).

initiated_by varchar Activity initiated by (applies to On-
Demand Backup only).

num_files_skipped float8 Number of files unintentionally 
skipped (errors, and so forth).

num_of_files float8 Number of files processed. 

plugin_name varchar Name of the plugin used to perform 
this activity.

plugin_number int4 Numeric plugin ID.

proxy_cid varchar VMware proxy client unique ID.

recorded_date date Date activity was recorded.

recorded_date_time timestamp Date and time activity was recorded.

recorded_time time Time activity was recorded.

retention_policy varchar Retention policy used to perform this 
backup (applies to group-based 
backups only).

retention_policy_override bool True if client retention policy was 
used instead of group retention policy 
to perform this backup. 

schedule varchar Schedule used for scheduled 
backups.

schedule_recurrence varchar Recurrence interval. One of daily, 
weekly, yearly or monthly.

scheduled_end_date date Expected end date of activity. 

scheduled_end_time time Expected end time of activity.

scheduled_end_ts timestamp Expected end date and time of 
activity.

scheduled_start_date date Scheduled start date.

scheduled_start_time time Scheduled start time.

COLUMN TYPE DESCRIPTION
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v_activity_errors

This view contains a record (row) that stores the total number of times a specific 
event code is encountered during a specific activity.

scheduled_start_ts timestamp Scheduled start date and time.

session_id varchar Unique identifier for this activity.

snapup_label varchar Backup label.
Is blank for replication activities.

snapup_number varchar Backup number.
Is blank for replication activities.

started_date date Actual start date of activity.

started_time time Actual start time of activity.

started_ts timestamp Actual start date and time of activity.

status_code int4 Last known status code of activity. 

status_code_summary varchar Short summary of this status code. 

type varchar Type of activity. Valid values are: 
• On-Demand Backup
• Scheduled Backup
• Restore
• Validate

NOTE:  Value “Archive Source” 
deprecated in version 3.7.

wid varchar Unique workorder identifier for this 
activity.

COLUMN TYPE DESCRIPTION

cid varchar Client ID.

cnt int4 Count of the number of this event code 
encountered.

code int4 Event code.

pid_number int4 Plugin number.

session_id varchar Session ID.

COLUMN TYPE DESCRIPTION
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v_audits

This view contains a record (row) for each audit log entry. 

COLUMN TYPE DESCRIPTION

audit_id int4 Internally generated unique ID for this audit 
entry.

date_time timestamp Date and time of event.

domain varchar Domain associated with this event.

ecode int4 Event code.

product varchar Values include:
• EM
• EMS
• END_USER
• MCCLI
• MCGUI
• MCS
• SNMP_SUB_AGENT
• WEB_RESTORE

role varchar Values include:
• Administrator
• Activity Operator
• Restore Only Operator

object varchar Values include:
• ACTIVITY
• AGENT
• BACKUP
• CLIENT
• CP
• CPV
• CRG
• CRON
• DATASET
• DOMAIN
• EMS
• EVENT
• GC
• GROUP
• HFSCHECK
• MCS
• PLUGIN
• PROFILE
• REPL
• REPORT
• RETENTION
• SCHEDULE
• SNMP_SUB_AGENT
• SNMPD
• SYSLOGD
• USER
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  569



 MCS Database Views
APPENDIX C — MCS AND EMS DATABASE VIEWS
v_clients

This view contains a record (row) for each client known to the MCS. 

IMPORTANT:  Beginning with version 4.0, use of this data-
base view is deprecated in favor of v_clients_2 (page 573).
All official support for this database view is likely to be dis-
continued in a future release. 

operation varchar Values include:
• ACK
• ACTIVATE
• ADD
• AUTH
• BACKUP
• BROWSE
• CANCEL
• COPY
• DELETE
• DISABLE
• EDIT
• ENABLE
• EXPORT
• LOGON
• RESTART
• RESUME
• RETIRE
• RUN
• START
• STOP
• SUSPEND
• VALIDATE

user_name varchar User ID that initiated this action.

COLUMN TYPE DESCRIPTION

agent_version varchar Version of agent installed.

allow_overtime bool True if client can ignore 
scheduling window end time.
See also overtime_option (page 
572).

allow_userinit_snapup_file_sel varchar Allow file selection on user 
initiated backups.

allow_userinit_snapups varchar Allow user initiated backups.

backed_up_ts timestamp Last backup date/time.

COLUMN TYPE DESCRIPTION
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can_page bool True if MCS can call out to client.

checkin_ts timestamp Last checkin date/time.

cid varchar Client ID (subject to change - 
avoid storing externally).

client_addr varchar Client IP address.

client_name varchar Client name.

client_type varchar Client type. One of the 
following:

• REGULAR
• VCENTER
• VMACHINE
• VPROXY
• VREGULAR

contact_email varchar Contact email address.

contact_location varchar Contact location.

contact_name varchar Person to contact regarding 
issues with this client.

contact_notes varchar Contact notes.

contact_phone varchar Contact phone number.

created date Creation date.

ds_override bool True if client can override group 
dataset

enabled bool True if client can generate 
activities.

full_domain_name varchar Fully qualified client location.

has_snapups bool True if the client has backups.

modified date Date that client information was 
last modified.

os_type varchar Client OS type.

override_userinit_retpol varchar Override standard retention 
policy on user initiated backups.

COLUMN TYPE DESCRIPTION
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overtime_option varchar One of the following:

ALWAYS Scheduled 
group 
backups are 
always 
allowed to 
run past the 
schedule 
duration 
setting.

NEXT Only the 
next 
scheduled 
group 
backup is 
allowed to 
run past the 
schedule 
duration 
setting.

NEXT_SUCCESS Scheduled 
group 
backups are 
allowed to 
run past the 
schedule 
duration 
setting until 
a successful 
backup is 
completed.

NEVER Scheduled 
group 
backups are 
never 
allowed to 
run past the 
schedule 
duration 
setting.

This value is automatically set to 
NEXT_SUCCESS when client 
initially registers and is cleared 
after one backup successfully 
completes.

page_addr varchar IP address used to contact this 
client.

COLUMN TYPE DESCRIPTION
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v_clients_2

This view contains a record (row) for each client known to the MCS. 

page_port varchar Data port used to contact this 
client.

pageadr_locked bool True if address cannot be 
updated automatically by MCS.

plugin_for_last_backup varchar Plugin used for the last backup.

rc_override bool True if client can override group 
retry count setting.

registered bool True if client has checked into 
MCS.

registered_ts timestamp Registered date/time.

restore_only bool True if client can only do 
restores.

retry_cnt int4 Connection retry count.

rp_override bool True if client can override group 
retention policy.

timeout int4 Connection timeout value.

tp_override bool True if client can override group 
timeout period setting.

COLUMN TYPE DESCRIPTION

agent_version varchar Version of agent installed.

allow_overtime bool True if client can ignore 
scheduling window end time.
See also overtime_option (page 
575).

allow_userinit_snapup_file_sel varchar Allow file selection on user 
initiated backups.

allow_userinit_snapups varchar Allow user initiated backups.

backed_up_ts timestamp Last backup date/time.

can_page bool True if MCS can call out to client.

checkin_ts timestamp Last checkin date/time.

cid varchar Client ID (subject to change - 
avoid storing externally).

client_addr varchar Client IP address.

COLUMN TYPE DESCRIPTION
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client_name varchar Client name.

client_type varchar Client type. One of the 
following:

• REGULAR
• VCENTER
• VMACHINE
• VPROXY
• VREGULAR

contact_email varchar Contact email address.

contact_location varchar Contact location.

contact_name varchar Person to contact regarding 
issues with this client.

contact_notes varchar Contact notes.

contact_phone varchar Contact phone number.

created date Creation date.

display_client_name varchar Virtual machine displayable 
node name.

display_full_domain varchar Fully qualified domain and client 
display name.

ds_override bool True if client can override group 
dataset

enabled bool True if client can generate 
activities.

full_domain_name varchar Fully qualified client location.

has_snapups bool True if the client has backups.

modified date Date that client information was 
last modified.

os_type varchar Client OS type.

override_userinit_retpol varchar Override standard retention 
policy on user initiated backups.

COLUMN TYPE DESCRIPTION
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overtime_option varchar One of the following:

ALWAYS Scheduled 
group 
backups are 
always 
allowed to 
run past the 
schedule 
duration 
setting.

NEXT Only the 
next 
scheduled 
group 
backup is 
allowed to 
run past the 
schedule 
duration 
setting.

NEXT_SUCCESS Scheduled 
group 
backups are 
allowed to 
run past the 
schedule 
duration 
setting until 
a successful 
backup is 
completed.

NEVER Scheduled 
group 
backups are 
never 
allowed to 
run past the 
schedule 
duration 
setting.

This value is automatically set to 
NEXT_SUCCESS when client 
initially registers and is cleared 
after one backup successfully 
completes.

page_addr varchar IP address used to contact this 
client.

COLUMN TYPE DESCRIPTION
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v_compatibility

This view stores MCS database compatibility information.

page_port varchar Data port used to contact this 
client.

pageadr_locked bool True if address cannot be 
updated automatically by MCS.

plugin_for_last_backup varchar Plugin used for the last backup.

rc_override bool True if client can override group 
retry count setting.

registered bool True if client has checked into 
MCS.

registered_ts timestamp Registered date/time.

restore_only bool True if client can only do 
restores.

retry_cnt int4 Connection retry count.

rp_override bool True if client can override group 
retention policy.

timeout int4 Connection timeout value.

tp_override bool True if client can override group 
timeout period setting.

COLUMN TYPE DESCRIPTION

component varchar Subsystem component. One of the following:
• db_schema_version_init
• db_schema_version
• db_views_schema_version

version varchar Specific version number of the component.

COLUMN TYPE DESCRIPTION
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v_datasets

This view contains a record (row) for each dataset known to the MCS. 

v_dpnsummary

This view contains a record (row) for each backup, restore or validation activity on 
a client-by-client basis. 

COLUMN TYPE DESCRIPTION

all_data bool True if dataset will save all data.

domain varchar Avamar domain associated with dataset.

is_link bool True if dataset is pointer to another dataset.

is_read_only bool True if dataset cannot be modified.

link_name varchar Name of dataset if is_link is true.

name varchar Name of dataset.

COLUMN TYPE DESCRIPTION

clientver varchar Version of agent software running on client.

host varchar Client name.

mod_sent float8 Bytes modified and sent.

modnotsent float8 Bytes modified but not sent.

numfiles float8 Number of files processed.

nummodfiles float8 Number of files modified.

operation varchar Type of activity reported by this entry.

os varchar Client operating system.

overhead float8 Number of bytes of overhead sent and stored on 
storage subsystem.

pcntcommon int4 Percent data deduplication.

reduced float8 Bytes reduced by compression.

root varchar Dataset used in backup applies to group-based 
backups only.

seconds float8 Completed or terminated date and time.

sessionid varchar Unique identifier for client to storage subsystem 
session for this activity.
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v_dpn_stats

This view contains a record (row) for Avamar server statistics. 

v_ds_commands

This view contains a record (row) for each optional plugin command defined for 
each dataset.

starttime timestamp Date and time job was actually dispatched to 
client by Avamar Administrator. 
NOTE:  Start time in client log might be slightly 
later due to communication and job setup 
latency. 

startvalue float8 Scheduled start date and time, expressed as 
elapsed time (in seconds) since beginning of the 
Unix epoch.

status varchar Success/fail result of this activity.

totalbytes float8 Number of bytes processed.

workorderid varchar Unique workorder identifier for this activity.

COLUMN TYPE DESCRIPTION

data_protected_mb float8 Megabytes protected.

date date Date.

date_time timestamp Date and time.

dpn_name varchar Avamar server name.

time time Time.

COLUMN TYPE DESCRIPTION

command_name varchar Name of command.

dataset_name varchar Name of dataset.

domain varchar Domain.

plugin_name varchar Name of plugin.

type varchar Type of optional plugin command.

value varchar Value associated with command name.

COLUMN TYPE DESCRIPTION
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v_ds_excludes

This view contains a record (row) for each exclude definition defined for each 
dataset.

v_ds_includes

This view contains a record (row) for each include definition defined for each 
dataset.

v_ds_targets

This view contains a record (row) for each source target defined for each dataset. 

v_ev_catalog

This view contains a record (row) for each event code in the events catalog. 

COLUMN TYPE DESCRIPTION

dataset_name varchar Name of dataset.

domain varchar Domain.

plugin_name varchar Name of plugin.

value varchar Exclude value for dataset/plugin.

COLUMN TYPE DESCRIPTION

dataset_name varchar Name of dataset.

domain varchar Domain.

plugin_name varchar Name of plugin.

value varchar Include value for dataset/plugin.

COLUMN TYPE DESCRIPTION

dataset_name varchar Name of dataset.

domain varchar Domain.

plugin_name varchar Name of plugin.

value varchar Target value for dataset/plugin.

COLUMN TYPE DESCRIPTION

category varchar Event category.

code int4 Event code.

name varchar Event name.
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object varchar Values include:
• ACTIVITY
• AGENT
• BACKUP
• CLIENT
• CP
• CPV
• CRG 
• CRON
• DATASET
• DOMAIN
• EMS
• EVENT
• GC
• GROUP
• HFSCHECK
• MCS
• PLUGIN
• PROFILE
• REPL
• REPORT
• RETENTION
• SCHEDULE
• SNMP_SUB_AGENT
• SNMPD
• SYSLOGD
• USER

operation varchar Values include:
• ACK
• ACTIVATE
• ADD
• AUTH
• BACKUP
• BROWSE
• CANCEL
• COPY,
• DELETE
• DISABLE
• EDIT
• ENABLE
• EXPORT
• LOGON
• RESTART
• RESUME
• RETIRE
• RUN
• START
• STOP
• SUSPEND
• VALIDATE

severity varchar Event severity.

COLUMN TYPE DESCRIPTION
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v_ev_cus_body

This view contains a record (row) listing the attachments for each custom events 
profile. 

v_ev_cus_cc_list

This view contains a record (row) listing the email cc recipients for each custom 
events profile. 

v_ev_cus_codes

This view contains a record (row) for each event code that should be included in a 
custom events profile. 

summary varchar Single-line event description.

swSource varchar Software modules generating event.

type varchar Event type.

COLUMN TYPE DESCRIPTION

attachments varchar String of attachment data.

epid varchar Unique ID for this events profile.

COLUMN TYPE DESCRIPTION

cc_list varchar List of email cc recipients.

epid varchar Unique ID for this events profile.

COLUMN TYPE DESCRIPTION

code int4 Event code to monitor.

cur_value bool True if code triggers email and syslog 
notification.

default_value bool Original default setting for email and syslog 
notification.

epid varchar Unique ID for this events profile.

COLUMN TYPE DESCRIPTION
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v_ev_cus_prof

This view contains a record (row) for each custom events profile. 

v_ev_cus_prof_params

This view contains event code-specific parameters for custom event profiles.

COLUMN TYPE DESCRIPTION

active bool True if profile is enabled.

connectemc_channel varchar ConnectEMC configuration channel 
used for this profile.

connectemc_notify_enabled bool True if ConnectEMC Notification is 
enabled for this profile.

domain varchar Profile domain.

email_notify_enabled bool True if email notification should 
occur.

epid varchar Unique ID for this events profile.

include_logs bool True if logs are included in email.

include_nodelist bool True if nodelist is included in email.

inline_email_attachments bool True if email attacments are 
included in the body of the email.

log_dir varchar Directory location of log files.

name varchar Name of custom profile.

read_only bool True if not modifiable.

sched_id varchar Email schedule.

snmp_notify_enabled bool True if snmp notification should.

subject varchar Email subject header string.

syslog_notify_enabled bool True if syslog notification should 
occur.

timestamp numeric Date and time of last email check, 
expressed as elapsed time (in 
seconds) since beginning of the 
Unix epoch.

COLUMN TYPE DESCRIPTION

ecode int4 Event code.

epid varchar Profile ID.

param varchar Parameter.

value varchar Value.
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v_ev_cus_rpt

This view contains a record (row) for each report emailed with an event profile.

v_ev_cus_snmp_contact

This view contains a record (row) for each profile’s snmp trap configuration.

COLUMN TYPE DESCRIPTION

enabled bool True if option to email report was set.

epid varchar Profile ID.

output_csv bool True if report was emailed in Comma-Separated 
Values (CSV) format.

output_txt bool True if report was emailed in plain text format.

output_xml bool True if report was emailed in XML format.

rptid varchar Report ID.

since_count int4 Number of days, weeks or months since last email 
was sent, or 0 if since_option is last_notified.

since_option varchar Unit of measure for since_count. Values include:
• day
• week
• month
• last_notified

COLUMN TYPE DESCRIPTION

community varchar Name of the snmp community to send traps as.

epid varchar Profile ID.

snmp_host varchar Host to send snmp traps to.

snmp_port varchar Data port to send snmp traps to (default: 162).
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v_ev_cus_syslog_contact

This view contains a record (row) for each custom event profile that uses syslog as 
the notification mechanism. 

v_ev_cus_to_list

This view contains a record (row) listing the email recipients for each custom 
events profile. 

COLUMN TYPE DESCRIPTION

epid varchar Unique ID for this events profile.

facility int4 Syslog facility. Valid values are:

1 user.

16 local0.

17 local1.

18 local2.

19 local3.

20 local4.

21 local5.

22 local6.

23 local7.

format int4 Output format. Valid values are:

1 XML.

2 Plain text.

syslog_host varchar Default value is localhost.

syslog_port int4 Default value is port 514.

COLUMN TYPE DESCRIPTION

epid varchar Unique ID for this events profile.

to_list varchar List of email recipients.
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v_ev_unack

This view contains a record (row) for each unacknowledged event logged by the 
MCS. 

COLUMN TYPE DESCRIPTION

audience varchar Intended audience of event.

category varchar Event category. Valid values are:
• APPLICATION
• SECURITY
• SYSTEM
• USER

code int4 Event code.

data varchar Event data.

date date Date of event.

description varchar Long event description.

domain varchar Domain associated with the event.

event_id int4 Internally-generated event ID.

notes varchar Event notes text.

remedy varchar Event remedy text.

severity varchar Event severity. Valid values are:
• NODE
• NODE_FATAL
• OK
• PROCESS
• PROCESS_FATAL
• SYSTEM_FATAL
• USER
• USER_FATAL

software_source varchar Software modules generating event.

source varchar Host generating event.

summary varchar Single-line event description.

time time Time of event.

timestamp numeric Date and time of event, expressed as elapsed 
time (in seconds) since beginning of the Unix 
epoch.

type varchar Event type. Valid values are:
• INTERNAL
• ERROR
• WARNING
• INFORMATION
• DEBUG
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v_events

This view contains a record (row) for each event logged by the MCS.

COLUMN TYPE DESCRIPTION

audience varchar Intended audience of event.

category varchar Event category. Valid values are:
• APPLICATION
• SECURITY
• SYSTEM
• USER

code int4 Event code.

data varchar Event data.

date date Date of event.

description varchar Long event description.

domain varchar Domain associated with the event.

event_id int4 Internally-generated event ID.

notes varchar Event notes text.

remedy varchar Event remedy text.

severity varchar Event severity. Valid values are:
• NODE
• NODE_FATAL
• OK
• PROCESS
• PROCESS_FATAL
• SYSTEM_FATAL
• USER
• USER_FATAL

software_source varchar Software modules generating event.

source varchar Host generating event.

summary varchar Single-line event description.

time time Time of event.

timestamp numeric Date and time of event, expressed as elapsed 
time (in seconds) since beginning of the Unix 
epoch.

type varchar Event type. Valid values are:
• INTERNAL
• ERROR
• WARNING
• INFORMATION
• DEBUG
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v_gcstatus

This view contains a record (row) for each garbage collect (GC) operation.

COLUMN TYPE DESCRIPTION

bytes_recovered int8 Number of bytes recovered in this 
garbage collect operation.

chunks_deleted int4 Number of chunks deleted in this 
garbage collect operation.

elapsed_time int8 Total elapsed time in seconds for this 
garbage collect operation.

end_time timestamp Date and time this garbage collect 
operation ended.

gcstatusid int8 Unique ID for this garbage collect 
operation.

indexstripes_processed int4 Number of index stripes involved in this 
garbage collect operation.

indexstripes_total int4 Number of index stripes.

node_count int4 Number of nodes involved in this 
garbage collect operation.

result varchar String result code.

start_time timestamp Date and time this garbage collect 
operation started.
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  587



 MCS Database Views
APPENDIX C — MCS AND EMS DATABASE VIEWS
v_group_members

This view contains a record (row) for each client organized by group assignment.

NOTE:  One client can be a member of more than one
group.

COLUMN TYPE DESCRIPTION

cid varchar Client ID (subject to change - avoid storing 
externally).

client_name varchar Client name.

dataset_name varchar Dataset name.

enabled bool True if client enabled in the group.

full_client_name varchar Client domain and hostname.

group_name varchar Group name.

restore_only bool True if client has been deleted and is 
available only for restore.

retention_name varchar Retention policy name.

use_client_ds bool True if client dataset should be used.

use_client_retry bool True if client retry should be used.

use_client_rp bool True if client retention policy should be used.

use_client_timeout bool True if client timeout should be used.
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v_groups

This view contains a record (row) for each group known to the MCS.

COLUMN TYPE DESCRIPTION

created date Creation date.

dataset_name varchar Dataset name.

dataset_domain varchar Dataset domain.

domain varchar Domain.

enabled bool True if group is active/enabled.

failed_stop bool True if group backups should stop on failed 
backup.

group_type varchar One of the following:
• REGULAR
• VCENTER

modified date Last modified date.

name varchar Group name.

priority int4 Group priority.

read_only bool True if group cannot be modified.

retention_name varchar Retention policy name.

retention_domain varchar Retention policy domain.

retry_cnt int4 Retry count.

run_once bool True if running only one backup.

schedule_name varchar Schedule name.

schedule_domain varchar Schedule domain.

skip_next bool True if skipping next scheduled backup.

target_dpn varchar Avamar server to be used for this group.

timeout_min int4 Timeout in minutes.
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v_node_space

This view contains a record (row) of disk capacity data retrieved or calculated per 
disk and per node.

COLUMN TYPE DESCRIPTION

capacity_mb float8 Disk size.

date date Date.

date_time timestamp Date and time.

disk int2 Disk number.

diskreadonly int2 Value applied to normalize percent full.

node varchar Node number.

stripes_reserved_mb float8 Bytes reserved for stripe usage.

stripes_used_mb float8 Amount of reserved stripe bytes used.

time time Time.

used_mb float8 Disk capacity used.

utilization numeric Percentage of storage space used.
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v_node_util

This view contains a record (row) of node statistics retrieved or calculated per 
node at a particular date and time.

v_plugin_can_restore

This view contains a record (row) of allowable plugin substitutions for restores. 
Each record is a one-to-one allowable substition in which the orignal backup plugin 
(build, version) is matched with with an allowable substitute plugin ID 
(can_restore_pid). 

COLUMN TYPE DESCRIPTION

cpu_sys_percentage numeric Percentage of node utilization by 
operating system.

cpu_user_percentage numeric Percentage of node utilization by user.

date date Date.

date_time timestamp Date and time.

disk_reads_per_sec int4 Disk reads per second.

disk_writes_per_sec int4 Disk writes per second.

diskreadonly int2 Value applied to normalize percent full.

load_avg numeric Load average.

net_in_kbytes_per_sec int4 Network received (KB/s).

net_out_kbytes_per_sec int4 Network transmitted (KB/s).

net_ping numeric Node ping time.

node varchar Node ID.

state varchar Node state.

time time Time.

utilization numeric Percentage of storage space used.

COLUMN TYPE DESCRIPTION

build varchar An exception to the plugin version value if not 
ALL.

can_restore_pid int4 PID of the plugin which this plugin can use to 
perform restores.

pid_number int4 Numeric plugin ID.

version varchar Plugin version.
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v_plugin_catalog

This view contains a record (row) for each known plugin.

COLUMN TYPE DESCRIPTION

content varchar Content description of the 
plugin.

description varchar Descriptive name of the 
plugin.

encryption_mode varchar Encryption method used. 
Valid values are:

• proprietary
• ssl

explicit_target_supported bool True if targets for the 
plugin can be entered when 
creating/editing a dataset 
for the plugin.

implicit_target_supported bool True if the concept of all 
systems for the plugin is 
supported when creating/
editing a dataset.

include_implicit_as_default bool True if implicit target 
included by default when 
creating/editing a dataset.

multiple_restore_targets_supported bool True if multiple restore 
targets can be entered 
when restoring a backup.

multiple_targets_supported bool True if multiple targets can 
be entered when creating/
editing a dataset for the 
plugin.

pid varchar Name of the plugin.

pid_number int4 Unique plugin 
identification.

version varchar Plugin version.
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v_plugin_depends_upon

This view contains a record (row) for each known plugin dependency. Each record 
is a one-to-one match of an existing plugin ID (build, version) and the plugin ID 
on which it is dependent (dependence_on_pid). 

v_plugin_flag_groups

This view contains a record (row) for each grouping of plugin options (flags).

v_plugin_flag_pulldown

This view contains a record (row) for each entry in a pulldown plugin option (flag).

COLUMN TYPE DESCRIPTION

build varchar An exception to the plugin version value if 
not ALL.

dependence_on_pid int4 PID of the plugin that this plugin depends 
upon.

pid_number int4 Numeric plugin ID.

version varchar Plugin version.

COLUMN TYPE DESCRIPTION

cgid varchar Control group ID.

description varchar

group_order int4 Order of group.

tooltip varchar Text shown when cursor hovers over plugin.

type varchar One of the following:
• logical
• radio

COLUMN TYPE DESCRIPTION

build varchar An exception to the plugin version value if not 
ALL.

description varchar Displayable value of the entry.

entry varchar Entry in the pulldown menu.

fid varchar Flag ID.

flag_order int4 Order of flag in pulldown.

plugin_number int4 Numeric plugin ID.

version varchar Plugin version.
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v_plugin_flags

This view contains a record (row) for each plugin option (flag) available to be used 
for backups and restores for each plugin.

COLUMN TYPE DESCRIPTION

build varchar An exception to the plugin version value if not 
ALL.

cgid varchar Control grouping.

command varchar One of the following:
• restore
• backup

description varchar

fid varchar Flag ID.

flag_order int4 Order of group.

max int4 Maximum value of the flag, if applicable.

min int4 Minimum value of the flag, if applicable.

name varchar

plugin_number int4 Numeric plugin ID.

pidnum int4 Plugin number that this flag should be directed 
too.

tooltip varchar Text shown when cursor hovers over plugin.

type varchar One of the following:
• boolean (checkbox)
• integer (field)
• string (field)

value varchar Default value of the flag.

version varchar Plugin version.
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v_plugin_options

This view contains a record (row) of available options for a plugin; one option per 
record (row).

v_plugin_state

This view contains a record (row) that stores the state of each plugin.

COLUMN TYPE DESCRIPTION

build varchar An exception to the version if not ALL.

can_modify bool For disable options only. True if the option 
value is preserved on upgrades.

option_name varchar Valid values are:
• browse_supported
• disable_browse
• disable_mc_adhoc_snapups
• disable_restore disable_validate
• disable_scc_adhoc_snapups
• disable_scheduled_snapups
• restore_supported
• snapup_supported
• snapup_supports_cl_options
• snapup_supports_exclusion
• snapup_supports_inclusion
• validate_supports

option_value bool True or false.

pid_number int4 Numeric plugin ID.

version varchar Plugin version.

COLUMN TYPE DESCRIPTION

build varchar An exception to the plugin version values if 
not ALL.

obsolete bool True if the plugin is obsolete.

obsolete_comment varchar Comment as to why the plugin became 
obsolete.

pid_number int4 Numeric plugin ID.

user_added bool True if the user added the build.

version varchar Plugin version.
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v_plugins

This view contains a record (row) for each plugin installed on any client known to 
the MCS. 

v_repl_activities

This view contains a record (row) for each replication activity that has taken place. 

COLUMN TYPE DESCRIPTION

backed_up_ts timestamp Last backup date using this plugin.

build varchar Plugin build.

cid varchar Client ID (subject to change - avoid storing 
externally).

client_name varchar Name of client.

full_client_name varchar Client domain and hostname.

installed_ts timestamp Date this plugin type was first registered with 
MCS.

lastupdate_ts timestamp Date this current plugin version was first 
registered with MCS.

name varchar Description of plugin.

plugin_name varchar Name of plugin.

version varchar Plugin version.

COLUMN TYPE DESCRIPTION

bytes_excluded float8 Number of bytes intentionally 
excluded.

bytes_modified_sent float8 Number of bytes modified and sent.

bytes_modified_not_sent float8 Number of bytes modified but not 
sent.

bytes_new float8 Number of bytes processed after data 
deduplication.

bytes_overhead float8 Number of bytes of overhead.

bytes_reduced_comp float8 Number of bytes reduced by 
compression.

bytes_scanned float8 Number of bytes processed.

bytes_skipped float8 Number of bytes unintentionally 
skipped (errors, and so forth).

cid varchar Client ID (subject to change — avoid 
storing externally).
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client_name varchar Client name.

client_os varchar Client operation system.

client_ver varchar Avamar client software version.

completed_ts timestamp Date and time this replication 
operation actually ended.

dpn_domain varchar Client domain.

encryp_method text Encryption method used for client/
server data transfer. Choices are:

• proprietary
• ssl

NOTE:  This column is deprecated 
and exists for historical purposes 
only. Use encryp_method2 instead.

encryp_method2 varchar Encryption method used for client/
server data transfer. Choices are:

High Strongest available 
encryption setting for that 
specific client platform.

Medium Medium strength 
encryption.

None No encryption.

NOTE:  The exact encryption 
technology and bit strength used for 
any given client-server connection is 
dependent on a number of factors, 
including the client platform and 
Avamar server version. Refer to your 
Avamar Product Security Guide for 
additional information.

encrypt_method2_sa bool True if server authentication was 
enforced at the time of the backup 
(that is, mcserver.xml 
encrypt_server_authenticate 
preference is set true).

error_code int4 Numeric activity status completion 
code.

error_code_summary varchar Last known error code summary.

initiated_by varchar Activity initiated by this user or MCS.

num_files_skipped float8 Number of file unintentionally 
skipped (errors, and so forth).

num_mod_files float8 Number of files modified.

COLUMN TYPE DESCRIPTION
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num_of_files float8 Number of files processed. Can be 
zero for replication activities.

plugin_name varchar Plugin name.

plugin_number int4 Plugin number.

recorded_date date Date replication occurred.

retention_type varchar This replicatication activity included 
one or more of the following 
retention types:

D Daily backups.

W Weekly backups.

M Monthly backups.

Y Yearly backups.

N Backups not tagged as 
having a specific retention 
type.

scheduled_end_ts timestamp Date and time this replication 
operation was scheduled to end.

scheduled_start_ts timestamp Date and time this replication 
operation was scheduled to occur.

session_id varchar Unique identifier for this activity.

started_ts timestamp Date and time this replication 
operation actually started.

status_code int4 Numeric status code.

status_code_summary varchar Status code summary.

systemid varchar Avamar system ID.

type varchar Type of activity. Valid values are: 
• Replication Destination
• Replication Source

wid varchar Unique workorder identifier for this 
activity.

COLUMN TYPE DESCRIPTION
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v_report_filter

This view contains a record (row) for each report identifying its filter options. 

v_reports

This view contains a record (row) for each report.

COLUMN TYPE DESCRIPTION

filter_name varchar Filter name.

filter_value varchar Filter value.

rptid varchar Report ID.

COLUMN TYPE DESCRIPTION

adhoc_query bool True if a query statement is being used instead 
of filtering options.

domain varchar Report domain.

graphs_allowed varchar Not currently supported.

name varchar Report name.

readonly bool True if the report can not be edited or deleted. 
Used for 'canned' reports.

rptid varchar Report ID.

sql varchar SQL statement if adhoc_query is true.

view_name varchar Database view used by this report.
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v_retention_policies

This view contains a record (row) for each retention policy known to the MCS.

COLUMN TYPE DESCRIPTION

daily int4 Advanced policy daily retention.

domain varchar Domain.

duration numeric Duration of retention.

enabled bool True if enabled.

expiration_date numeric Expiration date.

is_link bool True if this is a reference to another retention 
policy.

link_name varchar Name of retention policy if is_link is true.

monthly int4 Advanced policy monthly retention.

name varchar Name of retention policy.

override bool True if advanced policy used for scheduled 
backups.

policy_no int4 Policy number. Valid policy numbers are:

0 Undefined.

1 Compute expiration date.

2 Static expiration date.

3 No expiration date.

read_only bool True if retention policy cannot be modified.

unit int4 Duration unit. Valid duration units are:

0 No expiration

1 Days

2 Weeks

3 Months

4 Years

weekly int4 Advanced policy weekly retention.

yearly int4 Advanced policy yearly retention.
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v_sch_recurrence

This view contains a record (row) for each recurring schedule known to the MCS.

COLUMN TYPE DESCRIPTION

domain varchar Schedule domain.

modifier text Qualifies entries in the value column as 
follows:

day Indicates that this is a monthly 
schedule that runs on every 
numerical calendar day specified by 
the value column entry. 

hour Indicates that this is a daily 
schedule that runs on every hour of 
the day specified by the value 
column entry.

every Indicates that this is a weekly 
schedule that runs on every day of 
the week specified by the value 
column entry. 

first Indicates that this is a monthly 
schedule that runs during the first 
week of the month on the day of the 
week specified by the value column 
entry. 

second Indicates that this is a monthly 
schedule that runs during the 
second week of the month on the 
day of the week specified by the 
value column entry. 

third Indicates that this is a monthly 
schedule that runs during the third 
week of the month on the day of the 
week specified by the value column 
entry. 

fourth Indicates that this is a monthly 
schedule that runs during the fourth 
week of the month on the day of the 
week specified by the value column 
entry. 

last Indicates that this is a monthly 
schedule that runs during the last 
week of the month on the day of the 
week specified by the value column 
entry. 

name varchar Name of the schedule.
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v_schedules

This view contains a record (row) for each schedule known to the MCS.

IMPORTANT:  Beginning with version 4.0, use of this data-
base view is deprecated in favor of v_schedules_2 (page
604). All official support for this database view is likely to be
discontinued in a future release.

recur_interval text Recurrence interval. Valid recurrence intervals 
are:

• DAILY
• HOURLY
• WEEKLY
• MONTHLY
• YEARLY

value text Recurrence value.
For DAILY schedules, this value is the hour of 
the day.
For WEEKLY schedules, this value is the day of 
week, such as Saturday, Sunday, Monday, 
Tuesday, Wednesday, Thursday, and Friday.
For MONTHLY schedules that repeat on a 
specific day of the month, this numerical 
value is the day of the month.
For MONTHLY schedules that repeat on a 
specific day of a specific week, this value is 
the day of week, such as Saturday, Sunday, 
Monday, Tuesday, Wednesday, Thursday, and 
Friday.

COLUMN TYPE DESCRIPTION

description varchar Schedule description.

domain varchar Domain.

enabled bool True if schedule is enabled/active.

end_policy int4 Type of schedule termination setting. Valid 
values are:

2 Never end.

3 Run N number of times.

4 End on a specific date.

COLUMN TYPE DESCRIPTION
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end_recur numeric End recurrence. This is a specific date or a count 
of the number of times the schedule should run 
or 0 if the schedule never ends. This value is 
related to the value of end_policy.

first_start timestamp First start.

is_link bool True if this is a reference to another schedule.

last_check timestamp Last check.

last_start timestamp Last started.

link_name varchar Schedule name if is_link is true.

min_interval timestamp Minimum interval.

name varchar Name of schedule.

overtime bool True if schedule end time can be overridden.

read_only bool True if cannot be modified.

recur_counter numeric Recurrence counter.

recur_interval varchar Recurrence interval. Valid recurrence intervals 
are:

• DAILY
• HOURLY
• WEEKLY
• MONTHLY
• YEARLY

start_duration timestamp Duration of start scheduling window.

start_time timestamp Start time for scheduling window.

time_zone_id varchar Time zone of where the schedule was created or 
last modified.

total_duration timestamp Total duration of scheduling window.

type_enum varchar Type of schedule. The only valid schedule type is 
CALENDAR.

COLUMN TYPE DESCRIPTION
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v_schedules_2

This view contains a record (row) for each schedule known to the MCS.

COLUMN TYPE DESCRIPTION

description varchar Schedule description.

domain varchar Domain.

enabled bool True if schedule is enabled/active.

end_policy int4 Type of schedule termination setting. Valid 
values are:

2 Never end.

3 Run N number of times.

4 End on a specific date.

end_recur numeric End recurrence. This is a specific date or a count 
of the number of times the schedule should run 
or 0 if the schedule never ends. This value is 
related to the value of end_policy.

first_start timestamp First start.

is_link bool True if this is a reference to another schedule.

last_check timestamp Last check.

last_start timestamp Last started.

link_name varchar Schedule name if is_link is true.

min_interval timestamp Minimum interval.

name varchar Name of schedule.

overtime bool True if schedule end time can be overridden.

read_only bool True if cannot be modified.

recur_counter numeric Recurrence counter.

recur_interval varchar Recurrence interval. Valid recurrence intervals 
are:

• DAILY
• WEEKLY
• MONTHLY
• ADHOC

start_duration timestamp Duration of start scheduling window.

start_time timestamp Start time for scheduling window.

time_zone_id varchar Time zone of where the schedule was created or 
last modified.

total_duration timestamp Total duration of scheduling window.
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v_serial_numbers
This view stores a list of all Avamar server node serial numbers. 

v_systems

This view contains a record (row) for each Avamar system. 

type_enum varchar Type of schedule. The only valid schedule type is 
CALENDAR.

COLUMN TYPE DESCRIPTION

nodeid varchar Avamar logical node designation (for 
example, 0.0, 0.1, 0.s, and so forth).

serial_number varchar Avamar server node serial number.

serial_numbers_id bigint Unique Avamar server node ID.

COLUMN TYPE DESCRIPTION

gsansystemid varchar Avamar server ID.

gsansystemname varchar User assigned name.

hfsaddr varchar IP address of server.

hfsport int4 Port address of server.

lastupdate timestamp Last updated timestamp.

local_hfsaddr varchar Local IP address of server.

mcsport int4 Port address of MCS for server from 
axion_systems.

systemid int8 Numeric system ID (automatically assigned 
by MCS).

COLUMN TYPE DESCRIPTION
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EMS Database Views
The following topics list each EMS database view and describes the individual 
columns storing data within each view.

v_avamar_server

This view contains a record (row) for each Avamar server monitored by Avamar 
Enterprise Manager. 

COLUMN TYPE DESCRIPTION

adaurl varchar Universal Resource Locator (URL) for an 
optional Avamar Data Archive (ADA).

avamar_server_id bigint Unique Avamar server ID.

hfsport integer Avamar Hash File System (HFS) port number.

hostname varchar Avamar server hostname.

ip varchar Avamar server IP address.

lastcontact timestamp Time in UTC time the avamar system was last 
succesfully polled

local boolean True if this Avamar server is running on the 
same system as the Avamar Enterprise 
Manager server.

mcport integer Management Console Server (MCS) Remote 
Method Invocation (RMI) port number.

monitoring boolean True if monitoring this Avamar server.

note varchar Note about Avamar server entered by 
administrator.

rollbacktime bigint Unix time of last rollback.

status varchar Current polling status.

statusdetails varchar Detailed polling status.

systemid varchar Avamar system ID.

systemname varchar Avamar system name.

version varchar Avamar server version.
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v_compatibility

This view stores Avamar Enterprise Manager server database compatibility 
information. 

COLUMN TYPE DESCRIPTION

component varchar

version varchar
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Activation. See Client Activation (page 608).

Authentication System. A user name/ 
password system that is used to grant user 
access to the Avamar server. Avamar 
supports its own internal authentication 
system (avs), as well as several external 
authentication systems (OpenLDAP, 
Windows Active Directory, NIS and SMB). 

Avamar Administrator. Avamar 
Administrator is a graphical management 
console software application that is used to 
remotely administer an Avamar system from 
a supported Windows or client computer. 

Avamar Client. A computer or workstation 
running Avamar software and accessing the 
Avamar server over a network connection. 
Avamar client software comprises a client 
agent and one or more plugins.

Avamar Enterprise Manager. Avamar 
Enterprise Manager is a multi-server 
management console application that 
provides centralized Avamar server 
administration capabilities for larger 
businesses and enterprises.

Avamar Server. The server component of the 
Avamar client/server system. Avamar server 
is a fault-tolerant, high-availability system 
that efficiently stores the backups from all 
protected clients. It also provides essential 
processes and services required for data 
restores, client access and remote system 
administration. Avamar server runs as a 
distributed application across multiple 
networked storage nodes.

Avamar Web Access. Browser-based user 
interface that allows access to the Avamar 
server for the express purpose of restoring 
files to a client. 

Backup. A point-in-time copy of client data 
that can be restored as individual files, 
selected directories or as entire filesystems. 
Although more efficient than a conventional 
incremental backup, a backup is always a 
full, stand-alone copy of client data that can 
be restored immediately from an Avamar 
server. 

Client Activation. The process of passing the 
client ID (CID) back to the client, where it is 
stored in an encrypted file on the client 
filesystem.

Client Agent. An Avamar client agent is a 
platform-specific software process running 
on the client that actually communicates 
with the MCS (page 169) and with any 
plugins installed on that client. 
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  608



 
GLOSSARY
Client Registration. The process of 
establishing an identity with the Avamar 
server. When Avamar “knows” the client, it 
assigns a unique client ID (CID), which it will 
eventually pass back to the client during 
activation.

Dataset. A policy that defines a set of files, 
directories and filesystems for each 
supported platform that will be included or 
excluded in backups across a group of 
clients. A dataset is a persistent and 
reusable Avamar policy that can be named 
and attached to multiple groups. 

DNS . Domain Name Server. A dynamic and 
distributed directory service for assigning 
domain names to specific IP addresses.

Domain. A feature in Avamar Administrator 
that is used to organize large numbers of 
clients into named areas of control and 
management. 

Email Home feature. Optional feature that 
uses the High Priority Events profile and 
Notification schedule to regularly send 
server error and status messages directly to 
EMC Technical Support.

Enterprise Manager Server (EMS). The 
Avamar Enterprise Manager Server (EMS) 
provides essential services required to 
display Avamar system information and 
provides a mechanism for managing Avamar 
systems using a standard web browser. The 
Avamar Enterprise Manager server also 
communicates directly with existing MCSs, 
which are an integral part of the all Avamar 
systems in your enterprise.

Full Replication. A full “root-to-root” 
replication creates a complete logical copy of 
an entire source system on the destination 
system. The replicated data is not copied to 
the REPLICATE domain, it is added directly 
to the root domain just as if source clients 
had registered with the destination system. 
Also, source server data replicated in this 
manner is fully modifiable on the destination 
system. This is typically used for system 
migration (from a smaller Avamar 
configuration to a larger, possibly multi-node 
configuration) or system replacement (for 
instance, in a case of disaster recovery).

Group. A level of organization in Avamar 
Administrator for one or more Avamar 
clients. All clients in an Avamar group use 
the same group policies (dataset, backup 
schedule and retention policy). 

Group Policy. The dataset, schedule and 
backup retention policy attached to a group 
that will be used by all clients in a group, 
unless these policies settings are overridden 
by an administrator at the client level. 

HFS. Hash Filesystem. The content addressed 
storage area inside the Avamar server used 
to store client backups.

HFS Check. An Avamar Hash Filesystem 
check (HFS check) is an internal operation 
that validates the integrity of a specific 
checkpoint. Once a checkpoint has passed 
an HFS check, it can be considered reliable 
enough to be used for a server rollback.

JRE. Java Runtime Environment.

LAN. Local Area Network.

LOFS. Loopback Filesystem.

MAC Address. Media Access Control Address. 
A unique hardware address, typically 
embedded at the lowest level in a hardware 
assembly, that uniquely identifies each 
device on a network. 

Management Console Server (MCS). The 
MCS provides centralized administration 
(scheduling, monitoring and management) 
for the Avamar server. The MCS also runs 
the server-side processes used by the 
Avamar Administrator graphical 
management console.

Module. Avamar 1.2.0 and earlier multi-node 
Avamar servers utilized a dual-module 
synchronous RAIN architecture in which 
nodes were equally distributed in two 
separate equipment cabinets on separate 
VLANs. The term “module” is a logical 
construct used to describe and support this 
architecture (older multi-node Avamar 
servers comprised a primary module and a 
secondary module). These legacy systems 
continue to be supported. However, newer 
multi-node Avamar servers utilize a single 
AVAMAR 5.0 • SYSTEM ADMINISTRATION GUIDE  609



 
GLOSSARY
module architecture and even though 
Avamar Administrator provides “module 
detail” information, a module is therefore 
logically equivalent to the entire server.

NAT. Network Address Translation.

NDMP. Network Data Management Protocol.

NDMP Accelerator. Avamar NDMP 
Accelerator (accelerator) is a dedicated 
single-node Avamar client, that when used 
as part of an Avamar system, provides a 
complete backup and recovery solution for 
Network Appliance™ filers (filers) by way of 
the Network Data Management Protocol 
(NDMP).

NFS. Network Filesystem.

NIS. Network Information Service. An 
external authentication system that can be 
used to log into an Avamar server.

Node. A networked storage subsystem 
consisting of both processing power and 
hard drive storage, running Avamar 
software. 

NTP. Network Time Protocol. Controls time 
synchronization of a client or server 
computer to another reference time source.

ODBC. Open DataBase Connectivity. A 
standard database access method that 
makes it possible to access any data from 
any application, regardless of which 
database management system (DBMS) is 
handling the data. 

OpenLDAP. Open Lightweight Directory 
Access Protocol. An external authentication 
system that can be used to log into an 
Avamar server.

PAM. Pluggable Authentication Module. A 
Linux library that allows a local system 
administrator to define how individual 
applications authenticate users.

Plugin. An Avamar plugin is a software 
process that recognizes a particular kind of 
data resident on that client. 

Policy. A set of defined rules for client 
backups that can be named and applied to 
multiple groups. Groups have dataset, 
schedule and retention policies. 

RAIN. Redundant Array of Independent 
Nodes. A flexible, fault-tolerant architecture 
that allows an Avamar server to maintain 
availability and preserve data storage if 
single nodes fail in an Avamar module. 

RDMS. Relational Database Management 
System.

Registration. See Client Registration (page 
609). 

Replication. Replication is an optional feature 
that allows one Avamar server to store a 
read-only copy of its data on another 
Avamar server in order to support future 
disaster recovery of that server.

Restore. File or object restore. An operation 
that retrieves one or more filesystems, 
directories, files or data objects from an 
existing backup and writes it to a designated 
location.

Retention. The ability to control the length of 
time backups will be kept in an Avamar 
server before automated deletion. Retention 
can be set to permanent for backups that 
should not be deleted from an Avamar 
server. Retention is a persistent and 
reusable Avamar policy that can be named 
and attached to multiple groups.

Roles. A setting in Avamar Administrator that 
controls which operations each user can 
perform in the Avamar server. Roles are 
assigned on a user-by-user basis. 

Schedule. The ability to control the frequency 
and the start/end time per day for backups 
of clients in a group. A schedule is a 
persistent and reusable Avamar policy that 
can be named and attached to multiple 
groups.
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System Migration. System migrations are 
planned operations that use full “root-to-
root” replications to copy all data residing on 
a source Avamar server to a new destination 
server. If global client IDs (global CIDs) are 
used, clients that formerly backed up to the 
source server can continue to operate 
transparently without reregistering with the 
new destination server.

SSH. Secure Shell. A remote login utility that 
authenticates by way of encrypted security 
keys instead of prompting for passwords. 
This prevents passwords from traveling 
across networks in an unprotected manner.

Storage Node. A node in the Avamar server 
providing storage of data. 

TFTP. Trivial File Transfer Protocol. A version 
of the TCP/IP FTP protocol that has no 
directory or password capabilities.

Utility Node. In scalable multi-node Avamar 
servers, a single utility node provides 
essential internal services for the server (for 
example, MCS, cronjob, Domain Name 
Server (DNS), External authentication, 
Network Time Protocol (NTP) and Web 
access). Because utility nodes are dedicated 
to running these essential services, they 
cannot be used to store backups

VLAN. Virtual Local Area Network.
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