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FOREWORD

Scope and Intended Audience

Scope. This publication describes how to install, configure, administer, and use 
the Avamar SharePoint Client. 

Intended Audience. The information in this publication is primarily intended 
for:

• System administrators who are responsible for installing software and 
maintaining servers and clients on a network

• Microsoft SharePoint administrators who are responsible for backing up and 
maintaining Microsoft SharePoint servers

Prerequisites. Persons using this publication should have current practical 
experience with the following:

• Operating system shell commands on the SharePoint platform (root 
permission required)

• The specific version of Microsoft SharePoint currently deployed at your site

Product Information

For current documentation, release notes, software updates, information about 
EMC products, licensing and service, go to the EMC Powerlink website at  
http://Powerlink.EMC.com.
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 Typeface Conventions
FOREWORD 
Your Comments

Your suggestions will help us continue to improve the accuracy, organization and 
overall quality of our publications. You may email your comments to:

BSGDocumentation@emc.com

Please include the following information:

• Product name and version

• Document name, part number, and revision (for example, A01)

• Page numbers

• Other details that will help us address the documentation issue

Typeface Conventions

The following table provides examples of standard typeface styles used in this 
publication to convey various kinds of information.

EXAMPLE DESCRIPTION

Click OK. 
 or 
Select File > Close.

Bold text denotes actual buttons, commands, 
menus and options that initiate action.

Sequential commands are separated by a greater-
than (>) character. For example, the second 
example instructs you to select the Close 
command from the File menu.

Type: 
 cd /tmp

Bold fixed-width text denotes shell commands that 
must be entered exactly as they appear.

--logfile=FILE All caps text often denotes a placeholder (token) 
for an actual value that must be supplied by the 
user. In this example, FILE would be an actual 
filename. 

Installation Complete. Regular (not bold) fixed-width text denotes 
command shell messages, code and file contents.
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 Notes, Tips, and Warnings
FOREWORD 
Notes, Tips, and Warnings

The following kinds of notes, tips, and warnings appear in this publication:

IMPORTANT:  This is a warning. Warnings always contain 
information that if not heeded could result in unpredictable 
system behavior or loss of data. 

TIP:  This is a tip. Tips present optional information intended 
to improve your productivity or otherwise enhance your 
experience with the product. Tips never contain information 
that will cause a failure if ignored.

NOTE:  This is a general note. Notes contain ancillary infor-
mation intended to clarify a topic or procedure. Notes never 
contain information that will cause a failure if ignored.
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INTRODUCTION

The Avamar SharePoint Client provides a complete backup and recovery solution 
for Microsoft Office SharePoint Server (MOSS) 2007 SP1. 

If you need to recover the MOSS 2007 SP1 and its related components after an 
unexpected catastrophe, Disaster Recovery (page 35) includes preparation steps 
to fully recover the environment. To ensure that you have all the necessary 
information to perform a disaster recovery, review Disaster Recovery (page 35).
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 Important Terms and Concepts
INTRODUCTION 
Important Terms and Concepts

The Avamar SharePoint Client automatically discovers the topology of a 
SharePoint farm. The entire farm or just selected components can then be backed 
up and restored.

Components include Web applications and back-end databases, as well as 
SharePoint-specific features like the Single Sign-On (SSO) database. SSO provides 
user authentication for site–based portal applications that require information 
from third-party applications and back-end systems.

The following terms describe SharePoint and its topology.

Microsoft SharePoint An enterprise information portal that can run intranet 
and internet sites. It allows people, teams, and experts to connect and 
collaborate. SharePoint has features and tools that cover the following areas:

• Collaboration

• Enterprise portal

• Enterprise search

• Enterprise content management

• Forms-driven business processes

• Business intelligence

• Management

• Platform capabilities
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 Important Terms and Concepts
INTRODUCTION 
Microsoft Windows SharePoint Services 3.0 WSS 3.0 comprises the 
underlying services that provide people access to documents and information in a 
SharePoint environment. It is a Microsoft Windows Server technology that 
provides a storage and collaboration infrastructure and tools for building Web-
based applications and services. Collaboration and information-sharing includes 
workflows, RSS feeds, blogs, wikis, and ASP-style Web parts. WSS 3.0 is included 
in Windows Servers 2003 and 2008.

Features include the following:

• Project collaboration

• Document workspace

• Meeting subsite

• Discussion boards

Microsoft Office SharePoint Server 2007 SP1 MOSS 2007 SP1 relies on WSS 
3.0 technology to provide a consistent framework for lists and libraries, site 
administration, and site customization. It provides enhanced and additional 
features that are not available on a WSS site, including:

• Portals

• Business processes

• Business forms

MOSS 2007 SP1 is built on Windows Server 2003 SP1 technologies and services. 
Storage for all content, data, and configuration information is provided by 
Microsoft SQL Server. SQL Server 2005 is recommended, but SQL Server 2000 can 
be used.

SQL Server Databases The following table lists the back-end SQL Server 
databases:

DATABASE FUNCTIONS

Configuration Sites, databases, servers, and Web applications 

Content WSS site details, structure details, user content, 
files, and security information 

Shared services provider User profiles, audience data, business application 
data, Excel services functions, site usage data, 
InfoPath forms, and services session state 
information

Search Search data, history log, search log, calculation 
tables for crawl statistics, links tables, and 
statistical tables

Custom Third-party applications can store data in separate 
databases

Search indices Search indexes stored on the file system
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 System Requirements
INTRODUCTION 
System Requirements

This topic lists the supported configurations, hardware, and additional 
requirements that must be satisfied to successfully install and deploy the Avamar 
SharePoint Client backup and recovery solution. The supported configurations 
installation package column also lists the correct Avamar SharePoint Client 
software installation package required for that specific version of operation 
system.

Supported Configurations 

Hardware Requirements 

SHAREPOINT
VERSION(S) OS VERSION(S) BITS

AVAMAR SHAREPOINT 
CLIENT SOFTWARE 

INSTALLATION PACKAGE

2007 SP1 Microsoft Windows 2003 
or 2008 Server

32 AvamarMoss2007-windows-
x86-VERSION.msi

2007 SP1 Microsoft Windows Server 
2003 or 2008 Server

64 AvamarMoss2007-windows-
x86_64-VERSION.msi

2007 SP2 Microsoft Windows Server 
2008 or 2008 R2 Server

64 AvamarMoss2007-windows-
x86_64-VERSION.msi

REQUIREMENT MINIMUM

RAM 2 GB

File Systems NTFS

IMPORTANT:  FAT 16 and 32 systems must be 
converted to NTFS.

Hard Drive Space Must have enough free space for the largest SharePoint 
farm component.

Network Interface 10BaseT minimum; 100BaseT or higher recommended, 
configured with latest drivers for the platform.
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 Capabilities and Limitations
INTRODUCTION 
Capabilities and Limitations

This topic describes the backup and restore capabilities and limitations of the 
Avamar SharePoint Client based on the WSS 3.0 backup and restore object model.

Individual Websites. Backup or restore of an individual website, list, or list 
item is allowed only in the context of backing up or restoring the entire site 
collection to which it belongs.

Configuration and Content Databases. Backup or restore of the configuration 
database or the Central Administration content database of a SharePoint farm is 
allowed only when backing up or restoring the entire farm. A backup of these 
components provides a snapshot that can be useful for troubleshooting. For 
instance, they can be used with SQL Server tools to compare with the present 
state of the components.

Individual content databases outside of the Central Administration database can 
be backed up and restored without requiring a backup and restore of the entire 
farm. For example, content databases that are created when users create Web 
Applications in SharePoint. 

Backup to Tape. The Avamar SharePoint Client does not support backup to 
tape.

IIS Metabase. An Internet Information Server (IIS) metabase cannot be 
backed up or restored.

Custom Application Exceptions. The following items cannot be backed up 
with the Avamar SharePoint Client, but the WSS development kit might provide a 
custom backup solution for this kind of content:

• Registry keys

• Files located on front-end servers

This content includes files located outside any content database, such as 
certain master pages, .ascx files, web.config files, and other configuration 
files. They can also be backed up with the Avamar Windows client.

MOSS Version Support. The Avamar SharePoint Client is not supported on 
MOSS 2007 without service pack 1 or later.

Full Backup Required After Upgrade From 4.1. If you upgrade from Avamar 
4.1 to Avamar 5.0, you should perform a full backup. Avamar 5.0 cannot recover 
differential backups performed with the 4.1 client. You only can recover full 
backups performed with the 4.1 client. 

Issues Following Upgrade to Windows SharePoint Services 
3.0 SP2 When upgrading from Windows SharePoint Services 3.0 or Windows 

SharePoint Services 3.0 SP1 to Windows SharePoint Services 3.0 SP2 on a system 
already running Avamar SharePoint Client software, the SharePoint topology will 
not display correctly in Avamar Administrator. This can affect the ability to back up 
a SharePoint farm.

This issue is discussed in detail in Microsoft knowledgebase article 913384 
(http://support.microsoft.com/kb/913384). This knowledgebase article provides 
detailed instructions to resolve these issues, which might include removing  .NET 
frameworks later than 2.0 and applying the patch discussed in the article before 
reapplying updated framework software.
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INSTALLING/UNINSTALLING AVAMAR SHAREPOINT CLIENT

This chapter describes how to install and configure Avamar SharePoint Client 
software on a supported SharePoint server in either standalone or high-availability 
configurations. The Avamar SharePoint Client must be installed on the server 
running Microsoft Office SharePoint Server (MOSS) 2007 SP1.

Quick Reference (Road Map)

The following quick reference (“road map”) lists the installation tasks required to 
correctly install and configure the Avamar SharePoint Client in various 
environments. 

Installation tasks
• Install and configure Microsoft SharePoint for standalone server or distributed 

server farm deployment, following the respective Microsoft guidelines for the 
selected deployment type.

• Installing the Avamar Windows Client (page 12)

• Installing the Avamar SharePoint Client (page 14)
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 Installing the Avamar Windows Client
INSTALLING/UNINSTALLING AVAMAR SHAREPOINT CLIENT 
Installing the Avamar Windows Client

IMPORTANT:  You must install both the Avamar Windows 
Client and the Avamar SharePoint Client on the SharePoint 
server.

Windows Server 2008 and 2008 R2 with User Account Control

In Windows Server 2008, Microsoft added the User Account Control (UAC) feature. 
UAC is designed to provide additional operating system security by preventing 
software from being installed with administrator privileges, unless an 
administrator authorizes the elevated privileges.

If you start the Avamar Windows Client installer with normal account privileges on 
a computer with a default implementation of UAC, then the Avamar Windows 
Client software does not install correctly. Instead, run the installer with elevated 
administrative privileges. This workaround is included in the steps listed in the 
following procedure.

To install the Avamar Windows Client:

1. Log in to the client computer or workstation.

2. Point a Web browser at the Avamar server by typing the following URL:

HTTP://AVAMARSERVER

Where AVAMARSERVER is the actual Avamar system network hostname (as 
defined in DNS) or IP address.

You are automatically redirected to the Avamar secure Web server.

Depending on the browser security settings, a security alert dialog box 
might appear.

3. If a security alert dialog box appears, click Yes or OK to allow redirection 
to the Avamar secure Web server.

The Secure Log On page appears.

4. Scroll down until the Downloads and Documents hyperlink is visible.

5. Click Downloads and Documents.

The Downloads and Documentation page appears.

6. Click the correct operating system hyperlink for the client computer.

A folder listing appears in the browser.

7. Select the AvamarClient-windows-x86-VERSION.msi install package.

IMPORTANT:  For computers with UAC, you must download 
the install package to a temporary directory. Do not open it 
in place. “Windows Server 2008 and 2008 R2 with User 
Account Control” on page 12 provides more information.
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 Installing the Avamar Windows Client
INSTALLING/UNINSTALLING AVAMAR SHAREPOINT CLIENT 
8. Start the installer by using one of the following methods:

The installation wizard appears.

9. Follow the instructions to proceed through the wizard.

10.Click Finish.

TO DO THIS

Install on a non-UAC 
computer and run the 
installation file in place

Open the file in place on the server.

Install on a non-UAC 
computer and 
download and run the 
installation file

Download the file to a temporary directory 
on your computer, and then open the file.

Install on a UAC 
computer

1. In Windows, right-click the Command 
Prompt icon and select Run as 
administrator. 

2. In the command prompt window, change 
the working directory to the location of 
the installation package.

cd path-to-install-dir

Where path-to-install-dir is the full path 
of the temporary directory that contains 
the installation package. 

3. On a single line, type the following 
command to launch the installer:

msiexec /i AvamarClient-windows-
x86_64-VERSION.msi

Where version is the version number of 
the available install package.
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INSTALLING/UNINSTALLING AVAMAR SHAREPOINT CLIENT 
Installing the Avamar SharePoint Client

IMPORTANT:  You must install both the Avamar Windows 
Client and the Avamar SharePoint Client on the SharePoint 
server.

1. Log in to the client computer or workstation.

NOTE:  The Avamar SharePoint Client agent service and the 
MOSS administrator must be run with the same domain 
account.

2. Ensure that the Backup Agent login account is set to the SharePoint 
administrator account and is not set to the Local System account.

(a) Launch the Services application by selecting Start > Programs > 
Administrative Tools > Services.

The Services window appears.

(b) In the Services list, right-click the Backup Agent service and select 
Properties.

The Avamar Client Agent Properties dialog box appears.

(c) Click the Log On tab.

(d) If This account is set to the SharePoint administrator, then click OK 
and continue with step 3.

(e) If the Local System account is selected, click This account and type 
the SharePoint administrator account and password in the text boxes.

(f) Click OK.

3. Point a Web browser at the Avamar server by typing the following URL:

HTTP://AVAMARSERVER

Where AVAMARSERVER is the actual Avamar system network hostname (as 
defined in DNS) or IP address.

You will be automatically redirected to the Avamar secure Web server.

Depending on the browser security settings, a security alert dialog box 
might appear. 

4. If a security alert dialog box appears, click Yes or OK to allow redirection 
to the Avamar secure Web server. 

The Secure Log On page appears.

5. Scroll down until the Downloads and Documents hyperlink is visible.

6. Click Downloads and Documents.

The Downloads and Documentation page appears.
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INSTALLING/UNINSTALLING AVAMAR SHAREPOINT CLIENT 
7. Click the install package where the filename is one of the following:

Where VERSION is the version number of the package.

Your browser might prompt you to either open the file “in-place” (on the 
server) or save it to your local computer. Either method will work. However, 
if you save the file to your local computer, you must open (double-click) 
that installation file to continue with this procedure.

8. Either open the installation file in place (on the server) or double-click the 
downloaded installation file.

The InstallShield Wizard appears.

9. Follow the instructions to proceed through the wizard.

10.Click Finish.

Post-Installation

Prepare the MOSS 2007 SP1 and its related components for disaster recovery. 
Disaster Recovery (page 35) provides more information.

Uninstalling and Upgrading the Avamar SharePoint Client

Unlike other platforms, you do not have to uninstall earlier versions of Avamar 
SharePoint Client software before you install a new version. You can run the install 
package of the newer Avamar SharePoint Client on the client host that already has 
the older version installed.

To uninstall the Avamar SharePoint Client, you can use Add/Remove Programs 
feature in the Windows Control Panel.

BITS FILENAME

32-bit AvamarMoss2007-windows-x86-VERSION.msi

64-bit AvamarMoss2007-windows-x86_64-VERSION.msi
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USING THE AVAMAR SHAREPOINT CLIENT

This chapter describes how to use the Avamar SharePoint Client to back up or 
recover (restore) an entire SharePoint server farm or specified components.

You should have current practical experience with the following:

• Operating system shell commands on the SharePoint server platform (root 
permission required)

• The specific version of SharePoint currently deployed at the site

The Microsoft SharePoint Server documentation provides additional information.

Overview

The Avamar SharePoint Client can back up and restore a whole SharePoint farm or 
any of its discovered components down to the Web application level. Some listed 
components cannot be selected for backup or restore but are automatically 
selected based on their dependency to other components that you select.

The content components in Windows SharePoint Services (WSS) 3.0 that can be 
backed up and restored include the following:

• Website collections

• Content databases

• Web applications

• Content publishing Web services

• Search Windows service (including databases and indexes)

• An entire SharePoint farm

If an enhanced functionality product such as Microsoft Office SharePoint Server 
(MOSS) 2007 SP1 has been installed in addition to WSS 3.0 and that product 
includes Shared Service Providers, those can also be backed up and restored.
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On-Demand Backup
This topic describes how to perform an on-demand backup of an entire SharePoint 
farm or specific components.

Backup is a two-step process, first to a local (shared) hard drive and then to the 
Avamar server.

IMPORTANT:  This approach requires enough local free 
space for the backup process to handle the size of the larg-
est component of the Microsoft SharePoint farm.

IMPORTANT:  Additional files and databases must be 
backed up to support a disaster recovery scenario. Disaster 
Recovery (page 35) provides additional information.

Backing Up an Entire SharePoint Farm

To back up an entire SharePoint farm:

1. Start Avamar Administrator.

2. Select Navigation > Backup and Restore or click the  
Backup & Restore launcher button.

The Backup and Restore window appears.

3. Click the Select for Backup tab.

4. In the Clients tree, select the SharePoint farm.

REMINDER:  You cannot view clients outside the domain. 
To view all clients, you must be logged in to the root domain.
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 On-Demand Backup
USING THE AVAMAR SHAREPOINT CLIENT 
5. Select the Microsoft SharePoint plug-in.

TIP:  Select Actions > Preview List to view a summary of 
all directories and files that you selected for an on-demand 
backup.

6. Select either a whole farm or specific components of a farm for backup.

When backing up a whole farm, all farm components and associated 
components are automatically selected and backed up in one session. 
When backing up specific components, those components are backed up in 
multiple sessions.

IMPORTANT:  Be aware that some of the listed components 
are not available for selection, but are automatically selected 
based on their dependency on other components.

7. Select Actions > Backup Now or click the toolbar icon immediately to the 
left.

The On Demand Backup Options dialog box appears.

8. Review the backup settings.

9. To change the backup retention setting, type or select the following:

FIELD/OPTION DESCRIPTION

Retention 
period

To automatically delete this backup from the 
Avamar server after a specific number of days, 
weeks, months, or years, select this option and 
type the number of days, weeks, months, or years.

End date To automatically delete this backup from the 
Avamar server on a specific calendar date, select 
this option and browse to that date on the calendar.
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 On-Demand Backup
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10.Select the encryption method for client/server data transfer during this 

backup:

11.Click More Options.

12.On the Backup Command Line Options dialog box, specify a Temporary 
directory.

This temporary directory must be on a drive local to the SharePoint Server 
(Central Administrator/WebFront End) that the user is backing up from, 
and not the SQL Server being used as part of the SharePoint farm. Do this 
as follows:

(a) In Windows Explorer, create the temporary directory.

(b) Right-click the temporary directory and select Properties.

(c) On the Sharing tab, select Share this folder.

No end date To keep this backup for as long as this client 
remains active in the Avamar server, select this 
option.

High Strongest available encryption setting for that specific client 
platform.

Medium Medium strength encryption.

None No encryption.

NOTE:  The exact encryption technology and bit strength used for any 
given client/server connection depends on a number of factors, 
including the client platform and Avamar server version. The Avamar 
Product Security Guide provides additional information.

FIELD/OPTION DESCRIPTION
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(d) Click Permissions.

(e) On the Permissions dialog box, click Add.

(f) Use the Select Users, Computers, or Groups dialog box to select the 
following user accounts:

• SQL service

• MOSS service

• System

• Network services

(g) Click OK.

(h) On the Permissions dialog box, set each of these user accounts for Read 
and Change permissions on the temporary directory share.

(i) Remove the Everyone group.

(j) Click OK.

(k) Click OK again to close the Properties dialog box.

IMPORTANT:  If the Backup Command Line Options dialog 
box Remove tmp backup files option remains selected 
(the default), backup disk space must be at least as large as 
the largest MOSS component selected for backup. If this 
option is cleared, backup disk space must be at least as 
large as the sum of all MOSS components selected for 
backup.
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TIP:  To include other plug-in options with this backup, 
select or clear the desired options and type values in the 
Backup Command Line Options dialog box, where applicable. 
Appendix A — Plug-in Options (page 42) provides a complete 
list of supported Avamar SharePoint Client options.

13.Click OK.

The Backup Command Line Options dialog box closes.

14.Click OK.

The On Demand Backup Options dialog box closes and the following status 
message appears:

Backup initiated.

15.Click OK.
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Recovery (Restore)

Restore is a two-step process, first to a local (shared) hard drive and then to the 
destination target.

IMPORTANT:  This approach requires enough local free 
space for the restore process to handle the size of the larg-
est component of the Microsoft SharePoint farm.

Restore to a new location/configuration (for instance, a new SQL server) is not 
supported directly. You can restore data to a temporary location and from there, 
restore the data to a new location.

To recover (restore) an entire SharePoint farm or one or more components, 
perform the following:

SharePoint Server 
Preparation

1. Start Avamar Administrator.

2. Select Navigation > Backup and Restore or click the  
Backup & Restore launcher button.

The Backup and Restore window appears. 

3. Click the Select for Restore tab.

4. In the Clients tree, select the SharePoint server.

REMINDER:  You cannot view clients outside the domain. 
To view all clients, you must be logged in to the root domain.

5. Do one of the following:

Selecting by Calendar Date

6. To locate backups stored on the server by calendar date:

(a) Click the By Date tab.

Clicking the By Date tab displays a browsable 
calendar for locating backups in the Avamar 
server.

Dates highlighted in yellow indicate that a backup 
was performed on that date.

IF DO THIS

You want to locate backups stored on 
the server by calendar date.

Perform step 6, skip step 7, 
and then go directly to step 8.

You want to locate backups stored on 
the server by content (the specific 
directories and files contained within 
each backup).

Skip step 6 and go directly to 
step 7.
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Selecting a valid backup date on the calendar populates the backups 
list to the right of the calendar.

Selecting a backup populates the contents list below the Backup History 
pane.

(b) In the Backup History pane, browse to a valid backup date in the 
Calendar (highlighted in yellow).

(c) Select a backup from the backups list directly to the right of the 
calendar.

(d) Select one or more directories or files to restore.

Selecting by File/Folder

7. To locate backups stored on the server by content:

(a) Click the By File/Folder tab.

Clicking the By File/Folder tab displays a Backup History pane that can 
be used to retrieve all backups that contain a specified client file or 
folder.

(b) If you know the full path to the desired client file or folder, type that 
path in the Enter path to retrieve history for text box.

(c) If you do not know the full path to the desired client file or folder, click 
Browse and locate the desired client file or folder. 
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(d) Click Retrieve.

The Version History table lists all versions and sizes for that file or 
folder that have been backed up for this client. 

Selecting a row in the Version History table displays all backups for the 
selected client that contain the selected version of the file or directory. 

(e) Select the backup from which to restore.

TIP:  Select Actions > Preview List to view a summary of 
all directories and files that you selected for an on-demand 
restore.

8. Select Actions > Restore Now or click the toolbar icon immediately to 
the left.

The Restore Options dialog box appears.

9. Review the restore settings.

10. To change the restore destination choices, type or select the following:

FIELD/OPTION DESCRIPTION

Restore Everything 
to its original 
location

Restore Everything to its original location 
is the default destination—all files are restored 
to the original client in the original top-level 
(root) directory.

Restore Everything 
to a different 
location

Restore Everything to a different location 
allows you to specify another client or another 
directory on the same client.

Browse for Client/
Destination

Click Browse to locate a client or directory for 
the restore. You can also type this information 
directly in the Absolute Destination field. 
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11.Select the encryption method for client/server data transfer during this 

restore:

TIP:  To include plug-in options with this restore, click More 
Options, and then select or clear the desired options and 
type values where applicable. Appendix A — Plug-in Options
(page 42) provides a complete list of supported Avamar 
SharePoint Client options.

12.Click OK.

The Restore Options dialog box closes and the following status message 
appears: Restore initiated.

13.Click OK.

14.After restore is complete, restart Internet Information Server (IIS).

Restore Plug-in Type Restore Plug-in Type specifies which client 
plug-in is used to perform this restore. The 
default choice is the same plug-in used to take 
the original backup.

High Strongest available encryption setting for that specific client 
platform.

Medium Medium strength encryption.

None No encryption.

NOTE:  The exact encryption technology and bit strength used for any 
given client/server connection depends on a number of factors, 
including the client platform and Avamar server version. The Avamar 
Product Security Guide provides additional information.

FIELD/OPTION DESCRIPTION
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Scheduling MOSS Backups

To perform Microsoft Office SharePoint Server (MOSS) backups on a regular 
schedule:

• Create a new dataset expressly for SharePoint Server backups

• Create a new group expressly for SharePoint Server backups

• Add the SharePoint Server client to the new group

• Assign the new dataset to the new group

• Assign a schedule to the new group

• Assign a retention policy to the new group

• Enable scheduling for the new group

A thorough discussion of groups, group policy, datasets, schedules, and retention 
policies is beyond the scope of this publication. The Avamar System 
Administration Guide provides additional information.

Create a New Dataset for SharePoint Server Backups

REMINDER:  You must be logged in to the root domain as 
an administrative user to perform this procedure.

IMPORTANT:  If the SharePoint server is deployed as a 
cluster, you should add all nodes in the cluster to this data-
set.

1. Start Avamar Administrator.

2. Select Tools > Manage Datasets.

The Manage All Datasets window appears.
AVAMAR SHAREPOINT CLIENT 5.0 • USER GUIDE  26



 Scheduling MOSS Backups
USING THE AVAMAR SHAREPOINT CLIENT 
3. Click New. 

The New Dataset dialog box appears.

4. Type a name for the new dataset.

IMPORTANT:  Do not use any of the following characters in 
the dataset name: ~!@$^%(){}[]|,`;#\/:*?<>'”&.

5. Click the Source Data tab.

The Source Data tab is where you define a list of source data plug-ins that 
contribute data to this dataset. 

6. Type or select the following:

FIELD/OPTION DESCRIPTION

Enter Explicitly Select this option to define which plug-ins will be 
used by this particular source data entry. 

To add a plug-in type to this dataset, select it from 
the list. 

Select Plug-in 
Type

This list is only available when Enter Explicitly is 
selected.

Select a plug-in type from the list and click + to add 
it to the plug-in list.
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The remaining dialog box tabs are used to select optional parameters such 
as exclude and include list entries and optional plug-in options. 

IMPORTANT:  The Avamar SharePoint Client does not sup-
port include or exclude lists in datasets.

If you do not need to select these optional parameters in this dataset, skip 
step 7 and go directly to step 8. 

7. Click the Options tab.

IMPORTANT:  You must specify a Temporary directory and 
configure whether to Remove tmp backup files. The temp 
directory must be shared to the network and given share 
permissions for SQL Server to write to and read from. See 
steps 11 through 13 in Backing Up an Entire SharePoint 
Farm (page 17) for instructions on configuring these two 
options.

The Options tab is where you select various plug-in options.

Plug-in options can be selected two ways: by using the graphical controls 
or by typing option names and values as free text.

To include plug-in options with future backups, select or clear the desired 
options and type values where applicable.

IMPORTANT:  When typing option names and values as 
free text, no error checking or validation is performed on 
these free-text entries and free text entries override settings 
made through the graphical controls.

Select Files 
and/or Folders

This list is only available when Enter Explicitly is 
selected.

If you want this plug-in to point to a specific client 
subdirectory (somewhere other than the root 
directory), click ... and browse to the directory 
before you click +.

You can also type the full path to any client directory 
directly in the text box. 

IMPORTANT:  Do not use any of the following 
characters in the entry: ~!@$^%(){}[]|,`;#\/
:*?<>'”&.

Select All Data 
for All Local 
File Systems

Select this option to include all data on all client file 
systems. This adds all plug-in types to the source 
data list.

FIELD/OPTION DESCRIPTION
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Appendix A — Plug-in Options (page 42) provides a complete list of 
supported Avamar SharePoint Client options that can be executed by a 
dataset.

8. Click OK.

Setting Up Scheduled SharePoint Server Backups

REMINDER:  You must be logged in to the root domain as 
an administrative user to perform this procedure.

1. Start Avamar Administrator.

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.
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3. Select Actions > New Group or click the toolbar icon immediately to the 
left.

The New Group wizard appears.

4. Type or select the following:

FIELD/OPTION DESCRIPTION

Name Type a name for this new group.

IMPORTANT:  Do not use any of the following 
characters in the group name: ~!@$^%(){}[]|,`;#\/
:*?<>'”&.

Disabled This option is selected by default. Clear this option if 
you want to immediately use this group to take 
regularly scheduled client backups.

Encryption 
Method

This is the group encryption method that is used by all 
members of this group for client/server network 
communications unless the method is overridden at the 
client level. Choices are:

High Strongest available encryption setting for 
that specific client platform.

Medium Medium strength encryption.

None No encryption.

NOTE:  The exact encryption technology and bit 
strength used for any given client-server connection is 
dependent on a number of factors, including the client 
platform and Avamar server version. The Avamar 
Product Security Guide provides additional information.
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The remaining wizard screens are used to select a dataset, schedule, and 
retention policy, as well as build a client list for this group.

You can click Finish at any time. Doing so will cause the new group to be 
created using system default settings and an empty client list. You can 
change those settings by editing the group properties.

5. Click Next.

6. Select the dataset that you defined during Create a New Dataset for 
SharePoint Server Backups (page 26) from the Select an Existing Dataset 
list.

Override 
Schedule

Select this option if you want to override the assigned 
schedule for this group.

You also can skip the next scheduled backup entirely 
(Skip Next Backup) or perform the next scheduled 
backup one time only (Run Next Backup Once).

Domain Location in the Avamar server where this group should 
reside.

FIELD/OPTION DESCRIPTION
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7. Click Next.

8. Select a schedule from the Select an Existing Schedule list.

NOTE:  Schedules are not modifiable from this screen. 
Detailed schedule properties are displayed so that you can 
review them prior to making a selection. The Avamar Sys-
tem Administration Guide provides additional information 
about editing schedule properties.

9. Click Next.

10.Select a retention policy from the Select an Existing Retention Policy list.
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NOTE:  You cannot edit retention policies from this screen. 
Detailed retention policy properties are displayed so that you 
can review them prior to making a selection. The Avamar 
System Administration Guide provides additional information 
about editing retention policy properties.

11.Click Next.

This screen is used to build a list of clients that will be members of this 
group. In this case, the group contains only one client—the SharePoint 
server.

12.Select the SharePoint server from the client list.

13.Click Finish.

The New Group wizard closes and the new group appears in the Policy 
window.
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Enabling Scheduled SharePoint Server Backups

REMINDER:  You must be logged in to the root domain as 
an administrative user in order to perform this procedure.

1. Start Avamar Administrator.

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Groups tab.

5. Select the group that you created in the previous procedure (the group 
that now contains only the SharePoint server).

6. Select Actions > Group > Disable Group.

This clears the Disable Group option on the Actions > Group menu.

A confirmation message appears.

7. Click Yes to enable this group.
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Disaster Recovery

In case a disaster occurs, the following information provides the means to perform 
a redirected restore and recover lost data.

Overview

The MOSS environment is composed of the following elements:

• Operating system (OS) binary files

• IIS configurations

• MOSS binary files

• MOSS configurations

• Customizations

• Content

A backup and recovery plan should address each of these elements in all systems 
that are part of the MOSS environment.

For additional information about backing up and restoring MOSS, refer to Data 
protection and recovery for Microsoft Office SharePoint Server 2007 in small to 
medium-sized deployments, which is available on the Microsoft website.

Binary Files

For both OS and MOSS binary files, the file system client may be used for backup 
and restore purposes. Having copies of the installation disks for OS, MOSS and 
software updates both onsite and offsite is mandatory.

Configurations

IIS configurations are set in the MOSS Central Administration Application or IIS 
Manager on each front-end Web server or system that runs SQL Server Reporting 
Services in the MOSS environment. IIS configurations are stored in the IIS 
metabase, located in %systemroot%\system32\inetsrv\MetaBack, and include the 
following:

• Application pool settings, including service accounts

• IIS compression settings

• Timeout settings

• Custom Internet Server API (ISAPI) filters

• Computer domain membership

• Internet Protocol security (IPsec) settings

• Network Load Balancing settings

• Host header entries

• Secure Sockets Layer (SSL) certificates

• Dedicated IP address settings

EMC recommends documenting all configurations for each front-end Web server in 
case a disaster occurs. Then it is possible to reconfigure this part of the 
environment exactly as it was before. The file system client or VSS plug-in might 
also be used for this purpose.
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IIS also includes a script for backup/restore of the metabase. The backup can be 
run with the following command:

cscript.exe %systemroot%\system32\iisback.vbs /s servername /u accountname /p password 
/backup /b WeeklyBackup /v NEXT_VERSION /e backuppassword.

Configurations in MOSS are also set in the Central Administration application and 
stored in the configuration database. Although the configuration database and 
Central Administration can be backed up, they contain computer-specific 
information and can only be restored to an environment configured precisely the 
same, including all software updates, server names and numbers of servers.

Because it might not be possible to restore the configuration database, it is 
recommended that you document all settings in the Central Administration 
application. Also, you should consider a redundancy solution, such as clustering or 
mirroring of the computer running SQL Server with the configuration database.

Configuration settings in MOSS include the following:

• Application pool settings

This includes service accounts (all accounts that Web applications run as, 
including the crawler account and search account).

• Database names and locations

• Web application names and database

Document the content database names associated with each Web application.

• Crawler impact rules

• Farm-level search settings

• External service connection settings

• Workflow management settings

• Activated features

You can easily document alternate access mapping (AAM) settings. You can export 
the AAM settings to a text file by first running the command 
stsadm -o enumalternatedomains, and then backing up the exported file with 
the file system client.

Customizations

Customizations of MOSS sites can include:

• Master pages, page layouts and cascading stylesheets

These objects are stored in the content database for a Web application.

• Web parts, site or list definitions, custom columns, new content types, custom 
fields, custom actions, coded workflows, or workflow activities and conditions

• Third-party solutions

This includes associated binary files and registry keys, such as filters.

• Changes to standard XML files

• Custom site definitions (webtemp.xml)
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The following are the most common location customizations stored on front-end 
Web servers:

• Program Files\Common Files\Microsoft Shared\Web server extensions\12

This includes commonly updated files, custom assemblies, custom templates, 
and custom site definitions. This location is often called the 12 hive.

• Inetpub

This is the location of IIS virtual directories.

• %systemroot%\assembly

This is the global assembly cache (GAC), a protected OS location that contains 
.NET Framework code assemblies that are installed to provide full system 
access.

The file system client can be used to backup and restore files in these locations.

Content

MOSS content is stored in SQL Server databases. The following are databases 
associated with a MOSS implementation:

• Configuration

• Content

• SSP

• Search

IMPORTANT:  Configuration content can only be restored to 
precisely the same environment. The new setup must match 
the old setup: use the same OS, service packs, IP address, 
hostname, and domain, and install the same versions of SQL 
Server and SharePoint Sever as was used in the original 
environment. 

Either the SharePoint or SQL plug-ins can be used to back up and restore all 
content and SSP databases. The search database is a special case in that you 
should only use the Avamar SharePoint Client to back it up. The Avamar 
SharePoint Client synchronizes the database backup with the search index file 
backup, and both can be restored together.

Optional SQL Server Database Backups With SQL plug-in

The SQL Server databases used by SharePoint can be backed up and recovered 
with the Avamar SQL Server Client. Backing up these SQL Server databases with 
the SQL Server client is not a replacement for a backup with the Avamar 
SharePoint Client. For restore of a SharePoint farm, you need the full backup 
provided by the SharePoint client. 

If your company or database administrator already back up other SQL Server 
databases, you may want to include the SQL Server databases used by SharePoint 
in the regular SQL Server backup processes. When a SharePoint disaster recovery 
is performed through the SharePoint client, it is not necessary to perform a 
separate SQL Server recovery from a SQL Server client backup. 
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The Microsoft white paper, Data protection and recovery for Microsoft Office 
SharePoint Server 2007, available on the Microsoft website, describes the benefits 
and disadvantages of using a separate SQL Server backup tool:

Benefits include:

• Existing SQL Server disaster recovery strategies can be reused.

• Full and differential backups can be configured with added verification.

• Provides a full-fidelity data backup.

• Can be faster than Office SharePoint Server backups.

• When recovering a database to restore specific content items, we 
recommend that you use a recovery farm. 

Disadvantages include:

• Does not include front-end Web server custom solutions.

• Can back up the configuration database and Central Administration content 
database, but restoring is not supported. 

• Does not back up Internet Information Services (IIS) settings set outside 
of Office SharePoint Server, including host headers, dedicated IP 
addresses, and Secure Sockets Layer (SSL) certificates.

• If using Search, you must re-crawl after restoring content because indexes 
are not backed up in SQL Server.

• Should not be used to back up the Search database, because it cannot be 
synchronized with the Search index. 

• You must manually reattach your databases to the Web applications after a 
recovery.

Backup Procedure

1. Back up the entire farm by using the Avamar SharePoint Client.

2. Document alternate access mapping settings.

3. Document IIS settings.

4. Back up customizations by using the Avamar file system client.

Restore Procedure

1. Rebuild database servers.

(a) Install Microsoft Windows.

(b) Install Microsoft SQL Server.

(c) Install software updates (SP2 or later).

2. Rebuild application servers.

(a) Install Microsoft Windows.

(b) Install Microsoft .NET Framework 3.0.

(c) Install complete Microsoft Office SharePoint Server SP1 or later  
(Type: Complete).
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3. Rebuild front-end Web servers.

(a) Install Microsoft Windows.

(b) Install IIS.

(c) Install ASP.NET.

(d) Install Microsoft .NET Framework 3.0.

(e) Install Microsoft Office SharePoint Server SP1 or later  
(Type: front-end Web).

4. Using the SharePoint Products & Technologies wizard on the application 
server, create a new farm server.

5. Start Search services.

6. Re-create all Web applications using the original port number for Central 
Admin Web Application.

7. Using the SharePoint Products & Technologies wizard on the front-end Web 
servers, connect to an existing server farm.

8. Install Avamar Windows Client.

9. Install the Avamar SharePoint Client.

10.Deactivate the clients installed in the previous steps.

Do this by clearing the Activate it checkbox on the Client Properties 
dialog box. The Avamar System Administration Guide provides details.

11. Invite the clients installed previously.

The Avamar System Administration Guide provides details.

12. Perform a redirected restore of the whole Microsoft Office SharePoint 
Server farm backup.

Use the Restore to a different location option in Avamar Administrator 
and use a destination value of a shared location on the MOSS host.

13. Perform a standard restore from the redirected restore location.

Provide the backup path of the folder where redirected restore was 
performed (for example, \\aiqmossvm8\bckMOD-1236666068244#1).

(a) From the full farm components, first restore all web applications to a 
new configuration.

For the URL and database names, retain the information provided. Keep 
all data as it is and provide only user credentials.

(b) From the full farm components, restore search components to either a 
new configuration (alternate farm restore) or the original configuration 
(same farm restore).

(c) From the full farm components, restore the shared services provider to 
a new configuration.

For the URL and database names, retain the information provided. Keep 
all data as it and provide only user credentials.

14.Set one or more front-end Web servers to serve queries.

15.Reconfigure IIS settings.

16.Reconfigure alternate access mappings (optional).
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17.Start timer jobs.

18.On all front-end Web servers, redeploy solutions and reactivate features or 
restore the 12 hive by using the Avamar file system client (optional).

Restoring Deleted Web Applications and Search Database

In two specific circumstances, you must re-create the SharePoint component 
before restoring the lost data. The following procedures describe how to restore a 
Web application and search database if either was accidentally deleted.

Restoring a Deleted Web Application

There are several scenarios for restoring a deleted Web application, depending on 
how much data was lost and must be restored. 

• Restore Web Application Data Only, When Web Application With Attributes Still 
Exists (page 40) 

• Restore Deleted Web Application When The IIS Website and Content Database 
Still Exist (page 40)

• Restore Deleted Web Application When the IIS Website and Content Database 
Were Also Deleted (page 40)

Restore Web Application Data Only, When Web Application With Attributes Still Exists

This restore can be performed without stopping SharePoint or any services.

In Avamar Administrator, locate the deleted Web application, and then restore it. 

Restore Deleted Web Application When The IIS Website and Content Database Still Exist

1. Open the SharePoint Central Administration page.

2. On the Applications Management tab, create a new Web application.

IMPORTANT:  Data can only be restored to precisely the 
same environment, so ensure that all configuration parame-
ters (attributes) match the original Web application environ-
ment.

3. In Avamar Administrator, restore the Web application.

Restore Deleted Web Application When the IIS Website and Content Database Were Also 
Deleted

If the IIS Website and Content Database were deleted in addition to the Web 
application, follow the steps in Disaster Recovery (page 35) to recover those 
components.
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Restoring a Deleted Search Database

There are several scenarios for restoring a deleted Search Database, depending 
on how much data was lost and must be restored. 

• Restore Search Database Only, When the Search Web Application Still Exists 
(page 41) 

• Restore Deleted Search Web Application When the IIS Website and the Search 
Content Database Still Exist (page 41)

• Restore Deleted Search Web Application When the IIS Website and the Search 
Content Database Were Also Deleted (page 41)

Restore Search Database Only, When the Search Web Application Still Exists

This restore can be performed without stopping SharePoint or any services.

In Avamar Administrator, locate the deleted Search Web application, and then 
restore it.

Restore Deleted Search Web Application When the IIS Website and the Search Content 
Database Still Exist

1. Open the SharePoint Central Administration page.

2. On the Applications Management tab, create the Search Service in Manage 
Search Services.

IMPORTANT:  Data can only be restored to precisely the 
same environment, so ensure that all configuration parame-
ters match the original search database environment.

3. On the Operations tab, re-enable Search Services in Services on Server.

4. On the Applications Management tab, verify that the Office SharePoint 
Server Search service is running in Manage Search Services.

5. In Avamar Administrator, restore the search database.

Restore Deleted Search Web Application When the IIS Website and the Search Content 
Database Were Also Deleted

If the IIS Website and Content Database were deleted in addition to the Search 
Web application, follow the steps in Disaster Recovery (page 35) to recover those 
components.
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APPENDIX A — PLUG-IN OPTIONS

Important Terms and Concepts

Plug-in options provide additional control of backups and restores. These options 
are context-sensitive to both the operation being performed and the specific plug-
in selected for that operation.

These options can be specified during on-demand backup and restore operations, 
or persistently set within datasets for all future scheduled backups.

Backup or restore option dialog boxes automatically appear when initiating on-
demand backups or restores, respectively.

When creating a new dataset, the new dataset wizard offers an opportunity to 
configure persistent backup plug-in option settings for that dataset.

To view or set plug-in options for an existing dataset: 

1. Start Avamar Administrator.

2. Select Tools > Manage Datasets…

The Manage All Datasets window appears.

3. Select a dataset from the list and click Edit. 

The Edit Dataset dialog box appears.

4. Click the Options tab.

Plug-in options can be set two ways:

• By using the graphical controls

• By typing option names and values as free text

Setting Plug-in Options by Using Graphical Controls. By clicking the 
Options tab and selecting a plug-in you can display all current options for that 
specific plug-in. 

These settings are represented by graphical controls (for example, options, radio 
buttons, list boxes, and so forth).
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The advantage to setting plug-in options by using graphical controls is that you 
cannot type an option name or value incorrectly. Only valid states are shown.

Setting Show Advanced Options expands this list even further by displaying 
options that are normally only of interest to persons debugging an Avamar 
system. These advanced options are shown in red.

Typing Option Names and Values as Free Text. You can also set plug-in 
options by typing option names and values as free text. 

Clicking More expands the dialog box to include Enter Attribute and Attribute 
Value fields, which can be used to input plug-in options and values as free text. 

However, it must be understood that no error checking or validation is performed 
on these free text entries and that free text entries override settings made by way 
of the graphical controls. 

Microsoft Office SharePoint Server Plug-in Options

This topic lists and describes the plug-in options available for use with the Avamar 
Microsoft Office SharePoint Server plug-in.

Backup Options

FIELD/OPTION DESCRIPTION

Temporary backup 
directory

Temporary backup directory

Backup Type Sets backup level: either Full or Differential

Remove temporary 
backup files after 
backup completes

A
D

V
A

N
C

E
D

 O
P

T
IO

N
S Enable debugging 

messages
If selected, maximum information is written to log 
files.

IMPORTANT:  If selected, very large log files are 
created.
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Restore Options

FIELD/OPTION DESCRIPTION

Username Username with admin rights on farm.

Password

Restore Type Restore by overwriting existing data (Overwrite) or 
restore just the new data (New).

A
D

V
A

N
C

E
D

 O
P

T
IO

N
S Enable debugging 

messages
If selected, maximum information is written to log 
files.

IMPORTANT:  If selected, very large log files are 
created.
AVAMAR SHAREPOINT CLIENT 5.0 • USER GUIDE  44


	Foreword
	Scope and Intended Audience
	Product Information
	Your Comments
	Typeface Conventions
	Notes, Tips, and Warnings

	Introduction
	Important Terms and Concepts
	System Requirements
	Capabilities and Limitations

	Installing/Uninstalling Avamar SharePoint Client
	Quick Reference (Road Map)
	Installation tasks

	Installing the Avamar Windows Client
	Windows Server 2008 and 2008 R2 with User Account Control

	Installing the Avamar SharePoint Client
	Post-Installation
	Uninstalling and Upgrading the Avamar SharePoint Client

	Using the Avamar SharePoint Client
	Overview
	On-Demand Backup
	Backing Up an Entire SharePoint Farm

	Recovery (Restore)
	Scheduling MOSS Backups
	Create a New Dataset for SharePoint Server Backups
	Setting Up Scheduled SharePoint Server Backups
	Enabling Scheduled SharePoint Server Backups

	Disaster Recovery
	Overview
	Backup Procedure
	Restore Procedure

	Restoring Deleted Web Applications and Search Database
	Restoring a Deleted Web Application
	Restoring a Deleted Search Database


	Appendix A — Plug-in Options
	Important Terms and Concepts
	Microsoft Office SharePoint Server Plug-in Options


