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CHAPTER 1

ViPR SRM introduction

The following topics introduce the ViPR SRM system and its components.

l System description............................................................................................. 12
l Log on and explore the ViPR SRM Interfaces..................................................... 14
l Provide an enterprise logo and message............................................................. 16
l Configuring an SMTP server .............................................................................. 17
l Navigation styles ................................................................................................17
l Use links in reports to get more detail ................................................................19
l For more information......................................................................................... 23
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System description
ViPR SRM provides a multi-vendor view into an enterprise storage infrastructure to
help visualize and optimize capacity and manage devices.

Features for Storage Administrators
The ViPR SRM user interface provides a single view of all discovered storage-related
components in your storage infrastructure. One user interface provides reports that
show information about storage systems, switches, connection fabric, and host
initiators. For storage administrators, ViPR SRM provides the following features:

l Enterprise wide capacity summary and details.

l Capacity planning and forecasting.

l Service level, replication, and virtual storage reporting.

l Storage infrastructure details, including hosts, switches, fabric, and port
information.

l Performance reporting and analysis.

l Detailed component inventories per storage system show, for example, disks, file
systems, volumes, and storage pools.

l Chargeback reporting.

l Topology views showing relationships between components.

l Consolidated alerting.

l Situations to watch reports to draw attention to developing problems.

l Compliance module shows compliance or non-compliance to storage best
practices and business policies.

These and other features for Storage Administrators are documented in the following
guides, available on the ViPR SRM 4.2 Documentation Index:

l ViPR SRM User Guide for Storage Administrators

l ViPR SRM Alerting Guide

l ViPR SRM Compliance Guide

l ViPR SRM Data Enrichment and Chargeback Guide

Features for ViPR SRM System Administrators
This guide describes features intended for the administrators of the ViPR SRM
system. ViPR SRM includes an Administration Interface, which is accessible from the
User Interface. Some of the functions available from the Administration Interface are:

l Physical and logical details about the ViPR SRM system setup.

l User account administration

l Process management

l Feature configuration

l Access to log files

l SolutionPack installation, configuration, and updating

l Discovery of new storage infrastructure components

The ViPR SRM servers are monitored by the SolutionPack for EMC M&R Health,
making the ViPR SRM system self-monitoring. This SolutionPack provides alerting,

ViPR SRM introduction
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health status and metrics, sizing information, and operational reports for the ViPR
SRM infrastructure.

Components in ViPR SRM
The typical physical system for ViPR SRM consists of a set of servers or vApps that
host various operations for the system, as follows:

Frontend

Hosts the Tomcat web server and the ViPR SRM Console. Users and
administrators log onto the Frontend server. All Frontend services, including
reports, alerting, and compliance, are integrated into a single User Interface on
the Console.

Primary Backend

Hosts the database and system processes and tasks, including the Alerting,
Compliance, and Topology Backend components.

Secondary Backend

Hosts additional backend elements.

Collector Manager

Hosts the metrics collectors that receive information from the monitored storage
devices.

The following figure shows the relationships between these components.

Figure 1 ViPR SRM physical architecture

Logically, ViPR SRM consists of the core platform ( EMC M&R) and a set of
SolutionPacks installed onto the core that add storage-specific and device-specific
functionality.

SolutionPacks essentially customize the system to your infrastructure—you install
only the ones you need. A SolutionPack installs a metrics collector, reports, alert
definitions, compliance policies and many other components that enable meaningful
reporting for a storage device type or feature set.

When you install a new SolutionPack, you also configure a discovery process to look
for the new device types. ViPR SRM discovers devices and initiates metrics collection

ViPR SRM introduction
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from them, and those new devices eventually appear in the reporting infrastructure on
the ViPR SRM User Interface.

The following figure shows how metrics from various devices are collected, enriched,
merged into a single database, and displayed in one user interface. The Load Balancer
Arbitrator/Load Balancer Connector (LBA/LBC) manages collected data. The data is
inserted into the database where it is available to the Frontend for reporting purposes
on the Web Portal, which is the ViPR SRM User Interface (UI).

Figure 2 ViPR SRM metrics collection

Log on and explore the ViPR SRM Interfaces
A single web portal application provides access to all user and administrative features
of ViPR SRM.

Procedure

1. In a web browser, go to the following URL:

https://<frontend_server_name>:58443/APG

Obtain the ViPR SRM Frontend server name from your system installer.

2. On the login screen, enter a valid ViPR SRM user name and password, and click
LOGIN.

Note

Obtain the initial user name and password from your system installer. You can
create more user accounts once you are logged in as an administrative user.

Here is the default Home report page.

ViPR SRM introduction
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Note

As an administrator, you can configure the initial report that appears
immediately after logging in for various user profiles by navigating to
Administration > Profiles > ProfileName > Customizable Settings.

3. To explore reports in the User Interface, make selections in the navigation
column.

4. To explore the Administration features, click Administration in the banner.

5. Expand nodes in the Administration navigation tree to access administrative
features.

6. To return to the reports and the User Interface, click User Interface in the
banner.

ViPR SRM introduction
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7. To open the Help topics, click ? > Documentation in the banner.

The Help describes features available on the User Interface, such as managing
and scheduling reports, browsing features, and how to edit report definitions.
The Help also describes Administrative features available from the Console.

8. To explore user preference settings, click Profile > View Profile in the banner.

9. To log off, click Profile > Log out.

Provide an enterprise logo and message
Customize the ViPR SRM web portal by uploading an enterprise logo and adding a
welcome message.

The logo appears on the Login screen and in the upper left corner of the User
Interface Console when Navigation Style is tree navigation. The welcome message
appears on the Login screen.

Procedure

1. Log on to the Console and go to Administration  > Portal.

2. On the Frontend Status tab, in the Welcome Message field, provide a
message to your users for the Login screen.

Use plain text or HTML.

3. To upload a logo, click the Default Display tab.

4. Click Upload New Logo and select a file from your local system.

5. Click Save.

ViPR SRM introduction
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6. To test, click Profile > Logout in the banner, and then start over with the URL
to see the new Login screen.

Configuring an SMTP server
Configure an SMTP server to enable the email features in the product.

Procedure

1. Click Administration  > Modules > Alerting.

2. In the banner, click Global Settings .

3. Configure the SMTP fields.

4. Click Save.

You have successfully set the SMTP variables on the Backend (alerting) server.
In a 1-server setup, these settings also apply to the Frontend server.

5. In a setup with more than one server, set the SMTP variables on each Frontend
server.

Note

This step is required in a 4-VM vApp, or if the installation includes more than
one Frontend.

a. On the Backend server, copy the SMTP variables in /opt/APG/bin/
apg.properties.

b. On each Frontend server, paste the variables into /opt/APG/bin/
apg.properties.

6. Restart the Tomcat server.

a. Go to Administration > Centralized Management > Logical Overview >
Miscellaneous > Web Servers.

b. Click a Tomcat server.

c. Click Restart.

Navigation styles
The navigation column on the User Interface provides access to all reports. You can
choose between the Icon Navigation and Tree Navigation styles. The Administrator
sets the default style for the installation.

Default style

The administrator sets a global default navigation style in the Navigation Style
field at Administration > Portal  > Default Display.

Each user account can override the global default style and set their own
preferred style in the Navigation Style field at Profile > View Profile  >
Preferences.

ViPR SRM introduction
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Icon Navigation

The Icon Navigation style helps preserve space on smaller-sized windows. Initially,
it shows only a thin column of icons.

To navigate to a report, click an icon. A second column of categories appears.
Click a category to expand it, and click again to select a report. Notice the scroll-
bar on the expanded second column.

The second column disappears when you click a report. To navigate further into
the reporting structure, use the tabs, dashboards, and links in the reporting pane.

Tree Navigation

The Tree Navigation style can display the entire reporting structure, with multiple
nodes expanded at once.

Use the arrows to expand or contract the nodes. Click any entry in the tree to
display a report. You can also use the tabs, dashboards, and links in the reporting
pane to navigate around the reporting structure.

Set the navigation style
You can change the navigation style for your user account.

The administrator sets a global default navigation style under Administration >
Portal > Default Display. Your user account settings can override the global setting.

ViPR SRM introduction
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Procedure

1. In the banner at the top of the User Interface, click Profile  > View Profile.

2. Click User Preferences.

3. In Navigation Style, make a selection.

Option Description

default The administrator's global setting

tree Hierarchical tree

icon Thin icon column

4. Click Save.

Make icon navigation column static
For the icon navigation style, use the pin to toggle the second column between
temporary and static states.

In its default state, the second column disappears when you select a report. You can
pin the second column so it remains visible and the report pane moves to the right to
accommodate it.

Procedure

1. Click the pin at the top of the icon navigation bar.

2. Click the pin again to return the second column to a temporary display.

Use links in reports to get more detail
Reports contain links that let you drill down into more detail. Learn how to recognize
the links and understand where they lead you.

Here is a summary of the types of links contained in reports.

Note

To expose the links, hover your cursor over parts of a report.

Underline on configuration item indicates link to home report

An underline appearing when you hover the cursor over a configuration item in a
report indicates a link to a detailed storage system report for that item.

ViPR SRM introduction
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More details about a table row displays below a table

In some tables, click a row to show more details below the table. The original table
conveniently remains in view, letting you click each row in it and see the details
change per row.

Question mark (?) indicates link to history for a metric

A question mark (?) appearing when you hover the cursor over a metric indicates
a link to a historical trending report for the metric in a table cell.

Underline on report title indicates link to full-size report and supporting details

On dashboards and mixed reports, the report titles are links to the full-size report.
The full-size report typically includes a table of supporting details below the
report.

The following procedure illustrates these link types and shows how to recognize them
in a report.

Procedure

1. Click Report Library > solutionpack_name > Summary  > Table View.

The table lists all configuration items discovered by the SolutionPack.

For example, here is a Summary table for Report Library > EMC VMAX >
Summary > Table View.

2. Hover the cursor over items in the summary report to discover active links.

In the report above, the Array column contains active links to the home reports
for each discovered array.

3. Click a link to jump to the array's home report.
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4. Use your browser's Back button to return to a previous report.

5. Click Report Library > solutionpack_name > Inventory.

Here is an Inventory report for Report Library > EMC VMAX > Inventory.

The tabs on an Inventory report show the objects that are tracked by this
SolutionPack. In this case, there are enough tabs to require a scrolling tab bar.

6. Click a tab to explore the reports.

a. Hover the cursor over items in the report to discover active links.

b. In many Inventory reports, click a row to show additional details.

For example, in the following EMC VMAX > Inventory > Directors report,
click a row to see supporting details for each Array/Director combination.

ViPR SRM introduction
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Those details appear below the first table.

7. Click Report Library > solutionpack_name > Capacity, or click Dashboards >
Storage > Enterprise Capacity.

Either of the above displays a Capacity Dashboard showing multiple capacity
reports.

On dashboards and mixed reports, the report titles are links to supporting
details. Click the report title.

The full-size report appears, with the supporting details below it.

ViPR SRM introduction
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For more information
Find additional documentation about ViPR SRM and EMC M&R.

Documentation Index

The ViPR SRM 4.2 Documentation Index provides access to installation, security,
upgrade, configuration, and usage guides. It also contains release notes and a set
of matrixes of supported features and detailed system information. Pointers to
EMC M&R documentation are also included.

The index is here: EMC Storage Monitoring and Reporting Documentation Index

Embedded Help

The Help system embedded in the product provides information about features on
the User Interface and Administration Interface.

To open the Help, click the ? icon in the banner in the ViPR SRM web portal.

ViPR SRM introduction

For more information     23

https://community.emc.com/docs/DOC-62710
https://community.emc.com/docs/DOC-62950


ViPR SRM introduction

24 EMC ViPR SRM 4.2  Administrator Guide



CHAPTER 2

Manage users, profiles, roles, and
authentication

The following topics describe administrative procedures required to add or maintain
user accounts in ViPR SRM.

l User management.............................................................................................. 26
l View and edit profiles..........................................................................................31
l View and edit roles.............................................................................................35
l Authentication and realms..................................................................................40
l More security information..................................................................................48
l LockOutRealm and RoleLock............................................................................. 48
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User management
On the ViPR SRM Console, administrators can create and manage ViPR SRM user
accounts, and set roles and privileges on user accounts.

ViPR SRM supports multiple user accounts that have different purposes. The product
has predefined roles such as Datacenter Administrators, Storage Administrators, and
Network Administrators. You can also create new custom roles and assign specific
privileges to those roles.

To perform these operations, you need ViPR SRM login credentials with global
administrative privileges.

View and edit existing user accounts
Administrators can view a list of ViPR SRM user accounts and edit a user account.

The ViPR SRM User Management page lists all users, their status, their profile,
whether the profile is enabled, and some optional information about the user, such as
name and email address.
Procedure

1. Click Administration .
2. In the right pane, click User Management > Users, or in the left pane, click

Users.

The resulting page shows all defined user accounts.

Manage users, profiles, roles, and authentication
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3. Right-click a user to access a context menu of management actions.

4. Choose Edit to view or change information about a user account.

You can also click a user name to edit it.

5. Make changes on the tabs on the Users Modification page, and then click Save.

Add a user
Administrators can add new user accounts.

Procedure

1. Go to Administration  > Users > New User.

2. Complete the User Data tab.

Manage users, profiles, roles, and authentication
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a. Enter the user login and password credentials.

The new user will initially use these credentials to log on. Users can change
their password after logging on with these credentials, in their own settings
dialog.
The user login and passwords are case-sensitive.

Passwords do not need to be set if ViPR SRM is configured to use an
external authentication system such as LDAP.

b. Optionally enter a title, first and last name, and email address of the user.

The email address is used to send notifications of stored reports.

Users can enter these settings in their own settings dialog, which overrides
anything set here.

3. Click the User Status tab and set the user's rights and access.

a. For User Status, select either Normal User or Global Administrator.

Global Administrators have full rights to the EMC M&R framework and all its
components, cannot be disabled, and have no restrictions on templates.

Normal User is the default status for other users.

b. If you want to disable the user's ability to log on, select Disabled.

The user will not be able to log on until the account is enabled. You can also
toggle users to enabled or disabled using the right-click menu on the User
Management page.

c. For Profile, select the profile to apply to the new user.

Manage users, profiles, roles, and authentication
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Profiles determine language, time zone, dynamic graph usage, and the logo
used for the Web Portal.

d. For User Roles, add or remove assigned roles as necessary, using the Add
Role and Remove Role buttons.

Roles determine access and restrictions for the user.

4. Click the Other Options tab, and set the reports and metrics the user has
access to.

a. For Master Filter, enter a filter that restricts the metrics the user can see.

This filter is applied to the root node. The user cannot modify this filter.
Roles also have filters. The filter at the top of the page shows the Role filters
that apply to the user, based on the roles that the user belongs to. Role
filters are combined with an OR, and the user filter, with an AND.

b. For Custom Reports, select whether custom reports are accessible for the
user.

The user custom tree is a specific per-user branch of the tree nested under
My Reports, which the user can modify.

Manage users, profiles, roles, and authentication
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5. Click Save.

User authorization
Roles restrict access to resources through the use of role-based access control.

The default roles available are Normal User and Global Administrator. However, if
required you can also create a new role and apply filters to manage access
permissions.

RoleLock realm
To prevent users who do not have specific roles from logging in, use the RoleLock
realm feature. To enable this feature, go to Centralized Management, click
Configuration > Authentication. Click Add a Realm. From the Authentication Type
drop-down for the newly created realm, select RoleLock. The Roles Allowed
parameter accepts a comma-separated lists of roles. Any user who does not have one
of those roles is not allowed to log in.

LockOutRealm
The LockOutRealm feature provides a way to prevent a user from logging in if there
have been too many authentication failures for the user. This is designed to protect
against password-guessing and brute force attacks. This feature is enabled by default.

To customize this feature, go to Centralized Management, click Configuration >
Authentication and expand Realm Configuration [LockOutRealm].

Use the failureCount property to set the number of failed login attempts that are
permitted before locking out the user. The default is five failures. Use the
lockOutTime property to set how long a user will be locked out once the lock out has
been triggered. The default is 300 seconds. Click Save to enable the lock out
processing.

Multiple failures using the Test Authentication button will not result in locking out a
user in Testing mode or in Live mode. However, if a realm being tested itself has lock
out processing, repeated failures may result in the user being locked out of that realm.
For example, if an LDAP realm is configured and that realm has its own lock out
handling, then a user may be considered locked out in the LDAP realm even though
the user is not locked out in EMC M&R.

If added to Authentication Settings, lock out processing will apply to all of the other
realms configured in the system. For example, if the Authentication Settings includes
Local and LDAP realms as well as LockOutRealm, then a sufficient number of failures
in authentication attempts for a Local or LDAP user will result in the user being
temporarily locked out.

To disable this feature, expand the Realm Configuration and click the delete icon.

Delete a user
Administrators can delete a user account.

Procedure

1. Go to Administration  > Users.

2. Right-click the user you want to delete and select Delete.

Manage users, profiles, roles, and authentication
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Test user settings
You can test user settings to check how the settings are applied. Test mode applies
settings as if you were logging in as this user.

Procedure

1. Click Administration .

2. Under User Management, click Users.

3. Right-click the user you want to test, and choose Test User.

You are launched into the User Interface, interacting with the Console as if you
had logged in as the user being tested. The user name that you are testing
appears in the banner.

4. Browse reports and edit reports, and perform any other regular functions.

Any changes you make, such as editing report settings, are saved with their new
settings.

5. To exit test mode, click the X next to the test user's name in the banner.

View and edit profiles
The Profiles page gives you an immediate view of the profiles on your system, their
descriptions, and how many users are currently assigned to each profile. You can also
access a profile for editing from this page.

Procedure

1. Click Administration .

2. In the right pane, click User Management > Profiles or click Profiles in the left
pane.

The resulting page shows all defined profiles.

Manage users, profiles, roles, and authentication
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3. To view or edit the profile settings, click its name.

The Profile Modification window opens, where you can change the configured
settings.

4. If you make any changes, click Save.

Create new profiles and assign users to profiles
Administrators can create new profiles and assign users to profiles.

Procedure

1. Go to Administration  > Profiles > New Profile.

2. On the Main Properties tab, enter a name and a description for the new profile.

Manage users, profiles, roles, and authentication
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3. Click the Customizable Settings tab and set the language, time zone and logo.

Use the ? icons on the page for information about these settings. You can
upload a custom logo here which then appears on the login screen as well as on
the ViPR SRM user interface pages.

4. Click the Members tab and assign roles to this profile.

Manage users, profiles, roles, and authentication
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5. Click the External Members tab and, if appropriate, bind an external group to
the profile.
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6. Click Save.

View and edit roles
The Roles page provides a view of the roles on your system, their descriptions, and
how many users currently use each profile.

Procedure

1. Go to Administration  > Roles.
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2. To edit a role, click the role name.

3. Make changes on the tabs on the Role Modification page, and then click Save.

Create roles and assign users to roles
Administrators can create new roles and assign users to roles.

Procedure

1. Go to Administration  > Roles > New Role.

2. On the Main Properties tab, enter a name and description for the role.
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3. Click the Members tab, and add users to the role.

4. If LDAP authentication is configured, click the External Members tab and bind
an external group to the new role (LDAP Users).
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5. Click the Template Access tab and set1` ` report pack access for this role.

6. Click the Actions tab and select actions that this role can perform.
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7. Click the Module & Restrictions Access tab. For each module, select whether
users with this profile can access the module.
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8. Click the Role and User Management tab and select whether the new role can
manage other roles or the users with those roles.

Authentication and realms
User authentication is achieved through realms.

A realm defines how user credentials are obtained and checked. A realm defines the
connection, access, and search parameters required to perform authentication.

The default realm is the local realm, which accesses credentials stored in the EMC
M&R database. You can configure several realms and specify the order that they are
used for credential verification.

The following realm types are supported:

Type Description

Local Obtains user credentials from the user accounts stored in the EMC M&R
database.

LDAP Obtains user credentials from an LDAP server. LDAPS is also supported.

RoleLock Prevents users who do not have specific roles from logging in.

LockOutRealm Prevents users who have too many authentication attempts from logging
in.

Keystone Uses the OpenStack identity service.
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Type Description

Custom Uses other credential sources.

LDAP authentications are supported. A custom choice is also provided.

When using an external database such as LDAP for authentication, you still need at
least one local user account, with global administrator rights, matching a domain
account.

You can configure roles and profiles in ViPR SRM, and map those roles and profiles to
values in the external database.

Add new realm
Add a new realm to define a new authentication source or to enable authentication-
related features.

Procedure

1. Go to Administration > Centralized Management.

2. In the right corner of any Centralized Management screen, click
CONFIGURATION > AUTHENTICATION.

The Authentication Settings dialog appears.

Two realms are provided by default after installation:

l Local
l LockoutRealm

3. Click Add a Realm.

4. Select an Authentication Type.

5. Configure additional fields that appear for the selected authentication type.

6. Click Add Property if you need to supply additional parameters to the
authentication source.
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For example, if you selected Custom, use Add Property to define the
parameter names required to configure connections and credential search.

7. ClickTest Authentication ( the  icon) to test connectivity to the realm.

The  icon indicates that connectivity was established.

The  icon indicates that connectivity failed.

8. If authentication failed, check configured property values or add additional
properties as needed for the realm, and retest connectivity.

9. Click Save.

Prioritizing authentication realms
You can set the LDAP server as the first authentication method that is used to check
credentials. If you have several realm configurations, the system will check user
credentials one after another according to the order they are listed.

Procedure

1. From the CONFIGURATION drop-down, select AUTHENTICATION.

The Authentication Settings dialog appears.

2. Use the up and down arrow icons to set the order of the authentication
methods that will be used to check credentials.

Local realm

The Local realm authenticates from user names and passwords configured in ViPR
SRM.

The Local realm is the default authentication method that is activated after
installation. It does not require any additional configurations.

If you configure an external database, such as Active Directory, for authentication,
you still need at least one local user account, with global administrator rights, that
matches a domain account.

Configuring an LDAP server for authentication
To authenticate ViPR SRM users with LDAP or LDAPS, add an LDAP realm to ViPR
SRM and configure the LDAP connection and user search information.

Procedure

1. For LDAPS, copy and import certificates for the LDAP server and for the ViPR
SRM Frontend server.

See the EMC M&R Security Configuration Guide for procedures.

2. Select an existing LDAP user to use for the LDAP connections, and obtain the
Distinguished Name (DN) for that user.

To avoid security issues, select a user with read-only privileges to the directory.
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You can obtain the DN using dsquery or another tool on the AD server. For
example, the following dsquery obtains the DN for the user W4NAD.

> dsquery user -name W4NAD
"CN=W4NAD,CN=Users,DC=support,DC=local"

3. Navigate to Administration > Centralized Management.

4. From the CONFIGURATION drop-down, select AUTHENTICATION.

The Authentication Settings dialog appears.

5. Click Add a realm.

6. In Authentication Type, select LDAP.

7. Configure the required LDAP connection properties that appear. See 
Configuration properties for LDAP authentication on page 44 for property
explanations.

8. Add additional optional properties, as needed by your LDAP implementation.

See Configuration properties for LDAP authentication on page 44 for property
descriptions for typical use cases.

To add a property, use either of these methods:

l Select a property from the Add Property drop-down list, and click Add.
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l Type a property name in the text box, and click Add.

Each Add action adds the new property name and accompanying text box for
configuring the value for the property.

9. Click the  icon to test connectivity to the LDAP server.

The  icon indicates that connectivity to the LDAP server has been
established.

The  icon indicates that connectivity to the LDAP server failed.

10. If authentication failed, add additional properties as needed for your LDAP
implementation and their values and retest connectivity.

11. Click Save.

12. Provide ViPR SRM privileges to the LDAP authenticated users by either:

l Create ViPR SRM local users that match the LDAP users.

l Map LDAP/AD groups to ViPR SRM roles. See Adding external members to
a role on page 47.
For LDAP, you can use just the group name in the mapping. The
distinquished name is not required.

For example, using information from the following dsquery that requests all
group names starting with Watc, the external group name to map is
Watch4netLDAP.

 >dsquery group -name Watc*
"CN=Watch4netLDAP,CN=Users,DC=support,DC=local"

Configuration properties for LDAP authentication
Properties in the LDAP realm configuration define how to connect to the LDAP server,
where to search for user names, and how to obtain roles.

LDAP configurations can be diverse and complex.

The first section below shows the properties that are typically required. The
subsequent sections show additional optional properties for common configurations.
For more complex configurations, where additional properties are needed for
authentication to succeed, you might need to research the LDAP implementation at
your installation before completing the configuration.
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To add optional properties to a realm configuration, select a property from the Add
Property dropdown list, or type a custom property name, and click Add. The added
property appears on the configuration dialog, where you can then configure its value.

Required properties
The following properties are mandatory for connection.

Table 1 Required properties for LDAP authentication

Property name Description and example

connectionURL The protocol, IP address, and port of the server that provides
access to the Directory Information Tree (DIT). For example:

ldap://your-ldap-server1:389

or

ldapS://your-ldap-server1:389

connectionName The Distinguished Name of the LDAP user you selected to connect
to the LDAP directory. For example:

 CN=W4NAD,CN=Users,DC=support,DC=local

connectionPassword The password of the user specified in connectionName.

userBase The base element for user searches. This is the base branch whose
members will be allowed to log into ViPR SRM. It is a key shared by
all of the users that need LDAP authentication. Often it is the
connectionName minus the first CN. For example:

CN=Users,DC=support,DC=local

Note

The connectionName and the userBase can be different branches.
To accommodate groups of users under different branches,
configure userBase so the search begins higher or at the top of the
DIT. Alternatively, you can configure multiple LDAP realms.

userSearch The message format used to search for a user. This is the LDAP
filter expression used to search for a user's directory entry. The
syntax is (variable={0}), where {0} represents the username.

Examples of common values for userSearch are:

l For Active Directory:

n (sAMAccountName={0})
n (userPrincipalName={0})

l For OpenLDAP:

n (uid={0})
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Alternate LDAP server connection
The following optional property provides a second connection URL.

Property name Description and example

alternateURL URL for a second LDAP server that provides redundant directory
services.

Binding roles to LDAP groups
The following properties are typically required before you can bind the ViPR SRM roles
to LDAP/AD groups.

Table 2 Required properties for mapping LDAP groups to roles

Property name Description and example

userRoleName Defines the attribute in the user directory entries that contain the
names of roles assigned to a user. Different schemas use different
attribute names for this purpose. Some commonly used values are:

memberOf
isMemberOf
member

If this property is not specified, the default is that all roles for a user

derive from the role search defined in roleSearch.

roleBase The base DN for group membership search (the DN of the DIT
location where groups are located. If not specified, the default is the
top-level directory context.
Example value:

CN=Users,DC=corp,DC=Example,DC=com

userSubTree Values are true or false.

When set to true, the search looks in the entire subtree of the

element specified by the roleBase property for role entries
associated with the user. The default value of false searches only

the top level.

roleSearch The LDAP filter expression used for performing role searches. Use {0}
to substitute the DN of the user, or {1} to substitute the username.
Example values:

(uniqueMember={1}) 
(member={0})

If not specified, a role search does not take place and roles are taken
only from the attribute in the user's entry defined in the

userRoleName property.

roleName The name of the attribute that contains role names in the directory
entries found by a role search. In addition, you can use the

userRoleName property to specify the name of an attribute in the

user's entry that contains additional role names. If roleName is not
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Table 2 Required properties for mapping LDAP groups to roles (continued)

Property name Description and example

specified, a role search does not take place, and roles are taken only
from the user's entry.
Example value:

sAMAccountName

Active Directory properties
Depending on your LDAP implementation, you might need to specify additional
properties for connecting to Active Directory. For example:

 referrals
 derefAliases

Adding external members to a role
If you are authenticating users with an external mechanism, such as LDAP, you can
assign groups of users defined in the external source to a role.

Procedure

1. Click Administration .

2. Under User Management, click Roles.

3. Select the role.

4. Click the External Members tab.

5. In Bind an external group to this role, type a group name defined in the
external source.

For example, type an LDAP group name.

6. Click Add to this role.

7. Repeat the previous two steps to add additional groups to the role.

8. Click Save.

Adding external members to a profile
If you are authenticating users with an external mechanism, such as LDAP, you can
assign groups of users defined in the external source to a profile.

Procedure

1. Click Administration .

2. Under User Management, click Profiles.

3. Select the profile.

4. Click the External Members tab.

5. In Bind an external group to this profile, type a group name defined in the
external source.

For example, type an LDAP group name.
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6. Click Add to this profile.

7. Repeat the previous two steps to add additional groups to the profile.

8. Click Save.

More security information

For more information about system access and other security topics, see the EMC
M&R Security Configuration Guide on the documentation index at EMC Storage
Monitoring and Reporting Documentation Index.

LockOutRealm and RoleLock
The LockOutRealm and RoleLock realms are used in addition to other realm types to
provide specialized authorization features.

The LockOutRealm prevents a user from logging in if there have been too many
authentication failures for the user. To disable this feature, delete the realm.

The RoleLock realm prevents users who do not have specific roles from logging in. In
the realm configuration, the Roles Allowed parameter accepts a comma-separated
lists of roles. Any user who does not have one of those roles is not allowed to log in.

Also see User authorization on page 30.
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CHAPTER 3

Manage ViPR SRM processes and scheduled
tasks

The following topics describe administrative tasks for managing and configuring the
ViPR SRM processes and scheduled tasks.

l Starting and stopping processes .......................................................................50
l Access configuration and log files for system processes.................................... 51
l Check status of all processes.............................................................................52
l Stopping processes on the command line.......................................................... 54
l Access and configure scheduled tasks............................................................... 54
l Metrics collection and reporting........................................................................ 55
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Starting and stopping processes
You can manage the ViPR SRM system processes from the Console.

Procedure

1. Go to Administration > Centralized Management > Logical View >
component_type > component_name.

2. In the right pane, view process information and status, and use the Start, Stop,
or Restart buttons to manage the process.
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Access configuration and log files for system processes
You can view and edit the configuration files for the ViPR SRM processes from the
Administration Console. The process log files, if any are generated, are downloaded
from the same window.

Procedure

1. Go to Administration > Centralized Management > Logical View >
component_type > component_name.

2. To view or edit a configuration file:

a. In the right pane, click the blue bar for Configuration Files.

b. In the list of configuration files, click the Edit (pencil) icon to open a file.

c. If needed, make changes to the file, and click Save.

3. To download or delete a log file:

a. Click the blue bar for Log files.

b. In the list of log files, click a file to select it.
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c. Click Download and respond to your browser's prompts for storing the file.

d. Click Delete and respond to the prompt to verify the delete action.

Check status of all processes
Use the EMC M&R Health reports for a quick view of process status. You can drill
down from problem indicators to details of the problems.

Procedure

1. Go to Report Library > EMC M&R Health  > Logical Summary.

2. Scroll down to bring the heat maps in view.

3. Look for blocks that are red or orange.

Red indicates that critical alerts exist for a component. Orange indicates major
alerts.

4. Hover your cursor over the block to see the component name.
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5. Click the block to display the detailed alert information for the component.
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Stopping processes on the command line

Stopping EMC M&R platform services on a UNIX server
Use the manage-modules.sh service stop command to stop a specific EMC
M&R platform service or to stop all EMC M&R platform services on a UNIX server.

Before you begin

Make sure you have logged in with root or APG privileges.

Note

The list of services varies depending upon which type of installation was performed,
for example, vApp, collector, backend, frontend, and so forth.

Procedure

l Type manage-modules.sh service stop <service_name> from the bin
directory of the installation to stop a specific EMC M&R platform service.

This example shows how to stop all EMC M&R platform services:

./manage-modules.sh service stop all 

Stopping EMC M&R platform services on a Windows server
Use this procedure to stop EMC M&R platform services from the Windows desktop.

Before you begin

Make sure you have logged in with system administrator credentials to manage
services.

Note

The list of services varies depending upon which type of installation was performed,
for example, vApp, collector, backend, frontend, and so forth.

Procedure

1. Type manage-modules.cmd service stop <service_name> from the bin
directory of the installation to stop a specific EMC M&R platform service.

This example shows how to stop all EMC M&R platform services:

./manage-modules.cmd service stop all 

Access and configure scheduled tasks
You can manage the ViPR SRM scheduled tasks from the Console.

Scheduled tasks run based on a CRON schedule in the task configuration file. You can
perform the following management functions on scheduled tasks:

l Edit the schedule and other parameters in the task's configuration file
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l View the task logs

l Run the task manually

l Disable the task

Procedure

1. To access the ViPR SRM scheduled tasks, go to Administration > Centralized
Management > Scheduled Tasks > task_category > task_name.

The task page shows information about the last run of the task.

2. To view or edit the configuration file:

a. Click to expand Configuration Files.

b. Click the Edit (pencil) icon next to the configuration file name.

The file opens in an editing window.

c. Make changes with care.

Note

Consider copying the original contents and saving it offline before making
any changes.

d. Click Save or Cancel to exit the editing window.

3. To view the log files, click to expand Log Files.

User interface features let you open a file, download large files, or view the end
of a file (tail command).

4. To run the task manually or disable it, use the Run Now or Disable buttons at
the top of the page.

Metrics collection and reporting
The ViPR SRM reports depend on a consistent stream of metrics collection. Gaps and
changes in the collected stream could indicate real problems, or they could represent
intentional configuration changes or decommissions. ViPR SRM makes certain
assumptions about collection gaps to provide reliable reporting.

Collectors and metrics

About Collectors
Collector instances are associated with specific SolutionPacks and are configured
during SolutionPack installation. For many collectors, you can configure the collection
frequency to conform to conditions at your site.

To change a collection frequency, reconfigure the corresponding SolutionPack. No
disruption in metrics collection occurs when you change a collection frequency.

A Collector Manager process manages a set of collector instances. On the
Administration console, you can see the Collector Manager processes and the status
(Started or Stopped), configuration files, and log files. Look under Administration >
Centralized Management > Logical View > Collecting.

Consistent reporting periods and aggregations
For accurate alignments between dashboard summaries and detailed reports, and for
usability, it is important to display reports by using a consistent reporting period and
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metric aggregation. For this reason, most reports, across all SolutionPacks, are
installed with standardized default display values. For example, many reports use last
aggregration over last 2 weeks.

Users can change the displayed values using the Display menu at the top of any
report. Changes that a user makes with the Display menu apply to only that user
account. The changes are temporary unless the user saves the changes in a saved
report. To make a permanent change that is visible to all users, an administrator would
change the report using Modifications > Edit Reports.

Metric status (active and inactive vstatus)
All metrics have an associated status (vstatus) of active or inactive. The active/
inactive status is maintained by a system task called the import_variable_status task.
By default, this task is scheduled to run every 6 hours, but you can reconfigure that
schedule.

Metric status progresses from active to inactive as follows:

Active

Under normal circumstances, a collector obtains a new value for each metric at
every collection frequency interval. This metric is an active metric.

Active but stale

When collection interruptions occur, a metric becomes stale. Depending on the
circumstances (explained later), a stale metric might be marked inactive after 24
hours plus the variable status task frequency, or it might remain active for up to 2
weeks. During the time that a metric is active but stale, reports typically show the
last collected value for the metric. After 2 weeks, a stale metric becomes inactive.

Inactive

When the system determines that a stale metric is inactive, the entire row
disappears from inventory reports. As a result, reports do not typically show
blanks. On occasion, a blank might appear if a single metric becomes inactive and
other metrics for that expansion are still active.

Configure the import_variable_status task
The import_variable_status task examines active but stale metrics and determines
when to make them inactive. The installed configuration settings are adequate for
typical installations.

The installed default settings are as follows:

Configurable settings Installed defaults

<schedule> element The task runs every 6 hours

<param> element,

"inactive" attribute

Stale metrics become inactive after 14 days of inactivity when
the inactivity is the result of collection failures.

<param> element, "max-
inactive" attributes

Stale metrics where only one member in a group of peers is
affected become inactive after 24 hours of inactivity.

If needed, you can change the schedule and the delays. The following list parses the
elements in the configuration file.
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<schedule>

Sets the run schedule for the task. The installed setting is every 6 hours.

<schedule 
     cron="0 */6 * * *" 
     xsi:type="schedule-repeated" 
     disabled="false">

<param> {"inactive":"14d",

The inactive parameter sets how long a metric can be stale before being
changed to inactive when all metrics in a specific peer group are stale (indicating
a collection failure). The installed setting makes stale metrics inactive after 14
days of inactivity.

<parameters>
     <param>{"inactive":"14d",...

The assumption is that collection failures are typically corrected within a 14-day
time period and most installations do not want to see fluctuations in metrics
caused by collection failures.

You can decrease (or increase) this time period if needed.

"max-inactive": "24h"

The max-inactive attribute defines how long one member of a peer group can
be stale before becoming inactive.

When no metric is collected for a single member of a group (and metrics are
collected for other members), this is not a collection failure. Rather, it typically
indicates a permanent change, such as a deleted or reconfigured component. The
assumption is that most installations want to see such a change reflected as soon
as possible in reports.

For most installations, the 24-hour delay is optimal. The 24-hour delay
accommodates the timing of other processes, such as all collector intervals and
database processes.

You can increase this delay period if needed.

Note

Only small installations with correctly timed processes can consider decreasing
this period.

Note

There are multiple max-inactive attributes. All of them must be changed to the
same value to maintain integrity of global reporting.

WARNING

Do not change the vgroup filter definitions. The vgroups are properly tooled to
work together to accommodate all peer group possibilities for all SolutionPacks.
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Use this procedure to change the configuration settings.

Procedure

1. Go to Administration > Centralized Management > Scheduled Tasks >
Backend  > import_variable_status_instance.

Each Backend in your installation has an import_variable_status task.

2. On the task page, click to expand Configuration Files.

3. Click the Edit (pencil) icon beside the following file.

data/task_repository/backend/Default/
import_variable_status.task

4. Make changes in the text editor, and click Save.

5. Make the same change for each Backend instance.

How ViPR SRM handles collection interruptions
An interruption in the collection of an active metric could be caused by a temporary
problem with a collector or a device, or a permanent reconfiguration or decommission.

Reasons for collection gaps
The following conditions can interrupt or stop metric collection.

Subcomponent reconfigured, removed, or temporarily down

A component or part related to a device is reconfigured or deleted. For example,
one or several ports or arrays could be reassigned, or a LUN could be removed
from a configuration. In these situations, the previously collected metric will never
reappear.

A subcomponent or part could be temporarily down. In this case, the metric will
resume collection normally when the part is up.

Temporary collection issue

There is a temporary problem that prevents collection for a time. As examples,
the device could be shut down for maintenance, there could be a problem in the
network, or a problem with the collector process itself.

Collection of this metric will eventually resume.

Device decommissioned

An entire device is decommissioned or removed from the infrastructure. The
previously collected metrics will never reappear.

These are very different use cases. For the most meaningful reporting, the system
distinguishes between these use cases and accommodates for them differently in the
reports.

Examining status of peer group members
When a gap in metric collection occurs, ViPR SRM examines other components that
are peers to the one that is missing metrics. For example, if a port or a LUN
experiences a collection gap, ViPR SRM examines other ports or LUNs on the same
device.

l If at least some peers are collecting normally, then the issue is affecting only
isolated subcomponents, and not the entire device.
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l If all peers are experiencing gaps, then the issue is either a collection issue or a
decommission. The system cannot immediately determine which one.

Reporting results
The following table shows the reporting results for the three collection gap use cases.

Table 3 Reporting results for metric collection gaps

Condition preventing
metric collection

Reporting results

Subcomponent reconfigured,
removed, or down
(peers of the subcomponent are
collecting normally)

l The last collected value is used in reports until the
metric is made inactive, or until collection resumes in
the case of a temporarily down port or other such
subcomponent.

l After 24 hours plus the configured frequency of the
import variable status task, all of the metrics
associated with the subcomponent are made inactive,
and the subcomponent disappears from reports.

l In the case where a subcomponent is down long
enough for the metric to become inactive, when the
component is up and metrics are collected again, the
metric becomes active again after being inactive for a
time.
For example, a port might be down for more than a
day, and its metrics will become inactive after about 24
hours (since other peers are still actively collected).
When the port comes back up, the inactive metrics
become active again. When looking at such metrics
historically, we will not know that the metric was
inactive for any period of time in the middle. The
reports look as if the metric was just stale.

Temporary collection issue l Reports continue to show the component as active for
2 weeks, using best guess values based on the last
available value.
In this way, the reports bridge the gap in collection,
preventing artificial dips in graphs and empty table
cells.

For availability reports, 0 is used.

l The assumption is that a collection issue would be
detected and fixed within a 2 week period.

l After 2 weeks plus the configured frequency of the
variable status task, the metric is made inactive and
disappears from active reports.
The assumption is that if a collection issue is not
resolved in 2 weeks, it must be a decommission.

l Historical metrics for the device remain in the database
and continue to appear on trending reports until it ages
out based on time periods.
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Table 3 Reporting results for metric collection gaps (continued)

Condition preventing
metric collection

Reporting results

Device decommissioned l Reports continue to show the component as active for
2 weeks, using best guess values based on the last
available value. For availability reports, 0 is used.

l After 2 weeks plus the configured frequency of the
variable status task, the metric is made inactive and
disappears from active reports.
The assumption is that if a collection issue is not
resolved in 2 weeks, it must be a decommission.

l Historical metrics for the device remain in the database
and continue to appear on trending reports until it ages
out based on time periods.

Monitoring for collection interruptions
The Explore > Storage > Storage Systems report contains a column that shows time
since last collection. You can schedule an alert that watches this column and sends
notifications or alerts when interruptions are detected.

Procedure

1. Go to Explore > Storage > Storage Systems.

The default report has visual cues set up based on thresholds. These are only
visual cues and are not related to alerts or notifications.

2. To view or change the threshold settings:

a. With the Storage Systems report in view, click Modifications > Edit
Reports.

b. On the Report Details:Table tab, expand the blue bar for the Total time
since last collection column.
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c. Click Value Settings.

d. View or change the current threshold settings in the Thresholds Definition
section.

e. Click Save if you make any changes.

f. Click BROWSE MODE to return to the report.

3. To set up an alert, first schedule an alert on the report:

a. At the top of the report page, click Tools > Schedule this report.

b. On the Schedule tab, set up the schedule for automatic runs of the report.

The schedule is the frequency to check for data collection issues. For
example, select Every day at 00 hours 00 minutes.

c. On the Alert tab, click a box to select the Alerting Backend process. This
step sends the report information to the Alerting Backend for alert
processing every scheduled run.

d. Click Save.

4. To continue with alert setup, enable and configure the Data collection issue
alert definition.

The Data collection issue alert definition captures and processes the
information on the Storage Systems report. Follow these steps to access the
alert definition:

a. Go to Administration > Modules > Alerting > Alert definitions.

b. Click in the header of the Type column to re-sort that column to list the
global definitions first.

c. Right-click the alert definition named Data collection issue and select
Enable.

d. Right-click the alert definition again and select Configure.

The default configuration triggers an alert if the time difference between the
last collected time and the current time is more than 86400 seconds, which
is 24 hours.

e. Optionally change the configured time setting, and click Save.

Results

Whenever any storage array does not collect for more than the specified time (24
hours by default), an alert appears in the All Alerts report. The following figure shows
example alerts.
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Figure 3 Data Collection Issue alerts on the All Alerts report

If you click a row in the All Alerts report, a detailed report about that alert appears.

Figure 4 Data Collection Issue alert details

Isolated causes of reporting gaps
Some reporting gaps, such as empty table cells, trend chart dips, and report
mismatches cannot be avoided.

You might notice the following minor inconsistencies in reported metrics:

l A collection issue at the beginning of a time range or a newly discovered device
can cause missing data points at the beginning of a trend chart.

l For inactive capacity metrics, data points at the end of a trend chart remain blank.
If the capacity metric is active, the line continues forward as if the data was still
being collected. This can be done because capacity metrics are known not to
change very often.

Manage ViPR SRM processes and scheduled tasks

62 EMC ViPR SRM 4.2  Administrator Guide



l Missing data points at the end of a performance chart are left blank, for both
active and inactive metrics. Even if the metric is still active, it would be undesirable
to extrapolate performance metrics to fill in missing performance data, as
performance data varies widely.

l The last collected metrics are included in trend charts for the two weeks until the
metric becomes inactive. As a side effect, decommissioned devices or their
components continue to show in the trend charts for the two weeks between the
time of the decommission and when the metrics become inactive. When the
metrics become inactive, the trend charts reflect the true decommission time.
For example, if a device is decommissioned on 10/1, the metrics continue showing
up in the trend chart until 10/15, filling in the blanks at the end of the time range
with last collected value. When the metrics become inactive on 10/15, the metrics
are no longer filled in, and the trend chart shows the drop on 10/1, because that is
the last known data point.

l Collection failures can cause a mismatch between rolled up metrics on a storage
array and the sub-component report. For example:

n The Used Capacity > Capacity of NAS File Systems report shows the last
collected value when a partial collection issue occurs. However, the Used
Capacity for a File Storage Array shows 0 which is derived from the sum of all
NAS FileSystems.

n The Used Capacity for Masked and Mapped LUNs report shows the last
collected value when a partial collection issue occurs. However, the Used for
Block for a Block Storage Array shows 0 which is the sum of mapped and
masked LUNs.

l Some reports use blank or a 0 for rolled-up capacity metrics when the value is
actually not supported or not applicable to the device in the row. Examples are:

n Total Raw Capacity does not apply to VPLEX or ViPR Controller, and such cells
show blank.

n If a block array is not connected to a Virtual Storage or Object array, the value
0 shows in cells for Used for Virtual Storage and Used for Object in the rolled-
up dashboards.

l Partial collection issues can cause fluctuations in line charts for roll up capacity
values such as Used for File, Block, Virtual Storage (between 0 and the valid
value).

l A mismatch might occur between capacity or configuration reports and topology
maps when a report is using the last available value due to a collection issue.

l Collector restarts might cause dips in charts, as some aggregate metrics require
multiple collection cycles to resolve completely, and the values during the initial
collection intervals after the restart may not be accurate.

l Down periods in the middle of a time range may not be represented correctly. For
example, in a report that aggregates multiple port metrics, if some of the ports go
down, you will see a dip in the end of the time range, because the aggregate line
chart aggregates values only for the ports that are currently up. Once those ports
come back up, this dip (which should really remain, if the port was truly down) is
lost, because the system has no way to know whether the missing metric values
were due to a collection issue or because the components were down.
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CHAPTER 4

Routine maintenance and health checks

The following topics describe how to ensure ViPR SRM performance and availability.

l Quick access to serious infrastructure alert details............................................66
l System health checks........................................................................................ 68
l Use alerting reports to monitor system health....................................................76
l JVM sizing requirements.................................................................................... 78
l Backup and restore............................................................................................ 78
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Quick access to serious infrastructure alert details
The ViPR SRM Home page provides a quick overview of serious infrastructure
problems and provides quick access to more details.

The Home page is the default landing page immediately after log in. The four item
reports on the page indicate serious problems in your infrastructure, in the following
categories:

l Storage Systems—How many Storage Systems are experiencing hardware
failures or critical alerts?

l Fabric Switches—How many Fabric Switches are experiencing hardware failures
or critical alerts?

l Hosts—How many Hosts are experiencing hardware failures or critical alerts?

l SRM Components—How many SRM Components are experiencing critical or
major alerts?

From any of these items, you can quickly drill into the supporting details, and then to
the details of an individual alert.

Procedure

1. If not already there, click Home in the left navigation bar.

The following details appear in each item report:

Link

Jumps to a pre-filtered All Alerts report. For Storage Systems, Fabric
Switches, and Hosts, the All Alerts report is filtered to show all critical
alerts and any other alerts related to hardware failures for the category
type. For SRM Components, the All Alerts report is filtered to show all
critical and major alerts for SRM components.

Pie chart

Shows the percentage of components in the category that are currently
affected by serious problems. In our example, 50% of SRM Components
are experiencing problems.

Red number in middle of pie chart

Shows the number of components in the category that are currently
affected by serious problems. There can be many reported alerts, all
related to the same issue on a single component. In our example, 2 SRM
Components are experiencing problems, with 10 alerts reported.
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Out of x

Indicates the total number of components in the category. In our example,
2 out of 4 SRM Components are experiencing critical or major alerts.
Likewise, there are 0 out of 11 Fabric Switches experiencing hardware
failures or critical alerts.

Category

Identifies the type of component: Storage Systems, Fabric Switches,
Hosts, or SRM Components.

Last two lines

Shows the count of alerts that will appear in the linked All Alerts report. In
our example, the filtered All Alerts report for Storage Systems will show 4
alerts related to hardware failures. The red number 1 indicates that all 4 of
those alerts are associated with the same storage system.

2. To view details about the alerts in one of the categories, click the link at the top
of the item.

The result is the All Alerts report with filters applied.
For example, the following report shows 10 major alerts on ViPR SRM
components.

3. To view complete details on a single alert, click that alert row.

The Alert Details report for the specified alert appears.
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System health checks
To ensure normal operation of ViPR SRM, basic monthly health checks are
recommended.

Regular monitoring of system health and proactive actions ensure expected levels of
accessibility and performance for ViPR SRM.

The health checks described here use metrics and status values in ViPR SRM reports
as indicators of current health. The tasks describe:

1. How to navigate to the key health indicator reports, which columns to examine,
expected values, and hints for resolving potential issues.

2. How to access important log files.

Prerequisites
You must use an account with administrator privileges to perform most of these tasks.

Web server health
Verify the health of the Tomcat web servers.

Procedure

1. Go to Report Library > EMC M&R Health > Misc. Reports > Daily
Dashboard , and scroll to the Web Servers (Tomcat) report.
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2. Check the following metrics:

❑ Availability (%) should be near 100%.

❑ Memory Usage (%) should be under defined thresholds.

❑ CPU Usage (%) should be under defined thresholds.

3. Resolution: As needed, increase memory and quantity of vCPUs on the Web
Server virtual machine. Continue to monitor utilization.

Services health
Verify that all services are running on each ViPR SRM server.

Procedure

1. Enter these commands:

On Linux

 /opt/APG/bin/manage-modules.sh service status all

On Windows

C:\Program Files\APG\bin\manage-modules.cmd service status 
all

2. Check the command output for stopped services.

❑ Typically, all services should be running.

3. Resolution: If a service is down, determine if it is stopped for a reason. If not,
start the service. If a service does not start, investigate and resolve the
problem.
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Server disk space
Check the used and available space on all servers in the ViPR SRM environment.
Running out of disk space can result in a loss of data.

Procedure

1. On Linux servers, run the df -h command to check available disk space.

2. On Windows servers, open Windows Explorer and click Computer to check
available disk space.

3. On the ViPR SRM Console, go to Report Library > EMC M&R Health > Misc.
Reports > Daily Dashboard and scroll to the File Systems report.

4. Verify that no servers are running out of space.

❑ Verify disks on all Frontend servers

❑ Verify disks on all Backend servers

❑ Verify disks on all Collector servers

5. Resolution: Assign disk space as needed.

Database health
Verify the health of the ViPR SRM databases.

Procedure

1. Go to Report Library > EMC M&R Health > Misc. Reports > Daily Dashboard,
and scroll to the Databases report.
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2. Verify the following:

❑ Current Metrics Count per database should be less than 1.5 million
(1,500,000).

3. Resolution: When these numbers are exceeded, the database is overloaded.
Install an additional database and redistribute the metrics.

Note

The ViPR SRM upgrade service does not include this effort. If desired, EMC
Professional Services can assist with this effort.

Backend servers health
Verify the health of the ViPR SRM backend servers.

Procedure

1. Go to Report Library > EMC M&R Health > Misc. Reports > Daily Dashboard
and scroll to the Backends report.

2. Check the following:

❑ Memory Utilization % should be less than 70%.
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❑ CPU Usage % should be less than 60%.

❑ Current Queued Files Count should always be less than 20. That number
should also never increase dramatically and then return to a value near
zero. A continuously increasing number indicates a problem with new data
insertion. A backlog can cause gaps in graphs and lack of data in reports.

3. Resolution: As needed, increase memory and quantity of vCPUs.

Collector managers
Verify the health of the ViPR SRM collector managers.

Procedure

1. Go to Report Library > EMC M&R Health > Misc. Reports > Daily Dashboard
and scroll to the Collector Managers report.

2. Check the following metrics:

❑ Memory Usage (%) should be less than 90%.

❑ CPU Usage (%) should be less than 60%.

3. Resolution: If overages exist, examine the server-specific reports to determine
the causes.

Server CPU and swap space
Verify the health of ViPR SRM servers.

Procedure

1. Go to Report Library > EMC M&R Health > Misc. Reports > Daily Dashboard,
and scroll to the Servers Summary report.
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2. Check the following metrics:

❑ CPU Utilization values should be less than 60%.

❑ Swap Usage values should be at or near 0.

3. Resolution: For overages, perform troubleshooting on the server to find the
process using the large amount of CPU or swap space. Then make appropriate
decisions, such as assigning more memory to resolve swapping.

Temporary files
Ensure that temporary files on the Backend servers are getting cleaned up
appropriately.

The Backend servers use temporary files to help increase performance. These files are
located on each of the Backend servers at Backends/APG-Backend/<instance
name>/tmp/.

Temporary files should be cleaned up automatically by the system. You should verify
that temporary files are not building up over time.

Procedure

1. Go to Report Library > EMC M&R Health > Servers Summary.

2. Click a row in the report.
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A page of detailed reports about that server appears. Near the top, you can find
the server's role.

3. If the server's Vapp Role is a Backend or AdditionalBackEnd, scroll down to find
its Backends Temp Files Count report.

4. Check the following:

❑ Verify that the temporary file count rises and falls consistently.

5. Use the browser's Back button to return to the Servers Summary report, and
repeat these steps for other Backend servers.

Note

The temporary files count is not an issue for the Frontend and Collector roles. A
Temp Files Count report does not exist for those roles.

6. Resolution: If the file counts indicate that temporary files are not getting
deleted automatically, this might indicate a problem with data insertion. Open a
Service Request with EMC Support.

Check log files
Review the Collector Manager and Web Server log files for errors.

You can access log files on the server command line or through the ViPR SRM
Console.
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Procedure

1. Review logs from the Collector Manager for errors.

l The file path name is:
Collecting/Collector-Manager/Default/logs/
collecting-0-0.log

l To download from the Console, go to Administration > Logical Overview >
Collecting > Collector-Manager::instance_name. In the right pane, expand
the blue bar for Log files, select logs/collection-0-0, and click
Download.

2. Review logs from the Web Servers for errors.

l The file path names are:

n Web-Servers/Tomcat/Default/logs/apg-tomcat-
default.out
This is the log file for the current Tomcat running instance.

n Web-Servers/Tomcat/Default/logs/catalina.<date>.log
The system indicates if there are any errors.

l To download from the Console, go to Administration > Logical Overview >
Miscellaneous > Web-Servers > Tomcat:: instance-name. In the right
pane, expand the blue bar for Log files, select the files as named above, and
click Download.

3. Resolution: Troubleshoot the root cause of any errors as indicated by the error
text. For additional assistance, open a Service Request with EMC Support.

Task completion
Verify that all ViPR SRM tasks on each server completed successfully during their last
run.

Procedure

1. Go to Administration > Centralized Management > Physical Overview  >
server_name > Tasks.
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2. Check the following:

❑ Last Result values should be Success. Ignore for tasks that are disabled or
unscheduled.

3. Resolution: If tasks are unsuccessful without a known reason, contact EMC
support.

Data collection
Verify that data collection is occurring as expected.

Procedure

1. Go to Report Library.

2. For each SolutionPack name, select Summary and check the following:

❑ Verify that data exists in the summary report, indicating that collection is
occurring.

3. Resolution: If missing data is not expected, investigate whether it is a
collection configuration issue, collector problem, or discovery issue and resolve
it. Otherwise, contact EMC support.

Use alerting reports to monitor system health
The SolutionPack for EMC M&R Health includes predefined alerts for system health
issues.

The alerts are pre-configured but must be enabled. If those alert definitions are
enabled, the alerting reports will show health issues as they occur. You can monitor
alerts on a daily basis or configure the alert definitions for email notification.

1. To see a list of alert definitions for system health and enable them:

a. Go to Administration  > Modules > Alerting > Local Manager > Alert
definitions > EMC M&R Health.
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b. If the State column does not contain a green check mark, click the row and
select Enable.

c. If a configuration dialog opens, you must configure the alert definition before
enabling it.

2. To return to the reporting interface, click User Interface  in the banner.

3. To view alerts related to system health:

a. Go to Dashboards > Operations > Alerts Summary, and scroll to the Alerts by
Source report.

b. To make Alerts by Source larger on the dashboard, hover your cursor above
the right corner of the report until a mini-menu appears, and click the Make
this element wider icon.

c. If APG_Health is one of the bar labels, click that bar or tooltip. The result is a
detailed alerts report filtered for APG_Health.

d. Click a row in the Alerts report to see more details for that alert, including the
related alert message.

Routine maintenance and health checks

Use alerting reports to monitor system health     77



JVM sizing requirements
ViPR SRM provides a report to help you to set the ideal memory size for the JVM
maximum memory setting (memory.max).

To see the report, go to Report Library > EMC M&R Health > Misc. Reports > JVMs
Sizing Recommendation.

l This report helps you to set the ideal memory size for the JVM maximum memory
setting (memory.max). The report calculates the proper memory allocation for
EMC M&R Modules by computing the 15% of the 95th percentile Used Memory to
better utilize the memory resources of your servers.

l The memory.max setting should be rounded to the nearest multiple of 64: Value
between 0 and 64 : 64, Value between 65 and 128 : 128

l The report shows each of the modules running and the memory consumption for
each of those modules. It monitors the maximum used memory for the last 24 hour
period. It shows the currently allocated heap size and the optimal recommendation
for memory.

l It is best practice not to lower memory but rather increase it when needed.

Backup and restore
A consistent backup schedule is recommended.

See the ViPR SRM documentation index at ViPR SRM 4.2 Documentation Index for
documents that describe backup and restore methods and recommendations.
Instructions are included for several backup technologies.
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CHAPTER 5

Occasional administrative tasks

The following topics describe procedures for managing the ViPR SRM features that
require some configuration, maintenance, or enabling and disabling of entities.

l Tasks after new SolutionPack installations........................................................ 80
l Saving Display settings...................................................................................... 80
l Exclude maintenance period from report totals.................................................. 81
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Tasks after new SolutionPack installations
Some configuration tasks might be required after installing a new SolutionPack.

You can find all of the documentation referenced below on the ViPR SRM
documentation index here: ViPR SRM 4.2 Documentation Index.

Discover new devices

If the Solutionpack adds support for a new type of device, the devices must be
discovered before they will appear on reports. For procedures, see the
SolutionPack-specific chapter in the EMC ViPR SRM SolutionPack Guide.

Configure new devices to send alerts to ViPR SRM

If your site is using consolidated alerting to show alerts from all devices in the
storage infrastructure, each device must be configured to send alerts to ViPR
SRM. For procedures, see the SolutionPack-specific chapter in the EMC ViPR
SRM SolutionPack Guide.

Enable or disable new alert definitions

Most SolutionPacks install alert definitions for the SolutionPack's devices or
features. You should review them and decide which to enable or disable. For
procedures, see the EMC ViPR SRM Alerting Guide. For a list of alerts by
SolutionPack, see the Alerts Matrix.

Configure and enable new compliance policies and rules

Many SolutionPacks install compliance policies and rules for the devices. If your
site uses the compliance features, you should review them and decide which to
configure and enable or disable. For procedures, and a list of policies, see the
EMC ViPR SRM Compliance Guide.

Saving Display settings
Changes to Display settings normally apply to the current report and current session
only. Use the following methods to make changes more permanent.

l Click the Lock icon. Your changes are applied to all reports that you browse during
the current session. (Exception: On Dashboard reports of type mixed using
defaults, the child reports always retain their default time settings.)

l Click Tools > Save this Report. All of your changes are stored as a report under
My Reports > Stored Reports. This version of the report persists across sessions,
but is visible only in your user account.

l To save your changes as the default display for all users, use Modifications > Edit
Reports. On the Report Configuration tab, look for the following fields to change
the reporting periods:

n Default Duration

n Sampling Period

n Sampling Type
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Exclude maintenance period from report totals
You can configure a report to exclude a time period that might skew the report totals
or provide inaccurate projections. You can specify days and hours to exclude from the
metrics.

Procedure

1. Click Display at the top of any report page to show settings that control the
reporting period.

2. Under Time Range Quick Switch, click the Maintenance Period calendar icon.

The Maintenance Period calendar appears.

3. Click one or more squares to specify a time period to exclude from reports.

Squares that are greyed out are excluded from the report. For example, the
following calendar excludes metrics collected for 11 to 11:59 PM every Monday.
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4. Click Ok.

The current display on your Console excludes the specified time period. Other
users do not see the excluded time period, and the settings do not persist
across sessions for your user account.

5. To save this configuration for your user account, click Tools > Store this
report.

The report with the altered display configuration is saved in My Reports >
Stored Reports. Other user accounts do not see your stored reports.

6. To apply this configuration for all user accounts, persisting across all sessions,
use EDIT MODE:

a. Click EDIT MODE at the top of a report page.

b. Click the Report Configuration tab.

c. Under Default Duration, click the Maintenance Period calendar icon.

d. Click one or more squares in the calendar to specify the time period to
exclude from reports.

e. Click Save.

f. Click BROWSE MODE at the top of the page to return to the report.

The report configuration is changed for all users. The navigation path to the
report remains the same as before.
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CHAPTER 6

Update and expand ViPR SRM

The following topics provide guidelines for keeping all ViPR SRM components up to
date and expanding the environment to accommodate growth.

l Online Update overview..................................................................................... 84
l Updating SolutionPacks..................................................................................... 87
l Expand reporting capabilities with additional SolutionPacks............................... 91
l Plan for future growth........................................................................................ 91
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Online Update overview
Online Update automatically downloads the latest versions of the SolutionPacks and
EMC M&R components from the EMC Update server to the Module Repository on the
Centralized Management (CM) server.

In a multi-server environment, the downloaded modules are distributed to all of the
remote servers managed by the CM server.

Configuring server settings for online updates
Procedure

1. Click Administration .

2. Click Centralized Management.

3. Click Configuration > Online Update .

4. Ensure that you are on the Settings tab.

5. Check the Enabled checkbox.

6. Type your EMC Online Support username and password.

7. Click the  icon to test connectivity to the update server.

The  icon indicates that connectivity to the server has been established.

The  icon indicates that connectivity to the server failed.

8. Click Save.

Enabling the online update task
Enable the Online Update task to download the latest updates from the EMC Update
server automatically.

Procedure

1. Click Administration .

2. Click Centralized Management.

3. On the Physical Overview page, click the <host_name> - Front End where
the Online Update task needs to run.

4. Click Tasks.

5. Type OnlineUpdate in the Search bar.

6. Click the OnlineUpdate scheduled task.

7. Click Enable.

Note

By default, this task is set to run once everyday at 12AM. You can customize
the task schedule by editing the configuration file.
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Running the online update task manually
At any time, you can run the Online Update task manually to access the available
updates.

Procedure

1. Click Administration .

2. Click Centralized Management.

3. On the Physical Overview page, click the <host_name> - Front End where
the Online Update task needs to run.

4. Click Tasks.

5. Type OnlineUpdate in the Search bar.

6. Click the OnlineUpdate scheduled task.

7. Click Run Now.

Online Update Status
The Online Update Status tab indicates whether or not the last online update check
was successful, provides the date and time of the last successful check, and lists any
updates that are available for download.

Figure 5 Online Update Status

If a major update of the EMC M&R platform is detected, the Status tab includes a
Major Update Status section that describes the version that is available, provides a
link to the upgrade documentation, and includes a Start Download button.
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Figure 6 Online Update Status with a major version update detected

Downloading a major update
You can use Online Update to download a major version of the EMC M&R platform.
You should only download a major version if you intend to immediately complete the
full upgrade process.

Procedure

1. Click Administration .

2. Click Centralized Management.

3. Click Configuration > Online Update.

4. Click the Status tab.

5. Click Start Download. When the download is finished, the Download State will
change from "Not Downloaded" to "Complete."

6. Complete the upgrade process as described in the upgrade documentation.
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Online Update History
The Online Update History tab provides a download history with the names of the
components, the version numbers, and the date and time of the downloads.

The History tab also allows you to search the download history for a particular
component name or version number.

Disabling the online update task
You can disable the Online Update task if you prefer to manually download the updates
from the EMC Update server.

Procedure

1. Click Administration .

2. Click Centralized Management.

3. On the Physical Overview page, click the <host_name> - Front End where
the Online Update task needs to run.

4. Click Tasks.

5. Type OnlineUpdate in the Search bar.

6. Click the OnlineUpdate scheduled task.

7. Click Disable.

Updating SolutionPacks

Overview
Use these procedures to update SolutionPacks and other components that Online
Update has downloaded from the EMC Update server to the Module Repository on
the Centralized Management (CM) server. You can update SolutionPacks separately
from the process of upgrading the system to the latest version.

The update process detects if any manual edits were made to the SolutionPack files. If
a manually edited file is compatible with the new version of the SolutionPack, it will be
reused and the system will display a message to let you know. If a manually edited file
is not compatible with the new version of the SolutionPack, the system will back up
the file and display a warning message that indicates the name and location of the
incompatible file. The system does not check files that were not were not included
with the SolutionPack.

Upgrading all SolutionPacks and other components
You can upgrade all of your installed SolutionPacks and other components with a
single click.

Before you begin

If you want to update a single SolutionPack to receive the benefit of a required fix or
feature, refer to Updating SolutionPacks and Other Components.

Synchronize the packages across the servers:

1. From Centralized Management, click Packages Management on the left-hand
pane.
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2. Click the Synchronization button.

3. Select retrieve the latest packages from the remote servers.

4. Wait for the synchronization to complete before proceeding.

Procedure

1. From Centralized Management, click SolutionPacks on the left-hand pane.

2. Click the Update All Components button in the top-right corner of the page.

The Initialization window opens and lists the following details:

l Number of components from SolutionPacks that will be updated to the
latest version.

l Number of components that contain new features that require
configuration.

3. Click Next. The Configuration window opens. The left-hand pane lists each of
the components that include new features that you need to configure. The
right-hand pane displays the configuration details for the component with the
new features highlighted in yellow. Carefully review the selections to make sure
the configuration details for the components and SolutionPacks are correct,
and modify any configuration that are not set correctly. When you have finished
configuring a component, click Next to move onto the next component. You
must edit some SolutionPack entries while reviewing the configuration:

l For the SolutionPack for EMC M&R Health, select the Front End hostname
for the Web-Service Gateway.

Figure 7 Configuring the SolutionPack for EMC M&R Health

4. After you have configured every component on the list, click Next.

5. The Confirmation window opens and lists all of the components that will be
updated. Confirm that all of the components are correctly listed, and then click
Update.

6. The Update window opens and displays the progress of each update and the
percentage complete of the overall update. Do not close the browser window
during this step.

The update process detects if any manual edits were made to the SolutionPack
files. If a manually edited file is compatible with the new version of the
SolutionPack, it will be reused and the system will display a message to let you
know. If a manually edited file is not compatible with the new version of the
SolutionPack, the system will back up the file and display a warning message
that indicates the name and location of the incompatible file. The backed up
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files are saved in their current directory with the following format: <file-
name>-old-<version>_<date>.<ext>
Messages about the following incompatible files can safely be ignored:

l tmsconfig.xml

l snmp-masks.xml

l slave-snmp-poller.xml

l emc-vmax-mapping.xml

Figure 8 SolutionPack update incompatible file messages

7. The Results window opens. Use the drop-down menu to check the status of
each component. Any manually edited files that were backed up by the system
will be displayed under “Updated with warnings.”

Updating SolutionPacks and other components
Learn how to update installed SolutionPacks and other components.

Procedure

1. Navigate to the installed SolutionPacks page: http://<Frontend IP
address>:58080/centralized-management/#/sp

2. Depending on which SolutionPacks or components you want to update, click
the appropriate button:
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Option Description

Update all of the installed
SolutionPacks and other
components

Click the Update All Components button in the
top-right corner of the page.

Update all of the installed
SolutionPacks

Click the Select All button located below the
SolutionPacks table, and then click the Update
button.

Update all of the installed
other components

Click the Select All button located below the
Other Components table, and then click the
Update button.

Update individual
SolutionPacks or other
components

In the SolutionPacks table or the Other

Components table, click the update icon  for
the SolutionPacks or other components that you
want to update.

The Initialization window opens and lists the following details:

l Number of components from SolutionPacks that will be updated to the
latest version.

l Number of components that contain new features that require
configuration.

3. Click Next.

The Configuration window opens. The left-hand pane lists each of the
components that include new features that you need to configure. The right-
hand pane displays the configuration details for the component with the new
features highlighted in yellow. Carefully review the selections to make sure the
configuration details for the components and SolutionPacks are correct, and
modify any configuration that are not set correctly. When you have finished
configuring a component, click Next to move onto the next component. After
you have configured every component on the list, click Next.

4. The Confirmation window opens and lists all of the components that will be
updated. Confirm that all of the components are correctly listed, and then click
Update.

The Update window opens and displays the progress of each update and the
percentage complete of the overall update. Do not close the browser window
during this step. When the installation is complete, the Results page opens.

5. The Update window opens and displays the progress of each update and the
percentage complete of the overall update. Do not close the browser window
during this step.

The update process detects if any manual edits were made to the SolutionPack
files. If a manually edited file is compatible with the new version of the
SolutionPack, it will be reused and the system will display a message to let you
know. If a manually edited file is not compatible with the new version of the
SolutionPack, the system will back up the file and display a warning message
that indicates the name and location of the incompatible file. The backed up
files are saved in their current directory with the following format: <file-
name>-old-<version>_<date>.<ext>
Messages about an incompatible tmsconfig file can safely be ignored. Similar
warnings while updating generic-snmp about incompatible files for module
'snmp-collector' can also safely be ignored.
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6. The Results window opens. Use the drop-down menu to check the status of
each component. Any manually edited files that were backed up by the system
will be displayed under “Updated with warnings.”

Adding new components

Procedure

1. Navigate to the installed SolutionPacks page: http://<Frontend IP
address>:58080/centralized-management/#/sp

2. In the Other Components section of the page, click Add Component.

The Browse and Install Other Components page opens.

3. Click the component that you want to install.

4. Specify the server where you want to install the new component, and click
Next.

5. If necessary, specify additional configuration settings.

6. Click Install.

Expand reporting capabilities with additional SolutionPacks
As your environment acquires additional device types, you can expand the ViPR SRM
reporting capabilities to accommodate the new devices by licensing additional
SolutionPacks.

See the Licensing chapter for information about trial and new licenses.

Plan for future growth
Use these guidelines to plan ahead for ViPR SRM system growth.

A ViPR SRM configuration typically consists of multiple servers, each with assigned
responsibilities. Each server type has a different set of growth parameters to watch to
determine whether additional servers of that type might be needed.

The following figure summarizes the ViPR SRM server configuration and when to
consider additional servers.
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Figure 9 Growth metrics to monitor

1 Scale the Presentation layer horizontally based on the number of concurrent
users.

2 Scale the Backend layer horizontally based on the number of metrics.

3 Scale the Collection layer horizontally based on the number of devices and sites.

When is an additional Frontend server needed?

l The number of concurrent users increases.

l The recommendation is one Frontend server for every 10 concurrent users.

When is an additional Backend/Database server needed?

l The number of metrics per database is approaching 1.5 million.

l The number of properties per database exceeds 20 times the number of
metrics per database.

Note

Performance issues will arise once these limits are exceeded.

l Upgrading could significantly increase the number of metrics in the database
as new metrics are introduced with new functionality. Customers must
understand the impact when upgrading.
For example, suppose that an upgrade introduces 8 new VMAX performance
metrics for LUNS. If a VMAX installation has 50,000 LUNS, this would
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translate into 400,000 new metrics added in the database as a result of the
upgrade. Customers should always consult the latest Planner prior to upgrade.

When is an additional Collector Manager server needed?

l Server load is above 4 and more devices are being added to data collection.

l Server resources are always running at full capacity.

l Not enough disk space and adding additional storage is not an option.

l Collector server needs to be close to resources being polled.

When is an additional SNMP collector needed?

l The maximum load value of the collector is exceeded. (defaut:5000)

l The SNMP collector is becoming unresponsive.

l Timeouts occur when polling SNMP groups.

l Multiple polling frequencies are needed.
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CHAPTER 7

Licensing

The following topics describe how to manage and troubleshoot ViPR SRM ELMS
licensing, including how to upload license files, delete trial licenses, verify available
licenses, and synchronize licenses on multiple hosts.

l Licensing concepts............................................................................................ 96
l Licensing operations...........................................................................................97
l Troubleshooting licensing ................................................................................ 102
l ELMS license entitlements............................................................................... 105
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Licensing concepts
Learn how to manage and troubleshoot ViPR SRM ELMS licensing. Learn how to
upload license files, delete trial licenses, verify available licenses, and synchronize
licenses on multiple hosts.

Starting with ViPR SRM 3.0, ViPR SRM uses ViPR SRM the Electronic Licensing
Management System (ELMS) for licensing. ViPR SRM runs on the EMC M&R
platform, which uses a different licensing system. Various other products that also run
on EMC M&R, such as Software Assurance Suite (SAS) and ViPR, continue to use the
legacy license system, which is also referred to as EMC M&R licenses.

To manage ViPR SRM licensing, you need to understand permanent and trial licensing
and the relationship between EMC M&R features and the ViPR SRM ELMS licenses.

After installation: Licenses and SolutionPacks
A ViPR SRM installation includes the software for the core system features and all
SolutionPacks. Although the installation includes the software for all SolutionPacks,
your site might not have permanent licenses for all of them.

The ViPR SRM licensing method divides product content into the following three
categories:

1. ViPR SRM core software, which is a bundling of core features and selected
SolutionPacks.

2. ViPR SRM add-on SolutionPacks.

3. SolutionPacks that are not part of ViPR SRM.

EMC M&R feature names and ELMS licenses
EMC M&R is the underlying platform for ViPR SRM. EMC M&R identifies
functionality using strings known as EMC M&R feature names. ELMS licenses use a
different set of strings to refer to sets of features.

Feature names are formal references to SolutionPack names, collectors, and
components that work within the product. For example, XML Collector is the feature
name corresponding to the collector component that collects XML data. As another
example, the SolutionPack that collects VNX data uses the feature name SolutionPack
for EMC VNX. Services and components typically require multiple sets of features to
run properly.

An ELMS license maps to a set of EMC M&R features.

Trial licenses
Your ViPR SRM software can include all trial licenses or a combination of permanent
and trial licenses.

Licenses that you purchase are permanent. Other software comes with trial licenses.

Trial licenses let you test features in the UI and perform some initial configurations
before full purchase. Trial licenses typically last for 30 days after the installation time.
You cannot copy or regenerate a trial license in the product.

If all of your licenses are trial licenses, including the core software license that includes
the Web Portal feature, the software can lock out all users from accessing the UI
when the trial expires.
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License duration
Permanent licenses do not expire. Trial licenses have expiration dates, typically 30
days after the installation date.

When trial licenses expire, module license checks fail and the modules stop working. If
the Web Portal module fails, you cannot access the product.

Because the License Management UI operates behind the Web Portal module, you
must upload your permanent license file or extended trials before the 30-day license
for the core features expires. Otherwise, the UI locks and you cannot upload the
license file. If this happens, see Troubleshooting licensing on page 102.

License purchase
To convert a feature from a trial license into a permanently licensed feature, you need
to purchase a license.

To initiate the purchase of a license for a SolutionPack or ReportPack, visit EMC
Online Support using the following URL:

https://support.emc.com/servicecenter/createSR/

On the page that appears, submit a service request to EMC. Include the SolutionPack
or ReportPack name that you want to purchase.

When all purchasing transactions are complete, EMC sends you instructions for
downloading a regenerated license file for your site that includes the newly purchased
software license. Download the file to a local server, and then follow instructions in 
Upload a new license file on page 100 to upload the new license file into ViPR SRM.

Note

Until the license is purchased and the new license file is obtained and uploaded into
ViPR SRM, the SolutionPack is inoperable, unless the 30-day trial license is still in
effect.

Licensing operations
Use the ViPR SRM Centralized Management UI to perform licensing management
operations, such as uploading, verifying, deleting, and synchronizing licenses.

Log in with admin credentials
You must have administrator credentials to perform license management operations.

Procedure

1. Access ViPR SRM by typing the following URL in a web browser:

https://frontend-hostname/centralized-management

where frontend-hostname is the server where the ViPR SRM frontend
module is installed.

The ViPR SRM login page opens.

Licensing

License duration     97



2. Log in with a user account that has administrator credentials.

The Centralized Management UI opens to the Physical Overview page.

3. In the navigation tree in the left pane, click Licenses Management.

The Licenses Listing page opens. Notice the Upload and Synchronize
operational commands at the top of the page.

View license information
You can view license information in two ways in ViPR SRM. One method displays
licenses by host. The other one shows a centralized view of all licenses.

Procedure

1. Log in to ViPR SRM.

2. To view active licenses on a physical host, navigate to Administration >
Centralized Management > Physical Overview  > host-name.

3. Click the Licenses tab.

The host's Licenses tab opens, as shown in the following figure. The page
shows the features with active licences on that host. It also indicates whether
licenses are permanent or trial, the expiration date for trials, and additional
license properties, if applicable.
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4. To view a consolidated list of licenses for all hosts, and to perform license
management operations, in the navigation tree in the left pane, click Licenses
Management.

The Licenses Listing page opens showing all licenses on all servers.
The following figure shows this page. Notice the ELMS permanent license,
showing all features included in the license and the license serial number. Also
notice the Upload and Synchronize commands at the top of the page.
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This table displays Information for ELMS licenses related to product name for
the license, SWID, and serial numbers.

Upload a new license file
To add a new license to your system, such as a newly purchased SolutionPack or
ReportPack license, you upload a new license file.

Before you begin

1. Purchase the required licenses.

2. Download the new license file to a local server, as directed by EMC during the
purchase process.

When you upload a license file, the new file affects all servers capable of using the
licenses.

Procedure

1. Log in to the Centralized Management UI in ViPR SRM using the following URL:

https://frontend-hostname/centralized-management

2. In the navigation pane, select Licenses Management.

3. Click Upload at the top of the page.
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The License Upload dialog appears.

4. Click Browse and locate the new license file that you downloaded.

5. Click OK.

The system extracts the licenses and displays them in the table on the Licenses
Listing pane.

6. When the License Upload Complete dialog appears, click OK, and then click
Continue.

The new license automatically affects all servers capable of using the license.

7. Delete the trial licenses that correspond to newly licensed features, if any.

To delete a trial license, see Delete licenses on page 101.

Delete licenses
You can select and delete specific licenses or delete all licenses. A delete action
affects all servers that use the license.

After you install a permanent license, delete the trial licenses that are covered by the
permanent license.

Procedure

1. Log in to the Centralized Management UI in ViPR SRM using the following URL:

https://frontend-hostname/centralized-management

2. In the navigation pane, select Licenses Management.

3. In the Licenses Listing table, select one or more license check boxes.

4. Click Delete.

The Delete command appears below the table. It is dimmed until you select at
least one license.

The system deletes the selected license from all available servers.

Synchronize licenses on multiple hosts
The Synchronize action ensures that all remote hosts have licenses based on those
available on the Centralized Management host.

Certain situations might cause licenses to become out of sync. For example, if a
remote host is unavailable when you perform an upload or a delete operation, those
operations would not be propagated to the offline server. Another example is if you
add a new server to your configuration, the new server would need licensing
information.

Procedure

1. Log in to the Centralized Management UI in ViPR SRM using the following URL:

https://frontend-hostname/centralized-management

2. In the navigation pane, select Licenses Management.
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3. Click Synchronize at the top of the page.

The system synchronizes the licenses on all remote hosts.

Troubleshooting licensing
You can resolve common licensing problems.

Permanent license stops working after host reconfiguration
If you change the configuration of a host, for example, by adding interfaces, removing
interfaces, or changing the operating system, your permanent license might stop
working. If your license does not work, obtain a new host ID and request a new
permanent license.

Before you begin

Ensure that you have a login with root, EMC M&R, or system administrator privileges
to perform this task. The user apg is the account that the application uses instead of
root.

Procedure

1. Log in to the operating system command line on the EMC M&R host server.

2. To obtain the new host ID, run one of the following operating system
commands:

Operating system Command

UNIX /opt/APG/bin/manage-licenses.sh host-id

Windows C:\Program Files\APG\bin\manage-licenses.cmd host-
id

The command output is the new EMC M&R host ID.

3. Copy the host ID information to the clipboard or to a text file.

4. To obtain the new license, go to the EMC support site using the following URL:

https://support.emc.com/servicecenter/createSR/

The Create a Service Request page opens.

5. Submit a service request to EMC, asking for a new permanent license file for a
new host. Paste the new host ID into the request.

6. When EMC sends you the new license file, follow the procedure in Upload a new
license file on page 100.

Users are locked out of ViPR SRM
If the license for the core ViPR SRM features expires, the system locks users out of
the UI.

To recover from this scenario:

1. Obtain a license file with permanent licenses. See License purchase on page 97.

Licensing

102 EMC ViPR SRM 4.2  Administrator Guide



2. Install the new license file from the command line. See Install license file from the
command line on page 103.

3. Restart the Tomcat service. See Restart Tomcat service on page 103.

4. Log in to ViPR SRM and perform the following tasks:

a. Reinstall the new license file from the Centralized Management UI.

b. Delete the expired trial licenses.

See Reinstall license file and delete trial licenses after lockout on page 104.

Install license file from the command line
You can install a license file from the command line if you are locked out of the UI.
Always use the UI unless you are locked out.

Before you begin

l Ensure that you have an OS account with root, apg, or system administrator
privileges. The application uses the apg account, rather than root.

l Acquire a new license file from EMC and download it to a local server. To request a
new license file, create a Service Request on EMC Online Support.

Procedure

1. Log in to the server where the ViPR SRM core software is installed.

2. Copy the new, valid license file to this same server. The file is a .zip file.

3. At the OS command line, navigate to the bin directory.

4. Install the license file using one of the following commands appropriate to your
OS:

Operating
System

Command

UNIX
./manage-licenses.sh install download_path/license.zip

Windows
manage-licenses.cmd install download_path\license.zip

Note

The command installs the license file on this server only.

Restart Tomcat service
If the Web Portal license expires, you might need to restart the Tomcat service.

Before you begin

1. Install the new license file using operating system commands.

2. Ensure that the library search path is correct on the server that is the host for the
core software. This requirement applies to the libstdc package on a Solaris
server and the libaio package on a LINUX server.

It is only necessary to restart the Tomcat service when the license for a web
application, such as the Web Portal, expires.
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Procedure

1. Log in to the server where the ViPR SRM core software is installed.

2. At the OS command line, navigate to the bin directory.

3. Run one of the following commands appropriate to the OS:

Operating System Command

UNIX ./manage-modules.sh service restart tomcat

Windows manage-modules.cmd service restart tomcat

The command output starts like this:

* Starting 'tomcat Default'... [ OK ]

Reinstall license file and delete trial licenses after lockout
After you install a permanent license file on the command line, you need to reinstall
that file using the Centralized Management UI to make the license visible in the UI and
available for distribution to other remote servers. You also need to delete the expired
trial licenses.

Procedure

1. Open a browser and log in to the Centralized Management UI in ViPR SRM
using the following URL:

https://frontend-hostname/centralized-management

2. In the navigation pane, select Licenses Management.

3. Click Upload at the top of the page.

The License Upload dialog appears.

4. Click Browse and locate the new license file.

5. Click OK.

The system extracts the licenses and displays them in the table on the Licenses
Listing pane.

6. When the License Upload Complete dialog appears, click OK, and then click
Continue.

The new license automatically affects all servers capable of using the license.

7. In the License Listing table, select all expired trial licenses by clicking the
appropriate check boxes.

8. Click Delete.

The Delete command appears at the bottom of the page, below the table of
licenses.

The delete action automatically affects all available servers.
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Module does not start or has no license
If a component reports that it has no license or does not start, verify the licenses on
the physical host.

Procedure

1. Log in to the Centralized Management UI in ViPR SRM using the following URL:

https://frontend-hostname/centralized-management

2. Navigate to Physical hosts  > host-name > Licenses.

The page shows all licenses active on this local host.

3. Inspect the Expiration column for the termination date of each license.

ELMS license entitlements
This section describes the features associated with the core ViPR SRM license.

The ELMS SRMSUITE_GENERAL feature bundles all of the basic features and
SolutionPacks that you receive as part of any ViPR SRM purchase. This bundle
enables most of the EMC M&R functionality, in addition to the SolutionPacks for
infrastructure components, such as hosts, VMs, fabrics, switches, and the database.

Array support is achieved through add-on features. For the add-on features, there are
several Open Platform licensing categories, and several array-based licensing
schemes. Add-on licensing is out of the scope of this document.

The following table lists the features included in SRMSUITE_GENERAL.

Table 4 Features in ELMS SRMSUITE_GENERAL

Feature Name

ReportPack for Fibre Channel Fabrics

ReportPack for Oracle

SolutionPack for Brocade FC Switch

SolutionPack for Cisco MDS Nexus

SolutionPack for Cisco UCS

SolutionPack for EMC AppSync

SolutionPack for EMC Data Protection Advisor

SolutionPack for EMC RecoverPoint

SolutionPack for EMC ViPR Controller

SolutionPack for EMC VPLEX

SolutionPack for EMC M&R Health

SolutionPack for IBM LPAR

SolutionPack for IBM SVC V7000
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Table 4 Features in ELMS SRMSUITE_GENERAL (continued)

Feature Name

SolutionPack for Microsoft Hyper-V

SolutionPack for Microsoft SQL Server

SolutionPack for Oracle Database

SolutionPack for Oracle MySQL Database

SolutionPack for Physical Hosts

SolutionPack for Storage Compliance

SolutionPack for VMware vCenter

ViPR SRM ELA License
Starting with EMC M&R 6.4u1, a ViPR SRM ELA license is available under the ELMS
feature name ViPRSRM_ELA. This license grants all of the functionality and
SolutionPacks for ViPR SRM. It is equivalent to a license for SRMSUITE_GENERAL
plus all of the available ELMS features (all SolutionPacks).

Note

The Backend Adapter for this license allows for 1 million devices and 4 million metrics
per device.
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CHAPTER 8

Troubleshooting procedures

The following topics describe troubleshooting procedures and utilities to help prevent
or diagnose problems with ViPR SRM operations.

l EMC Secure Remote Support (ESRS)............................................................. 108
l General recommendations for customer troubleshooting.................................. 112
l SSL certificates.................................................................................................112
l Troubleshooting ............................................................................................... 116
l Collecting diagnostics on UNIX......................................................................... 118
l Collecting diagnostics on Windows....................................................................118
l Detect and repair database crashes.................................................................. 118
l Find the SolutionPack that discovered a device................................................120
l VM Utilities Manager........................................................................................ 120
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EMC Secure Remote Support (ESRS)

EMC Secure Remote Support overview
Learn how to configure EMC Secure Remote Support (ESRS) for ViPR SRM. ESRS is
a software-based, secure access point for remote support activities between EMC
and your EMC information infrastructure.

Configuring ESRS
Configuring the product to communicate with ESRS allows the product to call home
and provide system configuration information to EMC support staff.

Before you begin

l ESRS V3 (Virtual Edition) must be running in a supported VMware ESX or
Microsoft HyperV environment.

l A valid ELMS license must be installed. (ESRS will not work with a trial license.)

l You need valid EMC Online Support credentials.

l Opening port 22 on both the ViPR SRM frontend host and the ESRS host is
required for additional communication between the two components.

l Optional: For validated SSL communications, a truststore is required to validate
the server's SSL certificate.

Procedure

1. In Centralized Management, click Configuration > Remote Support.

2. Check the Enabled checkbox.

If you do not check Enabled, ESRS is disabled with the following results:

l The ESRS task does not send any data to EMC.

l The Usage Intelligence task does not send any data to EMC.

l The Alerting backend does not send any ESRS alerts to EMC.

3. Type the IP address or server name of the ESRS server.

4. Type the port number. The default value is 9443.

5. Select SSL Validation if you want the system to check that the SSL certificate
used by the server is valid.

6. Type your EMC Online Support username and password.

7. Click the  icon to test connectivity to the ESRS server.

The  icon indicates that connectivity to the server has been established.

The  icon indicates that connectivity to the server failed.

8. After you have determined that the connection was successful, click Save.

9. EMC recommends that you enable HTTPS access (via port 58443 and 58080)
to the front-end UI. For detailed instructions, refer to the EMC M&R Security
Configuration Guide, which is available from the ViPR SRM 4.2 Documentation
Index.
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Running and scheduling the ESRS task
You can change how frequently ESRS calls home by editing the configuration file for
the scheduled task. By default, this task is set to run once a week.

Procedure

1. In Centralized Management, click Scheduled Tasks.

2. Type ESRS in the search field.

3. Click the ESRS task.

The Properties window for the task opens.

4. The ESRS task is disabled by default. If it has not yet been enabled, click
Enable.

5. Click the Configuration Files section to expand it.

6. Select the checkbox for the ESRS task, and then click the Edit File icon.

The configuration file opens.

7. Change the schedule by editing the cron expression. The expression for the
default setting (once a week) is "0 0 * * 0".

Example: To change the schedule so the task runs once a month at midnight on
the morning of the first day of the month, change the cron expression to "0 0
1 * *".

8. Click Run Now if you want to test the task.

9. Click Save.

Configuring an SSL truststore
For validated SSL connections, you must configure a truststore to validate the
server's SSL certificate.

The ESRS truststore is located at <Install_Dir>/APG/Custom/WebApps-
Resources/Default/centralized-management/esrs-truststore.
Procedure

1. If an SSL certificate has not been issued, you can use the certificate that the
ESRS VE is using.

a. Use a browser to navigate to the VE site.

The following instructions are for Google Chrome. The steps will vary slightly
depending on your browser. Refer to the documentation for your browser
for details about downloading certificate files.

b. Click the View site information button in the address bar. (It looks like a
lock.)

c. On the Connection tab, click Certificate information.

d. Click the Details tab, and then click Copy to file.

The Certificate Export Wizard opens.

e. Click Next, and then click the Base-64 encoded X.509 (.CER) radio
button.

f. Click Next. Provide a name for the certificate and specify the download
location for the file.
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g. Click Next, and then click Finish.

2. Add the certificate to your local truststore using Java Keytool:

keytool -import -trustcacerts -alias esrsve -file esrs.cer
–keystore new-truststore -storepass abcdef

3. Create an encrypted password with the crypt-password.sh tool:

Unix:

/opt/APG/bin/crypt-password.sh abcdef
Windows:

<installation directory>\APG\bin\crypt-password.cmd abcdef

4. Store the encrypted truststore password in the apg.properties file
(<INSTALL_DIR>/APG/bin/apg.properties).

For example:
esrs.trustStorePassword={289A04BF3B904C3A7ECA8C646FA0A0C3B
68948AEBC27EAE088161597EACED43E2B0A6CF1E7A3E019A1D8130CC2F
00AA5}

Configuration information sent to EMC via ESRS
The product sends a configuration file to EMC once a week that contains internal data
about your environment.

Category Details

Basic system information for the system
running Centralized Management

l System version

l Hostname

l IP address

l Operating system

l Operating system version

l Maximum memory

l Used memory

Managed servers (servers registered with
Centralized Management)

l Name

l Operating system

l Operating system version

l IP address

Installed licenses (all licenses registered to all
registered servers)

l Feature

l Expiration date

l Host ID

l Properties

Installed modules (all modules registered to all
registered servers)

l Name

l Version

l Server name

l Revision
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Category Details

l Category

l Operating system

Installed packages (all packages registered to
all registered servers)

l Category

l Version

l Server name

Installed services l ID

l Module

l Status

l Server name

Instance details (query results about the
installed system)

l Number of appliances by type

l Number of discovered devices

l Hosts by category

Instance details are provided by the esrs-
query-config SolutionPackBlock.

Reconfiguring the esrs-query-config SolutionPackBlock
By default, the esrs-query-config SolutionPackBlock gathers information from the
primary frontend. To change the host (or any other settings), you can reconfigure the
SolutionPackBlock.

Procedure

1. Navigate to the installed SolutionPacks page: http://frontend-hostname:
58080/centralized-management/#/sp.

2. Click SolutionPacks.

3. Under Other Components, click the Reconfigure icon for the ESRS-Query-
Config instance.

4. From the Frontend Web service drop-down menu, select Add a new FrontEnd
Web service.

5. In the Tomcat hostname or IP address field, enter the hostname or IP address
of the host from which you want esrs-query-config to gather instance details.

Alerts sent to EMC via ESRS

Component Alert Opening Criteria

EMC M&R Health Component error count 15 severe alerts within 3 intervals

EMC M&R Health Database metric count Count over 1 million

EMC M&R Health LoadBalancer error count 3 major alerts within a single interval

EMC M&R Health Percentage of file system
free space

Less than 10% free space available
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General recommendations for customer troubleshooting

Unless Customer Service asks you to perform different actions, follow these
recommendations:

l Limit troubleshooting to the UI and avoid performing troubleshooting steps at the
host, with the exception of pulling logs or starting or stopping services.

l Make a record of all changes you make and all procedures you perform so you can
work with support if the troubleshooting fails.

l Avoid changing XML files, but if you edit them:

n Before you edit, make a copy of the original XML file and place it in a safe
location.

Note

If the XML file is part of critical applications, take a snapshot of all application
VMs before making changes.

n Make a record of the edits you enter.

l If Customer Support asks you to change XML files, you will receive instructions on
how to perform backups before making changes. ViPR SRM does not support
autobackups.

SSL certificates
Generally, EMC products are distributed with a self-signed SSL certificate. If you
receive an SSL certificate error or a blank pane when you are attempting to access
content served by a data source, resolve the issue by doing one of the following
procedures.

SSL certificate error examples on page 113 provides a list of sample errors.

Temporary resolution
Accept the certificate exception temporarily: Troubleshooting an SSL certificate error:
Accepting the exception on page 113.

Permanent resolution
Add an SSL certificate to your truststore to permanently prevent the exceptions from
appearing.

You can: Perform:

Install the self-signed SSL certificate
that is provided with the EMC
product using an Internet Explorer
browser.

Installing a self-signed SSL certificate from
an Internet Explorer browser on page 113

Install the self-signed SSL certificate
that is provided with the EMC
product using a Chrome or Firefox
browser.

1. Export the self-signed SSL certificate to
save it to the export location: Exporting
an SSL certificate from an Internet
Explorer browser on page 115

2. Importing an SSL certificate into your
truststore on page 114
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You can: Perform:

Import an exported SSL certificate
that you or another administrator
prepared.

Importing an SSL certificate into your
truststore on page 114

If you need to prepare an SSL certificate to share with other users, use: Exporting an
SSL certificate from an Internet Explorer browser on page 115.

SSL certificate error examples
The SSL certificate error or a blank pane appears because the certificate is self-signed
and it is not added as an exception or into the truststore yet. For example, if you are
attempting to access content served by a data source, a blank pane appears when you
select views under SolutionPacks.

Chrome error examples

This site's security certificate is not trusted!

Or, a blank pane.

Firefox error example

This Connection is Untrusted

Internet Explorer error examples

There is a problem with this website's security certificate.

Content was blocked because it was not signed by a valid security 
certificate.

Troubleshooting an SSL certificate error: Accepting the exception
An SSL certificate error appears in your browser.

To resolve this issue,

Procedure

l Accept the exception.

Steps may vary for your browser. For example, for Internet Explorer, click
Continue to this website (not recommended).

This temporary solution causes the exception to be ignored for the current
browser session, but the exception reappears if you open another browser tab or
window.

Installing a self-signed SSL certificate from an Internet Explorer browser
Install the self-signed SSL certificate that is provided with the EMC product to
prevent certificate exception errors.

The following procedure is for Internet Explorer version 9.0. The steps may vary
slightly depending on your browser version.
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Procedure

1. Click Continue to this website (not recommended) in the browser window.

2. Click the red Certificate Error indicator next to the address bar.

3. In the Untrusted Certificate window, select View certificates.

4. In the Certificate dialog box, in the General tab, click Install Certificate.

5. Follow the instructions in the Certificate Import Wizard.

a. Select the Place all certificates in the following store setting to add the
certificate to your truststore.

6. In the Certificate dialog box, in the General tab, click OK.

After you finish

Refresh the browser window.

Importing an SSL certificate into your truststore
Import an SSL certificate into your truststore to prevent certificate exception errors.

Procedure

l Import the certificate using one of the following procedures:

n Importing an SSL certificate in Chrome on page 114

n Importing an SSL certificate in Firefox on page 114

n Importing an SSL certificate in Internet Explorer on page 115

Importing an SSL certificate in Chrome
For Chrome, use this procedure to import the certificate into your truststore.

The following procedure is for Chrome version 28.0.1500.95. The steps may vary
slightly depending on your browser version.

Procedure

1. Go to Settings > Show advanced settings.

2. Scroll down and select HTTP/SSL > Manage Certificates.

3. In the Trusted Root Certification Authorities tab, click Import.

4. Follow the instructions in the Certificate Import Wizard to import the
certificate.

5. Click OK in Internet options.

6. Refresh the browser window.

Importing an SSL certificate in Firefox
For Firefox, use this procedure to import the certificate into your truststore.

The following procedure is for Firefox version 23.0. The steps may vary slightly
depending on your browser version.

Procedure

1. Go to Firefox > Options > Options.

2. Click Advanced.

3. In the Certificates tab, click View Certificates.
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4. Click Import.

5. Locate the certificate file and click Open.

6. Click Save.

7. Click OK in Certificate Manager.

8. Refresh the browser window.

Importing an SSL certificate in Internet Explorer
For Internet Explorer, use this procedure to import the certificate into your truststore.

The following procedure is for Internet Explorer version 9.0. The steps may vary
slightly depending on your browser version.

Procedure

1. Go to Tools > Internet options.

2. In the Content tab, click Certificates.

3. Select the Trusted Root Certification Authorities tab.

4. Click Import.

5. Follow the instructions in the Certificate Import Wizard to import the
certificate.

6. Click OK in Internet options.

7. Refresh the browser window.

Exporting an SSL certificate from an Internet Explorer browser
Use this procedure to export a self-signed SSL certificate, so that you can either
import the resulting exported certificate into your truststore or share it with other
users.

The following procedure is for Internet Explorer version 10.0. The steps may vary
slightly depending on your browser version.

Procedure

1. Access the host for which you want to export the SSL certificate from the
browser.

For example: https://<myHostname>.emc.com
2. Select Continue to this website (not recommended) in the There is a

problem with this website's security certificate window.

3. Click the red Certificate Error indicator next to the address bar.

4. In the Untrusted Certificate window, select View certificates.

5. In the Certificate dialog box, select the Details tab and ensure that the Show
field is set to All. Click Copy to File.

6. In the Certificate Export Wizard,

a. Click Next in the Welcome screen.

b. Click Next to accept the default DER encoded binary X.509 setting in the
Export File Format screen.

c. Browse to the location where you want to save the certificate.

d. Specify the certificate file name and click Save.
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e. In the File name field, ensure that the location and the certificate file name
are correct. Click Next.

f. Click Finish.

g. Click OK when The export was successful appears.

7. In the Certificate dialog box, click OK in the Details tab.

8. Share the resulting exported SSL certificate with other users to use.

Troubleshooting

Report display problems

l What to do if data does not appear in any reports on page 116

l What to do if data does not appear in some reports on page 117

l Viewing collector errors in the Collector-Manager log files on page 117

What to do if data does not appear in any reports

Procedure

1. After the completion of at least three collection cycles, verify if data is
populating into the reports. If there is still no data in the reports, continue to the
next step.

2. Run the scheduled task to import data into reports. If there is still no data in the
reports, continue to the next step.

3. To view the log files for errors, go to Centralized Management and click
Logical Overview > Collecting > Collector-Manager::<instance name> > Log
Files.

Running a scheduled task to import data into reports
After you push a new configuration into a collector, a scheduled task runs and
populates the reports with new data. You can manually run the scheduled task to
import the data more quickly.

Before you begin

Allow at least three polling cycles to pass before manually running the scheduled task.

Procedure

1. Click Administration .

2. Click Centralized Management.

3. Expand Scheduled Tasks.

4. Click Database.

5. Select the import-properties-Default task.

6. Click Run Now.

7. Confirm success in running the task in the Last Result and Last Result Time
columns.
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What to do if data does not appear in some reports

Procedure

1. Run the scheduled task to import data into reports. If there is still no data in the
reports, continue to step 2.

2. Search for the metric in the database.

3. To view the log files for errors, go to Centralized Management and click
Logical Overview > Collecting > Collector-Manager::<instance name> > Log
Files.

4. To view the log files for errors, go to Centralized Management and click
Events > Event-Processing_Manager::Instance name > Logs.

To debug the errors, enable the Event-Spy for the Event Processing Manager.

Searching for metrics in the database
You can verify that a metric is being collected and used for reporting when you search
and find the metric in the database.

Procedure

1. Click Administration .

2. Under Modules, click Management of Database Metrics.

3. On the Metric Selection page, create the filter, type the number of results, and
select the properties to display for the metric.

For example, to list up to 100 results of the Capacity metric with the properties
of device and IP, type name=='Capacity' in the Filter field, 100 in the
Maximum results field, and select device and IP for the Properties to show.

4. Click Query.

A list of the metric results appears. If nothing displays, the metric is not being
collected.

Viewing collector errors in the Collector-Manager log files
Review the Collector-Manager log files to troubleshoot problems with data collection.

Procedure

1. Click Administration .

2. Click Centralized Management > Logical Overview.

3. Expand Collecting.

4. Click the Collector-Manager for your collector instance.

Collector-Manager::<Collector-Manager instance> - <host_ID>

5. Expand Log Files and click the View File icon to review the error messages.
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Collecting diagnostics on UNIX
You can run the diagnostic.sh script to collect data for Customer Support. The
script collects files required for troubleshooting EMC M&R and compresses them into
a zip file.

Procedure

1. Log in to a UNIX machine with root access.

2. Access the diagnostic.sh script at /opt/APG/Tools/APG-Diagnostic-
Tools/Default/bin/diagnostic.sh and run it.

If EMC M&R is installed as Minimal, the script is missing from the installation
and you need to run # manage-modules.sh install diagnostic-tools to
install the script.

Output from the script goes into a zip file in the /tmp/ directory. The output
file name is APG-DiagnosticFiles.tar.gz

3. Upload the output file into a Service Request or if the file is large, to an FTP site
specified by Customer Support.

Collecting diagnostics on Windows
You can run the diagnostic.sh script to collect data for Customer Support. The
script collects files required for troubleshooting EMC M&R and compresses them into
a zip file.

Procedure

1. Log into a Windows machine and open a command window.

2. Navigate to the folder <%INSTALL_ROOT%>\Program Files\APG\bin.

If EMC M&R is installed as Minimal, the diagnostic.sh script it missing and
you need to run manage-modules.cmd install diagnostic-tools to install
the script.

3. Run diagnostic.cmd.

Output goes into the file C:/Program Files/APG"\APG-
DiagnosticFiles.zip.

4. Upload the file into a Service Request or if the file is large, to an FTP site
specified by Customer Support.

Detect and repair database crashes

Procedure

1. Perform a weekly check:

a. Browse log files.

b. Check for suspicious errors.
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2. If you find slow reports, data missing, a portal hanging, and so on, suspect a
database crash and closely check the log files. For instance, if the database
crashes from an import-properties" task, you may receive errors like this:

140611 13:16:23 : INFO: Importing data from 'data_property' 
into '/opt/APG/Databases/APG-Property-Store/Default/tmp/DB/
APG-DB'...
140611 13:16:23 : Jun 11, 2014 1:16:23 PM 
com.watch4net.propstore.apg.ErrorLoggingCallback onTaskFailed
140611 13:16:23 : SEVERE: Importing data from 'data_property' 
into '/opt/APG/Databases/APG-Property-Store/Default/tmp/DB/
APG-DB' failed !
140611 13:16:23 : java.sql.SQLException: Table 
'data_property' is marked as crashed and should be repaired
.
.
.
140611 13:16:23 : Jun 11, 2014 1:16:23 PM 
com.watch4net.propstore.apg.ErrorLoggingCallback onTaskFailed

MySQSL errors could appear:

140611 13:16:23 [ERROR] /opt/APG/Databases/MySQL/Default/bin/
mysqld: Table 'data_property' is marked as crashed and should 
be repaired
140611 13:16:23 [ERROR] /opt/APG/Databases/MySQL/Default/bin/
mysqld: Sort aborted: Table 'data_property' is marked as 
crashed and should be repaired

3. If a database crash occurs, you should run mysql-database-check.sh:

[root@lglbb142 APG]# ./bin/mysql-database-check.sh
Enter username: [apg]

Enter database: [apg]

Enter password:
# Connecting to 127.0.0.1...
apg.cache_group_0_1401278400                       OK
[...]
apg.cache_group_86400_1399680000                   OK
apg.data_property
error    : Size of datafile is: 2         Should be: 3758440
error    : Corrupt
apg.data_property_flat                             Table is 
already up to date
apg.data_variable                                  OK

Repairing tables
apg.data_property
Error    : Incorrect information in file: './apg/
data_property.frm'
error    : Corrupt
# Disconnecting from 127.0.0.1...

4. Depending on the severity of the crash, you may or may not be able to restore
the table.

You may need to restart affected services.
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Find the SolutionPack that discovered a device

Procedure

1. Click the down arrow next to the quick search field.

A popup screen appears.

2. Click the Filter field to display a list of options and select Edit expression.

3. Type an expression. For example:

device=='000195700930'

4. Click OK.

5. in the Expansion field, replace “device” by "device, source".

6. In the Search Base field click the down arrow and select search from root.

7. Click Apply.

Figure 10 Finding the collector for a device

All devices that meet the search criteria and all collectors associated with them
are displayed. The name of the collector enables you to identify the
SolutionPack associated with the collector.
You can filter the column using the filter icon displayed in the table title.

VM Utilities Manager

VM Utilities Manager overview
The VM Utilities Manager allows you to easily install and remove debugging utilities
from the VMs in a vApp deployment of ViPR SRM.

The following utilities are available:

l man

Troubleshooting procedures

120 EMC ViPR SRM 4.2  Administrator Guide



l tcpdump

l netcat

l net-snmp

l sysstat

l iotop

The VM Utilities Manager is available through a GUI and a CLI.

Using the VM Utilities Manager GUI
Learn how to use the VM Utilities Manager GUI.

Procedure

1. Open the the GUI by entering vmutils-manager.sh from any directory on
the VM.

The GUI provides a checklist of available utilities. The checklist displays
checkmarks next to any of the utilities that are already installed. The following
screenshot shows the default checklist with no utilities installed.

2. To install a utility, click the checkbox next to the utility you want to install.

3. To uninstall a utility, uncheck the checkbox next to the utility that you want to
uninstall.

4. Select OK.

The Managing Utilities progress screen opens and shows the progress of the
installation and/or uninstallation activities.

Using the VM Utilities Manager CLI
Learn how to use the VM Utilities Manager CLI.

Procedure

1. To install a utility, enter the following command from any directory:

vmutils-manager.sh -i <utility name>
For example: vmutils-manager.sh -i iotop
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2. To uninstall a utility, enter the following command:

vmutils-manager.sh -u <utility name>
For example: vmutils-manager.sh -u iotop
You can install and/or uninstall multiple utilities with a single command.
Regardless of the order of the arguments on the command line, the script
always executes the uninstall action first.

Log files
The VM Utilities Manager provides two log files.

Log and location Description

/var/log/vmutils-manager.log Simple log of actions that contains "info" level
information. Use this log to confirm that an
action was attempted. If any action fails, look
at this log first.

/var/log/vmutils-manager_out.log A more verbose log of actions that includes
output from the Zypper commands that the
script uses to install and uninstall utilities. Use
this log when a Zypper command fails and the
error is not included in the simple log.
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CHAPTER 9

About the datastore

This chapter contains the following topics about the underlying datastore for ViPR
SRM.

l Overview.......................................................................................................... 124
l Usage............................................................................................................... 124
l SQL syntax....................................................................................................... 126
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Overview
Learn the fundamentals of querying the EMC M&R Datastore.

The EMC M&R Datastore is the underlying database engine used in the APG
Datastore module starting at version 5.0. The datastore is a standard database engine
that uses its own native query language (X100). However, all of the relational
concepts (and more) are available through the use of a SQL converting JDBC driver.

A single datastore can only host a single database without schema support. This
means that all of the tables are in the same namespace, therefore they have to be
properly qualified.

The datastore is listening on port 53308 by default, this can be changed in the conf/
module.properties file with the database.port setting. When set to 0, the port
is randomely chosen. The datastore is always listening on 0.0.0.0 (all interfaces) and
there is no way to change it currently. The port is protected by a randomly generated
hash which is stored in data/default/authpass and recreated each times the
service starts.

When a client connects to the database: it first goes through the webservice-gateway
to get the port number and the random token and then it connects to the actual
server listening on the retrieved port and uses the retrieved token. This means that if
the machine is firewalled, both 48443 (the webservice gateway) and 53308 (the
datastore) have to be opened.

Usage

There are two ways to use the database:

l Through one of the APG modules, such as the Datastore Writer or Web Portal

l Through the CLI built-inside the APG-Datastore module (/opt/APG/bin/
datastore-client.sh)

JDBC driver
To use the driver, you have to make sure the driver class
(com.watch4net.x100.jdbc.Driver) has been classloaded. The JDBC driver
handles the following URL:

jdbc:x100://localhost:48443/Databases/APG-Datastore/Default
                    
                          (1)                   (2)

Where:

l (1) is the host and port of the Webservice Gateway runing on the same host as the
database server

l (2) is the path to the Datastore module you are talking to

The following connection properties are honored:

l user and password: These are the two standard JDBC properties used to
specify the username and password. For this driver, thoee are the Web Service
gateway credentials.
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l ssl and sslVerify: These two flags control how to connect to the Web Service
gateway. By default ssl=true and sslVerify=false, meaning that HTTPS is
used to connect to the gateway but the certificate will not be verified.

l sessionType: This setting controls the type of session you want. It can be either
sqlToX100 (the default), which means that you want to use SQL language
(which is translated into X100 language) or x100 to use native X100 language
directly.

l loaderClass (since 6.3u1): This controls the loader implementation used by the
EXECUTE LOAD query. The valid values for this setting are
com.watch4net.x100.loader.X100BlockLoader and
com.watch4net.x100.loader.X100LoadLoader.

CLI
The APG Datastore module comes with a CLI which can connect to a local or remote
instance. The CLI is installed as /opt/APG/bin/datastore-client.sh.

Cli [<database>] [--debug] [--host (-h) <host name>] [--mode [x100 
| sql]] [--password (-p) <password>] [--port (-P) <port number>] [--
ssl [on | off | strict]] [--user (-u) <user name>]
 <database>                 : the database path (default: auto)
 --debug                    : enable debug mode
 --host (-h) <host name>    : the host name (default: 'localhost')
 --mode [x100 | sql]        : the session mode (default: 'sql')
 --password (-p) <password> : the password (default: auto)
 --port (-P) <port number>  : the port number (default: auto)
 --ssl [on | off | strict]  : the SSL mode (default: auto)
 --user (-u) <user name>    : the user name (default: auto)

When used locally, the CLI can be started without any argument since it is able to
connect automatically to a local datastore instance without any authentication (since
it can bypass the webservice gateway and talk to the datastore service directly).

dom@vanilla APG % ./bin/datastore-client.sh 
Welcome to APG-Datastore 5.0 CLI (Ctrl+D to exit).

Connected to jdbc:x100://localhost:43138/ !

sql> 

When used remotely (hostname is specified and is not localhost), the CLI uses
arguments very similar to the !MySQL CLI:

dom@vanilla APG % ./bin/datastore-client.sh -h w4n-dl-test1 -P 
48443 -u admin Databases/APG-Datastore/Default             
Enter password: 
Welcome to APG-Datastore 5.0 CLI (Ctrl+D to exit).

Connected to jdbc:x100://w4n-dl-test1:48443/Databases/APG-Datastore/
Default !

sql> 

The CLI offers two interesting options:

l --debug: Prints the complete stacktraces on error and enables debug log. This is
particularly interesting to troubleshoot connectivity issue or analyze SQL to X100
conversion.
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l --mode: Allows you to choose between SQL (the default) or the native X100
language. This is useful to run X100 queries that does not have any SQL
equivalent.

The CLI expects inputs to be either SQL or X100 queries, at the exception of two
built-in commands:

l .tables: lists all the tables available

l .columns [table]: lists all the columns, possibly restricted to the given table
name

SQL syntax
The SQL converting JDBC driver provides a simple SQL dialect, similar to MySQL.

Table definition
The general syntax is:

CREATE TABLE table ( col_name column_type [ NOT NULL ], ... )

DROP TABLE table

The supported types are:

l BOOLEAN: true or false
l TINYINT: 8 bit signed integer

l SMALLINT: 16 bit signed integer

l INTEGER: 32 bit signed integer

l BIGINT: 64 bit signed integer

l REAL: single precision floating point number (also known as FLOAT but the SQL
syntax doesn't allow one to use this keyword)

l DOUBLE: double precision floating point number

l VARCHAR or TEXT: bounded or unbounded string

Notes:

l Neither primary keys nor indexes are supported in this SQL syntax.

l REAL and DOUBLE are not compressed, this should be used sparingly.

l A nullable column is stored as an additional boolean column, whether a particular
value is null or not. This is not completely free (in disk space and loading time) and
should be avoided whenever possible.

Query
The general query syntax is:

SELECT [DISTINCT] select_expr [ AS alias ], ...
[ FROM table ]
[ WHERE where_clause ]
[ GROUP BY {col_name | alias} ]
[ ORDER BY {col_name | alias} [ASC | DESC], ...]
[ LIMIT row_count ]

Notes:
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l Duplicates in the select clause are not allowed.

l JOIN is not supported, table has to be a single table name.

l GROUP BY and ORDER BY can reference column names or aliases defined in the
select clause. When an ambiguity arises, aliases are prefered.

l GROUP BY does not support MySQL specific syntax where columns other than the
GROUP BY ones or aggregations can be specified in the select clause (for
example: SELECT a, b FROM table GROUP BY a). This is however allowed
for constants (for example: SELECT 1, a, sum(b) FROM table GROUP BY
a).

l Multiple queries can be merged together using UNION ALL only. UNION is not
supported. In this situation, ORDER BY and LIMIT applies to the resulting union,
not individual queries.

l While the datastore does not natively support schema, the SQL conversion layer
offers a sys schema which allows accessing internal system tables. The list of
available system tables and columns can be retrieved with SELECT * FROM
sys.sys_tables / SELECT * FROM sys.sys_table_columns.

Modification
Only DELETE is supported for now. The general syntax is:

DELETE FROM table [ WHERE where_clause ]

Notes:

l By default, update propagation is disabled. This means that deletes (as well as
updates) are not really applied onto data but stored instead as a difference on data
(this is called the Posotional Delta Tree). If deleted rows are not consecutive, this
can get very big and a manual update propagation operation might be necessary.

Loading
The loader can be invoked with:

EXECUTE LOAD('table', 'file1', 'file2', ...)

The loader uses little-endian binary files which format is:

l Each rescord is composed of

n The size of the record (as an unsigned short), excluding those 2 bytes

n The null mask, which is encoded as the mimimal number of bytes required to
store a 1 bit flag per column (even non null columns)

n Each record, in its natural form. Strings are stored as NUL terminated C strings
(NUL within the string is forbidden).

Notes:

l The default loader is com.watch4net.x100.loader.X100BlockLoader in
6.3 and com.watch4net.x100.loader.X100LoadLoader since 6.3u1. The
local load (used by the writer) is not using a loader, but simply is a particular native
query. The loader can be changed with the system property
com.watch4net.x100.loader or the JDBC connection property
loaderClass.
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l By default, the loader runs in a separate JVM. This behavior can be controlled by
the com.watch4net.x100.loader.fork system property (which default is
true).

l The X100BlockLoader loader (which is the default in 6.3) only loads complete
blocks. The direct consequence of this is that the last block of a load is wasting
some disk space. The more important consequence of this is that small loads are
not desirable since to mitigate this wasting, it should be at least 512k compressed
for each column. Since 6.3u1, the default is X100LoadLoader which does not
exhibit this behavior and should be preferred in most cases.

Select *
The datastore does not natively support the concept of selecting all columns of a
table. However, this is handled at the conversion layer and used naturally in SQL as a
regular SELECT *. The downside is that before every query which contains a SELECT
*, the driver has to issue a first query to retrieve column names.

SELECT * FROM test;

               |
               |
              \ /
               v

Project (
        Project (
                Project (
                        MScan ('test', ['__SELECT_ALL__'])
                , [__SELECT_ALL__])
        , [__SELECT_ALL__])
, [__SELECT_ALL__])

               |
               |
              \ /
               v

Project (
        Project (
                Project (
                        MScan ('test', ['i', 'j', 'k'])
                , [i, j, k])
        , [i, j, k])
, [i, j, k])

Table expansion
Since partitioned tables are used, table expansion was added to the SQL conversion
layer to make queries on them easy. The table expansion has different syntaxes and
works on all the supported queries (select, delete, create table, ...).

In general, if a table name contains one of the table expansion tokens listed here, the
query is going to be transparently dispatched across the matching tables. The
behavior is the same as doing the query on the union of the matching tables (meaning
that cross table aggregation, order, ... works).

__ALL__ (catch-all)

The catch-all syntax allows selecting tables using a pattern. Wherever found in the
table table, this is considered as a * wildcard to match table names. The downside is
that before every query which contains a table containing __ALL__, the driver has to
issue a first query to retrieve table names.
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For example, if the database contains three tables: my_table, your_table and
other, running a query on __ALL__table will use my_table and your_table.

SELECT COUNT(*) FROM "__ALL__table";

               |
               |
              \ /
               v

Project (
        Project (
                Aggr (
                        Project (
                                MScan ('__ALL__table', ['__tid__'])
                        , [__tid__])
                , [], [
                        _aggregatenode_7d15d06c = count(*)
                ], 1)
        , [_aggregatenode_7d15d06c])
, [_aggregatenode_7d15d06c])

               |
               |
              \ /
               v

Project (
        Project (
                Aggr (
                        Project (
                                Union (
                                        MScan ('my_table', 
['__tid__'])
                                , 
                                        MScan ('your_table', 
['__tid__'])
                                )
                        , [__tid__])
                , [], [
                        _aggregatenode_7d15d06c = count(*)
                ], 1)
        , [_aggregatenode_7d15d06c])
, [_aggregatenode_7d15d06c])

__SEQ_n_m__ (sequence)

The sequence syntax allows selecting a range of tables. Wherever found in the table
table, it is replaced with a sequence starting at n up to m (both inclusive). Note that
this query does not verify whether the generated table names exist, which has the
advantage of avoiding the overhead of a preliminary query.

SELECT COUNT(*) FROM "table__SEQ_1_2__";

               |
               |
              \ /
               v

Project (
        Project (
                Aggr (
                        Project (
                                MScan ('table__SEQ_1_2__', 
['__tid__'])
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                        , [__tid__])
                , [], [
                        _aggregatenode_9d686c1 = count(*)
                ], 1)
        , [_aggregatenode_9d686c1])
, [_aggregatenode_9d686c1])

               |
               |
              \ /
               v

Project (
        Project (
                Aggr (
                        Project (
                                Union (
                                        MScan ('table1', 
['__tid__'])
                                , 
                                        MScan ('table2', 
['__tid__'])
                                )
                        , [__tid__])
                , [], [
                        _aggregatenode_9d686c1 = count(*)
                ], 1)
        , [_aggregatenode_9d686c1])
, [_aggregatenode_9d686c1])

Troubleshooting
Since the driver does not know the database schema and the datastore does not
return an error message when a query fails, understanding why a query fails can be
challenging. Here are a few hints:

l Always run the CLI using the --debug option. This gives you the complete error
message and not just the outermost.

l When the error message starts with Error while parsing query ..., this
means that the query cannot even be parsed. When this error occurs, the query
never reached the database engine. This is most likely an error in the query and
the full stacktrace gives more detail on what the exact issue with it is.

l When the error message contains an error occured executing
query ..., this means that the query has been converted to a native database
query successfully but its execution on the database engine failed. Frequent
causes are misspelled table or column names. Since no error message is given to
clients, you have to check the database log file (Databases/APG-Datastore/
Default/logs/database-0-0.log) and look for error messages like
your_table.a not found in ColumnBM, which means that the table or
column cannot be found.
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