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Revision history
The following table presents the revision history of this document.

Table 1 Revision history

Revision Date Description

01 September, 2015 First release of these technical notes for EMC NetWorker Module
for Microsoft release 9.0.

Introduction
These technical notes are for use by a technically trained person who must use EMC®

NetWorker® Module for Microsoft (NMM) with Ontrack PowerControls to perform Granular
Level Recovery (GLR) of deleted Microsoft Exchange Server 2010, and 2013 items
including mailboxes, public folders, and public folder mailboxes. You can also use
PowerControls to recover Exchange Server items that have not been deleted.

The NetWorker Module for Microsoft Administration Guide provides information about all
NMM features. The NetWorker Module for Microsoft for Exchange Server VSS User Guide
provides information about using NMM to back up and recover Exchange Server. The
PowerControls documentation provides information about PowerControls functionality.

Recovering deleted Exchange Server items
Use NMM with PowerControls to recover deleted Exchange Server items.

Procedure

1. Use NMM to back up the entire Exchange Server or a single database.

You can use NMM to recover deleted Exchange Server 2010 and 2013 items. The
recovery process is the same for all supported versions of Exchange Server, although
the application information and save sets vary depending on the version of Exchange
Server you use. The steps in these procedures use an Exchange 2010 database
availability group (DAG) as an example.

2. Use NMM to recover the Exchange Server mailbox database without using the
Microsoft VSS writer.

3. Use PowerControls to perform a GLR to recover the Exchange Server files to a local
disk or network share.

You can use other third-party tools to perform this task. The exact steps of this task
vary, depending on which tool you use. The steps in these procedures use
PowerControls as an example.

Solution overview
NMM is an enterprise backup and recovery product, which uses the Microsoft VSS
infrastructure to perform backup and recovery of Exchange application data.

NMM allows you to perform backups at the writer level or database level. You can recover
entire databases or individual items such as emails, folders, calendars, notes, tasks, and
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contacts directly to your production system. This powerful software also protects the
Exchange organization from disaster situations.

NMM supports backup and recovery for standalone and DAG Exchange Server
configurations.

NMM provides the following backup and recovery features to protect Exchange Server
mailboxes:

l Mailbox, public folder, public mailbox database level backups

l Writer level backups

l FULL and incremental backups

l Database level recovery

l GLR

l Disaster Recoveries

The NetWorker Module for Microsoft for Exchange Server VSS User Guide provides
information about supported configurations and features.

PowerControls for Exchange
PowerControls for Exchange enables you to extract and recover mailbox components
(such as Inbox, Calendar, Tasks, and Notes) or entire mailboxes directly to your
production Exchange server.

PowerControls for Exchange extract Exchange mailbox database files. You can select
individual items and recover them directly to Exchange production user mailboxes. The
following figure shows a typical PowerControls configuration.

Figure 1  PowerControls configuration

Exchange configuration
You can use PowerControls to recover Exchange items in either of two configurations.

Configuration 1 — Recover Exchange items to a host on which you installed
PowerControls but not Exchange Server. Use PowerControls to recover the mail items to a
production Exchange Server mailbox. The following figure illustrates this configuration.
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Figure 2  Configuration 1: PowerControls running on an Exchange server

Configuration 2 — Recover Exchange items to a host on which you installed both
PowerControls and Exchange Server. In this configuration, install PowerControls on any
node in the DAG. Use PowerControls to recover Exchange Server items on any DAG node
where you have performed a backup. The following figure illustrates this configuration.
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Figure 3  Configuration 2: PowerControls running on a an Exchange server

These technical notes use Configuration 1 to demonstrate how to use PowerControls to
recover Exchange Server items.

The example setup is an Exchange Server 2010 DAG with the following details:

l The Exchange 2010 DAG system is configured with two mailbox servers with the
following configuration:

n The first host name is tigernode1.tigerdc.com.

n The second host name is tigernode2.tigerdc.com.

n NMM is installed on both DAG nodes.

l PowerControls is installed on a third host with the following configuration:

n The host name is tigerad.tigerdc.com.

n Exchange Server is not installed.
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Figure 3  Configuration 2: PowerControls running on a an Exchange server (continued)

n Outlook 2010 is installed and configured with one or more user mailbox that has
sent and received at least one message.

Prerequisite tasks
To perform GLR by using NMM and PowerControls, first complete the NMM and
PowerControls prerequisite tasks.

Performing NMM prerequisite tasks
Create and configure NMM client resources to use NMM to perform a FULL or Incremental
backup of the Exchange Server DAG.

Procedure

1. In the NetWorker Management Console, create a client resource for the DAG client and
each DAG node.

2. For the DAG client resource tigernode1.tigerdc.com, add the following database save
sets:

l APPLICATIONS:\Microsoft Exchange 2010\Kroll1

l APPLICATIONS:\Microsoft Exchange 2010\Kroll-public

In the above save set examples, Kroll1 is a mailbox database and Kroll-Public is a
public folder database.

3. For the DAG client resource tigernode1.tigerdc.com, add the following client resource
properties:

a. In the Backup command field, type the following command:

nsrnmmsv.exe

b. In the Application Information field, type the following variables:

CIRCULAR_PROMOTION_POLICY=Promote
NSR_EXCH_BACKUP=all
NSR_EXCH_DAG=tigerdag.tigerdc.com

c. In the Group field, select Test.

4. Back up the database.

5. After the backup succeeds, identify the database that you recover.

You can recover Exchange items regardless of whether the database is deleted from
the Exchange organization.

6. Verify that the target file system has enough free disk space to recover the Exchange
database.

Results

For Exchange database file recoveries, the target file system must have at least the same
amount of available space as the recovery file system at the time of the backup.
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You can use NMM to recover Exchange files to a remote host by mapping a network drive
on the NMM client host.

The NetWorker Module for Microsoft for Exchange Server VSS User Guide provides
information about how to configure clients, perform Exchange backups, and recover
Exchange items.

Performing PowerControls prerequisite tasks
Ensure that you meet the following requirements to use PowerControls to perform a GLR
of Exchange items.

l You installed PowerControls. You can install PowerControls on either an Exchange
server or a non-Exchange server.

l If you installed PowerControls on the Exchange Server, ensure that you uninstalled
the MAPI/CDO software. You cannot install Outlook and MAPI/CDO software on the
same host.

l You installed the Outlook 2010 software (32-bit) and the user mailboxes are
connected in Outlook.

l The PowerControls license is valid. The PowerControls documentation provides
information.

Recovering Exchange database files by using NMM
Use NMM to recover the Exchange mailbox, public folder, or public mailbox database
files. This section describes how to recover Exchange Server 2010 DAG mailbox database
files by using NMM.

Procedure

1. Log in to the DAG node.

For example: tigernode1.tigerdc.com.

2. Start a recovery session:

a. Open the NMM client user interface.

b. On the main toolbar, select the Client drop-down menu, and then select the DAG
name.

For example: tigerdag.

c. Click View and then click Refresh.

d. Click Recover > Exchange 2010 Recover Session > Database Recover.

The NMM user interface shows the mailbox databases that are available for
recovery.

3. Select the mailbox database to recover and click Recover Options.

For example: Kroll1.

4. On the Exchange tab, click Select Destination.

5. Browse to the mapped network drive.

For example: C:\alter.
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6. In the Deleted Database Target Selection dialog box:

a. Select Restore Deleted Database.

b. Browse to the target location for the recoverd mailbox database files.

c. Click OK.

7. Start the flat file recovery of the database:

a. Select the mailbox, public folder, or public folder mailbox database you want to
recover.

b. From the Exchange Recover toolbar, click Recover.

8. After the flat file recovery completes, verify whether the logs and .edb files are
recovered as expected on the mapped network drive.

Results

For example: C:\alter.

The NetWorker Module for Microsoft for Exchange Server VSS User Guide provides
information about how to recover Exchange Server database items to a local host or a
remote host.

Performing a Granular Level Recovery on Exchange Server
database files

To perform a Granular Level Recovery on an Exchange Server mailbox, public folder, or
public folder mailbox database files, log in to the host on which you installed
PowerControls. For example, tigerad.tigerdc.com.

In Recovering Exchange database files by using NMM on page 7, you recovered the
Exchange Server database files on tigernode1.tigerdc.com. However, PowerControls is
installed on tigerad.tigerdc.com, which does not have Exchange Server installed.
Because PowerControls is installed on a host that does not have Exchange Server
installed, you must copy the recovered Exchange Server files to the PowerControls host.

To copy the recovered files to the PowerControls host, perform one of the following steps:

l Copy all the recovered files from tigernode1.tigerdc.com to C:\Kroll1 on
tigerad.tigerdc.com. Provide this location as the source for PowerControls to perform
the Granular Level Recovery.

l Map a network drive to C:\alter on tigerad.tigerdc.com. Provide this location as the
source for PowerControls to perform the Granular Level Recovery.

l Recover the files to a remote host, as described in the NetWorker Module for Microsoft
for Exchange Server VSS User Guide.
For this example, copy the recovered files from tigernode1.tigerdc.com to
tigerad.tigerdc.com.

Recovering Exchange Server 2010 database files
Procedure

1. Verify whether the recovered files are available in the alternate path that you
specified.

For example:

C:\Kroll1 on tigerad.tigerdc.com.
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2. On the Kroll workstation, start the Data Wizard by selecting Start > Program >
Kroll Ontrack > Ontrack PowerControls.

3. Select File > Open Source.

4. In the Select Source Files dialog box:

a. In the Source File field, browse to the folder that contains the .edb files.

For example:

C:\Kroll1\DB\Kroll1.edb.

b. In the Log File Path field, browse to the folder that contains the log files.

For example:

C:\Kroll1\Logs

c. In the Temporary File Path field, accept the default location for the .idx and .dat
files.

For example: 
c:\Users\ADMINI~1\AppData\Local\Temp\2\PC

If the files require more hard drive space, specify a new location by clicking
Browse. These files might require hard drive space equal to the size of the .log
files.

5. Click OK.

6. In the Sources area of the PowerControls user interface, expand the mailboxes and
folders and then select the items to recover.

7. Select File > Open/Create Target > Open Exchange Target Server to open the mailbox
for the recovered mailbox items.

8. In the Data Wizard:

a. Under Target Path & Type, select Connect to Microsoft Exchange Server (Single
Mailbox).

b. In the E-mail Address field, type the email address of the user mailbox that
receives the recovered files.

For example:

administrator@tigerdc.com

c. In the Server Name field, type the Exchange server name.

For example:

tigernode1.tigerdc.com

d. Click Next.

9. To perform the item level recovery, right-click items in the Source area and select
Copy.

10.Select the Target user mailbox, right-click the Target folder and select Paste.

11.After the copy process completes, click Close.

12.Verify whether you can browse the recovered mailbox items:

a. In the PowerControls user interface, click the Target user mailbox and then click
target folder to view the recovered mailbox items.
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b. Open the target user’s mailbox and verify whether you can open the recovered
items.

Recovering Exchange Server 2013 database files
Procedure

1. Verify whether the .edb and log files are recovered to separate folders in the alternate
path that you specified.

For example:

C:\Kroll1 on tigerad.tigerdc.com contains DB and Logs.

2. Open the PowerControls application.

3. Click Edit > Preferences.

4. In the Preferences dialog box, on the Target Options tab:

a. Select the following options:

l Use Autodiscover to detect Microsoft Exchange server connection settings

l Use Outlook Anywhere to connect to Microsoft Exchange server

b. Verify whether the following options are selected:

l Create new PST folders when PST message/folder limits are reached

l Allow mailbox creation during copy

c. Click OK.

5. Click File > User Wizard.

6. Click Next.

7. In the Source Path Selection dialog box:

a. In the Source File field, browse to the folder that contains the .edb files.

For example:

C:\Alter1\DB\DB1.edb

b. In the Log File Path field, browse to the folder that contains the log files.

For example:

C:\Alter\Logs

8. Click Next.

9. In the Target Type & Path Selection dialog box:

a. Select Connect to Microsoft Exchange Server (Single Mailbox).

b. In the Mailbox Name field, type the email address of the user mailbox that receives
the recovered files.

For example:

administrator@tigerdc.com

c. In the Server Name field, type the Exchange server name.

For example:

tigernode1.tigerdc.com
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d. Verify that the following options are selected:

l Connect to Public Folders

l Connect using Autodiscover

e. Click Next.

10.When the processes complete, click Finish.

11.To perform the item level recovery, right-click items in the Source area and select
Copy.

12.Select the Target user mailbox, right-click the Target folder and select Paste.

13.After the copy process completes, click Close.

14.Verify whether you can browse the recovered mailbox item:

a. In the PowerControls user interface, click the Target user mailbox and then click
target folder to view the recovered mailbox items.

b. Open the target user’s mailbox and verify whether you can open the recovered
items.
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